%%phrase%%

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Controls Assembly ()

Namespaces

Namespace | Description
System.Windows.Controls |
Telerik.Windows |
Telerik.Windows.Controls |
Telerik.Windows.Controls.Primitives |
Telerik.Windows.Input |
© 2008 All Rights Reserved.


%%ItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
System.Windows.Controls Namespace
See Also Inheritance Hierarchy

Enumerations

 | Enumeration | Description
Enumeration | SelectionMode | Defines the selection behavior for various controls.

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionMode Enumeration
See Also
[image]
System.Windows.Controls Namespace : SelectionMode Enumeration

Defines the selection behavior for various controls.

Syntax

Visual Basic (Declaration)
Public Enum SelectionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SelectionMode
C#
public enum SelectionMode : Enum
Managed Extensions for C++
__value public enum SelectionMode : public Enum
C++/CLI
public enum class SelectionMode : public Enum

Members

Member | Description
Single | The user can select only one item at a time.
Multiple | The user can select multiple items without holding down a modifier key.
Extended | The user can select multiple consecutive items while holding down the SHIFT key.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
System.Windows.Controls.SelectionMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

System.Windows.Controls Namespace


%%ItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DependencyPropertyExtensions | Contains utility methods for registering dependency properties with extended metadata.
Class | DependencyPropertyKey | Provides a dependency property identifier for limited write access to a read-only dependency property.
Class | EventManager | Provides event-related utility methods that register routed events for class owners and add class handlers.
Class | PropertyMetadata | Defines certain behavior aspects of a dependency property as it is applied to a specific type, including conditions it was registered with.
Class | RadRoutedEventArgs | Contains state information and event data associated with a routed event.
Class | RoutedEvent | Represents and identifies a routed event and declares its characteristics.

Delegates

 | Delegate | Description
Delegate | CoerceValueCallback | Gets or sets a reference to a CoerceValueCallback implementation specified in this metadata.

Enumerations

 | Enumeration | Description
Enumeration | RoutingStrategy | Indicates the routing strategy of a routed event.

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyExtensions Class
See Also Members
[image]
Telerik.Windows Namespace : DependencyPropertyExtensions Class

Contains utility methods for registering dependency properties with extended metadata.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DependencyPropertyExtensions
Visual Basic (Usage) Copy Code
Dim instance As DependencyPropertyExtensions
C#
public static class DependencyPropertyExtensions
Managed Extensions for C++
public __gc abstract __sealed class DependencyPropertyExtensions
C++/CLI
public ref class DependencyPropertyExtensions abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.DependencyPropertyExtensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyExtensions Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyExtensions Class Members
See Also Methods
[image]
Telerik.Windows Namespace : DependencyPropertyExtensions Class

The following tables list the members exposed by DependencyPropertyExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a dependency property with the specified property name, property type, owner type, and property metadata.
static (Shared in Visual Basic) | RegisterReadOnly | Registers a read-only dependency property with the specified property name, property type, owner type, and property metadata.
Top

See Also

Reference

DependencyPropertyExtensions Class
Telerik.Windows Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyExtensions Class Methods
See Also
[image]
Telerik.Windows Namespace : DependencyPropertyExtensions Class

For a list of all members of this type, see DependencyPropertyExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a dependency property with the specified property name, property type, owner type, and property metadata.
static (Shared in Visual Basic) | RegisterReadOnly | Registers a read-only dependency property with the specified property name, property type, owner type, and property metadata.
Top

See Also

Reference

DependencyPropertyExtensions Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Register Method
See Also
[image]
Telerik.Windows Namespace > DependencyPropertyExtensions Class : Register Method

name
The name of the dependency property to register.
propertyType
The type of the property.
ownerType
The owner type that is registering the dependency property.
metadata
Property metadata for the dependency property.
Registers a dependency property with the specified property name, property type, owner type, and property metadata.

Syntax

Visual Basic (Declaration)
Public Shared Function Register( _
   ByVal name As String, _
   ByVal propertyType As Type, _
   ByVal ownerType As Type, _
   ByVal metadata As PropertyMetadata _
) As DependencyProperty
Visual Basic (Usage) Copy Code
Dim name As String
Dim propertyType As Type
Dim ownerType As Type
Dim metadata As PropertyMetadata
Dim value As DependencyProperty

value = DependencyPropertyExtensions.Register(name, propertyType, ownerType, metadata)
C#
public static DependencyProperty Register(
   string name,
   Type propertyType,
   Type ownerType,
   PropertyMetadata metadata
)
Managed Extensions for C++
public: static DependencyProperty* Register(
   string* name,
   Type* propertyType,
   Type* ownerType,
   PropertyMetadata* metadata
)
C++/CLI
public:
static DependencyProperty^ Register(
   String^ name,
   Type^ propertyType,
   Type^ ownerType,
   PropertyMetadata^ metadata
)

Parameters

name
The name of the dependency property to register.
propertyType
The type of the property.
ownerType
The owner type that is registering the dependency property.
metadata
Property metadata for the dependency property.

Return Value

A dependency property identifier that should be used to set the value of a public static readonly field in your class. That identifier is then used to reference the dependency property later, for operations such as setting its value programmatically or obtaining metadata.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyExtensions Class
DependencyPropertyExtensions Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RegisterReadOnly Method
See Also
[image]
Telerik.Windows Namespace > DependencyPropertyExtensions Class : RegisterReadOnly Method

name
The name of the dependency property to register.
propertyType
The type of the property.
ownerType
The owner type that is registering the dependency property.
metadata
Property metadata for the dependency property.
Registers a read-only dependency property with the specified property name, property type, owner type, and property metadata.

Syntax

Visual Basic (Declaration)
Public Shared Function RegisterReadOnly( _
   ByVal name As String, _
   ByVal propertyType As Type, _
   ByVal ownerType As Type, _
   ByVal metadata As PropertyMetadata _
) As DependencyPropertyKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim propertyType As Type
Dim ownerType As Type
Dim metadata As PropertyMetadata
Dim value As DependencyPropertyKey

value = DependencyPropertyExtensions.RegisterReadOnly(name, propertyType, ownerType, metadata)
C#
public static DependencyPropertyKey RegisterReadOnly(
   string name,
   Type propertyType,
   Type ownerType,
   PropertyMetadata metadata
)
Managed Extensions for C++
public: static DependencyPropertyKey* RegisterReadOnly(
   string* name,
   Type* propertyType,
   Type* ownerType,
   PropertyMetadata* metadata
)
C++/CLI
public:
static DependencyPropertyKey^ RegisterReadOnly(
   String^ name,
   Type^ propertyType,
   Type^ ownerType,
   PropertyMetadata^ metadata
)

Parameters

name
The name of the dependency property to register.
propertyType
The type of the property.
ownerType
The owner type that is registering the dependency property.
metadata
Property metadata for the dependency property.

Return Value

A dependency property identifier that should be used to set the value of a public static readonly field in your class. That identifier is then used to reference the dependency property later, for operations such as setting its value programmatically or obtaining metadata.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyExtensions Class
DependencyPropertyExtensions Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyKey Class
See Also Members
[image]
Telerik.Windows Namespace : DependencyPropertyKey Class

Provides a dependency property identifier for limited write access to a read-only dependency property.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DependencyPropertyKey
Visual Basic (Usage) Copy Code
Dim instance As DependencyPropertyKey
C#
public sealed class DependencyPropertyKey
Managed Extensions for C++
public __gc __sealed class DependencyPropertyKey
C++/CLI
public ref class DependencyPropertyKey sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.DependencyPropertyKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyKey Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyKey Class Members
See Also Properties
[image]
Telerik.Windows Namespace : DependencyPropertyKey Class

The following tables list the members exposed by DependencyPropertyKey.

Public Constructors

 | Name | Description
Public Constructor | DependencyPropertyKey Constructor |
Top

Public Properties

 | Name | Description
Public Property | DependencyProperty | Gets the dependency property identifier associated with this specialized read-only dependency property identifier.
Top

See Also

Reference

DependencyPropertyKey Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyKey Constructor
See Also
[image]
Telerik.Windows Namespace > DependencyPropertyKey Class : DependencyPropertyKey Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DependencyPropertyKey()
C#
public DependencyPropertyKey()
Managed Extensions for C++
public: DependencyPropertyKey();
C++/CLI
public:
DependencyPropertyKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyKey Class
DependencyPropertyKey Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
DependencyPropertyKey Class Properties
See Also
[image]
Telerik.Windows Namespace : DependencyPropertyKey Class

For a list of all members of this type, see DependencyPropertyKey members.

Public Properties

 | Name | Description
Public Property | DependencyProperty | Gets the dependency property identifier associated with this specialized read-only dependency property identifier.
Top

See Also

Reference

DependencyPropertyKey Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DependencyProperty Property
See Also
[image]
Telerik.Windows Namespace > DependencyPropertyKey Class : DependencyProperty Property

Gets the dependency property identifier associated with this specialized read-only dependency property identifier.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property DependencyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim instance As DependencyPropertyKey
Dim value As DependencyProperty

value = instance.DependencyProperty
C#
[CompilerGeneratedAttribute()]
public DependencyProperty DependencyProperty {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property DependencyProperty* get_DependencyProperty();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property DependencyProperty^ DependencyProperty {
   DependencyProperty^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DependencyPropertyKey Class
DependencyPropertyKey Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
EventManager Class
See Also Members
[image]
Telerik.Windows Namespace : EventManager Class

Provides event-related utility methods that register routed events for class owners and add class handlers.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EventManager
Visual Basic (Usage) Copy Code
Dim instance As EventManager
C#
public static class EventManager
Managed Extensions for C++
public __gc abstract __sealed class EventManager
C++/CLI
public ref class EventManager abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.EventManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventManager Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
EventManager Class Members
See Also Methods
[image]
Telerik.Windows Namespace : EventManager Class

The following tables list the members exposed by EventManager.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RegisterClassHandler | Overloaded. Registers a class handler for a particular routed event.
static (Shared in Visual Basic) | RegisterRoutedEvent | Registers a new routed event with the Windows Presentation Foundation (WPF) event system.
Top

See Also

Reference

EventManager Class
Telerik.Windows Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
EventManager Class Methods
See Also
[image]
Telerik.Windows Namespace : EventManager Class

For a list of all members of this type, see EventManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RegisterClassHandler | Overloaded. Registers a class handler for a particular routed event.
static (Shared in Visual Basic) | RegisterRoutedEvent | Registers a new routed event with the Windows Presentation Foundation (WPF) event system.
Top

See Also

Reference

EventManager Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RegisterClassHandler Method
See Also
[image]
Telerik.Windows Namespace > EventManager Class : RegisterClassHandler Method

Registers a class handler for a particular routed event.

Overload List

Overload | Description
RegisterClassHandler(Type,RoutedEvent,Delegate) | Registers a class handler for a particular routed event.
RegisterClassHandler(Type,RoutedEvent,Delegate,Boolean) | Registers a class handler for a particular routed event, with the option to handle events where event data is already marked handled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventManager Class
EventManager Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RegisterClassHandler(Type,RoutedEvent,Delegate) Method
See Also
[image]
Telerik.Windows Namespace > EventManager Class > RegisterClassHandler Method : RegisterClassHandler(Type,RoutedEvent,Delegate) Method

classType
routedEvent
handler
Registers a class handler for a particular routed event.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub RegisterClassHandler( _
   ByVal classType As Type, _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
Visual Basic (Usage) Copy Code
Dim classType As Type
Dim routedEvent As RoutedEvent
Dim handler As Delegate

EventManager.RegisterClassHandler(classType, routedEvent, handler)
C#
public static void RegisterClassHandler(
   Type classType,
   RoutedEvent routedEvent,
   Delegate handler
)
Managed Extensions for C++
public: static void RegisterClassHandler(
   Type* classType,
   RoutedEvent* routedEvent,
   Delegate* handler
)
C++/CLI
public:
static void RegisterClassHandler(
   Type^ classType,
   RoutedEvent^ routedEvent,
   Delegate^ handler
)

Parameters

classType
routedEvent
handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventManager Class
EventManager Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RegisterClassHandler(Type,RoutedEvent,Delegate,Boolean) Method
See Also
[image]
Telerik.Windows Namespace > EventManager Class > RegisterClassHandler Method : RegisterClassHandler(Type,RoutedEvent,Delegate,Boolean) Method

classType
The type of the class that is declaring class handling.
routedEvent
The routed event identifier of the event to handle.
handler
A reference to the class handler implementation.
handledEventsToo
true to invoke this class handler even if arguments of the routed event have been marked as handled; false to retain the default behavior of not invoking the handler on any marked-handled event.
Registers a class handler for a particular routed event, with the option to handle events where event data is already marked handled.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub RegisterClassHandler( _
   ByVal classType As Type, _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
Visual Basic (Usage) Copy Code
Dim classType As Type
Dim routedEvent As RoutedEvent
Dim handler As Delegate
Dim handledEventsToo As Boolean

EventManager.RegisterClassHandler(classType, routedEvent, handler, handledEventsToo)
C#
public static void RegisterClassHandler(
   Type classType,
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
)
Managed Extensions for C++
public: static void RegisterClassHandler(
   Type* classType,
   RoutedEvent* routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
C++/CLI
public:
static void RegisterClassHandler(
   Type^ classType,
   RoutedEvent^ routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

classType
The type of the class that is declaring class handling.
routedEvent
The routed event identifier of the event to handle.
handler
A reference to the class handler implementation.
handledEventsToo
true to invoke this class handler even if arguments of the routed event have been marked as handled; false to retain the default behavior of not invoking the handler on any marked-handled event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventManager Class
EventManager Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RegisterRoutedEvent Method
See Also
[image]
Telerik.Windows Namespace > EventManager Class : RegisterRoutedEvent Method

name
The name of the routed event. The name must be unique within the owner type and cannot be nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
routingStrategy
The routing strategy of the event as a value of the enumeration.
handlerType
The type of the event handler. This must be a delegate type and cannot be nullNothingnullptra null reference (Nothing in Visual Basic).
ownerType
The owner class type of the routed event. This cannot be nullNothingnullptra null reference (Nothing in Visual Basic).
Registers a new routed event with the Windows Presentation Foundation (WPF) event system.

Syntax

Visual Basic (Declaration)
Public Shared Function RegisterRoutedEvent( _
   ByVal name As String, _
   ByVal routingStrategy As RoutingStrategy, _
   ByVal handlerType As Type, _
   ByVal ownerType As Type _
) As RoutedEvent
Visual Basic (Usage) Copy Code
Dim name As String
Dim routingStrategy As RoutingStrategy
Dim handlerType As Type
Dim ownerType As Type
Dim value As RoutedEvent

value = EventManager.RegisterRoutedEvent(name, routingStrategy, handlerType, ownerType)
C#
public static RoutedEvent RegisterRoutedEvent(
   string name,
   RoutingStrategy routingStrategy,
   Type handlerType,
   Type ownerType
)
Managed Extensions for C++
public: static RoutedEvent* RegisterRoutedEvent(
   string* name,
   RoutingStrategy routingStrategy,
   Type* handlerType,
   Type* ownerType
)
C++/CLI
public:
static RoutedEvent^ RegisterRoutedEvent(
   String^ name,
   RoutingStrategy routingStrategy,
   Type^ handlerType,
   Type^ ownerType
)

Parameters

name
The name of the routed event. The name must be unique within the owner type and cannot be nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
routingStrategy
The routing strategy of the event as a value of the enumeration.
handlerType
The type of the event handler. This must be a delegate type and cannot be nullNothingnullptra null reference (Nothing in Visual Basic).
ownerType
The owner class type of the routed event. This cannot be nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

The identifier for the newly registered routed event. This identifier object can now be stored as a static field in a class and then used as a parameter for methods that attach handlers to the event. The routed event identifier is also used for other event system APIs.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventManager Class
EventManager Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PropertyMetadata Class
See Also Members
[image]
Telerik.Windows Namespace : PropertyMetadata Class

Defines certain behavior aspects of a dependency property as it is applied to a specific type, including conditions it was registered with.

Syntax

Visual Basic (Declaration)
Public Class PropertyMetadata
   Inherits PropertyMetadata
Visual Basic (Usage) Copy Code
Dim instance As PropertyMetadata
C#
public class PropertyMetadata : PropertyMetadata
Managed Extensions for C++
public __gc class PropertyMetadata : public PropertyMetadata
C++/CLI
public ref class PropertyMetadata : public PropertyMetadata

Inheritance Hierarchy

System.Object
System.Windows.PropertyMetadata
Telerik.Windows.PropertyMetadata

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyMetadata Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
PropertyMetadata Class Members
See Also
[image]
Telerik.Windows Namespace : PropertyMetadata Class

The following tables list the members exposed by PropertyMetadata.

Public Constructors

 | Name | Description
Public Constructor | PropertyMetadata Constructor | Overloaded. Initializes a new instance of the PropertyMetadata class with the specified default value and callbacks.
Top

See Also

Reference

PropertyMetadata Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PropertyMetadata Constructor
See Also
[image]
Telerik.Windows Namespace > PropertyMetadata Class : PropertyMetadata Constructor

Initializes a new instance of the PropertyMetadata class with the specified default value and callbacks.

Overload List

Overload | Description
PropertyMetadata Constructor(Object,PropertyChangedCallback,CoerceValueCallback) | Initializes a new instance of the PropertyMetadata class with the specified default value and callbacks.
PropertyMetadata Constructor(PropertyChangedCallback) | Initializes a new instance of the PropertyMetadata class with the specified PropertyChangedCallback implementation reference.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyMetadata Class
PropertyMetadata Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PropertyMetadata Constructor(Object,PropertyChangedCallback,CoerceValueCallback)
See Also
[image]
Telerik.Windows Namespace > PropertyMetadata Class > PropertyMetadata Constructor : PropertyMetadata Constructor(Object,PropertyChangedCallback,CoerceValueCallback)

defaultValue
The default value of the dependency property, usually provided as a value of some specific type.
propertyChangedCallback
Reference to a handler implementation that is to be called by the property system whenever the effective value of the property changes.
coerceValueCallback
Reference to a handler implementation that is to be called whenever the property system calls CoerceValue against this property.
Initializes a new instance of the PropertyMetadata class with the specified default value and callbacks.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA1801:ReviewUnusedParameters",
   Scope="",
   Target="",
   MessageId="defaultValue",
   Justification="This parameter is added for compatibility with WPF")>
Public Function New( _
   ByVal defaultValue As Object, _
   ByVal propertyChangedCallback As PropertyChangedCallback, _
   ByVal coerceValueCallback As CoerceValueCallback _
)
Visual Basic (Usage) Copy Code
Dim defaultValue As Object
Dim propertyChangedCallback As PropertyChangedCallback
Dim coerceValueCallback As CoerceValueCallback

Dim instance As PropertyMetadata(defaultValue, propertyChangedCallback, coerceValueCallback)
C#
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA1801:ReviewUnusedParameters",
   Scope="",
   Target="",
   MessageId="defaultValue",
   Justification="This parameter is added for compatibility with WPF")]
public PropertyMetadata(
   object defaultValue,
   PropertyChangedCallback propertyChangedCallback,
   CoerceValueCallback coerceValueCallback
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA1801:ReviewUnusedParameters",
   Scope="",
   Target="",
   MessageId="defaultValue",
   Justification="This parameter is added for compatibility with WPF")]
public: PropertyMetadata(
   Object* defaultValue,
   PropertyChangedCallback* propertyChangedCallback,
   CoerceValueCallback* coerceValueCallback
)
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA1801:ReviewUnusedParameters",
   Scope="",
   Target="",
   MessageId="defaultValue",
   Justification="This parameter is added for compatibility with WPF")]
public:
PropertyMetadata(
   Object^ defaultValue,
   PropertyChangedCallback^ propertyChangedCallback,
   CoerceValueCallback^ coerceValueCallback
)

Parameters

defaultValue
The default value of the dependency property, usually provided as a value of some specific type.
propertyChangedCallback
Reference to a handler implementation that is to be called by the property system whenever the effective value of the property changes.
coerceValueCallback
Reference to a handler implementation that is to be called whenever the property system calls CoerceValue against this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyMetadata Class
PropertyMetadata Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PropertyMetadata Constructor(PropertyChangedCallback)
See Also
[image]
Telerik.Windows Namespace > PropertyMetadata Class > PropertyMetadata Constructor : PropertyMetadata Constructor(PropertyChangedCallback)

propertyChangedCallback
Initializes a new instance of the PropertyMetadata class with the specified PropertyChangedCallback implementation reference.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyChangedCallback As PropertyChangedCallback _
)
Visual Basic (Usage) Copy Code
Dim propertyChangedCallback As PropertyChangedCallback

Dim instance As PropertyMetadata(propertyChangedCallback)
C#
public PropertyMetadata(
   PropertyChangedCallback propertyChangedCallback
)
Managed Extensions for C++
public: PropertyMetadata(
   PropertyChangedCallback* propertyChangedCallback
)
C++/CLI
public:
PropertyMetadata(
   PropertyChangedCallback^ propertyChangedCallback
)

Parameters

propertyChangedCallback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyMetadata Class
PropertyMetadata Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Class
See Also Members
[image]
Telerik.Windows Namespace : RadRoutedEventArgs Class

Contains state information and event data associated with a routed event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadRoutedEventArgs
   Inherits RoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs
C#
public class RadRoutedEventArgs : RoutedEventArgs
Managed Extensions for C++
public __gc class RadRoutedEventArgs : public RoutedEventArgs
C++/CLI
public ref class RadRoutedEventArgs : public RoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadSelectionChangedEventArgs
Telerik.Windows.Controls.RadTreeViewDragEventArgs
Telerik.Windows.Controls.RadTreeViewItemEditedEventArgs
Telerik.Windows.Controls.SelectionChangedEventArgs
Telerik.Windows.Input.MouseButtonEventArgs
Telerik.Windows.Input.MouseWheelEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows Namespace : RadRoutedEventArgs Class

The following tables list the members exposed by RadRoutedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadRoutedEventArgs Constructor | Overloaded. Initializes a new instance of the RoutedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance.
Public Property | Source | Gets or sets a reference to the object that raised the event.
Top

See Also

Reference

RadRoutedEventArgs Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Constructor
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class : RadRoutedEventArgs Constructor

Initializes a new instance of the RoutedEventArgs class.

Overload List

Overload | Description
RadRoutedEventArgs Constructor() | Initializes a new instance of the RoutedEventArgs class.
RadRoutedEventArgs Constructor(RoutedEvent) | Initializes a new instance of the RoutedEventArgs class, using the supplied routed event identifier.
RadRoutedEventArgs Constructor(RoutedEvent,Object) | Initializes a new instance of the RoutedEventArgs class, using the supplied routed event identifier, and providing the opportunity to declare a different source for the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Constructor()
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class > RadRoutedEventArgs Constructor : RadRoutedEventArgs Constructor()

Initializes a new instance of the RoutedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs()
C#
public RadRoutedEventArgs()
Managed Extensions for C++
public: RadRoutedEventArgs();
C++/CLI
public:
RadRoutedEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Constructor(RoutedEvent)
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class > RadRoutedEventArgs Constructor : RadRoutedEventArgs Constructor(RoutedEvent)

routedEvent
The routed event identifier for this instance of the RoutedEventArgs class.
Initializes a new instance of the RoutedEventArgs class, using the supplied routed event identifier.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal routedEvent As RoutedEvent _
)
Visual Basic (Usage) Copy Code
Dim routedEvent As RoutedEvent

Dim instance As RadRoutedEventArgs(routedEvent)
C#
public RadRoutedEventArgs(
   RoutedEvent routedEvent
)
Managed Extensions for C++
public: RadRoutedEventArgs(
   RoutedEvent* routedEvent
)
C++/CLI
public:
RadRoutedEventArgs(
   RoutedEvent^ routedEvent
)

Parameters

routedEvent
The routed event identifier for this instance of the RoutedEventArgs class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Constructor(RoutedEvent,Object)
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class > RadRoutedEventArgs Constructor : RadRoutedEventArgs Constructor(RoutedEvent,Object)

routedEvent
The routed event identifier for this instance of the RoutedEventArgs class.
source
An alternate source that will be reported when the event is handled. This pre-populates the Source property.
Initializes a new instance of the RoutedEventArgs class, using the supplied routed event identifier, and providing the opportunity to declare a different source for the event.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As Object _
)
Visual Basic (Usage) Copy Code
Dim routedEvent As RoutedEvent
Dim source As Object

Dim instance As RadRoutedEventArgs(routedEvent, source)
C#
public RadRoutedEventArgs(
   RoutedEvent routedEvent,
   object source
)
Managed Extensions for C++
public: RadRoutedEventArgs(
   RoutedEvent* routedEvent,
   Object* source
)
C++/CLI
public:
RadRoutedEventArgs(
   RoutedEvent^ routedEvent,
   Object^ source
)

Parameters

routedEvent
The routed event identifier for this instance of the RoutedEventArgs class.
source
An alternate source that will be reported when the event is handled. This pre-populates the Source property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members
Overload List


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadRoutedEventArgs Class Properties
See Also
[image]
Telerik.Windows Namespace : RadRoutedEventArgs Class

For a list of all members of this type, see RadRoutedEventArgs members.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance.
Public Property | Source | Gets or sets a reference to the object that raised the event.
Top

See Also

Reference

RadRoutedEventArgs Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Handled Property
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class : Handled Property

Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Property Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs
Dim value As Boolean

instance.Handled = value

value = instance.Handled
C#
[SecurityCriticalAttribute()]
public bool Handled {get; set;}
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: __property bool get_Handled();
public: __property void set_Handled(
   bool value
);
C++/CLI
[SecurityCriticalAttribute()]
public:
property bool Handled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OriginalSource Property
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class : OriginalSource Property

Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property OriginalSource As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs
Dim value As Object

value = instance.OriginalSource
C#
[CompilerGeneratedAttribute()]
public object OriginalSource {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Object* get_OriginalSource();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Object^ OriginalSource {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RoutedEvent Property
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class : RoutedEvent Property

Gets or sets the RoutedEvent associated with this RoutedEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Property RoutedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs
Dim value As RoutedEvent

instance.RoutedEvent = value

value = instance.RoutedEvent
C#
public RoutedEvent RoutedEvent {get; set;}
Managed Extensions for C++
public: __property RoutedEvent* get_RoutedEvent();
public: __property void set_RoutedEvent(
   RoutedEvent* value
);
C++/CLI
public:
property RoutedEvent^ RoutedEvent {
   RoutedEvent^ get();
   void set (RoutedEvent^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Source Property
See Also
[image]
Telerik.Windows Namespace > RadRoutedEventArgs Class : Source Property

Gets or sets a reference to the object that raised the event.

Syntax

Visual Basic (Declaration)
Public Property Source As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRoutedEventArgs
Dim value As Object

instance.Source = value

value = instance.Source
C#
public object Source {get; set;}
Managed Extensions for C++
public: __property Object* get_Source();
public: __property void set_Source(
   Object* value
);
C++/CLI
public:
property Object^ Source {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadRoutedEventArgs Class
RadRoutedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RoutedEvent Class
See Also Members
[image]
Telerik.Windows Namespace : RoutedEvent Class

Represents and identifies a routed event and declares its characteristics.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RoutedEvent
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
C#
public sealed class RoutedEvent
Managed Extensions for C++
public __gc __sealed class RoutedEvent
C++/CLI
public ref class RoutedEvent sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.RoutedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Members
Telerik.Windows Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RoutedEvent Class Members
See Also Properties Methods
[image]
Telerik.Windows Namespace : RoutedEvent Class

The following tables list the members exposed by RoutedEvent.

Public Properties

 | Name | Description
Public Property | HandlerType | Gets the handler type of the routed event.
Public Property | Name | Gets the identifying name of the routed event.
Public Property | OwnerType | Gets the registered owner type of the routed event.
Public Property | RoutingStrategy | Gets the routing strategy of the routed event.
Top

Public Methods

 | Name | Description
Public Method | AddOwner | Associates another owner class with this routed event, and enables routing of the event and handling on this class.
Public Method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

Reference

RoutedEvent Class
Telerik.Windows Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RoutedEvent Class Methods
See Also
[image]
Telerik.Windows Namespace : RoutedEvent Class

For a list of all members of this type, see RoutedEvent members.

Public Methods

 | Name | Description
Public Method | AddOwner | Associates another owner class with this routed event, and enables routing of the event and handling on this class.
Public Method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

Reference

RoutedEvent Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddOwner Method
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : AddOwner Method

ownerType
The type of the class where the routed event is added.
Associates another owner class with this routed event, and enables routing of the event and handling on this class.

Syntax

Visual Basic (Declaration)
Public Function AddOwner( _
   ByVal ownerType As Type _
) As RoutedEvent
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim ownerType As Type
Dim value As RoutedEvent

value = instance.AddOwner(ownerType)
C#
public RoutedEvent AddOwner(
   Type ownerType
)
Managed Extensions for C++
public: RoutedEvent* AddOwner(
   Type* ownerType
)
C++/CLI
public:
RoutedEvent^ AddOwner(
   Type^ ownerType
)

Parameters

ownerType
The type of the class where the routed event is added.

Return Value

The identifier field for the event. This return value should be used to set a public static read-only field that will store the identifier for the representation of the routed event on the owning class. This field must be accessible because it will be required to attach any instance handlers for the event when using the AddHandler utility method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : ToString Method

Returns a String that represents the current Object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current Object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RoutedEvent Class Properties
See Also
[image]
Telerik.Windows Namespace : RoutedEvent Class

For a list of all members of this type, see RoutedEvent members.

Public Properties

 | Name | Description
Public Property | HandlerType | Gets the handler type of the routed event.
Public Property | Name | Gets the identifying name of the routed event.
Public Property | OwnerType | Gets the registered owner type of the routed event.
Public Property | RoutingStrategy | Gets the routing strategy of the routed event.
Top

See Also

Reference

RoutedEvent Class
Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HandlerType Property
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : HandlerType Property

Gets the handler type of the routed event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property HandlerType As Type
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim value As Type

value = instance.HandlerType
C#
[CompilerGeneratedAttribute()]
public Type HandlerType {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Type* get_HandlerType();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Type^ HandlerType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Name Property
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : Name Property

Gets the identifying name of the routed event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim value As String

value = instance.Name
C#
[CompilerGeneratedAttribute()]
public string Name {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property string* get_Name();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OwnerType Property
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : OwnerType Property

Gets the registered owner type of the routed event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property OwnerType As Type
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim value As Type

value = instance.OwnerType
C#
[CompilerGeneratedAttribute()]
public Type OwnerType {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Type* get_OwnerType();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Type^ OwnerType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RoutingStrategy Property
See Also
[image]
Telerik.Windows Namespace > RoutedEvent Class : RoutingStrategy Property

Gets the routing strategy of the routed event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property RoutingStrategy As RoutingStrategy
Visual Basic (Usage) Copy Code
Dim instance As RoutedEvent
Dim value As RoutingStrategy

value = instance.RoutingStrategy
C#
[CompilerGeneratedAttribute()]
public RoutingStrategy RoutingStrategy {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property RoutingStrategy get_RoutingStrategy();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property RoutingStrategy RoutingStrategy {
   RoutingStrategy get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RoutedEvent Class
RoutedEvent Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RoutingStrategy Enumeration
See Also
[image]
Telerik.Windows Namespace : RoutingStrategy Enumeration

Indicates the routing strategy of a routed event.

Syntax

Visual Basic (Declaration)
Public Enum RoutingStrategy
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RoutingStrategy
C#
public enum RoutingStrategy : Enum
Managed Extensions for C++
__value public enum RoutingStrategy : public Enum
C++/CLI
public enum class RoutingStrategy : public Enum

Members

Member | Description
Tunnel | The routed event uses a tunneling strategy, where the event instance routes downwards through the tree, from root to source element.
Bubble | The routed event uses a bubbling strategy, where the event instance routes upwards through the tree, from event source to root.
Direct | The routed event does not route through an element tree, but does support other routed event capabilities such as class handling, EventTrigger or EventSetter.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.RoutingStrategy

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
CoerceValueCallback Delegate
See Also
[image]
Telerik.Windows Namespace : CoerceValueCallback Delegate

element
The object that the property exists on. When the callback is invoked, the property system will pass this value.
baseValue
The new value of the property, prior to any coercion attempt.
Gets or sets a reference to a CoerceValueCallback implementation specified in this metadata.

Syntax

Visual Basic (Declaration)
Public Delegate Function CoerceValueCallback( _
   ByVal element As DependencyObject, _
   ByVal baseValue As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As New CoerceValueCallback(AddressOf HandlerMethod)
C#
public delegate object CoerceValueCallback(
   DependencyObject element,
   object baseValue
)
Managed Extensions for C++
public: __gc __delegate Object* CoerceValueCallback(
   DependencyObject* element,
   Object* baseValue
)
C++/CLI
public delegate Object^ CoerceValueCallback(
   DependencyObject^ element,
   Object^ baseValue
)

Parameters

element
The object that the property exists on. When the callback is invoked, the property system will pass this value.
baseValue
The new value of the property, prior to any coercion attempt.

Return Value

The coerced value (with appropriate type).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows Namespace


%%ItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DataTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element.
Class | DoubleRangeBase | DoubleRangeBase inherits RangeBase and introduces two new fields - SelectionStart and SelectionEnd. SelectionStart cannot be greater than SelectionEnd and SelectionEnd cannot be less than SelectionStart.
Class | HeaderedContentControl | Base class for the content controls that need a header.
Class | HeaderedItemsControl | Represents a control that contains multiple items and has a header.
Class | HierarchicalDataTemplate | Represents a DataTemplate that supports HeaderedItemsControl, such as RadTreeViewItem or RadMenuItem.
Class | ItemContainerGenerator | Base class for all the items controls.
Class | ItemsControl | Base class for all the items controls.
Class | ItemsControlExtensions | Contains helper extension methods for the ItemsControl class
Class | ListBoxItem | Represents a selectable item in a ListBox.
Class | RadControl | Static container for the Theme attached property.
Class | RadDockPanel | Defines an area where you can arrange child elements either horizontally or vertically, relative to each other.
Class | RadPopup | Represents a pop-up window that has content
Class | RadProgressBar | The RadProgressBar control can be used to to indicate the progress of an operation. It gives to an end-user visual feedback about an operation he is waiting for to complete.
Class | RadSelectionChangedEventArgs | Provides data for the SelectionChanged event.
Class | RadSlider | Slider control lets the user select from a range of values by moving a slider. Slider is used to enable to user to gradually modify a value (range selection). Slider is an easy and natural interface for users, because it provides good visual feedback.
Class | RadTickBar | Represents a control that draws a set of tick marks for a RadSlider control.
Class | RadWrapPanel | Positions child elements in sequential position from left to right, breaking content to the next line at the edge of the containing box. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the value of the Orientation property.
Class | RangeSelectionChangedEventArgs | Provides data for the SelectionStartChanged and SelectionEndChanged events.
Class | ResourceDictionary | Provides a source for loading ResourceDictionary objects and merging them with another ResourceDictionary.
Class | SelectionChangedEventArgs | Provides data for the Telerik.Windows.Controls.Selector.SelectionChanged event.
Class | Selector | Represents a control that allows a user to select items from among its child elements
Class | StyleSelector | Chooses the style for each item of the ItemsControl.
Class | TextSearch | Enables a user to quickly access items in a set by typing prefixes of strings.
Class | Theme | Contains the location of

Delegates

 | Delegate | Description
Delegate | SelectionChangedEventHandler | Represents the method that will handle the SelectionChanged routed event.

Enumerations

 | Enumeration | Description
Enumeration | Dock | Specifies the Dock position of a child element that is inside a DockPanel.
Enumeration | FilteringMode | Specifies the FilteringMode of RadComboBox.
Enumeration | PlacementMode | Describes the placement of where a Popup control appears on the screen.
Enumeration | PopupAnimation | Defines the values, specifying the animation type which will be played when a RadPopup is opened or closed.
Enumeration | TickBarPlacement | Specifies the placement of a TickBar with respect to the track of a RadSlider control.
Enumeration | TickPlacement | Specifies the position of tick marks in a RadSlider control with respect to the track in the control.

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DataTemplateSelector Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : DataTemplateSelector Class

Provides a way to choose a DataTemplate based on the data object and the data-bound element.

Syntax

Visual Basic (Declaration)
Public Class DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As DataTemplateSelector
C#
public class DataTemplateSelector
Managed Extensions for C++
public __gc class DataTemplateSelector
C++/CLI
public ref class DataTemplateSelector

Remarks

Typically, you create a DataTemplateSelector when you have more than one DataTemplate for the same type of objects and you want to supply your own logic to choose a DataTemplate to apply based on the properties of each data object.

To create a template selector, create a class that inherits from DataTemplateSelector and override the SelectTemplate method. Once your class is defined you can assign an instance of the class to the template selector property of your element.

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.DataTemplateSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataTemplateSelector Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
DataTemplateSelector Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : DataTemplateSelector Class

The following tables list the members exposed by DataTemplateSelector.

Public Constructors

 | Name | Description
Public Constructor | DataTemplateSelector Constructor |
Top

Public Methods

 | Name | Description
Public Method | SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
Top

See Also

Reference

DataTemplateSelector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DataTemplateSelector Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > DataTemplateSelector Class : DataTemplateSelector Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataTemplateSelector()
C#
public DataTemplateSelector()
Managed Extensions for C++
public: DataTemplateSelector();
C++/CLI
public:
DataTemplateSelector();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataTemplateSelector Class
DataTemplateSelector Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
DataTemplateSelector Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : DataTemplateSelector Class

For a list of all members of this type, see DataTemplateSelector members.

Public Methods

 | Name | Description
Public Method | SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
Top

See Also

Reference

DataTemplateSelector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > DataTemplateSelector Class : SelectTemplate Method

item
The data object for which to select the template.
container
The data-bound object.
When overridden in a derived class, returns a DataTemplate based on custom logic.

Syntax

Visual Basic (Declaration)
Public Overridable Function SelectTemplate( _
   ByVal item As Object, _
   ByVal container As DependencyObject _
) As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As DataTemplateSelector
Dim item As Object
Dim container As DependencyObject
Dim value As DataTemplate

value = instance.SelectTemplate(item, container)
C#
public virtual DataTemplate SelectTemplate(
   object item,
   DependencyObject container
)
Managed Extensions for C++
public: virtual DataTemplate* SelectTemplate(
   Object* item,
   DependencyObject* container
)
C++/CLI
public:
virtual DataTemplate^ SelectTemplate(
   Object^ item,
   DependencyObject^ container
)

Parameters

item
The data object for which to select the template.
container
The data-bound object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataTemplateSelector Class
DataTemplateSelector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

DoubleRangeBase inherits RangeBase and introduces two new fields - SelectionStart and SelectionEnd. SelectionStart cannot be greater than SelectionEnd and SelectionEnd cannot be less than SelectionStart.

Syntax

Visual Basic (Declaration)
Public Class DoubleRangeBase
   Inherits RangeBase
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
C#
public class DoubleRangeBase : RangeBase, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class DoubleRangeBase : public RangeBase, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class DoubleRangeBase : public RangeBase, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.DoubleRangeBase
Telerik.Windows.Controls.RadSlider

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

The following tables list the members exposed by DoubleRangeBase.

Public Constructors

 | Name | Description
Public Constructor | DoubleRangeBase Constructor | Initializes a new instance of the DoubleRangeBase class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectionEndProperty | Identifies the SelectionEnd dependency property.
static (Shared in Visual Basic) | SelectionStartProperty | Identifies the SelectionStart dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectionEnd | Gets or sets the largest value of a specified selection.
Public Property | SelectionRange | Gets the difference between SelectionStart and SelectionEnd.
Public Property | SelectionStart | Gets or sets the smallest value of a specified selection.
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | Overridden. Called when the Maximum property changes.
Protected Method | OnMinimumChanged | Overridden. Called when the Minimum property changes.
Protected Method | OnSelectionEndChanged | Called when SelectionEndChanged event occurs.
Protected Method | OnSelectionRangeChanged | Called when SelectionRange event occurs.
Protected Method | OnSelectionStartChanged | Called when SelectionStartChanged event occurs.
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionEndChanged | Occurs when SelectionEnd changes value.
Public Event | SelectionRangeChanged | Occurs when SelectionRange changes value.
Public Event | SelectionStartChanged | Occurs when SelectionStart changes value.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

DoubleRangeBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : DoubleRangeBase Constructor

Initializes a new instance of the DoubleRangeBase class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase()
C#
public DoubleRangeBase()
Managed Extensions for C++
public: DoubleRangeBase();
C++/CLI
public:
DoubleRangeBase();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

For a list of all members of this type, see DoubleRangeBase members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | Overridden. Called when the Maximum property changes.
Protected Method | OnMinimumChanged | Overridden. Called when the Minimum property changes.
Protected Method | OnSelectionEndChanged | Called when SelectionEndChanged event occurs.
Protected Method | OnSelectionRangeChanged | Called when SelectionRange event occurs.
Protected Method | OnSelectionStartChanged | Called when SelectionStartChanged event occurs.
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

DoubleRangeBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMaximumChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : OnMaximumChanged Method

oldMaximum
Old value of the Maximum property.
newMaximum
New value of the Maximum property.
Called when the Maximum property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMaximumChanged( _
   ByVal oldMaximum As Double, _
   ByVal newMaximum As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim oldMaximum As Double
Dim newMaximum As Double

instance.OnMaximumChanged(oldMaximum, newMaximum)
C#
protected override void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
)
Managed Extensions for C++
protected: void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
) override
C++/CLI
protected:
void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
) override

Parameters

oldMaximum
Old value of the Maximum property.
newMaximum
New value of the Maximum property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMinimumChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : OnMinimumChanged Method

oldMinimum
Old value of the Minimum property.
newMinimum
New value of the Minimum property.
Called when the Minimum property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMinimumChanged( _
   ByVal oldMinimum As Double, _
   ByVal newMinimum As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim oldMinimum As Double
Dim newMinimum As Double

instance.OnMinimumChanged(oldMinimum, newMinimum)
C#
protected override void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
)
Managed Extensions for C++
protected: void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
) override
C++/CLI
protected:
void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
) override

Parameters

oldMinimum
Old value of the Minimum property.
newMinimum
New value of the Minimum property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionEndChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : OnSelectionEndChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionEndChanged event occurs.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionEndChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim oldValue As Double
Dim newValue As Double

instance.OnSelectionEndChanged(oldValue, newValue)
C#
protected virtual void OnSelectionEndChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: virtual void OnSelectionEndChanged(
   double oldValue,
   double newValue
)
C++/CLI
protected:
virtual void OnSelectionEndChanged(
   double oldValue,
   double newValue
)

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionRangeChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : OnSelectionRangeChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionRange event occurs.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionRangeChanged( _
   ByVal oldValue As RangeSelectionChangedEventArgs, _
   ByVal newValue As RangeSelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim oldValue As RangeSelectionChangedEventArgs
Dim newValue As RangeSelectionChangedEventArgs

instance.OnSelectionRangeChanged(oldValue, newValue)
C#
protected virtual void OnSelectionRangeChanged(
   RangeSelectionChangedEventArgs oldValue,
   RangeSelectionChangedEventArgs newValue
)
Managed Extensions for C++
protected: virtual void OnSelectionRangeChanged(
   RangeSelectionChangedEventArgs* oldValue,
   RangeSelectionChangedEventArgs* newValue
)
C++/CLI
protected:
virtual void OnSelectionRangeChanged(
   RangeSelectionChangedEventArgs^ oldValue,
   RangeSelectionChangedEventArgs^ newValue
)

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionStartChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : OnSelectionStartChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionStartChanged event occurs.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionStartChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim oldValue As Double
Dim newValue As Double

instance.OnSelectionStartChanged(oldValue, newValue)
C#
protected virtual void OnSelectionStartChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: virtual void OnSelectionStartChanged(
   double oldValue,
   double newValue
)
C++/CLI
protected:
virtual void OnSelectionStartChanged(
   double oldValue,
   double newValue
)

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

For a list of all members of this type, see DoubleRangeBase members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectionEnd | Gets or sets the largest value of a specified selection.
Public Property | SelectionRange | Gets the difference between SelectionStart and SelectionEnd.
Public Property | SelectionStart | Gets or sets the smallest value of a specified selection.
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

DoubleRangeBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionEnd Property

Gets or sets the largest value of a specified selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionEnd As Double
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim value As Double

instance.SelectionEnd = value

value = instance.SelectionEnd
C#
public double SelectionEnd {get; set;}
Managed Extensions for C++
public: __property double get_SelectionEnd();
public: __property void set_SelectionEnd(
   double value
);
C++/CLI
public:
property double SelectionEnd {
   double get();
   void set (double value);
}

Return Value

The selection end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionRange Property
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionRange Property

Gets the difference between SelectionStart and SelectionEnd.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectionRange As Double
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim value As Double

value = instance.SelectionRange
C#
public double SelectionRange {get;}
Managed Extensions for C++
public: __property double get_SelectionRange();
C++/CLI
public:
property double SelectionRange {
   double get();
}

Return Value

The difference between SelectionStart and SelectionEnd.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionStart Property

Gets or sets the smallest value of a specified selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionStart As Double
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim value As Double

instance.SelectionStart = value

value = instance.SelectionStart
C#
public double SelectionStart {get; set;}
Managed Extensions for C++
public: __property double get_SelectionStart();
public: __property void set_SelectionStart(
   double value
);
C++/CLI
public:
property double SelectionStart {
   double get();
   void set (double value);
}

Return Value

The selection start.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

For a list of all members of this type, see DoubleRangeBase members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectionEndProperty | Identifies the SelectionEnd dependency property.
static (Shared in Visual Basic) | SelectionStartProperty | Identifies the SelectionStart dependency property.
Top

See Also

Reference

DoubleRangeBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionEndProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionEndProperty Field

Identifies the SelectionEnd dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionEndProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = DoubleRangeBase.SelectionEndProperty
C#
public static readonly DependencyProperty SelectionEndProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionEndProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionEndProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionStartProperty Field

Identifies the SelectionStart dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = DoubleRangeBase.SelectionStartProperty
C#
public static readonly DependencyProperty SelectionStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionStartProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
DoubleRangeBase Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : DoubleRangeBase Class

For a list of all members of this type, see DoubleRangeBase members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionEndChanged | Occurs when SelectionEnd changes value.
Public Event | SelectionRangeChanged | Occurs when SelectionRange changes value.
Public Event | SelectionStartChanged | Occurs when SelectionStart changes value.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

DoubleRangeBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionEndChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionEndChanged Event

Occurs when SelectionEnd changes value.

Syntax

Visual Basic (Declaration)
Public Event SelectionEndChanged() As RoutedPropertyChangedEventHandler(Of Double)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim handler As RoutedPropertyChangedEventHandler(Of Double)

AddHandler instance.SelectionEndChanged, handler
C#
public event RoutedPropertyChangedEventHandler<double> SelectionEndChanged()
Managed Extensions for C++
public: __event RoutedPropertyChangedEventHandler<double>* SelectionEndChanged
C++/CLI
public:
event RoutedPropertyChangedEventHandler<double>^ SelectionEndChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionRangeChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionRangeChanged Event

Occurs when SelectionRange changes value.

Syntax

Visual Basic (Declaration)
Public Event SelectionRangeChanged() As RoutedPropertyChangedEventHandler(Of RangeSelectionChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim handler As RoutedPropertyChangedEventHandler(Of RangeSelectionChangedEventArgs)

AddHandler instance.SelectionRangeChanged, handler
C#
public event RoutedPropertyChangedEventHandler<RangeSelectionChangedEventArgs> SelectionRangeChanged()
Managed Extensions for C++
public: __event RoutedPropertyChangedEventHandler<RangeSelectionChangedEventArgs*>* SelectionRangeChanged
C++/CLI
public:
event RoutedPropertyChangedEventHandler<RangeSelectionChangedEventArgs^>^ SelectionRangeChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionStartChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > DoubleRangeBase Class : SelectionStartChanged Event

Occurs when SelectionStart changes value.

Syntax

Visual Basic (Declaration)
Public Event SelectionStartChanged() As RoutedPropertyChangedEventHandler(Of Double)
Visual Basic (Usage) Copy Code
Dim instance As DoubleRangeBase
Dim handler As RoutedPropertyChangedEventHandler(Of Double)

AddHandler instance.SelectionStartChanged, handler
C#
public event RoutedPropertyChangedEventHandler<double> SelectionStartChanged()
Managed Extensions for C++
public: __event RoutedPropertyChangedEventHandler<double>* SelectionStartChanged
C++/CLI
public:
event RoutedPropertyChangedEventHandler<double>^ SelectionStartChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DoubleRangeBase Class
DoubleRangeBase Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

Base class for the content controls that need a header.

Syntax

Visual Basic (Declaration)
<TemplatePartAttribute(Name="HeaderElement", Type=System.Windows.Controls.ContentControl)>
Public Class HeaderedContentControl
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
C#
[TemplatePartAttribute(Name="HeaderElement", Type=System.Windows.Controls.ContentControl)]
public class HeaderedContentControl : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplatePartAttribute(Name="HeaderElement", Type=System.Windows.Controls.ContentControl)]
public __gc class HeaderedContentControl : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplatePartAttribute(Name="HeaderElement", Type=System.Windows.Controls.ContentControl)]
public ref class HeaderedContentControl : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.HeaderedContentControl
Telerik.Windows.Controls.RadTabItem
Telerik.Windows.Controls.RadWindow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

The following tables list the members exposed by HeaderedContentControl.

Public Constructors

 | Name | Description
Public Constructor | HeaderedContentControl Constructor | Internal constructor to limit the use for now.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HasHeaderProperty | Identifies the HasHeader property.
static (Shared in Visual Basic) | HeaderProperty | Identifies the Header property.
static (Shared in Visual Basic) | HeaderTemplateProperty | Identifies the HeaderTemplatee property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property.
Public Property | Header | Gets or sets the header of the control. This is a dependency property.
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnHeaderChanged | Allows derived classes to act on header change.
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change.
Protected Method | OnIsEnabledChanged | Overridden. //TODO: Document
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

HeaderedContentControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HeaderedContentControl Constructor

Internal constructor to limit the use for now.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl()
C#
public HeaderedContentControl()
Managed Extensions for C++
public: HeaderedContentControl();
C++/CLI
public:
HeaderedContentControl();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

For a list of all members of this type, see HeaderedContentControl members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnHeaderChanged | Allows derived classes to act on header change.
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change.
Protected Method | OnIsEnabledChanged | Overridden. //TODO: Document
Top

See Also

Reference

HeaderedContentControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnHeaderChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : OnHeaderChanged Method

oldHeader
The old header value.
newHeader
The new header value.
Allows derived classes to act on header change.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHeaderChanged( _
   ByVal oldHeader As Object, _
   ByVal newHeader As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim oldHeader As Object
Dim newHeader As Object

instance.OnHeaderChanged(oldHeader, newHeader)
C#
protected virtual void OnHeaderChanged(
   object oldHeader,
   object newHeader
)
Managed Extensions for C++
protected: virtual void OnHeaderChanged(
   Object* oldHeader,
   Object* newHeader
)
C++/CLI
protected:
virtual void OnHeaderChanged(
   Object^ oldHeader,
   Object^ newHeader
)

Parameters

oldHeader
The old header value.
newHeader
The new header value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members
Header Property


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnHeaderTemplateChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : OnHeaderTemplateChanged Method

oldHeaderTemplate
The old header tempalte.
newHeaderTemplate
The new header tempalte.
Allows derived classes to act on HeaderTemplate change.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHeaderTemplateChanged( _
   ByVal oldHeaderTemplate As DataTemplate, _
   ByVal newHeaderTemplate As DataTemplate _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim oldHeaderTemplate As DataTemplate
Dim newHeaderTemplate As DataTemplate

instance.OnHeaderTemplateChanged(oldHeaderTemplate, newHeaderTemplate)
C#
protected virtual void OnHeaderTemplateChanged(
   DataTemplate oldHeaderTemplate,
   DataTemplate newHeaderTemplate
)
Managed Extensions for C++
protected: virtual void OnHeaderTemplateChanged(
   DataTemplate* oldHeaderTemplate,
   DataTemplate* newHeaderTemplate
)
C++/CLI
protected:
virtual void OnHeaderTemplateChanged(
   DataTemplate^ oldHeaderTemplate,
   DataTemplate^ newHeaderTemplate
)

Parameters

oldHeaderTemplate
The old header tempalte.
newHeaderTemplate
The new header tempalte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnIsEnabledChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : OnIsEnabledChanged Method

isEnabled
//TODO: Document

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnIsEnabledChanged( _
   ByVal isEnabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim isEnabled As Boolean

instance.OnIsEnabledChanged(isEnabled)
C#
protected override void OnIsEnabledChanged(
   bool isEnabled
)
Managed Extensions for C++
protected: void OnIsEnabledChanged(
   bool isEnabled
) override
C++/CLI
protected:
void OnIsEnabledChanged(
   bool isEnabled
) override

Parameters

isEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

For a list of all members of this type, see HeaderedContentControl members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property.
Public Property | Header | Gets or sets the header of the control. This is a dependency property.
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

HeaderedContentControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HasHeader Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HasHeader Property

Gets whether there is header assigned. This is a dependency property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property HasHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim value As Boolean

value = instance.HasHeader
C#
[BrowsableAttribute(false)]
public bool HasHeader {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_HasHeader();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool HasHeader {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Header Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : Header Property

Gets or sets the header of the control. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("ContentCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property Header As Object
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim value As Object

instance.Header = value

value = instance.Header
C#
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public object Header {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property Object* get_Header();
public: __property void set_Header(
   Object* value
);
C++/CLI
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property Object^ Header {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HeaderTemplate Property

Gets or sets the data tempalte for the header. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("ContentCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property HeaderTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As HeaderedContentControl
Dim value As DataTemplate

instance.HeaderTemplate = value

value = instance.HeaderTemplate
C#
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public DataTemplate HeaderTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property DataTemplate* get_HeaderTemplate();
public: __property void set_HeaderTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("ContentCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property DataTemplate^ HeaderTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

For a list of all members of this type, see HeaderedContentControl members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HasHeaderProperty | Identifies the HasHeader property.
static (Shared in Visual Basic) | HeaderProperty | Identifies the Header property.
static (Shared in Visual Basic) | HeaderTemplateProperty | Identifies the HeaderTemplatee property.
Top

See Also

Reference

HeaderedContentControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HasHeaderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HasHeaderProperty Field

Identifies the HasHeader property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HasHeaderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedContentControl.HasHeaderProperty
C#
public static readonly DependencyProperty HasHeaderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HasHeaderProperty
C++/CLI
public:
static readonly DependencyProperty^ HasHeaderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HeaderProperty Field

Identifies the Header property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedContentControl.HeaderProperty
C#
public static readonly DependencyProperty HeaderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedContentControl Class : HeaderTemplateProperty Field

Identifies the HeaderTemplatee property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedContentControl.HeaderTemplateProperty
C#
public static readonly DependencyProperty HeaderTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedContentControl Class
HeaderedContentControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

Represents a control that contains multiple items and has a header.

Object Model

Syntax

Visual Basic (Declaration)
Public Class HeaderedItemsControl
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
C#
public class HeaderedItemsControl : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class HeaderedItemsControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class HeaderedItemsControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.Calendar.CalendarView
Telerik.Windows.Controls.RadMenuItem
Telerik.Windows.Controls.RadPanelBarItem
Telerik.Windows.Controls.RadTreeViewItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

The following tables list the members exposed by HeaderedItemsControl.

Public Constructors

 | Name | Description
Public Constructor | HeaderedItemsControl Constructor | Initializes a new instance of the HeaderedItemsControl class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HasHeaderProperty | Identifies the HasHeader dependency property.
static (Shared in Visual Basic) | HeaderProperty | Identifies the Header dependency property.
static (Shared in Visual Basic) | HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
static (Shared in Visual Basic) | HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property.
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property.
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property.
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes.
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes.
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

HeaderedItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderedItemsControl Constructor

Initializes a new instance of the HeaderedItemsControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl()
C#
public HeaderedItemsControl()
Managed Extensions for C++
public: HeaderedItemsControl();
C++/CLI
public:
HeaderedItemsControl();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

For a list of all members of this type, see HeaderedItemsControl members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes.
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes.
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

See Also

Reference

HeaderedItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnHeaderChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : OnHeaderChanged Method

oldHeader
The old value of the Header property.
newHeader
The new value of the Header property.
Called when the Header property of a HeaderedItemsControl changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHeaderChanged( _
   ByVal oldHeader As Object, _
   ByVal newHeader As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim oldHeader As Object
Dim newHeader As Object

instance.OnHeaderChanged(oldHeader, newHeader)
C#
protected virtual void OnHeaderChanged(
   object oldHeader,
   object newHeader
)
Managed Extensions for C++
protected: virtual void OnHeaderChanged(
   Object* oldHeader,
   Object* newHeader
)
C++/CLI
protected:
virtual void OnHeaderChanged(
   Object^ oldHeader,
   Object^ newHeader
)

Parameters

oldHeader
The old value of the Header property.
newHeader
The new value of the Header property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnHeaderTemplateChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : OnHeaderTemplateChanged Method

oldHeaderTemplate
The old value of the HeaderTemplate property.
newHeaderTemplate
The new value of the HeaderTemplate property.
Called when the HeaderTemplate property of a HeaderedItemsControl changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHeaderTemplateChanged( _
   ByVal oldHeaderTemplate As DataTemplate, _
   ByVal newHeaderTemplate As DataTemplate _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim oldHeaderTemplate As DataTemplate
Dim newHeaderTemplate As DataTemplate

instance.OnHeaderTemplateChanged(oldHeaderTemplate, newHeaderTemplate)
C#
protected virtual void OnHeaderTemplateChanged(
   DataTemplate oldHeaderTemplate,
   DataTemplate newHeaderTemplate
)
Managed Extensions for C++
protected: virtual void OnHeaderTemplateChanged(
   DataTemplate* oldHeaderTemplate,
   DataTemplate* newHeaderTemplate
)
C++/CLI
protected:
virtual void OnHeaderTemplateChanged(
   DataTemplate^ oldHeaderTemplate,
   DataTemplate^ newHeaderTemplate
)

Parameters

oldHeaderTemplate
The old value of the HeaderTemplate property.
newHeaderTemplate
The new value of the HeaderTemplate property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnHeaderTemplateSelectorChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : OnHeaderTemplateSelectorChanged Method

oldHeaderTemplateSelector
The old value of the HeaderTemplateSelector property.
newHeaderTemplateSelector
The new value of the HeaderTemplateSelector property.
Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHeaderTemplateSelectorChanged( _
   ByVal oldHeaderTemplateSelector As DataTemplateSelector, _
   ByVal newHeaderTemplateSelector As DataTemplateSelector _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim oldHeaderTemplateSelector As DataTemplateSelector
Dim newHeaderTemplateSelector As DataTemplateSelector

instance.OnHeaderTemplateSelectorChanged(oldHeaderTemplateSelector, newHeaderTemplateSelector)
C#
protected virtual void OnHeaderTemplateSelectorChanged(
   DataTemplateSelector oldHeaderTemplateSelector,
   DataTemplateSelector newHeaderTemplateSelector
)
Managed Extensions for C++
protected: virtual void OnHeaderTemplateSelectorChanged(
   DataTemplateSelector* oldHeaderTemplateSelector,
   DataTemplateSelector* newHeaderTemplateSelector
)
C++/CLI
protected:
virtual void OnHeaderTemplateSelectorChanged(
   DataTemplateSelector^ oldHeaderTemplateSelector,
   DataTemplateSelector^ newHeaderTemplateSelector
)

Parameters

oldHeaderTemplateSelector
The old value of the HeaderTemplateSelector property.
newHeaderTemplateSelector
The new value of the HeaderTemplateSelector property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

For a list of all members of this type, see HeaderedItemsControl members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property.
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property.
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property.
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

HeaderedItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HasHeader Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HasHeader Property

Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim value As Boolean

value = instance.HasHeader
C#
public bool HasHeader {get;}
Managed Extensions for C++
public: __property bool get_HasHeader();
C++/CLI
public:
property bool HasHeader {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Header Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : Header Property

Gets or sets the item that labels the control. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Header As Object
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim value As Object

instance.Header = value

value = instance.Header
C#
public object Header {get; set;}
Managed Extensions for C++
public: __property Object* get_Header();
public: __property void set_Header(
   Object* value
);
C++/CLI
public:
property Object^ Header {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderTemplate Property

Gets or sets the template used to display the contents of the control's header. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property HeaderTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim value As DataTemplate

instance.HeaderTemplate = value

value = instance.HeaderTemplate
C#
public DataTemplate HeaderTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_HeaderTemplate();
public: __property void set_HeaderTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ HeaderTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderTemplateSelector Property

Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property HeaderTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As HeaderedItemsControl
Dim value As DataTemplateSelector

instance.HeaderTemplateSelector = value

value = instance.HeaderTemplateSelector
C#
public DataTemplateSelector HeaderTemplateSelector {get; set;}
Managed Extensions for C++
public: __property DataTemplateSelector* get_HeaderTemplateSelector();
public: __property void set_HeaderTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
public:
property DataTemplateSelector^ HeaderTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

For a list of all members of this type, see HeaderedItemsControl members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HasHeaderProperty | Identifies the HasHeader dependency property.
static (Shared in Visual Basic) | HeaderProperty | Identifies the Header dependency property.
static (Shared in Visual Basic) | HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
static (Shared in Visual Basic) | HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property.
Top

See Also

Reference

HeaderedItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HasHeaderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HasHeaderProperty Field

Identifies the HasHeader dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HasHeaderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedItemsControl.HasHeaderProperty
C#
public static readonly DependencyProperty HasHeaderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HasHeaderProperty
C++/CLI
public:
static readonly DependencyProperty^ HasHeaderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderProperty Field

Identifies the Header dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedItemsControl.HeaderProperty
C#
public static readonly DependencyProperty HeaderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderTemplateProperty Field

Identifies the HeaderTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedItemsControl.HeaderTemplateProperty
C#
public static readonly DependencyProperty HeaderTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > HeaderedItemsControl Class : HeaderTemplateSelectorProperty Field

Identifies the HeaderTemplateSelector dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = HeaderedItemsControl.HeaderTemplateSelectorProperty
C#
public static readonly DependencyProperty HeaderTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedItemsControl Class
HeaderedItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HierarchicalDataTemplate Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : HierarchicalDataTemplate Class

Represents a DataTemplate that supports HeaderedItemsControl, such as RadTreeViewItem or RadMenuItem.

Object Model

Syntax

Visual Basic (Declaration)
<ContentPropertyAttribute("HeaderTemplate")>
Public Class HierarchicalDataTemplate
   Inherits DataTemplate
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
C#
[ContentPropertyAttribute("HeaderTemplate")]
public class HierarchicalDataTemplate : DataTemplate, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[ContentPropertyAttribute("HeaderTemplate")]
public __gc class HierarchicalDataTemplate : public DataTemplate, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[ContentPropertyAttribute("HeaderTemplate")]
public ref class HierarchicalDataTemplate : public DataTemplate, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.FrameworkTemplate
System.Windows.DataTemplate
Telerik.Windows.Controls.HierarchicalDataTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
HierarchicalDataTemplate Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls Namespace : HierarchicalDataTemplate Class

The following tables list the members exposed by HierarchicalDataTemplate.

Public Constructors

 | Name | Description
Public Constructor | HierarchicalDataTemplate Constructor | Initializes a new instance of the HierarchicalDataTemplate class.
Top

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | HeaderTemplate | Gets or sets the DataTemplate to apply to the HeaderTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem).
Public Property | ItemsSource | Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.
Public Property | ItemTemplate | Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to display items from the next level in the data hierarchy.
Public Property | ItemTemplateSelector | Gets or sets the DataTemplateSelector to apply to the ItemTemplateSelector property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to select a template to display items from the next level in the data hierarchy.
Top

Public Methods

 | Name | Description
Public Method | ClearValue | (Inherited from System.Windows.DependencyObject)
Public Method | LoadContent | Creates the System.Windows.UIElement objects in the System.Windows.DataTemplate.
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

HierarchicalDataTemplate Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HierarchicalDataTemplate Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : HierarchicalDataTemplate Constructor

Initializes a new instance of the HierarchicalDataTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate()
C#
public HierarchicalDataTemplate()
Managed Extensions for C++
public: HierarchicalDataTemplate();
C++/CLI
public:
HierarchicalDataTemplate();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
HierarchicalDataTemplate Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : HierarchicalDataTemplate Class

For a list of all members of this type, see HierarchicalDataTemplate members.

Public Methods

 | Name | Description
Public Method | ClearValue | (Inherited from System.Windows.DependencyObject)
Public Method | LoadContent | Creates the System.Windows.UIElement objects in the System.Windows.DataTemplate.
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

HierarchicalDataTemplate Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
LoadContent Method
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : LoadContent Method

Creates the System.Windows.UIElement objects in the System.Windows.DataTemplate.

Syntax

Visual Basic (Declaration)
Public Function LoadContent() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
Dim value As DependencyObject

value = instance.LoadContent()
C#
public DependencyObject LoadContent()
Managed Extensions for C++
public: DependencyObject* LoadContent();
C++/CLI
public:
DependencyObject^ LoadContent();

Return Value

The root System.Windows.UIElement of the HeaderTemplate.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
HierarchicalDataTemplate Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : HierarchicalDataTemplate Class

For a list of all members of this type, see HierarchicalDataTemplate members.

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | HeaderTemplate | Gets or sets the DataTemplate to apply to the HeaderTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem).
Public Property | ItemsSource | Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.
Public Property | ItemTemplate | Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to display items from the next level in the data hierarchy.
Public Property | ItemTemplateSelector | Gets or sets the DataTemplateSelector to apply to the ItemTemplateSelector property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to select a template to display items from the next level in the data hierarchy.
Top

See Also

Reference

HierarchicalDataTemplate Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HeaderTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : HeaderTemplate Property

Gets or sets the DataTemplate to apply to the HeaderTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem).

Syntax

Visual Basic (Declaration)
Public Property HeaderTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
Dim value As DataTemplate

instance.HeaderTemplate = value

value = instance.HeaderTemplate
C#
public DataTemplate HeaderTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_HeaderTemplate();
public: __property void set_HeaderTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ HeaderTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemsSource Property
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : ItemsSource Property

Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property ItemsSource As Binding
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
Dim value As Binding

instance.ItemsSource = value

value = instance.ItemsSource
C#
[CompilerGeneratedAttribute()]
public Binding ItemsSource {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Binding* get_ItemsSource();
public: __property void set_ItemsSource(
   Binding* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Binding^ ItemsSource {
   Binding^ get();
   void set (Binding^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : ItemTemplate Property

Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to display items from the next level in the data hierarchy.

Syntax

Visual Basic (Declaration)
Public Property ItemTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
Dim value As DataTemplate

instance.ItemTemplate = value

value = instance.ItemTemplate
C#
public DataTemplate ItemTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_ItemTemplate();
public: __property void set_ItemTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ ItemTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > HierarchicalDataTemplate Class : ItemTemplateSelector Property

Gets or sets the DataTemplateSelector to apply to the ItemTemplateSelector property on a generated HeaderedItemsControl (such as a RadMenuItem or a RadTreeViewItem), to indicate how to select a template to display items from the next level in the data hierarchy.

Syntax

Visual Basic (Declaration)
Public Property ItemTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalDataTemplate
Dim value As DataTemplateSelector

instance.ItemTemplateSelector = value

value = instance.ItemTemplateSelector
C#
public DataTemplateSelector ItemTemplateSelector {get; set;}
Managed Extensions for C++
public: __property DataTemplateSelector* get_ItemTemplateSelector();
public: __property void set_ItemTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
public:
property DataTemplateSelector^ ItemTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HierarchicalDataTemplate Class
HierarchicalDataTemplate Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerGenerator Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ItemContainerGenerator Class

Base class for all the items controls.

Syntax

Visual Basic (Declaration)
Public Class ItemContainerGenerator
Visual Basic (Usage) Copy Code
Dim instance As ItemContainerGenerator
C#
public class ItemContainerGenerator
Managed Extensions for C++
public __gc class ItemContainerGenerator
C++/CLI
public ref class ItemContainerGenerator

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.ItemContainerGenerator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
ItemContainerGenerator Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : ItemContainerGenerator Class

The following tables list the members exposed by ItemContainerGenerator.

Public Constructors

 | Name | Description
Public Constructor | ItemContainerGenerator Constructor | Initializes a new instance of the ItemContainerGenerator class.
Top

Public Methods

 | Name | Description
Public Method | ContainerFromIndex | Returns the container for the given item index.
Public Method | ContainerFromItem | Returns the container for the given item of the ItemsControl.
Public Method | IndexFromContainer | Returns the index of the given container.
Public Method | ItemFromContainer | Returns the item for the given container.
Top

See Also

Reference

ItemContainerGenerator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerGenerator Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > ItemContainerGenerator Class : ItemContainerGenerator Constructor

itemsControl
The items control.
Initializes a new instance of the ItemContainerGenerator class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemsControl As ItemsControl _
)
Visual Basic (Usage) Copy Code
Dim itemsControl As ItemsControl

Dim instance As ItemContainerGenerator(itemsControl)
C#
public ItemContainerGenerator(
   ItemsControl itemsControl
)
Managed Extensions for C++
public: ItemContainerGenerator(
   ItemsControl* itemsControl
)
C++/CLI
public:
ItemContainerGenerator(
   ItemsControl^ itemsControl
)

Parameters

itemsControl
The items control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Class
ItemContainerGenerator Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
ItemContainerGenerator Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ItemContainerGenerator Class

For a list of all members of this type, see ItemContainerGenerator members.

Public Methods

 | Name | Description
Public Method | ContainerFromIndex | Returns the container for the given item index.
Public Method | ContainerFromItem | Returns the container for the given item of the ItemsControl.
Public Method | IndexFromContainer | Returns the index of the given container.
Public Method | ItemFromContainer | Returns the item for the given container.
Top

See Also

Reference

ItemContainerGenerator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ContainerFromIndex Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemContainerGenerator Class : ContainerFromIndex Method

index
The index of the item.
Returns the container for the given item index.

Syntax

Visual Basic (Declaration)
Public Function ContainerFromIndex( _
   ByVal index As Integer _
) As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As ItemContainerGenerator
Dim index As Integer
Dim value As DependencyObject

value = instance.ContainerFromIndex(index)
C#
public DependencyObject ContainerFromIndex(
   int index
)
Managed Extensions for C++
public: DependencyObject* ContainerFromIndex(
   int index
)
C++/CLI
public:
DependencyObject^ ContainerFromIndex(
   int index
)

Parameters

index
The index of the item.

Return Value

The container for the item at the given index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Class
ItemContainerGenerator Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ContainerFromItem Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemContainerGenerator Class : ContainerFromItem Method

item
The item for which ti finds the container
Returns the container for the given item of the ItemsControl.

Syntax

Visual Basic (Declaration)
Public Function ContainerFromItem( _
   ByVal item As Object _
) As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As ItemContainerGenerator
Dim item As Object
Dim value As DependencyObject

value = instance.ContainerFromItem(item)
C#
public DependencyObject ContainerFromItem(
   object item
)
Managed Extensions for C++
public: DependencyObject* ContainerFromItem(
   Object* item
)
C++/CLI
public:
DependencyObject^ ContainerFromItem(
   Object^ item
)

Parameters

item
The item for which ti finds the container

Return Value

Returns null if not found.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Class
ItemContainerGenerator Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IndexFromContainer Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemContainerGenerator Class : IndexFromContainer Method

container
The container for which to get the index.
Returns the index of the given container.

Syntax

Visual Basic (Declaration)
Public Function IndexFromContainer( _
   ByVal container As DependencyObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ItemContainerGenerator
Dim container As DependencyObject
Dim value As Integer

value = instance.IndexFromContainer(container)
C#
public int IndexFromContainer(
   DependencyObject container
)
Managed Extensions for C++
public: int IndexFromContainer(
   DependencyObject* container
)
C++/CLI
public:
int IndexFromContainer(
   DependencyObject^ container
)

Parameters

container
The container for which to get the index.

Return Value

The index of the container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Class
ItemContainerGenerator Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemFromContainer Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemContainerGenerator Class : ItemFromContainer Method

container
The container for which to get an item.
Returns the item for the given container.

Syntax

Visual Basic (Declaration)
Public Function ItemFromContainer( _
   ByVal container As DependencyObject _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ItemContainerGenerator
Dim container As DependencyObject
Dim value As Object

value = instance.ItemFromContainer(container)
C#
public object ItemFromContainer(
   DependencyObject container
)
Managed Extensions for C++
public: Object* ItemFromContainer(
   DependencyObject* container
)
C++/CLI
public:
Object^ ItemFromContainer(
   DependencyObject^ container
)

Parameters

container
The container for which to get an item.

Return Value

Returns the item for the container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemContainerGenerator Class
ItemContainerGenerator Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

Base class for all the items controls.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ItemsControl
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
C#
public class ItemsControl : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class ItemsControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class ItemsControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.MenuBase
Telerik.Windows.Controls.RadChaptersPresenter
Telerik.Windows.Controls.RadCube
Telerik.Windows.Controls.RadMediaItem
Telerik.Windows.Controls.RadMediaPlayer
Telerik.Windows.Controls.RadPanelBar
Telerik.Windows.Controls.RadTabControl
Telerik.Windows.Controls.RadTreeView
Telerik.Windows.Controls.Selector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

The following tables list the members exposed by ItemsControl.

Public Constructors

 | Name | Description
Public Constructor | ItemsControl Constructor | Default constructor for the ItemsControl.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsTextSearchEnabledProperty | Identifies the IsTextSearchEnabled dependency property.
static (Shared in Visual Basic) | ItemContainerStyleProperty | Identifies the ItemContainerStyle property.
static (Shared in Visual Basic) | ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector property.
static (Shared in Visual Basic) | ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control.
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property.
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property.
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | ItemsControlFromItemContainer | Returns the ItemsControl of the given container.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

ItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemsControl Constructor

Default constructor for the ItemsControl.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl()
C#
public ItemsControl()
Managed Extensions for C++
public: ItemsControl();
C++/CLI
public:
ItemsControl();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

For a list of all members of this type, see ItemsControl members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | ItemsControlFromItemContainer | Returns the ItemsControl of the given container.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

ItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ClearContainerForItemOverride Method

element
The container element.
item
The Item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The Item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemsControlFromItemContainer Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemsControlFromItemContainer Method

container
The container for which to retrieve the ItemsControl.
Returns the ItemsControl of the given container.

Syntax

Visual Basic (Declaration)
Public Shared Function ItemsControlFromItemContainer( _
   ByVal container As DependencyObject _
) As ItemsControl
Visual Basic (Usage) Copy Code
Dim container As DependencyObject
Dim value As ItemsControl

value = ItemsControl.ItemsControlFromItemContainer(container)
C#
public static ItemsControl ItemsControlFromItemContainer(
   DependencyObject container
)
Managed Extensions for C++
public: static ItemsControl* ItemsControlFromItemContainer(
   DependencyObject* container
)
C++/CLI
public:
static ItemsControl^ ItemsControlFromItemContainer(
   DependencyObject^ container
)

Parameters

container
The container for which to retrieve the ItemsControl.

Return Value

The ItemsControl of the container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnItemTemplateSelectorChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : OnItemTemplateSelectorChanged Method

oldItemTemplateSelector
The old TemplateSelector.
newItemTemplateSelector
The new TemplateSelector.
When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemTemplateSelectorChanged( _
   ByVal oldItemTemplateSelector As DataTemplateSelector, _
   ByVal newItemTemplateSelector As DataTemplateSelector _
)
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim oldItemTemplateSelector As DataTemplateSelector
Dim newItemTemplateSelector As DataTemplateSelector

instance.OnItemTemplateSelectorChanged(oldItemTemplateSelector, newItemTemplateSelector)
C#
protected virtual void OnItemTemplateSelectorChanged(
   DataTemplateSelector oldItemTemplateSelector,
   DataTemplateSelector newItemTemplateSelector
)
Managed Extensions for C++
protected: virtual void OnItemTemplateSelectorChanged(
   DataTemplateSelector* oldItemTemplateSelector,
   DataTemplateSelector* newItemTemplateSelector
)
C++/CLI
protected:
virtual void OnItemTemplateSelectorChanged(
   DataTemplateSelector^ oldItemTemplateSelector,
   DataTemplateSelector^ newItemTemplateSelector
)

Parameters

oldItemTemplateSelector
The old TemplateSelector.
newItemTemplateSelector
The new TemplateSelector.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

For a list of all members of this type, see ItemsControl members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control.
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property.
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property.
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

ItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HasItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : HasItems Property

Gets whether the ItemsControl has any children.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property HasItems As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As Boolean

value = instance.HasItems
C#
[BrowsableAttribute(false)]
public bool HasItems {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_HasItems();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool HasItems {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsTextSearchEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : IsTextSearchEnabled Property

Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsTextSearchEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As Boolean

instance.IsTextSearchEnabled = value

value = instance.IsTextSearchEnabled
C#
public bool IsTextSearchEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsTextSearchEnabled();
public: __property void set_IsTextSearchEnabled(
   bool value
);
C++/CLI
public:
property bool IsTextSearchEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerGenerator Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemContainerGenerator Property

Gets the ItemContainerGenerator that is associated with the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemContainerGenerator As ItemContainerGenerator
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As ItemContainerGenerator

value = instance.ItemContainerGenerator
C#
public ItemContainerGenerator ItemContainerGenerator {get;}
Managed Extensions for C++
public: __property ItemContainerGenerator* get_ItemContainerGenerator();
C++/CLI
public:
property ItemContainerGenerator^ ItemContainerGenerator {
   ItemContainerGenerator^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemContainerStyle Property

Gets or sets the style for the item containers of the control. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the style for the item containers of the control. This is a dependency property.")>
<SRCategoryAttribute("AppearanceCategory")>
Public Property ItemContainerStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As Style

instance.ItemContainerStyle = value

value = instance.ItemContainerStyle
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the style for the item containers of the control. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public Style ItemContainerStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the style for the item containers of the control. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public: __property Style* get_ItemContainerStyle();
public: __property void set_ItemContainerStyle(
   Style* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the style for the item containers of the control. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public:
property Style^ ItemContainerStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemContainerStyleSelector Property

Gets or sets the style selector for the items of the control. This is a dependency property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property ItemContainerStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As StyleSelector

instance.ItemContainerStyleSelector = value

value = instance.ItemContainerStyleSelector
C#
[BrowsableAttribute(false)]
public StyleSelector ItemContainerStyleSelector {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property StyleSelector* get_ItemContainerStyleSelector();
public: __property void set_ItemContainerStyleSelector(
   StyleSelector* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property StyleSelector^ ItemContainerStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemTemplateSelector Property

Gets or sets the template selector for the items of the control. This is a dependency proeprty.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property ItemTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As ItemsControl
Dim value As DataTemplateSelector

instance.ItemTemplateSelector = value

value = instance.ItemTemplateSelector
C#
[BrowsableAttribute(false)]
public DataTemplateSelector ItemTemplateSelector {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataTemplateSelector* get_ItemTemplateSelector();
public: __property void set_ItemTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property DataTemplateSelector^ ItemTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

For a list of all members of this type, see ItemsControl members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsTextSearchEnabledProperty | Identifies the IsTextSearchEnabled dependency property.
static (Shared in Visual Basic) | ItemContainerStyleProperty | Identifies the ItemContainerStyle property.
static (Shared in Visual Basic) | ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector property.
static (Shared in Visual Basic) | ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector property.
Top

See Also

Reference

ItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsTextSearchEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : IsTextSearchEnabledProperty Field

Identifies the IsTextSearchEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsTextSearchEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = ItemsControl.IsTextSearchEnabledProperty
C#
public static readonly DependencyProperty IsTextSearchEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsTextSearchEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsTextSearchEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemContainerStyleProperty Field

Identifies the ItemContainerStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = ItemsControl.ItemContainerStyleProperty
C#
public static readonly DependencyProperty ItemContainerStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemContainerStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemContainerStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemContainerStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemContainerStyleSelectorProperty Field

Identifies the ItemContainerStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = ItemsControl.ItemContainerStyleSelectorProperty
C#
public static readonly DependencyProperty ItemContainerStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemContainerStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemContainerStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControl Class : ItemTemplateSelectorProperty Field

Identifies the ItemTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = ItemsControl.ItemTemplateSelectorProperty
C#
public static readonly DependencyProperty ItemTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControl Class
ItemsControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemsControlExtensions Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ItemsControlExtensions Class

Contains helper extension methods for the ItemsControl class

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public MustInherit NotInheritable Class ItemsControlExtensions
Visual Basic (Usage) Copy Code
Dim instance As ItemsControlExtensions
C#
[ExtensionAttribute()]
public static class ItemsControlExtensions
Managed Extensions for C++
[ExtensionAttribute()]
public __gc abstract __sealed class ItemsControlExtensions
C++/CLI
[ExtensionAttribute()]
public ref class ItemsControlExtensions abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.ItemsControlExtensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControlExtensions Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControlExtensions Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : ItemsControlExtensions Class

The following tables list the members exposed by ItemsControlExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Generic ForEachContainerItem | Executes the given action on each container item of the control.
Top

See Also

Reference

ItemsControlExtensions Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControlExtensions Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsControlExtensions Class

For a list of all members of this type, see ItemsControlExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Generic ForEachContainerItem | Executes the given action on each container item of the control.
Top

See Also

Reference

ItemsControlExtensions Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

T
The type of container expected, depends on the ItemControl calss.
Telerik.Windows.Controls Send comments on this topic.
Generic ForEachContainerItem Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsControlExtensions Class : Generic ForEachContainerItem Method

itemsControl
The ItemsControl instance.
work
The action to execute on the items.
Executes the given action on each container item of the control.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Shared Sub ForEachContainerItem(Of T As DependencyObject)( _
   ByVal itemsControl As ItemsControl, _
   ByVal work As Action(Of T) _
)
Visual Basic (Usage) Copy Code
Dim itemsControl As ItemsControl
Dim work As Action(Of T)

ItemsControlExtensions.ForEachContainerItem(Of T)(itemsControl, work)
C#
[ExtensionAttribute()]
public static void ForEachContainerItem<T>(
   ItemsControl itemsControl,
   Action<T> work
)where T: DependencyObject
Managed Extensions for C++
[ExtensionAttribute()]
public: static void ForEachContainerItem<T>(
   ItemsControl* itemsControl,
   Action<T>* work
) where T: DependencyObject
C++/CLI
[ExtensionAttribute()]
public:
static void ForEachContainerItemgeneric<typename T>
(
   ItemsControl^ itemsControl,
   Action<T>^ work
) where T: DependencyObject

Parameters

itemsControl
The ItemsControl instance.
work
The action to execute on the items.

Type Parameters

T
The type of container expected, depends on the ItemControl calss.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsControlExtensions Class
ItemsControlExtensions Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

Represents a selectable item in a ListBox.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class ListBoxItem
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper, ISelectable
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
C#
public abstract class ListBoxItem : ContentControl, IManagedPeer, INativeCoreTypeWrapper, ISelectable
Managed Extensions for C++
public __gc abstract class ListBoxItem : public ContentControl, IManagedPeer, INativeCoreTypeWrapper, ISelectable
C++/CLI
public ref class ListBoxItem abstract : public ContentControl, IManagedPeer, INativeCoreTypeWrapper, ISelectable

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.ListBoxItem
Telerik.Windows.Controls.RadComboBoxItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

The following tables list the members exposed by ListBoxItem.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnMouseEnter | Invoked when an unhandled MouseEnter event is raised on this element.
Protected Method | OnMouseLeftButtonDown | Called when the user presses the left mouse button over the ListBoxItem.
Protected Method | OnMouseLeftButtonUp | Called when the user releases the left mouse button over the ListBoxItem.
Protected Method | OnSelected | Called when the ListBoxItem is selected in a ListBox.
Protected Method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Selected | Occurs when a ListBoxItem is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unselected | Occurs when a ListBoxItem is unselected.
Top

See Also

Reference

ListBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

For a list of all members of this type, see ListBoxItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnMouseEnter | Invoked when an unhandled MouseEnter event is raised on this element.
Protected Method | OnMouseLeftButtonDown | Called when the user presses the left mouse button over the ListBoxItem.
Protected Method | OnMouseLeftButtonUp | Called when the user releases the left mouse button over the ListBoxItem.
Protected Method | OnSelected | Called when the ListBoxItem is selected in a ListBox.
Protected Method | OnUnselected | Called when the ListBoxItem is unselected in a ListBox.
Top

See Also

Reference

ListBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMouseEnter Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnMouseEnter Method

e
The MouseEventArgs that contains the event data.
Invoked when an unhandled MouseEnter event is raised on this element.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseEnter( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim e As MouseEventArgs

instance.OnMouseEnter(e)
C#
protected virtual void OnMouseEnter(
   MouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseEnter(
   MouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseEnter(
   MouseEventArgs^ e
)

Parameters

e
The MouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMouseLeftButtonDown Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnMouseLeftButtonDown Method

e
The event data.
Called when the user presses the left mouse button over the ListBoxItem.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseLeftButtonDown( _
   ByVal e As MouseButtonEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim e As MouseButtonEventArgs

instance.OnMouseLeftButtonDown(e)
C#
protected virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs^ e
)

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMouseLeftButtonUp Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnMouseLeftButtonUp Method

e
The event data.
Called when the user releases the left mouse button over the ListBoxItem.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseLeftButtonUp( _
   ByVal e As MouseButtonEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim e As MouseButtonEventArgs

instance.OnMouseLeftButtonUp(e)
C#
protected virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs^ e
)

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnSelected Method

e
The event data.
Called when the ListBoxItem is selected in a ListBox.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim e As RadRoutedEventArgs

instance.OnSelected(e)
C#
protected virtual void OnSelected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelected(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data.

Remarks

This method is called when the IsSelected property changes to true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnUnselected Method
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : OnUnselected Method

e
The event data.
Called when the ListBoxItem is unselected in a ListBox.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUnselected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim e As RadRoutedEventArgs

instance.OnUnselected(e)
C#
protected virtual void OnUnselected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUnselected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnUnselected(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data.

Remarks

This method is called when the IsSelected property changes to false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

For a list of all members of this type, see ListBoxItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

ListBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : IsSelected Property

Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
public bool IsSelected {get; set;}
Managed Extensions for C++
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

For a list of all members of this type, see ListBoxItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

See Also

Reference

ListBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : SelectedEvent Field

Identifies the Selected routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="RoutedEvent is immutable")>
Public Shared ReadOnly SelectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = ListBoxItem.SelectedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="RoutedEvent is immutable")]
public static readonly RoutedEvent SelectedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="RoutedEvent is immutable")]
public: static readonly RoutedEvent* SelectedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="RoutedEvent is immutable")]
public:
static readonly RoutedEvent^ SelectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
UnselectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : UnselectedEvent Field

Identifies the Unselected routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Justification="RoutedEvent is immutable",
   Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="")>
Public Shared ReadOnly UnselectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = ListBoxItem.UnselectedEvent
C#
[SuppressMessageAttribute(Justification="RoutedEvent is immutable",
   Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="")]
public static readonly RoutedEvent UnselectedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Justification="RoutedEvent is immutable",
   Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="")]
public: static readonly RoutedEvent* UnselectedEvent
C++/CLI
[SuppressMessageAttribute(Justification="RoutedEvent is immutable",
   Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="")]
public:
static readonly RoutedEvent^ UnselectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
ListBoxItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : ListBoxItem Class

For a list of all members of this type, see ListBoxItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Selected | Occurs when a ListBoxItem is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unselected | Occurs when a ListBoxItem is unselected.
Top

See Also

Reference

ListBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Selected Event
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : Selected Event

Occurs when a ListBoxItem is selected.

Syntax

Visual Basic (Declaration)
Public Event Selected() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim handler As RoutedEventHandler

AddHandler instance.Selected, handler
C#
public event RoutedEventHandler Selected()
Managed Extensions for C++
public: __event RoutedEventHandler* Selected
C++/CLI
public:
event RoutedEventHandler^ Selected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Unselected Event
See Also
[image]
Telerik.Windows.Controls Namespace > ListBoxItem Class : Unselected Event

Occurs when a ListBoxItem is unselected.

Syntax

Visual Basic (Declaration)
Public Event Unselected() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListBoxItem
Dim handler As RoutedEventHandler

AddHandler instance.Unselected, handler
C#
public event RoutedEventHandler Unselected()
Managed Extensions for C++
public: __event RoutedEventHandler* Unselected
C++/CLI
public:
event RoutedEventHandler^ Unselected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBoxItem Class
ListBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadControl Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadControl Class

Static container for the Theme attached property.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadControl
C#
public static class RadControl
Managed Extensions for C++
public __gc abstract __sealed class RadControl
C++/CLI
public ref class RadControl abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.RadControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadControl Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadControl Class Members
See Also Fields Methods
[image]
Telerik.Windows.Controls Namespace : RadControl Class

The following tables list the members exposed by RadControl.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ThemeProperty | Identifies the Theme attached property.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetTheme | Gets the value of the Theme attached property from a given DependencyObject.
static (Shared in Visual Basic) | SetTheme | Sets the value of the Theme attached property to a given DependencyObject.
Top

See Also

Reference

RadControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadControl Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadControl Class

For a list of all members of this type, see RadControl members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetTheme | Gets the value of the Theme attached property from a given DependencyObject.
static (Shared in Visual Basic) | SetTheme | Sets the value of the Theme attached property to a given DependencyObject.
Top

See Also

Reference

RadControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetTheme Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadControl Class : GetTheme Method

obj
The DependencyObject from which to read the property value.
Gets the value of the Theme attached property from a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Function GetTheme( _
   ByVal obj As DependencyObject _
) As Theme
Visual Basic (Usage) Copy Code
Dim obj As DependencyObject
Dim value As Theme

value = RadControl.GetTheme(obj)
C#
public static Theme GetTheme(
   DependencyObject obj
)
Managed Extensions for C++
public: static Theme* GetTheme(
   DependencyObject* obj
)
C++/CLI
public:
static Theme^ GetTheme(
   DependencyObject^ obj
)

Parameters

obj
The DependencyObject from which to read the property value.

Return Value

The value of the Theme attached property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadControl Class
RadControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetTheme Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadControl Class : SetTheme Method

obj
The DependencyObject on which to set the property value.
value
The property value to set.
Sets the value of the Theme attached property to a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetTheme( _
   ByVal obj As DependencyObject, _
   ByVal value As Theme _
)
Visual Basic (Usage) Copy Code
Dim obj As DependencyObject
Dim value As Theme

RadControl.SetTheme(obj, value)
C#
public static void SetTheme(
   DependencyObject obj,
   Theme value
)
Managed Extensions for C++
public: static void SetTheme(
   DependencyObject* obj,
   Theme* value
)
C++/CLI
public:
static void SetTheme(
   DependencyObject^ obj,
   Theme^ value
)

Parameters

obj
The DependencyObject on which to set the property value.
value
The property value to set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadControl Class
RadControl Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadControl Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadControl Class

For a list of all members of this type, see RadControl members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ThemeProperty | Identifies the Theme attached property.
Top

See Also

Reference

RadControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ThemeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadControl Class : ThemeProperty Field

Identifies the Theme attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ThemeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadControl.ThemeProperty
C#
public static readonly DependencyProperty ThemeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ThemeProperty
C++/CLI
public:
static readonly DependencyProperty^ ThemeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadControl Class
RadControl Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

Defines an area where you can arrange child elements either horizontally or vertically, relative to each other.

Syntax

Visual Basic (Declaration)
Public Class RadDockPanel
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadDockPanel
C#
public class RadDockPanel : Panel, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadDockPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadDockPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.RadDockPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

The following tables list the members exposed by RadDockPanel.

Public Constructors

 | Name | Description
Public Constructor | RadDockPanel Constructor | Initializes a new instance of the RadDockPanel class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DockProperty | Identifies the Dock attached property.
static (Shared in Visual Basic) | LastChildFillProperty | Identifies the LastChildFill dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LastChildFill | Gets or sets a value that indicates whether the last child element within a DockPanel stretches to fill the remaining available space. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
static (Shared in Visual Basic) | GetDock | Gets the value of the Dock attached property for a specified UIElement.
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
static (Shared in Visual Basic) | SetDock | Sets the value of the Dock attached property to a specified element.
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.
Protected Method | MeasureOverride | Overridden. Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadDockPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : RadDockPanel Constructor

Initializes a new instance of the RadDockPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadDockPanel()
C#
public RadDockPanel()
Managed Extensions for C++
public: RadDockPanel();
C++/CLI
public:
RadDockPanel();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

For a list of all members of this type, see RadDockPanel members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
static (Shared in Visual Basic) | GetDock | Gets the value of the Dock attached property for a specified UIElement.
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
static (Shared in Visual Basic) | SetDock | Sets the value of the Dock attached property to a specified element.
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.
Protected Method | MeasureOverride | Overridden. Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.
Top

See Also

Reference

RadDockPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadDockPanel
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetDock Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : GetDock Method

element
The element from which the property value is read.
Gets the value of the Dock attached property for a specified UIElement.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")>
Public Shared Function GetDock( _
   ByVal element As UIElement _
) As Dock
Visual Basic (Usage) Copy Code
Dim element As UIElement
Dim value As Dock

value = RadDockPanel.GetDock(element)
C#
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public static Dock GetDock(
   UIElement element
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public: static Dock GetDock(
   UIElement* element
)
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public:
static Dock GetDock(
   UIElement^ element
)

Parameters

element
The element from which the property value is read.

Return Value

The Dock property value for the element.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadDockPanel
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetDock Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : SetDock Method

element
The element from which the property value is read.
dock
The Dock property value for the element.
Sets the value of the Dock attached property to a specified element.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")>
Public Shared Sub SetDock( _
   ByVal element As UIElement, _
   ByVal dock As Dock _
)
Visual Basic (Usage) Copy Code
Dim element As UIElement
Dim dock As Dock

RadDockPanel.SetDock(element, dock)
C#
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public static void SetDock(
   UIElement element,
   Dock dock
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public: static void SetDock(
   UIElement* element,
   Dock dock
)
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1011:ConsiderPassingBaseTypesAsParameters",
   Scope="",
   Target="",
   MessageId="",
   Justification="Dock should be used on UIElements only.")]
public:
static void SetDock(
   UIElement^ element,
   Dock dock
)

Parameters

element
The element from which the property value is read.
dock
The Dock property value for the element.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

For a list of all members of this type, see RadDockPanel members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LastChildFill | Gets or sets a value that indicates whether the last child element within a DockPanel stretches to fill the remaining available space. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadDockPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
LastChildFill Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : LastChildFill Property

Gets or sets a value that indicates whether the last child element within a DockPanel stretches to fill the remaining available space. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property LastChildFill As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadDockPanel
Dim value As Boolean

instance.LastChildFill = value

value = instance.LastChildFill
C#
public bool LastChildFill {get; set;}
Managed Extensions for C++
public: __property bool get_LastChildFill();
public: __property void set_LastChildFill(
   bool value
);
C++/CLI
public:
property bool LastChildFill {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

For a list of all members of this type, see RadDockPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DockProperty | Identifies the Dock attached property.
static (Shared in Visual Basic) | LastChildFillProperty | Identifies the LastChildFill dependency property.
Top

See Also

Reference

RadDockPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
DockProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : DockProperty Field

Identifies the Dock attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DockProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDockPanel.DockProperty
C#
public static readonly DependencyProperty DockProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DockProperty
C++/CLI
public:
static readonly DependencyProperty^ DockProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
LastChildFillProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDockPanel Class : LastChildFillProperty Field

Identifies the LastChildFill dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LastChildFillProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDockPanel.LastChildFillProperty
C#
public static readonly DependencyProperty LastChildFillProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LastChildFillProperty
C++/CLI
public:
static readonly DependencyProperty^ LastChildFillProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDockPanel Class
RadDockPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

Represents a pop-up window that has content

Syntax

Visual Basic (Declaration)
Public Class RadPopup
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
C#
public class RadPopup : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadPopup : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadPopup : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

Content Model: RadPopup has one content property: Child. A RadPopup can have a maximum of one child, which can be any UIElement.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.RadPopup

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

The following tables list the members exposed by RadPopup.

Public Constructors

 | Name | Description
Public Constructor | RadPopup Constructor | Initializes a new instance of the RadPopup class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HorizontalOffsetProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | IsOpenProperty | Identifies the IsOpen dependency property.
static (Shared in Visual Basic) | LogicalParentProperty | Identifies the LogicalParent dependency property
static (Shared in Visual Basic) | PlacementProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | PlacementRectangleProperty | Identifies the PlacementTarget dependency property.
static (Shared in Visual Basic) | PlacementTargetProperty | Identifies the PlacementTarget attached property.
static (Shared in Visual Basic) | StaysOpenProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the RadPopup alignment point. This is a dependency property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsOpen | Gets or sets a value that indicates whether the Popup is visible. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LogicalParent | The logical parent of the control.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Placement | Gets or sets the orientation of the RadPopup control when the control opens, and specifies the behavior of the RadPopup control when it overlaps plug-in boundaries. This is a dependency property.
Public Property | PlacementRectangle | Gets or sets the rectangle relative to which the RadPopup control is positioned when it opens. This is a dependency property.
Public Property | PlacementTarget | Gets or sets the element relative to which the RadPopup is positioned when it opens. This is a dependency property.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | StaysOpen | Gets or sets a value that indicates whether the Popup control closes when the control is no longer in focus. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VerticalOffset | Gets or sets the vertical distance between the target origin and the RadPopup alignment point. This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | GetLogicalParent | Gets the value of the LogicalParent attached property to a given DependencyObject.
static (Shared in Visual Basic) | SetLogicalParent | Sets the value of the LogicalParent attached property to a given DependencyObject.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | Overridden. Called when the value of the Content property changes.
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Closed | Occurs when the RadPopup is Closed
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Opened | Occurs when the RadPopup is Opened
Public Event | PopupMouseEnter | Occurs when the mouse pointer enters the bounds of this element.
Public Event | PopupMouseLeave | Occurs when the mouse pointer leaves the bounds of this element.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPopup Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadPopup Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : RadPopup Constructor

Initializes a new instance of the RadPopup class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPopup()
C#
public RadPopup()
Managed Extensions for C++
public: RadPopup();
C++/CLI
public:
RadPopup();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

For a list of all members of this type, see RadPopup members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | GetLogicalParent | Gets the value of the LogicalParent attached property to a given DependencyObject.
static (Shared in Visual Basic) | SetLogicalParent | Sets the value of the LogicalParent attached property to a given DependencyObject.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | Overridden. Called when the value of the Content property changes.
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

RadPopup Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetLogicalParent Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : GetLogicalParent Method

element
Gets the value of the LogicalParent attached property to a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLogicalParent( _
   ByVal element As DependencyObject _
) As FrameworkElement
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As FrameworkElement

value = RadPopup.GetLogicalParent(element)
C#
public static FrameworkElement GetLogicalParent(
   DependencyObject element
)
Managed Extensions for C++
public: static FrameworkElement* GetLogicalParent(
   DependencyObject* element
)
C++/CLI
public:
static FrameworkElement^ GetLogicalParent(
   DependencyObject^ element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnContentChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : OnContentChanged Method

oldContent
The old value of the Content property.
newContent
The new value of the Content property.
Called when the value of the Content property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged( _
   ByVal oldContent As Object, _
   ByVal newContent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim oldContent As Object
Dim newContent As Object

instance.OnContentChanged(oldContent, newContent)
C#
protected override void OnContentChanged(
   object oldContent,
   object newContent
)
Managed Extensions for C++
protected: void OnContentChanged(
   Object* oldContent,
   Object* newContent
) override
C++/CLI
protected:
void OnContentChanged(
   Object^ oldContent,
   Object^ newContent
) override

Parameters

oldContent
The old value of the Content property.
newContent
The new value of the Content property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetLogicalParent Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : SetLogicalParent Method

element
value
Sets the value of the LogicalParent attached property to a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetLogicalParent( _
   ByVal element As DependencyObject, _
   ByVal value As FrameworkElement _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As FrameworkElement

RadPopup.SetLogicalParent(element, value)
C#
public static void SetLogicalParent(
   DependencyObject element,
   FrameworkElement value
)
Managed Extensions for C++
public: static void SetLogicalParent(
   DependencyObject* element,
   FrameworkElement* value
)
C++/CLI
public:
static void SetLogicalParent(
   DependencyObject^ element,
   FrameworkElement^ value
)

Parameters

element
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

For a list of all members of this type, see RadPopup members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the RadPopup alignment point. This is a dependency property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsOpen | Gets or sets a value that indicates whether the Popup is visible. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LogicalParent | The logical parent of the control.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Placement | Gets or sets the orientation of the RadPopup control when the control opens, and specifies the behavior of the RadPopup control when it overlaps plug-in boundaries. This is a dependency property.
Public Property | PlacementRectangle | Gets or sets the rectangle relative to which the RadPopup control is positioned when it opens. This is a dependency property.
Public Property | PlacementTarget | Gets or sets the element relative to which the RadPopup is positioned when it opens. This is a dependency property.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | StaysOpen | Gets or sets a value that indicates whether the Popup control closes when the control is no longer in focus. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VerticalOffset | Gets or sets the vertical distance between the target origin and the RadPopup alignment point. This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadPopup Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HorizontalOffset Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : HorizontalOffset Property

Get or sets the horizontal distance between the target origin and the RadPopup alignment point. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As Double

instance.HorizontalOffset = value

value = instance.HorizontalOffset
C#
public double HorizontalOffset {get; set;}
Managed Extensions for C++
public: __property double get_HorizontalOffset();
public: __property void set_HorizontalOffset(
   double value
);
C++/CLI
public:
property double HorizontalOffset {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : IsOpen Property

Gets or sets a value that indicates whether the Popup is visible. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As Boolean

instance.IsOpen = value

value = instance.IsOpen
C#
public bool IsOpen {get; set;}
Managed Extensions for C++
public: __property bool get_IsOpen();
public: __property void set_IsOpen(
   bool value
);
C++/CLI
public:
property bool IsOpen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
LogicalParent Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : LogicalParent Property

The logical parent of the control.

Syntax

Visual Basic (Declaration)
Public Property LogicalParent As FrameworkElement
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As FrameworkElement

instance.LogicalParent = value

value = instance.LogicalParent
C#
public FrameworkElement LogicalParent {get; set;}
Managed Extensions for C++
public: __property FrameworkElement* get_LogicalParent();
public: __property void set_LogicalParent(
   FrameworkElement* value
);
C++/CLI
public:
property FrameworkElement^ LogicalParent {
   FrameworkElement^ get();
   void set (FrameworkElement^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Placement Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : Placement Property

Gets or sets the orientation of the RadPopup control when the control opens, and specifies the behavior of the RadPopup control when it overlaps plug-in boundaries. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Placement As PlacementMode
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As PlacementMode

instance.Placement = value

value = instance.Placement
C#
public PlacementMode Placement {get; set;}
Managed Extensions for C++
public: __property PlacementMode get_Placement();
public: __property void set_Placement(
   PlacementMode value
);
C++/CLI
public:
property PlacementMode Placement {
   PlacementMode get();
   void set (PlacementMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementRectangle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PlacementRectangle Property

Gets or sets the rectangle relative to which the RadPopup control is positioned when it opens. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property PlacementRectangle As FrameworkElement
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As FrameworkElement

instance.PlacementRectangle = value

value = instance.PlacementRectangle
C#
public FrameworkElement PlacementRectangle {get; set;}
Managed Extensions for C++
public: __property FrameworkElement* get_PlacementRectangle();
public: __property void set_PlacementRectangle(
   FrameworkElement* value
);
C++/CLI
public:
property FrameworkElement^ PlacementRectangle {
   FrameworkElement^ get();
   void set (FrameworkElement^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementTarget Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PlacementTarget Property

Gets or sets the element relative to which the RadPopup is positioned when it opens. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property PlacementTarget As FrameworkElement
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As FrameworkElement

instance.PlacementTarget = value

value = instance.PlacementTarget
C#
public FrameworkElement PlacementTarget {get; set;}
Managed Extensions for C++
public: __property FrameworkElement* get_PlacementTarget();
public: __property void set_PlacementTarget(
   FrameworkElement* value
);
C++/CLI
public:
property FrameworkElement^ PlacementTarget {
   FrameworkElement^ get();
   void set (FrameworkElement^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
StaysOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : StaysOpen Property

Gets or sets a value that indicates whether the Popup control closes when the control is no longer in focus. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Property StaysOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As Boolean

instance.StaysOpen = value

value = instance.StaysOpen
C#
[SRCategoryAttribute("Behavior")]
public bool StaysOpen {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __property bool get_StaysOpen();
public: __property void set_StaysOpen(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
property bool StaysOpen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
VerticalOffset Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : VerticalOffset Property

Gets or sets the vertical distance between the target origin and the RadPopup alignment point. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim value As Double

instance.VerticalOffset = value

value = instance.VerticalOffset
C#
public double VerticalOffset {get; set;}
Managed Extensions for C++
public: __property double get_VerticalOffset();
public: __property void set_VerticalOffset(
   double value
);
C++/CLI
public:
property double VerticalOffset {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

For a list of all members of this type, see RadPopup members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HorizontalOffsetProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | IsOpenProperty | Identifies the IsOpen dependency property.
static (Shared in Visual Basic) | LogicalParentProperty | Identifies the LogicalParent dependency property
static (Shared in Visual Basic) | PlacementProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | PlacementRectangleProperty | Identifies the PlacementTarget dependency property.
static (Shared in Visual Basic) | PlacementTargetProperty | Identifies the PlacementTarget attached property.
static (Shared in Visual Basic) | StaysOpenProperty | Identifies the StaysOpen dependency property.
static (Shared in Visual Basic) | VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
Top

See Also

Reference

RadPopup Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HorizontalOffsetProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : HorizontalOffsetProperty Field

Identifies the StaysOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HorizontalOffsetProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.HorizontalOffsetProperty
C#
public static readonly DependencyProperty HorizontalOffsetProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HorizontalOffsetProperty
C++/CLI
public:
static readonly DependencyProperty^ HorizontalOffsetProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : IsOpenProperty Field

Identifies the IsOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.IsOpenProperty
C#
public static readonly DependencyProperty IsOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ IsOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
LogicalParentProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : LogicalParentProperty Field

Identifies the LogicalParent dependency property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LogicalParentProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.LogicalParentProperty
C#
public static readonly DependencyProperty LogicalParentProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LogicalParentProperty
C++/CLI
public:
static readonly DependencyProperty^ LogicalParentProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PlacementProperty Field

Identifies the StaysOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PlacementProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.PlacementProperty
C#
public static readonly DependencyProperty PlacementProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PlacementProperty
C++/CLI
public:
static readonly DependencyProperty^ PlacementProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementRectangleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PlacementRectangleProperty Field

Identifies the PlacementTarget dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PlacementRectangleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.PlacementRectangleProperty
C#
public static readonly DependencyProperty PlacementRectangleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PlacementRectangleProperty
C++/CLI
public:
static readonly DependencyProperty^ PlacementRectangleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementTargetProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PlacementTargetProperty Field

Identifies the PlacementTarget attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PlacementTargetProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.PlacementTargetProperty
C#
public static readonly DependencyProperty PlacementTargetProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PlacementTargetProperty
C++/CLI
public:
static readonly DependencyProperty^ PlacementTargetProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
StaysOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : StaysOpenProperty Field

Identifies the StaysOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StaysOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.StaysOpenProperty
C#
public static readonly DependencyProperty StaysOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* StaysOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ StaysOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
VerticalOffsetProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : VerticalOffsetProperty Field

Identifies the VerticalOffset dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VerticalOffsetProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPopup.VerticalOffsetProperty
C#
public static readonly DependencyProperty VerticalOffsetProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VerticalOffsetProperty
C++/CLI
public:
static readonly DependencyProperty^ VerticalOffsetProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadPopup Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadPopup Class

For a list of all members of this type, see RadPopup members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Closed | Occurs when the RadPopup is Closed
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Opened | Occurs when the RadPopup is Opened
Public Event | PopupMouseEnter | Occurs when the mouse pointer enters the bounds of this element.
Public Event | PopupMouseLeave | Occurs when the mouse pointer leaves the bounds of this element.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPopup Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Closed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : Closed Event

Occurs when the RadPopup is Closed

Syntax

Visual Basic (Declaration)
Public Event Closed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
public event EventHandler Closed()
Managed Extensions for C++
public: __event EventHandler* Closed
C++/CLI
public:
event EventHandler^ Closed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Opened Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : Opened Event

Occurs when the RadPopup is Opened

Syntax

Visual Basic (Declaration)
Public Event Opened() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim handler As EventHandler

AddHandler instance.Opened, handler
C#
public event EventHandler Opened()
Managed Extensions for C++
public: __event EventHandler* Opened
C++/CLI
public:
event EventHandler^ Opened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PopupMouseEnter Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PopupMouseEnter Event

Occurs when the mouse pointer enters the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event PopupMouseEnter() As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim handler As MouseEventHandler

AddHandler instance.PopupMouseEnter, handler
C#
public event MouseEventHandler PopupMouseEnter()
Managed Extensions for C++
public: __event MouseEventHandler* PopupMouseEnter
C++/CLI
public:
event MouseEventHandler^ PopupMouseEnter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PopupMouseLeave Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPopup Class : PopupMouseLeave Event

Occurs when the mouse pointer leaves the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event PopupMouseLeave() As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadPopup
Dim handler As MouseEventHandler

AddHandler instance.PopupMouseLeave, handler
C#
public event MouseEventHandler PopupMouseLeave()
Managed Extensions for C++
public: __event MouseEventHandler* PopupMouseLeave
C++/CLI
public:
event MouseEventHandler^ PopupMouseLeave

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPopup Class
RadPopup Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

The RadProgressBar control can be used to to indicate the progress of an operation. It gives to an end-user visual feedback about an operation he is waiting for to complete.

Syntax

Visual Basic (Declaration)
Public Class RadProgressBar
   Inherits RangeBase
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadProgressBar
C#
public class RadProgressBar : RangeBase, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadProgressBar : public RangeBase, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadProgressBar : public RangeBase, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.RadProgressBar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

The following tables list the members exposed by RadProgressBar.

Public Constructors

 | Name | Description
Public Constructor | RadProgressBar Constructor | Class constructor. Sets the default style key.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets the direction of filling of the control. This is a dependancy property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | Overridden. Raises the System.Windows.Controls.Primitives.RangeBase.ValueChanged routed event.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadProgressBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadProgressBar Class : RadProgressBar Constructor

Class constructor. Sets the default style key.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressBar()
C#
public RadProgressBar()
Managed Extensions for C++
public: RadProgressBar();
C++/CLI
public:
RadProgressBar();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Class
RadProgressBar Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

For a list of all members of this type, see RadProgressBar members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | Overridden. Raises the System.Windows.Controls.Primitives.RangeBase.ValueChanged routed event.
Top

See Also

Reference

RadProgressBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadProgressBar Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressBar

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Class
RadProgressBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnValueChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadProgressBar Class : OnValueChanged Method

oldValue
Old value of the System.Windows.Controls.Primitives.RangeBase.Value property.
newValue
New value of the System.Windows.Controls.Primitives.RangeBase.Value property.
Raises the System.Windows.Controls.Primitives.RangeBase.ValueChanged routed event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValueChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressBar
Dim oldValue As Double
Dim newValue As Double

instance.OnValueChanged(oldValue, newValue)
C#
protected override void OnValueChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: void OnValueChanged(
   double oldValue,
   double newValue
) override
C++/CLI
protected:
void OnValueChanged(
   double oldValue,
   double newValue
) override

Parameters

oldValue
Old value of the System.Windows.Controls.Primitives.RangeBase.Value property.
newValue
New value of the System.Windows.Controls.Primitives.RangeBase.Value property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Class
RadProgressBar Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

For a list of all members of this type, see RadProgressBar members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets the direction of filling of the control. This is a dependancy property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadProgressBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadProgressBar Class : Orientation Property

Gets or sets the direction of filling of the control. This is a dependancy property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadProgressBar
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Class
RadProgressBar Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

For a list of all members of this type, see RadProgressBar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
Top

See Also

Reference

RadProgressBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadProgressBar Class : OrientationProperty Field

Identifies the Orientation property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadProgressBar.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadProgressBar Class
RadProgressBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadSelectionChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadSelectionChangedEventArgs Class

Provides data for the SelectionChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadSelectionChangedEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadSelectionChangedEventArgs
C#
public class RadSelectionChangedEventArgs : RadRoutedEventArgs
Managed Extensions for C++
public __gc class RadSelectionChangedEventArgs : public RadRoutedEventArgs
C++/CLI
public ref class RadSelectionChangedEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadSelectionChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSelectionChangedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadSelectionChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RadSelectionChangedEventArgs Class

The following tables list the members exposed by RadSelectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadSelectionChangedEventArgs Constructor | Initializes a new instance of the System.Windows.Controls.SelectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | AddedItems | Gets the items that were selected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RemovedItems | Gets the items that were unselected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadSelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadSelectionChangedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadSelectionChangedEventArgs Class : RadSelectionChangedEventArgs Constructor

id
The event identifier (ID).
removedItems
The items that were unselected during this event.
addedItems
The items that were selected during this event.
Initializes a new instance of the System.Windows.Controls.SelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As RoutedEvent, _
   ByVal removedItems As IList, _
   ByVal addedItems As IList _
)
Visual Basic (Usage) Copy Code
Dim id As RoutedEvent
Dim removedItems As IList
Dim addedItems As IList

Dim instance As RadSelectionChangedEventArgs(id, removedItems, addedItems)
C#
public RadSelectionChangedEventArgs(
   RoutedEvent id,
   IList removedItems,
   IList addedItems
)
Managed Extensions for C++
public: RadSelectionChangedEventArgs(
   RoutedEvent* id,
   IList* removedItems,
   IList* addedItems
)
C++/CLI
public:
RadSelectionChangedEventArgs(
   RoutedEvent^ id,
   IList^ removedItems,
   IList^ addedItems
)

Parameters

id
The event identifier (ID).
removedItems
The items that were unselected during this event.
addedItems
The items that were selected during this event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSelectionChangedEventArgs Class
RadSelectionChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadSelectionChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadSelectionChangedEventArgs Class

For a list of all members of this type, see RadSelectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | AddedItems | Gets the items that were selected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RemovedItems | Gets the items that were unselected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadSelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSelectionChangedEventArgs Class : AddedItems Property

Gets the items that were selected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AddedItems As IList
Visual Basic (Usage) Copy Code
Dim instance As RadSelectionChangedEventArgs
Dim value As IList

value = instance.AddedItems
C#
public IList AddedItems {get;}
Managed Extensions for C++
public: __property IList* get_AddedItems();
C++/CLI
public:
property IList^ AddedItems {
   IList^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSelectionChangedEventArgs Class
RadSelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemovedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSelectionChangedEventArgs Class : RemovedItems Property

Gets the items that were unselected since the last time the System.Windows.Controls.Primitives.Selector.SelectionChanged event occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemovedItems As IList
Visual Basic (Usage) Copy Code
Dim instance As RadSelectionChangedEventArgs
Dim value As IList

value = instance.RemovedItems
C#
public IList RemovedItems {get;}
Managed Extensions for C++
public: __property IList* get_RemovedItems();
C++/CLI
public:
property IList^ RemovedItems {
   IList^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSelectionChangedEventArgs Class
RadSelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

Slider control lets the user select from a range of values by moving a slider. Slider is used to enable to user to gradually modify a value (range selection). Slider is an easy and natural interface for users, because it provides good visual feedback.

Object Model

Syntax

Visual Basic (Declaration)
<TemplatePartAttribute(Name="RightTickBar", Type=Telerik.Windows.Controls.RadTickBar)>
Public Class RadSlider
   Inherits DoubleRangeBase
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
C#
[TemplatePartAttribute(Name="RightTickBar", Type=Telerik.Windows.Controls.RadTickBar)]
public class RadSlider : DoubleRangeBase, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplatePartAttribute(Name="RightTickBar", Type=Telerik.Windows.Controls.RadTickBar)]
public __gc class RadSlider : public DoubleRangeBase, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplatePartAttribute(Name="RightTickBar", Type=Telerik.Windows.Controls.RadTickBar)]
public ref class RadSlider : public DoubleRangeBase, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.DoubleRangeBase
Telerik.Windows.Controls.RadSlider

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

The following tables list the members exposed by RadSlider.

Public Constructors

 | Name | Description
Public Constructor | RadSlider Constructor | Initializes a new instance of the RadSlider class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HandlesVisibilityProperty | Identifies the HandlesVisibility dependency property.
static (Shared in Visual Basic) | IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsMouseWheelEnabledProperty | Identifies the IsMouseWheelEnabled dependency property.
static (Shared in Visual Basic) | IsMoveToPointEnabledProperty | Identifies the IsMoveToPointEnabled dependency property.
static (Shared in Visual Basic) | IsSelectionRangeEnabledProperty | Identifies the IsSelectionRangeEnabled dependency property.
static (Shared in Visual Basic) | IsSnapToTickEnabledProperty | Identifies the IsSnapToTickEnabled dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
static (Shared in Visual Basic) | TickFrequencyProperty | Identifies the TickFrequency dependency property.
static (Shared in Visual Basic) | TickPlacementProperty | Identifies the TickPlacement dependency property.
static (Shared in Visual Basic) | TicksProperty | Identifies the Ticks dependency property.
static (Shared in Visual Basic) | TickTemplateProperty | Identifies the TickTemplate dependency property.
static (Shared in Visual Basic) | TickTemplateSelectorProperty | Identifies the TickTemplateSelector dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HandlesVisibility | Gets or sets the Visibility property of the Increase and Decrease handles.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDirectionReversed | Gets or sets the direction of increasing value. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value that indicates whether this element is enabled in the user interface (UI).
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseWheelEnabled | Gets or sets the IsMouseWheelEnabled possible Value of the bool object.
Public Property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. This is a dependency property.
Public Property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider can displays a selection range. This is a dependency property.
Public Property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets the orientation of a Slider. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectionEnd | Gets or sets the largest value of a specified selection. (Inherited from DoubleRangeBase)
Public Property | SelectionRange | Gets the difference between SelectionStart and SelectionEnd. (Inherited from DoubleRangeBase)
Public Property | SelectionStart | Gets or sets the smallest value of a specified selection. (Inherited from DoubleRangeBase)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TickFrequency | Gets or sets the interval between tick marks. This is a dependency property.
Public Property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. This is a dependency property.
Public Property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. This is a dependency property.
Public Property | TickTemplate | Gets or sets the TickTemplate that will be used to represent a single tick on the TickBar.
Public Property | TickTemplateSelector | Gets or sets the TickTemplateSelector possible Value of the DataTemplateSelector object.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnIsEnabledChanged | Called when the IsEnabled property changes value.
Protected Method | OnIsSelectionRangeEnabledChanged | Called when the IsSelectionRangeEnabled property changes value.
Protected Method | OnMaximumChanged | Overridden. Called when the Maximum property changes.
Protected Method | OnMinimumChanged | Overridden. Called when the Minimum property changes.
Protected Method | OnOrientationChanged | Called when the Orientation property changes value.
Protected Method | OnSelectionEndChanged | Overridden. Called when SelectionEnd changes value.
Protected Method | OnSelectionRangeChanged | Called when SelectionRange event occurs. (Inherited from DoubleRangeBase)
Protected Method | OnSelectionStartChanged | Overridden. Called when SelectionStart changes value.
Protected Method | OnTickPlacementChanged | Called when the TickPlacement property changes value.
Protected Method | OnValueChanged | Overridden. Called when the Value property changes.
Protected Method | UpdateTrackLayout | This method will take the current min, max, and value to calculate and layout the current control measurements.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionEndChanged | Occurs when SelectionEnd changes value. (Inherited from DoubleRangeBase)
Public Event | SelectionRangeChanged | Occurs when SelectionRange changes value. (Inherited from DoubleRangeBase)
Public Event | SelectionStartChanged | Occurs when SelectionStart changes value. (Inherited from DoubleRangeBase)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadSlider Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadSlider Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : RadSlider Constructor

Initializes a new instance of the RadSlider class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider()
C#
public RadSlider()
Managed Extensions for C++
public: RadSlider();
C++/CLI
public:
RadSlider();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

For a list of all members of this type, see RadSlider members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnIsEnabledChanged | Called when the IsEnabled property changes value.
Protected Method | OnIsSelectionRangeEnabledChanged | Called when the IsSelectionRangeEnabled property changes value.
Protected Method | OnMaximumChanged | Overridden. Called when the Maximum property changes.
Protected Method | OnMinimumChanged | Overridden. Called when the Minimum property changes.
Protected Method | OnOrientationChanged | Called when the Orientation property changes value.
Protected Method | OnSelectionEndChanged | Overridden. Called when SelectionEnd changes value.
Protected Method | OnSelectionRangeChanged | Called when SelectionRange event occurs. (Inherited from DoubleRangeBase)
Protected Method | OnSelectionStartChanged | Overridden. Called when SelectionStart changes value.
Protected Method | OnTickPlacementChanged | Called when the TickPlacement property changes value.
Protected Method | OnValueChanged | Overridden. Called when the Value property changes.
Protected Method | UpdateTrackLayout | This method will take the current min, max, and value to calculate and layout the current control measurements.
Top

See Also

Reference

RadSlider Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnIsEnabledChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnIsEnabledChanged Method

isEnabled
New value of the IsEnabled property.
Called when the IsEnabled property changes value.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsEnabledChanged( _
   ByVal isEnabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim isEnabled As Boolean

instance.OnIsEnabledChanged(isEnabled)
C#
protected virtual void OnIsEnabledChanged(
   bool isEnabled
)
Managed Extensions for C++
protected: virtual void OnIsEnabledChanged(
   bool isEnabled
)
C++/CLI
protected:
virtual void OnIsEnabledChanged(
   bool isEnabled
)

Parameters

isEnabled
New value of the IsEnabled property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnIsSelectionRangeEnabledChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnIsSelectionRangeEnabledChanged Method

Called when the IsSelectionRangeEnabled property changes value.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsSelectionRangeEnabledChanged()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider

instance.OnIsSelectionRangeEnabledChanged()
C#
protected virtual void OnIsSelectionRangeEnabledChanged()
Managed Extensions for C++
protected: virtual void OnIsSelectionRangeEnabledChanged();
C++/CLI
protected:
virtual void OnIsSelectionRangeEnabledChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMaximumChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnMaximumChanged Method

oldMaximum
Old value of the Maximum property.
newMaximum
New value of the Maximum property.
Called when the Maximum property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMaximumChanged( _
   ByVal oldMaximum As Double, _
   ByVal newMaximum As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim oldMaximum As Double
Dim newMaximum As Double

instance.OnMaximumChanged(oldMaximum, newMaximum)
C#
protected override void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
)
Managed Extensions for C++
protected: void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
) override
C++/CLI
protected:
void OnMaximumChanged(
   double oldMaximum,
   double newMaximum
) override

Parameters

oldMaximum
Old value of the Maximum property.
newMaximum
New value of the Maximum property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnMinimumChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnMinimumChanged Method

oldMinimum
Old value of the Minimum property.
newMinimum
New value of the Minimum property.
Called when the Minimum property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMinimumChanged( _
   ByVal oldMinimum As Double, _
   ByVal newMinimum As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim oldMinimum As Double
Dim newMinimum As Double

instance.OnMinimumChanged(oldMinimum, newMinimum)
C#
protected override void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
)
Managed Extensions for C++
protected: void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
) override
C++/CLI
protected:
void OnMinimumChanged(
   double oldMinimum,
   double newMinimum
) override

Parameters

oldMinimum
Old value of the Minimum property.
newMinimum
New value of the Minimum property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnOrientationChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnOrientationChanged Method

Called when the Orientation property changes value.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnOrientationChanged()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider

instance.OnOrientationChanged()
C#
protected virtual void OnOrientationChanged()
Managed Extensions for C++
protected: virtual void OnOrientationChanged();
C++/CLI
protected:
virtual void OnOrientationChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionEndChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnSelectionEndChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionEnd changes value.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelectionEndChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim oldValue As Double
Dim newValue As Double

instance.OnSelectionEndChanged(oldValue, newValue)
C#
protected override void OnSelectionEndChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: void OnSelectionEndChanged(
   double oldValue,
   double newValue
) override
C++/CLI
protected:
void OnSelectionEndChanged(
   double oldValue,
   double newValue
) override

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionStartChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnSelectionStartChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionStart changes value.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelectionStartChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim oldValue As Double
Dim newValue As Double

instance.OnSelectionStartChanged(oldValue, newValue)
C#
protected override void OnSelectionStartChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: void OnSelectionStartChanged(
   double oldValue,
   double newValue
) override
C++/CLI
protected:
void OnSelectionStartChanged(
   double oldValue,
   double newValue
) override

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnTickPlacementChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnTickPlacementChanged Method

Called when the TickPlacement property changes value.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTickPlacementChanged()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider

instance.OnTickPlacementChanged()
C#
protected virtual void OnTickPlacementChanged()
Managed Extensions for C++
protected: virtual void OnTickPlacementChanged();
C++/CLI
protected:
virtual void OnTickPlacementChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnValueChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OnValueChanged Method

oldValue
Old value of the Value property.
newValue
New value of the Value property.
Called when the Value property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValueChanged( _
   ByVal oldValue As Double, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim oldValue As Double
Dim newValue As Double

instance.OnValueChanged(oldValue, newValue)
C#
protected override void OnValueChanged(
   double oldValue,
   double newValue
)
Managed Extensions for C++
protected: void OnValueChanged(
   double oldValue,
   double newValue
) override
C++/CLI
protected:
void OnValueChanged(
   double oldValue,
   double newValue
) override

Parameters

oldValue
Old value of the Value property.
newValue
New value of the Value property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
UpdateTrackLayout Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : UpdateTrackLayout Method

This method will take the current min, max, and value to calculate and layout the current control measurements.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UpdateTrackLayout()
Visual Basic (Usage) Copy Code
Dim instance As RadSlider

instance.UpdateTrackLayout()
C#
protected virtual void UpdateTrackLayout()
Managed Extensions for C++
protected: virtual void UpdateTrackLayout();
C++/CLI
protected:
virtual void UpdateTrackLayout();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

For a list of all members of this type, see RadSlider members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HandlesVisibility | Gets or sets the Visibility property of the Increase and Decrease handles.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDirectionReversed | Gets or sets the direction of increasing value. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value that indicates whether this element is enabled in the user interface (UI).
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseWheelEnabled | Gets or sets the IsMouseWheelEnabled possible Value of the bool object.
Public Property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. This is a dependency property.
Public Property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider can displays a selection range. This is a dependency property.
Public Property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets the orientation of a Slider. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectionEnd | Gets or sets the largest value of a specified selection. (Inherited from DoubleRangeBase)
Public Property | SelectionRange | Gets the difference between SelectionStart and SelectionEnd. (Inherited from DoubleRangeBase)
Public Property | SelectionStart | Gets or sets the smallest value of a specified selection. (Inherited from DoubleRangeBase)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TickFrequency | Gets or sets the interval between tick marks. This is a dependency property.
Public Property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. This is a dependency property.
Public Property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. This is a dependency property.
Public Property | TickTemplate | Gets or sets the TickTemplate that will be used to represent a single tick on the TickBar.
Public Property | TickTemplateSelector | Gets or sets the TickTemplateSelector possible Value of the DataTemplateSelector object.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadSlider Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HandlesVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : HandlesVisibility Property

Gets or sets the Visibility property of the Increase and Decrease handles.

Syntax

Visual Basic (Declaration)
Public Property HandlesVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Visibility

instance.HandlesVisibility = value

value = instance.HandlesVisibility
C#
public Visibility HandlesVisibility {get; set;}
Managed Extensions for C++
public: __property Visibility get_HandlesVisibility();
public: __property void set_HandlesVisibility(
   Visibility value
);
C++/CLI
public:
property Visibility HandlesVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsDirectionReversed Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsDirectionReversed Property

Gets or sets the direction of increasing value. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsDirectionReversed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsDirectionReversed = value

value = instance.IsDirectionReversed
C#
public bool IsDirectionReversed {get; set;}
Managed Extensions for C++
public: __property bool get_IsDirectionReversed();
public: __property void set_IsDirectionReversed(
   bool value
);
C++/CLI
public:
property bool IsDirectionReversed {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsEnabled Property

Gets or sets a value that indicates whether this element is enabled in the user interface (UI).

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsMouseWheelEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsMouseWheelEnabled Property

Gets or sets the IsMouseWheelEnabled possible Value of the bool object.

Syntax

Visual Basic (Declaration)
Public Property IsMouseWheelEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsMouseWheelEnabled = value

value = instance.IsMouseWheelEnabled
C#
public bool IsMouseWheelEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsMouseWheelEnabled();
public: __property void set_IsMouseWheelEnabled(
   bool value
);
C++/CLI
public:
property bool IsMouseWheelEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsMoveToPointEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsMoveToPointEnabled Property

Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsMoveToPointEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsMoveToPointEnabled = value

value = instance.IsMoveToPointEnabled
C#
public bool IsMoveToPointEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsMoveToPointEnabled();
public: __property void set_IsMoveToPointEnabled(
   bool value
);
C++/CLI
public:
property bool IsMoveToPointEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSelectionRangeEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsSelectionRangeEnabled Property

Gets or sets a value that indicates whether the Slider can displays a selection range. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsSelectionRangeEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsSelectionRangeEnabled = value

value = instance.IsSelectionRangeEnabled
C#
public bool IsSelectionRangeEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsSelectionRangeEnabled();
public: __property void set_IsSelectionRangeEnabled(
   bool value
);
C++/CLI
public:
property bool IsSelectionRangeEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSnapToTickEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsSnapToTickEnabled Property

Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsSnapToTickEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Boolean

instance.IsSnapToTickEnabled = value

value = instance.IsSnapToTickEnabled
C#
public bool IsSnapToTickEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsSnapToTickEnabled();
public: __property void set_IsSnapToTickEnabled(
   bool value
);
C++/CLI
public:
property bool IsSnapToTickEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : Orientation Property

Gets or sets the orientation of a Slider. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickFrequency Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickFrequency Property

Gets or sets the interval between tick marks. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property TickFrequency As Double
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As Double

instance.TickFrequency = value

value = instance.TickFrequency
C#
public double TickFrequency {get; set;}
Managed Extensions for C++
public: __property double get_TickFrequency();
public: __property void set_TickFrequency(
   double value
);
C++/CLI
public:
property double TickFrequency {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickPlacement Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickPlacement Property

Gets or sets the position of tick marks with respect to the Track of the Slider. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property TickPlacement As TickPlacement
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As TickPlacement

instance.TickPlacement = value

value = instance.TickPlacement
C#
public TickPlacement TickPlacement {get; set;}
Managed Extensions for C++
public: __property TickPlacement get_TickPlacement();
public: __property void set_TickPlacement(
   TickPlacement value
);
C++/CLI
public:
property TickPlacement TickPlacement {
   TickPlacement get();
   void set (TickPlacement value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Ticks Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : Ticks Property

Gets or sets the positions of the tick marks to display for a Slider. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Ticks As DoubleCollection
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As DoubleCollection

instance.Ticks = value

value = instance.Ticks
C#
public DoubleCollection Ticks {get; set;}
Managed Extensions for C++
public: __property DoubleCollection* get_Ticks();
public: __property void set_Ticks(
   DoubleCollection* value
);
C++/CLI
public:
property DoubleCollection^ Ticks {
   DoubleCollection^ get();
   void set (DoubleCollection^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickTemplate Property

Gets or sets the TickTemplate that will be used to represent a single tick on the TickBar.

Syntax

Visual Basic (Declaration)
Public Property TickTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As DataTemplate

instance.TickTemplate = value

value = instance.TickTemplate
C#
public DataTemplate TickTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_TickTemplate();
public: __property void set_TickTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ TickTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickTemplateSelector Property

Gets or sets the TickTemplateSelector possible Value of the DataTemplateSelector object.

Syntax

Visual Basic (Declaration)
Public Property TickTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadSlider
Dim value As DataTemplateSelector

instance.TickTemplateSelector = value

value = instance.TickTemplateSelector
C#
public DataTemplateSelector TickTemplateSelector {get; set;}
Managed Extensions for C++
public: __property DataTemplateSelector* get_TickTemplateSelector();
public: __property void set_TickTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
public:
property DataTemplateSelector^ TickTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

For a list of all members of this type, see RadSlider members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | HandlesVisibilityProperty | Identifies the HandlesVisibility dependency property.
static (Shared in Visual Basic) | IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsMouseWheelEnabledProperty | Identifies the IsMouseWheelEnabled dependency property.
static (Shared in Visual Basic) | IsMoveToPointEnabledProperty | Identifies the IsMoveToPointEnabled dependency property.
static (Shared in Visual Basic) | IsSelectionRangeEnabledProperty | Identifies the IsSelectionRangeEnabled dependency property.
static (Shared in Visual Basic) | IsSnapToTickEnabledProperty | Identifies the IsSnapToTickEnabled dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
static (Shared in Visual Basic) | TickFrequencyProperty | Identifies the TickFrequency dependency property.
static (Shared in Visual Basic) | TickPlacementProperty | Identifies the TickPlacement dependency property.
static (Shared in Visual Basic) | TicksProperty | Identifies the Ticks dependency property.
static (Shared in Visual Basic) | TickTemplateProperty | Identifies the TickTemplate dependency property.
static (Shared in Visual Basic) | TickTemplateSelectorProperty | Identifies the TickTemplateSelector dependency property.
Top

See Also

Reference

RadSlider Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HandlesVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : HandlesVisibilityProperty Field

Identifies the HandlesVisibility dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HandlesVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.HandlesVisibilityProperty
C#
public static readonly DependencyProperty HandlesVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HandlesVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ HandlesVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsDirectionReversedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsDirectionReversedProperty Field

Identifies the IsDirectionReversed dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDirectionReversedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsDirectionReversedProperty
C#
public static readonly DependencyProperty IsDirectionReversedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDirectionReversedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDirectionReversedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsMouseWheelEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsMouseWheelEnabledProperty Field

Identifies the IsMouseWheelEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMouseWheelEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsMouseWheelEnabledProperty
C#
public static readonly DependencyProperty IsMouseWheelEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMouseWheelEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMouseWheelEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsMoveToPointEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsMoveToPointEnabledProperty Field

Identifies the IsMoveToPointEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMoveToPointEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsMoveToPointEnabledProperty
C#
public static readonly DependencyProperty IsMoveToPointEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMoveToPointEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMoveToPointEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSelectionRangeEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsSelectionRangeEnabledProperty Field

Identifies the IsSelectionRangeEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectionRangeEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsSelectionRangeEnabledProperty
C#
public static readonly DependencyProperty IsSelectionRangeEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectionRangeEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectionRangeEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSnapToTickEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : IsSnapToTickEnabledProperty Field

Identifies the IsSnapToTickEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSnapToTickEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.IsSnapToTickEnabledProperty
C#
public static readonly DependencyProperty IsSnapToTickEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSnapToTickEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSnapToTickEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : OrientationProperty Field

Identifies the Orientation dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickFrequencyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickFrequencyProperty Field

Identifies the TickFrequency dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickFrequencyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.TickFrequencyProperty
C#
public static readonly DependencyProperty TickFrequencyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickFrequencyProperty
C++/CLI
public:
static readonly DependencyProperty^ TickFrequencyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickPlacementProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickPlacementProperty Field

Identifies the TickPlacement dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickPlacementProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.TickPlacementProperty
C#
public static readonly DependencyProperty TickPlacementProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickPlacementProperty
C++/CLI
public:
static readonly DependencyProperty^ TickPlacementProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TicksProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TicksProperty Field

Identifies the Ticks dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TicksProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.TicksProperty
C#
public static readonly DependencyProperty TicksProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TicksProperty
C++/CLI
public:
static readonly DependencyProperty^ TicksProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickTemplateProperty Field

Identifies the TickTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.TickTemplateProperty
C#
public static readonly DependencyProperty TickTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ TickTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadSlider Class : TickTemplateSelectorProperty Field

Identifies the TickTemplateSelector dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadSlider.TickTemplateSelectorProperty
C#
public static readonly DependencyProperty TickTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ TickTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSlider Class
RadSlider Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

Represents a control that draws a set of tick marks for a RadSlider control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadTickBar
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
C#
public class RadTickBar : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadTickBar : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadTickBar : public Control, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadTickBar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

The following tables list the members exposed by RadTickBar.

Public Constructors

 | Name | Description
Public Constructor | RadTickBar Constructor | Initializes a new instance of the RadTickBar class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
static (Shared in Visual Basic) | MaximumProperty | Identifies the Maximum dependency property.
static (Shared in Visual Basic) | MinimumProperty | Identifies the Minimum dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
static (Shared in Visual Basic) | PlacementProperty | Identifies the Placement dependency property.
static (Shared in Visual Basic) | TickFrequencyProperty | Identifies the TickFrequency dependency property.
static (Shared in Visual Basic) | TicksProperty | Identifies the Ticks dependency property.
static (Shared in Visual Basic) | TickTemplateProperty | Identifies the TickTemplate dependency property.
static (Shared in Visual Basic) | TickTemplateSelectorProperty | Identifies the TickTemplateSelector dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDirectionReversed | Binds to the IsDirectionReversed property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | Binds to the Maximum property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | Binds to the Minimum property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Binds to the Orientation property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Placement | Gets or sets where tick marks appear relative to a track of a RadSlider control.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TickFrequency | Binds to the TickFrequency property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Ticks | Binds to the Ticks property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | TickTemplate | Binds to the TickTemplate property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | TickTemplateSelector | Binds to the TickTemplateSelector property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTickBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : RadTickBar Constructor

Initializes a new instance of the RadTickBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar()
C#
public RadTickBar()
Managed Extensions for C++
public: RadTickBar();
C++/CLI
public:
RadTickBar();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

For a list of all members of this type, see RadTickBar members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

See Also

Reference

RadTickBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

For a list of all members of this type, see RadTickBar members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDirectionReversed | Binds to the IsDirectionReversed property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | Binds to the Maximum property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | Binds to the Minimum property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Binds to the Orientation property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Placement | Gets or sets where tick marks appear relative to a track of a RadSlider control.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TickFrequency | Binds to the TickFrequency property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Ticks | Binds to the Ticks property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | TickTemplate | Binds to the TickTemplate property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | TickTemplateSelector | Binds to the TickTemplateSelector property of the RadSlider control that owns the current instance of RadTickBar.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadTickBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsDirectionReversed Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : IsDirectionReversed Property

Binds to the IsDirectionReversed property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property IsDirectionReversed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As Boolean

instance.IsDirectionReversed = value

value = instance.IsDirectionReversed
C#
public bool IsDirectionReversed {get; set;}
Managed Extensions for C++
public: __property bool get_IsDirectionReversed();
public: __property void set_IsDirectionReversed(
   bool value
);
C++/CLI
public:
property bool IsDirectionReversed {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Maximum Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : Maximum Property

Binds to the Maximum property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property Maximum As Double
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As Double

instance.Maximum = value

value = instance.Maximum
C#
public double Maximum {get; set;}
Managed Extensions for C++
public: __property double get_Maximum();
public: __property void set_Maximum(
   double value
);
C++/CLI
public:
property double Maximum {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Minimum Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : Minimum Property

Binds to the Minimum property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property Minimum As Double
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As Double

instance.Minimum = value

value = instance.Minimum
C#
public double Minimum {get; set;}
Managed Extensions for C++
public: __property double get_Minimum();
public: __property void set_Minimum(
   double value
);
C++/CLI
public:
property double Minimum {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : Orientation Property

Binds to the Orientation property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Placement Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : Placement Property

Gets or sets where tick marks appear relative to a track of a RadSlider control.

Syntax

Visual Basic (Declaration)
Public Property Placement As TickBarPlacement
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As TickBarPlacement

instance.Placement = value

value = instance.Placement
C#
public TickBarPlacement Placement {get; set;}
Managed Extensions for C++
public: __property TickBarPlacement get_Placement();
public: __property void set_Placement(
   TickBarPlacement value
);
C++/CLI
public:
property TickBarPlacement Placement {
   TickBarPlacement get();
   void set (TickBarPlacement value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickFrequency Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickFrequency Property

Binds to the TickFrequency property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property TickFrequency As Double
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As Double

instance.TickFrequency = value

value = instance.TickFrequency
C#
public double TickFrequency {get; set;}
Managed Extensions for C++
public: __property double get_TickFrequency();
public: __property void set_TickFrequency(
   double value
);
C++/CLI
public:
property double TickFrequency {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Ticks Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : Ticks Property

Binds to the Ticks property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property Ticks As DoubleCollection
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As DoubleCollection

instance.Ticks = value

value = instance.Ticks
C#
public DoubleCollection Ticks {get; set;}
Managed Extensions for C++
public: __property DoubleCollection* get_Ticks();
public: __property void set_Ticks(
   DoubleCollection* value
);
C++/CLI
public:
property DoubleCollection^ Ticks {
   DoubleCollection^ get();
   void set (DoubleCollection^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickTemplate Property

Binds to the TickTemplate property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property TickTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As DataTemplate

instance.TickTemplate = value

value = instance.TickTemplate
C#
public DataTemplate TickTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_TickTemplate();
public: __property void set_TickTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ TickTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickTemplateSelector Property

Binds to the TickTemplateSelector property of the RadSlider control that owns the current instance of RadTickBar.

Syntax

Visual Basic (Declaration)
Public Property TickTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadTickBar
Dim value As DataTemplateSelector

instance.TickTemplateSelector = value

value = instance.TickTemplateSelector
C#
public DataTemplateSelector TickTemplateSelector {get; set;}
Managed Extensions for C++
public: __property DataTemplateSelector* get_TickTemplateSelector();
public: __property void set_TickTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
public:
property DataTemplateSelector^ TickTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

For a list of all members of this type, see RadTickBar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
static (Shared in Visual Basic) | MaximumProperty | Identifies the Maximum dependency property.
static (Shared in Visual Basic) | MinimumProperty | Identifies the Minimum dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
static (Shared in Visual Basic) | PlacementProperty | Identifies the Placement dependency property.
static (Shared in Visual Basic) | TickFrequencyProperty | Identifies the TickFrequency dependency property.
static (Shared in Visual Basic) | TicksProperty | Identifies the Ticks dependency property.
static (Shared in Visual Basic) | TickTemplateProperty | Identifies the TickTemplate dependency property.
static (Shared in Visual Basic) | TickTemplateSelectorProperty | Identifies the TickTemplateSelector dependency property.
Top

See Also

Reference

RadTickBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsDirectionReversedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : IsDirectionReversedProperty Field

Identifies the IsDirectionReversed dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDirectionReversedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.IsDirectionReversedProperty
C#
public static readonly DependencyProperty IsDirectionReversedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDirectionReversedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDirectionReversedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MaximumProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : MaximumProperty Field

Identifies the Maximum dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaximumProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.MaximumProperty
C#
public static readonly DependencyProperty MaximumProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MaximumProperty
C++/CLI
public:
static readonly DependencyProperty^ MaximumProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MinimumProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : MinimumProperty Field

Identifies the Minimum dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinimumProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.MinimumProperty
C#
public static readonly DependencyProperty MinimumProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MinimumProperty
C++/CLI
public:
static readonly DependencyProperty^ MinimumProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : OrientationProperty Field

Identifies the Orientation dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : PlacementProperty Field

Identifies the Placement dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PlacementProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.PlacementProperty
C#
public static readonly DependencyProperty PlacementProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PlacementProperty
C++/CLI
public:
static readonly DependencyProperty^ PlacementProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickFrequencyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickFrequencyProperty Field

Identifies the TickFrequency dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickFrequencyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.TickFrequencyProperty
C#
public static readonly DependencyProperty TickFrequencyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickFrequencyProperty
C++/CLI
public:
static readonly DependencyProperty^ TickFrequencyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TicksProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TicksProperty Field

Identifies the Ticks dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TicksProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.TicksProperty
C#
public static readonly DependencyProperty TicksProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TicksProperty
C++/CLI
public:
static readonly DependencyProperty^ TicksProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickTemplateProperty Field

Identifies the TickTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.TickTemplateProperty
C#
public static readonly DependencyProperty TickTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ TickTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTickBar Class : TickTemplateSelectorProperty Field

Identifies the TickTemplateSelector dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TickTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTickBar.TickTemplateSelectorProperty
C#
public static readonly DependencyProperty TickTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TickTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ TickTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTickBar Class
RadTickBar Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

Positions child elements in sequential position from left to right, breaking content to the next line at the edge of the containing box. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the value of the Orientation property.

Syntax

Visual Basic (Declaration)
Public Class RadWrapPanel
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
C#
public class RadWrapPanel : Panel, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadWrapPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadWrapPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.RadWrapPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

The following tables list the members exposed by RadWrapPanel.

Public Constructors

 | Name | Description
Public Constructor | RadWrapPanel Constructor | Initializes a new instance of the RadWrapPanel class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AnimationDurationProperty | Identifies the AnimationDuration dependency property.
static (Shared in Visual Basic) | IsAnimatedProperty | Identifies the IsAnimated dependency property
static (Shared in Visual Basic) | ItemHeightProperty | Identifies the ItemHeight dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Identifies the ItemWidth dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AnimationDuration | Gets or sets the duration of the animation.
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsAnimated | Gets or sets a value indicating whether this RadWrapPanel is animated.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | ItemHeight | Gets or sets a value that specifies the height of all items that are contained within a WrapPanel. This is a dependency property.
Public Property | ItemWidth | Gets or sets a value that specifies the width of all items that are contained within a WrapPanel. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.
Protected Method | MeasureOverride | Overridden. Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadWrapPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : RadWrapPanel Constructor

Initializes a new instance of the RadWrapPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel()
C#
public RadWrapPanel()
Managed Extensions for C++
public: RadWrapPanel();
C++/CLI
public:
RadWrapPanel();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

For a list of all members of this type, see RadWrapPanel members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.
Protected Method | MeasureOverride | Overridden. Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.
Top

See Also

Reference

RadWrapPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
Provides the behavior for the "Arrange" pass of Silverlight layout. Classes can override this method to define their own arrange pass behavior.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
Provides the behavior for the "measure" pass of Silverlight layout. Classes can override this method to define their own measure pass behavior.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

For a list of all members of this type, see RadWrapPanel members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AnimationDuration | Gets or sets the duration of the animation.
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsAnimated | Gets or sets a value indicating whether this RadWrapPanel is animated.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | ItemHeight | Gets or sets a value that specifies the height of all items that are contained within a WrapPanel. This is a dependency property.
Public Property | ItemWidth | Gets or sets a value that specifies the width of all items that are contained within a WrapPanel. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadWrapPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AnimationDuration Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : AnimationDuration Property

Gets or sets the duration of the animation.

Syntax

Visual Basic (Declaration)
Public Property AnimationDuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim value As Integer

instance.AnimationDuration = value

value = instance.AnimationDuration
C#
public int AnimationDuration {get; set;}
Managed Extensions for C++
public: __property int get_AnimationDuration();
public: __property void set_AnimationDuration(
   int value
);
C++/CLI
public:
property int AnimationDuration {
   int get();
   void set (int value);
}

Return Value

The duration of the animation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsAnimated Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : IsAnimated Property

Gets or sets a value indicating whether this RadWrapPanel is animated.

Syntax

Visual Basic (Declaration)
Public Property IsAnimated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim value As Boolean

instance.IsAnimated = value

value = instance.IsAnimated
C#
public bool IsAnimated {get; set;}
Managed Extensions for C++
public: __property bool get_IsAnimated();
public: __property void set_IsAnimated(
   bool value
);
C++/CLI
public:
property bool IsAnimated {
   bool get();
   void set (bool value);
}

Return Value

true if this instance is animated; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemHeight Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : ItemHeight Property

Gets or sets a value that specifies the height of all items that are contained within a WrapPanel. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property ItemHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim value As Double

instance.ItemHeight = value

value = instance.ItemHeight
C#
public double ItemHeight {get; set;}
Managed Extensions for C++
public: __property double get_ItemHeight();
public: __property void set_ItemHeight(
   double value
);
C++/CLI
public:
property double ItemHeight {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : ItemWidth Property

Gets or sets a value that specifies the width of all items that are contained within a WrapPanel. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property ItemWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim value As Double

instance.ItemWidth = value

value = instance.ItemWidth
C#
public double ItemWidth {get; set;}
Managed Extensions for C++
public: __property double get_ItemWidth();
public: __property void set_ItemWidth(
   double value
);
C++/CLI
public:
property double ItemWidth {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : Orientation Property

Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadWrapPanel
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

For a list of all members of this type, see RadWrapPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AnimationDurationProperty | Identifies the AnimationDuration dependency property.
static (Shared in Visual Basic) | IsAnimatedProperty | Identifies the IsAnimated dependency property
static (Shared in Visual Basic) | ItemHeightProperty | Identifies the ItemHeight dependency property.
static (Shared in Visual Basic) | ItemWidthProperty | Identifies the ItemWidth dependency property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
Top

See Also

Reference

RadWrapPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AnimationDurationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : AnimationDurationProperty Field

Identifies the AnimationDuration dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AnimationDurationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWrapPanel.AnimationDurationProperty
C#
public static readonly DependencyProperty AnimationDurationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AnimationDurationProperty
C++/CLI
public:
static readonly DependencyProperty^ AnimationDurationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsAnimatedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : IsAnimatedProperty Field

Identifies the IsAnimated dependency property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsAnimatedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWrapPanel.IsAnimatedProperty
C#
public static readonly DependencyProperty IsAnimatedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsAnimatedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsAnimatedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemHeightProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : ItemHeightProperty Field

Identifies the ItemHeight dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemHeightProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWrapPanel.ItemHeightProperty
C#
public static readonly DependencyProperty ItemHeightProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemHeightProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemHeightProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ItemWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : ItemWidthProperty Field

Identifies the ItemWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWrapPanel.ItemWidthProperty
C#
public static readonly DependencyProperty ItemWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWrapPanel Class : OrientationProperty Field

Identifies the Orientation dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWrapPanel.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWrapPanel Class
RadWrapPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RangeSelectionChangedEventArgs Class

Provides data for the SelectionStartChanged and SelectionEndChanged events.

Syntax

Visual Basic (Declaration)
Public Class RangeSelectionChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RangeSelectionChangedEventArgs
C#
public class RangeSelectionChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class RangeSelectionChangedEventArgs : public EventArgs
C++/CLI
public ref class RangeSelectionChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.RangeSelectionChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RangeSelectionChangedEventArgs Class

The following tables list the members exposed by RangeSelectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RangeSelectionChangedEventArgs Constructor | Overloaded. Initializes a new instance of the RangeSelectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | SelectionEnd | Gets the selection end.
Public Property | SelectionStart | Gets the selection start.
Top

See Also

Reference

RangeSelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RangeSelectionChangedEventArgs Class : RangeSelectionChangedEventArgs Constructor

Initializes a new instance of the RangeSelectionChangedEventArgs class.

Overload List

Overload | Description
RangeSelectionChangedEventArgs Constructor() | Initializes a new instance of the RangeSelectionChangedEventArgs class.
RangeSelectionChangedEventArgs Constructor(Double,Double) | Initializes a new instance of the RangeSelectionChangedEventArgs class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Class
RangeSelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Constructor()
See Also
[image]
Telerik.Windows.Controls Namespace > RangeSelectionChangedEventArgs Class > RangeSelectionChangedEventArgs Constructor : RangeSelectionChangedEventArgs Constructor()

Initializes a new instance of the RangeSelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RangeSelectionChangedEventArgs()
C#
public RangeSelectionChangedEventArgs()
Managed Extensions for C++
public: RangeSelectionChangedEventArgs();
C++/CLI
public:
RangeSelectionChangedEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Class
RangeSelectionChangedEventArgs Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Constructor(Double,Double)
See Also
[image]
Telerik.Windows.Controls Namespace > RangeSelectionChangedEventArgs Class > RangeSelectionChangedEventArgs Constructor : RangeSelectionChangedEventArgs Constructor(Double,Double)

selectionStart
The selection start.
selectionEnd
The selection end.
Initializes a new instance of the RangeSelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectionStart As Double, _
   ByVal selectionEnd As Double _
)
Visual Basic (Usage) Copy Code
Dim selectionStart As Double
Dim selectionEnd As Double

Dim instance As RangeSelectionChangedEventArgs(selectionStart, selectionEnd)
C#
public RangeSelectionChangedEventArgs(
   double selectionStart,
   double selectionEnd
)
Managed Extensions for C++
public: RangeSelectionChangedEventArgs(
   double selectionStart,
   double selectionEnd
)
C++/CLI
public:
RangeSelectionChangedEventArgs(
   double selectionStart,
   double selectionEnd
)

Parameters

selectionStart
The selection start.
selectionEnd
The selection end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Class
RangeSelectionChangedEventArgs Members
Overload List


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RangeSelectionChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RangeSelectionChangedEventArgs Class

For a list of all members of this type, see RangeSelectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectionEnd | Gets the selection end.
Public Property | SelectionStart | Gets the selection start.
Top

See Also

Reference

RangeSelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > RangeSelectionChangedEventArgs Class : SelectionEnd Property

Gets the selection end.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectionEnd As Double
Visual Basic (Usage) Copy Code
Dim instance As RangeSelectionChangedEventArgs
Dim value As Double

value = instance.SelectionEnd
C#
public double SelectionEnd {get;}
Managed Extensions for C++
public: __property double get_SelectionEnd();
C++/CLI
public:
property double SelectionEnd {
   double get();
}

Return Value

The selection end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Class
RangeSelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RangeSelectionChangedEventArgs Class : SelectionStart Property

Gets the selection start.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectionStart As Double
Visual Basic (Usage) Copy Code
Dim instance As RangeSelectionChangedEventArgs
Dim value As Double

value = instance.SelectionStart
C#
public double SelectionStart {get;}
Managed Extensions for C++
public: __property double get_SelectionStart();
C++/CLI
public:
property double SelectionStart {
   double get();
}

Return Value

The selection start.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RangeSelectionChangedEventArgs Class
RangeSelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ResourceDictionary Class

Provides a source for loading ResourceDictionary objects and merging them with another ResourceDictionary.

Syntax

Visual Basic (Declaration)
Public Class ResourceDictionary
Visual Basic (Usage) Copy Code
Dim instance As ResourceDictionary
C#
public class ResourceDictionary
Managed Extensions for C++
public __gc class ResourceDictionary
C++/CLI
public ref class ResourceDictionary

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.ResourceDictionary

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Class Members
See Also Fields Properties Methods
[image]
Telerik.Windows.Controls Namespace : ResourceDictionary Class

The following tables list the members exposed by ResourceDictionary.

Public Constructors

 | Name | Description
Public Constructor | ResourceDictionary Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MergedDictionariesProperty | Identifies the MergedDictionaries attached property.
Top

Public Properties

 | Name | Description
Public Property | Keys | Comma separated string, containing all resource keys that need to be merged into the parent ResourceDictionary.
Public Property | Source | Uri from which to load the ResourceDictionary resources
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetMergedDictionaries | Gets the value of the MergedDictionaries attached property from a given DependencyObject.
static (Shared in Visual Basic) | SetMergedDictionaries | Sets the value of the MergedDictionaries attached property to a given DependencyObject.
Top

See Also

Reference

ResourceDictionary Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : ResourceDictionary Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ResourceDictionary()
C#
public ResourceDictionary()
Managed Extensions for C++
public: ResourceDictionary();
C++/CLI
public:
ResourceDictionary();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ResourceDictionary Class

For a list of all members of this type, see ResourceDictionary members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetMergedDictionaries | Gets the value of the MergedDictionaries attached property from a given DependencyObject.
static (Shared in Visual Basic) | SetMergedDictionaries | Sets the value of the MergedDictionaries attached property to a given DependencyObject.
Top

See Also

Reference

ResourceDictionary Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetMergedDictionaries Method
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : GetMergedDictionaries Method

obj
The DependencyObject from which to read the property value.
Gets the value of the MergedDictionaries attached property from a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Function GetMergedDictionaries( _
   ByVal obj As DependencyObject _
) As ResourceDictionary
Visual Basic (Usage) Copy Code
Dim obj As DependencyObject
Dim value As ResourceDictionary

value = ResourceDictionary.GetMergedDictionaries(obj)
C#
public static ResourceDictionary GetMergedDictionaries(
   DependencyObject obj
)
Managed Extensions for C++
public: static ResourceDictionary* GetMergedDictionaries(
   DependencyObject* obj
)
C++/CLI
public:
static ResourceDictionary^ GetMergedDictionaries(
   DependencyObject^ obj
)

Parameters

obj
The DependencyObject from which to read the property value.

Return Value

The value of the MergedDictionaries attached property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetMergedDictionaries Method
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : SetMergedDictionaries Method

obj
The DependencyObject on which to set the property value.
value
The property value to set.
Sets the value of the MergedDictionaries attached property to a given DependencyObject.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetMergedDictionaries( _
   ByVal obj As DependencyObject, _
   ByVal value As ResourceDictionary _
)
Visual Basic (Usage) Copy Code
Dim obj As DependencyObject
Dim value As ResourceDictionary

ResourceDictionary.SetMergedDictionaries(obj, value)
C#
public static void SetMergedDictionaries(
   DependencyObject obj,
   ResourceDictionary value
)
Managed Extensions for C++
public: static void SetMergedDictionaries(
   DependencyObject* obj,
   ResourceDictionary* value
)
C++/CLI
public:
static void SetMergedDictionaries(
   DependencyObject^ obj,
   ResourceDictionary^ value
)

Parameters

obj
The DependencyObject on which to set the property value.
value
The property value to set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : ResourceDictionary Class

For a list of all members of this type, see ResourceDictionary members.

Public Properties

 | Name | Description
Public Property | Keys | Comma separated string, containing all resource keys that need to be merged into the parent ResourceDictionary.
Public Property | Source | Uri from which to load the ResourceDictionary resources
Top

See Also

Reference

ResourceDictionary Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Keys Property
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : Keys Property

Comma separated string, containing all resource keys that need to be merged into the parent ResourceDictionary.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property Keys As String
Visual Basic (Usage) Copy Code
Dim instance As ResourceDictionary
Dim value As String

instance.Keys = value

value = instance.Keys
C#
[CompilerGeneratedAttribute()]
public string Keys {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property string* get_Keys();
public: __property void set_Keys(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property String^ Keys {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Source Property
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : Source Property

Uri from which to load the ResourceDictionary resources

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")>
Public Property Source As Uri
Visual Basic (Usage) Copy Code
Dim instance As ResourceDictionary
Dim value As Uri

instance.Source = value

value = instance.Source
C#
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public Uri Source {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public: __property Uri* get_Source();
public: __property void set_Source(
   Uri* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public:
property Uri^ Source {
   Uri^ get();
   void set (Uri^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
ResourceDictionary Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : ResourceDictionary Class

For a list of all members of this type, see ResourceDictionary members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MergedDictionariesProperty | Identifies the MergedDictionaries attached property.
Top

See Also

Reference

ResourceDictionary Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MergedDictionariesProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > ResourceDictionary Class : MergedDictionariesProperty Field

Identifies the MergedDictionaries attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MergedDictionariesProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = ResourceDictionary.MergedDictionariesProperty
C#
public static readonly DependencyProperty MergedDictionariesProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MergedDictionariesProperty
C++/CLI
public:
static readonly DependencyProperty^ MergedDictionariesProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceDictionary Class
ResourceDictionary Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : SelectionChangedEventArgs Class

Provides data for the Telerik.Windows.Controls.Selector.SelectionChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SelectionChangedEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As SelectionChangedEventArgs
C#
public class SelectionChangedEventArgs : RadRoutedEventArgs
Managed Extensions for C++
public __gc class SelectionChangedEventArgs : public RadRoutedEventArgs
C++/CLI
public ref class SelectionChangedEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.SelectionChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectionChangedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : SelectionChangedEventArgs Class

The following tables list the members exposed by SelectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SelectionChangedEventArgs Constructor | Initializes a new instance of the Telerik.Windows.Controls.SelectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | AddedItems | Gets a list that contains the items that were selected.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RemovedItems | Gets a list that contains the items that were unselected.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

SelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > SelectionChangedEventArgs Class : SelectionChangedEventArgs Constructor

routedEvent
The routed event
source
An alternate source that will be reported when the event is handled. This pre-populates the Source property.
removedItems
The items that were unselected.
addedItems
The items that were selected.
Initializes a new instance of the Telerik.Windows.Controls.SelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As Object, _
   ByVal removedItems As IList, _
   ByVal addedItems As IList _
)
Visual Basic (Usage) Copy Code
Dim routedEvent As RoutedEvent
Dim source As Object
Dim removedItems As IList
Dim addedItems As IList

Dim instance As SelectionChangedEventArgs(routedEvent, source, removedItems, addedItems)
C#
public SelectionChangedEventArgs(
   RoutedEvent routedEvent,
   object source,
   IList removedItems,
   IList addedItems
)
Managed Extensions for C++
public: SelectionChangedEventArgs(
   RoutedEvent* routedEvent,
   Object* source,
   IList* removedItems,
   IList* addedItems
)
C++/CLI
public:
SelectionChangedEventArgs(
   RoutedEvent^ routedEvent,
   Object^ source,
   IList^ removedItems,
   IList^ addedItems
)

Parameters

routedEvent
The routed event
source
An alternate source that will be reported when the event is handled. This pre-populates the Source property.
removedItems
The items that were unselected.
addedItems
The items that were selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : SelectionChangedEventArgs Class

For a list of all members of this type, see SelectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | AddedItems | Gets a list that contains the items that were selected.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RemovedItems | Gets a list that contains the items that were unselected.
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

SelectionChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > SelectionChangedEventArgs Class : AddedItems Property

Gets a list that contains the items that were selected.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property AddedItems As IList
Visual Basic (Usage) Copy Code
Dim instance As SelectionChangedEventArgs
Dim value As IList

value = instance.AddedItems
C#
[CompilerGeneratedAttribute()]
public IList AddedItems {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property IList* get_AddedItems();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property IList^ AddedItems {
   IList^ get();
}

Return Value

The items that were selected in this event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemovedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > SelectionChangedEventArgs Class : RemovedItems Property

Gets a list that contains the items that were unselected.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property RemovedItems As IList
Visual Basic (Usage) Copy Code
Dim instance As SelectionChangedEventArgs
Dim value As IList

value = instance.RemovedItems
C#
[CompilerGeneratedAttribute()]
public IList RemovedItems {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property IList* get_RemovedItems();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property IList^ RemovedItems {
   IList^ get();
}

Return Value

The items that were unselected in this event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Selector Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : Selector Class

Represents a control that allows a user to select items from among its child elements

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class Selector
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As Selector
C#
public abstract class Selector : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc abstract class Selector : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class Selector abstract : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.Selector
Telerik.Windows.Controls.RadComboBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
Selector Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : Selector Class

The following tables list the members exposed by Selector.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected attached property.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex dependency property.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem dependency property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
Public Property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddSelectedHandler | Adds a handler for the Selected attached event.
static (Shared in Visual Basic) | AddUnselectedHandler | Adds a handler for the Unselected attached event.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | GetIsSelected | Gets the value of the IsSelected attached property that indicates whether an item is selected.
static (Shared in Visual Basic) | RemoveSelectedHandler | Removes a handler for the Selected attached event.
static (Shared in Visual Basic) | RemoveUnselectedHandler | Removes a handler for the Unselected attached event.
static (Shared in Visual Basic) | SetIsSelected | Sets a property value that indicates whether an item in a Selector is selected.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectionChanged | Called when the selection changes.
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when the selection of a Selector changes.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

Selector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
Selector Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : Selector Class

For a list of all members of this type, see Selector members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddSelectedHandler | Adds a handler for the Selected attached event.
static (Shared in Visual Basic) | AddUnselectedHandler | Adds a handler for the Unselected attached event.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | GetIsSelected | Gets the value of the IsSelected attached property that indicates whether an item is selected.
static (Shared in Visual Basic) | RemoveSelectedHandler | Removes a handler for the Selected attached event.
static (Shared in Visual Basic) | RemoveUnselectedHandler | Removes a handler for the Unselected attached event.
static (Shared in Visual Basic) | SetIsSelected | Sets a property value that indicates whether an item in a Selector is selected.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectionChanged | Called when the selection changes.
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

See Also

Reference

Selector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddSelectedHandler Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : AddSelectedHandler Method

element
Element that listens to this event.
handler
Event handler to add.
Adds a handler for the Selected attached event.

Syntax

Visual Basic (Declaration)
Public Shared Sub AddSelectedHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As RoutedEventHandler

Selector.AddSelectedHandler(element, handler)
C#
public static void AddSelectedHandler(
   DependencyObject element,
   RoutedEventHandler handler
)
Managed Extensions for C++
public: static void AddSelectedHandler(
   DependencyObject* element,
   RoutedEventHandler* handler
)
C++/CLI
public:
static void AddSelectedHandler(
   DependencyObject^ element,
   RoutedEventHandler^ handler
)

Parameters

element
Element that listens to this event.
handler
Event handler to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddUnselectedHandler Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : AddUnselectedHandler Method

element
Element that listens to this event.
handler
Event handler to add.
Adds a handler for the Unselected attached event.

Syntax

Visual Basic (Declaration)
Public Shared Sub AddUnselectedHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As RoutedEventHandler

Selector.AddUnselectedHandler(element, handler)
C#
public static void AddUnselectedHandler(
   DependencyObject element,
   RoutedEventHandler handler
)
Managed Extensions for C++
public: static void AddUnselectedHandler(
   DependencyObject* element,
   RoutedEventHandler* handler
)
C++/CLI
public:
static void AddUnselectedHandler(
   DependencyObject^ element,
   RoutedEventHandler^ handler
)

Parameters

element
Element that listens to this event.
handler
Event handler to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetIsSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : GetIsSelected Method

element
Object to query concerning the IsSelected property.
Gets the value of the IsSelected attached property that indicates whether an item is selected.

Syntax

Visual Basic (Declaration)
Public Shared Function GetIsSelected( _
   ByVal element As DependencyObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As Boolean

value = Selector.GetIsSelected(element)
C#
public static bool GetIsSelected(
   DependencyObject element
)
Managed Extensions for C++
public: static bool GetIsSelected(
   DependencyObject* element
)
C++/CLI
public:
static bool GetIsSelected(
   DependencyObject^ element
)

Parameters

element
Object to query concerning the IsSelected property.

Return Value

Boolean value, true if the IsSelected property is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : OnItemsChanged Method

e
Information about the change.
Invoked when the Items property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Selector
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Information about the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
OnSelectionChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : OnSelectionChanged Method

e
The event data.
Called when the selection changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Selector
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
C#
protected virtual void OnSelectionChanged(
   SelectionChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectionChanged(
   SelectionChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelectionChanged(
   SelectionChangedEventArgs^ e
)

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemoveSelectedHandler Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : RemoveSelectedHandler Method

element
Element that listens to this event.
handler
Event handler to remove.
Removes a handler for the Selected attached event.

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveSelectedHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As RoutedEventHandler

Selector.RemoveSelectedHandler(element, handler)
C#
public static void RemoveSelectedHandler(
   DependencyObject element,
   RoutedEventHandler handler
)
Managed Extensions for C++
public: static void RemoveSelectedHandler(
   DependencyObject* element,
   RoutedEventHandler* handler
)
C++/CLI
public:
static void RemoveSelectedHandler(
   DependencyObject^ element,
   RoutedEventHandler^ handler
)

Parameters

element
Element that listens to this event.
handler
Event handler to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemoveUnselectedHandler Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : RemoveUnselectedHandler Method

element
Element that listens to this event.
handler
Event handler to remove.
Removes a handler for the Unselected attached event.

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveUnselectedHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As RoutedEventHandler

Selector.RemoveUnselectedHandler(element, handler)
C#
public static void RemoveUnselectedHandler(
   DependencyObject element,
   RoutedEventHandler handler
)
Managed Extensions for C++
public: static void RemoveUnselectedHandler(
   DependencyObject* element,
   RoutedEventHandler* handler
)
C++/CLI
public:
static void RemoveUnselectedHandler(
   DependencyObject^ element,
   RoutedEventHandler^ handler
)

Parameters

element
Element that listens to this event.
handler
Event handler to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetIsSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SetIsSelected Method

element
Object on which to set the property.
isSelected
Value to set.
Sets a property value that indicates whether an item in a Selector is selected.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetIsSelected( _
   ByVal element As DependencyObject, _
   ByVal isSelected As Boolean _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim isSelected As Boolean

Selector.SetIsSelected(element, isSelected)
C#
public static void SetIsSelected(
   DependencyObject element,
   bool isSelected
)
Managed Extensions for C++
public: static void SetIsSelected(
   DependencyObject* element,
   bool isSelected
)
C++/CLI
public:
static void SetIsSelected(
   DependencyObject^ element,
   bool isSelected
)

Parameters

element
Object on which to set the property.
isSelected
Value to set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
Selector Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : Selector Class

For a list of all members of this type, see Selector members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
Public Property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

Selector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedIndex Property
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectedIndex Property

Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As Selector
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[SRCategoryAttribute("Appearance")]
public int SelectedIndex {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectedItem Property

Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As Selector
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[SRCategoryAttribute("Appearance")]
public object SelectedItem {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
Selector Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : Selector Class

For a list of all members of this type, see Selector members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected attached property.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex dependency property.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem dependency property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

See Also

Reference

Selector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
IsSelectedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : IsSelectedProperty Field

Identifies the IsSelected attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = Selector.IsSelectedProperty
C#
public static readonly DependencyProperty IsSelectedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectedEvent Field

Identifies the Selected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Selector.SelectedEvent
C#
public static readonly RoutedEvent SelectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SelectedEvent
C++/CLI
public:
static readonly RoutedEvent^ SelectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedIndexProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectedIndexProperty Field

Identifies the SelectedIndex dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = Selector.SelectedIndexProperty
C#
public static readonly DependencyProperty SelectedIndexProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedIndexProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedIndexProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectedItemProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectedItemProperty Field

Identifies the SelectedItem dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = Selector.SelectedItemProperty
C#
public static readonly DependencyProperty SelectedItemProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedItemProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedItemProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectionChangedEvent Field

Identifies the SelectionChanged routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Selector.SelectionChangedEvent
C#
public static readonly RoutedEvent SelectionChangedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SelectionChangedEvent
C++/CLI
public:
static readonly RoutedEvent^ SelectionChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
UnselectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : UnselectedEvent Field

Identifies the Unselected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UnselectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Selector.UnselectedEvent
C#
public static readonly RoutedEvent UnselectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* UnselectedEvent
C++/CLI
public:
static readonly RoutedEvent^ UnselectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
Selector Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : Selector Class

For a list of all members of this type, see Selector members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when the selection of a Selector changes.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

Selector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > Selector Class : SelectionChanged Event

Occurs when the selection of a Selector changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event SelectionChanged() As SelectionChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Selector
Dim handler As SelectionChangedEventHandler

AddHandler instance.SelectionChanged, handler
C#
[SRCategoryAttribute("Behavior")]
public event SelectionChangedEventHandler SelectionChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event SelectionChangedEventHandler* SelectionChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event SelectionChangedEventHandler^ SelectionChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Selector Class
Selector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
StyleSelector Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : StyleSelector Class

Chooses the style for each item of the ItemsControl.

Syntax

Visual Basic (Declaration)
Public Class StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
C#
public class StyleSelector
Managed Extensions for C++
public __gc class StyleSelector
C++/CLI
public ref class StyleSelector

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.StyleSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StyleSelector Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
StyleSelector Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : StyleSelector Class

The following tables list the members exposed by StyleSelector.

Public Constructors

 | Name | Description
Public Constructor | StyleSelector Constructor |
Top

Public Methods

 | Name | Description
Public Method | SelectStyle | When overriden this method is used for determining the Style of items.
Top

See Also

Reference

StyleSelector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
StyleSelector Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > StyleSelector Class : StyleSelector Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector()
C#
public StyleSelector()
Managed Extensions for C++
public: StyleSelector();
C++/CLI
public:
StyleSelector();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StyleSelector Class
StyleSelector Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
StyleSelector Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : StyleSelector Class

For a list of all members of this type, see StyleSelector members.

Public Methods

 | Name | Description
Public Method | SelectStyle | When overriden this method is used for determining the Style of items.
Top

See Also

Reference

StyleSelector Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectStyle Method
See Also
[image]
Telerik.Windows.Controls Namespace > StyleSelector Class : SelectStyle Method

item
The item for whoose container is wanted.
container
The container for which a Style is selected.
When overriden this method is used for determining the Style of items.

Syntax

Visual Basic (Declaration)
Public Overridable Function SelectStyle( _
   ByVal item As Object, _
   ByVal container As DependencyObject _
) As Style
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
Dim item As Object
Dim container As DependencyObject
Dim value As Style

value = instance.SelectStyle(item, container)
C#
public virtual Style SelectStyle(
   object item,
   DependencyObject container
)
Managed Extensions for C++
public: virtual Style* SelectStyle(
   Object* item,
   DependencyObject* container
)
C++/CLI
public:
virtual Style^ SelectStyle(
   Object^ item,
   DependencyObject^ container
)

Parameters

item
The item for whoose container is wanted.
container
The container for which a Style is selected.

Return Value

The Style for the given container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StyleSelector Class
StyleSelector Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TextSearch Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : TextSearch Class

Enables a user to quickly access items in a set by typing prefixes of strings.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextSearch
Visual Basic (Usage) Copy Code
Dim instance As TextSearch
C#
public sealed class TextSearch
Managed Extensions for C++
public __gc __sealed class TextSearch
C++/CLI
public ref class TextSearch sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.TextSearch

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
TextSearch Class Members
See Also Fields Methods
[image]
Telerik.Windows.Controls Namespace : TextSearch Class

The following tables list the members exposed by TextSearch.

Public Constructors

 | Name | Description
Public Constructor | TextSearch Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | TextPathProperty | Identifies the TextPath attached property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text attached property.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetText | Returns the string to that identifies the specified item.
static (Shared in Visual Basic) | GetTextPath | Returns the name of the property that identifies an item in the specified element's collection.
static (Shared in Visual Basic) | SetText | Writes the Text attached property to the specified element.
static (Shared in Visual Basic) | SetTextPath | Writes the TextPath attached property to the specified element.
Top

See Also

Reference

TextSearch Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TextSearch Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : TextSearch Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextSearch()
C#
public TextSearch()
Managed Extensions for C++
public: TextSearch();
C++/CLI
public:
TextSearch();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
TextSearch Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : TextSearch Class

For a list of all members of this type, see TextSearch members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetText | Returns the string to that identifies the specified item.
static (Shared in Visual Basic) | GetTextPath | Returns the name of the property that identifies an item in the specified element's collection.
static (Shared in Visual Basic) | SetText | Writes the Text attached property to the specified element.
static (Shared in Visual Basic) | SetTextPath | Writes the TextPath attached property to the specified element.
Top

See Also

Reference

TextSearch Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetText Method
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : GetText Method

element
The element from which the property value is read.
Returns the string to that identifies the specified item.

Syntax

Visual Basic (Declaration)
Public Shared Function GetText( _
   ByVal element As DependencyObject _
) As String
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As String

value = TextSearch.GetText(element)
C#
public static string GetText(
   DependencyObject element
)
Managed Extensions for C++
public: static string* GetText(
   DependencyObject* element
)
C++/CLI
public:
static String^ GetText(
   DependencyObject^ element
)

Parameters

element
The element from which the property value is read.

Return Value

The string that identifies the specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetTextPath Method
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : GetTextPath Method

element
The element from which the property value is read.
Returns the name of the property that identifies an item in the specified element's collection.

Syntax

Visual Basic (Declaration)
Public Shared Function GetTextPath( _
   ByVal element As DependencyObject _
) As String
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As String

value = TextSearch.GetTextPath(element)
C#
public static string GetTextPath(
   DependencyObject element
)
Managed Extensions for C++
public: static string* GetTextPath(
   DependencyObject* element
)
C++/CLI
public:
static String^ GetTextPath(
   DependencyObject^ element
)

Parameters

element
The element from which the property value is read.

Return Value

The name of the property that identifies the item to the user.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetText Method
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : SetText Method

element
The element to which the property value is written.
value
The string that identifies the item.
Writes the Text attached property to the specified element.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetText( _
   ByVal element As DependencyObject, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As String

TextSearch.SetText(element, value)
C#
public static void SetText(
   DependencyObject element,
   string value
)
Managed Extensions for C++
public: static void SetText(
   DependencyObject* element,
   string* value
)
C++/CLI
public:
static void SetText(
   DependencyObject^ element,
   String^ value
)

Parameters

element
The element to which the property value is written.
value
The string that identifies the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SetTextPath Method
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : SetTextPath Method

element
The element to which the property value is written.
value
The name of the property that identifies an item.
Writes the TextPath attached property to the specified element.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetTextPath( _
   ByVal element As DependencyObject, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim value As String

TextSearch.SetTextPath(element, value)
C#
public static void SetTextPath(
   DependencyObject element,
   string value
)
Managed Extensions for C++
public: static void SetTextPath(
   DependencyObject* element,
   string* value
)
C++/CLI
public:
static void SetTextPath(
   DependencyObject^ element,
   String^ value
)

Parameters

element
The element to which the property value is written.
value
The name of the property that identifies an item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
TextSearch Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : TextSearch Class

For a list of all members of this type, see TextSearch members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | TextPathProperty | Identifies the TextPath attached property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text attached property.
Top

See Also

Reference

TextSearch Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TextPathProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : TextPathProperty Field

Identifies the TextPath attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TextPathProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = TextSearch.TextPathProperty
C#
public static readonly DependencyProperty TextPathProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TextPathProperty
C++/CLI
public:
static readonly DependencyProperty^ TextPathProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TextProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > TextSearch Class : TextProperty Field

Identifies the Text attached property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = TextSearch.TextProperty
C#
public static readonly DependencyProperty TextProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TextProperty
C++/CLI
public:
static readonly DependencyProperty^ TextProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSearch Class
TextSearch Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Theme Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : Theme Class

Contains the location of

Syntax

Visual Basic (Declaration)
Public Class Theme
Visual Basic (Usage) Copy Code
Dim instance As Theme
C#
public class Theme
Managed Extensions for C++
public __gc class Theme
C++/CLI
public ref class Theme

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Theme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
Theme Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls Namespace : Theme Class

The following tables list the members exposed by Theme.

Public Constructors

 | Name | Description
Public Constructor | Theme Constructor | Overloaded. Initializes a new instance of the Theme class.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ApplicationTheme | Gets or sets the application theme.
Public Property | Source | Uri from which to load the Theme resources.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResource | Returns a resource with the specified key.
Top

See Also

Reference

Theme Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Theme Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class : Theme Constructor

Initializes a new instance of the Theme class.

Overload List

Overload | Description
Theme Constructor() | Initializes a new instance of the Theme class.
Theme Constructor(Uri) | Initializes a new instance of the Theme class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Theme Constructor()
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class > Theme Constructor : Theme Constructor()

Initializes a new instance of the Theme class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Theme()
C#
public Theme()
Managed Extensions for C++
public: Theme();
C++/CLI
public:
Theme();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Theme Constructor(Uri)
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class > Theme Constructor : Theme Constructor(Uri)

source
The Uri from which to load the Theme resources.
Initializes a new instance of the Theme class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As Uri _
)
Visual Basic (Usage) Copy Code
Dim source As Uri

Dim instance As Theme(source)
C#
public Theme(
   Uri source
)
Managed Extensions for C++
public: Theme(
   Uri* source
)
C++/CLI
public:
Theme(
   Uri^ source
)

Parameters

source
The Uri from which to load the Theme resources.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
Theme Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : Theme Class

For a list of all members of this type, see Theme members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResource | Returns a resource with the specified key.
Top

See Also

Reference

Theme Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetResource Method
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class : GetResource Method

key
The key of the resource to be returned.
element
Optional DependencyObject from which to retrieve the value of the Theme attached property.
Returns a resource with the specified key.

Syntax

Visual Basic (Declaration)
Public Shared Function GetResource( _
   ByVal key As String, _
   ByVal element As DependencyObject _
) As Object
Visual Basic (Usage) Copy Code
Dim key As String
Dim element As DependencyObject
Dim value As Object

value = Theme.GetResource(key, element)
C#
public static object GetResource(
   string key,
   DependencyObject element
)
Managed Extensions for C++
public: static Object* GetResource(
   string* key,
   DependencyObject* element
)
C++/CLI
public:
static Object^ GetResource(
   String^ key,
   DependencyObject^ element
)

Parameters

key
The key of the resource to be returned.
element
Optional DependencyObject from which to retrieve the value of the Theme attached property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
Theme Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : Theme Class

For a list of all members of this type, see Theme members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ApplicationTheme | Gets or sets the application theme.
Public Property | Source | Uri from which to load the Theme resources.
Top

See Also

Reference

Theme Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ApplicationTheme Property
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class : ApplicationTheme Property

Gets or sets the application theme.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Shared Property ApplicationTheme As String
Visual Basic (Usage) Copy Code
Dim value As String

Theme.ApplicationTheme = value

value = Theme.ApplicationTheme
C#
[CompilerGeneratedAttribute()]
public static string ApplicationTheme {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property static string* get_ApplicationTheme();
public: __property static void set_ApplicationTheme(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
static property String^ ApplicationTheme {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Source Property
See Also
[image]
Telerik.Windows.Controls Namespace > Theme Class : Source Property

Uri from which to load the Theme resources.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")>
Public Property Source As Uri
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As Uri

instance.Source = value

value = instance.Source
C#
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public Uri Source {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public: __property Uri* get_Source();
public: __property void set_Source(
   Uri* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public:
property Uri^ Source {
   Uri^ get();
   void set (Uri^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Dock Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : Dock Enumeration

Specifies the Dock position of a child element that is inside a DockPanel.

Syntax

Visual Basic (Declaration)
Public Enum Dock
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Dock
C#
public enum Dock : Enum
Managed Extensions for C++
__value public enum Dock : public Enum
C++/CLI
public enum class Dock : public Enum

Members

Member | Description
Left | A child element that is positioned on the left side of the DockPanel.
Top | A child element that is positioned at the top of the DockPanel.
Right | A child element that is positioned at the top of the DockPanel.
Bottom | A child element that is positioned at the bottom of the DockPanel.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.Dock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
FilteringMode Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : FilteringMode Enumeration

Specifies the FilteringMode of RadComboBox.

Syntax

Visual Basic (Declaration)
Public Enum FilteringMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FilteringMode
C#
public enum FilteringMode : Enum
Managed Extensions for C++
__value public enum FilteringMode : public Enum
C++/CLI
public enum class FilteringMode : public Enum

Members

Member | Description
None | Filtering disabled.
Contains | Matches items, containing the search text
StartsWith | Matches items, which text starts with the search text

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.FilteringMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PlacementMode Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : PlacementMode Enumeration

Describes the placement of where a Popup control appears on the screen.

Syntax

Visual Basic (Declaration)
Public Enum PlacementMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PlacementMode
C#
public enum PlacementMode : Enum
Managed Extensions for C++
__value public enum PlacementMode : public Enum
C++/CLI
public enum class PlacementMode : public Enum

Members

Member | Description
Bottom | A position of the Popup control where the control aligns its upper edge with the lower edge of the PlacementTarget and aligns its left edge with the left edge of the PlacementTarget. If the lower screen-edge obscures the Popup, the control repositions itself so that its lower edge aligns with the upper edge of the PlacementTarget. If the upper screen-edge obscures the Popup, the control then repositions itself so that its upper edge aligns with the upper screen-edge.
Center | A position of the Popup control where it is centered over the PlacementTarget. If a screen edge obscures the Popup, the control repositions itself to align with the screen edge.
Right | A position of the Popup control that aligns its left edge with the right edge of the PlacementTarget and aligns its upper edge with the upper edge of the PlacementTarget. If the right screen-edge obscures the Popup, the control repositions itself so that its left edge aligns with the left edge of the PlacementTarget. If the left screen-edge obscures the Popup, the control repositions itself so that its left edge aligns with the left screen-edge. If the upper or lower screen-edge obscures the Popup, the control then repositions itself to align with the obscuring screen edge.
Left | A Popup control that aligns its right edge with the left edge of the PlacementTarget and aligns its upper edge with the upper edge of the PlacementTarget. If the left screen-edge obscures the Popup, the Popup repositions itself so that its left edge aligns with the right edge of the PlacementTarget. If the right screen-edge obscures the Popup, the right edge of the control aligns with the right screen-edge. If the upper or lower screen-edge obscures the Popup, the control repositions itself to align with the obscuring screen edge.
Top | A position of the Popup control that aligns its lower edge with the upper edge of the PlacementTarget and aligns its left edge with the left edge of the PlacementTarget. If the upper screen-edge obscures the Popup, the control repositions itself so that its upper edge aligns with the lower edge of the PlacementTarget. If the lower screen-edge obscures the Popup, the lower edge of the control aligns with the lower screen-edge. If the left or right screen-edge obscures the Popup, it then repositions itself to align with the obscuring screen.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.PlacementMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PopupAnimation Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : PopupAnimation Enumeration

Defines the values, specifying the animation type which will be played when a RadPopup is opened or closed.

Syntax

Visual Basic (Declaration)
Public Enum PopupAnimation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PopupAnimation
C#
public enum PopupAnimation : Enum
Managed Extensions for C++
__value public enum PopupAnimation : public Enum
C++/CLI
public enum class PopupAnimation : public Enum

Members

Member | Description
None | Disables the RadPopup animation.
Fade | Fades in or out the RadPopup when it is opened or closed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.PopupAnimation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickBarPlacement Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : TickBarPlacement Enumeration

Specifies the placement of a TickBar with respect to the track of a RadSlider control.

Syntax

Visual Basic (Declaration)
Public Enum TickBarPlacement
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TickBarPlacement
C#
public enum TickBarPlacement : Enum
Managed Extensions for C++
__value public enum TickBarPlacement : public Enum
C++/CLI
public enum class TickBarPlacement : public Enum

Members

Member | Description
Left | The tick bar is positioned to the left of the track of the slider.
Top | The tick bar is positioned above the track of the slider.
Right | The tick bar is positioned to the right of the track of the slider.
Bottom | The tick bar is positioned below the track of the slider.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.TickBarPlacement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
TickPlacement Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : TickPlacement Enumeration

Specifies the position of tick marks in a RadSlider control with respect to the track in the control.

Syntax

Visual Basic (Declaration)
Public Enum TickPlacement
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TickPlacement
C#
public enum TickPlacement : Enum
Managed Extensions for C++
__value public enum TickPlacement : public Enum
C++/CLI
public enum class TickPlacement : public Enum

Members

Member | Description
None | No tick marks appear.
TopLeft | Tick marks appear above the track for a horizontal slider, or to the left of the track for a vertical slider.
BottomRight | Tick marks appear below the track for a horizontal slider, or to the right of the track for a vertical slider.
Both | Tick marks appear above and below the track bar for a horizontal slider, or to the left and right of the track for a vertical slider.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.TickPlacement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
SelectionChangedEventHandler Delegate
See Also
[image]
Telerik.Windows.Controls Namespace : SelectionChangedEventHandler Delegate

sender
e
Represents the method that will handle the SelectionChanged routed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SelectionChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New SelectionChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void SelectionChangedEventHandler(
   object sender,
   SelectionChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void SelectionChangedEventHandler(
   Object* sender,
   SelectionChangedEventArgs* e
)
C++/CLI
public delegate void SelectionChangedEventHandler(
   Object^ sender,
   SelectionChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%ItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Controls.Primitives Namespace (Telerik.Windows.Controls)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | RadUniformGrid | Uniform grid panel with orientation.

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class
See Also Members
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

Uniform grid panel with orientation.

Syntax

Visual Basic (Declaration)
Public Class RadUniformGrid
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
C#
public class RadUniformGrid : Panel, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadUniformGrid : public Panel, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadUniformGrid : public Panel, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.Primitives.RadUniformGrid
Telerik.Windows.Controls.Calendar.CalendarPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Members
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

The following tables list the members exposed by RadUniformGrid.

Public Constructors

 | Name | Description
Public Constructor | RadUniformGrid Constructor | Initializes a new instance of the RadUniformGrid class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ChildrenFlowProperty | Identifies the ChildrenFlow dependency property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns dependency property.
static (Shared in Visual Basic) | FirstColumnProperty | Identifies the FirstColumn dependency property.
static (Shared in Visual Basic) | HideFirstColumnProperty | Identifies the HideFirstColumn dependency property.
static (Shared in Visual Basic) | HideFirstRowProperty | Identifies the HideFirstRow dependency property.
static (Shared in Visual Basic) | PreserveSpaceForCollapsedChildrenProperty | Identifies the PreserveSpaceForCollapsedChildren dependency property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | ChildrenFlow | Gets or sets a value that specifies the dimension in which child content is arranged.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns that are in the grid.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideFirstColumn | Gets or sets value that hide or show the first column. This is a Dependency property.
Public Property | HideFirstRow | Gets or sets value that hide or show the first row. This is a Dependency property.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PreserveSpaceForCollapsedChildren | Gets or sets a value specifying whether a collapsed child's size should be preserved.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows that are in the grid.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Defines the layout of the RadUniformGrid by distributing space evenly among all of the child elements.
Protected Method | MeasureOverride | Overridden. Computes the desired size of the RadUniformGrid by measuring all of the child elements.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadUniformGrid Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Constructor
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : RadUniformGrid Constructor

Initializes a new instance of the RadUniformGrid class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid()
C#
public RadUniformGrid()
Managed Extensions for C++
public: RadUniformGrid();
C++/CLI
public:
RadUniformGrid();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class Methods
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

For a list of all members of this type, see RadUniformGrid members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. Defines the layout of the RadUniformGrid by distributing space evenly among all of the child elements.
Protected Method | MeasureOverride | Overridden. Computes the desired size of the RadUniformGrid by measuring all of the child elements.
Top

See Also

Reference

RadUniformGrid Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : ArrangeOverride Method

finalSize
The Size of the area for the grid to use.
Defines the layout of the RadUniformGrid by distributing space evenly among all of the child elements.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The Size of the area for the grid to use.

Return Value

The actual Size of the grid that is rendered to display the child elements that are visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : MeasureOverride Method

availableSize
The Size of the available area for the grid.
Computes the desired size of the RadUniformGrid by measuring all of the child elements.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The Size of the available area for the grid.

Return Value

The desired Size based on the child content of the grid and the constraint parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class Properties
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

For a list of all members of this type, see RadUniformGrid members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | ChildrenFlow | Gets or sets a value that specifies the dimension in which child content is arranged.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns that are in the grid.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideFirstColumn | Gets or sets value that hide or show the first column. This is a Dependency property.
Public Property | HideFirstRow | Gets or sets value that hide or show the first row. This is a Dependency property.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PreserveSpaceForCollapsedChildren | Gets or sets a value specifying whether a collapsed child's size should be preserved.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows that are in the grid.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadUniformGrid Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ChildrenFlow Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : ChildrenFlow Property

Gets or sets a value that specifies the dimension in which child content is arranged.

Syntax

Visual Basic (Declaration)
Public Property ChildrenFlow As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Orientation

instance.ChildrenFlow = value

value = instance.ChildrenFlow
C#
public Orientation ChildrenFlow {get; set;}
Managed Extensions for C++
public: __property Orientation get_ChildrenFlow();
public: __property void set_ChildrenFlow(
   Orientation value
);
C++/CLI
public:
property Orientation ChildrenFlow {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Columns Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : Columns Property

Gets or sets the number of columns that are in the grid.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
FirstColumn Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : FirstColumn Property

Gets or sets the number of leading blank cells in the first row of the grid.

Syntax

Visual Basic (Declaration)
Public Property FirstColumn As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Integer

instance.FirstColumn = value

value = instance.FirstColumn
C#
public int FirstColumn {get; set;}
Managed Extensions for C++
public: __property int get_FirstColumn();
public: __property void set_FirstColumn(
   int value
);
C++/CLI
public:
property int FirstColumn {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HideFirstColumn Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : HideFirstColumn Property

Gets or sets value that hide or show the first column. This is a Dependency property.

Syntax

Visual Basic (Declaration)
Public Property HideFirstColumn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Boolean

instance.HideFirstColumn = value

value = instance.HideFirstColumn
C#
public bool HideFirstColumn {get; set;}
Managed Extensions for C++
public: __property bool get_HideFirstColumn();
public: __property void set_HideFirstColumn(
   bool value
);
C++/CLI
public:
property bool HideFirstColumn {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HideFirstRow Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : HideFirstRow Property

Gets or sets value that hide or show the first row. This is a Dependency property.

Syntax

Visual Basic (Declaration)
Public Property HideFirstRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Boolean

instance.HideFirstRow = value

value = instance.HideFirstRow
C#
public bool HideFirstRow {get; set;}
Managed Extensions for C++
public: __property bool get_HideFirstRow();
public: __property void set_HideFirstRow(
   bool value
);
C++/CLI
public:
property bool HideFirstRow {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PreserveSpaceForCollapsedChildren Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : PreserveSpaceForCollapsedChildren Property

Gets or sets a value specifying whether a collapsed child's size should be preserved.

Syntax

Visual Basic (Declaration)
Public Property PreserveSpaceForCollapsedChildren As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Boolean

instance.PreserveSpaceForCollapsedChildren = value

value = instance.PreserveSpaceForCollapsedChildren
C#
public bool PreserveSpaceForCollapsedChildren {get; set;}
Managed Extensions for C++
public: __property bool get_PreserveSpaceForCollapsedChildren();
public: __property void set_PreserveSpaceForCollapsedChildren(
   bool value
);
C++/CLI
public:
property bool PreserveSpaceForCollapsedChildren {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Rows Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : Rows Property

Gets or sets the number of rows that are in the grid.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUniformGrid
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class Fields
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

For a list of all members of this type, see RadUniformGrid members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ChildrenFlowProperty | Identifies the ChildrenFlow dependency property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns dependency property.
static (Shared in Visual Basic) | FirstColumnProperty | Identifies the FirstColumn dependency property.
static (Shared in Visual Basic) | HideFirstColumnProperty | Identifies the HideFirstColumn dependency property.
static (Shared in Visual Basic) | HideFirstRowProperty | Identifies the HideFirstRow dependency property.
static (Shared in Visual Basic) | PreserveSpaceForCollapsedChildrenProperty | Identifies the PreserveSpaceForCollapsedChildren dependency property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows dependency property.
Top

See Also

Reference

RadUniformGrid Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ChildrenFlowProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : ChildrenFlowProperty Field

Identifies the ChildrenFlow dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ChildrenFlowProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.ChildrenFlowProperty
C#
public static readonly DependencyProperty ChildrenFlowProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ChildrenFlowProperty
C++/CLI
public:
static readonly DependencyProperty^ ChildrenFlowProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ColumnsProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : ColumnsProperty Field

Identifies the Columns dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.ColumnsProperty
C#
public static readonly DependencyProperty ColumnsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ColumnsProperty
C++/CLI
public:
static readonly DependencyProperty^ ColumnsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
FirstColumnProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : FirstColumnProperty Field

Identifies the FirstColumn dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FirstColumnProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.FirstColumnProperty
C#
public static readonly DependencyProperty FirstColumnProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FirstColumnProperty
C++/CLI
public:
static readonly DependencyProperty^ FirstColumnProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HideFirstColumnProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : HideFirstColumnProperty Field

Identifies the HideFirstColumn dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HideFirstColumnProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.HideFirstColumnProperty
C#
public static readonly DependencyProperty HideFirstColumnProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HideFirstColumnProperty
C++/CLI
public:
static readonly DependencyProperty^ HideFirstColumnProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
HideFirstRowProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : HideFirstRowProperty Field

Identifies the HideFirstRow dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HideFirstRowProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.HideFirstRowProperty
C#
public static readonly DependencyProperty HideFirstRowProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HideFirstRowProperty
C++/CLI
public:
static readonly DependencyProperty^ HideFirstRowProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
PreserveSpaceForCollapsedChildrenProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : PreserveSpaceForCollapsedChildrenProperty Field

Identifies the PreserveSpaceForCollapsedChildren dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreserveSpaceForCollapsedChildrenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.PreserveSpaceForCollapsedChildrenProperty
C#
public static readonly DependencyProperty PreserveSpaceForCollapsedChildrenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PreserveSpaceForCollapsedChildrenProperty
C++/CLI
public:
static readonly DependencyProperty^ PreserveSpaceForCollapsedChildrenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RowsProperty Field
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > RadUniformGrid Class : RowsProperty Field

Identifies the Rows dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RowsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUniformGrid.RowsProperty
C#
public static readonly DependencyProperty RowsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RowsProperty
C++/CLI
public:
static readonly DependencyProperty^ RowsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUniformGrid Class
RadUniformGrid Members


%%ItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Input Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | Mouse | Represents the mouse device. Contains several extensions to the Silverlight mouse capabilities.
Class | MouseButtonEventArgs | Provides data for various events that report changes to the mouse wheel delta value of a mouse device
Class | MouseWheelEventArgs | Provides data for various events that report changes to the mouse wheel delta value of a mouse device

Enumerations

 | Enumeration | Description
Enumeration | MouseButton | Defines values that specify the buttons on a mouse device.
Enumeration | MouseButtonState | Specifies the possible states of a mouse button.

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Mouse Class
See Also Members
[image]
Telerik.Windows.Input Namespace : Mouse Class

Represents the mouse device. Contains several extensions to the Silverlight mouse capabilities.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Mouse
Visual Basic (Usage) Copy Code
Dim instance As Mouse
C#
public static class Mouse
Managed Extensions for C++
public __gc abstract __sealed class Mouse
C++/CLI
public ref class Mouse abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Input.Mouse

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Members
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
Mouse Class Members
See Also Fields Methods
[image]
Telerik.Windows.Input Namespace : Mouse Class

The following tables list the members exposed by Mouse.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MouseDownEvent | Occurs when the right mouse button is pressed
static (Shared in Visual Basic) | MouseUpEvent | Occurs when the right mouse button is released
static (Shared in Visual Basic) | MouseWheelEvent | Occurs when the mouse wheel is rotated
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddMouseButtonDownHandler | Adds a handler for the MouseDown attached event
static (Shared in Visual Basic) | AddMouseButtonUpHandler | Adds a handler for the MouseUp attached event
static (Shared in Visual Basic) | AddMouseWheelHandler | Adds a handler for the MouseWheel attached event
static (Shared in Visual Basic) | RemoveMouseButtonDownHandler | Removes a handler for the MouseDown attached event
static (Shared in Visual Basic) | RemoveMouseButtonUpHandler | Removes a handler for the MouseUp attached event
static (Shared in Visual Basic) | RemoveMouseWheelHandler | Removes a handler for the MouseWheel attached event
Top

See Also

Reference

Mouse Class
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
Mouse Class Methods
See Also
[image]
Telerik.Windows.Input Namespace : Mouse Class

For a list of all members of this type, see Mouse members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddMouseButtonDownHandler | Adds a handler for the MouseDown attached event
static (Shared in Visual Basic) | AddMouseButtonUpHandler | Adds a handler for the MouseUp attached event
static (Shared in Visual Basic) | AddMouseWheelHandler | Adds a handler for the MouseWheel attached event
static (Shared in Visual Basic) | RemoveMouseButtonDownHandler | Removes a handler for the MouseDown attached event
static (Shared in Visual Basic) | RemoveMouseButtonUpHandler | Removes a handler for the MouseUp attached event
static (Shared in Visual Basic) | RemoveMouseWheelHandler | Removes a handler for the MouseWheel attached event
Top

See Also

Reference

Mouse Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddMouseButtonDownHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : AddMouseButtonDownHandler Method

element
The UIElement that listens to this event
handler
The event handler
Adds a handler for the MouseDown attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub AddMouseButtonDownHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseButtonEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseButtonEventArgs)

Mouse.AddMouseButtonDownHandler(element, handler)
C#
public static void AddMouseButtonDownHandler(
   DependencyObject element,
   EventHandler<MouseButtonEventArgs> handler
)
Managed Extensions for C++
public: static void AddMouseButtonDownHandler(
   DependencyObject* element,
   EventHandler<MouseButtonEventArgs*>* handler
)
C++/CLI
public:
static void AddMouseButtonDownHandler(
   DependencyObject^ element,
   EventHandler<MouseButtonEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddMouseButtonUpHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : AddMouseButtonUpHandler Method

element
The UIElement that listens to this event
handler
The event handler
Adds a handler for the MouseUp attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub AddMouseButtonUpHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseButtonEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseButtonEventArgs)

Mouse.AddMouseButtonUpHandler(element, handler)
C#
public static void AddMouseButtonUpHandler(
   DependencyObject element,
   EventHandler<MouseButtonEventArgs> handler
)
Managed Extensions for C++
public: static void AddMouseButtonUpHandler(
   DependencyObject* element,
   EventHandler<MouseButtonEventArgs*>* handler
)
C++/CLI
public:
static void AddMouseButtonUpHandler(
   DependencyObject^ element,
   EventHandler<MouseButtonEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
AddMouseWheelHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : AddMouseWheelHandler Method

element
The UIElement that listens to this event
handler
The event handler
Adds a handler for the MouseWheel attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub AddMouseWheelHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseWheelEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseWheelEventArgs)

Mouse.AddMouseWheelHandler(element, handler)
C#
public static void AddMouseWheelHandler(
   DependencyObject element,
   EventHandler<MouseWheelEventArgs> handler
)
Managed Extensions for C++
public: static void AddMouseWheelHandler(
   DependencyObject* element,
   EventHandler<MouseWheelEventArgs*>* handler
)
C++/CLI
public:
static void AddMouseWheelHandler(
   DependencyObject^ element,
   EventHandler<MouseWheelEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemoveMouseButtonDownHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : RemoveMouseButtonDownHandler Method

element
The UIElement that listens to this event
handler
The event handler
Removes a handler for the MouseDown attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveMouseButtonDownHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseButtonEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseButtonEventArgs)

Mouse.RemoveMouseButtonDownHandler(element, handler)
C#
public static void RemoveMouseButtonDownHandler(
   DependencyObject element,
   EventHandler<MouseButtonEventArgs> handler
)
Managed Extensions for C++
public: static void RemoveMouseButtonDownHandler(
   DependencyObject* element,
   EventHandler<MouseButtonEventArgs*>* handler
)
C++/CLI
public:
static void RemoveMouseButtonDownHandler(
   DependencyObject^ element,
   EventHandler<MouseButtonEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemoveMouseButtonUpHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : RemoveMouseButtonUpHandler Method

element
The UIElement that listens to this event
handler
The event handler
Removes a handler for the MouseUp attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveMouseButtonUpHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseButtonEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseButtonEventArgs)

Mouse.RemoveMouseButtonUpHandler(element, handler)
C#
public static void RemoveMouseButtonUpHandler(
   DependencyObject element,
   EventHandler<MouseButtonEventArgs> handler
)
Managed Extensions for C++
public: static void RemoveMouseButtonUpHandler(
   DependencyObject* element,
   EventHandler<MouseButtonEventArgs*>* handler
)
C++/CLI
public:
static void RemoveMouseButtonUpHandler(
   DependencyObject^ element,
   EventHandler<MouseButtonEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
RemoveMouseWheelHandler Method
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : RemoveMouseWheelHandler Method

element
The UIElement that listens to this event
handler
The event handler
Removes a handler for the MouseWheel attached event

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveMouseWheelHandler( _
   ByVal element As DependencyObject, _
   ByVal handler As EventHandler(Of MouseWheelEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim element As DependencyObject
Dim handler As EventHandler(Of MouseWheelEventArgs)

Mouse.RemoveMouseWheelHandler(element, handler)
C#
public static void RemoveMouseWheelHandler(
   DependencyObject element,
   EventHandler<MouseWheelEventArgs> handler
)
Managed Extensions for C++
public: static void RemoveMouseWheelHandler(
   DependencyObject* element,
   EventHandler<MouseWheelEventArgs*>* handler
)
C++/CLI
public:
static void RemoveMouseWheelHandler(
   DependencyObject^ element,
   EventHandler<MouseWheelEventArgs^>^ handler
)

Parameters

element
The UIElement that listens to this event
handler
The event handler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls Send comments on this topic.
Mouse Class Fields
See Also
[image]
Telerik.Windows.Input Namespace : Mouse Class

For a list of all members of this type, see Mouse members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MouseDownEvent | Occurs when the right mouse button is pressed
static (Shared in Visual Basic) | MouseUpEvent | Occurs when the right mouse button is released
static (Shared in Visual Basic) | MouseWheelEvent | Occurs when the mouse wheel is rotated
Top

See Also

Reference

Mouse Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseDownEvent Field
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : MouseDownEvent Field

Occurs when the right mouse button is pressed

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MouseDownEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Mouse.MouseDownEvent
C#
public static readonly RoutedEvent MouseDownEvent
Managed Extensions for C++
public: static readonly RoutedEvent* MouseDownEvent
C++/CLI
public:
static readonly RoutedEvent^ MouseDownEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseUpEvent Field
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : MouseUpEvent Field

Occurs when the right mouse button is released

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MouseUpEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Mouse.MouseUpEvent
C#
public static readonly RoutedEvent MouseUpEvent
Managed Extensions for C++
public: static readonly RoutedEvent* MouseUpEvent
C++/CLI
public:
static readonly RoutedEvent^ MouseUpEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseWheelEvent Field
See Also
[image]
Telerik.Windows.Input Namespace > Mouse Class : MouseWheelEvent Field

Occurs when the mouse wheel is rotated

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MouseWheelEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = Mouse.MouseWheelEvent
C#
public static readonly RoutedEvent MouseWheelEvent
Managed Extensions for C++
public: static readonly RoutedEvent* MouseWheelEvent
C++/CLI
public:
static readonly RoutedEvent^ MouseWheelEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Mouse Class
Mouse Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseButtonEventArgs Class
See Also Members
[image]
Telerik.Windows.Input Namespace : MouseButtonEventArgs Class

Provides data for various events that report changes to the mouse wheel delta value of a mouse device

Object Model

Syntax

Visual Basic (Declaration)
Public Class MouseButtonEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As MouseButtonEventArgs
C#
public class MouseButtonEventArgs : RadRoutedEventArgs
Managed Extensions for C++
public __gc class MouseButtonEventArgs : public RadRoutedEventArgs
C++/CLI
public ref class MouseButtonEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Input.MouseButtonEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseButtonEventArgs Members
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
MouseButtonEventArgs Class Members
See Also Properties Methods
[image]
Telerik.Windows.Input Namespace : MouseButtonEventArgs Class

The following tables list the members exposed by MouseButtonEventArgs.

Public Properties

 | Name | Description
Public Property | ButtonState | Gets the state of the button associated with the event.
Public Property | ChangedButton | Gets the button associated with the event.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

Public Methods

 | Name | Description
Public Method | GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
Top

See Also

Reference

MouseButtonEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
MouseButtonEventArgs Class Methods
See Also
[image]
Telerik.Windows.Input Namespace : MouseButtonEventArgs Class

For a list of all members of this type, see MouseButtonEventArgs members.

Public Methods

 | Name | Description
Public Method | GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
Top

See Also

Reference

MouseButtonEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetPosition Method
See Also
[image]
Telerik.Windows.Input Namespace > MouseButtonEventArgs Class : GetPosition Method

relativeTo
Any UIElement-derived object that is contained by the Silverlight plug-in and connected to the object tree. To specify the object relative to the overall Silverlight coordinate system, set the relativeTo parameter to null.
Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.

Syntax

Visual Basic (Declaration)
Public Function GetPosition( _
   ByVal relativeTo As UIElement _
) As Point
Visual Basic (Usage) Copy Code
Dim instance As MouseButtonEventArgs
Dim relativeTo As UIElement
Dim value As Point

value = instance.GetPosition(relativeTo)
C#
public Point GetPosition(
   UIElement relativeTo
)
Managed Extensions for C++
public: Point GetPosition(
   UIElement* relativeTo
)
C++/CLI
public:
Point GetPosition(
   UIElement^ relativeTo
)

Parameters

relativeTo
Any UIElement-derived object that is contained by the Silverlight plug-in and connected to the object tree. To specify the object relative to the overall Silverlight coordinate system, set the relativeTo parameter to null.

Return Value

A Point that represents the current x- and y-coordinates of the mouse pointer position. If null was passed as relativeTo, this coordinate is for the overall Silverlight plug-in content area. If a non-null relativeTo was passed, this coordinate is relative to the object referenced by relativeTo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseButtonEventArgs Class
MouseButtonEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
MouseButtonEventArgs Class Properties
See Also
[image]
Telerik.Windows.Input Namespace : MouseButtonEventArgs Class

For a list of all members of this type, see MouseButtonEventArgs members.

Public Properties

 | Name | Description
Public Property | ButtonState | Gets the state of the button associated with the event.
Public Property | ChangedButton | Gets the button associated with the event.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

MouseButtonEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ButtonState Property
See Also
[image]
Telerik.Windows.Input Namespace > MouseButtonEventArgs Class : ButtonState Property

Gets the state of the button associated with the event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property ButtonState As MouseButtonState
Visual Basic (Usage) Copy Code
Dim instance As MouseButtonEventArgs
Dim value As MouseButtonState

value = instance.ButtonState
C#
[CompilerGeneratedAttribute()]
public MouseButtonState ButtonState {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property MouseButtonState get_ButtonState();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property MouseButtonState ButtonState {
   MouseButtonState get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseButtonEventArgs Class
MouseButtonEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
ChangedButton Property
See Also
[image]
Telerik.Windows.Input Namespace > MouseButtonEventArgs Class : ChangedButton Property

Gets the button associated with the event.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property ChangedButton As MouseButton
Visual Basic (Usage) Copy Code
Dim instance As MouseButtonEventArgs
Dim value As MouseButton

value = instance.ChangedButton
C#
[CompilerGeneratedAttribute()]
public MouseButton ChangedButton {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property MouseButton get_ChangedButton();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property MouseButton ChangedButton {
   MouseButton get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseButtonEventArgs Class
MouseButtonEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseWheelEventArgs Class
See Also Members
[image]
Telerik.Windows.Input Namespace : MouseWheelEventArgs Class

Provides data for various events that report changes to the mouse wheel delta value of a mouse device

Object Model

Syntax

Visual Basic (Declaration)
Public Class MouseWheelEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As MouseWheelEventArgs
C#
public class MouseWheelEventArgs : RadRoutedEventArgs
Managed Extensions for C++
public __gc class MouseWheelEventArgs : public RadRoutedEventArgs
C++/CLI
public ref class MouseWheelEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Input.MouseWheelEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseWheelEventArgs Members
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls Send comments on this topic.
MouseWheelEventArgs Class Members
See Also Properties Methods
[image]
Telerik.Windows.Input Namespace : MouseWheelEventArgs Class

The following tables list the members exposed by MouseWheelEventArgs.

Public Properties

 | Name | Description
Public Property | Delta | Gets a value that indicates the amount that the mouse wheel has changed.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

Public Methods

 | Name | Description
Public Method | GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
Top

See Also

Reference

MouseWheelEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls Send comments on this topic.
MouseWheelEventArgs Class Methods
See Also
[image]
Telerik.Windows.Input Namespace : MouseWheelEventArgs Class

For a list of all members of this type, see MouseWheelEventArgs members.

Public Methods

 | Name | Description
Public Method | GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
Top

See Also

Reference

MouseWheelEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
GetPosition Method
See Also
[image]
Telerik.Windows.Input Namespace > MouseWheelEventArgs Class : GetPosition Method

relativeTo
Any UIElement-derived object that is contained by the Silverlight plug-in and connected to the object tree. To specify the object relative to the overall Silverlight coordinate system, set the relativeTo parameter to null.
Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.

Syntax

Visual Basic (Declaration)
Public Function GetPosition( _
   ByVal relativeTo As UIElement _
) As Point
Visual Basic (Usage) Copy Code
Dim instance As MouseWheelEventArgs
Dim relativeTo As UIElement
Dim value As Point

value = instance.GetPosition(relativeTo)
C#
public Point GetPosition(
   UIElement relativeTo
)
Managed Extensions for C++
public: Point GetPosition(
   UIElement* relativeTo
)
C++/CLI
public:
Point GetPosition(
   UIElement^ relativeTo
)

Parameters

relativeTo
Any UIElement-derived object that is contained by the Silverlight plug-in and connected to the object tree. To specify the object relative to the overall Silverlight coordinate system, set the relativeTo parameter to null.

Return Value

A Point that represents the current x- and y-coordinates of the mouse pointer position. If null was passed as relativeTo, this coordinate is for the overall Silverlight plug-in content area. If a non-null relativeTo was passed, this coordinate is relative to the object referenced by relativeTo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseWheelEventArgs Class
MouseWheelEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls Send comments on this topic.
MouseWheelEventArgs Class Properties
See Also
[image]
Telerik.Windows.Input Namespace : MouseWheelEventArgs Class

For a list of all members of this type, see MouseWheelEventArgs members.

Public Properties

 | Name | Description
Public Property | Delta | Gets a value that indicates the amount that the mouse wheel has changed.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

MouseWheelEventArgs Class
Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
Delta Property
See Also
[image]
Telerik.Windows.Input Namespace > MouseWheelEventArgs Class : Delta Property

Gets a value that indicates the amount that the mouse wheel has changed.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property Delta As Integer
Visual Basic (Usage) Copy Code
Dim instance As MouseWheelEventArgs
Dim value As Integer

value = instance.Delta
C#
[CompilerGeneratedAttribute()]
public int Delta {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property int get_Delta();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property int Delta {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseWheelEventArgs Class
MouseWheelEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseButton Enumeration
See Also
[image]
Telerik.Windows.Input Namespace : MouseButton Enumeration

Defines values that specify the buttons on a mouse device.

Syntax

Visual Basic (Declaration)
Public Enum MouseButton
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MouseButton
C#
public enum MouseButton : Enum
Managed Extensions for C++
__value public enum MouseButton : public Enum
C++/CLI
public enum class MouseButton : public Enum

Members

Member | Description
Left | The left mouse button.
Middle | The middle mouse button.
Right | The right mouse button.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Input.MouseButton

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Input Namespace


%%PageItemTitle%%

Telerik.Windows.Controls Send comments on this topic.
MouseButtonState Enumeration
See Also
[image]
Telerik.Windows.Input Namespace : MouseButtonState Enumeration

Specifies the possible states of a mouse button.

Syntax

Visual Basic (Declaration)
Public Enum MouseButtonState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MouseButtonState
C#
public enum MouseButtonState : Enum
Managed Extensions for C++
__value public enum MouseButtonState : public Enum
C++/CLI
public enum class MouseButtonState : public Enum

Members

Member | Description
Released | The button is released.
Pressed | The button is pressed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Input.MouseButtonState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Input Namespace


%%phrase%%

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.Input Assembly

Namespaces

Namespace | Description
Telerik.Windows.Controls |
Telerik.Windows.Controls.Calendar |
Telerik.Windows.Controls.DatePicker.DateTimeParsing |
Telerik.Windows.Controls.Upload |


%%ItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.Input)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DateTimeTypeConverter | Provides a converter to convert DateTime objects to and from other representations.
Class | FilesSelectedEventArgs |
Class | FileUploadedEventArgs |
Class | RadCalendar | Represents a selection control that allows you to slect dates from a calendar.
Class | RadComboBox | Represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
Class | RadComboBoxItem | Implements a selectable item inside a RadComboBox.
Class | RadDatePicker | Input control for entering Dates.
Class | RadNumericUpDown | Partial class RadNumericUpDown which contains properties declaration and handlers
Class | RadUpDown | RadUpDown exposes two repeat buttons for easily handling the RangeBase value
Class | RadUpload | A composite control, allowing you to upload a single or multiple files. The RadUpload control allows you to validate in terms of size and extension the selected files on the client, progress display, skin, etc.
Class | RadUploadItem |
Class | RadUploadSelectedFile |
Class | UploadProgressEventArgs |
Class | UploadStartedEventArgs |

Enumerations

 | Enumeration | Description
Enumeration | ValueFormat | UpDownMode determines the format ot the value

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateTimeTypeConverter Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : DateTimeTypeConverter Class

Provides a converter to convert DateTime objects to and from other representations.

Syntax

Visual Basic (Declaration)
Public Class DateTimeTypeConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As DateTimeTypeConverter
C#
public class DateTimeTypeConverter : TypeConverter
Managed Extensions for C++
public __gc class DateTimeTypeConverter : public TypeConverter
C++/CLI
public ref class DateTimeTypeConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Windows.Controls.DateTimeTypeConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeTypeConverter Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
DateTimeTypeConverter Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : DateTimeTypeConverter Class

The following tables list the members exposed by DateTimeTypeConverter.

Public Constructors

 | Name | Description
Public Constructor | DateTimeTypeConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overridden. Returns whether the type converter can convert an object from the specified type to the type of this converter.
Public Method | CanConvertTo | Overridden. Returns whether the type converter can convert an object to the specified type to the type of this converter.
Public Method | ConvertFrom | Overridden. Converts from the specified value to the type of this converter.
Public Method | ConvertFromString | (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

DateTimeTypeConverter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateTimeTypeConverter Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > DateTimeTypeConverter Class : DateTimeTypeConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DateTimeTypeConverter()
C#
public DateTimeTypeConverter()
Managed Extensions for C++
public: DateTimeTypeConverter();
C++/CLI
public:
DateTimeTypeConverter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeTypeConverter Class
DateTimeTypeConverter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
DateTimeTypeConverter Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : DateTimeTypeConverter Class

For a list of all members of this type, see DateTimeTypeConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overridden. Returns whether the type converter can convert an object from the specified type to the type of this converter.
Public Method | CanConvertTo | Overridden. Returns whether the type converter can convert an object to the specified type to the type of this converter.
Public Method | ConvertFrom | Overridden. Converts from the specified value to the type of this converter.
Public Method | ConvertFromString | (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

DateTimeTypeConverter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CanConvertFrom Method
See Also
[image]
Telerik.Windows.Controls Namespace > DateTimeTypeConverter Class : CanConvertFrom Method

sourceType
The type you want to convert from.
Returns whether the type converter can convert an object from the specified type to the type of this converter.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateTimeTypeConverter
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(sourceType)
C#
public override bool CanConvertFrom(
   Type sourceType
)
Managed Extensions for C++
public: bool CanConvertFrom(
   Type* sourceType
) override
C++/CLI
public:
bool CanConvertFrom(
   Type^ sourceType
) override

Parameters

sourceType
The type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Exceptions

Exception | Description
ArgumentException | sourceType is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeTypeConverter Class
DateTimeTypeConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CanConvertTo Method
See Also
[image]
Telerik.Windows.Controls Namespace > DateTimeTypeConverter Class : CanConvertTo Method

destinationType
The type you want to convert to.
Returns whether the type converter can convert an object to the specified type to the type of this converter.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateTimeTypeConverter
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(destinationType)
C#
public override bool CanConvertTo(
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   Type^ destinationType
) override

Parameters

destinationType
The type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Exceptions

Exception | Description
ArgumentException | destinationType is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeTypeConverter Class
DateTimeTypeConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ConvertFrom Method
See Also
[image]
Telerik.Windows.Controls Namespace > DateTimeTypeConverter Class : ConvertFrom Method

value
The value to convert to the type of this converter.
Converts from the specified value to the type of this converter.

Syntax

Visual Basic (Declaration)
Public Overrides Function ConvertFrom( _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DateTimeTypeConverter
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(value)
C#
public override object ConvertFrom(
   object value
)
Managed Extensions for C++
public: Object* ConvertFrom(
   Object* value
) override
C++/CLI
public:
Object^ ConvertFrom(
   Object^ value
) override

Parameters

value
The value to convert to the type of this converter.

Return Value

The converted value.

Exceptions

Exception | Description
NotSupportedException | The conversion cannot be performed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeTypeConverter Class
DateTimeTypeConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilesSelectedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : FilesSelectedEventArgs Class

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class FilesSelectedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As FilesSelectedEventArgs
C#
[ScriptableTypeAttribute()]
public class FilesSelectedEventArgs : EventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class FilesSelectedEventArgs : public EventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class FilesSelectedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.FilesSelectedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FilesSelectedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
FilesSelectedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : FilesSelectedEventArgs Class

The following tables list the members exposed by FilesSelectedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FilesSelectedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | SelectedFiles | Gets the selected files.
Top

See Also

Reference

FilesSelectedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilesSelectedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > FilesSelectedEventArgs Class : FilesSelectedEventArgs Constructor

selectedFiles

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectedFiles As IList(Of RadUploadSelectedFile) _
)
Visual Basic (Usage) Copy Code
Dim selectedFiles As IList(Of RadUploadSelectedFile)

Dim instance As FilesSelectedEventArgs(selectedFiles)
C#
public FilesSelectedEventArgs(
   IList<RadUploadSelectedFile> selectedFiles
)
Managed Extensions for C++
public: FilesSelectedEventArgs(
   IList<RadUploadSelectedFile*>* selectedFiles
)
C++/CLI
public:
FilesSelectedEventArgs(
   IList<RadUploadSelectedFile^>^ selectedFiles
)

Parameters

selectedFiles

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FilesSelectedEventArgs Class
FilesSelectedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
FilesSelectedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : FilesSelectedEventArgs Class

For a list of all members of this type, see FilesSelectedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedFiles | Gets the selected files.
Top

See Also

Reference

FilesSelectedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedFiles Property
See Also
[image]
Telerik.Windows.Controls Namespace > FilesSelectedEventArgs Class : SelectedFiles Property

Gets the selected files.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property SelectedFiles As IList(Of RadUploadSelectedFile)
Visual Basic (Usage) Copy Code
Dim instance As FilesSelectedEventArgs
Dim value As IList(Of RadUploadSelectedFile)

value = instance.SelectedFiles
C#
[ScriptableMemberAttribute()]
public IList<RadUploadSelectedFile> SelectedFiles {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property IList<RadUploadSelectedFile*>* get_SelectedFiles();
C++/CLI
[ScriptableMemberAttribute()]
public:
property IList<RadUploadSelectedFile^>^ SelectedFiles {
   IList<RadUploadSelectedFile^>^ get();
}

Return Value

The selected files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FilesSelectedEventArgs Class
FilesSelectedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileUploadedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : FileUploadedEventArgs Class

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class FileUploadedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As FileUploadedEventArgs
C#
[ScriptableTypeAttribute()]
public class FileUploadedEventArgs : EventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class FileUploadedEventArgs : public EventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class FileUploadedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.FileUploadedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileUploadedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
FileUploadedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : FileUploadedEventArgs Class

The following tables list the members exposed by FileUploadedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FileUploadedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | HandlerData | Gets the handler data.
Top

See Also

Reference

FileUploadedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileUploadedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > FileUploadedEventArgs Class : FileUploadedEventArgs Constructor

handlerData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal handlerData As String _
)
Visual Basic (Usage) Copy Code
Dim handlerData As String

Dim instance As FileUploadedEventArgs(handlerData)
C#
public FileUploadedEventArgs(
   string handlerData
)
Managed Extensions for C++
public: FileUploadedEventArgs(
   string* handlerData
)
C++/CLI
public:
FileUploadedEventArgs(
   String^ handlerData
)

Parameters

handlerData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileUploadedEventArgs Class
FileUploadedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
FileUploadedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : FileUploadedEventArgs Class

For a list of all members of this type, see FileUploadedEventArgs members.

Public Properties

 | Name | Description
Public Property | HandlerData | Gets the handler data.
Top

See Also

Reference

FileUploadedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HandlerData Property
See Also
[image]
Telerik.Windows.Controls Namespace > FileUploadedEventArgs Class : HandlerData Property

Gets the handler data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HandlerData As Dictionary(Of String, Object)
Visual Basic (Usage) Copy Code
Dim instance As FileUploadedEventArgs
Dim value As Dictionary(Of String, Object)

value = instance.HandlerData
C#
public Dictionary<string, object> HandlerData {get;}
Managed Extensions for C++
public: __property Dictionary<string*, Object*>* get_HandlerData();
C++/CLI
public:
property Dictionary<String^, Object^>^ HandlerData {
   Dictionary<String^, Object^>^ get();
}

Return Value

The handler data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileUploadedEventArgs Class
FileUploadedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

Represents a selection control that allows you to slect dates from a calendar.

Object Model

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="Currently not feasible")>
<DefaultPropertyAttribute("SelectedDate")>
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
<DefaultEventAttribute("DateSelected")>
Public Class RadCalendar
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
C#
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="Currently not feasible")]
[DefaultPropertyAttribute("SelectedDate")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[DefaultEventAttribute("DateSelected")]
public class RadCalendar : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="Currently not feasible")]
[DefaultPropertyAttribute("SelectedDate")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[DefaultEventAttribute("DateSelected")]
public __gc class RadCalendar : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="Currently not feasible")]
[DefaultPropertyAttribute("SelectedDate")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[DefaultEventAttribute("DateSelected")]
public ref class RadCalendar : public Control, IManagedPeer, INativeCoreTypeWrapper

Remarks

The Calendar control allows the user to select a single date.

The user can navigate in the Calendar by clicking the arrow buttons in the calendar header that would cycle through the list of days, months or years. Clicking inbetween the two arrows would change the DisplayMode of the calendar so that it displays a year if a month was displayed. Clicking the button with today's date would navigate to the month view of the current month.

The DisplayMode property allows you to get or set the current display mode. By handling the DisplayModeChanged routed event you would recieve a notification whenever a change in the display mode occurs.

Disabling or enabling the selection of dates can be controlled by the SelectableDateStart and SelectableDateEnd properties. If none of the latter two has been set, i.e. their value is null then all the calendar dates are selctable. If the property is set to true then only today's date and the days after are selectable. Setting the SelectableDateStart/End properties takes precedence and specifies the first and the last dates that are selectable.

The SelectedDate property holds the DateTime value of the selected date. The default value is null (no date is selected). Adding a handler for the SelectedDate event would enable you to be notified whenever a date is selected.

Similarly, to modify which dates the user can navigate to, use the DisplayDateStart and DisplayDateEnd properties. Setting the DisplayDate property navigates the calendar to the month or year that contain this date (depending on the current DisplayMode). Please note that the DisplayDate property cannot be set to null.

Please note that the RadCalendar currently supports only Gregorian calendar

    The following list contains links to examples of common tasks.
  • TODO: EXAMPLE: Add examples list here.

The following example creates a Calendar and sets the display range to be the next three months and the selectable range the next two weeks.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadCalendar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Members
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

The following tables list the members exposed by RadCalendar.

Public Constructors

 | Name | Description
Public Constructor | RadCalendar Constructor | Default constructor.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AreWeekNamesVisibleProperty | Identifies the AreWeekNamesVisible proeprty.
static (Shared in Visual Basic) | AreWeekNumbersVisibleProperty | Identifies the AreWeekNumbersVisible proeprty.
static (Shared in Visual Basic) | CalendarWeekRuleProperty | Identifies the CalendarWeekRule property.
static (Shared in Visual Basic) | CenturyViewHeaderFormatProperty | Identifies the CenturyViewHeaderFormat property.
static (Shared in Visual Basic) | CenturyViewPanelProperty | Identifies the CenturyViewPanel property.
static (Shared in Visual Basic) | CenturyViewStyleProperty | Identifies the CenturyViewStyle property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | CultureProperty | Indetifies the Culture property.
static (Shared in Visual Basic) | DayButtonStyleProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DayButtonStyleSelectorProperty | Identifies the DayButtonStyleSelector property.
static (Shared in Visual Basic) | DayTemplateProperty | Identifies the DayTemplate property.
static (Shared in Visual Basic) | DayTemplateSelectorProperty | Identifies the DayTemplateSelector property.
static (Shared in Visual Basic) | DecadeButtonStyleProperty | Identifies the DecadeButtonStyle property.
static (Shared in Visual Basic) | DecadeButtonStyleSelectorProperty | Identifies the DecadeButtonStyleSelector property.
static (Shared in Visual Basic) | DecadeTemplateProperty | Identifies the DecadeTemplate property.
static (Shared in Visual Basic) | DecadeTemplateSelectorProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DecadeViewHeaderFormatProperty | Identifies the DecadeViewHeaderFormat property.
static (Shared in Visual Basic) | DecadeViewPanelProperty | Identifies the DecadeViewPanel property.
static (Shared in Visual Basic) | DecadeViewStyleProperty | Identifies the DecadeViewStyle property.
static (Shared in Visual Basic) | DisplayDateEndProperty | Identifies the DisplayDateEnd Property.
static (Shared in Visual Basic) | DisplayDateProperty | Identifies the DisplayDate property.
static (Shared in Visual Basic) | DisplayDateStartProperty | Identifies the DisplayDateStartProperty.
static (Shared in Visual Basic) | DisplayModeProperty | Identifies the DisplayMode Property.
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the first day of week property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled property.
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the ReadOnly proeprty.
static (Shared in Visual Basic) | IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property.
static (Shared in Visual Basic) | MaxDate | Gets the latest date that the calendar can display.
static (Shared in Visual Basic) | MinDate | Gets the earliest date that the calendar can display.
static (Shared in Visual Basic) | MonthButtonStyleProperty | Identifies the MonthButtonStyle property.
static (Shared in Visual Basic) | MonthButtonStyleSelectorProperty | Identifies the MonthButtonStyleSelector property.
static (Shared in Visual Basic) | MonthTemplateProperty | Identifies the MonthTemplate property.
static (Shared in Visual Basic) | MonthTemplateSelectorProperty | Identifies the MonthTemplateSelector property.
static (Shared in Visual Basic) | MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat property.
static (Shared in Visual Basic) | MonthViewPanelProperty | Identifies the MonthViewPanel property.
static (Shared in Visual Basic) | MonthViewStyleProperty | Identifies the MonthViewStyle property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
static (Shared in Visual Basic) | SelectableDateEndProperty | Identifies the SelectableDateEnd property.
static (Shared in Visual Basic) | SelectableDateStartProperty | Identifies the SelectableDateStart dependency property.
static (Shared in Visual Basic) | SelectedDateProperty | Identifies the SelectedDate dependency property.
static (Shared in Visual Basic) | SelectionModeProperty | Identifies the SelectionMode dependency property.
static (Shared in Visual Basic) | ViewsHeaderVisibilityProperty | Identifies the ViewsHeaderVisibility property.
static (Shared in Visual Basic) | YearButtonStyleProperty | Identifies the YearButtonStyle property.
static (Shared in Visual Basic) | YearButtonStyleSelectorProperty | Identifies the YearButtonStyleSelector property.
static (Shared in Visual Basic) | YearTemplateProperty | Identifies the YearTemplate property.
static (Shared in Visual Basic) | YearTemplateSelectorProperty | Identifies the YearTemplateSelector property.
static (Shared in Visual Basic) | YearViewHeaderFormatProperty | Identifies the YearViewHeaderFormat property.
static (Shared in Visual Basic) | YearViewPanelProperty | Identifies the YearViewPanel property.
static (Shared in Visual Basic) | YearViewStyleProperty | Identifies the YearViewStyle property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AreWeekNamesVisible | Gets or sets whether WeekNames will be displayed
Public Property | AreWeekNumbersVisible | Gets or sets whether WeekNumbers will be displayed
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CalendarWeekRule | Gets or sets how should the first week in the year be counted. This is a dependency property.
Public Property | CenturyViewHeaderFormat | Gets or sets the format for the header of the century views of the calendar. This is a dependency property.
Public Property | CenturyViewPanel | Gets or sets the items panel template for the century views of the calendar. This is a dependency property.
Public Property | CenturyViewStyle | Gets or sets the style of the century calendar view. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.
Public Property | Culture | Gets or sets the culture that the Calendar uses. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DayButtonStyle | Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayButtonStyleSelector | Gets or sets the style selector for the day buttons in the month views of the Calendar.
Public Property | DayTemplate | Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayTemplateSelector | Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyle | Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyleSelector | Gets or sets the style selector for the decade buttons in the century views of the Calendar.
Public Property | DecadeTemplate | Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeTemplateSelector | Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeViewHeaderFormat | Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewPanel | Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewStyle | Gets or sets the style of the decade calendar view. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayDate | Gets or sets the current date to display. This is a dependency property.
Public Property | DisplayDateEnd | Gets or sets the last date that would be able to be displayed. This is a dependency property.
Public Property | DisplayDateStart | Gets or sets the first date that would be able to be displayed. This is a dependency property.
Public Property | DisplayMode | Gets or sets the display mode of the Calendar. This is a dependency property.
Public Property | FirstDayOfWeek | Gets or sets the day that is considered the beginning of the week.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HeaderVisibility | Gets or sets the visibility of the Calendar's header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets whether the Calenadar is enable
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation.
Public Property | IsReadOnly | Gets or sets whether the Calendar's selection can be changed. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTodayHighlighted | Gets or sets whether the today date would be highlighted. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MonthButtonStyle | Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthButtonStyleSelector | Gets or sets the style selector for the month buttons in the year views of the Calendar.
Public Property | MonthTemplate | Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthTemplateSelector | Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthViewHeaderFormat | Gets or sets the format for the header of the month views of the calendar. This is a dependency property.
Public Property | MonthViewPanel | Gets or sets the items panel template for the month views of the calendar. This is a dependency property.
Public Property | MonthViewStyle | Gets or sets the style of the month calendar view. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the Calendar. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.
Public Property | SelectableDateEnd | Gets or sets the last date that can be selected. This is a dependency property.
Public Property | SelectableDateStart | Gets or sets the first date that can be selected. This is a dependency property.
Public Property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public Property | SelectedDates | Gets an list of the currenly selected dates.
Public Property | SelectionMode | Gets or sets the types of selection that would be allowed in the Calendar. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ViewsHeaderVisibility | Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | YearButtonStyle | Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearButtonStyleSelector | Gets or sets the style selector for the year buttons in the decade views of the Calendar.
Public Property | YearTemplate | Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearTemplateSelector | Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearViewHeaderFormat | Gets or sets the format for the header of the year views of the calendar. This is a dependency property.
Public Property | YearViewPanel | Gets or sets the items panel template for the year views of the calendar. This is a dependency property.
Public Property | YearViewStyle | Gets or sets the style of the calendar year view. This is a dependency property.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | IsDisplayDateEndValid | Checks whether the date is a valid DisplayDateEnd value for the given calendar.
static (Shared in Visual Basic) | IsDisplayDateStartValid | Checks whether the date is a valid DisplayDateStart value for the given calendar.
static (Shared in Visual Basic) | IsDisplayDateValid | Checks whether the given date is a valid display date for the calendar.
static (Shared in Visual Basic) | IsSelectableDateEndValid | Checks whether the date is a valid SelectableDateEnd value for the given calendar.
static (Shared in Visual Basic) | IsSelectableDateStartValid | Checks whether the date is a valid SelectableDateStart value for the given calendar.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnDisplayDateChanged | The OnDisplayDateChanged is called when the display date of the calendar chnages.
Protected Method | OnDisplayModeChanged | OnDisplayModeChanged is called when the display mode of the calendar changes.
Protected Method | OnSelectionChanged | OnSelectionChanged is called whenever the selected dates of the calnedar change.
Protected Method | OnSelectionModeChanged | Called when SelectionMode changed.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DisplayDateChanged | Occurs when the DisplayDate property is changed.
Public Event | DisplayModeChanged | Occurs when the DisplayMode property is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when a date is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadCalendar Class
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : RadCalendar Constructor

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar()
C#
public RadCalendar()
Managed Extensions for C++
public: RadCalendar();
C++/CLI
public:
RadCalendar();

Remarks

Please refer to the RadCalendar article for information and examples on how to use the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
RadCalendar Class


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

For a list of all members of this type, see RadCalendar members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
static (Shared in Visual Basic) | IsDisplayDateEndValid | Checks whether the date is a valid DisplayDateEnd value for the given calendar.
static (Shared in Visual Basic) | IsDisplayDateStartValid | Checks whether the date is a valid DisplayDateStart value for the given calendar.
static (Shared in Visual Basic) | IsDisplayDateValid | Checks whether the given date is a valid display date for the calendar.
static (Shared in Visual Basic) | IsSelectableDateEndValid | Checks whether the date is a valid SelectableDateEnd value for the given calendar.
static (Shared in Visual Basic) | IsSelectableDateStartValid | Checks whether the date is a valid SelectableDateStart value for the given calendar.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnDisplayDateChanged | The OnDisplayDateChanged is called when the display date of the calendar chnages.
Protected Method | OnDisplayModeChanged | OnDisplayModeChanged is called when the display mode of the calendar changes.
Protected Method | OnSelectionChanged | OnSelectionChanged is called whenever the selected dates of the calnedar change.
Protected Method | OnSelectionModeChanged | Called when SelectionMode changed.
Top

See Also

Reference

RadCalendar Class
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDisplayDateEndValid Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsDisplayDateEndValid Method

calendar
The calendar for which to test the value.
newDisplayDateEnd
The date to test.
Checks whether the date is a valid DisplayDateEnd value for the given calendar.

Syntax

Visual Basic (Declaration)
Public Shared Function IsDisplayDateEndValid( _
   ByVal calendar As RadCalendar, _
   ByVal newDisplayDateEnd As Nullable(Of Date) _
) As Boolean
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar
Dim newDisplayDateEnd As Nullable(Of Date)
Dim value As Boolean

value = RadCalendar.IsDisplayDateEndValid(calendar, newDisplayDateEnd)
C#
public static bool IsDisplayDateEndValid(
   RadCalendar calendar,
   Nullable<DateTime> newDisplayDateEnd
)
Managed Extensions for C++
public: static bool IsDisplayDateEndValid(
   RadCalendar* calendar,
   Nullable<DateTime> newDisplayDateEnd
)
C++/CLI
public:
static bool IsDisplayDateEndValid(
   RadCalendar^ calendar,
   Nullable<DateTime> newDisplayDateEnd
)

Parameters

calendar
The calendar for which to test the value.
newDisplayDateEnd
The date to test.

Return Value

True if it is a valid display date end, flase otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDisplayDateStartValid Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsDisplayDateStartValid Method

calendar
The calendar for which to test the value.
newDisplayDate
The date to test.
Checks whether the date is a valid DisplayDateStart value for the given calendar.

Syntax

Visual Basic (Declaration)
Public Shared Function IsDisplayDateStartValid( _
   ByVal calendar As RadCalendar, _
   ByVal newDisplayDate As Nullable(Of Date) _
) As Boolean
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar
Dim newDisplayDate As Nullable(Of Date)
Dim value As Boolean

value = RadCalendar.IsDisplayDateStartValid(calendar, newDisplayDate)
C#
public static bool IsDisplayDateStartValid(
   RadCalendar calendar,
   Nullable<DateTime> newDisplayDate
)
Managed Extensions for C++
public: static bool IsDisplayDateStartValid(
   RadCalendar* calendar,
   Nullable<DateTime> newDisplayDate
)
C++/CLI
public:
static bool IsDisplayDateStartValid(
   RadCalendar^ calendar,
   Nullable<DateTime> newDisplayDate
)

Parameters

calendar
The calendar for which to test the value.
newDisplayDate
The date to test.

Return Value

True if it is a valid display date start, flase otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDisplayDateValid Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsDisplayDateValid Method

calendar
The calendar to check the display date for.
newDisplayDate
The new display date to test.
Checks whether the given date is a valid display date for the calendar.

Syntax

Visual Basic (Declaration)
Public Shared Function IsDisplayDateValid( _
   ByVal calendar As RadCalendar, _
   ByVal newDisplayDate As Date _
) As Boolean
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar
Dim newDisplayDate As Date
Dim value As Boolean

value = RadCalendar.IsDisplayDateValid(calendar, newDisplayDate)
C#
public static bool IsDisplayDateValid(
   RadCalendar calendar,
   DateTime newDisplayDate
)
Managed Extensions for C++
public: static bool IsDisplayDateValid(
   RadCalendar* calendar,
   DateTime newDisplayDate
)
C++/CLI
public:
static bool IsDisplayDateValid(
   RadCalendar^ calendar,
   DateTime newDisplayDate
)

Parameters

calendar
The calendar to check the display date for.
newDisplayDate
The new display date to test.

Return Value

True if it is a valid display date, flase otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsSelectableDateEndValid Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsSelectableDateEndValid Method

calendar
The calendar to test for.
newSelectableDateEnd
The date to test.
Checks whether the date is a valid SelectableDateEnd value for the given calendar.

Syntax

Visual Basic (Declaration)
Public Shared Function IsSelectableDateEndValid( _
   ByVal calendar As RadCalendar, _
   ByVal newSelectableDateEnd As Nullable(Of Date) _
) As Boolean
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar
Dim newSelectableDateEnd As Nullable(Of Date)
Dim value As Boolean

value = RadCalendar.IsSelectableDateEndValid(calendar, newSelectableDateEnd)
C#
public static bool IsSelectableDateEndValid(
   RadCalendar calendar,
   Nullable<DateTime> newSelectableDateEnd
)
Managed Extensions for C++
public: static bool IsSelectableDateEndValid(
   RadCalendar* calendar,
   Nullable<DateTime> newSelectableDateEnd
)
C++/CLI
public:
static bool IsSelectableDateEndValid(
   RadCalendar^ calendar,
   Nullable<DateTime> newSelectableDateEnd
)

Parameters

calendar
The calendar to test for.
newSelectableDateEnd
The date to test.

Return Value

True if it is a valid selectable date end, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsSelectableDateStartValid Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsSelectableDateStartValid Method

calendar
The calendar to test for.
newSelectableDateStart
The date to test.
Checks whether the date is a valid SelectableDateStart value for the given calendar.

Syntax

Visual Basic (Declaration)
Public Shared Function IsSelectableDateStartValid( _
   ByVal calendar As RadCalendar, _
   ByVal newSelectableDateStart As Nullable(Of Date) _
) As Boolean
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar
Dim newSelectableDateStart As Nullable(Of Date)
Dim value As Boolean

value = RadCalendar.IsSelectableDateStartValid(calendar, newSelectableDateStart)
C#
public static bool IsSelectableDateStartValid(
   RadCalendar calendar,
   Nullable<DateTime> newSelectableDateStart
)
Managed Extensions for C++
public: static bool IsSelectableDateStartValid(
   RadCalendar* calendar,
   Nullable<DateTime> newSelectableDateStart
)
C++/CLI
public:
static bool IsSelectableDateStartValid(
   RadCalendar^ calendar,
   Nullable<DateTime> newSelectableDateStart
)

Parameters

calendar
The calendar to test for.
newSelectableDateStart
The date to test.

Return Value

True if it is a valid selectable date start, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnDisplayDateChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OnDisplayDateChanged Method

e
The parameter contains the new and the old display dates.
The OnDisplayDateChanged is called when the display date of the calendar chnages.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDisplayDateChanged( _
   ByVal e As CalendarDateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim e As CalendarDateChangedEventArgs

instance.OnDisplayDateChanged(e)
C#
protected virtual void OnDisplayDateChanged(
   CalendarDateChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDisplayDateChanged(
   CalendarDateChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnDisplayDateChanged(
   CalendarDateChangedEventArgs^ e
)

Parameters

e
The parameter contains the new and the old display dates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnDisplayModeChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OnDisplayModeChanged Method

args
The oarameter contains the old and the new display modes.
OnDisplayModeChanged is called when the display mode of the calendar changes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDisplayModeChanged( _
   ByVal args As CalendarModeChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim args As CalendarModeChangedEventArgs

instance.OnDisplayModeChanged(args)
C#
protected virtual void OnDisplayModeChanged(
   CalendarModeChangedEventArgs args
)
Managed Extensions for C++
protected: virtual void OnDisplayModeChanged(
   CalendarModeChangedEventArgs* args
)
C++/CLI
protected:
virtual void OnDisplayModeChanged(
   CalendarModeChangedEventArgs^ args
)

Parameters

args
The oarameter contains the old and the new display modes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnSelectionChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OnSelectionChanged Method

e
Parameter that describes how the selection has changed.
OnSelectionChanged is called whenever the selected dates of the calnedar change.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
C#
protected virtual void OnSelectionChanged(
   SelectionChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectionChanged(
   SelectionChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelectionChanged(
   SelectionChangedEventArgs^ e
)

Parameters

e
Parameter that describes how the selection has changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnSelectionModeChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OnSelectionModeChanged Method

oldValue
The old value.
newValue
The new value.
Called when SelectionMode changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionModeChanged( _
   ByVal oldValue As SelectionMode, _
   ByVal newValue As SelectionMode _
)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim oldValue As SelectionMode
Dim newValue As SelectionMode

instance.OnSelectionModeChanged(oldValue, newValue)
C#
protected virtual void OnSelectionModeChanged(
   SelectionMode oldValue,
   SelectionMode newValue
)
Managed Extensions for C++
protected: virtual void OnSelectionModeChanged(
   SelectionMode oldValue,
   SelectionMode newValue
)
C++/CLI
protected:
virtual void OnSelectionModeChanged(
   SelectionMode oldValue,
   SelectionMode newValue
)

Parameters

oldValue
The old value.
newValue
The new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

For a list of all members of this type, see RadCalendar members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AreWeekNamesVisible | Gets or sets whether WeekNames will be displayed
Public Property | AreWeekNumbersVisible | Gets or sets whether WeekNumbers will be displayed
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CalendarWeekRule | Gets or sets how should the first week in the year be counted. This is a dependency property.
Public Property | CenturyViewHeaderFormat | Gets or sets the format for the header of the century views of the calendar. This is a dependency property.
Public Property | CenturyViewPanel | Gets or sets the items panel template for the century views of the calendar. This is a dependency property.
Public Property | CenturyViewStyle | Gets or sets the style of the century calendar view. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.
Public Property | Culture | Gets or sets the culture that the Calendar uses. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DayButtonStyle | Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayButtonStyleSelector | Gets or sets the style selector for the day buttons in the month views of the Calendar.
Public Property | DayTemplate | Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayTemplateSelector | Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyle | Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyleSelector | Gets or sets the style selector for the decade buttons in the century views of the Calendar.
Public Property | DecadeTemplate | Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeTemplateSelector | Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeViewHeaderFormat | Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewPanel | Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewStyle | Gets or sets the style of the decade calendar view. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayDate | Gets or sets the current date to display. This is a dependency property.
Public Property | DisplayDateEnd | Gets or sets the last date that would be able to be displayed. This is a dependency property.
Public Property | DisplayDateStart | Gets or sets the first date that would be able to be displayed. This is a dependency property.
Public Property | DisplayMode | Gets or sets the display mode of the Calendar. This is a dependency property.
Public Property | FirstDayOfWeek | Gets or sets the day that is considered the beginning of the week.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HeaderVisibility | Gets or sets the visibility of the Calendar's header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets whether the Calenadar is enable
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation.
Public Property | IsReadOnly | Gets or sets whether the Calendar's selection can be changed. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTodayHighlighted | Gets or sets whether the today date would be highlighted. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MonthButtonStyle | Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthButtonStyleSelector | Gets or sets the style selector for the month buttons in the year views of the Calendar.
Public Property | MonthTemplate | Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthTemplateSelector | Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthViewHeaderFormat | Gets or sets the format for the header of the month views of the calendar. This is a dependency property.
Public Property | MonthViewPanel | Gets or sets the items panel template for the month views of the calendar. This is a dependency property.
Public Property | MonthViewStyle | Gets or sets the style of the month calendar view. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the Calendar. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.
Public Property | SelectableDateEnd | Gets or sets the last date that can be selected. This is a dependency property.
Public Property | SelectableDateStart | Gets or sets the first date that can be selected. This is a dependency property.
Public Property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public Property | SelectedDates | Gets an list of the currenly selected dates.
Public Property | SelectionMode | Gets or sets the types of selection that would be allowed in the Calendar. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ViewsHeaderVisibility | Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | YearButtonStyle | Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearButtonStyleSelector | Gets or sets the style selector for the year buttons in the decade views of the Calendar.
Public Property | YearTemplate | Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearTemplateSelector | Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearViewHeaderFormat | Gets or sets the format for the header of the year views of the calendar. This is a dependency property.
Public Property | YearViewPanel | Gets or sets the items panel template for the year views of the calendar. This is a dependency property.
Public Property | YearViewStyle | Gets or sets the style of the calendar year view. This is a dependency property.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadCalendar Class
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AreWeekNamesVisible Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : AreWeekNamesVisible Property

Gets or sets whether WeekNames will be displayed

Syntax

Visual Basic (Declaration)
Public Property AreWeekNamesVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

instance.AreWeekNamesVisible = value

value = instance.AreWeekNamesVisible
C#
public bool AreWeekNamesVisible {get; set;}
Managed Extensions for C++
public: __property bool get_AreWeekNamesVisible();
public: __property void set_AreWeekNamesVisible(
   bool value
);
C++/CLI
public:
property bool AreWeekNamesVisible {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AreWeekNumbersVisible Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : AreWeekNumbersVisible Property

Gets or sets whether WeekNumbers will be displayed

Syntax

Visual Basic (Declaration)
Public Property AreWeekNumbersVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

instance.AreWeekNumbersVisible = value

value = instance.AreWeekNumbersVisible
C#
public bool AreWeekNumbersVisible {get; set;}
Managed Extensions for C++
public: __property bool get_AreWeekNumbersVisible();
public: __property void set_AreWeekNumbersVisible(
   bool value
);
C++/CLI
public:
property bool AreWeekNumbersVisible {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarWeekRule Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CalendarWeekRule Property

Gets or sets how should the first week in the year be counted. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")>
<DefaultValueAttribute()>
Public Property CalendarWeekRule As Nullable(Of CalendarWeekRule)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of CalendarWeekRule)

instance.CalendarWeekRule = value

value = instance.CalendarWeekRule
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
[DefaultValueAttribute()]
public Nullable<CalendarWeekRule> CalendarWeekRule {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
[DefaultValueAttribute()]
public: __property Nullable<CalendarWeekRule> get_CalendarWeekRule();
public: __property void set_CalendarWeekRule(
   Nullable<CalendarWeekRule> value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
[DefaultValueAttribute()]
public:
property Nullable<CalendarWeekRule> CalendarWeekRule {
   Nullable<CalendarWeekRule> get();
   void set (Nullable<CalendarWeekRule> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewHeaderFormat Property

Gets or sets the format for the header of the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property CenturyViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As String

instance.CenturyViewHeaderFormat = value

value = instance.CenturyViewHeaderFormat
C#
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public string CenturyViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property string* get_CenturyViewHeaderFormat();
public: __property void set_CenturyViewHeaderFormat(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property String^ CenturyViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewPanel Property

Gets or sets the items panel template for the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property CenturyViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As ItemsPanelTemplate

instance.CenturyViewPanel = value

value = instance.CenturyViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate CenturyViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_CenturyViewPanel();
public: __property void set_CenturyViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ CenturyViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewStyle Property

Gets or sets the style of the century calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")>
Public Property CenturyViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.CenturyViewStyle = value

value = instance.CenturyViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
public Style CenturyViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
public: __property Style* get_CenturyViewStyle();
public: __property void set_CenturyViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
public:
property Style^ CenturyViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Columns Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : Columns Property

Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public int Columns {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property int Columns {
   int get();
   void set (int value);
}

Remarks

The minimum value of the Columns property is one and the maximum is four.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
Rows Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Culture Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : Culture Property

Gets or sets the culture that the Calendar uses. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public CultureInfo Culture {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property CultureInfo* get_Culture();
public: __property void set_Culture(
   CultureInfo* value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property CultureInfo^ Culture {
   CultureInfo^ get();
   void set (CultureInfo^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayButtonStyle Property

Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DayButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.DayButtonStyle = value

value = instance.DayButtonStyle
C#
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style DayButtonStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_DayButtonStyle();
public: __property void set_DayButtonStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ DayButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayButtonStyleSelector Property

Gets or sets the style selector for the day buttons in the month views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")>
<DefaultValueAttribute()>
Public Property DayButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As StyleSelector

instance.DayButtonStyleSelector = value

value = instance.DayButtonStyleSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
public StyleSelector DayButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
public: __property StyleSelector* get_DayButtonStyleSelector();
public: __property void set_DayButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
public:
property StyleSelector^ DayButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayTemplate Property

Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")>
Public Property DayTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplate

instance.DayTemplate = value

value = instance.DayTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public DataTemplate DayTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_DayTemplate();
public: __property void set_DayTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ DayTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayTemplateSelector Property

Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")>
Public Property DayTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplateSelector

instance.DayTemplateSelector = value

value = instance.DayTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public DataTemplateSelector DayTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_DayTemplateSelector();
public: __property void set_DayTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ DayTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeButtonStyle Property

Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.DecadeButtonStyle = value

value = instance.DecadeButtonStyle
C#
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style DecadeButtonStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_DecadeButtonStyle();
public: __property void set_DecadeButtonStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ DecadeButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeButtonStyleSelector Property

Gets or sets the style selector for the decade buttons in the century views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As StyleSelector

instance.DecadeButtonStyleSelector = value

value = instance.DecadeButtonStyleSelector
C#
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public StyleSelector DecadeButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property StyleSelector* get_DecadeButtonStyleSelector();
public: __property void set_DecadeButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property StyleSelector^ DecadeButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeTemplate Property

Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")>
Public Property DecadeTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplate

instance.DecadeTemplate = value

value = instance.DecadeTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
public DataTemplate DecadeTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_DecadeTemplate();
public: __property void set_DecadeTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ DecadeTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeTemplateSelector Property

Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")>
Public Property DecadeTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplateSelector

instance.DecadeTemplateSelector = value

value = instance.DecadeTemplateSelector
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public DataTemplateSelector DecadeTemplateSelector {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_DecadeTemplateSelector();
public: __property void set_DecadeTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ DecadeTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewHeaderFormat Property

Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")>
Public Property DecadeViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As String

instance.DecadeViewHeaderFormat = value

value = instance.DecadeViewHeaderFormat
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public string DecadeViewHeaderFormat {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public: __property string* get_DecadeViewHeaderFormat();
public: __property void set_DecadeViewHeaderFormat(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public:
property String^ DecadeViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewPanel Property

Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As ItemsPanelTemplate

instance.DecadeViewPanel = value

value = instance.DecadeViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate DecadeViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_DecadeViewPanel();
public: __property void set_DecadeViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ DecadeViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewStyle Property

Gets or sets the style of the decade calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")>
Public Property DecadeViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.DecadeViewStyle = value

value = instance.DecadeViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
public Style DecadeViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
public: __property Style* get_DecadeViewStyle();
public: __property void set_DecadeViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
public:
property Style^ DecadeViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDate Property

Gets or sets the current date to display. This is a dependency property.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property DisplayDate As Date
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Date

instance.DisplayDate = value

value = instance.DisplayDate
C#
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public DateTime DisplayDate {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property DateTime get_DisplayDate();
public: __property void set_DisplayDate(
   DateTime value
);
C++/CLI
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property DateTime DisplayDate {
   DateTime get();
   void set (DateTime value);
}

Remarks

The DisplayDate property specifies the date to display in the RadCalendar. If no display date was set, then the SelectedDate is used. Alternatively, if no date is selected then DateTime.Today is used.

Setting the display date does not affect the DisplayMode of the Calendar, e.g. if the DisplayMode is set to Year changing the DisplayDate within the same year would not change the view, while setting a DisplayDate of a different year would change the view.

Similarly to the other date properties of the Calendar, the time part of the DateTime object is not only ignored but set to 00:00:00 as well. See SelectedDate for an example and more infromation on that behaviour.

The DisplayDateStart and DisplayDateEnd properties defined a range within which the DisplayDate can be set, i.e. a range within which the user can navigate. If you try to set a DisplayDate outside the defined range an ArgumentOutOfRangeException would be thrown. Similarly, setting a display range that excludes the current DisplayDate would throw an exception.

Changing the DisplayDate property fires the DisplayDateChanged event. Please note that unless the DisplayDate is changed from code the event would fire only when the displayed month or year actually changes, i.e. selecting a day within the currenly viewed month would not fire the event (or cahnge the property). Selecting a month while the DisplayMode is Year would fire the event if the month is different from the previously selected.

Please note that unlike the other date properties DisplayDate cannot be set to null.

The following example show you how you can easily navigate the Calendar by setting the DisplayDate. In the example the Calendar jumps dates of events selected from a ListBox.

TODO: EXAMPLE: Add example code of example about DisplayDate.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
SelectedDate Property
DisplayDateStart Property
DisplayDateEnd Property
SelectableDateStart Property
SelectableDateEnd Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateEnd Property

Gets or sets the last date that would be able to be displayed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
Public Property DisplayDateEnd As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of Date)

instance.DisplayDateEnd = value

value = instance.DisplayDateEnd
C#
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public Nullable<DateTime> DisplayDateEnd {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_DisplayDateEnd();
public: __property void set_DisplayDateEnd(
   Nullable<DateTime> value
);
C++/CLI
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> DisplayDateEnd {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

The DisplayDateEnd property can limit the dates which can be navigated to. The DisplayDateEnd the date furthest away in time that can be shown. Setting the property to null would enable all dates to be viewed.

Please note that ArgumentOutOfRange exception would be thrown if the DisplayDateEnd is set to a date earlier than the currently displayed (DisplayDate).

More information about setting the displayble dates' range and an example can be found on the DisplayDateStart help page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
DisplayDateStart Property
DisplayDate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateStart Property

Gets or sets the first date that would be able to be displayed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property DisplayDateStart As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of Date)

instance.DisplayDateStart = value

value = instance.DisplayDateStart
C#
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public Nullable<DateTime> DisplayDateStart {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_DisplayDateStart();
public: __property void set_DisplayDateStart(
   Nullable<DateTime> value
);
C++/CLI
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> DisplayDateStart {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

The DisplayDateStart property together with DisplayDateEnd allows you to define a range within which the user would be able to navigate. The DisplayDateStart does not affect whether a date can be selected or not. Please refer to SelectableDateStart for more information on controlling selection.

For example setting the DisplayDateStart to DateTime.Today would ensure that the Calendar would not be able to navigate to the previous month or year but changing the DisplayMode or selecting dates from the current month is unaffected.

Similarly to the other date properties of the Calendar, the time part of the DateTime object is not only ignored but set to 00:00:00 as well. See SelectedDate for an example and more infromation on that behaviour.

Setting the DisplayDateStart to null means that DateTime.MinValue would be the start of the displayable range. The default values is null.

The example below demonstrates how tha navigation can be constrained within the current year.

TODO: EXAMPLE: Add displayDate constraint example.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
SelectedDate Property
DisplayDateStart Property
DisplayDateEnd Property
SelectableDateStart Property
SelectableDateEnd Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayMode Property

Gets or sets the display mode of the Calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public DisplayMode DisplayMode {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property DisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   DisplayMode value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (DisplayMode value);
}

Remarks

The DisplayMode property controls the span of time the calendar is currenly displaying - a month or a year.

The display mode can be changed to Year by clicking the calendar header between the previous and next buttons and to Month by choosing a month from the list of months. Alternatively the DisplayMode can be changed programmaticcally although this is not recommeded since that may contradict user expectations.

    The DisplayModes available are:
  • CalendarMode.Month: The Calendar displays a month, days from the previous or next months can also be visible but are visually differentiated and clicking them would navigate to the respective month. The names of the days are localized according to the current thread culture.
  • CalendarMode.Year: The Calendar displays a year - twelve buttons with the localized names of the months. The current thread culture is used for the localizaton.

The DisplayModeChanged event is fired when the property changes. The CalendarModeChangedEventArgs provide the old and new value of the display mode. An example where the event is used can be found on the SelectedDate help page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
SelectedDate Property
CalendarModeChangedEventArgs Class
DisplayModeChanged Event
DisplayMode Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FirstDayOfWeek Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : FirstDayOfWeek Property

Gets or sets the day that is considered the beginning of the week.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property FirstDayOfWeek As Nullable(Of DayOfWeek)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of DayOfWeek)

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public Nullable<DayOfWeek> FirstDayOfWeek {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property Nullable<DayOfWeek> get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   Nullable<DayOfWeek> value
);
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property Nullable<DayOfWeek> FirstDayOfWeek {
   Nullable<DayOfWeek> get();
   void set (Nullable<DayOfWeek> value);
}

Remarks

The FirstDayOfWeek property specifies which is the day in the leftmost column of the calendar view, i.e. which is the first day of the week. The default value is Sunday.

Generally, the start of the week varies with different cultures so if you would like the Calendar to display the dates as expected, be sure to set the FirstDayOfWeek property to match the localized value, e.g:

calendar.FirstDayOfWeek = CultureInfo.CurrentCulture.DateTimeFormat.FirstDayOfWeek;

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
DisplayMode Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : HeaderVisibility Property

Gets or sets the visibility of the Calendar's header. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property HeaderVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Visibility

instance.HeaderVisibility = value

value = instance.HeaderVisibility
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public Visibility HeaderVisibility {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property Visibility get_HeaderVisibility();
public: __property void set_HeaderVisibility(
   Visibility value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property Visibility HeaderVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsEnabled Property

Gets or sets whether the Calenadar is enable

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsLoaded Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsLoaded Property

Gets a value that indicates whether this element has been loaded for presentation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLoaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

value = instance.IsLoaded
C#
public bool IsLoaded {get;}
Managed Extensions for C++
public: __property bool get_IsLoaded();
C++/CLI
public:
property bool IsLoaded {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnly Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsReadOnly Property

Gets or sets whether the Calendar's selection can be changed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
Public Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

instance.IsReadOnly = value

value = instance.IsReadOnly
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public bool IsReadOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public: __property bool get_IsReadOnly();
public: __property void set_IsReadOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public:
property bool IsReadOnly {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsTodayHighlighted Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsTodayHighlighted Property

Gets or sets whether the today date would be highlighted. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property IsTodayHighlighted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Boolean

instance.IsTodayHighlighted = value

value = instance.IsTodayHighlighted
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool IsTodayHighlighted {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_IsTodayHighlighted();
public: __property void set_IsTodayHighlighted(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool IsTodayHighlighted {
   bool get();
   void set (bool value);
}

Remarks

The IsTodayHighlighted property indicates whether the today date in the calendar would be highlighted. The default value is true.

Please note that the IsTodayHighlighted property does not affect whether the today date is selected or not. Use the SelectedDate or SelectedDates properties to specify the selected date(s).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
SelectedDate Property
SelectedDates Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthButtonStyle Property

Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.MonthButtonStyle = value

value = instance.MonthButtonStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public Style MonthButtonStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property Style* get_MonthButtonStyle();
public: __property void set_MonthButtonStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property Style^ MonthButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthButtonStyleSelector Property

Gets or sets the style selector for the month buttons in the year views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")>
<SRCategoryAttribute("Appearance")>
Public Property MonthButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As StyleSelector

instance.MonthButtonStyleSelector = value

value = instance.MonthButtonStyleSelector
C#
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public StyleSelector MonthButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public: __property StyleSelector* get_MonthButtonStyleSelector();
public: __property void set_MonthButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public:
property StyleSelector^ MonthButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthTemplate Property

Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplate

instance.MonthTemplate = value

value = instance.MonthTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public DataTemplate MonthTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_MonthTemplate();
public: __property void set_MonthTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ MonthTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthTemplateSelector Property

Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplateSelector

instance.MonthTemplateSelector = value

value = instance.MonthTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public DataTemplateSelector MonthTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_MonthTemplateSelector();
public: __property void set_MonthTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ MonthTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewHeaderFormat Property

Gets or sets the format for the header of the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")>
Public Property MonthViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As String

instance.MonthViewHeaderFormat = value

value = instance.MonthViewHeaderFormat
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
public string MonthViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
public: __property string* get_MonthViewHeaderFormat();
public: __property void set_MonthViewHeaderFormat(
   string* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
public:
property String^ MonthViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewPanel Property

Gets or sets the items panel template for the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property MonthViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As ItemsPanelTemplate

instance.MonthViewPanel = value

value = instance.MonthViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate MonthViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_MonthViewPanel();
public: __property void set_MonthViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ MonthViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewStyle Property

Gets or sets the style of the month calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")>
Public Property MonthViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.MonthViewStyle = value

value = instance.MonthViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public Style MonthViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public: __property Style* get_MonthViewStyle();
public: __property void set_MonthViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public:
property Style^ MonthViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : Orientation Property

Gets or sets whether the orientation of the Calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Rows Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : Rows Property

Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")>
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
public int Rows {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
public:
property int Rows {
   int get();
   void set (int value);
}

Remarks

The minimum value of the Rows property is one and the maximum is four.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
Columns Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectableDateEnd Property

Gets or sets the last date that can be selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Behavior")>
Public Property SelectableDateEnd As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of Date)

instance.SelectableDateEnd = value

value = instance.SelectableDateEnd
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
public Nullable<DateTime> SelectableDateEnd {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
public: __property Nullable<DateTime> get_SelectableDateEnd();
public: __property void set_SelectableDateEnd(
   Nullable<DateTime> value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Behavior")]
public:
property Nullable<DateTime> SelectableDateEnd {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectableDateStart Property

Gets or sets the first date that can be selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRDescriptionAttribute("")>
Public Property SelectableDateStart As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of Date)

instance.SelectableDateStart = value

value = instance.SelectableDateStart
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRDescriptionAttribute("")]
public Nullable<DateTime> SelectableDateStart {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_SelectableDateStart();
public: __property void set_SelectableDateStart(
   Nullable<DateTime> value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> SelectableDateStart {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedDate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectedDate Property

Gets or sets the currently selected date. This is a dependency property.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property SelectedDate As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Nullable(Of Date)

instance.SelectedDate = value

value = instance.SelectedDate
C#
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public Nullable<DateTime> SelectedDate {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property Nullable<DateTime> get_SelectedDate();
public: __property void set_SelectedDate(
   Nullable<DateTime> value
);
C++/CLI
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property Nullable<DateTime> SelectedDate {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

The SelectedDate property identifies the last date that has been selected. If more than one date needs to be selected, please see the SelectedDates property.

Setting the SelectedDate proeprty to null would deselect any selection. The default value is null.

Selecting a date fires the SelectedDate event. An example about handling events is provided below.

Please note that the user would not be able to select dates outside the SelctdableDates range defined by the SelectableDateStart and SelectableDateEnd properties. Setting a date outside this range in code would result in an ArgumentOutOfRangeException.

Note that all DateTime properties of the RadCalendar discard the time of the DateTime object, i.e. the time is coerced to 0:0:0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedDates Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectedDates Property

Gets an list of the currenly selected dates.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
Public ReadOnly Property SelectedDates As IList(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As IList(Of Date)

value = instance.SelectedDates
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public IList<DateTime> SelectedDates {get;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public: __property IList<DateTime>* get_SelectedDates();
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public:
property IList<DateTime>^ SelectedDates {
   IList<DateTime>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectionMode Property

Gets or sets the types of selection that would be allowed in the Calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
Public Property SelectionMode As SelectionMode
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As SelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public SelectionMode SelectionMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (SelectionMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ViewsHeaderVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : ViewsHeaderVisibility Property

Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property ViewsHeaderVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Visibility

instance.ViewsHeaderVisibility = value

value = instance.ViewsHeaderVisibility
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public Visibility ViewsHeaderVisibility {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property Visibility get_ViewsHeaderVisibility();
public: __property void set_ViewsHeaderVisibility(
   Visibility value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property Visibility ViewsHeaderVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearButtonStyle Property

Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property YearButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.YearButtonStyle = value

value = instance.YearButtonStyle
C#
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style YearButtonStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_YearButtonStyle();
public: __property void set_YearButtonStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ YearButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearButtonStyleSelector Property

Gets or sets the style selector for the year buttons in the decade views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")>
Public Property YearButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As StyleSelector

instance.YearButtonStyleSelector = value

value = instance.YearButtonStyleSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
public StyleSelector YearButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
public: __property StyleSelector* get_YearButtonStyleSelector();
public: __property void set_YearButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
public:
property StyleSelector^ YearButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearTemplate Property

Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")>
Public Property YearTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplate

instance.YearTemplate = value

value = instance.YearTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
public DataTemplate YearTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_YearTemplate();
public: __property void set_YearTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ YearTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearTemplateSelector Property

Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")>
<DefaultValueAttribute()>
Public Property YearTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As DataTemplateSelector

instance.YearTemplateSelector = value

value = instance.YearTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public DataTemplateSelector YearTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public: __property DataTemplateSelector* get_YearTemplateSelector();
public: __property void set_YearTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public:
property DataTemplateSelector^ YearTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewHeaderFormat Property

Gets or sets the format for the header of the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property YearViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As String

instance.YearViewHeaderFormat = value

value = instance.YearViewHeaderFormat
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public string YearViewHeaderFormat {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property string* get_YearViewHeaderFormat();
public: __property void set_YearViewHeaderFormat(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property String^ YearViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewPanel Property

Gets or sets the items panel template for the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property YearViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As ItemsPanelTemplate

instance.YearViewPanel = value

value = instance.YearViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate YearViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_YearViewPanel();
public: __property void set_YearViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ YearViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewStyle Property

Gets or sets the style of the calendar year view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")>
Public Property YearViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim value As Style

instance.YearViewStyle = value

value = instance.YearViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public Style YearViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public: __property Style* get_YearViewStyle();
public: __property void set_YearViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public:
property Style^ YearViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

For a list of all members of this type, see RadCalendar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AreWeekNamesVisibleProperty | Identifies the AreWeekNamesVisible proeprty.
static (Shared in Visual Basic) | AreWeekNumbersVisibleProperty | Identifies the AreWeekNumbersVisible proeprty.
static (Shared in Visual Basic) | CalendarWeekRuleProperty | Identifies the CalendarWeekRule property.
static (Shared in Visual Basic) | CenturyViewHeaderFormatProperty | Identifies the CenturyViewHeaderFormat property.
static (Shared in Visual Basic) | CenturyViewPanelProperty | Identifies the CenturyViewPanel property.
static (Shared in Visual Basic) | CenturyViewStyleProperty | Identifies the CenturyViewStyle property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | CultureProperty | Indetifies the Culture property.
static (Shared in Visual Basic) | DayButtonStyleProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DayButtonStyleSelectorProperty | Identifies the DayButtonStyleSelector property.
static (Shared in Visual Basic) | DayTemplateProperty | Identifies the DayTemplate property.
static (Shared in Visual Basic) | DayTemplateSelectorProperty | Identifies the DayTemplateSelector property.
static (Shared in Visual Basic) | DecadeButtonStyleProperty | Identifies the DecadeButtonStyle property.
static (Shared in Visual Basic) | DecadeButtonStyleSelectorProperty | Identifies the DecadeButtonStyleSelector property.
static (Shared in Visual Basic) | DecadeTemplateProperty | Identifies the DecadeTemplate property.
static (Shared in Visual Basic) | DecadeTemplateSelectorProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DecadeViewHeaderFormatProperty | Identifies the DecadeViewHeaderFormat property.
static (Shared in Visual Basic) | DecadeViewPanelProperty | Identifies the DecadeViewPanel property.
static (Shared in Visual Basic) | DecadeViewStyleProperty | Identifies the DecadeViewStyle property.
static (Shared in Visual Basic) | DisplayDateEndProperty | Identifies the DisplayDateEnd Property.
static (Shared in Visual Basic) | DisplayDateProperty | Identifies the DisplayDate property.
static (Shared in Visual Basic) | DisplayDateStartProperty | Identifies the DisplayDateStartProperty.
static (Shared in Visual Basic) | DisplayModeProperty | Identifies the DisplayMode Property.
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the first day of week property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled property.
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the ReadOnly proeprty.
static (Shared in Visual Basic) | IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property.
static (Shared in Visual Basic) | MaxDate | Gets the latest date that the calendar can display.
static (Shared in Visual Basic) | MinDate | Gets the earliest date that the calendar can display.
static (Shared in Visual Basic) | MonthButtonStyleProperty | Identifies the MonthButtonStyle property.
static (Shared in Visual Basic) | MonthButtonStyleSelectorProperty | Identifies the MonthButtonStyleSelector property.
static (Shared in Visual Basic) | MonthTemplateProperty | Identifies the MonthTemplate property.
static (Shared in Visual Basic) | MonthTemplateSelectorProperty | Identifies the MonthTemplateSelector property.
static (Shared in Visual Basic) | MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat property.
static (Shared in Visual Basic) | MonthViewPanelProperty | Identifies the MonthViewPanel property.
static (Shared in Visual Basic) | MonthViewStyleProperty | Identifies the MonthViewStyle property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
static (Shared in Visual Basic) | SelectableDateEndProperty | Identifies the SelectableDateEnd property.
static (Shared in Visual Basic) | SelectableDateStartProperty | Identifies the SelectableDateStart dependency property.
static (Shared in Visual Basic) | SelectedDateProperty | Identifies the SelectedDate dependency property.
static (Shared in Visual Basic) | SelectionModeProperty | Identifies the SelectionMode dependency property.
static (Shared in Visual Basic) | ViewsHeaderVisibilityProperty | Identifies the ViewsHeaderVisibility property.
static (Shared in Visual Basic) | YearButtonStyleProperty | Identifies the YearButtonStyle property.
static (Shared in Visual Basic) | YearButtonStyleSelectorProperty | Identifies the YearButtonStyleSelector property.
static (Shared in Visual Basic) | YearTemplateProperty | Identifies the YearTemplate property.
static (Shared in Visual Basic) | YearTemplateSelectorProperty | Identifies the YearTemplateSelector property.
static (Shared in Visual Basic) | YearViewHeaderFormatProperty | Identifies the YearViewHeaderFormat property.
static (Shared in Visual Basic) | YearViewPanelProperty | Identifies the YearViewPanel property.
static (Shared in Visual Basic) | YearViewStyleProperty | Identifies the YearViewStyle property.
Top

See Also

Reference

RadCalendar Class
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AreWeekNamesVisibleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : AreWeekNamesVisibleProperty Field

Identifies the AreWeekNamesVisible proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AreWeekNamesVisibleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.AreWeekNamesVisibleProperty
C#
public static readonly DependencyProperty AreWeekNamesVisibleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AreWeekNamesVisibleProperty
C++/CLI
public:
static readonly DependencyProperty^ AreWeekNamesVisibleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AreWeekNumbersVisibleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : AreWeekNumbersVisibleProperty Field

Identifies the AreWeekNumbersVisible proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AreWeekNumbersVisibleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.AreWeekNumbersVisibleProperty
C#
public static readonly DependencyProperty AreWeekNumbersVisibleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AreWeekNumbersVisibleProperty
C++/CLI
public:
static readonly DependencyProperty^ AreWeekNumbersVisibleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarWeekRuleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CalendarWeekRuleProperty Field

Identifies the CalendarWeekRule property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CalendarWeekRuleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.CalendarWeekRuleProperty
C#
public static readonly DependencyProperty CalendarWeekRuleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CalendarWeekRuleProperty
C++/CLI
public:
static readonly DependencyProperty^ CalendarWeekRuleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewHeaderFormatProperty Field

Identifies the CenturyViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.CenturyViewHeaderFormatProperty
C#
public static readonly DependencyProperty CenturyViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewPanelProperty Field

Identifies the CenturyViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.CenturyViewPanelProperty
C#
public static readonly DependencyProperty CenturyViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CenturyViewStyleProperty Field

Identifies the CenturyViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.CenturyViewStyleProperty
C#
public static readonly DependencyProperty CenturyViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ColumnsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : ColumnsProperty Field

Identifies the Columns property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.ColumnsProperty
C#
public static readonly DependencyProperty ColumnsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ColumnsProperty
C++/CLI
public:
static readonly DependencyProperty^ ColumnsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CultureProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : CultureProperty Field

Indetifies the Culture property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.CultureProperty
C#
public static readonly DependencyProperty CultureProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CultureProperty
C++/CLI
public:
static readonly DependencyProperty^ CultureProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayButtonStyleProperty Field

Identifies the DayButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DayButtonStyleProperty
C#
public static readonly DependencyProperty DayButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DayButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayButtonStyleSelectorProperty Field

Identifies the DayButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DayButtonStyleSelectorProperty
C#
public static readonly DependencyProperty DayButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DayButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayTemplateProperty Field

Identifies the DayTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DayTemplateProperty
C#
public static readonly DependencyProperty DayTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ DayTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DayTemplateSelectorProperty Field

Identifies the DayTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DayTemplateSelectorProperty
C#
public static readonly DependencyProperty DayTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DayTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeButtonStyleProperty Field

Identifies the DecadeButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeButtonStyleProperty
C#
public static readonly DependencyProperty DecadeButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeButtonStyleSelectorProperty Field

Identifies the DecadeButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeButtonStyleSelectorProperty
C#
public static readonly DependencyProperty DecadeButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeTemplateProperty Field

Identifies the DecadeTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeTemplateProperty
C#
public static readonly DependencyProperty DecadeTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeTemplateSelectorProperty Field

Identifies the DayButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeTemplateSelectorProperty
C#
public static readonly DependencyProperty DecadeTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewHeaderFormatProperty Field

Identifies the DecadeViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeViewHeaderFormatProperty
C#
public static readonly DependencyProperty DecadeViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewPanelProperty Field

Identifies the DecadeViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeViewPanelProperty
C#
public static readonly DependencyProperty DecadeViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DecadeViewStyleProperty Field

Identifies the DecadeViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DecadeViewStyleProperty
C#
public static readonly DependencyProperty DecadeViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateEndProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateEndProperty Field

Identifies the DisplayDateEnd Property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateEndProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DisplayDateEndProperty
C#
public static readonly DependencyProperty DisplayDateEndProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateEndProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateEndProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateProperty Field

Identifies the DisplayDate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DisplayDateProperty
C#
public static readonly DependencyProperty DisplayDateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateStartProperty Field

Identifies the DisplayDateStartProperty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DisplayDateStartProperty
C#
public static readonly DependencyProperty DisplayDateStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateStartProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayModeProperty Field

Identifies the DisplayMode Property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.DisplayModeProperty
C#
public static readonly DependencyProperty DisplayModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayModeProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FirstDayOfWeekProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : FirstDayOfWeekProperty Field

Identifies the first day of week property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FirstDayOfWeekProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.FirstDayOfWeekProperty
C#
public static readonly DependencyProperty FirstDayOfWeekProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FirstDayOfWeekProperty
C++/CLI
public:
static readonly DependencyProperty^ FirstDayOfWeekProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : HeaderVisibilityProperty Field

Identifies the HeaderVisibility property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.HeaderVisibilityProperty
C#
public static readonly DependencyProperty HeaderVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsEnabledProperty Field

Identifies the IsEnabled property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnlyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsReadOnlyProperty Field

Identifies the ReadOnly proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.IsReadOnlyProperty
C#
public static readonly DependencyProperty IsReadOnlyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsReadOnlyProperty
C++/CLI
public:
static readonly DependencyProperty^ IsReadOnlyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsTodayHighlightedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : IsTodayHighlightedProperty Field

Identifies the IsTodayHighlighted dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsTodayHighlightedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.IsTodayHighlightedProperty
C#
public static readonly DependencyProperty IsTodayHighlightedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsTodayHighlightedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsTodayHighlightedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxDate Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MaxDate Field

Gets the latest date that the calendar can display.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxDate As Date
Visual Basic (Usage) Copy Code
Dim value As Date

value = RadCalendar.MaxDate
C#
public static readonly DateTime MaxDate
Managed Extensions for C++
public: static readonly DateTime MaxDate
C++/CLI
public:
static readonly DateTime MaxDate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MinDate Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MinDate Field

Gets the earliest date that the calendar can display.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinDate As Date
Visual Basic (Usage) Copy Code
Dim value As Date

value = RadCalendar.MinDate
C#
public static readonly DateTime MinDate
Managed Extensions for C++
public: static readonly DateTime MinDate
C++/CLI
public:
static readonly DateTime MinDate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthButtonStyleProperty Field

Identifies the MonthButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthButtonStyleProperty
C#
public static readonly DependencyProperty MonthButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthButtonStyleSelectorProperty Field

Identifies the MonthButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthButtonStyleSelectorProperty
C#
public static readonly DependencyProperty MonthButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthTemplateProperty Field

Identifies the MonthTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthTemplateProperty
C#
public static readonly DependencyProperty MonthTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthTemplateSelectorProperty Field

Identifies the MonthTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthTemplateSelectorProperty
C#
public static readonly DependencyProperty MonthTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewHeaderFormatProperty Field

Identifies the MonthViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthViewHeaderFormatProperty
C#
public static readonly DependencyProperty MonthViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewPanelProperty Field

Identifies the MonthViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthViewPanelProperty
C#
public static readonly DependencyProperty MonthViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : MonthViewStyleProperty Field

Identifies the MonthViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.MonthViewStyleProperty
C#
public static readonly DependencyProperty MonthViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : OrientationProperty Field

Identifies the Orientation property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RowsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : RowsProperty Field

Identifies the Rows property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RowsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.RowsProperty
C#
public static readonly DependencyProperty RowsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RowsProperty
C++/CLI
public:
static readonly DependencyProperty^ RowsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateEndProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectableDateEndProperty Field

Identifies the SelectableDateEnd property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectableDateEndProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.SelectableDateEndProperty
C#
public static readonly DependencyProperty SelectableDateEndProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectableDateEndProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectableDateEndProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectableDateStartProperty Field

Identifies the SelectableDateStart dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectableDateStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.SelectableDateStartProperty
C#
public static readonly DependencyProperty SelectableDateStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectableDateStartProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectableDateStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedDateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectedDateProperty Field

Identifies the SelectedDate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedDateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.SelectedDateProperty
C#
public static readonly DependencyProperty SelectedDateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedDateProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedDateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectionModeProperty Field

Identifies the SelectionMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.SelectionModeProperty
C#
public static readonly DependencyProperty SelectionModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionModeProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ViewsHeaderVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : ViewsHeaderVisibilityProperty Field

Identifies the ViewsHeaderVisibility property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ViewsHeaderVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.ViewsHeaderVisibilityProperty
C#
public static readonly DependencyProperty ViewsHeaderVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ViewsHeaderVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ ViewsHeaderVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearButtonStyleProperty Field

Identifies the YearButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearButtonStyleProperty
C#
public static readonly DependencyProperty YearButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ YearButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearButtonStyleSelectorProperty Field

Identifies the YearButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearButtonStyleSelectorProperty
C#
public static readonly DependencyProperty YearButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ YearButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearTemplateProperty Field

Identifies the YearTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearTemplateProperty
C#
public static readonly DependencyProperty YearTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ YearTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearTemplateSelectorProperty Field

Identifies the YearTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearTemplateSelectorProperty
C#
public static readonly DependencyProperty YearTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ YearTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewHeaderFormatProperty Field

Identifies the YearViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearViewHeaderFormatProperty
C#
public static readonly DependencyProperty YearViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewPanelProperty Field

Identifies the YearViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearViewPanelProperty
C#
public static readonly DependencyProperty YearViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : YearViewStyleProperty Field

Identifies the YearViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCalendar.YearViewStyleProperty
C#
public static readonly DependencyProperty YearViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadCalendar Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadCalendar Class

For a list of all members of this type, see RadCalendar members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DisplayDateChanged | Occurs when the DisplayDate property is changed.
Public Event | DisplayModeChanged | Occurs when the DisplayMode property is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when a date is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadCalendar Class
Telerik.Windows.Controls Namespace
SelectedDate Property
DisplayDate Property
SelectableDateStart Property
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayDateChanged Event

Occurs when the DisplayDate property is changed.

Syntax

Visual Basic (Declaration)
Public Event DisplayDateChanged() As EventHandler(Of CalendarDateChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim handler As EventHandler(Of CalendarDateChangedEventArgs)

AddHandler instance.DisplayDateChanged, handler
C#
public event EventHandler<CalendarDateChangedEventArgs> DisplayDateChanged()
Managed Extensions for C++
public: __event EventHandler<CalendarDateChangedEventArgs*>* DisplayDateChanged
C++/CLI
public:
event EventHandler<CalendarDateChangedEventArgs^>^ DisplayDateChanged

Remarks

The DisplayDateChanged event is fired when the DisplayDate property of the calendar changes.

For more information on the event go to the DisplayDate help article. An example where the event is used can be found on the SelectedDate help page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
RadCalendar Class
DisplayDate Property
SelectedDate Property
DisplayDateStart Property
DisplayDateEnd Property
CalendarDateChangedEventArgs Class


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayModeChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : DisplayModeChanged Event

Occurs when the DisplayMode property is changed.

Syntax

Visual Basic (Declaration)
Public Event DisplayModeChanged() As EventHandler(Of CalendarModeChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim handler As EventHandler(Of CalendarModeChangedEventArgs)

AddHandler instance.DisplayModeChanged, handler
C#
public event EventHandler<CalendarModeChangedEventArgs> DisplayModeChanged()
Managed Extensions for C++
public: __event EventHandler<CalendarModeChangedEventArgs*>* DisplayModeChanged
C++/CLI
public:
event EventHandler<CalendarModeChangedEventArgs^>^ DisplayModeChanged

Remarks

The DisplayModeChanged event is fired when the DisplayDate proeprty changes.

For more infromation please go to the DisplayMode article. An example where the event is used can be found on the SelectedDate help page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
RadCalendar Class
DisplayMode Property
SelectedDate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadCalendar Class : SelectionChanged Event

Occurs when a date is selected.

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged() As EventHandler(Of SelectionChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadCalendar
Dim handler As EventHandler(Of SelectionChangedEventArgs)

AddHandler instance.SelectionChanged, handler
C#
public event EventHandler<SelectionChangedEventArgs> SelectionChanged()
Managed Extensions for C++
public: __event EventHandler<SelectionChangedEventArgs*>* SelectionChanged
C++/CLI
public:
event EventHandler<SelectionChangedEventArgs^>^ SelectionChanged

Remarks

The DateSelected event is fired when the selected date is changed.

The DateSelected is designed to be used in single selction mode. For more information on handling events in multiple selection mode, please refer to SelectedDates help article.

For more information and examples on selecting dates please refer to help page for the SelectedDate property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCalendar Class
RadCalendar Members
RadCalendar Class
SelectedDate Property
SelectableDateStart Property
SelectableDateEnd Property
CalendarDateChangedEventArgs Class


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

Represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadComboBox
   Inherits Selector
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
C#
public class RadComboBox : Selector, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadComboBox : public Selector, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadComboBox : public Selector, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.Selector
Telerik.Windows.Controls.RadComboBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

The following tables list the members exposed by RadComboBox.

Public Constructors

 | Name | Description
Public Constructor | RadComboBox Constructor | Initializes a new instance of the RadComboBox class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DropDownWidthProperty | Identifies the DropDownWidth dependency property
static (Shared in Visual Basic) | FilteringModeProperty | Identifies the FilteringMode dependency property.
static (Shared in Visual Basic) | IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | IsHighlightedProperty |
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
static (Shared in Visual Basic) | MaxDropDownHeightProperty | Identifies the MaxDropDownHeight dependency property.
static (Shared in Visual Basic) | SelectionBoxItemProperty | Identifies the SelectionBoxItem dependency property.
static (Shared in Visual Basic) | SelectionBoxItemTemplateProperty | Identifies the SelectionBoxItemTemplate dependency property.
static (Shared in Visual Basic) | StaysOpenOnEditProperty | Identifies the StaysOpenOnEdit dependency property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | DropDownWidth | Gets or sets the width for a RadComboBox drop-down. This is a dependency property.
Public Property | FilteringMode | Specifies the filtering mode for the RadComboBox. This is a dependency property.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDropDownOpen | Gets or sets the value that indicates whether the RadComboBox dropdown is currently open. This is a dependency property.
Public Property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the RadComboBox. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value indicating whether the RadComboBox is enabled.
Public Property | IsFocused | Gets a value that determines whether this element has focus. This is a dependency property.
Public Property | IsHighlighted |
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the RadComboBox are selectable but not editable. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxDropDownHeight | Gets or sets the maximum height for a RadComboBox drop-down. This is a dependency property.
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector)
Public Property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector)
Public Property | SelectionBoxItem | Gets or sets ... This is a dependency property.
Public Property | SelectionBoxItemTemplate | Gets or sets ... This is a dependency property.
Public Property | StaysOpenOnEdit | Gets or sets whether a RadComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Text | Gets or sets the text of the currently selected item. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnDropDownClosed | Raises the E:DropDownClosed event.
Protected Method | OnDropDownOpened | Raises the E:DropDownOpened event.
Protected Method | OnIsDropDownOpenChanged | Called when the IsDropDownOpen property is changed
Protected Method | OnIsEditableChanged | Called when the IsEditable property is changed.
Protected Method | OnIsReadOnlyChanged | Called when the IsReadOnly property is changed.
Protected Method | OnItemsChanged | Invoked when the Items property changes. (Inherited from Selector)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectionChanged | Overridden. Called when the selection changes.
Protected Method | OnTextChanged | Called when the Text property is changed.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DropDownClosed | Occurs when the drop-down list of the combo box closes.
Public Event | DropDownOpened | Occurs when the drop-down list of the combo box opens.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadComboBox Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : RadComboBox Constructor

Initializes a new instance of the RadComboBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox()
C#
public RadComboBox()
Managed Extensions for C++
public: RadComboBox();
C++/CLI
public:
RadComboBox();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

For a list of all members of this type, see RadComboBox members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnDropDownClosed | Raises the E:DropDownClosed event.
Protected Method | OnDropDownOpened | Raises the E:DropDownOpened event.
Protected Method | OnIsDropDownOpenChanged | Called when the IsDropDownOpen property is changed
Protected Method | OnIsEditableChanged | Called when the IsEditable property is changed.
Protected Method | OnIsReadOnlyChanged | Called when the IsReadOnly property is changed.
Protected Method | OnItemsChanged | Invoked when the Items property changes. (Inherited from Selector)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectionChanged | Overridden. Called when the selection changes.
Protected Method | OnTextChanged | Called when the Text property is changed.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadComboBox Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : ClearContainerForItemOverride Method

element
The container element.
item
The Item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The Item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnDropDownClosed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnDropDownClosed Method

e
The EventArgs instance containing the event data.
Raises the E:DropDownClosed event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDropDownClosed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim e As EventArgs

instance.OnDropDownClosed(e)
C#
protected virtual void OnDropDownClosed(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDropDownClosed(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDropDownClosed(
   EventArgs^ e
)

Parameters

e
The EventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnDropDownOpened Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnDropDownOpened Method

e
The EventArgs instance containing the event data.
Raises the E:DropDownOpened event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDropDownOpened( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim e As EventArgs

instance.OnDropDownOpened(e)
C#
protected virtual void OnDropDownOpened(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDropDownOpened(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDropDownOpened(
   EventArgs^ e
)

Parameters

e
The EventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnIsDropDownOpenChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnIsDropDownOpenChanged Method

oldValue
The old value of the IsDropDownOpen property
newValue
The new value of the IsDropDownOpen property
Called when the IsDropDownOpen property is changed

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsDropDownOpenChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsDropDownOpenChanged(oldValue, newValue)
C#
protected virtual void OnIsDropDownOpenChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsDropDownOpenChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsDropDownOpenChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The old value of the IsDropDownOpen property
newValue
The new value of the IsDropDownOpen property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnIsEditableChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnIsEditableChanged Method

oldValue
The old value of the IsEditable property
newValue
The new value of the IsEditable property
Called when the IsEditable property is changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsEditableChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsEditableChanged(oldValue, newValue)
C#
protected virtual void OnIsEditableChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsEditableChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsEditableChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The old value of the IsEditable property
newValue
The new value of the IsEditable property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnIsReadOnlyChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnIsReadOnlyChanged Method

oldValue
The old value of the IsReadOnly property
newValue
The new value of the IsReadOnly property
Called when the IsReadOnly property is changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsReadOnlyChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsReadOnlyChanged(oldValue, newValue)
C#
protected virtual void OnIsReadOnlyChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsReadOnlyChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsReadOnlyChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The old value of the IsReadOnly property
newValue
The new value of the IsReadOnly property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnSelectionChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnSelectionChanged Method

e
The event data.
Called when the selection changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
C#
protected override void OnSelectionChanged(
   SelectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnSelectionChanged(
   SelectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnSelectionChanged(
   SelectionChangedEventArgs^ e
) override

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnTextChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : OnTextChanged Method

oldValue
The old value of the Text property
newValue
The new value of the Text property
Called when the Text property is changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTextChanged( _
   ByVal oldValue As String, _
   ByVal newValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim oldValue As String
Dim newValue As String

instance.OnTextChanged(oldValue, newValue)
C#
protected virtual void OnTextChanged(
   string oldValue,
   string newValue
)
Managed Extensions for C++
protected: virtual void OnTextChanged(
   string* oldValue,
   string* newValue
)
C++/CLI
protected:
virtual void OnTextChanged(
   String^ oldValue,
   String^ newValue
)

Parameters

oldValue
The old value of the Text property
newValue
The new value of the Text property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

For a list of all members of this type, see RadComboBox members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | DropDownWidth | Gets or sets the width for a RadComboBox drop-down. This is a dependency property.
Public Property | FilteringMode | Specifies the filtering mode for the RadComboBox. This is a dependency property.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDropDownOpen | Gets or sets the value that indicates whether the RadComboBox dropdown is currently open. This is a dependency property.
Public Property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the RadComboBox. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value indicating whether the RadComboBox is enabled.
Public Property | IsFocused | Gets a value that determines whether this element has focus. This is a dependency property.
Public Property | IsHighlighted |
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the RadComboBox are selectable but not editable. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxDropDownHeight | Gets or sets the maximum height for a RadComboBox drop-down. This is a dependency property.
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector)
Public Property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector)
Public Property | SelectionBoxItem | Gets or sets ... This is a dependency property.
Public Property | SelectionBoxItemTemplate | Gets or sets ... This is a dependency property.
Public Property | StaysOpenOnEdit | Gets or sets whether a RadComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Text | Gets or sets the text of the currently selected item. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadComboBox Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DropDownWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : DropDownWidth Property

Gets or sets the width for a RadComboBox drop-down. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property DropDownWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Double

instance.DropDownWidth = value

value = instance.DropDownWidth
C#
public double DropDownWidth {get; set;}
Managed Extensions for C++
public: __property double get_DropDownWidth();
public: __property void set_DropDownWidth(
   double value
);
C++/CLI
public:
property double DropDownWidth {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilteringMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : FilteringMode Property

Specifies the filtering mode for the RadComboBox. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property FilteringMode As FilteringMode
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As FilteringMode

instance.FilteringMode = value

value = instance.FilteringMode
C#
public FilteringMode FilteringMode {get; set;}
Managed Extensions for C++
public: __property FilteringMode get_FilteringMode();
public: __property void set_FilteringMode(
   FilteringMode value
);
C++/CLI
public:
property FilteringMode FilteringMode {
   FilteringMode get();
   void set (FilteringMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDropDownOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsDropDownOpen Property

Gets or sets the value that indicates whether the RadComboBox dropdown is currently open. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsDropDownOpen = value

value = instance.IsDropDownOpen
C#
public bool IsDropDownOpen {get; set;}
Managed Extensions for C++
public: __property bool get_IsDropDownOpen();
public: __property void set_IsDropDownOpen(
   bool value
);
C++/CLI
public:
property bool IsDropDownOpen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEditable Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsEditable Property

Gets or sets a value that enables or disables editing of the text in text box of the RadComboBox. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsEditable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsEditable = value

value = instance.IsEditable
C#
public bool IsEditable {get; set;}
Managed Extensions for C++
public: __property bool get_IsEditable();
public: __property void set_IsEditable(
   bool value
);
C++/CLI
public:
property bool IsEditable {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsEnabled Property

Gets or sets a value indicating whether the RadComboBox is enabled.

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Return Value

true if this instance is enabled; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsFocused Property

Gets a value that determines whether this element has focus. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsFocused = value

value = instance.IsFocused
C#
public bool IsFocused {get; set;}
Managed Extensions for C++
public: __property bool get_IsFocused();
public: __property void set_IsFocused(
   bool value
);
C++/CLI
public:
property bool IsFocused {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsHighlighted Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsHighlighted Property

Syntax

Visual Basic (Declaration)
Public Property IsHighlighted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsHighlighted = value

value = instance.IsHighlighted
C#
public bool IsHighlighted {get; set;}
Managed Extensions for C++
public: __property bool get_IsHighlighted();
public: __property void set_IsHighlighted(
   bool value
);
C++/CLI
public:
property bool IsHighlighted {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnly Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsReadOnly Property

Gets or sets a value that enables selection-only mode, in which the contents of the RadComboBox are selectable but not editable. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.IsReadOnly = value

value = instance.IsReadOnly
C#
public bool IsReadOnly {get; set;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
public: __property void set_IsReadOnly(
   bool value
);
C++/CLI
public:
property bool IsReadOnly {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxDropDownHeight Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : MaxDropDownHeight Property

Gets or sets the maximum height for a RadComboBox drop-down. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property MaxDropDownHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Double

instance.MaxDropDownHeight = value

value = instance.MaxDropDownHeight
C#
public double MaxDropDownHeight {get; set;}
Managed Extensions for C++
public: __property double get_MaxDropDownHeight();
public: __property void set_MaxDropDownHeight(
   double value
);
C++/CLI
public:
property double MaxDropDownHeight {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionBoxItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : SelectionBoxItem Property

Gets or sets ... This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectionBoxItem As Object
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Object

value = instance.SelectionBoxItem
C#
public object SelectionBoxItem {get;}
Managed Extensions for C++
public: __property Object* get_SelectionBoxItem();
C++/CLI
public:
property Object^ SelectionBoxItem {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionBoxItemTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : SelectionBoxItemTemplate Property

Gets or sets ... This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property SelectionBoxItemTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As DataTemplate

instance.SelectionBoxItemTemplate = value

value = instance.SelectionBoxItemTemplate
C#
public DataTemplate SelectionBoxItemTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_SelectionBoxItemTemplate();
public: __property void set_SelectionBoxItemTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ SelectionBoxItemTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
StaysOpenOnEdit Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : StaysOpenOnEdit Property

Gets or sets whether a RadComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property StaysOpenOnEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As Boolean

instance.StaysOpenOnEdit = value

value = instance.StaysOpenOnEdit
C#
public bool StaysOpenOnEdit {get; set;}
Managed Extensions for C++
public: __property bool get_StaysOpenOnEdit();
public: __property void set_StaysOpenOnEdit(
   bool value
);
C++/CLI
public:
property bool StaysOpenOnEdit {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Text Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : Text Property

Gets or sets the text of the currently selected item. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

For a list of all members of this type, see RadComboBox members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DropDownWidthProperty | Identifies the DropDownWidth dependency property
static (Shared in Visual Basic) | FilteringModeProperty | Identifies the FilteringMode dependency property.
static (Shared in Visual Basic) | IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | IsHighlightedProperty |
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
static (Shared in Visual Basic) | MaxDropDownHeightProperty | Identifies the MaxDropDownHeight dependency property.
static (Shared in Visual Basic) | SelectionBoxItemProperty | Identifies the SelectionBoxItem dependency property.
static (Shared in Visual Basic) | SelectionBoxItemTemplateProperty | Identifies the SelectionBoxItemTemplate dependency property.
static (Shared in Visual Basic) | StaysOpenOnEditProperty | Identifies the StaysOpenOnEdit dependency property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property.
Top

See Also

Reference

RadComboBox Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DropDownWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : DropDownWidthProperty Field

Identifies the DropDownWidth dependency property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DropDownWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.DropDownWidthProperty
C#
public static readonly DependencyProperty DropDownWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DropDownWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ DropDownWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilteringModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : FilteringModeProperty Field

Identifies the FilteringMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FilteringModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.FilteringModeProperty
C#
public static readonly DependencyProperty FilteringModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FilteringModeProperty
C++/CLI
public:
static readonly DependencyProperty^ FilteringModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDropDownOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsDropDownOpenProperty Field

Identifies the IsDropDownOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsDropDownOpenProperty
C#
public static readonly DependencyProperty IsDropDownOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDropDownOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDropDownOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEditableProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsEditableProperty Field

Identifies the IsEditable dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEditableProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsEditableProperty
C#
public static readonly DependencyProperty IsEditableProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEditableProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEditableProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocusedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsFocusedProperty Field

Identifies the IsFocused dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsFocusedProperty
C#
public static readonly DependencyProperty IsFocusedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFocusedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFocusedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsHighlightedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsHighlightedProperty Field

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsHighlightedProperty
C#
public static readonly DependencyProperty IsHighlightedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsHighlightedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsHighlightedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnlyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : IsReadOnlyProperty Field

Identifies the IsReadOnly dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.IsReadOnlyProperty
C#
public static readonly DependencyProperty IsReadOnlyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsReadOnlyProperty
C++/CLI
public:
static readonly DependencyProperty^ IsReadOnlyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxDropDownHeightProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : MaxDropDownHeightProperty Field

Identifies the MaxDropDownHeight dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxDropDownHeightProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.MaxDropDownHeightProperty
C#
public static readonly DependencyProperty MaxDropDownHeightProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MaxDropDownHeightProperty
C++/CLI
public:
static readonly DependencyProperty^ MaxDropDownHeightProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionBoxItemProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : SelectionBoxItemProperty Field

Identifies the SelectionBoxItem dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionBoxItemProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.SelectionBoxItemProperty
C#
public static readonly DependencyProperty SelectionBoxItemProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionBoxItemProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionBoxItemProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionBoxItemTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : SelectionBoxItemTemplateProperty Field

Identifies the SelectionBoxItemTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionBoxItemTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.SelectionBoxItemTemplateProperty
C#
public static readonly DependencyProperty SelectionBoxItemTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionBoxItemTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionBoxItemTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
StaysOpenOnEditProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : StaysOpenOnEditProperty Field

Identifies the StaysOpenOnEdit dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StaysOpenOnEditProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.StaysOpenOnEditProperty
C#
public static readonly DependencyProperty StaysOpenOnEditProperty
Managed Extensions for C++
public: static readonly DependencyProperty* StaysOpenOnEditProperty
C++/CLI
public:
static readonly DependencyProperty^ StaysOpenOnEditProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TextProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : TextProperty Field

Identifies the Text dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadComboBox.TextProperty
C#
public static readonly DependencyProperty TextProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TextProperty
C++/CLI
public:
static readonly DependencyProperty^ TextProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBox Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBox Class

For a list of all members of this type, see RadComboBox members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DropDownClosed | Occurs when the drop-down list of the combo box closes.
Public Event | DropDownOpened | Occurs when the drop-down list of the combo box opens.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadComboBox Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DropDownClosed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : DropDownClosed Event

Occurs when the drop-down list of the combo box closes.

Syntax

Visual Basic (Declaration)
Public Event DropDownClosed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim handler As EventHandler

AddHandler instance.DropDownClosed, handler
C#
public event EventHandler DropDownClosed()
Managed Extensions for C++
public: __event EventHandler* DropDownClosed
C++/CLI
public:
event EventHandler^ DropDownClosed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DropDownOpened Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBox Class : DropDownOpened Event

Occurs when the drop-down list of the combo box opens.

Syntax

Visual Basic (Declaration)
Public Event DropDownOpened() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadComboBox
Dim handler As EventHandler

AddHandler instance.DropDownOpened, handler
C#
public event EventHandler DropDownOpened()
Managed Extensions for C++
public: __event EventHandler* DropDownOpened
C++/CLI
public:
event EventHandler^ DropDownOpened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBox Class
RadComboBox Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadComboBoxItem Class

Implements a selectable item inside a RadComboBox.

Syntax

Visual Basic (Declaration)
Public Class RadComboBoxItem
   Inherits ListBoxItem
   Implements IManagedPeer, INativeCoreTypeWrapper, ISelectable
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
C#
public class RadComboBoxItem : ListBoxItem, IManagedPeer, INativeCoreTypeWrapper, ISelectable
Managed Extensions for C++
public __gc class RadComboBoxItem : public ListBoxItem, IManagedPeer, INativeCoreTypeWrapper, ISelectable
C++/CLI
public ref class RadComboBoxItem : public ListBoxItem, IManagedPeer, INativeCoreTypeWrapper, ISelectable

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.ListBoxItem
Telerik.Windows.Controls.RadComboBoxItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadComboBoxItem Class

The following tables list the members exposed by RadComboBoxItem.

Public Constructors

 | Name | Description
Public Constructor | RadComboBoxItem Constructor | Initializes a new instance of the RadComboBoxItem class.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHighlighted | Gets a value that indicates whether the item is highlighted. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | Overridden. Called when the value of the IsEnabled property changes.
Protected Method | OnIsHighlightedChanged | Called when the IsHighlighted property is changed.
Protected Method | OnMouseEnter | Overridden. Responds to a MouseEnter event.
Protected Method | OnMouseLeftButtonDown | Overridden. Called when the user presses the left mouse button over the RadComboBoxItem.
Protected Method | OnMouseLeftButtonUp | Overridden. Called when the user releases the left mouse button over the ListBoxItem.
Protected Method | OnSelected | Overridden. Called when the RadComboBoxItem is selected in a RadComboBox.
Protected Method | OnUnselected | Overridden. Called when the RadComboBoxItem is unselected in a RadComboBox.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem)
Top

See Also

Reference

RadComboBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : RadComboBoxItem Constructor

Initializes a new instance of the RadComboBoxItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem()
C#
public RadComboBoxItem()
Managed Extensions for C++
public: RadComboBoxItem();
C++/CLI
public:
RadComboBoxItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBoxItem Class

For a list of all members of this type, see RadComboBoxItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | Overridden. Called when the value of the IsEnabled property changes.
Protected Method | OnIsHighlightedChanged | Called when the IsHighlighted property is changed.
Protected Method | OnMouseEnter | Overridden. Responds to a MouseEnter event.
Protected Method | OnMouseLeftButtonDown | Overridden. Called when the user presses the left mouse button over the RadComboBoxItem.
Protected Method | OnMouseLeftButtonUp | Overridden. Called when the user releases the left mouse button over the ListBoxItem.
Protected Method | OnSelected | Overridden. Called when the RadComboBoxItem is selected in a RadComboBox.
Protected Method | OnUnselected | Overridden. Called when the RadComboBoxItem is unselected in a RadComboBox.
Top

See Also

Reference

RadComboBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnIsEnabledChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnIsEnabledChanged Method

isEnabled
The new value of the IsEnabled property.
Called when the value of the IsEnabled property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnIsEnabledChanged( _
   ByVal isEnabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim isEnabled As Boolean

instance.OnIsEnabledChanged(isEnabled)
C#
protected override void OnIsEnabledChanged(
   bool isEnabled
)
Managed Extensions for C++
protected: void OnIsEnabledChanged(
   bool isEnabled
) override
C++/CLI
protected:
void OnIsEnabledChanged(
   bool isEnabled
) override

Parameters

isEnabled
The new value of the IsEnabled property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnIsHighlightedChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnIsHighlightedChanged Method

oldValue
The old value of the IsHighlighted property
newValue
The new value of the IsHighlighted property
Called when the IsHighlighted property is changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsHighlightedChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsHighlightedChanged(oldValue, newValue)
C#
protected virtual void OnIsHighlightedChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsHighlightedChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsHighlightedChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The old value of the IsHighlighted property
newValue
The new value of the IsHighlighted property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnMouseEnter Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnMouseEnter Method

e
The MouseEventArgs instance containing the event data.
Responds to a MouseEnter event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim e As MouseEventArgs

instance.OnMouseEnter(e)
C#
protected override void OnMouseEnter(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseEnter(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseEnter(
   MouseEventArgs^ e
) override

Parameters

e
The MouseEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnMouseLeftButtonDown Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnMouseLeftButtonDown Method

e
The event data.
Called when the user presses the left mouse button over the RadComboBoxItem.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown( _
   ByVal e As MouseButtonEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim e As MouseButtonEventArgs

instance.OnMouseLeftButtonDown(e)
C#
protected override void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)
Managed Extensions for C++
protected: void OnMouseLeftButtonDown(
   MouseButtonEventArgs* e
) override
C++/CLI
protected:
void OnMouseLeftButtonDown(
   MouseButtonEventArgs^ e
) override

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnMouseLeftButtonUp Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnMouseLeftButtonUp Method

e
The event data.
Called when the user releases the left mouse button over the ListBoxItem.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp( _
   ByVal e As MouseButtonEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim e As MouseButtonEventArgs

instance.OnMouseLeftButtonUp(e)
C#
protected override void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)
Managed Extensions for C++
protected: void OnMouseLeftButtonUp(
   MouseButtonEventArgs* e
) override
C++/CLI
protected:
void OnMouseLeftButtonUp(
   MouseButtonEventArgs^ e
) override

Parameters

e
The event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnSelected Method

e
The event data.
Called when the RadComboBoxItem is selected in a RadComboBox.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim e As RadRoutedEventArgs

instance.OnSelected(e)
C#
protected override void OnSelected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: void OnSelected(
   RadRoutedEventArgs* e
) override
C++/CLI
protected:
void OnSelected(
   RadRoutedEventArgs^ e
) override

Parameters

e
The event data.

Remarks

This method is called when the IsSelected property changes to true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnUnselected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : OnUnselected Method

e
The event data.
Called when the RadComboBoxItem is unselected in a RadComboBox.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnselected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim e As RadRoutedEventArgs

instance.OnUnselected(e)
C#
protected override void OnUnselected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: void OnUnselected(
   RadRoutedEventArgs* e
) override
C++/CLI
protected:
void OnUnselected(
   RadRoutedEventArgs^ e
) override

Parameters

e
The event data.

Remarks

This method is called when the IsSelected property changes to false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBoxItem Class

For a list of all members of this type, see RadComboBoxItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHighlighted | Gets a value that indicates whether the item is highlighted. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadComboBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsHighlighted Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadComboBoxItem Class : IsHighlighted Property

Gets a value that indicates whether the item is highlighted. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHighlighted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadComboBoxItem
Dim value As Boolean

value = instance.IsHighlighted
C#
public bool IsHighlighted {get;}
Managed Extensions for C++
public: __property bool get_IsHighlighted();
C++/CLI
public:
property bool IsHighlighted {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadComboBoxItem Class
RadComboBoxItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

Input control for entering Dates.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultPropertyAttribute("SelectedDate")>
<DefaultEventAttribute("DateSelected")>
Public Class RadDatePicker
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
C#
[DefaultPropertyAttribute("SelectedDate")]
[DefaultEventAttribute("DateSelected")]
public class RadDatePicker : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[DefaultPropertyAttribute("SelectedDate")]
[DefaultEventAttribute("DateSelected")]
public __gc class RadDatePicker : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[DefaultPropertyAttribute("SelectedDate")]
[DefaultEventAttribute("DateSelected")]
public ref class RadDatePicker : public Control, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadDatePicker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

The following tables list the members exposed by RadDatePicker.

Public Constructors

 | Name | Description
Public Constructor | RadDatePicker Constructor | Constructor.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CalendarWeekRuleProperty | Identifies the CalendarWeekRule property.
static (Shared in Visual Basic) | CenturyViewHeaderFormatProperty | Identifies the CenturyViewHeaderFormat property.
static (Shared in Visual Basic) | CenturyViewPanelProperty | Identifies the CenturyViewPanel property.
static (Shared in Visual Basic) | CenturyViewStyleProperty | Identifies the CenturyViewStyle property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | CultureProperty | Indetifies the Culture property.
static (Shared in Visual Basic) | DayButtonStyleProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DayButtonStyleSelectorProperty | Identifies the DayButtonStyleSelector property.
static (Shared in Visual Basic) | DayTemplateProperty | Identifies the DayTemplate property.
static (Shared in Visual Basic) | DayTemplateSelectorProperty | Identifies the DayTemplateSelector property.
static (Shared in Visual Basic) | DecadeButtonStyleProperty | Identifies the DecadeButtonStyle property.
static (Shared in Visual Basic) | DecadeButtonStyleSelectorProperty | Identifies the DecadeButtonStyleSelector property.
static (Shared in Visual Basic) | DecadeTemplateProperty | Identifies the DecadeTemplate property.
static (Shared in Visual Basic) | DecadeTemplateSelectorProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DecadeViewHeaderFormatProperty | Identifies the DecadeViewHeaderFormat property.
static (Shared in Visual Basic) | DecadeViewPanelProperty | Identifies the DecadeViewPanel property.
static (Shared in Visual Basic) | DecadeViewStyleProperty | Identifies the DecadeViewStyle property.
static (Shared in Visual Basic) | DisplayDateEndProperty | Identifies the DisplayDateEnd dependency property.
static (Shared in Visual Basic) | DisplayDateProperty | Identifies the DisplayDate dependency property.
static (Shared in Visual Basic) | DisplayDateStartProperty | Identifies the DisplayDateStart dependency property.
static (Shared in Visual Basic) | DisplayModeProperty | Identifies the DisplayMode dependency property.
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility property.
static (Shared in Visual Basic) | IsDropDownOpenProperty | Identifies the IsDropDownOpen proeprty.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the IsReadOnly property.
static (Shared in Visual Basic) | IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property.
static (Shared in Visual Basic) | MonthButtonStyleProperty | Identifies the MonthButtonStyle property.
static (Shared in Visual Basic) | MonthButtonStyleSelectorProperty | Identifies the MonthButtonStyleSelector property.
static (Shared in Visual Basic) | MonthTemplateProperty | Identifies the MonthTemplate property.
static (Shared in Visual Basic) | MonthTemplateSelectorProperty | Identifies the MonthTemplateSelector property.
static (Shared in Visual Basic) | MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat property.
static (Shared in Visual Basic) | MonthViewPanelProperty | Identifies the MonthViewPanel property.
static (Shared in Visual Basic) | MonthViewStyleProperty | Identifies the MonthViewStyle property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
static (Shared in Visual Basic) | SelectableDateEndProperty | Identifies the SelectableDateEnd dependency property.
static (Shared in Visual Basic) | SelectableDateStartProperty | Identifies the SelectableDateStart dependency property.
static (Shared in Visual Basic) | SelectedDateProperty | Identifies the SelectedDate dependency property.
static (Shared in Visual Basic) | ViewsHeaderVisibilityProperty | Identifies the ViewsHeaderVisibility property.
static (Shared in Visual Basic) | YearButtonStyleProperty | Identifies the YearButtonStyle property.
static (Shared in Visual Basic) | YearButtonStyleSelectorProperty | Identifies the YearButtonStyleSelector property.
static (Shared in Visual Basic) | YearTemplateProperty | Identifies the YearTemplate property.
static (Shared in Visual Basic) | YearTemplateSelectorProperty | Identifies the YearTemplateSelector property.
static (Shared in Visual Basic) | YearViewHeaderFormatProperty | Identifies the YearViewHeaderFormat property.
static (Shared in Visual Basic) | YearViewPanelProperty | Identifies the YearViewPanel property.
static (Shared in Visual Basic) | YearViewStyleProperty | Identifies the YearViewStyle property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CalendarWeekRule | Gets or sets how should the first week in the year be counted. This is a dependency property.
Public Property | CenturyViewHeaderFormat | Gets or sets the format for the header of the century views of the calendar. This is a dependency property.
Public Property | CenturyViewPanel | Gets or sets the items panel template for the century views of the calendar. This is a dependency property.
Public Property | CenturyViewStyle | Gets or sets the style of the century calendar view. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.
Public Property | Culture | Gets or sets the culture that the Calendar uses. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DayButtonStyle | Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayButtonStyleSelector | Gets or sets the style selector for the day buttons in the month views of the Calendar.
Public Property | DayTemplate | Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayTemplateSelector | Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyle | Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyleSelector | Gets or sets the style selector for the decade buttons in the century views of the Calendar.
Public Property | DecadeTemplate | Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeTemplateSelector | Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeViewHeaderFormat | Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewPanel | Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewStyle | Gets or sets the style of the decade calendar view. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayDate | Gets or sets the current date to display. This is a dependency property.
Public Property | DisplayDateEnd | Gets or sets the last date that would be able to be displayed. This is a dependency property.
Public Property | DisplayDateStart | Gets or sets the first date that would be able to be displayed. This is a dependency property.
Public Property | DisplayMode | Gets or sets the display mode of the Calendar. This is a dependency property.
Public Property | FirstDayOfWeek | Gets or sets the day that is considered the beginning of the week.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HeaderVisibility | Gets or sets the visibility of the Calendar's header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDropDownOpen | Gets or sets whether the Calendar DropDown is open. This is a dependency proeprty.
Public Property | IsEnabled | Gets or sets whether this Calendar is enabled in the user interface. This is a dependency proeprty.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsReadOnly | Gets or sets whether the Calendar's selection can be changed. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTodayHighlighted | Gets or sets whether the today date would be highlighted. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MonthButtonStyle | Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthButtonStyleSelector | Gets or sets the style selector for the month buttons in the year views of the Calendar.
Public Property | MonthTemplate | Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthTemplateSelector | Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthViewHeaderFormat | Gets or sets the format for the header of the month views of the calendar. This is a dependency property.
Public Property | MonthViewPanel | Gets or sets the items panel template for the month views of the calendar. This is a dependency property.
Public Property | MonthViewStyle | Gets or sets the style of the month calendar view. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the Calendar. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.
Public Property | SelectableDateEnd | Gets or sets the last date that can be selected. This is a dependency property.
Public Property | SelectableDateStart | Gets or sets the first date that can be selected. This is a dependency property.
Public Property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ViewsHeaderVisibility | Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | YearButtonStyle | Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearButtonStyleSelector | Gets or sets the style selector for the year buttons in the decade views of the Calendar.
Public Property | YearTemplate | Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearTemplateSelector | Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearViewHeaderFormat | Gets or sets the format for the header of the year views of the calendar. This is a dependency property.
Public Property | YearViewPanel | Gets or sets the items panel template for the year views of the calendar. This is a dependency property.
Public Property | YearViewStyle | Gets or sets the style of the calendar year view. This is a dependency property.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Public Method | ToString | Overridden. Provides a text representation of the selected date.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DisplayDateChanged | Occurs when the DisplayDate property is changed.
Public Event | DisplayModeChanged | Occurs when the DisplayMode property is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when a date is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadDatePicker Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : RadDatePicker Constructor

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker()
C#
public RadDatePicker()
Managed Extensions for C++
public: RadDatePicker();
C++/CLI
public:
RadDatePicker();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

For a list of all members of this type, see RadDatePicker members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Public Method | ToString | Overridden. Provides a text representation of the selected date.
Top

See Also

Reference

RadDatePicker Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : ToString Method

Provides a text representation of the selected date.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A text representation of the selected date, or an empty string if SelectedDate is a null reference.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

For a list of all members of this type, see RadDatePicker members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CalendarWeekRule | Gets or sets how should the first week in the year be counted. This is a dependency property.
Public Property | CenturyViewHeaderFormat | Gets or sets the format for the header of the century views of the calendar. This is a dependency property.
Public Property | CenturyViewPanel | Gets or sets the items panel template for the century views of the calendar. This is a dependency property.
Public Property | CenturyViewStyle | Gets or sets the style of the century calendar view. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.
Public Property | Culture | Gets or sets the culture that the Calendar uses. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DayButtonStyle | Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayButtonStyleSelector | Gets or sets the style selector for the day buttons in the month views of the Calendar.
Public Property | DayTemplate | Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DayTemplateSelector | Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyle | Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.
Public Property | DecadeButtonStyleSelector | Gets or sets the style selector for the decade buttons in the century views of the Calendar.
Public Property | DecadeTemplate | Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeTemplateSelector | Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.
Public Property | DecadeViewHeaderFormat | Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewPanel | Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.
Public Property | DecadeViewStyle | Gets or sets the style of the decade calendar view. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayDate | Gets or sets the current date to display. This is a dependency property.
Public Property | DisplayDateEnd | Gets or sets the last date that would be able to be displayed. This is a dependency property.
Public Property | DisplayDateStart | Gets or sets the first date that would be able to be displayed. This is a dependency property.
Public Property | DisplayMode | Gets or sets the display mode of the Calendar. This is a dependency property.
Public Property | FirstDayOfWeek | Gets or sets the day that is considered the beginning of the week.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HeaderVisibility | Gets or sets the visibility of the Calendar's header. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDropDownOpen | Gets or sets whether the Calendar DropDown is open. This is a dependency proeprty.
Public Property | IsEnabled | Gets or sets whether this Calendar is enabled in the user interface. This is a dependency proeprty.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsReadOnly | Gets or sets whether the Calendar's selection can be changed. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTodayHighlighted | Gets or sets whether the today date would be highlighted. This is a dependency property.
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MonthButtonStyle | Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthButtonStyleSelector | Gets or sets the style selector for the month buttons in the year views of the Calendar.
Public Property | MonthTemplate | Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthTemplateSelector | Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.
Public Property | MonthViewHeaderFormat | Gets or sets the format for the header of the month views of the calendar. This is a dependency property.
Public Property | MonthViewPanel | Gets or sets the items panel template for the month views of the calendar. This is a dependency property.
Public Property | MonthViewStyle | Gets or sets the style of the month calendar view. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the Calendar. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.
Public Property | SelectableDateEnd | Gets or sets the last date that can be selected. This is a dependency property.
Public Property | SelectableDateStart | Gets or sets the first date that can be selected. This is a dependency property.
Public Property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ViewsHeaderVisibility | Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | YearButtonStyle | Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearButtonStyleSelector | Gets or sets the style selector for the year buttons in the decade views of the Calendar.
Public Property | YearTemplate | Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearTemplateSelector | Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.
Public Property | YearViewHeaderFormat | Gets or sets the format for the header of the year views of the calendar. This is a dependency property.
Public Property | YearViewPanel | Gets or sets the items panel template for the year views of the calendar. This is a dependency property.
Public Property | YearViewStyle | Gets or sets the style of the calendar year view. This is a dependency property.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadDatePicker Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarWeekRule Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CalendarWeekRule Property

Gets or sets how should the first week in the year be counted. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")>
Public Property CalendarWeekRule As Nullable(Of CalendarWeekRule)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of CalendarWeekRule)

instance.CalendarWeekRule = value

value = instance.CalendarWeekRule
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
public Nullable<CalendarWeekRule> CalendarWeekRule {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
public: __property Nullable<CalendarWeekRule> get_CalendarWeekRule();
public: __property void set_CalendarWeekRule(
   Nullable<CalendarWeekRule> value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Gets or sets how should the first week in the year be counted. This is a dependency property.")]
public:
property Nullable<CalendarWeekRule> CalendarWeekRule {
   Nullable<CalendarWeekRule> get();
   void set (Nullable<CalendarWeekRule> value);
}

Remarks

Please refer to RadCalendar.CalendarWeekRule for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewHeaderFormat Property

Gets or sets the format for the header of the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property CenturyViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As String

instance.CenturyViewHeaderFormat = value

value = instance.CenturyViewHeaderFormat
C#
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public string CenturyViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property string* get_CenturyViewHeaderFormat();
public: __property void set_CenturyViewHeaderFormat(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the format for the header of the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property String^ CenturyViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Remarks

Please refer to RadCalendar.CenturyViewHeaderFormat for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewPanel Property

Gets or sets the items panel template for the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property CenturyViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As ItemsPanelTemplate

instance.CenturyViewPanel = value

value = instance.CenturyViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate CenturyViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_CenturyViewPanel();
public: __property void set_CenturyViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ CenturyViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Remarks

Please refer to RadCalendar.CenturyViewPanel for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewStyle Property

Gets or sets the style of the century calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property CenturyViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.CenturyViewStyle = value

value = instance.CenturyViewStyle
C#
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style CenturyViewStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_CenturyViewStyle();
public: __property void set_CenturyViewStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style of the century calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ CenturyViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Columns Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : Columns Property

Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")>
<DefaultValueAttribute()>
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public int Columns {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the number of columns of calendar views in the calendar. This is a dependency property.")]
[DefaultValueAttribute()]
public:
property int Columns {
   int get();
   void set (int value);
}

Remarks

Please refer to RadCalendar.Columns for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
Rows Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Culture Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : Culture Property

Gets or sets the culture that the Calendar uses. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public CultureInfo Culture {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property CultureInfo* get_Culture();
public: __property void set_Culture(
   CultureInfo* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property CultureInfo^ Culture {
   CultureInfo^ get();
   void set (CultureInfo^ value);
}

Remarks

Please refer to RadCalendar.Culture for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayButtonStyle Property

Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DayButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.DayButtonStyle = value

value = instance.DayButtonStyle
C#
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style DayButtonStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_DayButtonStyle();
public: __property void set_DayButtonStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style for the day buttons in the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ DayButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Remarks

Please refer to RadCalendar.DayButtonStyle for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayButtonStyleSelector Property

Gets or sets the style selector for the day buttons in the month views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property DayButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As StyleSelector

instance.DayButtonStyleSelector = value

value = instance.DayButtonStyleSelector
C#
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public StyleSelector DayButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property StyleSelector* get_DayButtonStyleSelector();
public: __property void set_DayButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style selector for the day buttons in the month views of the Calendar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property StyleSelector^ DayButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Remarks

Please refer to RadCalendar.DayButtonStyleSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayTemplate Property

Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")>
Public Property DayTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplate

instance.DayTemplate = value

value = instance.DayTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public DataTemplate DayTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_DayTemplate();
public: __property void set_DayTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the day buttons in the month views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ DayTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Remarks

Please refer to RadCalendar.DayTemplate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayTemplateSelector Property

Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")>
Public Property DayTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplateSelector

instance.DayTemplateSelector = value

value = instance.DayTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public DataTemplateSelector DayTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_DayTemplateSelector();
public: __property void set_DayTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the day buttons in the month views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ DayTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Remarks

Please refer to RadCalendar.DayTemplateSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeButtonStyle Property

Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.DecadeButtonStyle = value

value = instance.DecadeButtonStyle
C#
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style DecadeButtonStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_DecadeButtonStyle();
public: __property void set_DecadeButtonStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style for the year decade in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ DecadeButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Remarks

Please refer to RadCalendar.DecadeButtonStyle for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeButtonStyleSelector Property

Gets or sets the style selector for the decade buttons in the century views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property DecadeButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As StyleSelector

instance.DecadeButtonStyleSelector = value

value = instance.DecadeButtonStyleSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public StyleSelector DecadeButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property StyleSelector* get_DecadeButtonStyleSelector();
public: __property void set_DecadeButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property StyleSelector^ DecadeButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Remarks

Please refer to RadCalendar.DecadeButtonStyleSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeTemplate Property

Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplate

instance.DecadeTemplate = value

value = instance.DecadeTemplate
C#
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public DataTemplate DecadeTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property DataTemplate* get_DecadeTemplate();
public: __property void set_DecadeTemplate(
   DataTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the content templates for the decade buttons in the century views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property DataTemplate^ DecadeTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Remarks

Please refer to RadCalendar.DecadeTemplate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeTemplateSelector Property

Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")>
Public Property DecadeTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplateSelector

instance.DecadeTemplateSelector = value

value = instance.DecadeTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public DataTemplateSelector DecadeTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_DecadeTemplateSelector();
public: __property void set_DecadeTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the decade buttons in the century views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ DecadeTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Remarks

Please refer to RadCalendar.DecadeTemplateSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewHeaderFormat Property

Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")>
Public Property DecadeViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As String

instance.DecadeViewHeaderFormat = value

value = instance.DecadeViewHeaderFormat
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public string DecadeViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public: __property string* get_DecadeViewHeaderFormat();
public: __property void set_DecadeViewHeaderFormat(
   string* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the format for the header of the decade views of the calendar. This is a dependency property.")]
public:
property String^ DecadeViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Remarks

Please refer to RadCalendar.DecadeViewHeaderFormat for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewPanel Property

Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As ItemsPanelTemplate

instance.DecadeViewPanel = value

value = instance.DecadeViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate DecadeViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_DecadeViewPanel();
public: __property void set_DecadeViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ DecadeViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Remarks

Please refer to RadCalendar.DecadeViewPanel for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewStyle Property

Gets or sets the style of the decade calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property DecadeViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.DecadeViewStyle = value

value = instance.DecadeViewStyle
C#
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public Style DecadeViewStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property Style* get_DecadeViewStyle();
public: __property void set_DecadeViewStyle(
   Style* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style of the decade calendar view. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property Style^ DecadeViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDate Property

Gets or sets the current date to display. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Appearance")>
Public Property DisplayDate As Date
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Date

instance.DisplayDate = value

value = instance.DisplayDate
C#
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
public DateTime DisplayDate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
public: __property DateTime get_DisplayDate();
public: __property void set_DisplayDate(
   DateTime value
);
C++/CLI
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
public:
property DateTime DisplayDate {
   DateTime get();
   void set (DateTime value);
}

Remarks

Please refer to DisplayDate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayDate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateEnd Property

Gets or sets the last date that would be able to be displayed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
Public Property DisplayDateEnd As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of Date)

instance.DisplayDateEnd = value

value = instance.DisplayDateEnd
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public Nullable<DateTime> DisplayDateEnd {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public: __property Nullable<DateTime> get_DisplayDateEnd();
public: __property void set_DisplayDateEnd(
   Nullable<DateTime> value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public:
property Nullable<DateTime> DisplayDateEnd {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

Please refer to DisplayDateEnd for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayDateEnd Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateStart Property

Gets or sets the first date that would be able to be displayed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
Public Property DisplayDateStart As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of Date)

instance.DisplayDateStart = value

value = instance.DisplayDateStart
C#
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public Nullable<DateTime> DisplayDateStart {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_DisplayDateStart();
public: __property void set_DisplayDateStart(
   Nullable<DateTime> value
);
C++/CLI
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> DisplayDateStart {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

Please refer to DisplayDateStart for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayMode Property

Gets or sets the display mode of the Calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public DisplayMode DisplayMode {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property DisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   DisplayMode value
);
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (DisplayMode value);
}

Remarks

Please refer to DisplayMode for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayMode Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FirstDayOfWeek Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : FirstDayOfWeek Property

Gets or sets the day that is considered the beginning of the week.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property FirstDayOfWeek As Nullable(Of DayOfWeek)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of DayOfWeek)

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public Nullable<DayOfWeek> FirstDayOfWeek {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property Nullable<DayOfWeek> get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   Nullable<DayOfWeek> value
);
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property Nullable<DayOfWeek> FirstDayOfWeek {
   Nullable<DayOfWeek> get();
   void set (Nullable<DayOfWeek> value);
}

Remarks

Please refer to RadCalendar.FirstDayOfWeek for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
FirstDayOfWeek Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : HeaderVisibility Property

Gets or sets the visibility of the Calendar's header. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property HeaderVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Visibility

instance.HeaderVisibility = value

value = instance.HeaderVisibility
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public Visibility HeaderVisibility {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property Visibility get_HeaderVisibility();
public: __property void set_HeaderVisibility(
   Visibility value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property Visibility HeaderVisibility {
   Visibility get();
   void set (Visibility value);
}

Remarks

Please refer to RadCalendar.HeaderVisibility for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
HeaderVisibility Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDropDownOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsDropDownOpen Property

Gets or sets whether the Calendar DropDown is open. This is a dependency proeprty.

Syntax

Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Boolean

instance.IsDropDownOpen = value

value = instance.IsDropDownOpen
C#
public bool IsDropDownOpen {get; set;}
Managed Extensions for C++
public: __property bool get_IsDropDownOpen();
public: __property void set_IsDropDownOpen(
   bool value
);
C++/CLI
public:
property bool IsDropDownOpen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsEnabled Property

Gets or sets whether this Calendar is enabled in the user interface. This is a dependency proeprty.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Remarks

Please refer to IsEnabled for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
IsEnabled Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnly Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsReadOnly Property

Gets or sets whether the Calendar's selection can be changed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Boolean

instance.IsReadOnly = value

value = instance.IsReadOnly
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public bool IsReadOnly {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property bool get_IsReadOnly();
public: __property void set_IsReadOnly(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property bool IsReadOnly {
   bool get();
   void set (bool value);
}

Remarks

Please refer to RadCalendar.IsReadOnly for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
IsReadOnly Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsTodayHighlighted Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsTodayHighlighted Property

Gets or sets whether the today date would be highlighted. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property IsTodayHighlighted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Boolean

instance.IsTodayHighlighted = value

value = instance.IsTodayHighlighted
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public bool IsTodayHighlighted {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property bool get_IsTodayHighlighted();
public: __property void set_IsTodayHighlighted(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property bool IsTodayHighlighted {
   bool get();
   void set (bool value);
}

Remarks

Please refer to RadCalendar.IsTodayHighlighted for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
IsTodayHighlighted Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthButtonStyle Property

Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.MonthButtonStyle = value

value = instance.MonthButtonStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public Style MonthButtonStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property Style* get_MonthButtonStyle();
public: __property void set_MonthButtonStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property Style^ MonthButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Remarks

Please refer to RadCalendar.MonthButtonStyle for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthButtonStyleSelector Property

Gets or sets the style selector for the month buttons in the year views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")>
Public Property MonthButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As StyleSelector

instance.MonthButtonStyleSelector = value

value = instance.MonthButtonStyleSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
public StyleSelector MonthButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
public: __property StyleSelector* get_MonthButtonStyleSelector();
public: __property void set_MonthButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style selector for the month buttons in the year views of the Calendar.")]
public:
property StyleSelector^ MonthButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Remarks

Please refer to RadCalendar.MonthButtonStyleSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthTemplate Property

Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplate

instance.MonthTemplate = value

value = instance.MonthTemplate
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public DataTemplate MonthTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property DataTemplate* get_MonthTemplate();
public: __property void set_MonthTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the content templates for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property DataTemplate^ MonthTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Remarks

Please refer to RadCalendar.MonthTemplate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthTemplateSelector Property

Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")>
Public Property MonthTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplateSelector

instance.MonthTemplateSelector = value

value = instance.MonthTemplateSelector
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public DataTemplateSelector MonthTemplateSelector {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_MonthTemplateSelector();
public: __property void set_MonthTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the month buttons in the year views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ MonthTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Remarks

Please refer to RadCalendar.MonthTemplateSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewHeaderFormat Property

Gets or sets the format for the header of the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property MonthViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As String

instance.MonthViewHeaderFormat = value

value = instance.MonthViewHeaderFormat
C#
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public string MonthViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property string* get_MonthViewHeaderFormat();
public: __property void set_MonthViewHeaderFormat(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the format for the header of the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property String^ MonthViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Remarks

Please refer to RadCalendar.MonthViewHeaderFormat for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewPanel Property

Gets or sets the items panel template for the month views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property MonthViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As ItemsPanelTemplate

instance.MonthViewPanel = value

value = instance.MonthViewPanel
C#
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ItemsPanelTemplate MonthViewPanel {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ItemsPanelTemplate* get_MonthViewPanel();
public: __property void set_MonthViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the items panel template for the month views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ItemsPanelTemplate^ MonthViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Remarks

Please refer to RadCalendar.MonthViewPanel for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewStyle Property

Gets or sets the style of the month calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")>
Public Property MonthViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.MonthViewStyle = value

value = instance.MonthViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public Style MonthViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public: __property Style* get_MonthViewStyle();
public: __property void set_MonthViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the month calendar view. This is a dependency property.")]
public:
property Style^ MonthViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : Orientation Property

Gets or sets whether the orientation of the Calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Remarks

Please refer to RadCalendar.Orientation for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Rows Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : Rows Property

Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public int Rows {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the number of rows of calendar views in the calendar. This is a dependency proeprty.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property int Rows {
   int get();
   void set (int value);
}

Remarks

Please refer to SelectedDate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
Columns Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateEnd Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectableDateEnd Property

Gets or sets the last date that can be selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("")>
Public Property SelectableDateEnd As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of Date)

instance.SelectableDateEnd = value

value = instance.SelectableDateEnd
C#
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public Nullable<DateTime> SelectableDateEnd {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_SelectableDateEnd();
public: __property void set_SelectableDateEnd(
   Nullable<DateTime> value
);
C++/CLI
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> SelectableDateEnd {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

Please refer to SelectableDateEnd for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
SelectableDateEnd Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectableDateStart Property

Gets or sets the first date that can be selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
Public Property SelectableDateStart As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of Date)

instance.SelectableDateStart = value

value = instance.SelectableDateStart
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public Nullable<DateTime> SelectableDateStart {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public: __property Nullable<DateTime> get_SelectableDateStart();
public: __property void set_SelectableDateStart(
   Nullable<DateTime> value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
public:
property Nullable<DateTime> SelectableDateStart {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

Please refer to SelectableDateStart for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
SelectableDateStart Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedDate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectedDate Property

Gets or sets the currently selected date. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property SelectedDate As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Nullable(Of Date)

instance.SelectedDate = value

value = instance.SelectedDate
C#
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public Nullable<DateTime> SelectedDate {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property Nullable<DateTime> get_SelectedDate();
public: __property void set_SelectedDate(
   Nullable<DateTime> value
);
C++/CLI
[DefaultValueAttribute()]
[TypeConverterAttribute("Telerik.Windows.Controls.DateTimeTypeConverter, Telerik.Windows.Controls.Input, Version=2008.1.605.0, Culture=neutral, PublicKeyToken=9c7324f9b8e4111a")]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property Nullable<DateTime> SelectedDate {
   Nullable<DateTime> get();
   void set (Nullable<DateTime> value);
}

Remarks

Please refer to SelectedDate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
SelectedDate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ViewsHeaderVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : ViewsHeaderVisibility Property

Gets or sets the visibility of the header of the calendar views (month, year, decade, century). This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
Public Property ViewsHeaderVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Visibility

instance.ViewsHeaderVisibility = value

value = instance.ViewsHeaderVisibility
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public Visibility ViewsHeaderVisibility {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public: __property Visibility get_ViewsHeaderVisibility();
public: __property void set_ViewsHeaderVisibility(
   Visibility value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public:
property Visibility ViewsHeaderVisibility {
   Visibility get();
   void set (Visibility value);
}

Remarks

Please refer to RadCalendar.ViewsHeaderVisibility for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearButtonStyle Property

Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")>
Public Property YearButtonStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.YearButtonStyle = value

value = instance.YearButtonStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
public Style YearButtonStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
public: __property Style* get_YearButtonStyle();
public: __property void set_YearButtonStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style for the year buttons in the decade views of the calendar. This is a dependency property.")]
public:
property Style^ YearButtonStyle {
   Style^ get();
   void set (Style^ value);
}

Remarks

Please refer to RadCalendar.YearButtonStyle for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearButtonStyleSelector Property

Gets or sets the style selector for the year buttons in the decade views of the Calendar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")>
<SRCategoryAttribute("Appearance")>
Public Property YearButtonStyleSelector As StyleSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As StyleSelector

instance.YearButtonStyleSelector = value

value = instance.YearButtonStyleSelector
C#
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public StyleSelector YearButtonStyleSelector {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public: __property StyleSelector* get_YearButtonStyleSelector();
public: __property void set_YearButtonStyleSelector(
   StyleSelector* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the style selector for the year buttons in the decade views of the Calendar.")]
[SRCategoryAttribute("Appearance")]
public:
property StyleSelector^ YearButtonStyleSelector {
   StyleSelector^ get();
   void set (StyleSelector^ value);
}

Remarks

Please refer to RadCalendar.YearButtonStyleSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearTemplate Property

Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property YearTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplate

instance.YearTemplate = value

value = instance.YearTemplate
C#
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public DataTemplate YearTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property DataTemplate* get_YearTemplate();
public: __property void set_YearTemplate(
   DataTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the content templates for the year buttons in the decade views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property DataTemplate^ YearTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Remarks

Please refer to RadCalendar.YearTemplate for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateSelector Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearTemplateSelector Property

Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")>
Public Property YearTemplateSelector As DataTemplateSelector
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As DataTemplateSelector

instance.YearTemplateSelector = value

value = instance.YearTemplateSelector
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
public DataTemplateSelector YearTemplateSelector {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
public: __property DataTemplateSelector* get_YearTemplateSelector();
public: __property void set_YearTemplateSelector(
   DataTemplateSelector* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the DataTemplate selectors for the year buttons in the decade views of the calendar. This is a dependency property.")]
public:
property DataTemplateSelector^ YearTemplateSelector {
   DataTemplateSelector^ get();
   void set (DataTemplateSelector^ value);
}

Remarks

Please refer to RadCalendar.YearTemplateSelector for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewHeaderFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewHeaderFormat Property

Gets or sets the format for the header of the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property YearViewHeaderFormat As String
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As String

instance.YearViewHeaderFormat = value

value = instance.YearViewHeaderFormat
C#
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public string YearViewHeaderFormat {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property string* get_YearViewHeaderFormat();
public: __property void set_YearViewHeaderFormat(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the format for the header of the year views of the calendar. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property String^ YearViewHeaderFormat {
   String^ get();
   void set (String^ value);
}

Remarks

Please refer to RadCalendar.YearViewHeaderFormat for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewPanel Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewPanel Property

Gets or sets the items panel template for the year views of the calendar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")>
Public Property YearViewPanel As ItemsPanelTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As ItemsPanelTemplate

instance.YearViewPanel = value

value = instance.YearViewPanel
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
public ItemsPanelTemplate YearViewPanel {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
public: __property ItemsPanelTemplate* get_YearViewPanel();
public: __property void set_YearViewPanel(
   ItemsPanelTemplate* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the items panel template for the year views of the calendar. This is a dependency property.")]
public:
property ItemsPanelTemplate^ YearViewPanel {
   ItemsPanelTemplate^ get();
   void set (ItemsPanelTemplate^ value);
}

Remarks

Please refer to RadCalendar.YearViewPanel for more information on the property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewStyle Property

Gets or sets the style of the calendar year view. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")>
Public Property YearViewStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim value As Style

instance.YearViewStyle = value

value = instance.YearViewStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public Style YearViewStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public: __property Style* get_YearViewStyle();
public: __property void set_YearViewStyle(
   Style* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the style of the yearcalendar view. This is a dependency property.")]
public:
property Style^ YearViewStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

For a list of all members of this type, see RadDatePicker members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CalendarWeekRuleProperty | Identifies the CalendarWeekRule property.
static (Shared in Visual Basic) | CenturyViewHeaderFormatProperty | Identifies the CenturyViewHeaderFormat property.
static (Shared in Visual Basic) | CenturyViewPanelProperty | Identifies the CenturyViewPanel property.
static (Shared in Visual Basic) | CenturyViewStyleProperty | Identifies the CenturyViewStyle property.
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | CultureProperty | Indetifies the Culture property.
static (Shared in Visual Basic) | DayButtonStyleProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DayButtonStyleSelectorProperty | Identifies the DayButtonStyleSelector property.
static (Shared in Visual Basic) | DayTemplateProperty | Identifies the DayTemplate property.
static (Shared in Visual Basic) | DayTemplateSelectorProperty | Identifies the DayTemplateSelector property.
static (Shared in Visual Basic) | DecadeButtonStyleProperty | Identifies the DecadeButtonStyle property.
static (Shared in Visual Basic) | DecadeButtonStyleSelectorProperty | Identifies the DecadeButtonStyleSelector property.
static (Shared in Visual Basic) | DecadeTemplateProperty | Identifies the DecadeTemplate property.
static (Shared in Visual Basic) | DecadeTemplateSelectorProperty | Identifies the DayButtonStyle property.
static (Shared in Visual Basic) | DecadeViewHeaderFormatProperty | Identifies the DecadeViewHeaderFormat property.
static (Shared in Visual Basic) | DecadeViewPanelProperty | Identifies the DecadeViewPanel property.
static (Shared in Visual Basic) | DecadeViewStyleProperty | Identifies the DecadeViewStyle property.
static (Shared in Visual Basic) | DisplayDateEndProperty | Identifies the DisplayDateEnd dependency property.
static (Shared in Visual Basic) | DisplayDateProperty | Identifies the DisplayDate dependency property.
static (Shared in Visual Basic) | DisplayDateStartProperty | Identifies the DisplayDateStart dependency property.
static (Shared in Visual Basic) | DisplayModeProperty | Identifies the DisplayMode dependency property.
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility property.
static (Shared in Visual Basic) | IsDropDownOpenProperty | Identifies the IsDropDownOpen proeprty.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsReadOnlyProperty | Identifies the IsReadOnly property.
static (Shared in Visual Basic) | IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property.
static (Shared in Visual Basic) | MonthButtonStyleProperty | Identifies the MonthButtonStyle property.
static (Shared in Visual Basic) | MonthButtonStyleSelectorProperty | Identifies the MonthButtonStyleSelector property.
static (Shared in Visual Basic) | MonthTemplateProperty | Identifies the MonthTemplate property.
static (Shared in Visual Basic) | MonthTemplateSelectorProperty | Identifies the MonthTemplateSelector property.
static (Shared in Visual Basic) | MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat property.
static (Shared in Visual Basic) | MonthViewPanelProperty | Identifies the MonthViewPanel property.
static (Shared in Visual Basic) | MonthViewStyleProperty | Identifies the MonthViewStyle property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
static (Shared in Visual Basic) | SelectableDateEndProperty | Identifies the SelectableDateEnd dependency property.
static (Shared in Visual Basic) | SelectableDateStartProperty | Identifies the SelectableDateStart dependency property.
static (Shared in Visual Basic) | SelectedDateProperty | Identifies the SelectedDate dependency property.
static (Shared in Visual Basic) | ViewsHeaderVisibilityProperty | Identifies the ViewsHeaderVisibility property.
static (Shared in Visual Basic) | YearButtonStyleProperty | Identifies the YearButtonStyle property.
static (Shared in Visual Basic) | YearButtonStyleSelectorProperty | Identifies the YearButtonStyleSelector property.
static (Shared in Visual Basic) | YearTemplateProperty | Identifies the YearTemplate property.
static (Shared in Visual Basic) | YearTemplateSelectorProperty | Identifies the YearTemplateSelector property.
static (Shared in Visual Basic) | YearViewHeaderFormatProperty | Identifies the YearViewHeaderFormat property.
static (Shared in Visual Basic) | YearViewPanelProperty | Identifies the YearViewPanel property.
static (Shared in Visual Basic) | YearViewStyleProperty | Identifies the YearViewStyle property.
Top

See Also

Reference

RadDatePicker Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarWeekRuleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CalendarWeekRuleProperty Field

Identifies the CalendarWeekRule property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CalendarWeekRuleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.CalendarWeekRuleProperty
C#
public static readonly DependencyProperty CalendarWeekRuleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CalendarWeekRuleProperty
C++/CLI
public:
static readonly DependencyProperty^ CalendarWeekRuleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewHeaderFormatProperty Field

Identifies the CenturyViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.CenturyViewHeaderFormatProperty
C#
public static readonly DependencyProperty CenturyViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewPanelProperty Field

Identifies the CenturyViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.CenturyViewPanelProperty
C#
public static readonly DependencyProperty CenturyViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CenturyViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CenturyViewStyleProperty Field

Identifies the CenturyViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CenturyViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.CenturyViewStyleProperty
C#
public static readonly DependencyProperty CenturyViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CenturyViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ CenturyViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ColumnsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : ColumnsProperty Field

Identifies the Columns property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.ColumnsProperty
C#
public static readonly DependencyProperty ColumnsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ColumnsProperty
C++/CLI
public:
static readonly DependencyProperty^ ColumnsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CultureProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : CultureProperty Field

Indetifies the Culture property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.CultureProperty
C#
public static readonly DependencyProperty CultureProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CultureProperty
C++/CLI
public:
static readonly DependencyProperty^ CultureProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayButtonStyleProperty Field

Identifies the DayButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DayButtonStyleProperty
C#
public static readonly DependencyProperty DayButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DayButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayButtonStyleSelectorProperty Field

Identifies the DayButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DayButtonStyleSelectorProperty
C#
public static readonly DependencyProperty DayButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DayButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayTemplateProperty Field

Identifies the DayTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DayTemplateProperty
C#
public static readonly DependencyProperty DayTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ DayTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DayTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DayTemplateSelectorProperty Field

Identifies the DayTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DayTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DayTemplateSelectorProperty
C#
public static readonly DependencyProperty DayTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DayTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DayTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeButtonStyleProperty Field

Identifies the DecadeButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeButtonStyleProperty
C#
public static readonly DependencyProperty DecadeButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeButtonStyleSelectorProperty Field

Identifies the DecadeButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeButtonStyleSelectorProperty
C#
public static readonly DependencyProperty DecadeButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeTemplateProperty Field

Identifies the DecadeTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeTemplateProperty
C#
public static readonly DependencyProperty DecadeTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeTemplateSelectorProperty Field

Identifies the DayButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeTemplateSelectorProperty
C#
public static readonly DependencyProperty DecadeTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewHeaderFormatProperty Field

Identifies the DecadeViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeViewHeaderFormatProperty
C#
public static readonly DependencyProperty DecadeViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewPanelProperty Field

Identifies the DecadeViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeViewPanelProperty
C#
public static readonly DependencyProperty DecadeViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecadeViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DecadeViewStyleProperty Field

Identifies the DecadeViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecadeViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DecadeViewStyleProperty
C#
public static readonly DependencyProperty DecadeViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecadeViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ DecadeViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateEndProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateEndProperty Field

Identifies the DisplayDateEnd dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateEndProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DisplayDateEndProperty
C#
public static readonly DependencyProperty DisplayDateEndProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateEndProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateEndProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateProperty Field

Identifies the DisplayDate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DisplayDateProperty
C#
public static readonly DependencyProperty DisplayDateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateStartProperty Field

Identifies the DisplayDateStart dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayDateStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DisplayDateStartProperty
C#
public static readonly DependencyProperty DisplayDateStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayDateStartProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayDateStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayModeProperty Field

Identifies the DisplayMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DisplayModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.DisplayModeProperty
C#
public static readonly DependencyProperty DisplayModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DisplayModeProperty
C++/CLI
public:
static readonly DependencyProperty^ DisplayModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FirstDayOfWeekProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : FirstDayOfWeekProperty Field

Identifies the FirstDayOfWeek dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FirstDayOfWeekProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.FirstDayOfWeekProperty
C#
public static readonly DependencyProperty FirstDayOfWeekProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FirstDayOfWeekProperty
C++/CLI
public:
static readonly DependencyProperty^ FirstDayOfWeekProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : HeaderVisibilityProperty Field

Identifies the HeaderVisibility property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.HeaderVisibilityProperty
C#
public static readonly DependencyProperty HeaderVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDropDownOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsDropDownOpenProperty Field

Identifies the IsDropDownOpen proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.IsDropDownOpenProperty
C#
public static readonly DependencyProperty IsDropDownOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDropDownOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDropDownOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsReadOnlyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsReadOnlyProperty Field

Identifies the IsReadOnly property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.IsReadOnlyProperty
C#
public static readonly DependencyProperty IsReadOnlyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsReadOnlyProperty
C++/CLI
public:
static readonly DependencyProperty^ IsReadOnlyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsTodayHighlightedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : IsTodayHighlightedProperty Field

Identifies the IsTodayHighlighted dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsTodayHighlightedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.IsTodayHighlightedProperty
C#
public static readonly DependencyProperty IsTodayHighlightedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsTodayHighlightedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsTodayHighlightedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthButtonStyleProperty Field

Identifies the MonthButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthButtonStyleProperty
C#
public static readonly DependencyProperty MonthButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthButtonStyleSelectorProperty Field

Identifies the MonthButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthButtonStyleSelectorProperty
C#
public static readonly DependencyProperty MonthButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthTemplateProperty Field

Identifies the MonthTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthTemplateProperty
C#
public static readonly DependencyProperty MonthTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthTemplateSelectorProperty Field

Identifies the MonthTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthTemplateSelectorProperty
C#
public static readonly DependencyProperty MonthTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewHeaderFormatProperty Field

Identifies the MonthViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthViewHeaderFormatProperty
C#
public static readonly DependencyProperty MonthViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewPanelProperty Field

Identifies the MonthViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthViewPanelProperty
C#
public static readonly DependencyProperty MonthViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MonthViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : MonthViewStyleProperty Field

Identifies the MonthViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MonthViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.MonthViewStyleProperty
C#
public static readonly DependencyProperty MonthViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MonthViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ MonthViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : OrientationProperty Field

Identifies the Orientation property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RowsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : RowsProperty Field

Identifies the Rows property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RowsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.RowsProperty
C#
public static readonly DependencyProperty RowsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RowsProperty
C++/CLI
public:
static readonly DependencyProperty^ RowsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateEndProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectableDateEndProperty Field

Identifies the SelectableDateEnd dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectableDateEndProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.SelectableDateEndProperty
C#
public static readonly DependencyProperty SelectableDateEndProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectableDateEndProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectableDateEndProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectableDateStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectableDateStartProperty Field

Identifies the SelectableDateStart dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectableDateStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.SelectableDateStartProperty
C#
public static readonly DependencyProperty SelectableDateStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectableDateStartProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectableDateStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedDateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectedDateProperty Field

Identifies the SelectedDate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedDateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.SelectedDateProperty
C#
public static readonly DependencyProperty SelectedDateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedDateProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedDateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ViewsHeaderVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : ViewsHeaderVisibilityProperty Field

Identifies the ViewsHeaderVisibility property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ViewsHeaderVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.ViewsHeaderVisibilityProperty
C#
public static readonly DependencyProperty ViewsHeaderVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ViewsHeaderVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ ViewsHeaderVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearButtonStyleProperty Field

Identifies the YearButtonStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearButtonStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearButtonStyleProperty
C#
public static readonly DependencyProperty YearButtonStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearButtonStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ YearButtonStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearButtonStyleSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearButtonStyleSelectorProperty Field

Identifies the YearButtonStyleSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearButtonStyleSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearButtonStyleSelectorProperty
C#
public static readonly DependencyProperty YearButtonStyleSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearButtonStyleSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ YearButtonStyleSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearTemplateProperty Field

Identifies the YearTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearTemplateProperty
C#
public static readonly DependencyProperty YearTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ YearTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearTemplateSelectorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearTemplateSelectorProperty Field

Identifies the YearTemplateSelector property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearTemplateSelectorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearTemplateSelectorProperty
C#
public static readonly DependencyProperty YearTemplateSelectorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearTemplateSelectorProperty
C++/CLI
public:
static readonly DependencyProperty^ YearTemplateSelectorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewHeaderFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewHeaderFormatProperty Field

Identifies the YearViewHeaderFormat property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewHeaderFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearViewHeaderFormatProperty
C#
public static readonly DependencyProperty YearViewHeaderFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewHeaderFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewHeaderFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewPanelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewPanelProperty Field

Identifies the YearViewPanel property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewPanelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearViewPanelProperty
C#
public static readonly DependencyProperty YearViewPanelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewPanelProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewPanelProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
YearViewStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : YearViewStyleProperty Field

Identifies the YearViewStyle property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YearViewStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadDatePicker.YearViewStyleProperty
C#
public static readonly DependencyProperty YearViewStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YearViewStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ YearViewStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadDatePicker Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadDatePicker Class

For a list of all members of this type, see RadDatePicker members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DisplayDateChanged | Occurs when the DisplayDate property is changed.
Public Event | DisplayModeChanged | Occurs when the DisplayMode property is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Occurs when a date is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadDatePicker Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayDateChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayDateChanged Event

Occurs when the DisplayDate property is changed.

Syntax

Visual Basic (Declaration)
Public Event DisplayDateChanged() As EventHandler(Of CalendarDateChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim handler As EventHandler(Of CalendarDateChangedEventArgs)

AddHandler instance.DisplayDateChanged, handler
C#
public event EventHandler<CalendarDateChangedEventArgs> DisplayDateChanged()
Managed Extensions for C++
public: __event EventHandler<CalendarDateChangedEventArgs*>* DisplayDateChanged
C++/CLI
public:
event EventHandler<CalendarDateChangedEventArgs^>^ DisplayDateChanged

Remarks

Please refer to DisplayDateChanged for more information on the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayDateChanged Event


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayModeChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : DisplayModeChanged Event

Occurs when the DisplayMode property is changed.

Syntax

Visual Basic (Declaration)
Public Event DisplayModeChanged() As EventHandler(Of CalendarModeChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim handler As EventHandler(Of CalendarModeChangedEventArgs)

AddHandler instance.DisplayModeChanged, handler
C#
public event EventHandler<CalendarModeChangedEventArgs> DisplayModeChanged()
Managed Extensions for C++
public: __event EventHandler<CalendarModeChangedEventArgs*>* DisplayModeChanged
C++/CLI
public:
event EventHandler<CalendarModeChangedEventArgs^>^ DisplayModeChanged

Remarks

Please refer to DisplayModeChanged for more information on the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
DisplayModeChanged Event


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectionChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadDatePicker Class : SelectionChanged Event

Occurs when a date is selected.

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged() As EventHandler(Of SelectionChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadDatePicker
Dim handler As EventHandler(Of SelectionChangedEventArgs)

AddHandler instance.SelectionChanged, handler
C#
public event EventHandler<SelectionChangedEventArgs> SelectionChanged()
Managed Extensions for C++
public: __event EventHandler<SelectionChangedEventArgs*>* SelectionChanged
C++/CLI
public:
event EventHandler<SelectionChangedEventArgs^>^ SelectionChanged

Remarks

Please refer to RadCalendar.SelectionChanged for more information on the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadDatePicker Class
RadDatePicker Members
SelectionChanged Event


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

Partial class RadNumericUpDown which contains properties declaration and handlers

Syntax

Visual Basic (Declaration)
Public Class RadNumericUpDown
   Inherits RadUpDown
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
C#
public class RadNumericUpDown : RadUpDown, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadNumericUpDown : public RadUpDown, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadNumericUpDown : public RadUpDown, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.RadUpDown
Telerik.Windows.Controls.RadNumericUpDown

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

The following tables list the members exposed by RadNumericUpDown.

Public Constructors

 | Name | Description
Public Constructor | RadNumericUpDown Constructor | Initializes a new instance of the RadNumericUpDown class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ContentTextProperty | Identifies the ContentText dependency property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | NumberFormatInfoProperty | Identifies the NumberFormatInfo dependency property.
static (Shared in Visual Basic) | NumericUnitProperty | Identifies the NumericUnit dependency property.
static (Shared in Visual Basic) | ValueFormatProperty | Identifies the ValueFormat dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoReverse | Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa. This is a dependency property. (Inherited from RadUpDown)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ChangeAcceleration | Gets or sets Change Acceleration property. This is a dependency property. (Inherited from RadUpDown)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ContentText | Gets the current text content held by the textbox. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DecreaseButtonContentTemplate | Gets or sets the data template of the DecreaseButton. This is a dependency property. (Inherited from RadUpDown)
Public Property | Delay | Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property. (Inherited from RadUpDown)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IncreaseButtonContentTemplate | Gets or sets the data template of the IncreaseButton. This is a dependency property. (Inherited from RadUpDown)
Public Property | IsEditable | Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.
Public Property | IsFocused | Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | NumberFormatInfo | Gets or sets the NumberFormatInfo to format the value if the ValueFormat = ValueFormat.Custom. This is a dependency property.
Public Property | NumericUnit | Gets or sets additional string to appear in the end of numeric values. This is a dependency property.
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepeatInterval | Gets or sets the repeat interval between every repetition except the first one. This is a dependency property. (Inherited from RadUpDown)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | ValueFormat | Gets or sets the current value format. This is a dependency property.
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | Decrease | Decrease repeat button wrapper for children classes (Inherited from RadUpDown)
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Protected Property | Increase | Increase repeat button wrapper for children class (Inherited from RadUpDown)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. Overrides OnApplyTemplate and attach all necessary events to the controls
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadNumericUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : RadNumericUpDown Constructor

Initializes a new instance of the RadNumericUpDown class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown()
C#
public RadNumericUpDown()
Managed Extensions for C++
public: RadNumericUpDown();
C++/CLI
public:
RadNumericUpDown();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

For a list of all members of this type, see RadNumericUpDown members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. Overrides OnApplyTemplate and attach all necessary events to the controls
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadNumericUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : OnApplyTemplate Method

Overrides OnApplyTemplate and attach all necessary events to the controls

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

For a list of all members of this type, see RadNumericUpDown members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoReverse | Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa. This is a dependency property. (Inherited from RadUpDown)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ChangeAcceleration | Gets or sets Change Acceleration property. This is a dependency property. (Inherited from RadUpDown)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ContentText | Gets the current text content held by the textbox. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DecreaseButtonContentTemplate | Gets or sets the data template of the DecreaseButton. This is a dependency property. (Inherited from RadUpDown)
Public Property | Delay | Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property. (Inherited from RadUpDown)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IncreaseButtonContentTemplate | Gets or sets the data template of the IncreaseButton. This is a dependency property. (Inherited from RadUpDown)
Public Property | IsEditable | Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.
Public Property | IsFocused | Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | NumberFormatInfo | Gets or sets the NumberFormatInfo to format the value if the ValueFormat = ValueFormat.Custom. This is a dependency property.
Public Property | NumericUnit | Gets or sets additional string to appear in the end of numeric values. This is a dependency property.
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepeatInterval | Gets or sets the repeat interval between every repetition except the first one. This is a dependency property. (Inherited from RadUpDown)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | ValueFormat | Gets or sets the current value format. This is a dependency property.
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | Decrease | Decrease repeat button wrapper for children classes (Inherited from RadUpDown)
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Protected Property | Increase | Increase repeat button wrapper for children class (Inherited from RadUpDown)
Top

See Also

Reference

RadNumericUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ContentText Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : ContentText Property

Gets the current text content held by the textbox. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets the current text content held by the textbox.")>
<SRCategoryAttribute("MiscCategory")>
Public ReadOnly Property ContentText As String
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As String

value = instance.ContentText
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the current text content held by the textbox.")]
[SRCategoryAttribute("MiscCategory")]
public string ContentText {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the current text content held by the textbox.")]
[SRCategoryAttribute("MiscCategory")]
public: __property string* get_ContentText();
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the current text content held by the textbox.")]
[SRCategoryAttribute("MiscCategory")]
public:
property String^ ContentText {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEditable Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : IsEditable Property

Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("BehaviorCategory")>
Public Property IsEditable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As Boolean

instance.IsEditable = value

value = instance.IsEditable
C#
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public bool IsEditable {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public: __property bool get_IsEditable();
public: __property void set_IsEditable(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public:
property bool IsEditable {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : IsFocused Property

Gets or sets the bool indicating whether the control is editable or not. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("BehaviorCategory")>
Public Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As Boolean

instance.IsFocused = value

value = instance.IsFocused
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public bool IsFocused {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public: __property bool get_IsFocused();
public: __property void set_IsFocused(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BehaviorCategory")]
public:
property bool IsFocused {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
NumberFormatInfo Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : NumberFormatInfo Property

Gets or sets the NumberFormatInfo to format the value if the ValueFormat = ValueFormat.Custom. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the NumberFormatInfo to format the value if the ValueFormat is ValueFormat.Custom. This is a dependency property.")>
<SRCategoryAttribute("AppearanceCategory")>
Public Property NumberFormatInfo As NumberFormatInfo
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As NumberFormatInfo

instance.NumberFormatInfo = value

value = instance.NumberFormatInfo
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the NumberFormatInfo to format the value if the ValueFormat is ValueFormat.Custom. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public NumberFormatInfo NumberFormatInfo {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the NumberFormatInfo to format the value if the ValueFormat is ValueFormat.Custom. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public: __property NumberFormatInfo* get_NumberFormatInfo();
public: __property void set_NumberFormatInfo(
   NumberFormatInfo* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the NumberFormatInfo to format the value if the ValueFormat is ValueFormat.Custom. This is a dependency property.")]
[SRCategoryAttribute("AppearanceCategory")]
public:
property NumberFormatInfo^ NumberFormatInfo {
   NumberFormatInfo^ get();
   void set (NumberFormatInfo^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
NumericUnit Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : NumericUnit Property

Gets or sets additional string to appear in the end of numeric values. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets additional string to appear in the end of numeric values. This is a dependency property.")>
Public Property NumericUnit As String
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As String

instance.NumericUnit = value

value = instance.NumericUnit
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets additional string to appear in the end of numeric values. This is a dependency property.")]
public string NumericUnit {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets additional string to appear in the end of numeric values. This is a dependency property.")]
public: __property string* get_NumericUnit();
public: __property void set_NumericUnit(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets additional string to appear in the end of numeric values. This is a dependency property.")]
public:
property String^ NumericUnit {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ValueFormat Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : ValueFormat Property

Gets or sets the current value format. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the current value format. This is a dependency property.")>
<SRCategoryAttribute("MiscCategory")>
Public Property ValueFormat As ValueFormat
Visual Basic (Usage) Copy Code
Dim instance As RadNumericUpDown
Dim value As ValueFormat

instance.ValueFormat = value

value = instance.ValueFormat
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the current value format. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public ValueFormat ValueFormat {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the current value format. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public: __property ValueFormat get_ValueFormat();
public: __property void set_ValueFormat(
   ValueFormat value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the current value format. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public:
property ValueFormat ValueFormat {
   ValueFormat get();
   void set (ValueFormat value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

For a list of all members of this type, see RadNumericUpDown members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ContentTextProperty | Identifies the ContentText dependency property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | NumberFormatInfoProperty | Identifies the NumberFormatInfo dependency property.
static (Shared in Visual Basic) | NumericUnitProperty | Identifies the NumericUnit dependency property.
static (Shared in Visual Basic) | ValueFormatProperty | Identifies the ValueFormat dependency property.
Top

See Also

Reference

RadNumericUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ContentTextProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : ContentTextProperty Field

Identifies the ContentText dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ContentTextProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadNumericUpDown.ContentTextProperty
C#
public static readonly DependencyProperty ContentTextProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ContentTextProperty
C++/CLI
public:
static readonly DependencyProperty^ ContentTextProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocusedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : IsFocusedProperty Field

Identifies the IsFocused dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadNumericUpDown.IsFocusedProperty
C#
public static readonly DependencyProperty IsFocusedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFocusedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFocusedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
NumberFormatInfoProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : NumberFormatInfoProperty Field

Identifies the NumberFormatInfo dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NumberFormatInfoProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadNumericUpDown.NumberFormatInfoProperty
C#
public static readonly DependencyProperty NumberFormatInfoProperty
Managed Extensions for C++
public: static readonly DependencyProperty* NumberFormatInfoProperty
C++/CLI
public:
static readonly DependencyProperty^ NumberFormatInfoProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
NumericUnitProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : NumericUnitProperty Field

Identifies the NumericUnit dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NumericUnitProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadNumericUpDown.NumericUnitProperty
C#
public static readonly DependencyProperty NumericUnitProperty
Managed Extensions for C++
public: static readonly DependencyProperty* NumericUnitProperty
C++/CLI
public:
static readonly DependencyProperty^ NumericUnitProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ValueFormatProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadNumericUpDown Class : ValueFormatProperty Field

Identifies the ValueFormat dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ValueFormatProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadNumericUpDown.ValueFormatProperty
C#
public static readonly DependencyProperty ValueFormatProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ValueFormatProperty
C++/CLI
public:
static readonly DependencyProperty^ ValueFormatProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadNumericUpDown Class
RadNumericUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

RadUpDown exposes two repeat buttons for easily handling the RangeBase value

Syntax

Visual Basic (Declaration)
Public Class RadUpDown
   Inherits RangeBase
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
C#
public class RadUpDown : RangeBase, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadUpDown : public RangeBase, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadUpDown : public RangeBase, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.RadUpDown
Telerik.Windows.Controls.RadNumericUpDown

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

The following tables list the members exposed by RadUpDown.

Public Constructors

 | Name | Description
Public Constructor | RadUpDown Constructor | Default constructors which initializes the default values
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DecreaseButtonContentTemplateProperty | Identifies the IncreaseButtonContentTemplate dependency property.
static (Shared in Visual Basic) | DelayProperty | Identifies the DelayProperty dependency property.
static (Shared in Visual Basic) | IncreaseButtonContentTemplateProperty | Identifies the IncreaseButtonContentTemplate dependency property.
static (Shared in Visual Basic) | RepeatIntervalProperty | Identifies the RepeatInterval dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoReverse | Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa. This is a dependency property.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ChangeAcceleration | Gets or sets Change Acceleration property. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DecreaseButtonContentTemplate | Gets or sets the data template of the DecreaseButton. This is a dependency property.
Public Property | Delay | Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IncreaseButtonContentTemplate | Gets or sets the data template of the IncreaseButton. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepeatInterval | Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | Decrease | Decrease repeat button wrapper for children classes
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Protected Property | Increase | Increase repeat button wrapper for children class
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. Overrides OnApplyTemplate and attach all necessary events to the controls TODO: change the binding to TemplateBinding
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : RadUpDown Constructor

Default constructors which initializes the default values

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown()
C#
public RadUpDown()
Managed Extensions for C++
public: RadUpDown();
C++/CLI
public:
RadUpDown();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

For a list of all members of this type, see RadUpDown members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. Overrides OnApplyTemplate and attach all necessary events to the controls TODO: change the binding to TemplateBinding
Public Method | ToString | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnMaximumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnMinimumChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Protected Method | OnValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : OnApplyTemplate Method

Overrides OnApplyTemplate and attach all necessary events to the controls TODO: change the binding to TemplateBinding

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

For a list of all members of this type, see RadUpDown members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoReverse | Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa. This is a dependency property.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ChangeAcceleration | Gets or sets Change Acceleration property. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DecreaseButtonContentTemplate | Gets or sets the data template of the DecreaseButton. This is a dependency property.
Public Property | Delay | Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IncreaseButtonContentTemplate | Gets or sets the data template of the IncreaseButton. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LargeChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Maximum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | Minimum | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepeatInterval | Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SmallChange | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Value | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | Decrease | Decrease repeat button wrapper for children classes
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Protected Property | Increase | Increase repeat button wrapper for children class
Top

See Also

Reference

RadUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AutoReverse Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : AutoReverse Property

Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa.This is a dependency property.")>
<SRCategoryAttribute("BehaviorCategory")>
Public Property AutoReverse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As Boolean

instance.AutoReverse = value

value = instance.AutoReverse
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa.This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public bool AutoReverse {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa.This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public: __property bool get_AutoReverse();
public: __property void set_AutoReverse(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the bool indicating whether the control reverses from maximal to minimal value and vice versa.This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public:
property bool AutoReverse {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ChangeAcceleration Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : ChangeAcceleration Property

Gets or sets Change Acceleration property. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets Change Acceleration property. This is a dependency property.")>
<SRCategoryAttribute("BehaviorCategory")>
Public Property ChangeAcceleration As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As Boolean

instance.ChangeAcceleration = value

value = instance.ChangeAcceleration
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets Change Acceleration property. This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public bool ChangeAcceleration {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets Change Acceleration property. This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public: __property bool get_ChangeAcceleration();
public: __property void set_ChangeAcceleration(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets Change Acceleration property. This is a dependency property.")]
[SRCategoryAttribute("BehaviorCategory")]
public:
property bool ChangeAcceleration {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Decrease Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : Decrease Property

Decrease repeat button wrapper for children classes

Syntax

Visual Basic (Declaration)
Protected Property Decrease As RepeatButton
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As RepeatButton

instance.Decrease = value

value = instance.Decrease
C#
protected RepeatButton Decrease {get; set;}
Managed Extensions for C++
protected: __property RepeatButton* get_Decrease();
protected: __property void set_Decrease(
   RepeatButton* value
);
C++/CLI
protected:
property RepeatButton^ Decrease {
   RepeatButton^ get();
   void set (RepeatButton^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecreaseButtonContentTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : DecreaseButtonContentTemplate Property

Gets or sets the data template of the DecreaseButton. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property DecreaseButtonContentTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As DataTemplate

instance.DecreaseButtonContentTemplate = value

value = instance.DecreaseButtonContentTemplate
C#
public DataTemplate DecreaseButtonContentTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_DecreaseButtonContentTemplate();
public: __property void set_DecreaseButtonContentTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ DecreaseButtonContentTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Delay Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : Delay Property

Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.")>
<DefaultValueAttribute()>
Public Property Delay As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As Integer

instance.Delay = value

value = instance.Delay
C#
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.")]
[DefaultValueAttribute()]
public int Delay {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.")]
[DefaultValueAttribute()]
public: __property int get_Delay();
public: __property void set_Delay(
   int value
);
C++/CLI
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets the delay time in millisconds between the first repetition of the buttons. This is a dependency property.")]
[DefaultValueAttribute()]
public:
property int Delay {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Increase Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : Increase Property

Increase repeat button wrapper for children class

Syntax

Visual Basic (Declaration)
Protected Property Increase As RepeatButton
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As RepeatButton

instance.Increase = value

value = instance.Increase
C#
protected RepeatButton Increase {get; set;}
Managed Extensions for C++
protected: __property RepeatButton* get_Increase();
protected: __property void set_Increase(
   RepeatButton* value
);
C++/CLI
protected:
property RepeatButton^ Increase {
   RepeatButton^ get();
   void set (RepeatButton^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IncreaseButtonContentTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : IncreaseButtonContentTemplate Property

Gets or sets the data template of the IncreaseButton. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IncreaseButtonContentTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As DataTemplate

instance.IncreaseButtonContentTemplate = value

value = instance.IncreaseButtonContentTemplate
C#
public DataTemplate IncreaseButtonContentTemplate {get; set;}
Managed Extensions for C++
public: __property DataTemplate* get_IncreaseButtonContentTemplate();
public: __property void set_IncreaseButtonContentTemplate(
   DataTemplate* value
);
C++/CLI
public:
property DataTemplate^ IncreaseButtonContentTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RepeatInterval Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : RepeatInterval Property

Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
Public Property RepeatInterval As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpDown
Dim value As Integer

instance.RepeatInterval = value

value = instance.RepeatInterval
C#
[SRDescriptionAttribute("Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public int RepeatInterval {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public: __property int get_RepeatInterval();
public: __property void set_RepeatInterval(
   int value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the repeat interval between every repetition except the first one. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public:
property int RepeatInterval {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

For a list of all members of this type, see RadUpDown members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DecreaseButtonContentTemplateProperty | Identifies the IncreaseButtonContentTemplate dependency property.
static (Shared in Visual Basic) | DelayProperty | Identifies the DelayProperty dependency property.
static (Shared in Visual Basic) | IncreaseButtonContentTemplateProperty | Identifies the IncreaseButtonContentTemplate dependency property.
static (Shared in Visual Basic) | RepeatIntervalProperty | Identifies the RepeatInterval dependency property.
Top

See Also

Reference

RadUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DecreaseButtonContentTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : DecreaseButtonContentTemplateProperty Field

Identifies the IncreaseButtonContentTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DecreaseButtonContentTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpDown.DecreaseButtonContentTemplateProperty
C#
public static readonly DependencyProperty DecreaseButtonContentTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DecreaseButtonContentTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ DecreaseButtonContentTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DelayProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : DelayProperty Field

Identifies the DelayProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DelayProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpDown.DelayProperty
C#
public static readonly DependencyProperty DelayProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DelayProperty
C++/CLI
public:
static readonly DependencyProperty^ DelayProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IncreaseButtonContentTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : IncreaseButtonContentTemplateProperty Field

Identifies the IncreaseButtonContentTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IncreaseButtonContentTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpDown.IncreaseButtonContentTemplateProperty
C#
public static readonly DependencyProperty IncreaseButtonContentTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IncreaseButtonContentTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ IncreaseButtonContentTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RepeatIntervalProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpDown Class : RepeatIntervalProperty Field

Identifies the RepeatInterval dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RepeatIntervalProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpDown.RepeatIntervalProperty
C#
public static readonly DependencyProperty RepeatIntervalProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RepeatIntervalProperty
C++/CLI
public:
static readonly DependencyProperty^ RepeatIntervalProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpDown Class
RadUpDown Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

A composite control, allowing you to upload a single or multiple files. The RadUpload control allows you to validate in terms of size and extension the selected files on the client, progress display, skin, etc.

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class RadUpload
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
C#
[ScriptableTypeAttribute()]
public class RadUpload : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class RadUpload : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[ScriptableTypeAttribute()]
public ref class RadUpload : public Control, IManagedPeer, INativeCoreTypeWrapper

Remarks

Use the RadUpload control to allow the upload of a single or multiple files.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadUpload

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

The following tables list the members exposed by RadUpload.

Public Constructors

 | Name | Description
Public Constructor | RadUpload Constructor | Initializes a new instance of the RadUpload class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BufferSizeProperty | Identifies the BufferSizeProperty dependency property.
static (Shared in Visual Basic) | FilterIndexProperty | Identifies the FilterIndexProperty dependency property.
static (Shared in Visual Basic) | FilterProperty | Identifies the FilterProperty dependency property.
static (Shared in Visual Basic) | IsAutomaticUploadProperty | Identifies the IsAutomaticUploadProperty dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabledProperty dependency property.
static (Shared in Visual Basic) | IsMultiselectProperty | Identifies the IsMultiselectProperty dependency property.
static (Shared in Visual Basic) | IsPauseEnabledProperty | Identifies the IsPauseEnabledProperty dependency property.
static (Shared in Visual Basic) | MaxFileCountProperty | Identifies the MaxFileCountProperty dependency property.
static (Shared in Visual Basic) | MaxFileSizeProperty | Identifies the MaxFileSizeProperty dependency property.
static (Shared in Visual Basic) | MaxUploadSizeProperty | Identifies the MaxUploadSizeProperty dependency property.
static (Shared in Visual Basic) | OverwriteExistingFilesProperty | Identifies the OverwriteExistingFilesProperty dependency property.
static (Shared in Visual Basic) | RegisterForSubmitProperty | Identifies the RegisterForSubmitProperty dependency property.
static (Shared in Visual Basic) | TargetFolderProperty | Identifies the TargetFolderProperty dependency property.
static (Shared in Visual Basic) | TargetPhysicalFolderProperty | Identifies the TargetPhysicalFolderProperty dependency property.
static (Shared in Visual Basic) | UploadServiceUrlProperty | Identifies the UploadServiceUrlProperty dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BufferSize | Gets or sets the size of the chunks on which the files will be posted to the server.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Open File Dialog" box.
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsAutomaticUpload | Gets or sets whether the file(s) should be uploaded right after they are selected.
Public Property | IsEnabled | Gets or sets whether the control is enabled.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMultiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public Property | IsPauseEnabled | Gets or sets a value indicating whether the pause button is enabled.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxFileCount | Gets or sets the maximum allowed number of files selected.
Public Property | MaxFileSize | Gets or sets the maximum allowed size of a single file, in bytes.
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxUploadSize | Gets or sets the maximum Total allowed size for the selected files, in bytes.
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | OverwriteExistingFiles | Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | TargetFolder | Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TargetPhysicalFolder | Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | UploadServiceUrl | Gets or sets the url to the UploadService.
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | CancelUpload |
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden.
Public Method | PauseUpload |
Public Method | ResumeUpload |
Public Method | SetInitialUIState |
Public Method | ShowFileDialog |
Public Method | StartUpload |
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | FileCountExceeded |
Public Event | FilesSelected |
Public Event | FileTooLarge |
Public Event | FileUploaded |
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | ProgressChanged |
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | UploadCanceled |
Public Event | UploadFinished |
Public Event | UploadPaused |
Public Event | UploadResumed |
Public Event | UploadSizeExceeded |
Public Event | UploadStarted |
Top

See Also

Reference

RadUpload Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : RadUpload Constructor

Initializes a new instance of the RadUpload class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload()
C#
public RadUpload()
Managed Extensions for C++
public: RadUpload();
C++/CLI
public:
RadUpload();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Methods

 | Name | Description
Public Method | CancelUpload |
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden.
Public Method | PauseUpload |
Public Method | ResumeUpload |
Public Method | SetInitialUIState |
Public Method | ShowFileDialog |
Public Method | StartUpload |
Top

See Also

Reference

RadUpload Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CancelUpload Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : CancelUpload Method

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub CancelUpload()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.CancelUpload()
C#
[ScriptableMemberAttribute()]
public void CancelUpload()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void CancelUpload();
C++/CLI
[ScriptableMemberAttribute()]
public:
void CancelUpload();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : OnApplyTemplate Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
PauseUpload Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : PauseUpload Method

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub PauseUpload()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.PauseUpload()
C#
[ScriptableMemberAttribute()]
public void PauseUpload()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void PauseUpload();
C++/CLI
[ScriptableMemberAttribute()]
public:
void PauseUpload();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ResumeUpload Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : ResumeUpload Method

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub ResumeUpload()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.ResumeUpload()
C#
[ScriptableMemberAttribute()]
public void ResumeUpload()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void ResumeUpload();
C++/CLI
[ScriptableMemberAttribute()]
public:
void ResumeUpload();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SetInitialUIState Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : SetInitialUIState Method

Syntax

Visual Basic (Declaration)
Public Sub SetInitialUIState()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.SetInitialUIState()
C#
public void SetInitialUIState()
Managed Extensions for C++
public: void SetInitialUIState();
C++/CLI
public:
void SetInitialUIState();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ShowFileDialog Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : ShowFileDialog Method

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub ShowFileDialog()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.ShowFileDialog()
C#
[ScriptableMemberAttribute()]
public void ShowFileDialog()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void ShowFileDialog();
C++/CLI
[ScriptableMemberAttribute()]
public:
void ShowFileDialog();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
StartUpload Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : StartUpload Method

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub StartUpload()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload

instance.StartUpload()
C#
[ScriptableMemberAttribute()]
public void StartUpload()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void StartUpload();
C++/CLI
[ScriptableMemberAttribute()]
public:
void StartUpload();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BufferSize | Gets or sets the size of the chunks on which the files will be posted to the server.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Open File Dialog" box.
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsAutomaticUpload | Gets or sets whether the file(s) should be uploaded right after they are selected.
Public Property | IsEnabled | Gets or sets whether the control is enabled.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMultiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public Property | IsPauseEnabled | Gets or sets a value indicating whether the pause button is enabled.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxFileCount | Gets or sets the maximum allowed number of files selected.
Public Property | MaxFileSize | Gets or sets the maximum allowed size of a single file, in bytes.
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxUploadSize | Gets or sets the maximum Total allowed size for the selected files, in bytes.
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | OverwriteExistingFiles | Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | TargetFolder | Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TargetPhysicalFolder | Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | UploadServiceUrl | Gets or sets the url to the UploadService.
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadUpload Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
BufferSize Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : BufferSize Property

Gets or sets the size of the chunks on which the files will be posted to the server.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property BufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.BufferSize = value

value = instance.BufferSize
C#
[ScriptableMemberAttribute()]
public int BufferSize {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_BufferSize();
public: __property void set_BufferSize(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property int BufferSize {
   int get();
   void set (int value);
}

Remarks

The size is in Bytes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Filter Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : Filter Property

Gets or sets the current file name filter string, which determines the choices that appear in the "Open File Dialog" box.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property Filter As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.Filter = value

value = instance.Filter
C#
[ScriptableMemberAttribute()]
public string Filter {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_Filter();
public: __property void set_Filter(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ Filter {
   String^ get();
   void set (String^ value);
}

Example

The following is an example of a filter string: Text files (*.txt)|*.txt|All files (*.*)|*.* You can add several filter patterns to a filter by separating the file types with semicolons, for example: Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*

Remarks

For each filtering option, the filter string contains a description of the filter, followed by the vertical bar (|) and the filter pattern. The strings for different filtering options are separated by the vertical bar. You can add several filter patterns to a filter by separating the file types with semicolons, for example: Use the FilterIndex property to set which filtering option is shown first to the user. By default all file extensions will be allowed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
FilterIndex Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilterIndex Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property FilterIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.FilterIndex = value

value = instance.FilterIndex
C#
[ScriptableMemberAttribute()]
public int FilterIndex {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_FilterIndex();
public: __property void set_FilterIndex(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property int FilterIndex {
   int get();
   void set (int value);
}

Remarks

The index value of the first filter entry is 1. by default the first item is selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
Filter Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsAutomaticUpload Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsAutomaticUpload Property

Gets or sets whether the file(s) should be uploaded right after they are selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsAutomaticUpload As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.IsAutomaticUpload = value

value = instance.IsAutomaticUpload
C#
[ScriptableMemberAttribute()]
public bool IsAutomaticUpload {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsAutomaticUpload();
public: __property void set_IsAutomaticUpload(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsAutomaticUpload {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsEnabled Property

Gets or sets whether the control is enabled.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[ScriptableMemberAttribute()]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsMultiselect Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsMultiselect Property

Gets or sets a value indicating whether the dialog box allows multiple files to be selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsMultiselect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.IsMultiselect = value

value = instance.IsMultiselect
C#
[ScriptableMemberAttribute()]
public bool IsMultiselect {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsMultiselect();
public: __property void set_IsMultiselect(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsMultiselect {
   bool get();
   void set (bool value);
}

Remarks

By default the multiple selection is enabled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
Filter Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsPauseEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsPauseEnabled Property

Gets or sets a value indicating whether the pause button is enabled.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsPauseEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.IsPauseEnabled = value

value = instance.IsPauseEnabled
C#
[ScriptableMemberAttribute()]
public bool IsPauseEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsPauseEnabled();
public: __property void set_IsPauseEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsPauseEnabled {
   bool get();
   void set (bool value);
}

Remarks

By default the pause button is enabled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxFileCount Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxFileCount Property

Gets or sets the maximum allowed number of files selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property MaxFileCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.MaxFileCount = value

value = instance.MaxFileCount
C#
[ScriptableMemberAttribute()]
public int MaxFileCount {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_MaxFileCount();
public: __property void set_MaxFileCount(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property int MaxFileCount {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxFileSize Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxFileSize Property

Gets or sets the maximum allowed size of a single file, in bytes.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property MaxFileSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.MaxFileSize = value

value = instance.MaxFileSize
C#
[ScriptableMemberAttribute()]
public int MaxFileSize {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_MaxFileSize();
public: __property void set_MaxFileSize(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property int MaxFileSize {
   int get();
   void set (int value);
}

Remarks

The size is in Bytes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxUploadSize Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxUploadSize Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxUploadSize Property

Gets or sets the maximum Total allowed size for the selected files, in bytes.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property MaxUploadSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.MaxUploadSize = value

value = instance.MaxUploadSize
C#
[ScriptableMemberAttribute()]
public int MaxUploadSize {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_MaxUploadSize();
public: __property void set_MaxUploadSize(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property int MaxUploadSize {
   int get();
   void set (int value);
}

Remarks

The size is in Bytes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileSize Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OverwriteExistingFiles Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : OverwriteExistingFiles Property

Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property OverwriteExistingFiles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.OverwriteExistingFiles = value

value = instance.OverwriteExistingFiles
C#
[ScriptableMemberAttribute()]
public bool OverwriteExistingFiles {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_OverwriteExistingFiles();
public: __property void set_OverwriteExistingFiles(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool OverwriteExistingFiles {
   bool get();
   void set (bool value);
}

Remarks

When set to true, the existing files are overwritten, else no action is taken.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TargetFolder Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : TargetFolder Property

Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property TargetFolder As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.TargetFolder = value

value = instance.TargetFolder
C#
[ScriptableMemberAttribute()]
public string TargetFolder {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_TargetFolder();
public: __property void set_TargetFolder(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ TargetFolder {
   String^ get();
   void set (String^ value);
}

Return Value

A string containing the virtual path of the folder where RadUpload will automatically save the valid files after the upload completes.

Remarks

If both TargetPhysicalFolder property and this property are set, the TargetPhysicalFolder will override the virtual path provided by TargetFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
OverwriteExistingFiles Property
FileExists Event
TargetPhysicalFolder Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TargetPhysicalFolder Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : TargetPhysicalFolder Property

Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property TargetPhysicalFolder As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.TargetPhysicalFolder = value

value = instance.TargetPhysicalFolder
C#
[ScriptableMemberAttribute()]
public string TargetPhysicalFolder {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_TargetPhysicalFolder();
public: __property void set_TargetPhysicalFolder(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ TargetPhysicalFolder {
   String^ get();
   void set (String^ value);
}

Return Value

A string containing the physical path of the folder where RadUpload will automatically save the valid files after the upload completes.

Remarks

If both TargetFolder property and this property are set, the TargetPhysicalFolder will override the virtual path provided by TargetFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members
TargetFolder Property
OverwriteExistingFiles Property


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadServiceUrl Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadServiceUrl Property

Gets or sets the url to the UploadService.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property UploadServiceUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.UploadServiceUrl = value

value = instance.UploadServiceUrl
C#
[ScriptableMemberAttribute()]
public string UploadServiceUrl {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_UploadServiceUrl();
public: __property void set_UploadServiceUrl(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ UploadServiceUrl {
   String^ get();
   void set (String^ value);
}

Example

<telerik:RadUpload TargetFolder="~/Uploads" UploadServiceUrl="/Ag/RadUploadHandler.ashx" />

Remarks

The Upload handler should be on the same server where the silverlight page is hosted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BufferSizeProperty | Identifies the BufferSizeProperty dependency property.
static (Shared in Visual Basic) | FilterIndexProperty | Identifies the FilterIndexProperty dependency property.
static (Shared in Visual Basic) | FilterProperty | Identifies the FilterProperty dependency property.
static (Shared in Visual Basic) | IsAutomaticUploadProperty | Identifies the IsAutomaticUploadProperty dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabledProperty dependency property.
static (Shared in Visual Basic) | IsMultiselectProperty | Identifies the IsMultiselectProperty dependency property.
static (Shared in Visual Basic) | IsPauseEnabledProperty | Identifies the IsPauseEnabledProperty dependency property.
static (Shared in Visual Basic) | MaxFileCountProperty | Identifies the MaxFileCountProperty dependency property.
static (Shared in Visual Basic) | MaxFileSizeProperty | Identifies the MaxFileSizeProperty dependency property.
static (Shared in Visual Basic) | MaxUploadSizeProperty | Identifies the MaxUploadSizeProperty dependency property.
static (Shared in Visual Basic) | OverwriteExistingFilesProperty | Identifies the OverwriteExistingFilesProperty dependency property.
static (Shared in Visual Basic) | RegisterForSubmitProperty | Identifies the RegisterForSubmitProperty dependency property.
static (Shared in Visual Basic) | TargetFolderProperty | Identifies the TargetFolderProperty dependency property.
static (Shared in Visual Basic) | TargetPhysicalFolderProperty | Identifies the TargetPhysicalFolderProperty dependency property.
static (Shared in Visual Basic) | UploadServiceUrlProperty | Identifies the UploadServiceUrlProperty dependency property.
Top

See Also

Reference

RadUpload Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
BufferSizeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : BufferSizeProperty Field

Identifies the BufferSizeProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BufferSizeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.BufferSizeProperty
C#
public static readonly DependencyProperty BufferSizeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* BufferSizeProperty
C++/CLI
public:
static readonly DependencyProperty^ BufferSizeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilterIndexProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FilterIndexProperty Field

Identifies the FilterIndexProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FilterIndexProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.FilterIndexProperty
C#
public static readonly DependencyProperty FilterIndexProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FilterIndexProperty
C++/CLI
public:
static readonly DependencyProperty^ FilterIndexProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilterProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FilterProperty Field

Identifies the FilterProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FilterProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.FilterProperty
C#
public static readonly DependencyProperty FilterProperty
Managed Extensions for C++
public: static readonly DependencyProperty* FilterProperty
C++/CLI
public:
static readonly DependencyProperty^ FilterProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsAutomaticUploadProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsAutomaticUploadProperty Field

Identifies the IsAutomaticUploadProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsAutomaticUploadProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.IsAutomaticUploadProperty
C#
public static readonly DependencyProperty IsAutomaticUploadProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsAutomaticUploadProperty
C++/CLI
public:
static readonly DependencyProperty^ IsAutomaticUploadProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsEnabledProperty Field

Identifies the IsEnabledProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsMultiselectProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsMultiselectProperty Field

Identifies the IsMultiselectProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMultiselectProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.IsMultiselectProperty
C#
public static readonly DependencyProperty IsMultiselectProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMultiselectProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMultiselectProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsPauseEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : IsPauseEnabledProperty Field

Identifies the IsPauseEnabledProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsPauseEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.IsPauseEnabledProperty
C#
public static readonly DependencyProperty IsPauseEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsPauseEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsPauseEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxFileCountProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxFileCountProperty Field

Identifies the MaxFileCountProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxFileCountProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.MaxFileCountProperty
C#
public static readonly DependencyProperty MaxFileCountProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MaxFileCountProperty
C++/CLI
public:
static readonly DependencyProperty^ MaxFileCountProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxFileSizeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxFileSizeProperty Field

Identifies the MaxFileSizeProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxFileSizeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.MaxFileSizeProperty
C#
public static readonly DependencyProperty MaxFileSizeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MaxFileSizeProperty
C++/CLI
public:
static readonly DependencyProperty^ MaxFileSizeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MaxUploadSizeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : MaxUploadSizeProperty Field

Identifies the MaxUploadSizeProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxUploadSizeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.MaxUploadSizeProperty
C#
public static readonly DependencyProperty MaxUploadSizeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MaxUploadSizeProperty
C++/CLI
public:
static readonly DependencyProperty^ MaxUploadSizeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OverwriteExistingFilesProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : OverwriteExistingFilesProperty Field

Identifies the OverwriteExistingFilesProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OverwriteExistingFilesProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.OverwriteExistingFilesProperty
C#
public static readonly DependencyProperty OverwriteExistingFilesProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OverwriteExistingFilesProperty
C++/CLI
public:
static readonly DependencyProperty^ OverwriteExistingFilesProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RegisterForSubmitProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : RegisterForSubmitProperty Field

Identifies the RegisterForSubmitProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RegisterForSubmitProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.RegisterForSubmitProperty
C#
public static readonly DependencyProperty RegisterForSubmitProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RegisterForSubmitProperty
C++/CLI
public:
static readonly DependencyProperty^ RegisterForSubmitProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TargetFolderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : TargetFolderProperty Field

Identifies the TargetFolderProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TargetFolderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.TargetFolderProperty
C#
public static readonly DependencyProperty TargetFolderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TargetFolderProperty
C++/CLI
public:
static readonly DependencyProperty^ TargetFolderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TargetPhysicalFolderProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : TargetPhysicalFolderProperty Field

Identifies the TargetPhysicalFolderProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TargetPhysicalFolderProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.TargetPhysicalFolderProperty
C#
public static readonly DependencyProperty TargetPhysicalFolderProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TargetPhysicalFolderProperty
C++/CLI
public:
static readonly DependencyProperty^ TargetPhysicalFolderProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadServiceUrlProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadServiceUrlProperty Field

Identifies the UploadServiceUrlProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UploadServiceUrlProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadUpload.UploadServiceUrlProperty
C#
public static readonly DependencyProperty UploadServiceUrlProperty
Managed Extensions for C++
public: static readonly DependencyProperty* UploadServiceUrlProperty
C++/CLI
public:
static readonly DependencyProperty^ UploadServiceUrlProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpload Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | FileCountExceeded |
Public Event | FilesSelected |
Public Event | FileTooLarge |
Public Event | FileUploaded |
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | ProgressChanged |
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | UploadCanceled |
Public Event | UploadFinished |
Public Event | UploadPaused |
Public Event | UploadResumed |
Public Event | UploadSizeExceeded |
Public Event | UploadStarted |
Top

See Also

Reference

RadUpload Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileCountExceeded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FileCountExceeded Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event FileCountExceeded() As EventHandler(Of RoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of RoutedEventArgs)

AddHandler instance.FileCountExceeded, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RoutedEventArgs> FileCountExceeded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RoutedEventArgs*>* FileCountExceeded
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RoutedEventArgs^>^ FileCountExceeded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FilesSelected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FilesSelected Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event FilesSelected() As EventHandler(Of FilesSelectedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of FilesSelectedEventArgs)

AddHandler instance.FilesSelected, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<FilesSelectedEventArgs> FilesSelected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<FilesSelectedEventArgs*>* FilesSelected
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<FilesSelectedEventArgs^>^ FilesSelected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileTooLarge Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FileTooLarge Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event FileTooLarge() As EventHandler(Of RoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of RoutedEventArgs)

AddHandler instance.FileTooLarge, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RoutedEventArgs> FileTooLarge()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RoutedEventArgs*>* FileTooLarge
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RoutedEventArgs^>^ FileTooLarge

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileUploaded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : FileUploaded Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event FileUploaded() As EventHandler(Of FileUploadedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of FileUploadedEventArgs)

AddHandler instance.FileUploaded, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<FileUploadedEventArgs> FileUploaded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<FileUploadedEventArgs*>* FileUploaded
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<FileUploadedEventArgs^>^ FileUploaded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ProgressChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : ProgressChanged Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event ProgressChanged() As EventHandler(Of UploadProgressEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of UploadProgressEventArgs)

AddHandler instance.ProgressChanged, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<UploadProgressEventArgs> ProgressChanged()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<UploadProgressEventArgs*>* ProgressChanged
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<UploadProgressEventArgs^>^ ProgressChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadCanceled Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadCanceled Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadCanceled() As EventHandler(Of EventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.UploadCanceled, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<EventArgs> UploadCanceled()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<EventArgs*>* UploadCanceled
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<EventArgs^>^ UploadCanceled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadFinished Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadFinished Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadFinished() As EventHandler(Of EventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.UploadFinished, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<EventArgs> UploadFinished()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<EventArgs*>* UploadFinished
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<EventArgs^>^ UploadFinished

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadPaused Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadPaused Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadPaused() As EventHandler(Of EventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.UploadPaused, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<EventArgs> UploadPaused()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<EventArgs*>* UploadPaused
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<EventArgs^>^ UploadPaused

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadResumed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadResumed Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadResumed() As EventHandler(Of EventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.UploadResumed, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<EventArgs> UploadResumed()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<EventArgs*>* UploadResumed
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<EventArgs^>^ UploadResumed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadSizeExceeded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadSizeExceeded Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadSizeExceeded() As EventHandler(Of RoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of RoutedEventArgs)

AddHandler instance.UploadSizeExceeded, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RoutedEventArgs> UploadSizeExceeded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RoutedEventArgs*>* UploadSizeExceeded
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RoutedEventArgs^>^ UploadSizeExceeded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadStarted Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUpload Class : UploadStarted Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event UploadStarted() As EventHandler(Of UploadStartedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As EventHandler(Of UploadStartedEventArgs)

AddHandler instance.UploadStarted, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<UploadStartedEventArgs> UploadStarted()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<UploadStartedEventArgs*>* UploadStarted
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<UploadStartedEventArgs^>^ UploadStarted

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUpload Class
RadUpload Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadUploadItem Class

Syntax

Visual Basic (Declaration)
Public Class RadUploadItem
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
C#
public class RadUploadItem : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadUploadItem : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadUploadItem : public Control, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadUploadItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadUploadItem Class

The following tables list the members exposed by RadUploadItem.

Public Constructors

 | Name | Description
Public Constructor | RadUploadItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FileName |
Public Property | FileProgress |
Public Property | FileSize |
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDeleteEnabled |
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden.
Public Method | SetError |
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Delete |
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadUploadItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : RadUploadItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem()
C#
public RadUploadItem()
Managed Extensions for C++
public: RadUploadItem();
C++/CLI
public:
RadUploadItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadUploadItem Class

For a list of all members of this type, see RadUploadItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden.
Public Method | SetError |
Top

See Also

Reference

RadUploadItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : OnApplyTemplate Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SetError Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : SetError Method

message

Syntax

Visual Basic (Declaration)
Public Sub SetError( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
Dim message As String

instance.SetError(message)
C#
public void SetError(
   string message
)
Managed Extensions for C++
public: void SetError(
   string* message
)
C++/CLI
public:
void SetError(
   String^ message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadUploadItem Class

For a list of all members of this type, see RadUploadItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FileName |
Public Property | FileProgress |
Public Property | FileSize |
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsDeleteEnabled |
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadUploadItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileName Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : FileName Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
Dim value As String

instance.FileName = value

value = instance.FileName
C#
[CompilerGeneratedAttribute()]
public string FileName {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileProgress Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : FileProgress Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FileProgress As Double
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem

instance.FileProgress = value
C#
public double FileProgress {set;}
Managed Extensions for C++
public: __property void set_FileProgress(
   double value
);
C++/CLI
public:
property double FileProgress {
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
FileSize Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : FileSize Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property FileSize As String
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
Dim value As String

instance.FileSize = value

value = instance.FileSize
C#
[CompilerGeneratedAttribute()]
public string FileSize {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property string* get_FileSize();
public: __property void set_FileSize(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property String^ FileSize {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsDeleteEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : IsDeleteEnabled Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property IsDeleteEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
Dim value As Boolean

instance.IsDeleteEnabled = value

value = instance.IsDeleteEnabled
C#
[CompilerGeneratedAttribute()]
public bool IsDeleteEnabled {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property bool get_IsDeleteEnabled();
public: __property void set_IsDeleteEnabled(
   bool value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property bool IsDeleteEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadUploadItem Class

For a list of all members of this type, see RadUploadItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Delete |
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadUploadItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Delete Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadItem Class : Delete Event

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Delete() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUploadItem
Dim handler As EventHandler

AddHandler instance.Delete, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler Delete()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler* Delete
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler^ Delete

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadItem Class
RadUploadItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadSelectedFile Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadUploadSelectedFile Class

Syntax

Visual Basic (Declaration)
Public Class RadUploadSelectedFile
Visual Basic (Usage) Copy Code
Dim instance As RadUploadSelectedFile
C#
public class RadUploadSelectedFile
Managed Extensions for C++
public __gc class RadUploadSelectedFile
C++/CLI
public ref class RadUploadSelectedFile

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.RadUploadSelectedFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadSelectedFile Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadSelectedFile Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RadUploadSelectedFile Class

The following tables list the members exposed by RadUploadSelectedFile.

Public Constructors

 | Name | Description
Public Constructor | RadUploadSelectedFile Constructor |
Top

Public Properties

 | Name | Description
Public Property | File |
Public Property | Name |
Public Property | Size |
Top

See Also

Reference

RadUploadSelectedFile Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadSelectedFile Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadSelectedFile Class : RadUploadSelectedFile Constructor

file

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal file As FileDialogFileInfo _
)
Visual Basic (Usage) Copy Code
Dim file As FileDialogFileInfo

Dim instance As RadUploadSelectedFile(file)
C#
public RadUploadSelectedFile(
   FileDialogFileInfo file
)
Managed Extensions for C++
public: RadUploadSelectedFile(
   FileDialogFileInfo* file
)
C++/CLI
public:
RadUploadSelectedFile(
   FileDialogFileInfo^ file
)

Parameters

file

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadSelectedFile Class
RadUploadSelectedFile Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUploadSelectedFile Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadUploadSelectedFile Class

For a list of all members of this type, see RadUploadSelectedFile members.

Public Properties

 | Name | Description
Public Property | File |
Public Property | Name |
Public Property | Size |
Top

See Also

Reference

RadUploadSelectedFile Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
File Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadSelectedFile Class : File Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property File As FileDialogFileInfo
Visual Basic (Usage) Copy Code
Dim instance As RadUploadSelectedFile
Dim value As FileDialogFileInfo

value = instance.File
C#
public FileDialogFileInfo File {get;}
Managed Extensions for C++
public: __property FileDialogFileInfo* get_File();
C++/CLI
public:
property FileDialogFileInfo^ File {
   FileDialogFileInfo^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadSelectedFile Class
RadUploadSelectedFile Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Name Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadSelectedFile Class : Name Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As RadUploadSelectedFile
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadSelectedFile Class
RadUploadSelectedFile Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Size Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadUploadSelectedFile Class : Size Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Long
Visual Basic (Usage) Copy Code
Dim instance As RadUploadSelectedFile
Dim value As Long

value = instance.Size
C#
public long Size {get;}
Managed Extensions for C++
public: __property long get_Size();
C++/CLI
public:
property long long Size {
   long long get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadUploadSelectedFile Class
RadUploadSelectedFile Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadProgressEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : UploadProgressEventArgs Class

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class UploadProgressEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
C#
[ScriptableTypeAttribute()]
public class UploadProgressEventArgs : EventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class UploadProgressEventArgs : public EventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class UploadProgressEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.UploadProgressEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
UploadProgressEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : UploadProgressEventArgs Class

The following tables list the members exposed by UploadProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UploadProgressEventArgs Constructor | Initializes a new instance of the UploadProgressEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CurrentFileIndex | Gets the index of the current file.
Public Property | CurrentFileLength | Gets the length of the current file.
Public Property | CurrentFileName | Gets the name of the current file.
Public Property | CurrentFilePosition | Gets the current file position.
Public Property | TotalFileCount | Gets the total file count.
Top

See Also

Reference

UploadProgressEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadProgressEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : UploadProgressEventArgs Constructor

currentFileName
Name of the current file.
currentFileIndex
Index of the current file.
currentFilePosition
The current file position.
currentFileLength
Length of the current file.
totalFileCount
The total file count.
Initializes a new instance of the UploadProgressEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal currentFileName As String, _
   ByVal currentFileIndex As Integer, _
   ByVal currentFilePosition As Long, _
   ByVal currentFileLength As Long, _
   ByVal totalFileCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim currentFileName As String
Dim currentFileIndex As Integer
Dim currentFilePosition As Long
Dim currentFileLength As Long
Dim totalFileCount As Integer

Dim instance As UploadProgressEventArgs(currentFileName, currentFileIndex, currentFilePosition, currentFileLength, totalFileCount)
C#
public UploadProgressEventArgs(
   string currentFileName,
   int currentFileIndex,
   long currentFilePosition,
   long currentFileLength,
   int totalFileCount
)
Managed Extensions for C++
public: UploadProgressEventArgs(
   string* currentFileName,
   int currentFileIndex,
   long currentFilePosition,
   long currentFileLength,
   int totalFileCount
)
C++/CLI
public:
UploadProgressEventArgs(
   String^ currentFileName,
   int currentFileIndex,
   long long currentFilePosition,
   long long currentFileLength,
   int totalFileCount
)

Parameters

currentFileName
Name of the current file.
currentFileIndex
Index of the current file.
currentFilePosition
The current file position.
currentFileLength
Length of the current file.
totalFileCount
The total file count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
UploadProgressEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : UploadProgressEventArgs Class

For a list of all members of this type, see UploadProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | CurrentFileIndex | Gets the index of the current file.
Public Property | CurrentFileLength | Gets the length of the current file.
Public Property | CurrentFileName | Gets the name of the current file.
Public Property | CurrentFilePosition | Gets the current file position.
Public Property | TotalFileCount | Gets the total file count.
Top

See Also

Reference

UploadProgressEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CurrentFileIndex Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : CurrentFileIndex Property

Gets the index of the current file.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property CurrentFileIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
Dim value As Integer

value = instance.CurrentFileIndex
C#
[ScriptableMemberAttribute()]
public int CurrentFileIndex {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_CurrentFileIndex();
C++/CLI
[ScriptableMemberAttribute()]
public:
property int CurrentFileIndex {
   int get();
}

Return Value

The index of the current file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CurrentFileLength Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : CurrentFileLength Property

Gets the length of the current file.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property CurrentFileLength As Long
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
Dim value As Long

value = instance.CurrentFileLength
C#
[ScriptableMemberAttribute()]
public long CurrentFileLength {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property long get_CurrentFileLength();
C++/CLI
[ScriptableMemberAttribute()]
public:
property long long CurrentFileLength {
   long long get();
}

Return Value

The length of the current file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CurrentFileName Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : CurrentFileName Property

Gets the name of the current file.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property CurrentFileName As String
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
Dim value As String

value = instance.CurrentFileName
C#
[ScriptableMemberAttribute()]
public string CurrentFileName {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_CurrentFileName();
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ CurrentFileName {
   String^ get();
}

Return Value

The name of the current file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CurrentFilePosition Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : CurrentFilePosition Property

Gets the current file position.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property CurrentFilePosition As Long
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
Dim value As Long

value = instance.CurrentFilePosition
C#
[ScriptableMemberAttribute()]
public long CurrentFilePosition {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property long get_CurrentFilePosition();
C++/CLI
[ScriptableMemberAttribute()]
public:
property long long CurrentFilePosition {
   long long get();
}

Return Value

The current file position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TotalFileCount Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadProgressEventArgs Class : TotalFileCount Property

Gets the total file count.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property TotalFileCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As UploadProgressEventArgs
Dim value As Integer

value = instance.TotalFileCount
C#
[ScriptableMemberAttribute()]
public int TotalFileCount {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property int get_TotalFileCount();
C++/CLI
[ScriptableMemberAttribute()]
public:
property int TotalFileCount {
   int get();
}

Return Value

The total file count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadProgressEventArgs Class
UploadProgressEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadStartedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : UploadStartedEventArgs Class

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class UploadStartedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UploadStartedEventArgs
C#
[ScriptableTypeAttribute()]
public class UploadStartedEventArgs : EventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class UploadStartedEventArgs : public EventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class UploadStartedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.UploadStartedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadStartedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
UploadStartedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : UploadStartedEventArgs Class

The following tables list the members exposed by UploadStartedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UploadStartedEventArgs Constructor | Initializes a new instance of the UploadStartedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | SelectedFiles | Gets the selected files.
Top

See Also

Reference

UploadStartedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
UploadStartedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > UploadStartedEventArgs Class : UploadStartedEventArgs Constructor

selectedFiles
The selected files.
Initializes a new instance of the UploadStartedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectedFiles As IList(Of RadUploadSelectedFile) _
)
Visual Basic (Usage) Copy Code
Dim selectedFiles As IList(Of RadUploadSelectedFile)

Dim instance As UploadStartedEventArgs(selectedFiles)
C#
public UploadStartedEventArgs(
   IList<RadUploadSelectedFile> selectedFiles
)
Managed Extensions for C++
public: UploadStartedEventArgs(
   IList<RadUploadSelectedFile*>* selectedFiles
)
C++/CLI
public:
UploadStartedEventArgs(
   IList<RadUploadSelectedFile^>^ selectedFiles
)

Parameters

selectedFiles
The selected files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadStartedEventArgs Class
UploadStartedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
UploadStartedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : UploadStartedEventArgs Class

For a list of all members of this type, see UploadStartedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedFiles | Gets the selected files.
Top

See Also

Reference

UploadStartedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SelectedFiles Property
See Also
[image]
Telerik.Windows.Controls Namespace > UploadStartedEventArgs Class : SelectedFiles Property

Gets the selected files.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property SelectedFiles As IList(Of RadUploadSelectedFile)
Visual Basic (Usage) Copy Code
Dim instance As UploadStartedEventArgs
Dim value As IList(Of RadUploadSelectedFile)

value = instance.SelectedFiles
C#
[ScriptableMemberAttribute()]
public IList<RadUploadSelectedFile> SelectedFiles {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property IList<RadUploadSelectedFile*>* get_SelectedFiles();
C++/CLI
[ScriptableMemberAttribute()]
public:
property IList<RadUploadSelectedFile^>^ SelectedFiles {
   IList<RadUploadSelectedFile^>^ get();
}

Return Value

The selected files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UploadStartedEventArgs Class
UploadStartedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ValueFormat Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : ValueFormat Enumeration

UpDownMode determines the format ot the value

Syntax

Visual Basic (Declaration)
Public Enum ValueFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ValueFormat
C#
public enum ValueFormat : Enum
Managed Extensions for C++
__value public enum ValueFormat : public Enum
C++/CLI
public enum class ValueFormat : public Enum

Members

Member | Description
Numeric | Formats value using fixed point notation using thousand separator
Currency | Formats value in currency notation
Percentage | Formats value in percentage notation, according to a decimal value

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.ValueFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%ItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.Calendar Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | ActionRequest | Request for a simple action.
Class | Generic ActionRequest | Request for an action that takes one parameter.
Class | Generic ActionRequest | Request for an action that takes two parameters.
Class | CalendarAnimation | Class that governs the transition animations in the calendar.
Class | CalendarButton | The class of the calendar button.
Class | CalendarButtonContent | The content that each calendar button is assigned.
Class | CalendarDateChangedEventArgs | Provides data for the DateSelected and DisplayDateChanged events.
Class | CalendarModeChangedEventArgs | The EventArgs of the RadCalendar.DisplayModeChanged event.
Class | CalendarPanel | Panel that lays out the items in a calendar view (DayView, MonthView).
Class | CalendarView | CalendarView is the calendar items wrapper for the calendar.
Class | RequestBase | Base class for delayed action calls.
Class | TransitionPanel | A panel that governs transitions from one of its children to another.

Enumerations

 | Enumeration | Description
Enumeration | CalendarButtonType | Identifies the type of the Calendar Button.
Enumeration | DisplayMode | Specifies the display mode of the calendar.

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : ActionRequest Class

Request for a simple action.

Syntax

Visual Basic (Declaration)
Public Class ActionRequest
   Inherits RequestBase
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest
C#
public class ActionRequest : RequestBase
Managed Extensions for C++
public __gc class ActionRequest : public RequestBase
C++/CLI
public ref class ActionRequest : public RequestBase

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.RequestBase
Telerik.Windows.Controls.Calendar.ActionRequest

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ActionRequest Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Class Members
See Also Methods
[image]
Telerik.Windows.Controls.Calendar Namespace : ActionRequest Class

The following tables list the members exposed by ActionRequest.

Public Constructors

 | Name | Description
Public Constructor | ActionRequest Constructor | Initializes a new instance of the ActionRequest class.
Top

Public Methods

 | Name | Description
Public Method | Execute | Overridden. Executes this instance.
Top

See Also

Reference

ActionRequest Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > ActionRequest Class : ActionRequest Constructor

action
The action.
Initializes a new instance of the ActionRequest class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As Action _
)
Visual Basic (Usage) Copy Code
Dim action As Action

Dim instance As ActionRequest(action)
C#
public ActionRequest(
   Action action
)
Managed Extensions for C++
public: ActionRequest(
   Action* action
)
C++/CLI
public:
ActionRequest(
   Action^ action
)

Parameters

action
The action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ActionRequest Class
ActionRequest Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : ActionRequest Class

For a list of all members of this type, see ActionRequest members.

Public Methods

 | Name | Description
Public Method | Execute | Overridden. Executes this instance.
Top

See Also

Reference

ActionRequest Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Execute Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > ActionRequest Class : Execute Method

Executes this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute()
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest

instance.Execute()
C#
public override void Execute()
Managed Extensions for C++
public: void Execute(); override
C++/CLI
public:
void Execute(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ActionRequest Class
ActionRequest Members


%%PageItemTitle%%

T
The first parameter.
Telerik.Windows.Controls.Input Send comments on this topic.
Generic ActionRequest Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : Generic ActionRequest Class

Request for an action that takes one parameter.

Syntax

Visual Basic (Declaration)
Public Class ActionRequest(Of T)
   Inherits RequestBase
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest(Of T)
C#
public class ActionRequest<T> : RequestBase
Managed Extensions for C++
public __gc class ActionRequest<T> : public RequestBase
C++/CLI
generic<typename T>
public ref class ActionRequest : public RequestBase

Type Parameters

T
The first parameter.

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.RequestBase
Telerik.Windows.Controls.Calendar.ActionRequest

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
Generic ActionRequest Class Members
See Also Methods
[image]
Telerik.Windows.Controls.Calendar Namespace : Generic ActionRequest Class

The following tables list the members exposed by Generic ActionRequest.

Public Constructors

 | Name | Description
Public Constructor | ActionRequest Constructor | Initializes a new instance of the Generic ActionRequest class.
Top

Public Methods

 | Name | Description
Public Method | Execute | Overridden. Executes this instance.
Top

See Also

Reference

Generic ActionRequest Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > Generic ActionRequest Class : ActionRequest Constructor

action
The action.
parameter1
The first parameter.
Initializes a new instance of the Generic ActionRequest class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As Action(Of T), _
   ByVal parameter1 As T _
)
Visual Basic (Usage) Copy Code
Dim action As Action(Of T)
Dim parameter1 As T

Dim instance As ActionRequest(Of T)(action, parameter1)
C#
public Generic ActionRequest(
   Action<T> action,
   T parameter1
)
Managed Extensions for C++
public: Generic ActionRequest(
   Action<T>* action,
   T parameter1
)
C++/CLI
public:
Generic ActionRequest(
   Action<T>^ action,
   T parameter1
)

Parameters

action
The action.
parameter1
The first parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Class
Generic ActionRequest Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
Generic ActionRequest Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : Generic ActionRequest Class

For a list of all members of this type, see Generic ActionRequest members.

Public Methods

 | Name | Description
Public Method | Execute | Overridden. Executes this instance.
Top

See Also

Reference

Generic ActionRequest Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Execute Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > Generic ActionRequest Class : Execute Method

Executes this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute()
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest(Of T)

instance.Execute()
C#
public override void Execute()
Managed Extensions for C++
public: void Execute(); override
C++/CLI
public:
void Execute(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Class
Generic ActionRequest Members


%%PageItemTitle%%

T1
The first parameter.
T2
The second parameter.
Telerik.Windows.Controls.Input Send comments on this topic.
Generic ActionRequest Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : Generic ActionRequest Class

Request for an action that takes two parameters.

Syntax

Visual Basic (Declaration)
Public Class ActionRequest
     (Of T1,T2)
   Inherits RequestBase
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest(Of T1,T2)
C#
public class ActionRequest<T1,T2> : RequestBase
Managed Extensions for C++
public __gc class ActionRequest<T1,T2> : public RequestBase
C++/CLI
generic<typename T1>
generic<typename T2>
public ref class ActionRequest : public RequestBase

Type Parameters

T1
The first parameter.
T2
The second parameter.

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.RequestBase
Telerik.Windows.Controls.Calendar.ActionRequest

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ActionRequest Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > Generic ActionRequest Class : ActionRequest Constructor

action
The action.
parameter1
The first parameter.
parameter2
The second parameter.
Initializes a new instance of the Generic ActionRequest class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As Action(Of T1, T2), _
   ByVal parameter1 As T1, _
   ByVal parameter2 As T2 _
)
Visual Basic (Usage) Copy Code
Dim action As Action(Of T1, T2)
Dim parameter1 As T1
Dim parameter2 As T2

Dim instance As ActionRequest(Of T1,T2)(action, parameter1, parameter2)
C#
public Generic ActionRequest(
   Action<T1, T2> action,
   T1 parameter1,
   T2 parameter2
)
Managed Extensions for C++
public: Generic ActionRequest(
   Action<T1, T2>* action,
   T1 parameter1,
   T2 parameter2
)
C++/CLI
public:
Generic ActionRequest(
   Action<T1, T2>^ action,
   T1 parameter1,
   T2 parameter2
)

Parameters

action
The action.
parameter1
The first parameter.
parameter2
The second parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Class
Generic ActionRequest Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Execute Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > Generic ActionRequest Class : Execute Method

Executes this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute()
Visual Basic (Usage) Copy Code
Dim instance As ActionRequest(Of T1,T2)

instance.Execute()
C#
public override void Execute()
Managed Extensions for C++
public: void Execute(); override
C++/CLI
public:
void Execute(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic ActionRequest Class
Generic ActionRequest Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarAnimation Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarAnimation Class

Class that governs the transition animations in the calendar.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public MustInherit NotInheritable Class CalendarAnimation
Visual Basic (Usage) Copy Code
Dim instance As CalendarAnimation
C#
[ExtensionAttribute()]
public static class CalendarAnimation
Managed Extensions for C++
[ExtensionAttribute()]
public __gc abstract __sealed class CalendarAnimation
C++/CLI
[ExtensionAttribute()]
public ref class CalendarAnimation abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.CalendarAnimation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarAnimation Class Members
See Also Methods
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarAnimation Class

The following tables list the members exposed by CalendarAnimation.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SlideIn | Overloaded. Slides the given element into view. This is an extension method.
static (Shared in Visual Basic) | SlideOut | Overloaded. Slides the given element out of view. This is an extension method.
static (Shared in Visual Basic) | Translate | Overloaded.
Top

See Also

Reference

CalendarAnimation Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarAnimation Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarAnimation Class

For a list of all members of this type, see CalendarAnimation members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SlideIn | Overloaded. Slides the given element into view. This is an extension method.
static (Shared in Visual Basic) | SlideOut | Overloaded. Slides the given element out of view. This is an extension method.
static (Shared in Visual Basic) | Translate | Overloaded.
Top

See Also

Reference

CalendarAnimation Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideIn Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class : SlideIn Method

Slides the given element into view. This is an extension method.

Overload List

Overload | Description
SlideIn(FrameworkElement,TimeSpan) | Slides the given element into view. This is an extension method.
SlideIn(FrameworkElement) | Slides the given element into view. This is an extension method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideIn(FrameworkElement,TimeSpan) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > SlideIn Method : SlideIn(FrameworkElement,TimeSpan) Method

target
The given element.
duration
How long should the transition take?
Slides the given element into view. This is an extension method.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub SlideIn( _
   ByVal target As FrameworkElement, _
   ByVal duration As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement
Dim duration As TimeSpan

CalendarAnimation.SlideIn(target, duration)
C#
[ExtensionAttribute()]
public static void SlideIn(
   FrameworkElement target,
   TimeSpan duration
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void SlideIn(
   FrameworkElement* target,
   TimeSpan duration
)
C++/CLI
[ExtensionAttribute()]
public:
static void SlideIn(
   FrameworkElement^ target,
   TimeSpan duration
)

Parameters

target
The given element.
duration
How long should the transition take?

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideIn(FrameworkElement) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > SlideIn Method : SlideIn(FrameworkElement) Method

target
The target.
Slides the given element into view. This is an extension method.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub SlideIn( _
   ByVal target As FrameworkElement _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement

CalendarAnimation.SlideIn(target)
C#
[ExtensionAttribute()]
public static void SlideIn(
   FrameworkElement target
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void SlideIn(
   FrameworkElement* target
)
C++/CLI
[ExtensionAttribute()]
public:
static void SlideIn(
   FrameworkElement^ target
)

Parameters

target
The target.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideOut Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class : SlideOut Method

Slides the given element out of view. This is an extension method.

Overload List

Overload | Description
SlideOut(FrameworkElement,TimeSpan) | Slides the given element out of view. This is an extension method.
SlideOut(FrameworkElement) | Slides the given element out of view. This is an extension method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideOut(FrameworkElement,TimeSpan) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > SlideOut Method : SlideOut(FrameworkElement,TimeSpan) Method

target
The target element.
duration
How long should the transition take?
Slides the given element out of view. This is an extension method.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub SlideOut( _
   ByVal target As FrameworkElement, _
   ByVal duration As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement
Dim duration As TimeSpan

CalendarAnimation.SlideOut(target, duration)
C#
[ExtensionAttribute()]
public static void SlideOut(
   FrameworkElement target,
   TimeSpan duration
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void SlideOut(
   FrameworkElement* target,
   TimeSpan duration
)
C++/CLI
[ExtensionAttribute()]
public:
static void SlideOut(
   FrameworkElement^ target,
   TimeSpan duration
)

Parameters

target
The target element.
duration
How long should the transition take?

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
SlideOut(FrameworkElement) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > SlideOut Method : SlideOut(FrameworkElement) Method

target
The target.
Slides the given element out of view. This is an extension method.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub SlideOut( _
   ByVal target As FrameworkElement _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement

CalendarAnimation.SlideOut(target)
C#
[ExtensionAttribute()]
public static void SlideOut(
   FrameworkElement target
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void SlideOut(
   FrameworkElement* target
)
C++/CLI
[ExtensionAttribute()]
public:
static void SlideOut(
   FrameworkElement^ target
)

Parameters

target
The target.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Translate Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class : Translate Method

Overload List

Overload | Description
Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan) |
Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan,RequestBase) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > Translate Method : Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan) Method

target
fromX
fromY
toX
toY
duration

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub Translate( _
   ByVal target As FrameworkElement, _
   ByVal fromX As Nullable(Of Double), _
   ByVal fromY As Nullable(Of Double), _
   ByVal toX As Nullable(Of Double), _
   ByVal toY As Nullable(Of Double), _
   ByVal duration As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement
Dim fromX As Nullable(Of Double)
Dim fromY As Nullable(Of Double)
Dim toX As Nullable(Of Double)
Dim toY As Nullable(Of Double)
Dim duration As TimeSpan

CalendarAnimation.Translate(target, fromX, fromY, toX, toY, duration)
C#
[ExtensionAttribute()]
public static void Translate(
   FrameworkElement target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void Translate(
   FrameworkElement* target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration
)
C++/CLI
[ExtensionAttribute()]
public:
static void Translate(
   FrameworkElement^ target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration
)

Parameters

target
fromX
fromY
toX
toY
duration

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan,RequestBase) Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarAnimation Class > Translate Method : Translate(FrameworkElement,Generic Nullable,Generic Nullable,Generic Nullable,Generic Nullable,TimeSpan,RequestBase) Method

target
fromX
fromY
toX
toY
duration
action

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public Overloads Shared Sub Translate( _
   ByVal target As FrameworkElement, _
   ByVal fromX As Nullable(Of Double), _
   ByVal fromY As Nullable(Of Double), _
   ByVal toX As Nullable(Of Double), _
   ByVal toY As Nullable(Of Double), _
   ByVal duration As TimeSpan, _
   ByVal action As RequestBase _
)
Visual Basic (Usage) Copy Code
Dim target As FrameworkElement
Dim fromX As Nullable(Of Double)
Dim fromY As Nullable(Of Double)
Dim toX As Nullable(Of Double)
Dim toY As Nullable(Of Double)
Dim duration As TimeSpan
Dim action As RequestBase

CalendarAnimation.Translate(target, fromX, fromY, toX, toY, duration, action)
C#
[ExtensionAttribute()]
public static void Translate(
   FrameworkElement target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration,
   RequestBase action
)
Managed Extensions for C++
[ExtensionAttribute()]
public: static void Translate(
   FrameworkElement* target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration,
   RequestBase* action
)
C++/CLI
[ExtensionAttribute()]
public:
static void Translate(
   FrameworkElement^ target,
   Nullable<double> fromX,
   Nullable<double> fromY,
   Nullable<double> toX,
   Nullable<double> toY,
   TimeSpan duration,
   RequestBase^ action
)

Parameters

target
fromX
fromY
toX
toY
duration
action

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarAnimation Class
CalendarAnimation Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

The class of the calendar button.

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="SelectionStates")>
Public Class CalendarButton
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
C#
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="SelectionStates")]
public class CalendarButton : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="SelectionStates")]
public __gc class CalendarButton : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="SelectionStates")]
public ref class CalendarButton : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

The CalendarButton class is not to be used outside the RadCalendar control. If you need a button functionality, use the ButtonBase or Button classes.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.Calendar.CalendarButton

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

The following tables list the members exposed by CalendarButton.

Public Constructors

 | Name | Description
Public Constructor | CalendarButton Constructor | Initializes a new instance of the CalendarButton class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ButtonTypeProperty | Identifies the ButtonType property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused property.
static (Shared in Visual Basic) | IsFromCurrentViewProperty | Identifies the IsFromCurrentView property.
static (Shared in Visual Basic) | IsInAnotherViewProperty | Identifies the IsInAnotherView property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ButtonType | Gets or sets the type of the button. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsFocused | Gets whether the element currently has focus
Public Property | IsFromCurrentView | Gets or sets whether the button belongs to the current month/year/decade/century. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInAnotherView | Gets or sets whether a button with the same content exists in another view (in a multi-view calendar). This is a dependency property.
Public Property | IsMouseOver | Gets whether the mouse is above the element.
Public Property | IsSelected | Gets or sets whether the button is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Text | Gets or sets the text displayed by the button. This is a dependency property.
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | Overridden. Called when the Content property changes.
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarButton Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : CalendarButton Constructor

Initializes a new instance of the CalendarButton class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton()
C#
public CalendarButton()
Managed Extensions for C++
public: CalendarButton();
C++/CLI
public:
CalendarButton();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

For a list of all members of this type, see CalendarButton members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | Overridden. Called when the Content property changes.
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

CalendarButton Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnContentChanged Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : OnContentChanged Method

oldContent
The old value of the Content property.
newContent
The new value of the Content property.
Called when the Content property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged( _
   ByVal oldContent As Object, _
   ByVal newContent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim oldContent As Object
Dim newContent As Object

instance.OnContentChanged(oldContent, newContent)
C#
protected override void OnContentChanged(
   object oldContent,
   object newContent
)
Managed Extensions for C++
protected: void OnContentChanged(
   Object* oldContent,
   Object* newContent
) override
C++/CLI
protected:
void OnContentChanged(
   Object^ oldContent,
   Object^ newContent
) override

Parameters

oldContent
The old value of the Content property.
newContent
The new value of the Content property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

For a list of all members of this type, see CalendarButton members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ButtonType | Gets or sets the type of the button. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsFocused | Gets whether the element currently has focus
Public Property | IsFromCurrentView | Gets or sets whether the button belongs to the current month/year/decade/century. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInAnotherView | Gets or sets whether a button with the same content exists in another view (in a multi-view calendar). This is a dependency property.
Public Property | IsMouseOver | Gets whether the mouse is above the element.
Public Property | IsSelected | Gets or sets whether the button is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Text | Gets or sets the text displayed by the button. This is a dependency property.
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

CalendarButton Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ButtonType Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : ButtonType Property

Gets or sets the type of the button. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property ButtonType As CalendarButtonType
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As CalendarButtonType

instance.ButtonType = value

value = instance.ButtonType
C#
public CalendarButtonType ButtonType {get; set;}
Managed Extensions for C++
public: __property CalendarButtonType get_ButtonType();
public: __property void set_ButtonType(
   CalendarButtonType value
);
C++/CLI
public:
property CalendarButtonType ButtonType {
   CalendarButtonType get();
   void set (CalendarButtonType value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsFocused Property

Gets whether the element currently has focus

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As Boolean

value = instance.IsFocused
C#
public bool IsFocused {get;}
Managed Extensions for C++
public: __property bool get_IsFocused();
C++/CLI
public:
property bool IsFocused {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFromCurrentView Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsFromCurrentView Property

Gets or sets whether the button belongs to the current month/year/decade/century. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsFromCurrentView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As Boolean

instance.IsFromCurrentView = value

value = instance.IsFromCurrentView
C#
public bool IsFromCurrentView {get; set;}
Managed Extensions for C++
public: __property bool get_IsFromCurrentView();
public: __property void set_IsFromCurrentView(
   bool value
);
C++/CLI
public:
property bool IsFromCurrentView {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsInAnotherView Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsInAnotherView Property

Gets or sets whether a button with the same content exists in another view (in a multi-view calendar). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsInAnotherView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As Boolean

instance.IsInAnotherView = value

value = instance.IsInAnotherView
C#
public bool IsInAnotherView {get; set;}
Managed Extensions for C++
public: __property bool get_IsInAnotherView();
public: __property void set_IsInAnotherView(
   bool value
);
C++/CLI
public:
property bool IsInAnotherView {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsMouseOver Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsMouseOver Property

Gets whether the mouse is above the element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMouseOver As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As Boolean

value = instance.IsMouseOver
C#
public bool IsMouseOver {get;}
Managed Extensions for C++
public: __property bool get_IsMouseOver();
C++/CLI
public:
property bool IsMouseOver {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsSelected Property

Gets or sets whether the button is selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
public bool IsSelected {get; set;}
Managed Extensions for C++
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Text Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : Text Property

Gets or sets the text displayed by the button. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As CalendarButton
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class Fields
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

For a list of all members of this type, see CalendarButton members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ButtonTypeProperty | Identifies the ButtonType property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused property.
static (Shared in Visual Basic) | IsFromCurrentViewProperty | Identifies the IsFromCurrentView property.
static (Shared in Visual Basic) | IsInAnotherViewProperty | Identifies the IsInAnotherView property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text property.
Top

See Also

Reference

CalendarButton Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ButtonTypeProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : ButtonTypeProperty Field

Identifies the ButtonType property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ButtonTypeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.ButtonTypeProperty
C#
public static readonly DependencyProperty ButtonTypeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ButtonTypeProperty
C++/CLI
public:
static readonly DependencyProperty^ ButtonTypeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFocusedProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsFocusedProperty Field

Identifies the IsFocused property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.IsFocusedProperty
C#
public static readonly DependencyProperty IsFocusedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFocusedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFocusedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFromCurrentViewProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsFromCurrentViewProperty Field

Identifies the IsFromCurrentView property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFromCurrentViewProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.IsFromCurrentViewProperty
C#
public static readonly DependencyProperty IsFromCurrentViewProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFromCurrentViewProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFromCurrentViewProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsInAnotherViewProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsInAnotherViewProperty Field

Identifies the IsInAnotherView property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsInAnotherViewProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.IsInAnotherViewProperty
C#
public static readonly DependencyProperty IsInAnotherViewProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsInAnotherViewProperty
C++/CLI
public:
static readonly DependencyProperty^ IsInAnotherViewProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsMouseOverProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsMouseOverProperty Field

Identifies the IsMouseOver property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.IsMouseOverProperty
C#
public static readonly DependencyProperty IsMouseOverProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMouseOverProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMouseOverProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsSelectedProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : IsSelectedProperty Field

Identifies the IsSelected property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.IsSelectedProperty
C#
public static readonly DependencyProperty IsSelectedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TextProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButton Class : TextProperty Field

Identifies the Text property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarButton.TextProperty
C#
public static readonly DependencyProperty TextProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TextProperty
C++/CLI
public:
static readonly DependencyProperty^ TextProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButton Class
CalendarButton Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonContent Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButtonContent Class

The content that each calendar button is assigned.

Syntax

Visual Basic (Declaration)
Public Class CalendarButtonContent
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
C#
public class CalendarButtonContent
Managed Extensions for C++
public __gc class CalendarButtonContent
C++/CLI
public ref class CalendarButtonContent

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.CalendarButtonContent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonContent Class Members
See Also Properties Events
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButtonContent Class

The following tables list the members exposed by CalendarButtonContent.

Public Constructors

 | Name | Description
Public Constructor | CalendarButtonContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | ButtonType | Gets the type of the button.
Public Property | Date | Gets or sets date that the button displays.
Public Property | IsEnabled | Gets or sets whether the date can be selected.
Public Property | IsFromCurrentView | Defines whther the element belongs to the current view (currently displayed month, year, decade or century).
Public Property | IsInAnotherView | Gets whether the button is initially visible;
Public Property | IsSelected | Gets whether the button is initially selected.
Public Property | Text | Gets or sets the text that gets displayed on the calendar.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top

See Also

Reference

CalendarButtonContent Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonContent Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : CalendarButtonContent Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent()
C#
public CalendarButtonContent()
Managed Extensions for C++
public: CalendarButtonContent();
C++/CLI
public:
CalendarButtonContent();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonContent Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButtonContent Class

For a list of all members of this type, see CalendarButtonContent members.

Public Properties

 | Name | Description
Public Property | ButtonType | Gets the type of the button.
Public Property | Date | Gets or sets date that the button displays.
Public Property | IsEnabled | Gets or sets whether the date can be selected.
Public Property | IsFromCurrentView | Defines whther the element belongs to the current view (currently displayed month, year, decade or century).
Public Property | IsInAnotherView | Gets whether the button is initially visible;
Public Property | IsSelected | Gets whether the button is initially selected.
Public Property | Text | Gets or sets the text that gets displayed on the calendar.
Top

See Also

Reference

CalendarButtonContent Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ButtonType Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : ButtonType Property

Gets the type of the button.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ButtonType As CalendarButtonType
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As CalendarButtonType

value = instance.ButtonType
C#
public CalendarButtonType ButtonType {get;}
Managed Extensions for C++
public: __property CalendarButtonType get_ButtonType();
C++/CLI
public:
property CalendarButtonType ButtonType {
   CalendarButtonType get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Date Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : Date Property

Gets or sets date that the button displays.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Date As Date
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As Date

value = instance.Date
C#
public DateTime Date {get;}
Managed Extensions for C++
public: __property DateTime get_Date();
C++/CLI
public:
property DateTime Date {
   DateTime get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : IsEnabled Property

Gets or sets whether the date can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As Boolean

value = instance.IsEnabled
C#
public bool IsEnabled {get;}
Managed Extensions for C++
public: __property bool get_IsEnabled();
C++/CLI
public:
property bool IsEnabled {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsFromCurrentView Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : IsFromCurrentView Property

Defines whther the element belongs to the current view (currently displayed month, year, decade or century).

Syntax

Visual Basic (Declaration)
Public Property IsFromCurrentView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As Boolean

instance.IsFromCurrentView = value

value = instance.IsFromCurrentView
C#
public bool IsFromCurrentView {get; set;}
Managed Extensions for C++
public: __property bool get_IsFromCurrentView();
public: __property void set_IsFromCurrentView(
   bool value
);
C++/CLI
public:
property bool IsFromCurrentView {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsInAnotherView Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : IsInAnotherView Property

Gets whether the button is initially visible;

Syntax

Visual Basic (Declaration)
Public Property IsInAnotherView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As Boolean

instance.IsInAnotherView = value

value = instance.IsInAnotherView
C#
public bool IsInAnotherView {get; set;}
Managed Extensions for C++
public: __property bool get_IsInAnotherView();
public: __property void set_IsInAnotherView(
   bool value
);
C++/CLI
public:
property bool IsInAnotherView {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : IsSelected Property

Gets whether the button is initially selected.

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
public bool IsSelected {get; set;}
Managed Extensions for C++
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Text Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : Text Property

Gets or sets the text that gets displayed on the calendar.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonContent Class Events
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButtonContent Class

For a list of all members of this type, see CalendarButtonContent members.

Public Events

 | Name | Description
Public Event | PropertyChanged | Occurs when a property value changes.
Top

See Also

Reference

CalendarButtonContent Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
PropertyChanged Event
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarButtonContent Class : PropertyChanged Event

Occurs when a property value changes.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonContent
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()
Managed Extensions for C++
public: __event PropertyChangedEventHandler* PropertyChanged
C++/CLI
public:
event PropertyChangedEventHandler^ PropertyChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarButtonContent Class
CalendarButtonContent Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarDateChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarDateChangedEventArgs Class

Provides data for the DateSelected and DisplayDateChanged events.

Syntax

Visual Basic (Declaration)
Public Class CalendarDateChangedEventArgs
   Inherits RoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As CalendarDateChangedEventArgs
C#
public class CalendarDateChangedEventArgs : RoutedEventArgs
Managed Extensions for C++
public __gc class CalendarDateChangedEventArgs : public RoutedEventArgs
C++/CLI
public ref class CalendarDateChangedEventArgs : public RoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.Controls.Calendar.CalendarDateChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarDateChangedEventArgs Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarDateChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarDateChangedEventArgs Class

The following tables list the members exposed by CalendarDateChangedEventArgs.

Public Properties

 | Name | Description
Public Property | AddedDate | Gets the date to be newly displayed.
Public Property | RemovedDate | Gets the date that was previously displayed.
Public Property | Source | (Inherited from System.Windows.RoutedEventArgs)
Top

See Also

Reference

CalendarDateChangedEventArgs Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarDateChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarDateChangedEventArgs Class

For a list of all members of this type, see CalendarDateChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | AddedDate | Gets the date to be newly displayed.
Public Property | RemovedDate | Gets the date that was previously displayed.
Public Property | Source | (Inherited from System.Windows.RoutedEventArgs)
Top

See Also

Reference

CalendarDateChangedEventArgs Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
AddedDate Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarDateChangedEventArgs Class : AddedDate Property

Gets the date to be newly displayed.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property AddedDate As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As CalendarDateChangedEventArgs
Dim value As Nullable(Of Date)

value = instance.AddedDate
C#
[CompilerGeneratedAttribute()]
public Nullable<DateTime> AddedDate {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Nullable<DateTime> get_AddedDate();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Nullable<DateTime> AddedDate {
   Nullable<DateTime> get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarDateChangedEventArgs Class
CalendarDateChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RemovedDate Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarDateChangedEventArgs Class : RemovedDate Property

Gets the date that was previously displayed.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property RemovedDate As Nullable(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As CalendarDateChangedEventArgs
Dim value As Nullable(Of Date)

value = instance.RemovedDate
C#
[CompilerGeneratedAttribute()]
public Nullable<DateTime> RemovedDate {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Nullable<DateTime> get_RemovedDate();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Nullable<DateTime> RemovedDate {
   Nullable<DateTime> get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarDateChangedEventArgs Class
CalendarDateChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarModeChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarModeChangedEventArgs Class

The EventArgs of the RadCalendar.DisplayModeChanged event.

Syntax

Visual Basic (Declaration)
Public Class CalendarModeChangedEventArgs
   Inherits RoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As CalendarModeChangedEventArgs
C#
public class CalendarModeChangedEventArgs : RoutedEventArgs
Managed Extensions for C++
public __gc class CalendarModeChangedEventArgs : public RoutedEventArgs
C++/CLI
public ref class CalendarModeChangedEventArgs : public RoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.Controls.Calendar.CalendarModeChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarModeChangedEventArgs Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarModeChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarModeChangedEventArgs Class

The following tables list the members exposed by CalendarModeChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CalendarModeChangedEventArgs Constructor | Initializes a new instance of the CalendarModeChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | NewMode | Gets the new mode of the Calendar.
Public Property | OldMode | Gets the previous mode of the Calendar.
Public Property | Source | (Inherited from System.Windows.RoutedEventArgs)
Top

See Also

Reference

CalendarModeChangedEventArgs Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarModeChangedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarModeChangedEventArgs Class : CalendarModeChangedEventArgs Constructor

oldMode
Previous value of the property, prior to the event being raised.
newMode
Current value of the property at the time of the event.
Initializes a new instance of the CalendarModeChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oldMode As DisplayMode, _
   ByVal newMode As DisplayMode _
)
Visual Basic (Usage) Copy Code
Dim oldMode As DisplayMode
Dim newMode As DisplayMode

Dim instance As CalendarModeChangedEventArgs(oldMode, newMode)
C#
public CalendarModeChangedEventArgs(
   DisplayMode oldMode,
   DisplayMode newMode
)
Managed Extensions for C++
public: CalendarModeChangedEventArgs(
   DisplayMode oldMode,
   DisplayMode newMode
)
C++/CLI
public:
CalendarModeChangedEventArgs(
   DisplayMode oldMode,
   DisplayMode newMode
)

Parameters

oldMode
Previous value of the property, prior to the event being raised.
newMode
Current value of the property at the time of the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarModeChangedEventArgs Class
CalendarModeChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarModeChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarModeChangedEventArgs Class

For a list of all members of this type, see CalendarModeChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | NewMode | Gets the new mode of the Calendar.
Public Property | OldMode | Gets the previous mode of the Calendar.
Public Property | Source | (Inherited from System.Windows.RoutedEventArgs)
Top

See Also

Reference

CalendarModeChangedEventArgs Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
NewMode Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarModeChangedEventArgs Class : NewMode Property

Gets the new mode of the Calendar.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property NewMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As CalendarModeChangedEventArgs
Dim value As DisplayMode

value = instance.NewMode
C#
[CompilerGeneratedAttribute()]
public DisplayMode NewMode {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property DisplayMode get_NewMode();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property DisplayMode NewMode {
   DisplayMode get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarModeChangedEventArgs Class
CalendarModeChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OldMode Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarModeChangedEventArgs Class : OldMode Property

Gets the previous mode of the Calendar.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property OldMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As CalendarModeChangedEventArgs
Dim value As DisplayMode

value = instance.OldMode
C#
[CompilerGeneratedAttribute()]
public DisplayMode OldMode {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property DisplayMode get_OldMode();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property DisplayMode OldMode {
   DisplayMode get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarModeChangedEventArgs Class
CalendarModeChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarPanel Class

Panel that lays out the items in a calendar view (DayView, MonthView).

Syntax

Visual Basic (Declaration)
Public Class CalendarPanel
   Inherits RadUniformGrid
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As CalendarPanel
C#
public class CalendarPanel : RadUniformGrid, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class CalendarPanel : public RadUniformGrid, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class CalendarPanel : public RadUniformGrid, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.Primitives.RadUniformGrid
Telerik.Windows.Controls.Calendar.CalendarPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarPanel Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarPanel Class

The following tables list the members exposed by CalendarPanel.

Public Constructors

 | Name | Description
Public Constructor | CalendarPanel Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | ChildrenFlow | Gets or sets a value that specifies the dimension in which child content is arranged. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns that are in the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideFirstColumn | Gets or sets value that hide or show the first column. This is a Dependency property. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | HideFirstRow | Gets or sets value that hide or show the first row. This is a Dependency property. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PreserveSpaceForCollapsedChildren | Gets or sets a value specifying whether a collapsed child's size should be preserved. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows that are in the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Defines the layout of the Telerik.Windows.Controls.Primitives.RadUniformGrid by distributing space evenly among all of the child elements. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Protected Method | MeasureOverride | Computes the desired size of the Telerik.Windows.Controls.Primitives.RadUniformGrid by measuring all of the child elements. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarPanel Class : CalendarPanel Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CalendarPanel()
C#
public CalendarPanel()
Managed Extensions for C++
public: CalendarPanel();
C++/CLI
public:
CalendarPanel();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarPanel Class
CalendarPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

CalendarView is the calendar items wrapper for the calendar.

Object Model

Syntax

Visual Basic (Declaration)
Public Class CalendarView
   Inherits HeaderedItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
C#
public class CalendarView : HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class CalendarView : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class CalendarView : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

CalendarView is primitive building block for the calendar control and is not intended to be used separately.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.Calendar.CalendarView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

The following tables list the members exposed by CalendarView.

Public Constructors

 | Name | Description
Public Constructor | CalendarView Constructor | Overloaded. Initializes a new instance of the CalendarView class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility proeprty.
static (Shared in Visual Basic) | HideColumnProperty | Identifies the HideColumn property.
static (Shared in Visual Basic) | HideRowProperty | Identifies the HideRow property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets whether the number of columns of the CalendarView. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderVisibility | Gets or sets the visibility of the header of the Calendar view. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideColumn | Gets or sets whether first column will be displayed
Public Property | HideRow | Gets or sets whether first row will be displayed
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the CalendarView. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets whether the number of rows of the CalendarView. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from Telerik.Windows.Controls.ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarView Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : CalendarView Constructor

Initializes a new instance of the CalendarView class.

Overload List

Overload | Description
CalendarView Constructor() | Initializes a new instance of the CalendarView class.
CalendarView Constructor(RadCalendar) | Initializes a new instance of the CalendarView class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Constructor()
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class > CalendarView Constructor : CalendarView Constructor()

Initializes a new instance of the CalendarView class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CalendarView()
C#
public CalendarView()
Managed Extensions for C++
public: CalendarView();
C++/CLI
public:
CalendarView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Constructor(RadCalendar)
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class > CalendarView Constructor : CalendarView Constructor(RadCalendar)

calendar
The owner calendar of the calendar view.
Initializes a new instance of the CalendarView class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal calendar As RadCalendar _
)
Visual Basic (Usage) Copy Code
Dim calendar As RadCalendar

Dim instance As CalendarView(calendar)
C#
public CalendarView(
   RadCalendar calendar
)
Managed Extensions for C++
public: CalendarView(
   RadCalendar* calendar
)
C++/CLI
public:
CalendarView(
   RadCalendar^ calendar
)

Parameters

calendar
The owner calendar of the calendar view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members
Overload List


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

For a list of all members of this type, see CalendarView members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from Telerik.Windows.Controls.ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

CalendarView Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : ClearContainerForItemOverride Method

element
The container element.
item
The item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Return Value

The element that is used to display the given item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As CalendarView

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

For a list of all members of this type, see CalendarView members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets whether the number of columns of the CalendarView. This is a dependency property.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from Telerik.Windows.Controls.HeaderedItemsControl)
Public Property | HeaderVisibility | Gets or sets the visibility of the header of the Calendar view. This is a dependency property.
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideColumn | Gets or sets whether first column will be displayed
Public Property | HideRow | Gets or sets whether first row will be displayed
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from Telerik.Windows.Controls.ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets whether the orientation of the CalendarView. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets whether the number of rows of the CalendarView. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

CalendarView Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Columns Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : Columns Property

Gets or sets whether the number of columns of the CalendarView. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibility Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HeaderVisibility Property

Gets or sets the visibility of the header of the Calendar view. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property HeaderVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Visibility

instance.HeaderVisibility = value

value = instance.HeaderVisibility
C#
public Visibility HeaderVisibility {get; set;}
Managed Extensions for C++
public: __property Visibility get_HeaderVisibility();
public: __property void set_HeaderVisibility(
   Visibility value
);
C++/CLI
public:
property Visibility HeaderVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HideColumn Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HideColumn Property

Gets or sets whether first column will be displayed

Syntax

Visual Basic (Declaration)
Public Property HideColumn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Boolean

instance.HideColumn = value

value = instance.HideColumn
C#
public bool HideColumn {get; set;}
Managed Extensions for C++
public: __property bool get_HideColumn();
public: __property void set_HideColumn(
   bool value
);
C++/CLI
public:
property bool HideColumn {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HideRow Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HideRow Property

Gets or sets whether first row will be displayed

Syntax

Visual Basic (Declaration)
Public Property HideRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Boolean

instance.HideRow = value

value = instance.HideRow
C#
public bool HideRow {get; set;}
Managed Extensions for C++
public: __property bool get_HideRow();
public: __property void set_HideRow(
   bool value
);
C++/CLI
public:
property bool HideRow {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : Orientation Property

Gets or sets whether the orientation of the CalendarView. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Rows Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : Rows Property

Gets or sets whether the number of rows of the CalendarView. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As CalendarView
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class Fields
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

For a list of all members of this type, see CalendarView members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColumnsProperty | Identifies the Columns property.
static (Shared in Visual Basic) | HeaderVisibilityProperty | Identifies the HeaderVisibility proeprty.
static (Shared in Visual Basic) | HideColumnProperty | Identifies the HideColumn property.
static (Shared in Visual Basic) | HideRowProperty | Identifies the HideRow property.
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation property.
static (Shared in Visual Basic) | RowsProperty | Identifies the Rows property.
Top

See Also

Reference

CalendarView Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ColumnsProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : ColumnsProperty Field

Identifies the Columns property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.ColumnsProperty
C#
public static readonly DependencyProperty ColumnsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ColumnsProperty
C++/CLI
public:
static readonly DependencyProperty^ ColumnsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HeaderVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HeaderVisibilityProperty Field

Identifies the HeaderVisibility proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeaderVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.HeaderVisibilityProperty
C#
public static readonly DependencyProperty HeaderVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HeaderVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ HeaderVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HideColumnProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HideColumnProperty Field

Identifies the HideColumn property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HideColumnProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.HideColumnProperty
C#
public static readonly DependencyProperty HideColumnProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HideColumnProperty
C++/CLI
public:
static readonly DependencyProperty^ HideColumnProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
HideRowProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : HideRowProperty Field

Identifies the HideRow property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HideRowProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.HideRowProperty
C#
public static readonly DependencyProperty HideRowProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HideRowProperty
C++/CLI
public:
static readonly DependencyProperty^ HideRowProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : OrientationProperty Field

Identifies the Orientation property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RowsProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > CalendarView Class : RowsProperty Field

Identifies the Rows property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RowsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = CalendarView.RowsProperty
C#
public static readonly DependencyProperty RowsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RowsProperty
C++/CLI
public:
static readonly DependencyProperty^ RowsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CalendarView Class
CalendarView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
RequestBase Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : RequestBase Class

Base class for delayed action calls.

Syntax

Visual Basic (Declaration)
Public MustInherit Class RequestBase
Visual Basic (Usage) Copy Code
Dim instance As RequestBase
C#
public abstract class RequestBase
Managed Extensions for C++
public __gc abstract class RequestBase
C++/CLI
public ref class RequestBase abstract

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Calendar.RequestBase
Generic Telerik.Windows.Controls.Calendar.ActionRequest<T1,T2>
Generic Telerik.Windows.Controls.Calendar.ActionRequest<T>
Telerik.Windows.Controls.Calendar.ActionRequest

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RequestBase Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
RequestBase Class Members
See Also Methods
[image]
Telerik.Windows.Controls.Calendar Namespace : RequestBase Class

The following tables list the members exposed by RequestBase.

Public Methods

 | Name | Description
Public Method | Execute | Executes this instance.
Top

See Also

Reference

RequestBase Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
RequestBase Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : RequestBase Class

For a list of all members of this type, see RequestBase members.

Public Methods

 | Name | Description
Public Method | Execute | Executes this instance.
Top

See Also

Reference

RequestBase Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Execute Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > RequestBase Class : Execute Method

Executes this instance.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Execute()
Visual Basic (Usage) Copy Code
Dim instance As RequestBase

instance.Execute()
C#
public abstract void Execute()
Managed Extensions for C++
public: abstract void Execute();
C++/CLI
public:
abstract void Execute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RequestBase Class
RequestBase Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class
See Also Members
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

A panel that governs transitions from one of its children to another.

Syntax

Visual Basic (Declaration)
Public Class TransitionPanel
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As TransitionPanel
C#
public class TransitionPanel : Panel, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class TransitionPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class TransitionPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.Calendar.TransitionPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Members
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

The following tables list the members exposed by TransitionPanel.

Public Constructors

 | Name | Description
Public Constructor | TransitionPanel Constructor | Initializes a new instance of the TransitionPanel class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ClipToBoundsProperty | Indetifies the ClipTobounds property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | Gets or sets whether the a clip masks with the size of the control would be applied.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Protected Method | MeasureOverride | Overridden. When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TransitionPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Constructor
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > TransitionPanel Class : TransitionPanel Constructor

Initializes a new instance of the TransitionPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TransitionPanel()
C#
public TransitionPanel()
Managed Extensions for C++
public: TransitionPanel();
C++/CLI
public:
TransitionPanel();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Class
TransitionPanel Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

For a list of all members of this type, see TransitionPanel members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Protected Method | MeasureOverride | Overridden. When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top

See Also

Reference

TransitionPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > TransitionPanel Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TransitionPanel
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Class
TransitionPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > TransitionPanel Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TransitionPanel
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Class
TransitionPanel Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

For a list of all members of this type, see TransitionPanel members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | Gets or sets whether the a clip masks with the size of the control would be applied.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TransitionPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ClipToBounds Property
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > TransitionPanel Class : ClipToBounds Property

Gets or sets whether the a clip masks with the size of the control would be applied.

Syntax

Visual Basic (Declaration)
Public Property ClipToBounds As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TransitionPanel
Dim value As Boolean

instance.ClipToBounds = value

value = instance.ClipToBounds
C#
public bool ClipToBounds {get; set;}
Managed Extensions for C++
public: __property bool get_ClipToBounds();
public: __property void set_ClipToBounds(
   bool value
);
C++/CLI
public:
property bool ClipToBounds {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Class
TransitionPanel Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class Fields
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

For a list of all members of this type, see TransitionPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ClipToBoundsProperty | Indetifies the ClipTobounds property.
Top

See Also

Reference

TransitionPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
ClipToBoundsProperty Field
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace > TransitionPanel Class : ClipToBoundsProperty Field

Indetifies the ClipTobounds property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ClipToBoundsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = TransitionPanel.ClipToBoundsProperty
C#
public static readonly DependencyProperty ClipToBoundsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ClipToBoundsProperty
C++/CLI
public:
static readonly DependencyProperty^ ClipToBoundsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TransitionPanel Class
TransitionPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButtonType Enumeration
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButtonType Enumeration

Identifies the type of the Calendar Button.

Syntax

Visual Basic (Declaration)
Public Enum CalendarButtonType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CalendarButtonType
C#
public enum CalendarButtonType : Enum
Managed Extensions for C++
__value public enum CalendarButtonType : public Enum
C++/CLI
public enum class CalendarButtonType : public Enum

Members

Member | Description
TodayDate | The date button of today's date.
Date | A date button.
WeekNumber | A calendar button with the week number.
WeekName | A calendar button with the week name.
Month | Calendar button with a month name or number.
Year | Calendar button with a year number.
Decade | Calendar button for a decade.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.Calendar.CalendarButtonType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DisplayMode Enumeration
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : DisplayMode Enumeration

Specifies the display mode of the calendar.

Syntax

Visual Basic (Declaration)
Public Enum DisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayMode
C#
public enum DisplayMode : Enum
Managed Extensions for C++
__value public enum DisplayMode : public Enum
C++/CLI
public enum class DisplayMode : public Enum

Members

Member | Description
MonthView | The calendar shows one or more months for choosing dates.
YearView | The calendar displays the months of one or more years.
DecadeView | The calendar displays one or more decades (10s) of years.
CenturyView | The calendar displays one or more centuries.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.Calendar.DisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls.Calendar Namespace


%%ItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DateParseException | Custom exception class

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Class
See Also Members
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace : DateParseException Class

Custom exception class

Syntax

Visual Basic (Declaration)
Public Class DateParseException
   Inherits Exception
Visual Basic (Usage) Copy Code
Dim instance As DateParseException
C#
public class DateParseException : Exception
Managed Extensions for C++
public __gc class DateParseException : public Exception
C++/CLI
public ref class DateParseException : public Exception

Inheritance Hierarchy

System.Object
System.Exception
Telerik.Windows.Controls.DatePicker.DateTimeParsing.DateParseException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Members
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace : DateParseException Class

The following tables list the members exposed by DateParseException.

Public Constructors

 | Name | Description
Public Constructor | DateParseException Constructor | Overloaded. Initializes a new instance of the DateParseException class.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DateParseException Class
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Constructor
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace > DateParseException Class : DateParseException Constructor

Initializes a new instance of the DateParseException class.

Overload List

Overload | Description
DateParseException Constructor() | Initializes a new instance of the DateParseException class.
DateParseException Constructor(String) | Initializes a new instance of the DateParseException class.
DateParseException Constructor(String,Exception) | Initializes a new instance of the DateParseException class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Class
DateParseException Members


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Constructor()
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace > DateParseException Class > DateParseException Constructor : DateParseException Constructor()

Initializes a new instance of the DateParseException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DateParseException()
C#
public DateParseException()
Managed Extensions for C++
public: DateParseException();
C++/CLI
public:
DateParseException();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Class
DateParseException Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Constructor(String)
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace > DateParseException Class > DateParseException Constructor : DateParseException Constructor(String)

message
The message.
Initializes a new instance of the DateParseException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As DateParseException(message)
C#
public DateParseException(
   string message
)
Managed Extensions for C++
public: DateParseException(
   string* message
)
C++/CLI
public:
DateParseException(
   String^ message
)

Parameters

message
The message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Class
DateParseException Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Constructor(String,Exception)
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace > DateParseException Class > DateParseException Constructor : DateParseException Constructor(String,Exception)

message
The message.
exception
The exception.
Initializes a new instance of the DateParseException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim exception As Exception

Dim instance As DateParseException(message, exception)
C#
public DateParseException(
   string message,
   Exception exception
)
Managed Extensions for C++
public: DateParseException(
   string* message,
   Exception* exception
)
C++/CLI
public:
DateParseException(
   String^ message,
   Exception^ exception
)

Parameters

message
The message.
exception
The exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Class
DateParseException Members
Overload List


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Class Properties
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace : DateParseException Class

For a list of all members of this type, see DateParseException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

DateParseException Class
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Message Property
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace > DateParseException Class : Message Property

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As DateParseException
Dim value As String

value = instance.Message
C#
public override string Message {get;}
Managed Extensions for C++
public: __property string* get_Message() override;
C++/CLI
public:
property String^ Message {
   String^ get() override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateParseException Class
DateParseException Members


%%ItemTitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.Upload Namespace
See Also Inheritance Hierarchy

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%phrase%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Telerik.Windows.Controls.MediaPlayer Assembly

Namespaces

Namespace | Description
Telerik.Windows.Controls |


%%ItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.MediaPlayer)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | FullscreenChangedEventArgs | Used in FullscreenChanged event. Arguments contain RadMediaPlayer's size and whether RadMediaPlayer is in Fullscreen mode or not.
Class | ItemsCountToIsEnabledConverter | Previous/Next buttons' IsEnabled state is bound to each RadMediaItem's Items.Count property. If the current RadMediaItem does not contain any chapters, then Previous/Next buttons are disabled.
Class | PlaylistPresenter | PlaylistPresenter is used by RadMediaPlayer to display its media items.
Class | RadChaptersPresenter | Control used to display all the RadChapter objects inside a certain RadMediaItem object.
Class | RadMediaChapter | Chapters gives you the ability to highlight key media content. Chapters are added to the a RadMediaItem object using its Items collection. In XAML RadMediaItem RadMediaChapter RadMediaItem Each chapter (which is a RadMediaChapter class) is defined with the following properties: Position - the exact time (in seconds) when the chapter begins Title - the title of the chapter. If the EnableCaption property is set to true, the title will be displayed to the user when the media player reaches the time index for this chapter. ImageSource - url of the image with which the chapter is previewed in RadChaptersPresenter
Class | RadMediaItem | RadMediaItem allows a user to populate RadMediaPlayer with media items. RadMediaItem is identified by the following properties: Source - the Uri of the media file ImageSource - the Uri of the image file that will represent RadMediaItem in RadmediaPlayer's playlist. Title - text that is displayed in the Title area of RadMediaPlayer Description - longer text describing the media
Class | RadMediaPlayer | RadMediaPlayer is a flexible UI component based on Silverlight 2.0 platform. It allows users to play a variety of video and audio formats into a web page.

See Also

Reference

Telerik.Windows.Controls.MediaPlayer Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : FullscreenChangedEventArgs Class

Used in FullscreenChanged event. Arguments contain RadMediaPlayer's size and whether RadMediaPlayer is in Fullscreen mode or not.

Syntax

Visual Basic (Declaration)
Public Class FullscreenChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As FullscreenChangedEventArgs
C#
public class FullscreenChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class FullscreenChangedEventArgs : public EventArgs
C++/CLI
public ref class FullscreenChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.FullscreenChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : FullscreenChangedEventArgs Class

The following tables list the members exposed by FullscreenChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FullscreenChangedEventArgs Constructor | Overloaded. Initializes a new instance of the FullscreenChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | IsFullscreen | Gets a value indicating whether RadMediaPlayer is fullscreen.
Public Property | MediaPlayerSize | Gets the size of the media player.
Top

See Also

Reference

FullscreenChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class : FullscreenChangedEventArgs Constructor

Initializes a new instance of the FullscreenChangedEventArgs class.

Overload List

Overload | Description
FullscreenChangedEventArgs Constructor() | Initializes a new instance of the FullscreenChangedEventArgs class.
FullscreenChangedEventArgs Constructor(Size) | Initializes a new instance of the FullscreenChangedEventArgs class.
FullscreenChangedEventArgs Constructor(Size,Boolean) | Initializes a new instance of the FullscreenChangedEventArgs class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Constructor()
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class > FullscreenChangedEventArgs Constructor : FullscreenChangedEventArgs Constructor()

Initializes a new instance of the FullscreenChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FullscreenChangedEventArgs()
C#
public FullscreenChangedEventArgs()
Managed Extensions for C++
public: FullscreenChangedEventArgs();
C++/CLI
public:
FullscreenChangedEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Constructor(Size)
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class > FullscreenChangedEventArgs Constructor : FullscreenChangedEventArgs Constructor(Size)

mediaPlayerSize
Size of the media player.
Initializes a new instance of the FullscreenChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mediaPlayerSize As Size _
)
Visual Basic (Usage) Copy Code
Dim mediaPlayerSize As Size

Dim instance As FullscreenChangedEventArgs(mediaPlayerSize)
C#
public FullscreenChangedEventArgs(
   Size mediaPlayerSize
)
Managed Extensions for C++
public: FullscreenChangedEventArgs(
   Size mediaPlayerSize
)
C++/CLI
public:
FullscreenChangedEventArgs(
   Size mediaPlayerSize
)

Parameters

mediaPlayerSize
Size of the media player.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Constructor(Size,Boolean)
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class > FullscreenChangedEventArgs Constructor : FullscreenChangedEventArgs Constructor(Size,Boolean)

mediaPlayerSize
Size of the media player.
isFullscreen
if set to true [is fullscreen].
Initializes a new instance of the FullscreenChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mediaPlayerSize As Size, _
   ByVal isFullscreen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim mediaPlayerSize As Size
Dim isFullscreen As Boolean

Dim instance As FullscreenChangedEventArgs(mediaPlayerSize, isFullscreen)
C#
public FullscreenChangedEventArgs(
   Size mediaPlayerSize,
   bool isFullscreen
)
Managed Extensions for C++
public: FullscreenChangedEventArgs(
   Size mediaPlayerSize,
   bool isFullscreen
)
C++/CLI
public:
FullscreenChangedEventArgs(
   Size mediaPlayerSize,
   bool isFullscreen
)

Parameters

mediaPlayerSize
Size of the media player.
isFullscreen
if set to true [is fullscreen].

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members
Overload List


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullscreenChangedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : FullscreenChangedEventArgs Class

For a list of all members of this type, see FullscreenChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | IsFullscreen | Gets a value indicating whether RadMediaPlayer is fullscreen.
Public Property | MediaPlayerSize | Gets the size of the media player.
Top

See Also

Reference

FullscreenChangedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
IsFullscreen Property
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class : IsFullscreen Property

Gets a value indicating whether RadMediaPlayer is fullscreen.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property IsFullscreen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FullscreenChangedEventArgs
Dim value As Boolean

value = instance.IsFullscreen
C#
[CompilerGeneratedAttribute()]
public bool IsFullscreen {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property bool get_IsFullscreen();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property bool IsFullscreen {
   bool get();
}

Return Value

true if this instance is fullscreen; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaPlayerSize Property
See Also
[image]
Telerik.Windows.Controls Namespace > FullscreenChangedEventArgs Class : MediaPlayerSize Property

Gets the size of the media player.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property MediaPlayerSize As Size
Visual Basic (Usage) Copy Code
Dim instance As FullscreenChangedEventArgs
Dim value As Size

value = instance.MediaPlayerSize
C#
[CompilerGeneratedAttribute()]
public Size MediaPlayerSize {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Size get_MediaPlayerSize();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Size MediaPlayerSize {
   Size get();
}

Return Value

The size of the media player.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FullscreenChangedEventArgs Class
FullscreenChangedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ItemsCountToIsEnabledConverter Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : ItemsCountToIsEnabledConverter Class

Previous/Next buttons' IsEnabled state is bound to each RadMediaItem's Items.Count property. If the current RadMediaItem does not contain any chapters, then Previous/Next buttons are disabled.

Syntax

Visual Basic (Declaration)
Public Class ItemsCountToIsEnabledConverter
Visual Basic (Usage) Copy Code
Dim instance As ItemsCountToIsEnabledConverter
C#
public class ItemsCountToIsEnabledConverter
Managed Extensions for C++
public __gc class ItemsCountToIsEnabledConverter
C++/CLI
public ref class ItemsCountToIsEnabledConverter

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.ItemsCountToIsEnabledConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsCountToIsEnabledConverter Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ItemsCountToIsEnabledConverter Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : ItemsCountToIsEnabledConverter Class

The following tables list the members exposed by ItemsCountToIsEnabledConverter.

Public Constructors

 | Name | Description
Public Constructor | ItemsCountToIsEnabledConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | Convert | Modifies the source data before passing it to the target for display in the UI.
Public Method | ConvertBack | Modifies the target data before passing it to the source object.
Top

See Also

Reference

ItemsCountToIsEnabledConverter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ItemsCountToIsEnabledConverter Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsCountToIsEnabledConverter Class : ItemsCountToIsEnabledConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ItemsCountToIsEnabledConverter()
C#
public ItemsCountToIsEnabledConverter()
Managed Extensions for C++
public: ItemsCountToIsEnabledConverter();
C++/CLI
public:
ItemsCountToIsEnabledConverter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsCountToIsEnabledConverter Class
ItemsCountToIsEnabledConverter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ItemsCountToIsEnabledConverter Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsCountToIsEnabledConverter Class

For a list of all members of this type, see ItemsCountToIsEnabledConverter members.

Public Methods

 | Name | Description
Public Method | Convert | Modifies the source data before passing it to the target for display in the UI.
Public Method | ConvertBack | Modifies the target data before passing it to the source object.
Top

See Also

Reference

ItemsCountToIsEnabledConverter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Convert Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsCountToIsEnabledConverter Class : Convert Method

value
The source data being passed to the target.
targetType
The Type of data expected by the target dependency property.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.
Modifies the source data before passing it to the target for display in the UI.

Syntax

Visual Basic (Declaration)
Public Function Convert( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ItemsCountToIsEnabledConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.Convert(value, targetType, parameter, culture)
C#
public object Convert(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
Managed Extensions for C++
public: Object* Convert(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
C++/CLI
public:
Object^ Convert(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The source data being passed to the target.
targetType
The Type of data expected by the target dependency property.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.

Return Value

The value to be passed to the target dependency property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsCountToIsEnabledConverter Class
ItemsCountToIsEnabledConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ConvertBack Method
See Also
[image]
Telerik.Windows.Controls Namespace > ItemsCountToIsEnabledConverter Class : ConvertBack Method

value
The target data being passed to the source.
targetType
The Type of data expected by the source object.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.
Modifies the target data before passing it to the source object.

Syntax

Visual Basic (Declaration)
Public Function ConvertBack( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ItemsCountToIsEnabledConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.ConvertBack(value, targetType, parameter, culture)
C#
public object ConvertBack(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
Managed Extensions for C++
public: Object* ConvertBack(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
C++/CLI
public:
Object^ ConvertBack(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The target data being passed to the source.
targetType
The Type of data expected by the source object.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.

Return Value

The value to be passed to the source object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemsCountToIsEnabledConverter Class
ItemsCountToIsEnabledConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : PlaylistPresenter Class

PlaylistPresenter is used by RadMediaPlayer to display its media items.

Syntax

Visual Basic (Declaration)
Public Class PlaylistPresenter
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As PlaylistPresenter
C#
public class PlaylistPresenter : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class PlaylistPresenter : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class PlaylistPresenter : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.PlaylistPresenter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PlaylistPresenter Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : PlaylistPresenter Class

The following tables list the members exposed by PlaylistPresenter.

Public Constructors

 | Name | Description
Public Constructor | PlaylistPresenter Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

PlaylistPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > PlaylistPresenter Class : PlaylistPresenter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PlaylistPresenter()
C#
public PlaylistPresenter()
Managed Extensions for C++
public: PlaylistPresenter();
C++/CLI
public:
PlaylistPresenter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PlaylistPresenter Class
PlaylistPresenter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : PlaylistPresenter Class

For a list of all members of this type, see PlaylistPresenter members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

PlaylistPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > PlaylistPresenter Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As PlaylistPresenter

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PlaylistPresenter Class
PlaylistPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadChaptersPresenter Class

Control used to display all the RadChapter objects inside a certain RadMediaItem object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadChaptersPresenter
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter
C#
public class RadChaptersPresenter : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadChaptersPresenter : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadChaptersPresenter : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadChaptersPresenter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadChaptersPresenter Class

The following tables list the members exposed by RadChaptersPresenter.

Public Constructors

 | Name | Description
Public Constructor | RadChaptersPresenter Constructor | Initializes a new instance of the RadChaptersPresenter class.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadChaptersPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadChaptersPresenter Class : RadChaptersPresenter Constructor

Initializes a new instance of the RadChaptersPresenter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter()
C#
public RadChaptersPresenter()
Managed Extensions for C++
public: RadChaptersPresenter();
C++/CLI
public:
RadChaptersPresenter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Class
RadChaptersPresenter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadChaptersPresenter Class

For a list of all members of this type, see RadChaptersPresenter members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadChaptersPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadChaptersPresenter Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Class
RadChaptersPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadChaptersPresenter Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Class
RadChaptersPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadChaptersPresenter Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Class
RadChaptersPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadChaptersPresenter Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadChaptersPresenter
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadChaptersPresenter Class
RadChaptersPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

Chapters gives you the ability to highlight key media content. Chapters are added to the a RadMediaItem object using its Items collection. In XAML RadMediaItem RadMediaChapter RadMediaItem Each chapter (which is a RadMediaChapter class) is defined with the following properties: Position - the exact time (in seconds) when the chapter begins Title - the title of the chapter. If the EnableCaption property is set to true, the title will be displayed to the user when the media player reaches the time index for this chapter. ImageSource - url of the image with which the chapter is previewed in RadChaptersPresenter

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
Public Class RadMediaChapter
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadMediaChapter
C#
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public class RadMediaChapter : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public __gc class RadMediaChapter : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public ref class RadMediaChapter : public Control, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadMediaChapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

The following tables list the members exposed by RadMediaChapter.

Public Constructors

 | Name | Description
Public Constructor | RadMediaChapter Constructor | Overloaded. Initializes a new instance of the RadMediaChapter class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ChapterClickEvent | Occurs whenever a chapter is clicked.
static (Shared in Visual Basic) | ImageSourceProperty | Identifies the ImageSource dependency property.
static (Shared in Visual Basic) | PositionProperty | Identifies the Position dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImageSource | Gets or sets the ImageSource possible Value of the ImageSource object.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Position | Gets or sets the position of RadMediaChapter. The Position property is used when the user wants to jump to a specific moment of the media item.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets or sets the Title property of RadMediaChapter. The title property provides a string that will be displayed when the current RadMediaChapter is reached.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaChapter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : RadMediaChapter Constructor

Initializes a new instance of the RadMediaChapter class.

Overload List

Overload | Description
RadMediaChapter Constructor() | Initializes a new instance of the RadMediaChapter class.
RadMediaChapter Constructor(String) | Initializes a new instance of the RadMediaChapter class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Constructor()
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class > RadMediaChapter Constructor : RadMediaChapter Constructor()

Initializes a new instance of the RadMediaChapter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaChapter()
C#
public RadMediaChapter()
Managed Extensions for C++
public: RadMediaChapter();
C++/CLI
public:
RadMediaChapter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Constructor(String)
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class > RadMediaChapter Constructor : RadMediaChapter Constructor(String)

position
The position.
Initializes a new instance of the RadMediaChapter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As String _
)
Visual Basic (Usage) Copy Code
Dim position As String

Dim instance As RadMediaChapter(position)
C#
public RadMediaChapter(
   string position
)
Managed Extensions for C++
public: RadMediaChapter(
   string* position
)
C++/CLI
public:
RadMediaChapter(
   String^ position
)

Parameters

position
The position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members
Overload List


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

For a list of all members of this type, see RadMediaChapter members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImageSource | Gets or sets the ImageSource possible Value of the ImageSource object.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | Position | Gets or sets the position of RadMediaChapter. The Position property is used when the user wants to jump to a specific moment of the media item.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets or sets the Title property of RadMediaChapter. The title property provides a string that will be displayed when the current RadMediaChapter is reached.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMediaChapter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ImageSource Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : ImageSource Property

Gets or sets the ImageSource possible Value of the ImageSource object.

Syntax

Visual Basic (Declaration)
Public Property ImageSource As ImageSource
Visual Basic (Usage) Copy Code
Dim instance As RadMediaChapter
Dim value As ImageSource

instance.ImageSource = value

value = instance.ImageSource
C#
public ImageSource ImageSource {get; set;}
Managed Extensions for C++
public: __property ImageSource* get_ImageSource();
public: __property void set_ImageSource(
   ImageSource* value
);
C++/CLI
public:
property ImageSource^ ImageSource {
   ImageSource^ get();
   void set (ImageSource^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Position Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : Position Property

Gets or sets the position of RadMediaChapter. The Position property is used when the user wants to jump to a specific moment of the media item.

Syntax

Visual Basic (Declaration)
Public Property Position As String
Visual Basic (Usage) Copy Code
Dim instance As RadMediaChapter
Dim value As String

instance.Position = value

value = instance.Position
C#
public string Position {get; set;}
Managed Extensions for C++
public: __property string* get_Position();
public: __property void set_Position(
   string* value
);
C++/CLI
public:
property String^ Position {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Title Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : Title Property

Gets or sets the Title property of RadMediaChapter. The title property provides a string that will be displayed when the current RadMediaChapter is reached.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadMediaChapter
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

For a list of all members of this type, see RadMediaChapter members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ChapterClickEvent | Occurs whenever a chapter is clicked.
static (Shared in Visual Basic) | ImageSourceProperty | Identifies the ImageSource dependency property.
static (Shared in Visual Basic) | PositionProperty | Identifies the Position dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
Top

See Also

Reference

RadMediaChapter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ChapterClickEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : ChapterClickEvent Field

Occurs whenever a chapter is clicked.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ChapterClickEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaChapter.ChapterClickEvent
C#
public static readonly RoutedEvent ChapterClickEvent
Managed Extensions for C++
public: static readonly RoutedEvent* ChapterClickEvent
C++/CLI
public:
static readonly RoutedEvent^ ChapterClickEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ImageSourceProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : ImageSourceProperty Field

Identifies the ImageSource dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ImageSourceProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaChapter.ImageSourceProperty
C#
public static readonly DependencyProperty ImageSourceProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ImageSourceProperty
C++/CLI
public:
static readonly DependencyProperty^ ImageSourceProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PositionProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : PositionProperty Field

Identifies the Position dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PositionProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaChapter.PositionProperty
C#
public static readonly DependencyProperty PositionProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PositionProperty
C++/CLI
public:
static readonly DependencyProperty^ PositionProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
TitleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaChapter Class : TitleProperty Field

Identifies the Title dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaChapter.TitleProperty
C#
public static readonly DependencyProperty TitleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TitleProperty
C++/CLI
public:
static readonly DependencyProperty^ TitleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaChapter Class
RadMediaChapter Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

RadMediaItem allows a user to populate RadMediaPlayer with media items. RadMediaItem is identified by the following properties: Source - the Uri of the media file ImageSource - the Uri of the image file that will represent RadMediaItem in RadmediaPlayer's playlist. Title - text that is displayed in the Title area of RadMediaPlayer Description - longer text describing the media

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
Public Class RadMediaItem
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
C#
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public class RadMediaItem : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public __gc class RadMediaItem : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public ref class RadMediaItem : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadMediaItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

The following tables list the members exposed by RadMediaItem.

Public Constructors

 | Name | Description
Public Constructor | RadMediaItem Constructor | Initializes a new instance of the RadMediaItem class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentItemChangedEvent | Occurs whenever a chapter is clicked.
static (Shared in Visual Basic) | DescriptionProperty | Identifies the Description dependency property.
static (Shared in Visual Basic) | ImageSourceProperty | Identifies the ImageSource dependency property.
static (Shared in Visual Basic) | SourceProperty | Identifies the Source dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
static (Shared in Visual Basic) | VideoHeightProperty | Identifies the VideoHeight dependency property.
static (Shared in Visual Basic) | VideoStretchProperty | Identifies the VideoStretch dependency property.
static (Shared in Visual Basic) | VideoWidthProperty | Identifies the VideoWidth dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | Description | Gets or sets the text that will be used as a description for RadMediaItem in RadMediaPlayer's playlist.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImageSource | Gets or sets the image file that will be used for representing RadMediaItem in RadMediaPlayer's playlist.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Source | Gets or sets the video file associated with the media item. Source is of type Uri.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets or sets the Title possible Value of the string object.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VideoHeight | Gets or sets the VideoHeight possible Value of the double object.
Public Property | VideoStretch | Gets or sets the VideoStretch possible Value of the Stretch object.
Public Property | VideoWidth | Gets or sets the VideoWidth possible Value of the double object.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : RadMediaItem Constructor

Initializes a new instance of the RadMediaItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem()
C#
public RadMediaItem()
Managed Extensions for C++
public: RadMediaItem();
C++/CLI
public:
RadMediaItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

For a list of all members of this type, see RadMediaItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

See Also

Reference

RadMediaItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

For a list of all members of this type, see RadMediaItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | Description | Gets or sets the text that will be used as a description for RadMediaItem in RadMediaPlayer's playlist.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImageSource | Gets or sets the image file that will be used for representing RadMediaItem in RadMediaPlayer's playlist.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Source | Gets or sets the video file associated with the media item. Source is of type Uri.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets or sets the Title possible Value of the string object.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VideoHeight | Gets or sets the VideoHeight possible Value of the double object.
Public Property | VideoStretch | Gets or sets the VideoStretch possible Value of the Stretch object.
Public Property | VideoWidth | Gets or sets the VideoWidth possible Value of the double object.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMediaItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Description Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : Description Property

Gets or sets the text that will be used as a description for RadMediaItem in RadMediaPlayer's playlist.

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}

Return Value

The description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ImageSource Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : ImageSource Property

Gets or sets the image file that will be used for representing RadMediaItem in RadMediaPlayer's playlist.

Syntax

Visual Basic (Declaration)
Public Property ImageSource As ImageSource
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As ImageSource

instance.ImageSource = value

value = instance.ImageSource
C#
public ImageSource ImageSource {get; set;}
Managed Extensions for C++
public: __property ImageSource* get_ImageSource();
public: __property void set_ImageSource(
   ImageSource* value
);
C++/CLI
public:
property ImageSource^ ImageSource {
   ImageSource^ get();
   void set (ImageSource^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Source Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : Source Property

Gets or sets the video file associated with the media item. Source is of type Uri.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")>
Public Property Source As Uri
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As Uri

instance.Source = value

value = instance.Source
C#
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public Uri Source {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public: __property Uri* get_Source();
public: __property void set_Source(
   Uri* value
);
C++/CLI
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public:
property Uri^ Source {
   Uri^ get();
   void set (Uri^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Title Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : Title Property

Gets or sets the Title possible Value of the string object.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoHeight Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoHeight Property

Gets or sets the VideoHeight possible Value of the double object.

Syntax

Visual Basic (Declaration)
Public Property VideoHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As Double

instance.VideoHeight = value

value = instance.VideoHeight
C#
public double VideoHeight {get; set;}
Managed Extensions for C++
public: __property double get_VideoHeight();
public: __property void set_VideoHeight(
   double value
);
C++/CLI
public:
property double VideoHeight {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoStretch Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoStretch Property

Gets or sets the VideoStretch possible Value of the Stretch object.

Syntax

Visual Basic (Declaration)
Public Property VideoStretch As Stretch
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As Stretch

instance.VideoStretch = value

value = instance.VideoStretch
C#
public Stretch VideoStretch {get; set;}
Managed Extensions for C++
public: __property Stretch get_VideoStretch();
public: __property void set_VideoStretch(
   Stretch value
);
C++/CLI
public:
property Stretch VideoStretch {
   Stretch get();
   void set (Stretch value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoWidth Property

Gets or sets the VideoWidth possible Value of the double object.

Syntax

Visual Basic (Declaration)
Public Property VideoWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadMediaItem
Dim value As Double

instance.VideoWidth = value

value = instance.VideoWidth
C#
public double VideoWidth {get; set;}
Managed Extensions for C++
public: __property double get_VideoWidth();
public: __property void set_VideoWidth(
   double value
);
C++/CLI
public:
property double VideoWidth {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

For a list of all members of this type, see RadMediaItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentItemChangedEvent | Occurs whenever a chapter is clicked.
static (Shared in Visual Basic) | DescriptionProperty | Identifies the Description dependency property.
static (Shared in Visual Basic) | ImageSourceProperty | Identifies the ImageSource dependency property.
static (Shared in Visual Basic) | SourceProperty | Identifies the Source dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
static (Shared in Visual Basic) | VideoHeightProperty | Identifies the VideoHeight dependency property.
static (Shared in Visual Basic) | VideoStretchProperty | Identifies the VideoStretch dependency property.
static (Shared in Visual Basic) | VideoWidthProperty | Identifies the VideoWidth dependency property.
Top

See Also

Reference

RadMediaItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentItemChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : CurrentItemChangedEvent Field

Occurs whenever a chapter is clicked.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CurrentItemChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaItem.CurrentItemChangedEvent
C#
public static readonly RoutedEvent CurrentItemChangedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* CurrentItemChangedEvent
C++/CLI
public:
static readonly RoutedEvent^ CurrentItemChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
DescriptionProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : DescriptionProperty Field

Identifies the Description dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DescriptionProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.DescriptionProperty
C#
public static readonly DependencyProperty DescriptionProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DescriptionProperty
C++/CLI
public:
static readonly DependencyProperty^ DescriptionProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ImageSourceProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : ImageSourceProperty Field

Identifies the ImageSource dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ImageSourceProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.ImageSourceProperty
C#
public static readonly DependencyProperty ImageSourceProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ImageSourceProperty
C++/CLI
public:
static readonly DependencyProperty^ ImageSourceProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
SourceProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : SourceProperty Field

Identifies the Source dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.SourceProperty
C#
public static readonly DependencyProperty SourceProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SourceProperty
C++/CLI
public:
static readonly DependencyProperty^ SourceProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
TitleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : TitleProperty Field

Identifies the Title dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.TitleProperty
C#
public static readonly DependencyProperty TitleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TitleProperty
C++/CLI
public:
static readonly DependencyProperty^ TitleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoHeightProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoHeightProperty Field

Identifies the VideoHeight dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoHeightProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.VideoHeightProperty
C#
public static readonly DependencyProperty VideoHeightProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoHeightProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoHeightProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoStretchProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoStretchProperty Field

Identifies the VideoStretch dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoStretchProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.VideoStretchProperty
C#
public static readonly DependencyProperty VideoStretchProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoStretchProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoStretchProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaItem Class : VideoWidthProperty Field

Identifies the VideoWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaItem.VideoWidthProperty
C#
public static readonly DependencyProperty VideoWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaItem Class
RadMediaItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

RadMediaPlayer is a flexible UI component based on Silverlight 2.0 platform. It allows users to play a variety of video and audio formats into a web page.

Object Model

Syntax

Visual Basic (Declaration)
<TemplatePartAttribute(Name="LayoutRoot", Type=System.Windows.FrameworkElement)>
<TemplateVisualStateAttribute(Name="VisibleChaptersPresenter", GroupName="ChaptersPresenterStates")>
Public Class RadMediaPlayer
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
C#
[TemplatePartAttribute(Name="LayoutRoot", Type=System.Windows.FrameworkElement)]
[TemplateVisualStateAttribute(Name="VisibleChaptersPresenter", GroupName="ChaptersPresenterStates")]
public class RadMediaPlayer : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplatePartAttribute(Name="LayoutRoot", Type=System.Windows.FrameworkElement)]
[TemplateVisualStateAttribute(Name="VisibleChaptersPresenter", GroupName="ChaptersPresenterStates")]
public __gc class RadMediaPlayer : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplatePartAttribute(Name="LayoutRoot", Type=System.Windows.FrameworkElement)]
[TemplateVisualStateAttribute(Name="VisibleChaptersPresenter", GroupName="ChaptersPresenterStates")]
public ref class RadMediaPlayer : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadMediaPlayer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

The following tables list the members exposed by RadMediaPlayer.

Public Constructors

 | Name | Description
Public Constructor | RadMediaPlayer Constructor | Initializes a new instance of the RadMediaPlayer class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AutoPlaylistAdvanceProperty | Identifies the AutoPlaylistAdvance dependency property.
static (Shared in Visual Basic) | AutoPlayProperty | Identifies the AutoPlay dependency property.
static (Shared in Visual Basic) | AutoReverseProperty | Identifies the AutoReverse dependency property.
static (Shared in Visual Basic) | ChapterReachedEvent | Occurs whenever a chapter has been reached.
static (Shared in Visual Basic) | ChapterTitleProperty | A dependency property that holds the Title property of the CurrentItem.
static (Shared in Visual Basic) | CurrentItemProperty | Identifies the CurrentItem dependency property.
static (Shared in Visual Basic) | CurrentStateChangedEvent | Occurs whenever RadMediaPlayer changes its state.
static (Shared in Visual Basic) | DownloadProgressChangedEvent | Occurs when there is a change in the download progress of RadMediaPlayr.
static (Shared in Visual Basic) | IsFullscreenProperty | Identifies the IsFullscreen dependency property.
static (Shared in Visual Basic) | MediaElementCurrentTimeProperty | A dependency property that holds the current time of the MediaElement in RadMediaPlayer. This is a string property and it is formatted in order to be used by a TextBlock.
static (Shared in Visual Basic) | MediaElementTotalSecondsProperty | A dependency property that holds the duration(in seconds) of the current media item. This property is used by TimeSlider's Maximum property.
static (Shared in Visual Basic) | MediaElementTotalTimeProperty | A dependency property that holds the duration(in seconds) of the current media item. This is a string property and it is formatted in order to be used by a TextBlock.
static (Shared in Visual Basic) | MediaEndedEvent | Occurs when the current RadMediaItem has ended.
static (Shared in Visual Basic) | MediaOpenedEvent | Occurs when the current RadMediaItem opens its source.
static (Shared in Visual Basic) | PlaylistPresenterTemplate | Identifies the PlaylistControlTemplate dependency property.
static (Shared in Visual Basic) | SourceProperty | Identifies the Source dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
static (Shared in Visual Basic) | VideoHeightProperty | Identifies the VideoHeight dependency property.
static (Shared in Visual Basic) | VideoStretchProperty | Identifies the VideoStretch dependency property.
static (Shared in Visual Basic) | VideoWidthProperty | Identifies the VideoWidth dependency property.
static (Shared in Visual Basic) | VolumeProperty | Identifies the Volume dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoPlay | Gets or sets the AutoPlay possible Value of the bool object. If Autoplay is True RadMediaPlayer will automatically play the first item in the playlist.
Public Property | AutoPlaylistAdvance | Gets or sets the AutoPlaylistAdvance property. When a MediaItem ends and AutoPlaylistAdvance is True, the RadMediaPlayer will play the next item in the playlist.
Public Property | AutoReverse | Gets or sets the AutoReverse property. When RadMediaPlayer reaches the end of its playlist and AutoReverse is set to True, RadMediaPlayer will play its first item in the playlist.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | CurrentItem | Gets the current RadMediaItem.
Public Property | CurrentState | Gets the current state of RadMediaPlayer.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsFullscreen | Gets or sets the IsFullscreen possible Value of the bool object.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PlaylistControlTemplate | Gets or sets the PlaylistControlTemplate possible Value of the ControlTemplate object.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Source | Gets or sets the video file associated with the media item. Source is of type Uri.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets the Title of the current RadMediaItem.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VideoHeight | Gets or sets the VideoHeight possible Value of the double object.
Public Property | VideoStretch | Gets or sets the VideoStretch possible Value of the Stretch object.
Public Property | VideoWidth | Gets or sets the VideoWidth possible Value of the double object.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Volume | Gets or sets the Volume possible Value of the double object.
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | NextChapter | Goes to the next chapter.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Public Method | Pause | Pauses RadMediaPlayer.
Public Method | Play | Plays RadMediaPlayer.
Public Method | PreviousChapter | Goes to the previous chapter.
Public Method | Stop | Stops RadMediaPlayer.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | ChapterReached | CLR accessors for ChapterReachedEvent
Public Event | CurrentStateChanged | CLR accessors for CurrentStateChangedEvent
Public Event | DownloadProgressChanged | CLR accessors for DownloadProgressChangedEvent
Public Event | FullScreenChanged | Occurs when RadMediaPlayer toggles between fullscreen and normal screen.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MediaEnded | CLR accessors for MediaEndedEvent
Public Event | MediaOpened | CLR accessors for MediaOpenedEvent
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaPlayer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : RadMediaPlayer Constructor

Initializes a new instance of the RadMediaPlayer class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer()
C#
public RadMediaPlayer()
Managed Extensions for C++
public: RadMediaPlayer();
C++/CLI
public:
RadMediaPlayer();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

For a list of all members of this type, see RadMediaPlayer members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | NextChapter | Goes to the next chapter.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Public Method | Pause | Pauses RadMediaPlayer.
Public Method | Play | Plays RadMediaPlayer.
Public Method | PreviousChapter | Goes to the previous chapter.
Public Method | Stop | Stops RadMediaPlayer.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

See Also

Reference

RadMediaPlayer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
NextChapter Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : NextChapter Method

Goes to the next chapter.

Syntax

Visual Basic (Declaration)
Public Sub NextChapter()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.NextChapter()
C#
public void NextChapter()
Managed Extensions for C++
public: void NextChapter();
C++/CLI
public:
void NextChapter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Pause Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Pause Method

Pauses RadMediaPlayer.

Syntax

Visual Basic (Declaration)
Public Sub Pause()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.Pause()
C#
public void Pause()
Managed Extensions for C++
public: void Pause();
C++/CLI
public:
void Pause();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Play Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Play Method

Plays RadMediaPlayer.

Syntax

Visual Basic (Declaration)
Public Sub Play()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.Play()
C#
public void Play()
Managed Extensions for C++
public: void Play();
C++/CLI
public:
void Play();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PreviousChapter Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : PreviousChapter Method

Goes to the previous chapter.

Syntax

Visual Basic (Declaration)
Public Sub PreviousChapter()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.PreviousChapter()
C#
public void PreviousChapter()
Managed Extensions for C++
public: void PreviousChapter();
C++/CLI
public:
void PreviousChapter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Stop Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Stop Method

Stops RadMediaPlayer.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer

instance.Stop()
C#
public void Stop()
Managed Extensions for C++
public: void Stop();
C++/CLI
public:
void Stop();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

For a list of all members of this type, see RadMediaPlayer members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AutoPlay | Gets or sets the AutoPlay possible Value of the bool object. If Autoplay is True RadMediaPlayer will automatically play the first item in the playlist.
Public Property | AutoPlaylistAdvance | Gets or sets the AutoPlaylistAdvance property. When a MediaItem ends and AutoPlaylistAdvance is True, the RadMediaPlayer will play the next item in the playlist.
Public Property | AutoReverse | Gets or sets the AutoReverse property. When RadMediaPlayer reaches the end of its playlist and AutoReverse is set to True, RadMediaPlayer will play its first item in the playlist.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | CurrentItem | Gets the current RadMediaItem.
Public Property | CurrentState | Gets the current state of RadMediaPlayer.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsFullscreen | Gets or sets the IsFullscreen possible Value of the bool object.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PlaylistControlTemplate | Gets or sets the PlaylistControlTemplate possible Value of the ControlTemplate object.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Source | Gets or sets the video file associated with the media item. Source is of type Uri.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Title | Gets the Title of the current RadMediaItem.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | VideoHeight | Gets or sets the VideoHeight possible Value of the double object.
Public Property | VideoStretch | Gets or sets the VideoStretch possible Value of the Stretch object.
Public Property | VideoWidth | Gets or sets the VideoWidth possible Value of the double object.
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Volume | Gets or sets the Volume possible Value of the double object.
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMediaPlayer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoPlay Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoPlay Property

Gets or sets the AutoPlay possible Value of the bool object. If Autoplay is True RadMediaPlayer will automatically play the first item in the playlist.

Syntax

Visual Basic (Declaration)
Public Property AutoPlay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Boolean

instance.AutoPlay = value

value = instance.AutoPlay
C#
public bool AutoPlay {get; set;}
Managed Extensions for C++
public: __property bool get_AutoPlay();
public: __property void set_AutoPlay(
   bool value
);
C++/CLI
public:
property bool AutoPlay {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoPlaylistAdvance Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoPlaylistAdvance Property

Gets or sets the AutoPlaylistAdvance property. When a MediaItem ends and AutoPlaylistAdvance is True, the RadMediaPlayer will play the next item in the playlist.

Syntax

Visual Basic (Declaration)
Public Property AutoPlaylistAdvance As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Boolean

instance.AutoPlaylistAdvance = value

value = instance.AutoPlaylistAdvance
C#
public bool AutoPlaylistAdvance {get; set;}
Managed Extensions for C++
public: __property bool get_AutoPlaylistAdvance();
public: __property void set_AutoPlaylistAdvance(
   bool value
);
C++/CLI
public:
property bool AutoPlaylistAdvance {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoReverse Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoReverse Property

Gets or sets the AutoReverse property. When RadMediaPlayer reaches the end of its playlist and AutoReverse is set to True, RadMediaPlayer will play its first item in the playlist.

Syntax

Visual Basic (Declaration)
Public Property AutoReverse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Boolean

instance.AutoReverse = value

value = instance.AutoReverse
C#
public bool AutoReverse {get; set;}
Managed Extensions for C++
public: __property bool get_AutoReverse();
public: __property void set_AutoReverse(
   bool value
);
C++/CLI
public:
property bool AutoReverse {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : CurrentItem Property

Gets the current RadMediaItem.

Syntax

Visual Basic (Declaration)
Public Property CurrentItem As RadMediaItem
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As RadMediaItem

instance.CurrentItem = value

value = instance.CurrentItem
C#
public RadMediaItem CurrentItem {get; set;}
Managed Extensions for C++
public: __property RadMediaItem* get_CurrentItem();
public: __property void set_CurrentItem(
   RadMediaItem* value
);
C++/CLI
public:
property RadMediaItem^ CurrentItem {
   RadMediaItem^ get();
   void set (RadMediaItem^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentState Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : CurrentState Property

Gets the current state of RadMediaPlayer.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA2201:DoNotRaiseReservedExceptionTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public ReadOnly Property CurrentState As MediaElementState
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As MediaElementState

value = instance.CurrentState
C#
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA2201:DoNotRaiseReservedExceptionTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public MediaElementState CurrentState {get;}
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA2201:DoNotRaiseReservedExceptionTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: __property MediaElementState get_CurrentState();
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Usage",
   CheckId="CA2201:DoNotRaiseReservedExceptionTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
property MediaElementState CurrentState {
   MediaElementState get();
}

Return Value

The state of RadMediaPlayer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
IsFullscreen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : IsFullscreen Property

Gets or sets the IsFullscreen possible Value of the bool object.

Syntax

Visual Basic (Declaration)
Public Property IsFullscreen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Boolean

instance.IsFullscreen = value

value = instance.IsFullscreen
C#
public bool IsFullscreen {get; set;}
Managed Extensions for C++
public: __property bool get_IsFullscreen();
public: __property void set_IsFullscreen(
   bool value
);
C++/CLI
public:
property bool IsFullscreen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistControlTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : PlaylistControlTemplate Property

Gets or sets the PlaylistControlTemplate possible Value of the ControlTemplate object.

Syntax

Visual Basic (Declaration)
Public Property PlaylistControlTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As ControlTemplate

instance.PlaylistControlTemplate = value

value = instance.PlaylistControlTemplate
C#
public ControlTemplate PlaylistControlTemplate {get; set;}
Managed Extensions for C++
public: __property ControlTemplate* get_PlaylistControlTemplate();
public: __property void set_PlaylistControlTemplate(
   ControlTemplate* value
);
C++/CLI
public:
property ControlTemplate^ PlaylistControlTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Source Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Source Property

Gets or sets the video file associated with the media item. Source is of type Uri.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")>
Public Property Source As Uri
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Uri

instance.Source = value

value = instance.Source
C#
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public Uri Source {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public: __property Uri* get_Source();
public: __property void set_Source(
   Uri* value
);
C++/CLI
[TypeConverterAttribute("System.UriTypeConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public:
property Uri^ Source {
   Uri^ get();
   void set (Uri^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Title Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Title Property

Gets the Title of the current RadMediaItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As String

value = instance.Title
C#
public string Title {get;}
Managed Extensions for C++
public: __property string* get_Title();
C++/CLI
public:
property String^ Title {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoHeight Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoHeight Property

Gets or sets the VideoHeight possible Value of the double object.

Syntax

Visual Basic (Declaration)
Public Property VideoHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Double

instance.VideoHeight = value

value = instance.VideoHeight
C#
public double VideoHeight {get; set;}
Managed Extensions for C++
public: __property double get_VideoHeight();
public: __property void set_VideoHeight(
   double value
);
C++/CLI
public:
property double VideoHeight {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoStretch Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoStretch Property

Gets or sets the VideoStretch possible Value of the Stretch object.

Syntax

Visual Basic (Declaration)
Public Property VideoStretch As Stretch
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Stretch

instance.VideoStretch = value

value = instance.VideoStretch
C#
public Stretch VideoStretch {get; set;}
Managed Extensions for C++
public: __property Stretch get_VideoStretch();
public: __property void set_VideoStretch(
   Stretch value
);
C++/CLI
public:
property Stretch VideoStretch {
   Stretch get();
   void set (Stretch value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoWidth Property

Gets or sets the VideoWidth possible Value of the double object.

Syntax

Visual Basic (Declaration)
Public Property VideoWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Double

instance.VideoWidth = value

value = instance.VideoWidth
C#
public double VideoWidth {get; set;}
Managed Extensions for C++
public: __property double get_VideoWidth();
public: __property void set_VideoWidth(
   double value
);
C++/CLI
public:
property double VideoWidth {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Volume Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : Volume Property

Gets or sets the Volume possible Value of the double object.

Syntax

Visual Basic (Declaration)
Public Property Volume As Double
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim value As Double

instance.Volume = value

value = instance.Volume
C#
public double Volume {get; set;}
Managed Extensions for C++
public: __property double get_Volume();
public: __property void set_Volume(
   double value
);
C++/CLI
public:
property double Volume {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

For a list of all members of this type, see RadMediaPlayer members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AutoPlaylistAdvanceProperty | Identifies the AutoPlaylistAdvance dependency property.
static (Shared in Visual Basic) | AutoPlayProperty | Identifies the AutoPlay dependency property.
static (Shared in Visual Basic) | AutoReverseProperty | Identifies the AutoReverse dependency property.
static (Shared in Visual Basic) | ChapterReachedEvent | Occurs whenever a chapter has been reached.
static (Shared in Visual Basic) | ChapterTitleProperty | A dependency property that holds the Title property of the CurrentItem.
static (Shared in Visual Basic) | CurrentItemProperty | Identifies the CurrentItem dependency property.
static (Shared in Visual Basic) | CurrentStateChangedEvent | Occurs whenever RadMediaPlayer changes its state.
static (Shared in Visual Basic) | DownloadProgressChangedEvent | Occurs when there is a change in the download progress of RadMediaPlayr.
static (Shared in Visual Basic) | IsFullscreenProperty | Identifies the IsFullscreen dependency property.
static (Shared in Visual Basic) | MediaElementCurrentTimeProperty | A dependency property that holds the current time of the MediaElement in RadMediaPlayer. This is a string property and it is formatted in order to be used by a TextBlock.
static (Shared in Visual Basic) | MediaElementTotalSecondsProperty | A dependency property that holds the duration(in seconds) of the current media item. This property is used by TimeSlider's Maximum property.
static (Shared in Visual Basic) | MediaElementTotalTimeProperty | A dependency property that holds the duration(in seconds) of the current media item. This is a string property and it is formatted in order to be used by a TextBlock.
static (Shared in Visual Basic) | MediaEndedEvent | Occurs when the current RadMediaItem has ended.
static (Shared in Visual Basic) | MediaOpenedEvent | Occurs when the current RadMediaItem opens its source.
static (Shared in Visual Basic) | PlaylistPresenterTemplate | Identifies the PlaylistControlTemplate dependency property.
static (Shared in Visual Basic) | SourceProperty | Identifies the Source dependency property.
static (Shared in Visual Basic) | TitleProperty | Identifies the Title dependency property.
static (Shared in Visual Basic) | VideoHeightProperty | Identifies the VideoHeight dependency property.
static (Shared in Visual Basic) | VideoStretchProperty | Identifies the VideoStretch dependency property.
static (Shared in Visual Basic) | VideoWidthProperty | Identifies the VideoWidth dependency property.
static (Shared in Visual Basic) | VolumeProperty | Identifies the Volume dependency property.
Top

See Also

Reference

RadMediaPlayer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoPlaylistAdvanceProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoPlaylistAdvanceProperty Field

Identifies the AutoPlaylistAdvance dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AutoPlaylistAdvanceProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.AutoPlaylistAdvanceProperty
C#
public static readonly DependencyProperty AutoPlaylistAdvanceProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AutoPlaylistAdvanceProperty
C++/CLI
public:
static readonly DependencyProperty^ AutoPlaylistAdvanceProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoPlayProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoPlayProperty Field

Identifies the AutoPlay dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AutoPlayProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.AutoPlayProperty
C#
public static readonly DependencyProperty AutoPlayProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AutoPlayProperty
C++/CLI
public:
static readonly DependencyProperty^ AutoPlayProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
AutoReverseProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : AutoReverseProperty Field

Identifies the AutoReverse dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AutoReverseProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.AutoReverseProperty
C#
public static readonly DependencyProperty AutoReverseProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AutoReverseProperty
C++/CLI
public:
static readonly DependencyProperty^ AutoReverseProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ChapterReachedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : ChapterReachedEvent Field

Occurs whenever a chapter has been reached.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ChapterReachedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaPlayer.ChapterReachedEvent
C#
public static readonly RoutedEvent ChapterReachedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* ChapterReachedEvent
C++/CLI
public:
static readonly RoutedEvent^ ChapterReachedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ChapterTitleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : ChapterTitleProperty Field

A dependency property that holds the Title property of the CurrentItem.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ChapterTitleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.ChapterTitleProperty
C#
public static readonly DependencyProperty ChapterTitleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ChapterTitleProperty
C++/CLI
public:
static readonly DependencyProperty^ ChapterTitleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentItemProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : CurrentItemProperty Field

Identifies the CurrentItem dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CurrentItemProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.CurrentItemProperty
C#
public static readonly DependencyProperty CurrentItemProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CurrentItemProperty
C++/CLI
public:
static readonly DependencyProperty^ CurrentItemProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentStateChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : CurrentStateChangedEvent Field

Occurs whenever RadMediaPlayer changes its state.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CurrentStateChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaPlayer.CurrentStateChangedEvent
C#
public static readonly RoutedEvent CurrentStateChangedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* CurrentStateChangedEvent
C++/CLI
public:
static readonly RoutedEvent^ CurrentStateChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
DownloadProgressChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : DownloadProgressChangedEvent Field

Occurs when there is a change in the download progress of RadMediaPlayr.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DownloadProgressChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaPlayer.DownloadProgressChangedEvent
C#
public static readonly RoutedEvent DownloadProgressChangedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* DownloadProgressChangedEvent
C++/CLI
public:
static readonly RoutedEvent^ DownloadProgressChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
IsFullscreenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : IsFullscreenProperty Field

Identifies the IsFullscreen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFullscreenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.IsFullscreenProperty
C#
public static readonly DependencyProperty IsFullscreenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFullscreenProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFullscreenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaElementCurrentTimeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaElementCurrentTimeProperty Field

A dependency property that holds the current time of the MediaElement in RadMediaPlayer. This is a string property and it is formatted in order to be used by a TextBlock.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MediaElementCurrentTimeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.MediaElementCurrentTimeProperty
C#
public static readonly DependencyProperty MediaElementCurrentTimeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MediaElementCurrentTimeProperty
C++/CLI
public:
static readonly DependencyProperty^ MediaElementCurrentTimeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaElementTotalSecondsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaElementTotalSecondsProperty Field

A dependency property that holds the duration(in seconds) of the current media item. This property is used by TimeSlider's Maximum property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MediaElementTotalSecondsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.MediaElementTotalSecondsProperty
C#
public static readonly DependencyProperty MediaElementTotalSecondsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MediaElementTotalSecondsProperty
C++/CLI
public:
static readonly DependencyProperty^ MediaElementTotalSecondsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaElementTotalTimeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaElementTotalTimeProperty Field

A dependency property that holds the duration(in seconds) of the current media item. This is a string property and it is formatted in order to be used by a TextBlock.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MediaElementTotalTimeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.MediaElementTotalTimeProperty
C#
public static readonly DependencyProperty MediaElementTotalTimeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* MediaElementTotalTimeProperty
C++/CLI
public:
static readonly DependencyProperty^ MediaElementTotalTimeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaEndedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaEndedEvent Field

Occurs when the current RadMediaItem has ended.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MediaEndedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaPlayer.MediaEndedEvent
C#
public static readonly RoutedEvent MediaEndedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* MediaEndedEvent
C++/CLI
public:
static readonly RoutedEvent^ MediaEndedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaOpenedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaOpenedEvent Field

Occurs when the current RadMediaItem opens its source.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MediaOpenedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMediaPlayer.MediaOpenedEvent
C#
public static readonly RoutedEvent MediaOpenedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* MediaOpenedEvent
C++/CLI
public:
static readonly RoutedEvent^ MediaOpenedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenterTemplate Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : PlaylistPresenterTemplate Field

Identifies the PlaylistControlTemplate dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PlaylistPresenterTemplate As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.PlaylistPresenterTemplate
C#
public static readonly DependencyProperty PlaylistPresenterTemplate
Managed Extensions for C++
public: static readonly DependencyProperty* PlaylistPresenterTemplate
C++/CLI
public:
static readonly DependencyProperty^ PlaylistPresenterTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
SourceProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : SourceProperty Field

Identifies the Source dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.SourceProperty
C#
public static readonly DependencyProperty SourceProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SourceProperty
C++/CLI
public:
static readonly DependencyProperty^ SourceProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
TitleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : TitleProperty Field

Identifies the Title dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.TitleProperty
C#
public static readonly DependencyProperty TitleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TitleProperty
C++/CLI
public:
static readonly DependencyProperty^ TitleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoHeightProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoHeightProperty Field

Identifies the VideoHeight dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoHeightProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.VideoHeightProperty
C#
public static readonly DependencyProperty VideoHeightProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoHeightProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoHeightProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoStretchProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoStretchProperty Field

Identifies the VideoStretch dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoStretchProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.VideoStretchProperty
C#
public static readonly DependencyProperty VideoStretchProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoStretchProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoStretchProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VideoWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VideoWidthProperty Field

Identifies the VideoWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VideoWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.VideoWidthProperty
C#
public static readonly DependencyProperty VideoWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VideoWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ VideoWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
VolumeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : VolumeProperty Field

Identifies the Volume dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VolumeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMediaPlayer.VolumeProperty
C#
public static readonly DependencyProperty VolumeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* VolumeProperty
C++/CLI
public:
static readonly DependencyProperty^ VolumeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaPlayer Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaPlayer Class

For a list of all members of this type, see RadMediaPlayer members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | ChapterReached | CLR accessors for ChapterReachedEvent
Public Event | CurrentStateChanged | CLR accessors for CurrentStateChangedEvent
Public Event | DownloadProgressChanged | CLR accessors for DownloadProgressChangedEvent
Public Event | FullScreenChanged | Occurs when RadMediaPlayer toggles between fullscreen and normal screen.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MediaEnded | CLR accessors for MediaEndedEvent
Public Event | MediaOpened | CLR accessors for MediaOpenedEvent
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaPlayer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
ChapterReached Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : ChapterReached Event

CLR accessors for ChapterReachedEvent

Syntax

Visual Basic (Declaration)
Public Event ChapterReached() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.ChapterReached, handler
C#
public event EventHandler<RadRoutedEventArgs> ChapterReached()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* ChapterReached
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ ChapterReached

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
CurrentStateChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : CurrentStateChanged Event

CLR accessors for CurrentStateChangedEvent

Syntax

Visual Basic (Declaration)
Public Event CurrentStateChanged() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.CurrentStateChanged, handler
C#
public event EventHandler<RadRoutedEventArgs> CurrentStateChanged()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* CurrentStateChanged
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ CurrentStateChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
DownloadProgressChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : DownloadProgressChanged Event

CLR accessors for DownloadProgressChangedEvent

Syntax

Visual Basic (Declaration)
Public Event DownloadProgressChanged() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.DownloadProgressChanged, handler
C#
public event EventHandler<RadRoutedEventArgs> DownloadProgressChanged()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* DownloadProgressChanged
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ DownloadProgressChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
FullScreenChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : FullScreenChanged Event

Occurs when RadMediaPlayer toggles between fullscreen and normal screen.

Syntax

Visual Basic (Declaration)
Public Event FullScreenChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler

AddHandler instance.FullScreenChanged, handler
C#
public event EventHandler FullScreenChanged()
Managed Extensions for C++
public: __event EventHandler* FullScreenChanged
C++/CLI
public:
event EventHandler^ FullScreenChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaEnded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaEnded Event

CLR accessors for MediaEndedEvent

Syntax

Visual Basic (Declaration)
Public Event MediaEnded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.MediaEnded, handler
C#
public event EventHandler<RadRoutedEventArgs> MediaEnded()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* MediaEnded
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ MediaEnded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%PageItemTitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
MediaOpened Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMediaPlayer Class : MediaOpened Event

CLR accessors for MediaOpenedEvent

Syntax

Visual Basic (Declaration)
Public Event MediaOpened() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadMediaPlayer
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.MediaOpened, handler
C#
public event EventHandler<RadRoutedEventArgs> MediaOpened()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* MediaOpened
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ MediaOpened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMediaPlayer Class
RadMediaPlayer Members


%%phrase%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Telerik.Windows.Controls.Navigation Assembly

Namespaces

Namespace | Description
Telerik.Windows.Controls |
Telerik.Windows.Controls.Primitives |


%%ItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.Navigation)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | MenuBase | Represents a control that defines choices for users to select.
Class | RadAlert | RadAlert notifies the user according to its invocation parameters
Class | RadConfirm | RadAlert notifies the user according to its invocation parameters
Class | RadCube | Navigation control rendered as a Cube
Class | RadMenu | Represents a Silverlight menu control that enables you to hierarchically organize elements associated event handlers.
Class | RadMenuItem | Represents a selectable item inside a RadMenu.
Class | RadPanelBar | RadPanelBar is a UI control that constitues a collection of RadPanelBarItem. This control is capable of displaying flat as well as hierarchical data by nesting RadPanelBarItems when necessary.
Class | RadPanelBarItem | Implements a selectable item in a RadPanelBar control.
Class | RadPrompt | RadPrompt exposes a textbox in which the user can put any value.
Class | RadSeparator | Control that is used to separate items in items controls.
Class | RadTabControl | A navigation control used to create tabbed interfaces.
Class | RadTabItem | Represents a tab item, the default item of the RadTabControl.
Class | RadTreeView |
Class | RadTreeViewAutomationPeer |
Class | RadTreeViewDragEndedEventArgs | The EventArgs for the DradEdned event of the TreeView.
Class | RadTreeViewDragEventArgs |
Class | RadTreeViewItem |
Class | RadTreeViewItemAutomationPeer |
Class | RadTreeViewItemEditedEventArgs |
Class | RadWindow | Partial class RadWindow which contains properties declaration and callbacks
Class | RadWindowManager | RadWindowManager class exposes methods that apply to all RadWindows which are in the current RootVisual element.
Class | TabStripExtensions | Helper TabStrip extensions.
Class | WindowClosedEventArgs | WindowClosedEventArgs exposes DialogResult and PromptResult property for handling the closed event of a window.
Class | WindowClosingEventArgs | WindowClosingEventArgs exposes DialogResult and PromptResult property for handling the closing event of a window.

Delegates

 | Delegate | Description
Delegate | RadTreeViewDragEndedEventHandler | The handler for the TreeViews's DragEnded event.
Delegate | RadTreeViewDragEventHandler |
Delegate | RadTreeViewItemEditedEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | DropPosition |
Enumeration | ExpandMode | The ExpandMode enumeration is used in RadPanelBar to specify the allowed number of expanded RadPanelBarItem
Enumeration | MenuItemRole | Defines the different roles that a RadMenuItem can have.
Enumeration | OptionListType | Specifies the type of option list formed by itemContainer item.
Enumeration | PinMode | Specifies whether a window has the Pin button. Used by the PinMode property
Enumeration | ResizeMode | Specifies whether a window can be resized and, if so, how it can be resized. Used by the ResizeMode property.
Enumeration | TabStripAlign | The align of the buttons in the TabStrip.
Enumeration | TraversalDirection | The TraversalDirection enumeration is used in RadPanelBar to specify the direction in which a user is moving the selected item of the control. TraversalDirection is used only when the user is navigating with the keyboard.
Enumeration | WindowStartupLocation | Specifies the position that a Window will be shown in when it is first opened. Used by the RadWindow.WindowStartupLocation property.
Enumeration | WindowState | Specifies whether a window is in normal, minimized, or maximized state. Used by the WindowState property.

See Also

Reference

Telerik.Windows.Controls.Navigation Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

Represents a control that defines choices for users to select.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class MenuBase
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
C#
public abstract class MenuBase : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc abstract class MenuBase : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class MenuBase abstract : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.MenuBase
Telerik.Windows.Controls.RadMenu

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

The following tables list the members exposed by MenuBase.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ClickToOpenProperty | Identifies the ClickToOpen dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ClickToOpen | Gets or sets whether the child group opens upon clikcing a parent item
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnKeyDown | Invoked when keyboard key is pressed while the element has focus.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

MenuBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

For a list of all members of this type, see MenuBase members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnKeyDown | Invoked when keyboard key is pressed while the element has focus.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

MenuBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnKeyDown Method
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : OnKeyDown Method

e
The KeyEventArgs that contains the event data.
Invoked when keyboard key is pressed while the element has focus.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected virtual void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
protected: virtual void OnKeyDown(
   KeyEventArgs* e
)
C++/CLI
protected:
virtual void OnKeyDown(
   KeyEventArgs^ e
)

Parameters

e
The KeyEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

For a list of all members of this type, see MenuBase members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ClickToOpen | Gets or sets whether the child group opens upon clikcing a parent item
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

MenuBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClickToOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : ClickToOpen Property

Gets or sets whether the child group opens upon clikcing a parent item

Syntax

Visual Basic (Declaration)
Public Property ClickToOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuBase
Dim value As Boolean

instance.ClickToOpen = value

value = instance.ClickToOpen
C#
public bool ClickToOpen {get; set;}
Managed Extensions for C++
public: __property bool get_ClickToOpen();
public: __property void set_ClickToOpen(
   bool value
);
C++/CLI
public:
property bool ClickToOpen {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

For a list of all members of this type, see MenuBase members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ClickToOpenProperty | Identifies the ClickToOpen dependency property.
Top

See Also

Reference

MenuBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClickToOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > MenuBase Class : ClickToOpenProperty Field

Identifies the ClickToOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ClickToOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = MenuBase.ClickToOpenProperty
C#
public static readonly DependencyProperty ClickToOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ClickToOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ ClickToOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuBase Class
MenuBase Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadAlert Class

RadAlert notifies the user according to its invocation parameters

Syntax

Visual Basic (Declaration)
Public Class RadAlert
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadAlert
C#
public class RadAlert : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadAlert : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadAlert : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.RadAlert
Telerik.Windows.Controls.RadConfirm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadAlert Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadAlert Class

The following tables list the members exposed by RadAlert.

Public Constructors

 | Name | Description
Public Constructor | RadAlert Constructor | Default constructor for RadAlert
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Configure | Configures RadAlert according to the RadWindow
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadAlert Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadAlert Class : RadAlert Constructor

Default constructor for RadAlert

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAlert()
C#
public RadAlert()
Managed Extensions for C++
public: RadAlert();
C++/CLI
public:
RadAlert();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadAlert Class
RadAlert Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadAlert Class

For a list of all members of this type, see RadAlert members.

Public Methods

 | Name | Description
Public Method | Configure | Configures RadAlert according to the RadWindow
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

RadAlert Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Configure Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadAlert Class : Configure Method

window
RadWindow in which the RadPrompt will appear.
Configures RadAlert according to the RadWindow

Syntax

Visual Basic (Declaration)
Public Overridable Sub Configure( _
   ByVal window As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAlert
Dim window As RadWindow

instance.Configure(window)
C#
public virtual void Configure(
   RadWindow window
)
Managed Extensions for C++
public: virtual void Configure(
   RadWindow* window
)
C++/CLI
public:
virtual void Configure(
   RadWindow^ window
)

Parameters

window
RadWindow in which the RadPrompt will appear.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadAlert Class
RadAlert Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadAlert Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadAlert

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadAlert Class
RadAlert Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadAlert Class

For a list of all members of this type, see RadAlert members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadAlert Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Ok Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadAlert Class : Ok Event

Identifier of Cancel

Syntax

Visual Basic (Declaration)
Public Event Ok() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadAlert
Dim handler As EventHandler

AddHandler instance.Ok, handler
C#
public event EventHandler Ok()
Managed Extensions for C++
public: __event EventHandler* Ok
C++/CLI
public:
event EventHandler^ Ok

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadAlert Class
RadAlert Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadConfirm Class

RadAlert notifies the user according to its invocation parameters

Syntax

Visual Basic (Declaration)
Public Class RadConfirm
   Inherits RadAlert
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadConfirm
C#
public class RadConfirm : RadAlert, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadConfirm : public RadAlert, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadConfirm : public RadAlert, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.RadAlert
Telerik.Windows.Controls.RadConfirm
Telerik.Windows.Controls.RadPrompt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadConfirm Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadConfirm Class

The following tables list the members exposed by RadConfirm.

Public Constructors

 | Name | Description
Public Constructor | RadConfirm Constructor | Default constructor for RadConfirm
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Configure | Overridden. Configures RadConfirm according to the RadWindow specified
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Cancel | Identifier of Cancel
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel (Inherited from RadAlert)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadConfirm Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadConfirm Class : RadConfirm Constructor

Default constructor for RadConfirm

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadConfirm()
C#
public RadConfirm()
Managed Extensions for C++
public: RadConfirm();
C++/CLI
public:
RadConfirm();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadConfirm Class
RadConfirm Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadConfirm Class

For a list of all members of this type, see RadConfirm members.

Public Methods

 | Name | Description
Public Method | Configure | Overridden. Configures RadConfirm according to the RadWindow specified
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

RadConfirm Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Configure Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadConfirm Class : Configure Method

window
RadWindow in which the RadConfirm will appear.
Configures RadConfirm according to the RadWindow specified

Syntax

Visual Basic (Declaration)
Public Overrides Sub Configure( _
   ByVal window As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As RadConfirm
Dim window As RadWindow

instance.Configure(window)
C#
public override void Configure(
   RadWindow window
)
Managed Extensions for C++
public: void Configure(
   RadWindow* window
) override
C++/CLI
public:
void Configure(
   RadWindow^ window
) override

Parameters

window
RadWindow in which the RadConfirm will appear.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadConfirm Class
RadConfirm Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadConfirm Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadConfirm

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadConfirm Class
RadConfirm Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadConfirm Class

For a list of all members of this type, see RadConfirm members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Cancel | Identifier of Cancel
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel (Inherited from RadAlert)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadConfirm Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Cancel Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadConfirm Class : Cancel Event

Identifier of Cancel

Syntax

Visual Basic (Declaration)
Public Event Cancel() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadConfirm
Dim handler As EventHandler

AddHandler instance.Cancel, handler
C#
public event EventHandler Cancel()
Managed Extensions for C++
public: __event EventHandler* Cancel
C++/CLI
public:
event EventHandler^ Cancel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadConfirm Class
RadConfirm Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadCube Class

Navigation control rendered as a Cube

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadCube
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadCube
C#
public class RadCube : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadCube : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadCube : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadCube

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadCube Class

The following tables list the members exposed by RadCube.

Public Constructors

 | Name | Description
Public Constructor | RadCube Constructor | Initializes a new instance of the RadCube class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsRotateOnClickEnabledProperty | Identifies the IsRotateOnClickEnabled dependency property.
static (Shared in Visual Basic) | IsRotateOnStartProperty | Identifies the IsRotateOnStart dependency property.
static (Shared in Visual Basic) | IsRotateXAxisOnlyProperty | Identifies the IsRotateXAxisOnly dependency property.
static (Shared in Visual Basic) | IsRotateYAxisOnlyProperty | Identifies the IsRotateYAxisOnly dependency property.
static (Shared in Visual Basic) | RotateSpeedProperty | Identifies the RotateSpeed dependency property.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex dependency property.
static (Shared in Visual Basic) | Side1BackgroundProperty | Identifies the Side1Background dependency property.
static (Shared in Visual Basic) | Side2BackgroundProperty | Identifies the Side2Background dependency property.
static (Shared in Visual Basic) | Side3BackgroundProperty | Identifies the Side3Background dependency property.
static (Shared in Visual Basic) | Side4BackgroundProperty | Identifies the Side4Background dependency property.
static (Shared in Visual Basic) | Side5BackgroundProperty | Identifies the Side5Background dependency property.
static (Shared in Visual Basic) | Side6BackgroundProperty | Identifies the Side6Background dependency property.
static (Shared in Visual Basic) | XWidthProperty | Identifies the XWidth dependency property.
static (Shared in Visual Basic) | YWidthProperty | Identifies the YWidth dependency property.
static (Shared in Visual Basic) | ZWidthProperty | Identifies the ZWidth dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsRotateOnClickEnabled | Gets or sets the Cube will start to rotate when user click on ots sides.
Public Property | IsRotateOnStart | Gets or sets a value indicating whether the cube should rotate when loaded.
Public Property | IsRotateXAxisOnly | Gets or sets a value indicating whether the cube should rotate on X Axis only.
Public Property | IsRotateYAxisOnly | Gets or sets a value indicating whether the cube should rotate on Y Axis only.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RotateSpeed | Gets or sets the speed of cube rotation.
Public Property | SelectedIndex | Gets or sets the index of the selected side.
Public Property | Side1Background | Gets or sets a side background.
Public Property | Side2Background | Gets or sets a side background.
Public Property | Side3Background | Gets or sets a side background.
Public Property | Side4Background | Gets or sets a side background.
Public Property | Side5Background | Gets or sets a side background.
Public Property | Side6Background | Gets or sets a side background.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | XWidth | Gets or sets the width of the X Axis of the Cube.
Public Property | YWidth | Gets or sets the width of the Y Axis of the Cube.
Public Property | ZWidth | Gets or sets the width of the Z Axis of the Cube.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetCubeFacePanel | Gets the cube face panel that holds the children of the cube side.
Public Method | OnApplyTemplate | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectedIndexChanged |
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectedIndexChanged | Occurs when a side of the cube is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadCube Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : RadCube Constructor

Initializes a new instance of the RadCube class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadCube()
C#
public RadCube()
Managed Extensions for C++
public: RadCube();
C++/CLI
public:
RadCube();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadCube Class

For a list of all members of this type, see RadCube members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetCubeFacePanel | Gets the cube face panel that holds the children of the cube side.
Public Method | OnApplyTemplate | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | IsItemItsOwnContainerOverride | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectedIndexChanged |
Protected Method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl)
Top

See Also

Reference

RadCube Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetCubeFacePanel Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : GetCubeFacePanel Method

faceIndex
Index of the face.
Gets the cube face panel that holds the children of the cube side.

Syntax

Visual Basic (Declaration)
Public Function GetCubeFacePanel( _
   ByVal faceIndex As Integer _
) As Panel
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim faceIndex As Integer
Dim value As Panel

value = instance.GetCubeFacePanel(faceIndex)
C#
public Panel GetCubeFacePanel(
   int faceIndex
)
Managed Extensions for C++
public: Panel* GetCubeFacePanel(
   int faceIndex
)
C++/CLI
public:
Panel^ GetCubeFacePanel(
   int faceIndex
)

Parameters

faceIndex
Index of the face.

Return Value

The cube face panel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : OnApplyTemplate Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadCube

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelectedIndexChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : OnSelectedIndexChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim e As EventArgs

instance.OnSelectedIndexChanged(e)
C#
protected virtual void OnSelectedIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadCube Class

For a list of all members of this type, see RadCube members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsRotateOnClickEnabled | Gets or sets the Cube will start to rotate when user click on ots sides.
Public Property | IsRotateOnStart | Gets or sets a value indicating whether the cube should rotate when loaded.
Public Property | IsRotateXAxisOnly | Gets or sets a value indicating whether the cube should rotate on X Axis only.
Public Property | IsRotateYAxisOnly | Gets or sets a value indicating whether the cube should rotate on Y Axis only.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RotateSpeed | Gets or sets the speed of cube rotation.
Public Property | SelectedIndex | Gets or sets the index of the selected side.
Public Property | Side1Background | Gets or sets a side background.
Public Property | Side2Background | Gets or sets a side background.
Public Property | Side3Background | Gets or sets a side background.
Public Property | Side4Background | Gets or sets a side background.
Public Property | Side5Background | Gets or sets a side background.
Public Property | Side6Background | Gets or sets a side background.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | XWidth | Gets or sets the width of the X Axis of the Cube.
Public Property | YWidth | Gets or sets the width of the Y Axis of the Cube.
Public Property | ZWidth | Gets or sets the width of the Z Axis of the Cube.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadCube Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateOnClickEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateOnClickEnabled Property

Gets or sets the Cube will start to rotate when user click on ots sides.

Syntax

Visual Basic (Declaration)
Public Property IsRotateOnClickEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Boolean

instance.IsRotateOnClickEnabled = value

value = instance.IsRotateOnClickEnabled
C#
public bool IsRotateOnClickEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsRotateOnClickEnabled();
public: __property void set_IsRotateOnClickEnabled(
   bool value
);
C++/CLI
public:
property bool IsRotateOnClickEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateOnStart Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateOnStart Property

Gets or sets a value indicating whether the cube should rotate when loaded.

Syntax

Visual Basic (Declaration)
Public Property IsRotateOnStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Boolean

instance.IsRotateOnStart = value

value = instance.IsRotateOnStart
C#
public bool IsRotateOnStart {get; set;}
Managed Extensions for C++
public: __property bool get_IsRotateOnStart();
public: __property void set_IsRotateOnStart(
   bool value
);
C++/CLI
public:
property bool IsRotateOnStart {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateXAxisOnly Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateXAxisOnly Property

Gets or sets a value indicating whether the cube should rotate on X Axis only.

Syntax

Visual Basic (Declaration)
Public Property IsRotateXAxisOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Boolean

instance.IsRotateXAxisOnly = value

value = instance.IsRotateXAxisOnly
C#
public bool IsRotateXAxisOnly {get; set;}
Managed Extensions for C++
public: __property bool get_IsRotateXAxisOnly();
public: __property void set_IsRotateXAxisOnly(
   bool value
);
C++/CLI
public:
property bool IsRotateXAxisOnly {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateYAxisOnly Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateYAxisOnly Property

Gets or sets a value indicating whether the cube should rotate on Y Axis only.

Syntax

Visual Basic (Declaration)
Public Property IsRotateYAxisOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Boolean

instance.IsRotateYAxisOnly = value

value = instance.IsRotateYAxisOnly
C#
public bool IsRotateYAxisOnly {get; set;}
Managed Extensions for C++
public: __property bool get_IsRotateYAxisOnly();
public: __property void set_IsRotateYAxisOnly(
   bool value
);
C++/CLI
public:
property bool IsRotateYAxisOnly {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RotateSpeed Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : RotateSpeed Property

Gets or sets the speed of cube rotation.

Syntax

Visual Basic (Declaration)
Public Property RotateSpeed As Double
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Double

instance.RotateSpeed = value

value = instance.RotateSpeed
C#
public double RotateSpeed {get; set;}
Managed Extensions for C++
public: __property double get_RotateSpeed();
public: __property void set_RotateSpeed(
   double value
);
C++/CLI
public:
property double RotateSpeed {
   double get();
   void set (double value);
}

Return Value

The speed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedIndex Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : SelectedIndex Property

Gets or sets the index of the selected side.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The index of the selected side.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side1Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side1Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side1Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side1Background = value

value = instance.Side1Background
C#
public Brush Side1Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side1Background();
public: __property void set_Side1Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side1Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side2Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side2Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side2Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side2Background = value

value = instance.Side2Background
C#
public Brush Side2Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side2Background();
public: __property void set_Side2Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side2Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side3Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side3Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side3Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side3Background = value

value = instance.Side3Background
C#
public Brush Side3Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side3Background();
public: __property void set_Side3Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side3Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side4Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side4Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side4Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side4Background = value

value = instance.Side4Background
C#
public Brush Side4Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side4Background();
public: __property void set_Side4Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side4Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side5Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side5Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side5Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side5Background = value

value = instance.Side5Background
C#
public Brush Side5Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side5Background();
public: __property void set_Side5Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side5Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side6Background Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side6Background Property

Gets or sets a side background.

Syntax

Visual Basic (Declaration)
Public Property Side6Background As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Brush

instance.Side6Background = value

value = instance.Side6Background
C#
public Brush Side6Background {get; set;}
Managed Extensions for C++
public: __property Brush* get_Side6Background();
public: __property void set_Side6Background(
   Brush* value
);
C++/CLI
public:
property Brush^ Side6Background {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
XWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : XWidth Property

Gets or sets the width of the X Axis of the Cube.

Syntax

Visual Basic (Declaration)
Public Property XWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Double

instance.XWidth = value

value = instance.XWidth
C#
public double XWidth {get; set;}
Managed Extensions for C++
public: __property double get_XWidth();
public: __property void set_XWidth(
   double value
);
C++/CLI
public:
property double XWidth {
   double get();
   void set (double value);
}

Return Value

The width of the X Axis of the Cube.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
YWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : YWidth Property

Gets or sets the width of the Y Axis of the Cube.

Syntax

Visual Basic (Declaration)
Public Property YWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Double

instance.YWidth = value

value = instance.YWidth
C#
public double YWidth {get; set;}
Managed Extensions for C++
public: __property double get_YWidth();
public: __property void set_YWidth(
   double value
);
C++/CLI
public:
property double YWidth {
   double get();
   void set (double value);
}

Return Value

The width of the Y Axis of the Cube.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ZWidth Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : ZWidth Property

Gets or sets the width of the Z Axis of the Cube.

Syntax

Visual Basic (Declaration)
Public Property ZWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim value As Double

instance.ZWidth = value

value = instance.ZWidth
C#
public double ZWidth {get; set;}
Managed Extensions for C++
public: __property double get_ZWidth();
public: __property void set_ZWidth(
   double value
);
C++/CLI
public:
property double ZWidth {
   double get();
   void set (double value);
}

Return Value

The width of the Z Axis of the Cube.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadCube Class

For a list of all members of this type, see RadCube members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsRotateOnClickEnabledProperty | Identifies the IsRotateOnClickEnabled dependency property.
static (Shared in Visual Basic) | IsRotateOnStartProperty | Identifies the IsRotateOnStart dependency property.
static (Shared in Visual Basic) | IsRotateXAxisOnlyProperty | Identifies the IsRotateXAxisOnly dependency property.
static (Shared in Visual Basic) | IsRotateYAxisOnlyProperty | Identifies the IsRotateYAxisOnly dependency property.
static (Shared in Visual Basic) | RotateSpeedProperty | Identifies the RotateSpeed dependency property.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex dependency property.
static (Shared in Visual Basic) | Side1BackgroundProperty | Identifies the Side1Background dependency property.
static (Shared in Visual Basic) | Side2BackgroundProperty | Identifies the Side2Background dependency property.
static (Shared in Visual Basic) | Side3BackgroundProperty | Identifies the Side3Background dependency property.
static (Shared in Visual Basic) | Side4BackgroundProperty | Identifies the Side4Background dependency property.
static (Shared in Visual Basic) | Side5BackgroundProperty | Identifies the Side5Background dependency property.
static (Shared in Visual Basic) | Side6BackgroundProperty | Identifies the Side6Background dependency property.
static (Shared in Visual Basic) | XWidthProperty | Identifies the XWidth dependency property.
static (Shared in Visual Basic) | YWidthProperty | Identifies the YWidth dependency property.
static (Shared in Visual Basic) | ZWidthProperty | Identifies the ZWidth dependency property.
Top

See Also

Reference

RadCube Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateOnClickEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateOnClickEnabledProperty Field

Identifies the IsRotateOnClickEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRotateOnClickEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.IsRotateOnClickEnabledProperty
C#
public static readonly DependencyProperty IsRotateOnClickEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRotateOnClickEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRotateOnClickEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateOnStartProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateOnStartProperty Field

Identifies the IsRotateOnStart dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRotateOnStartProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.IsRotateOnStartProperty
C#
public static readonly DependencyProperty IsRotateOnStartProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRotateOnStartProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRotateOnStartProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateXAxisOnlyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateXAxisOnlyProperty Field

Identifies the IsRotateXAxisOnly dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRotateXAxisOnlyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.IsRotateXAxisOnlyProperty
C#
public static readonly DependencyProperty IsRotateXAxisOnlyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRotateXAxisOnlyProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRotateXAxisOnlyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRotateYAxisOnlyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : IsRotateYAxisOnlyProperty Field

Identifies the IsRotateYAxisOnly dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRotateYAxisOnlyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.IsRotateYAxisOnlyProperty
C#
public static readonly DependencyProperty IsRotateYAxisOnlyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRotateYAxisOnlyProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRotateYAxisOnlyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RotateSpeedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : RotateSpeedProperty Field

Identifies the RotateSpeed dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RotateSpeedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.RotateSpeedProperty
C#
public static readonly DependencyProperty RotateSpeedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RotateSpeedProperty
C++/CLI
public:
static readonly DependencyProperty^ RotateSpeedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedIndexProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : SelectedIndexProperty Field

Identifies the SelectedIndex dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.SelectedIndexProperty
C#
public static readonly DependencyProperty SelectedIndexProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedIndexProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedIndexProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side1BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side1BackgroundProperty Field

Identifies the Side1Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side1BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side1BackgroundProperty
C#
public static readonly DependencyProperty Side1BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side1BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side1BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side2BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side2BackgroundProperty Field

Identifies the Side2Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side2BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side2BackgroundProperty
C#
public static readonly DependencyProperty Side2BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side2BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side2BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side3BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side3BackgroundProperty Field

Identifies the Side3Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side3BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side3BackgroundProperty
C#
public static readonly DependencyProperty Side3BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side3BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side3BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side4BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side4BackgroundProperty Field

Identifies the Side4Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side4BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side4BackgroundProperty
C#
public static readonly DependencyProperty Side4BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side4BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side4BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side5BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side5BackgroundProperty Field

Identifies the Side5Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side5BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side5BackgroundProperty
C#
public static readonly DependencyProperty Side5BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side5BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side5BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Side6BackgroundProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : Side6BackgroundProperty Field

Identifies the Side6Background dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Side6BackgroundProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.Side6BackgroundProperty
C#
public static readonly DependencyProperty Side6BackgroundProperty
Managed Extensions for C++
public: static readonly DependencyProperty* Side6BackgroundProperty
C++/CLI
public:
static readonly DependencyProperty^ Side6BackgroundProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
XWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : XWidthProperty Field

Identifies the XWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly XWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.XWidthProperty
C#
public static readonly DependencyProperty XWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* XWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ XWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
YWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : YWidthProperty Field

Identifies the YWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly YWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.YWidthProperty
C#
public static readonly DependencyProperty YWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* YWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ YWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ZWidthProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : ZWidthProperty Field

Identifies the ZWidth dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ZWidthProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadCube.ZWidthProperty
C#
public static readonly DependencyProperty ZWidthProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ZWidthProperty
C++/CLI
public:
static readonly DependencyProperty^ ZWidthProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadCube Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadCube Class

For a list of all members of this type, see RadCube members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectedIndexChanged | Occurs when a side of the cube is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadCube Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedIndexChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadCube Class : SelectedIndexChanged Event

Occurs when a side of the cube is selected.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadCube
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
public: __event EventHandler* SelectedIndexChanged
C++/CLI
public:
event EventHandler^ SelectedIndexChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadCube Class
RadCube Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

Represents a Silverlight menu control that enables you to hierarchically organize elements associated event handlers.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RadMenu
   Inherits MenuBase
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadMenu
C#
public class RadMenu : MenuBase, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadMenu : public MenuBase, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadMenu : public MenuBase, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.MenuBase
Telerik.Windows.Controls.RadMenu

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

The following tables list the members exposed by RadMenu.

Public Constructors

 | Name | Description
Public Constructor | RadMenu Constructor | Initializes a new instance of the RadMenu class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ClickToOpen | Gets or sets whether the child group opens upon clikcing a parent item (Inherited from MenuBase)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from MenuBase)
Protected Method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from MenuBase)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnKeyDown | Overridden. Invoked when keyboard key is pressed while the element has focus.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMenu Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : RadMenu Constructor

Initializes a new instance of the RadMenu class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMenu()
C#
public RadMenu()
Managed Extensions for C++
public: RadMenu();
C++/CLI
public:
RadMenu();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

For a list of all members of this type, see RadMenu members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from MenuBase)
Protected Method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from MenuBase)
Protected Method | OnItemsChanged | (Inherited from System.Windows.Controls.ItemsControl)
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnKeyDown | Overridden. Invoked when keyboard key is pressed while the element has focus.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadMenu Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnKeyDown Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : OnKeyDown Method

e
The KeyEventArgs that contains the event data.
Invoked when keyboard key is pressed while the element has focus.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenu
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected override void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
protected: void OnKeyDown(
   KeyEventArgs* e
) override
C++/CLI
protected:
void OnKeyDown(
   KeyEventArgs^ e
) override

Parameters

e
The KeyEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenu
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

For a list of all members of this type, see RadMenu members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | ClickToOpen | Gets or sets whether the child group opens upon clikcing a parent item (Inherited from MenuBase)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Orientation | Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMenu Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Orientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : Orientation Property

Gets or sets a value that specifies the dimension in which child content is arranged. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadMenu
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
public Orientation Orientation {get; set;}
Managed Extensions for C++
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

For a list of all members of this type, see RadMenu members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | OrientationProperty | Identifies the Orientation dependency property.
Top

See Also

Reference

RadMenu Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : OrientationProperty Field

Identifies the Orientation dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenu.OrientationProperty
C#
public static readonly DependencyProperty OrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* OrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ OrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenu Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenu Class

For a list of all members of this type, see RadMenu members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMenu Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PropertyChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenu Class : PropertyChanged Event

Occurs when a property value changes.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenu
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()
Managed Extensions for C++
public: __event PropertyChangedEventHandler* PropertyChanged
C++/CLI
public:
event PropertyChangedEventHandler^ PropertyChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenu Class
RadMenu Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

Represents a selectable item inside a RadMenu.

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="HideIcon", GroupName="CheckStateGroup")>
Public Class RadMenuItem
   Inherits HeaderedItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
C#
[TemplateVisualStateAttribute(Name="HideIcon", GroupName="CheckStateGroup")]
public class RadMenuItem : HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="HideIcon", GroupName="CheckStateGroup")]
public __gc class RadMenuItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="HideIcon", GroupName="CheckStateGroup")]
public ref class RadMenuItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.RadMenuItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

The following tables list the members exposed by RadMenuItem.

Public Constructors

 | Name | Description
Public Constructor | RadMenuItem Constructor | Initializes a new instance of the RadMenuItem class without menu text or a value.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CheckedEvent | Identifies the Checked routed event.
static (Shared in Visual Basic) | ClickEvent | Identifies the Click routed event.
static (Shared in Visual Basic) | HideDelayProperty | Identifies the HideDelay dependency property.
static (Shared in Visual Basic) | IconProperty | Identifies the Icon dependency property.
static (Shared in Visual Basic) | IsCheckableProperty | Identifies the IsCheckable dependency property.
static (Shared in Visual Basic) | IsCheckedProperty | Identifies the IsChecked dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsHighlightedProperty | Identifies the IsHighlighted dependency property.
static (Shared in Visual Basic) | IsSubmenuOpenProperty | Identifies the IsSubmenuOpen dependency property.
static (Shared in Visual Basic) | RoleProperty | Identifies the Role dependency property.
static (Shared in Visual Basic) | ShowDelayProperty | Identifies the ShowDelay dependency property.
static (Shared in Visual Basic) | StaysOpenOnClickProperty | Identifies the StaysOpenOnClick dependency property.
static (Shared in Visual Basic) | SubmenuClosedEvent | Identifies the SubmenuClosed routed event.
static (Shared in Visual Basic) | SubmenuHeaderTemplateKeyProperty | Identifies the SubmenuHeaderTemplateKey dependency property.
static (Shared in Visual Basic) | SubmenuItemTemplateKeyProperty | Identifies the SubmenuItemTemplateKey dependency property.
static (Shared in Visual Basic) | SubmenuOpenedEvent | Identifies the SubmenuOpened routed event.
static (Shared in Visual Basic) | TopLevelHeaderTemplateKeyProperty | Identifies the TopLevelHeaderTemplateKey dependency property.
static (Shared in Visual Basic) | TopLevelItemTemplateKeyProperty | Identifies the TopLevelItemTemplateKey dependency property.
static (Shared in Visual Basic) | UncheckedEvent | Identifies the Unchecked routed event.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideDelay | Gets or sets the time, in milliseconds, before closing menu when the mouse cursor leave a submenu item.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Icon | Gets or sets the icon that appears in a RadMenuItem. This is a dependency property.
Public Property | IsCheckable | Gets a value that indicates whether a RadMenuItem can be checked. This is a dependency property.
Public Property | IsChecked | Gets or sets a value that indicates whether the RadMenuItem is checked. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property.
Public Property | IsHighlighted | Gets a value that indicates whether a RadMenuItem is highlighted. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSubmenuOpen | Gets or sets a value that indicates whether the submenu of the RadMenuItem is open. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Role | Gets a value that indicates the role of a RadMenuItem. This is a dependency property.
Public Property | ShowDelay | Gets or sets the time, in milliseconds, before displaying menu when the mouse cursor is over a submenu item.
Public Property | StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | SubmenuHeaderTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a submenu.
Public Property | SubmenuItemTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a submenu.
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopLevelHeaderTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a top-level menu.
Public Property | TopLevelItemTemplateKey | Gets the resource key for a style applied to a RadMenuItem when it is a top-level RadMenuItem.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnChecked | Called when the IsChecked property becomes true.
Protected Method | OnClick | Called when a RadMenuItem is clicked and raises a Click event.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSubmenuClosed | Called when the submenu of a RadMenuItem is closed.
Protected Method | OnSubmenuOpened | Called when the submenu of a MenuItem is opened.
Protected Method | OnUnchecked | Called when the IsChecked property becomes false.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when a RadMenuItem is checked.
Public Event | Click | Occurs when a RadMenuItem is clicked.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false.
Public Event | SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true.
Public Event | Unchecked | Occurs when a RadMenuItem is unchecked.
Top

See Also

Reference

RadMenuItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : RadMenuItem Constructor

Initializes a new instance of the RadMenuItem class without menu text or a value.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem()
C#
public RadMenuItem()
Managed Extensions for C++
public: RadMenuItem();
C++/CLI
public:
RadMenuItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

For a list of all members of this type, see RadMenuItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl)
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnChecked | Called when the IsChecked property becomes true.
Protected Method | OnClick | Called when a RadMenuItem is clicked and raises a Click event.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSubmenuClosed | Called when the submenu of a RadMenuItem is closed.
Protected Method | OnSubmenuOpened | Called when the submenu of a MenuItem is opened.
Protected Method | OnUnchecked | Called when the IsChecked property becomes false.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadMenuItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnChecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnChecked Method

e
The event data for the Checked event.
Called when the IsChecked property becomes true.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnChecked( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim e As RadRoutedEventArgs

instance.OnChecked(e)
C#
protected virtual void OnChecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnChecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnChecked(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data for the Checked event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnClick Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnClick Method

Called when a RadMenuItem is clicked and raises a Click event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClick()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem

instance.OnClick()
C#
protected virtual void OnClick()
Managed Extensions for C++
protected: virtual void OnClick();
C++/CLI
protected:
virtual void OnClick();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnItemsChanged Method

e
Information about the change.
Invoked when the Items property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Information about the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSubmenuClosed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnSubmenuClosed Method

e
The event data for the SubmenuClosed event.
Called when the submenu of a RadMenuItem is closed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSubmenuClosed( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim e As RadRoutedEventArgs

instance.OnSubmenuClosed(e)
C#
protected virtual void OnSubmenuClosed(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSubmenuClosed(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnSubmenuClosed(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data for the SubmenuClosed event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSubmenuOpened Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnSubmenuOpened Method

e
The event data for the SubmenuOpened event.
Called when the submenu of a MenuItem is opened.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSubmenuOpened( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim e As RadRoutedEventArgs

instance.OnSubmenuOpened(e)
C#
protected virtual void OnSubmenuOpened(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSubmenuOpened(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnSubmenuOpened(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data for the SubmenuOpened event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnUnchecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : OnUnchecked Method

e
The event data for the Unchecked event.
Called when the IsChecked property becomes false.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUnchecked( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim e As RadRoutedEventArgs

instance.OnUnchecked(e)
C#
protected virtual void OnUnchecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUnchecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnUnchecked(
   RadRoutedEventArgs^ e
)

Parameters

e
The event data for the Unchecked event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

For a list of all members of this type, see RadMenuItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideDelay | Gets or sets the time, in milliseconds, before closing menu when the mouse cursor leave a submenu item.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Icon | Gets or sets the icon that appears in a RadMenuItem. This is a dependency property.
Public Property | IsCheckable | Gets a value that indicates whether a RadMenuItem can be checked. This is a dependency property.
Public Property | IsChecked | Gets or sets a value that indicates whether the RadMenuItem is checked. This is a dependency property.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property.
Public Property | IsHighlighted | Gets a value that indicates whether a RadMenuItem is highlighted. This is a dependency property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsSubmenuOpen | Gets or sets a value that indicates whether the submenu of the RadMenuItem is open. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Role | Gets a value that indicates the role of a RadMenuItem. This is a dependency property.
Public Property | ShowDelay | Gets or sets the time, in milliseconds, before displaying menu when the mouse cursor is over a submenu item.
Public Property | StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | SubmenuHeaderTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a submenu.
Public Property | SubmenuItemTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a submenu.
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopLevelHeaderTemplateKey | Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a top-level menu.
Public Property | TopLevelItemTemplateKey | Gets the resource key for a style applied to a RadMenuItem when it is a top-level RadMenuItem.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMenuItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HideDelay Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : HideDelay Property

Gets or sets the time, in milliseconds, before closing menu when the mouse cursor leave a submenu item.

Syntax

Visual Basic (Declaration)
Public Property HideDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Integer

instance.HideDelay = value

value = instance.HideDelay
C#
public int HideDelay {get; set;}
Managed Extensions for C++
public: __property int get_HideDelay();
public: __property void set_HideDelay(
   int value
);
C++/CLI
public:
property int HideDelay {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Icon Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : Icon Property

Gets or sets the icon that appears in a RadMenuItem. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property Icon As Object
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Object

instance.Icon = value

value = instance.Icon
C#
[SRCategoryAttribute("Appearance")]
public object Icon {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Object* get_Icon();
public: __property void set_Icon(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Object^ Icon {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCheckable Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsCheckable Property

Gets a value that indicates whether a RadMenuItem can be checked. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Property IsCheckable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

instance.IsCheckable = value

value = instance.IsCheckable
C#
[SRCategoryAttribute("Behavior")]
public bool IsCheckable {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __property bool get_IsCheckable();
public: __property void set_IsCheckable(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
property bool IsCheckable {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsChecked Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsChecked Property

Gets or sets a value that indicates whether the RadMenuItem is checked. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property IsChecked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

instance.IsChecked = value

value = instance.IsChecked
C#
[SRCategoryAttribute("Appearance")]
public bool IsChecked {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property bool get_IsChecked();
public: __property void set_IsChecked(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property bool IsChecked {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsEnabled Property

Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[SRCategoryAttribute("Behavior")]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsHighlighted Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsHighlighted Property

Gets a value that indicates whether a RadMenuItem is highlighted. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(False)>
Public ReadOnly Property IsHighlighted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

value = instance.IsHighlighted
C#
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public bool IsHighlighted {get;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public: __property bool get_IsHighlighted();
C++/CLI
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public:
property bool IsHighlighted {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSubmenuOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsSubmenuOpen Property

Gets or sets a value that indicates whether the submenu of the RadMenuItem is open. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(False)>
Public ReadOnly Property IsSubmenuOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

value = instance.IsSubmenuOpen
C#
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public bool IsSubmenuOpen {get;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public: __property bool get_IsSubmenuOpen();
C++/CLI
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
public:
property bool IsSubmenuOpen {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Role Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : Role Property

Gets a value that indicates the role of a RadMenuItem. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public ReadOnly Property Role As MenuItemRole
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As MenuItemRole

value = instance.Role
C#
[SRCategoryAttribute("Behavior")]
public MenuItemRole Role {get;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __property MenuItemRole get_Role();
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
property MenuItemRole Role {
   MenuItemRole get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ShowDelay Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : ShowDelay Property

Gets or sets the time, in milliseconds, before displaying menu when the mouse cursor is over a submenu item.

Syntax

Visual Basic (Declaration)
Public Property ShowDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Integer

instance.ShowDelay = value

value = instance.ShowDelay
C#
public int ShowDelay {get; set;}
Managed Extensions for C++
public: __property int get_ShowDelay();
public: __property void set_ShowDelay(
   int value
);
C++/CLI
public:
property int ShowDelay {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
StaysOpenOnClick Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : StaysOpenOnClick Property

Gets or sets a value that indicates that the submenu in which this RadMenuItem is located should not close when this item is clicked. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Property StaysOpenOnClick As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As Boolean

instance.StaysOpenOnClick = value

value = instance.StaysOpenOnClick
C#
[SRCategoryAttribute("Behavior")]
public bool StaysOpenOnClick {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __property bool get_StaysOpenOnClick();
public: __property void set_StaysOpenOnClick(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
property bool StaysOpenOnClick {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuHeaderTemplateKey Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuHeaderTemplateKey Property

Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a submenu.

Syntax

Visual Basic (Declaration)
Public Property SubmenuHeaderTemplateKey As String
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As String

instance.SubmenuHeaderTemplateKey = value

value = instance.SubmenuHeaderTemplateKey
C#
public string SubmenuHeaderTemplateKey {get; set;}
Managed Extensions for C++
public: __property string* get_SubmenuHeaderTemplateKey();
public: __property void set_SubmenuHeaderTemplateKey(
   string* value
);
C++/CLI
public:
property String^ SubmenuHeaderTemplateKey {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuItemTemplateKey Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuItemTemplateKey Property

Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a submenu.

Syntax

Visual Basic (Declaration)
Public Property SubmenuItemTemplateKey As String
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As String

instance.SubmenuItemTemplateKey = value

value = instance.SubmenuItemTemplateKey
C#
public string SubmenuItemTemplateKey {get; set;}
Managed Extensions for C++
public: __property string* get_SubmenuItemTemplateKey();
public: __property void set_SubmenuItemTemplateKey(
   string* value
);
C++/CLI
public:
property String^ SubmenuItemTemplateKey {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopLevelHeaderTemplateKey Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : TopLevelHeaderTemplateKey Property

Gets the resource key for a style applied to a RadMenuItem when the RadMenuItem is a header of a top-level menu.

Syntax

Visual Basic (Declaration)
Public Property TopLevelHeaderTemplateKey As String
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As String

instance.TopLevelHeaderTemplateKey = value

value = instance.TopLevelHeaderTemplateKey
C#
public string TopLevelHeaderTemplateKey {get; set;}
Managed Extensions for C++
public: __property string* get_TopLevelHeaderTemplateKey();
public: __property void set_TopLevelHeaderTemplateKey(
   string* value
);
C++/CLI
public:
property String^ TopLevelHeaderTemplateKey {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopLevelItemTemplateKey Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : TopLevelItemTemplateKey Property

Gets the resource key for a style applied to a RadMenuItem when it is a top-level RadMenuItem.

Syntax

Visual Basic (Declaration)
Public Property TopLevelItemTemplateKey As String
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim value As String

instance.TopLevelItemTemplateKey = value

value = instance.TopLevelItemTemplateKey
C#
public string TopLevelItemTemplateKey {get; set;}
Managed Extensions for C++
public: __property string* get_TopLevelItemTemplateKey();
public: __property void set_TopLevelItemTemplateKey(
   string* value
);
C++/CLI
public:
property String^ TopLevelItemTemplateKey {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

For a list of all members of this type, see RadMenuItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CheckedEvent | Identifies the Checked routed event.
static (Shared in Visual Basic) | ClickEvent | Identifies the Click routed event.
static (Shared in Visual Basic) | HideDelayProperty | Identifies the HideDelay dependency property.
static (Shared in Visual Basic) | IconProperty | Identifies the Icon dependency property.
static (Shared in Visual Basic) | IsCheckableProperty | Identifies the IsCheckable dependency property.
static (Shared in Visual Basic) | IsCheckedProperty | Identifies the IsChecked dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsHighlightedProperty | Identifies the IsHighlighted dependency property.
static (Shared in Visual Basic) | IsSubmenuOpenProperty | Identifies the IsSubmenuOpen dependency property.
static (Shared in Visual Basic) | RoleProperty | Identifies the Role dependency property.
static (Shared in Visual Basic) | ShowDelayProperty | Identifies the ShowDelay dependency property.
static (Shared in Visual Basic) | StaysOpenOnClickProperty | Identifies the StaysOpenOnClick dependency property.
static (Shared in Visual Basic) | SubmenuClosedEvent | Identifies the SubmenuClosed routed event.
static (Shared in Visual Basic) | SubmenuHeaderTemplateKeyProperty | Identifies the SubmenuHeaderTemplateKey dependency property.
static (Shared in Visual Basic) | SubmenuItemTemplateKeyProperty | Identifies the SubmenuItemTemplateKey dependency property.
static (Shared in Visual Basic) | SubmenuOpenedEvent | Identifies the SubmenuOpened routed event.
static (Shared in Visual Basic) | TopLevelHeaderTemplateKeyProperty | Identifies the TopLevelHeaderTemplateKey dependency property.
static (Shared in Visual Basic) | TopLevelItemTemplateKeyProperty | Identifies the TopLevelItemTemplateKey dependency property.
static (Shared in Visual Basic) | UncheckedEvent | Identifies the Unchecked routed event.
Top

See Also

Reference

RadMenuItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : CheckedEvent Field

Identifies the Checked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMenuItem.CheckedEvent
C#
public static readonly RoutedEvent CheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* CheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ CheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClickEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : ClickEvent Field

Identifies the Click routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ClickEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMenuItem.ClickEvent
C#
public static readonly RoutedEvent ClickEvent
Managed Extensions for C++
public: static readonly RoutedEvent* ClickEvent
C++/CLI
public:
static readonly RoutedEvent^ ClickEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HideDelayProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : HideDelayProperty Field

Identifies the HideDelay dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HideDelayProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.HideDelayProperty
C#
public static readonly DependencyProperty HideDelayProperty
Managed Extensions for C++
public: static readonly DependencyProperty* HideDelayProperty
C++/CLI
public:
static readonly DependencyProperty^ HideDelayProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IconProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IconProperty Field

Identifies the Icon dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IconProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IconProperty
C#
public static readonly DependencyProperty IconProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IconProperty
C++/CLI
public:
static readonly DependencyProperty^ IconProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCheckableProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsCheckableProperty Field

Identifies the IsCheckable dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsCheckableProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IsCheckableProperty
C#
public static readonly DependencyProperty IsCheckableProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsCheckableProperty
C++/CLI
public:
static readonly DependencyProperty^ IsCheckableProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCheckedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsCheckedProperty Field

Identifies the IsChecked dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsCheckedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IsCheckedProperty
C#
public static readonly DependencyProperty IsCheckedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsCheckedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsCheckedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsHighlightedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsHighlightedProperty Field

Identifies the IsHighlighted dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IsHighlightedProperty
C#
public static readonly DependencyProperty IsHighlightedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsHighlightedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsHighlightedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSubmenuOpenProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : IsSubmenuOpenProperty Field

Identifies the IsSubmenuOpen dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSubmenuOpenProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.IsSubmenuOpenProperty
C#
public static readonly DependencyProperty IsSubmenuOpenProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSubmenuOpenProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSubmenuOpenProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RoleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : RoleProperty Field

Identifies the Role dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RoleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.RoleProperty
C#
public static readonly DependencyProperty RoleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RoleProperty
C++/CLI
public:
static readonly DependencyProperty^ RoleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ShowDelayProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : ShowDelayProperty Field

Identifies the ShowDelay dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ShowDelayProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.ShowDelayProperty
C#
public static readonly DependencyProperty ShowDelayProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ShowDelayProperty
C++/CLI
public:
static readonly DependencyProperty^ ShowDelayProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
StaysOpenOnClickProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : StaysOpenOnClickProperty Field

Identifies the StaysOpenOnClick dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StaysOpenOnClickProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.StaysOpenOnClickProperty
C#
public static readonly DependencyProperty StaysOpenOnClickProperty
Managed Extensions for C++
public: static readonly DependencyProperty* StaysOpenOnClickProperty
C++/CLI
public:
static readonly DependencyProperty^ StaysOpenOnClickProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuClosedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuClosedEvent Field

Identifies the SubmenuClosed routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SubmenuClosedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMenuItem.SubmenuClosedEvent
C#
public static readonly RoutedEvent SubmenuClosedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SubmenuClosedEvent
C++/CLI
public:
static readonly RoutedEvent^ SubmenuClosedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuHeaderTemplateKeyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuHeaderTemplateKeyProperty Field

Identifies the SubmenuHeaderTemplateKey dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SubmenuHeaderTemplateKeyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.SubmenuHeaderTemplateKeyProperty
C#
public static readonly DependencyProperty SubmenuHeaderTemplateKeyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SubmenuHeaderTemplateKeyProperty
C++/CLI
public:
static readonly DependencyProperty^ SubmenuHeaderTemplateKeyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuItemTemplateKeyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuItemTemplateKeyProperty Field

Identifies the SubmenuItemTemplateKey dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SubmenuItemTemplateKeyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.SubmenuItemTemplateKeyProperty
C#
public static readonly DependencyProperty SubmenuItemTemplateKeyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SubmenuItemTemplateKeyProperty
C++/CLI
public:
static readonly DependencyProperty^ SubmenuItemTemplateKeyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuOpenedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuOpenedEvent Field

Identifies the SubmenuOpened routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SubmenuOpenedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMenuItem.SubmenuOpenedEvent
C#
public static readonly RoutedEvent SubmenuOpenedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SubmenuOpenedEvent
C++/CLI
public:
static readonly RoutedEvent^ SubmenuOpenedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopLevelHeaderTemplateKeyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : TopLevelHeaderTemplateKeyProperty Field

Identifies the TopLevelHeaderTemplateKey dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopLevelHeaderTemplateKeyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.TopLevelHeaderTemplateKeyProperty
C#
public static readonly DependencyProperty TopLevelHeaderTemplateKeyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopLevelHeaderTemplateKeyProperty
C++/CLI
public:
static readonly DependencyProperty^ TopLevelHeaderTemplateKeyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopLevelItemTemplateKeyProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : TopLevelItemTemplateKeyProperty Field

Identifies the TopLevelItemTemplateKey dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopLevelItemTemplateKeyProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadMenuItem.TopLevelItemTemplateKeyProperty
C#
public static readonly DependencyProperty TopLevelItemTemplateKeyProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopLevelItemTemplateKeyProperty
C++/CLI
public:
static readonly DependencyProperty^ TopLevelItemTemplateKeyProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
UncheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : UncheckedEvent Field

Identifies the Unchecked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UncheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadMenuItem.UncheckedEvent
C#
public static readonly RoutedEvent UncheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* UncheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ UncheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadMenuItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadMenuItem Class

For a list of all members of this type, see RadMenuItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when a RadMenuItem is checked.
Public Event | Click | Occurs when a RadMenuItem is clicked.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false.
Public Event | SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true.
Public Event | Unchecked | Occurs when a RadMenuItem is unchecked.
Top

See Also

Reference

RadMenuItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Checked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : Checked Event

Occurs when a RadMenuItem is checked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Checked() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim handler As RoutedEventHandler

AddHandler instance.Checked, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler Checked()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* Checked
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ Checked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Click Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : Click Event

Occurs when a RadMenuItem is clicked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Click() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim handler As RoutedEventHandler

AddHandler instance.Click, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler Click()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* Click
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ Click

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuClosed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuClosed Event

Occurs when the state of the IsSubmenuOpen property changes to false.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event SubmenuClosed() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim handler As RoutedEventHandler

AddHandler instance.SubmenuClosed, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler SubmenuClosed()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* SubmenuClosed
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ SubmenuClosed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SubmenuOpened Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : SubmenuOpened Event

Occurs when the state of the IsSubmenuOpen property changes to true.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event SubmenuOpened() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim handler As RoutedEventHandler

AddHandler instance.SubmenuOpened, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler SubmenuOpened()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* SubmenuOpened
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ SubmenuOpened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Unchecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadMenuItem Class : Unchecked Event

Occurs when a RadMenuItem is unchecked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Unchecked() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItem
Dim handler As RoutedEventHandler

AddHandler instance.Unchecked, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler Unchecked()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* Unchecked
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ Unchecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadMenuItem Class
RadMenuItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

RadPanelBar is a UI control that constitues a collection of RadPanelBarItem. This control is capable of displaying flat as well as hierarchical data by nesting RadPanelBarItems when necessary.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultPropertyAttribute("ExpandMode")>
<DefaultEventAttribute("Selected")>
Public Class RadPanelBar
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
C#
[DefaultPropertyAttribute("ExpandMode")]
[DefaultEventAttribute("Selected")]
public class RadPanelBar : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[DefaultPropertyAttribute("ExpandMode")]
[DefaultEventAttribute("Selected")]
public __gc class RadPanelBar : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[DefaultPropertyAttribute("ExpandMode")]
[DefaultEventAttribute("Selected")]
public ref class RadPanelBar : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadPanelBar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

The following tables list the members exposed by RadPanelBar.

Public Constructors

 | Name | Description
Public Constructor | RadPanelBar Constructor | Initializes a new instance of the RadPanelBar class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ExpandModeProperty | Identifies the ExpandMode dependency property.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem dependency property.
static (Shared in Visual Basic) | SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
static (Shared in Visual Basic) | SelectedValueProperty | Identifies the SelectedValue dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpandMode | Gets or sets the expand mode.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedItem | Gets or sets the selected item.
Public Property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by SelectedValuePath.
Public Property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | HasSelectedItem | Determines whether a RadPanelBar has a selected item.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Collapsed | Occurs when a RadPanelBarItem within a RadPanelBar is collapsed.
Public Event | Expanded | Occurs when a RadPanelBarItem within a RadPanelBar is expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewCollapsed | Occurs before a RadPanelBarItem within a RadPanelBar is collapsed.
Public Event | PreviewExpanded | Occurs before a RadPanelBarItem within a RadPanelBar is expanded.
Public Event | Selected | Occurs when a RadPanelBarItem within a RadPanelBar is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPanelBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : RadPanelBar Constructor

Initializes a new instance of the RadPanelBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar()
C#
public RadPanelBar()
Managed Extensions for C++
public: RadPanelBar();
C++/CLI
public:
RadPanelBar();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

For a list of all members of this type, see RadPanelBar members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | HasSelectedItem | Determines whether a RadPanelBar has a selected item.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadPanelBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : ClearContainerForItemOverride Method

element
The container element.
item
The Item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The Item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HasSelectedItem Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : HasSelectedItem Method

Determines whether a RadPanelBar has a selected item.

Syntax

Visual Basic (Declaration)
Public Function HasSelectedItem() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As Boolean

value = instance.HasSelectedItem()
C#
public bool HasSelectedItem()
Managed Extensions for C++
public: bool HasSelectedItem();
C++/CLI
public:
bool HasSelectedItem();

Return Value

true if the RadPanelBar has a selected item; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : OnItemsChanged Method

e
Information about the change.
Invoked when the Items property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Information about the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

For a list of all members of this type, see RadPanelBar members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpandMode | Gets or sets the expand mode.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SelectedItem | Gets or sets the selected item.
Public Property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by SelectedValuePath.
Public Property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadPanelBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : ExpandMode Property

Gets or sets the expand mode.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Identifies the ExpandMode dependency property.")>
<DefaultValueAttribute()>
Public Property ExpandMode As ExpandMode
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As ExpandMode

instance.ExpandMode = value

value = instance.ExpandMode
C#
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Identifies the ExpandMode dependency property.")]
[DefaultValueAttribute()]
public ExpandMode ExpandMode {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Identifies the ExpandMode dependency property.")]
[DefaultValueAttribute()]
public: __property ExpandMode get_ExpandMode();
public: __property void set_ExpandMode(
   ExpandMode value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Identifies the ExpandMode dependency property.")]
[DefaultValueAttribute()]
public:
property ExpandMode ExpandMode {
   ExpandMode get();
   void set (ExpandMode value);
}

Return Value

The expand mode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedItem Property

Gets or sets the selected item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[BrowsableAttribute(false)]
public object SelectedItem {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^ value);
}

Return Value

The selected item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValue Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedValue Property

Gets or sets the value of the SelectedItem, obtained by SelectedValuePath.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As Object

value = instance.SelectedValue
C#
[BrowsableAttribute(false)]
public object SelectedValue {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_SelectedValue();
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ SelectedValue {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValuePath Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedValuePath Property

Gets or sets the path that is used to get the SelectedValue from the SelectedItem

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Identifies the SelectedValuePath dependency property.")>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
Public Property SelectedValuePath As String
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim value As String

instance.SelectedValuePath = value

value = instance.SelectedValuePath
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the SelectedValuePath dependency property.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public string SelectedValuePath {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the SelectedValuePath dependency property.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public: __property string* get_SelectedValuePath();
public: __property void set_SelectedValuePath(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the SelectedValuePath dependency property.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public:
property String^ SelectedValuePath {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

For a list of all members of this type, see RadPanelBar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ExpandModeProperty | Identifies the ExpandMode dependency property.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem dependency property.
static (Shared in Visual Basic) | SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
static (Shared in Visual Basic) | SelectedValueProperty | Identifies the SelectedValue dependency property.
Top

See Also

Reference

RadPanelBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : ExpandModeProperty Field

Identifies the ExpandMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpandModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBar.ExpandModeProperty
C#
public static readonly DependencyProperty ExpandModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ExpandModeProperty
C++/CLI
public:
static readonly DependencyProperty^ ExpandModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItemProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedItemProperty Field

Identifies the SelectedItem dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBar.SelectedItemProperty
C#
public static readonly DependencyProperty SelectedItemProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedItemProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedItemProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValuePathProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedValuePathProperty Field

Identifies the SelectedValuePath dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedValuePathProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBar.SelectedValuePathProperty
C#
public static readonly DependencyProperty SelectedValuePathProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedValuePathProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedValuePathProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValueProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : SelectedValueProperty Field

Identifies the SelectedValue dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedValueProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBar.SelectedValueProperty
C#
public static readonly DependencyProperty SelectedValueProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedValueProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedValueProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBar Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBar Class

For a list of all members of this type, see RadPanelBar members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Collapsed | Occurs when a RadPanelBarItem within a RadPanelBar is collapsed.
Public Event | Expanded | Occurs when a RadPanelBarItem within a RadPanelBar is expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewCollapsed | Occurs before a RadPanelBarItem within a RadPanelBar is collapsed.
Public Event | PreviewExpanded | Occurs before a RadPanelBarItem within a RadPanelBar is expanded.
Public Event | Selected | Occurs when a RadPanelBarItem within a RadPanelBar is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPanelBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Collapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : Collapsed Event

Occurs when a RadPanelBarItem within a RadPanelBar is collapsed.

Syntax

Visual Basic (Declaration)
Public Event Collapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Collapsed, handler
C#
public event EventHandler<RadRoutedEventArgs> Collapsed()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Collapsed
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Collapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Expanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : Expanded Event

Occurs when a RadPanelBarItem within a RadPanelBar is expanded.

Syntax

Visual Basic (Declaration)
Public Event Expanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Expanded, handler
C#
public event EventHandler<RadRoutedEventArgs> Expanded()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Expanded
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Expanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : PreviewCollapsed Event

Occurs before a RadPanelBarItem within a RadPanelBar is collapsed.

Syntax

Visual Basic (Declaration)
Public Event PreviewCollapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewCollapsed, handler
C#
public event EventHandler<RadRoutedEventArgs> PreviewCollapsed()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* PreviewCollapsed
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewCollapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : PreviewExpanded Event

Occurs before a RadPanelBarItem within a RadPanelBar is expanded.

Syntax

Visual Basic (Declaration)
Public Event PreviewExpanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewExpanded, handler
C#
public event EventHandler<RadRoutedEventArgs> PreviewExpanded()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* PreviewExpanded
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewExpanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Selected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBar Class : Selected Event

Occurs when a RadPanelBarItem within a RadPanelBar is selected.

Syntax

Visual Basic (Declaration)
Public Event Selected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBar
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Selected, handler
C#
public event EventHandler<RadRoutedEventArgs> Selected()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Selected
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Selected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBar Class
RadPanelBar Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

Implements a selectable item in a RadPanelBar control.

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="Focused", GroupName="FocusStates")>
<DefaultPropertyAttribute("Header")>
<DefaultEventAttribute("Selected")>
<TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)>
Public Class RadPanelBarItem
   Inherits HeaderedItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
C#
[TemplateVisualStateAttribute(Name="Focused", GroupName="FocusStates")]
[DefaultPropertyAttribute("Header")]
[DefaultEventAttribute("Selected")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
public class RadPanelBarItem : HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="Focused", GroupName="FocusStates")]
[DefaultPropertyAttribute("Header")]
[DefaultEventAttribute("Selected")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
public __gc class RadPanelBarItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="Focused", GroupName="FocusStates")]
[DefaultPropertyAttribute("Header")]
[DefaultEventAttribute("Selected")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
public ref class RadPanelBarItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.RadPanelBarItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

The following tables list the members exposed by RadPanelBarItem.

Public Constructors

 | Name | Description
Public Constructor | RadPanelBarItem Constructor | Initializes a new instance of the RadPanelBarItem class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CollapsedEvent | Identifies the Collapsed routed event.
static (Shared in Visual Basic) | ExpandedEvent | Identifies the Expanded routed event.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandedProperty | Identifies the IsExpanded dependency property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | LevelProperty | Identifies the Level dependency property.
static (Shared in Visual Basic) | PreviewCollapsedEvent | Identifies the PreviewCollapsed routed event.
static (Shared in Visual Basic) | PreviewExpandedEvent | Identifies the PreviewExpanded routed event.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether this instance is enabled.
Public Property | IsExpanded | Gets or sets a value indicating whether this instance is expanded.
Public Property | IsFocused | Gets or sets a value indicating whether this instance is focused.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets or sets a value indicating whether the mouse cursor is over the current instance.
Public Property | IsSelected | Gets or sets a value indicating whether this instance is selected.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Gets the value of the current instance.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Level | Gets or sets the Level property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SecondLevelTemplate | Gets or sets the second level template.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopLevelTemplate | Gets or sets the top level template.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
static (Shared in Visual Basic) | OnIsExpandedChanged | Called when the IsExpanded property is changed.
static (Shared in Visual Basic) | OnIsSelectedChanged | Called when the IsSelected property is changed.
Public Method | ToString | Overridden. Return item text value
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnCollapsed | Raises the E:Collapsed event.
Protected Method | OnExpanded | Raises the E:Expanded event.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnPreviewCollapsed | Raises the E:PreviewCollapsed event.
Protected Method | OnPreviewExpanded | Raises the E:PreviewExpanded event.
Protected Method | OnSelected | Raises the E:Selected event.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Collapsed | Occurs when a RadPanelBarItem is collapsed.
Public Event | Expanded | Occurs when a RadPanelBarItem is expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewCollapsed | Occurs before a RadPanelBarItem is collapsed.
Public Event | PreviewExpanded | Occurs before a RadPanelBarItem is expanded.
Public Event | Selected | Occurs when a RadPanelBarItem is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPanelBarItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : RadPanelBarItem Constructor

Initializes a new instance of the RadPanelBarItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem()
C#
public RadPanelBarItem()
Managed Extensions for C++
public: RadPanelBarItem();
C++/CLI
public:
RadPanelBarItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

For a list of all members of this type, see RadPanelBarItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
static (Shared in Visual Basic) | OnIsExpandedChanged | Called when the IsExpanded property is changed.
static (Shared in Visual Basic) | OnIsSelectedChanged | Called when the IsSelected property is changed.
Public Method | ToString | Overridden. Return item text value
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | OnCollapsed | Raises the E:Collapsed event.
Protected Method | OnExpanded | Raises the E:Expanded event.
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnPreviewCollapsed | Raises the E:PreviewCollapsed event.
Protected Method | OnPreviewExpanded | Raises the E:PreviewExpanded event.
Protected Method | OnSelected | Raises the E:Selected event.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadPanelBarItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : ClearContainerForItemOverride Method

element
The container element.
item
The Item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The Item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnCollapsed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnCollapsed Method

e
The RadRoutedEventArgs instance containing the event data.
Raises the E:Collapsed event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollapsed( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As RadRoutedEventArgs

instance.OnCollapsed(e)
C#
protected virtual void OnCollapsed(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCollapsed(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnCollapsed(
   RadRoutedEventArgs^ e
)

Parameters

e
The RadRoutedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnExpanded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnExpanded Method

e
The RadRoutedEventArgs instance containing the event data.
Raises the E:Expanded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnExpanded( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As RadRoutedEventArgs

instance.OnExpanded(e)
C#
protected virtual void OnExpanded(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnExpanded(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnExpanded(
   RadRoutedEventArgs^ e
)

Parameters

e
The RadRoutedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnIsExpandedChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnIsExpandedChanged Method

d
The DependencyObject instance representing the RadPanelBarItem whose property was changed.
e
The DependencyPropertyChangedEventArgs instance containing the event data.
Called when the IsExpanded property is changed.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="e",
   Justification="")>
Public Shared Sub OnIsExpandedChanged( _
   ByVal d As DependencyObject, _
   ByVal e As DependencyPropertyChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim d As DependencyObject
Dim e As DependencyPropertyChangedEventArgs

RadPanelBarItem.OnIsExpandedChanged(d, e)
C#
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="e",
   Justification="")]
public static void OnIsExpandedChanged(
   DependencyObject d,
   DependencyPropertyChangedEventArgs e
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="e",
   Justification="")]
public: static void OnIsExpandedChanged(
   DependencyObject* d,
   DependencyPropertyChangedEventArgs e
)
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="e",
   Justification="")]
public:
static void OnIsExpandedChanged(
   DependencyObject^ d,
   DependencyPropertyChangedEventArgs e
)

Parameters

d
The DependencyObject instance representing the RadPanelBarItem whose property was changed.
e
The DependencyPropertyChangedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnIsSelectedChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnIsSelectedChanged Method

d
The DependencyObject instance representing the RadPanelBarItem whose property was changed.
e
The DependencyPropertyChangedEventArgs instance containing the event data.
Called when the IsSelected property is changed.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="d",
   Justification="")>
Public Shared Sub OnIsSelectedChanged( _
   ByVal d As DependencyObject, _
   ByVal e As DependencyPropertyChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim d As DependencyObject
Dim e As DependencyPropertyChangedEventArgs

RadPanelBarItem.OnIsSelectedChanged(d, e)
C#
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="d",
   Justification="")]
public static void OnIsSelectedChanged(
   DependencyObject d,
   DependencyPropertyChangedEventArgs e
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="d",
   Justification="")]
public: static void OnIsSelectedChanged(
   DependencyObject* d,
   DependencyPropertyChangedEventArgs e
)
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Naming",
   CheckId="CA1704:IdentifiersShouldBeSpelledCorrectly",
   Scope="",
   Target="",
   MessageId="d",
   Justification="")]
public:
static void OnIsSelectedChanged(
   DependencyObject^ d,
   DependencyPropertyChangedEventArgs e
)

Parameters

d
The DependencyObject instance representing the RadPanelBarItem whose property was changed.
e
The DependencyPropertyChangedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnItemsChanged Method

e
Information about the change.
Invoked when the Items property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Information about the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewCollapsed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnPreviewCollapsed Method

e
The RadRoutedEventArgs instance containing the event data.
Raises the E:PreviewCollapsed event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPreviewCollapsed( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As RadRoutedEventArgs

instance.OnPreviewCollapsed(e)
C#
protected virtual void OnPreviewCollapsed(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnPreviewCollapsed(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnPreviewCollapsed(
   RadRoutedEventArgs^ e
)

Parameters

e
The RadRoutedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewExpanded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnPreviewExpanded Method

e
The RadRoutedEventArgs instance containing the event data.
Raises the E:PreviewExpanded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPreviewExpanded( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As RadRoutedEventArgs

instance.OnPreviewExpanded(e)
C#
protected virtual void OnPreviewExpanded(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnPreviewExpanded(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnPreviewExpanded(
   RadRoutedEventArgs^ e
)

Parameters

e
The RadRoutedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : OnSelected Method

e
The RadRoutedEventArgs instance containing the event data.
Raises the E:Selected event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim e As RadRoutedEventArgs

instance.OnSelected(e)
C#
protected virtual void OnSelected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelected(
   RadRoutedEventArgs^ e
)

Parameters

e
The RadRoutedEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : ToString Method

Return item text value

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

the text of the item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

For a list of all members of this type, see RadPanelBarItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether this instance is enabled.
Public Property | IsExpanded | Gets or sets a value indicating whether this instance is expanded.
Public Property | IsFocused | Gets or sets a value indicating whether this instance is focused.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets or sets a value indicating whether the mouse cursor is over the current instance.
Public Property | IsSelected | Gets or sets a value indicating whether this instance is selected.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Gets the value of the current instance.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Level | Gets or sets the Level property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SecondLevelTemplate | Gets or sets the second level template.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopLevelTemplate | Gets or sets the top level template.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadPanelBarItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsEnabled Property

Gets or sets a value indicating whether this instance is enabled.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Enables or disables the item.")>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables or disables the item.")]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables or disables the item.")]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables or disables the item.")]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Return Value

true if this instance is enabled; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpanded Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsExpanded Property

Gets or sets a value indicating whether this instance is expanded.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Sets or gets the expand state of the item.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property IsExpanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Boolean

instance.IsExpanded = value

value = instance.IsExpanded
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Sets or gets the expand state of the item.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool IsExpanded {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Sets or gets the expand state of the item.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_IsExpanded();
public: __property void set_IsExpanded(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Sets or gets the expand state of the item.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool IsExpanded {
   bool get();
   void set (bool value);
}

Return Value

true if this instance is expanded; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsFocused Property

Gets or sets a value indicating whether this instance is focused.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Boolean

value = instance.IsFocused
C#
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public bool IsFocused {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_IsFocused();
C++/CLI
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public:
property bool IsFocused {
   bool get();
}

Return Value

true if this instance is focused; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsMouseOver Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsMouseOver Property

Gets or sets a value indicating whether the mouse cursor is over the current instance.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsMouseOver As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Boolean

value = instance.IsMouseOver
C#
[BrowsableAttribute(false)]
public bool IsMouseOver {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsMouseOver();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsMouseOver {
   bool get();
}

Return Value

true if this instance is under the mouse cursor; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsSelected Property

Gets or sets a value indicating whether this instance is selected.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Specifies whether an item is selected or not.")>
<DefaultValueAttribute()>
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies whether an item is selected or not.")]
[DefaultValueAttribute()]
public bool IsSelected {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies whether an item is selected or not.")]
[DefaultValueAttribute()]
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies whether an item is selected or not.")]
[DefaultValueAttribute()]
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Return Value

true if this instance is selected; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Item Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : Item Property

Gets the value of the current instance.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Item As Object
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Object

value = instance.Item
C#
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public object Item {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public: __property Object* get_Item();
C++/CLI
[CompilerGeneratedAttribute()]
[BrowsableAttribute(false)]
public:
property Object^ Item {
   Object^ get();
}

Return Value

The item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Level Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : Level Property

Gets or sets the Level property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Level As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As Integer

value = instance.Level
C#
[BrowsableAttribute(false)]
public int Level {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Level();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Level {
   int get();
}

Return Value

The level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SecondLevelTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : SecondLevelTemplate Property

Gets or sets the second level template.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<SRDescriptionAttribute("Specifies the control template for second-level items.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("Appearance")>
Public Property SecondLevelTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As ControlTemplate

instance.SecondLevelTemplate = value

value = instance.SecondLevelTemplate
C#
[CompilerGeneratedAttribute()]
[SRDescriptionAttribute("Specifies the control template for second-level items.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public ControlTemplate SecondLevelTemplate {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[SRDescriptionAttribute("Specifies the control template for second-level items.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public: __property ControlTemplate* get_SecondLevelTemplate();
public: __property void set_SecondLevelTemplate(
   ControlTemplate* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[SRDescriptionAttribute("Specifies the control template for second-level items.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public:
property ControlTemplate^ SecondLevelTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Return Value

The second level template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopLevelTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : TopLevelTemplate Property

Gets or sets the top level template.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Specifies the control template for top-level items.")>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
Public Property TopLevelTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim value As ControlTemplate

instance.TopLevelTemplate = value

value = instance.TopLevelTemplate
C#
[CompilerGeneratedAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies the control template for top-level items.")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public ControlTemplate TopLevelTemplate {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies the control template for top-level items.")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public: __property ControlTemplate* get_TopLevelTemplate();
public: __property void set_TopLevelTemplate(
   ControlTemplate* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Specifies the control template for top-level items.")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public:
property ControlTemplate^ TopLevelTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Return Value

The top level template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

For a list of all members of this type, see RadPanelBarItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CollapsedEvent | Identifies the Collapsed routed event.
static (Shared in Visual Basic) | ExpandedEvent | Identifies the Expanded routed event.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandedProperty | Identifies the IsExpanded dependency property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | LevelProperty | Identifies the Level dependency property.
static (Shared in Visual Basic) | PreviewCollapsedEvent | Identifies the PreviewCollapsed routed event.
static (Shared in Visual Basic) | PreviewExpandedEvent | Identifies the PreviewExpanded routed event.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
Top

See Also

Reference

RadPanelBarItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CollapsedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : CollapsedEvent Field

Identifies the Collapsed routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly CollapsedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadPanelBarItem.CollapsedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent CollapsedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* CollapsedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ CollapsedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : ExpandedEvent Field

Identifies the Expanded routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly ExpandedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadPanelBarItem.ExpandedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent ExpandedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* ExpandedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ ExpandedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBarItem.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpandedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsExpandedProperty Field

Identifies the IsExpanded dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBarItem.IsExpandedProperty
C#
public static readonly DependencyProperty IsExpandedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsExpandedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsExpandedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsMouseOverProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsMouseOverProperty Field

Identifies the IsMouseOver dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBarItem.IsMouseOverProperty
C#
public static readonly DependencyProperty IsMouseOverProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMouseOverProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMouseOverProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelectedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : IsSelectedProperty Field

Identifies the IsSelected dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBarItem.IsSelectedProperty
C#
public static readonly DependencyProperty IsSelectedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LevelProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : LevelProperty Field

Identifies the Level dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LevelProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadPanelBarItem.LevelProperty
C#
public static readonly DependencyProperty LevelProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LevelProperty
C++/CLI
public:
static readonly DependencyProperty^ LevelProperty

Remarks

This property specifies the depth of nesting of the current instance within the parent RadPanelBar.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : PreviewCollapsedEvent Field

Identifies the PreviewCollapsed routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly PreviewCollapsedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadPanelBarItem.PreviewCollapsedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent PreviewCollapsedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* PreviewCollapsedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ PreviewCollapsedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpandedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : PreviewExpandedEvent Field

Identifies the PreviewExpanded routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly PreviewExpandedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadPanelBarItem.PreviewExpandedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent PreviewExpandedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* PreviewExpandedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ PreviewExpandedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : SelectedEvent Field

Identifies the Selected routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly SelectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadPanelBarItem.SelectedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent SelectedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* SelectedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ SelectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPanelBarItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadPanelBarItem Class

For a list of all members of this type, see RadPanelBarItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Collapsed | Occurs when a RadPanelBarItem is collapsed.
Public Event | Expanded | Occurs when a RadPanelBarItem is expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewCollapsed | Occurs before a RadPanelBarItem is collapsed.
Public Event | PreviewExpanded | Occurs before a RadPanelBarItem is expanded.
Public Event | Selected | Occurs when a RadPanelBarItem is selected.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPanelBarItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Collapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : Collapsed Event

Occurs when a RadPanelBarItem is collapsed.

Syntax

Visual Basic (Declaration)
Public Event Collapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Collapsed, handler
C#
public event EventHandler<RadRoutedEventArgs> Collapsed()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Collapsed
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Collapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Expanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : Expanded Event

Occurs when a RadPanelBarItem is expanded.

Syntax

Visual Basic (Declaration)
Public Event Expanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Expanded, handler
C#
public event EventHandler<RadRoutedEventArgs> Expanded()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Expanded
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Expanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : PreviewCollapsed Event

Occurs before a RadPanelBarItem is collapsed.

Syntax

Visual Basic (Declaration)
Public Event PreviewCollapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewCollapsed, handler
C#
public event EventHandler<RadRoutedEventArgs> PreviewCollapsed()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* PreviewCollapsed
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewCollapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : PreviewExpanded Event

Occurs before a RadPanelBarItem is expanded.

Syntax

Visual Basic (Declaration)
Public Event PreviewExpanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewExpanded, handler
C#
public event EventHandler<RadRoutedEventArgs> PreviewExpanded()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* PreviewExpanded
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewExpanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Selected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadPanelBarItem Class : Selected Event

Occurs when a RadPanelBarItem is selected.

Syntax

Visual Basic (Declaration)
Public Event Selected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadPanelBarItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Selected, handler
C#
public event EventHandler<RadRoutedEventArgs> Selected()
Managed Extensions for C++
public: __event EventHandler<RadRoutedEventArgs*>* Selected
C++/CLI
public:
event EventHandler<RadRoutedEventArgs^>^ Selected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPanelBarItem Class
RadPanelBarItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadPrompt Class

RadPrompt exposes a textbox in which the user can put any value.

Syntax

Visual Basic (Declaration)
Public Class RadPrompt
   Inherits RadConfirm
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadPrompt
C#
public class RadPrompt : RadConfirm, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadPrompt : public RadConfirm, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadPrompt : public RadConfirm, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.RadAlert
Telerik.Windows.Controls.RadConfirm
Telerik.Windows.Controls.RadPrompt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPrompt Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadPrompt Class

The following tables list the members exposed by RadPrompt.

Public Constructors

 | Name | Description
Public Constructor | RadPrompt Constructor | Default constructor for RadPrompt
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Configure | Overridden. Configures RadPrompt according to the RadWindow specified
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Cancel | Identifier of Cancel (Inherited from RadConfirm)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel (Inherited from RadAlert)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPrompt Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadPrompt Class : RadPrompt Constructor

Default constructor for RadPrompt

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPrompt()
C#
public RadPrompt()
Managed Extensions for C++
public: RadPrompt();
C++/CLI
public:
RadPrompt();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPrompt Class
RadPrompt Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadPrompt Class

For a list of all members of this type, see RadPrompt members.

Public Methods

 | Name | Description
Public Method | Configure | Overridden. Configures RadPrompt according to the RadWindow specified
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

RadPrompt Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Configure Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPrompt Class : Configure Method

window
RadWindow in which the RadPrompt will appear.
Configures RadPrompt according to the RadWindow specified

Syntax

Visual Basic (Declaration)
Public Overrides Sub Configure( _
   ByVal window As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As RadPrompt
Dim window As RadWindow

instance.Configure(window)
C#
public override void Configure(
   RadWindow window
)
Managed Extensions for C++
public: void Configure(
   RadWindow* window
) override
C++/CLI
public:
void Configure(
   RadWindow^ window
) override

Parameters

window
RadWindow in which the RadPrompt will appear.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPrompt Class
RadPrompt Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadPrompt Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadPrompt

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadPrompt Class
RadPrompt Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadSeparator Class

Control that is used to separate items in items controls.

Syntax

Visual Basic (Declaration)
Public Class RadSeparator
   Inherits Control
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadSeparator
C#
public class RadSeparator : Control, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadSeparator : public Control, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadSeparator : public Control, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Telerik.Windows.Controls.RadSeparator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSeparator Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadSeparator Class

The following tables list the members exposed by RadSeparator.

Public Constructors

 | Name | Description
Public Constructor | RadSeparator Constructor | Initializes a new instance of the RadSeparator class.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadSeparator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadSeparator Class : RadSeparator Constructor

Initializes a new instance of the RadSeparator class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSeparator()
C#
public RadSeparator()
Managed Extensions for C++
public: RadSeparator();
C++/CLI
public:
RadSeparator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadSeparator Class
RadSeparator Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

A navigation control used to create tabbed interfaces.

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="Disabled", GroupName="CommonStates")>
<DefaultMemberAttribute("Item")>
<TemplatePartAttribute(Name="ArrangeGridElement", Type=System.Windows.Controls.Grid)>
<DefaultEventAttribute("SelectionChanged")>
<DefaultPropertyAttribute("Items")>
Public Class RadTabControl
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
C#
[TemplateVisualStateAttribute(Name="Disabled", GroupName="CommonStates")]
[DefaultMemberAttribute("Item")]
[TemplatePartAttribute(Name="ArrangeGridElement", Type=System.Windows.Controls.Grid)]
[DefaultEventAttribute("SelectionChanged")]
[DefaultPropertyAttribute("Items")]
public class RadTabControl : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="Disabled", GroupName="CommonStates")]
[DefaultMemberAttribute("Item")]
[TemplatePartAttribute(Name="ArrangeGridElement", Type=System.Windows.Controls.Grid)]
[DefaultEventAttribute("SelectionChanged")]
[DefaultPropertyAttribute("Items")]
public __gc class RadTabControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="Disabled", GroupName="CommonStates")]
[DefaultMemberAttribute("Item")]
[TemplatePartAttribute(Name="ArrangeGridElement", Type=System.Windows.Controls.Grid)]
[DefaultEventAttribute("SelectionChanged")]
[DefaultPropertyAttribute("Items")]
public ref class RadTabControl : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

The RadTabControl is used to create a list of tabs. The TabConstrol is ItemsControl and its default items are of type RadTabItem.

    The TabControl supports the following features:
  • Customizable look through the theming mechanism.
  • Control over the position of the TabStrip relative to its content.
  • Ability to set the orientation of the items.
  • Multirow TabStrips can be created by setting the IsBreak property of an item.
  • The align of the tab rows can be changed.
  • Any content can be placed in the TabItem headers such as icons, buttons and multiline text.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadTabControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

The following tables list the members exposed by RadTabControl.

Public Constructors

 | Name | Description
Public Constructor | RadTabControl Constructor | Initializes a new instance of the RadTabControl class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AlignProperty | Identifies the Align property.
static (Shared in Visual Basic) | AllTabsEqualHeightProperty | Identifies the AllTabsEqualHeight property.
static (Shared in Visual Basic) | BackgroundVisibilityProperty | Identifies the BackgroundVisibility property.
static (Shared in Visual Basic) | BottomTemplateProperty | Identifies the BottomTemplate property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused property.
static (Shared in Visual Basic) | LeftTemplateProperty | Identifies the LeftTemplate property.
static (Shared in Visual Basic) | ReorderTabRowsProperty | Identifies the ReorderTabRows property.
static (Shared in Visual Basic) | RightTemplateProperty | Identifies the RightTemplate property.
static (Shared in Visual Basic) | SelectedContentProperty | Identifies the SelectedContent property.
static (Shared in Visual Basic) | SelectedContentTemplateProperty | Identifies the SelectedContentTemplate property.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex proeprty.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged Event.
static (Shared in Visual Basic) | TabOrientationProperty | Identifies the TabOrientation property.
static (Shared in Visual Basic) | TabStripPlacementProperty | Identifies the TabStripPlacement property.
static (Shared in Visual Basic) | TopTemplateProperty | Identifies the TopTemplate property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Align | Gets or sets the align of the TabItems in the row - Left, Right, Center, Justify. This is a dependency property.
Public Property | AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. This is a dependency property.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl.
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BottomTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets whether the TabControl is enabled. This is a dependency property.
Public Property | IsFocused | Gets whether the TabControl is focused. This is a dependnecy property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Indexer, gets the TabItem with the given index in the items collection.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LeftTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Left. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RightTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.
Public Property | SelectedContent | Gets the content of the selected item. This is a dependency property.
Public Property | SelectedContentTemplate | Gets the content template of the currenly selected item. This is a dependency property.
Public Property | SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. This is a dependency property.
Public Property | SelectedItem | Gets or sets the currenly selected item. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | TabOrientation |
Public Property | TabStripPlacement | Gets or sets the Position of the TabStrip with regard to the content. This is a dependency property.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to top. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | MeasureOverride | Overridden.
Protected Method | OnIsFocusedChanged | Called when the focus has been changed.
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectedIndexChanged | Called when the selected index has been changed.
Protected Method | OnSelectionChanged | Called when the selection is changed.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Fired when a tab is selected. This is a routed event.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTabControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : RadTabControl Constructor

Initializes a new instance of the RadTabControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl()
C#
public RadTabControl()
Managed Extensions for C++
public: RadTabControl();
C++/CLI
public:
RadTabControl();

Remarks

Use this constructor to create an instance of the RadTabControl. In order for the TabControl to be displayed, you need to add it to the visual tree.

The Following examples show how you can create an instance of the RadTabControl control.

RadTabControl tabControl = new RadTabControl();
tabControl.Items.Add(new RadTabItem(){Header="Tab 1", Content="Tab Content"});

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

For a list of all members of this type, see RadTabControl members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden. When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.
Protected Method | GetContainerForItemOverride | Overridden. Creates or identifies the element that is used to display the given item.
Protected Method | IsItemItsOwnContainerOverride | Overridden. Determines if the specified item is (or is eligible to be) its own container.
Protected Method | MeasureOverride | Overridden.
Protected Method | OnIsFocusedChanged | Called when the focus has been changed.
Protected Method | OnItemsChanged | Overridden. Invoked when the Items property changes.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnSelectedIndexChanged | Called when the selected index has been changed.
Protected Method | OnSelectionChanged | Called when the selection is changed.
Protected Method | PrepareContainerForItemOverride | Overridden. Prepares the specified element to display the specified item.
Top

See Also

Reference

RadTabControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : ClearContainerForItemOverride Method

element
The container element.
item
The Item.
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride method.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
The container element.
item
The Item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : GetContainerForItemOverride Method

Creates or identifies the element that is used to display the given item.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : IsItemItsOwnContainerOverride Method

item
The item to check.
Determines if the specified item is (or is eligible to be) its own container.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : MeasureOverride Method

availableSize

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnIsFocusedChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : OnIsFocusedChanged Method

oldValue
The previous value of IsFocused.
newValue
The current calue of IsFocused.
Called when the focus has been changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsFocusedChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsFocusedChanged(oldValue, newValue)
C#
protected virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The previous value of IsFocused.
newValue
The current calue of IsFocused.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : OnItemsChanged Method

e
Information about the change.
Invoked when the Items property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Information about the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelectedIndexChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : OnSelectedIndexChanged Method

oldIndex
The old selected index.
newIndex
The new selected index.
Called when the selected index has been changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal oldIndex As Integer, _
   ByVal newIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim oldIndex As Integer
Dim newIndex As Integer

instance.OnSelectedIndexChanged(oldIndex, newIndex)
C#
protected virtual void OnSelectedIndexChanged(
   int oldIndex,
   int newIndex
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   int oldIndex,
   int newIndex
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
The old selected index.
newIndex
The new selected index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelectionChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : OnSelectionChanged Method

removedItems
The items removed from the selection.
addedItems
The items added to the selection.
Called when the selection is changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionChanged( _
   ByVal removedItems As IList, _
   ByVal addedItems As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim removedItems As IList
Dim addedItems As IList

instance.OnSelectionChanged(removedItems, addedItems)
C#
protected virtual void OnSelectionChanged(
   IList removedItems,
   IList addedItems
)
Managed Extensions for C++
protected: virtual void OnSelectionChanged(
   IList* removedItems,
   IList* addedItems
)
C++/CLI
protected:
virtual void OnSelectionChanged(
   IList^ removedItems,
   IList^ addedItems
)

Parameters

removedItems
The items removed from the selection.
addedItems
The items added to the selection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : PrepareContainerForItemOverride Method

element
Element used to display the specified item.
item
Specified item.
Prepares the specified element to display the specified item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
Element used to display the specified item.
item
Specified item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

For a list of all members of this type, see RadTabControl members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Align | Gets or sets the align of the TabItems in the row - Left, Right, Center, Justify. This is a dependency property.
Public Property | AllTabsEqualHeight | Gets or sets whether all the present tabs have equal height. This is a dependency property.
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BackgroundVisibility | Gets or sets the visibility of the Background of the TabControl.
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BottomTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets whether the TabControl is enabled. This is a dependency property.
Public Property | IsFocused | Gets whether the TabControl is focused. This is a dependnecy property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Indexer, gets the TabItem with the given index in the items collection.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LeftTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Left. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ReorderTabRows | Gets or sets whether the TabItem rows would be reordered when selected. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RightTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.
Public Property | SelectedContent | Gets the content of the selected item. This is a dependency property.
Public Property | SelectedContentTemplate | Gets the content template of the currenly selected item. This is a dependency property.
Public Property | SelectedIndex | Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. This is a dependency property.
Public Property | SelectedItem | Gets or sets the currenly selected item. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | TabOrientation |
Public Property | TabStripPlacement | Gets or sets the Position of the TabStrip with regard to the content. This is a dependency property.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TopTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to top. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadTabControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Align Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : Align Property

Gets or sets the align of the TabItems in the row - Left, Right, Center, Justify. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("AppearanceCategory")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property Align As TabStripAlign
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As TabStripAlign

instance.Align = value

value = instance.Align
C#
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public TabStripAlign Align {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property TabStripAlign get_Align();
public: __property void set_Align(
   TabStripAlign value
);
C++/CLI
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property TabStripAlign Align {
   TabStripAlign get();
   void set (TabStripAlign value);
}

Remarks

The Align property arranges the TabItems in the preferred way - Left, Right, Center or Justify.

If Align Justify is selected, the items would be scaled proportionally all the to fill the available space.

If not enough space is available (i.e. the desired width of the row of TabItems is more than the available space), then the TabItems are arranged as if "Justify" is chosen. Unlike the WPF TabControl behaviour the TabItems would not automatically move to the next row if there is not enough space, instead their width is reduced and parts of them can be clipped.

If you would like to create a multirow RadTabControl, please use the RadTabItem.IsBreak property of the RadTabItem

The default value is Justify.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
TabStripPlacement Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AllTabsEqualHeight Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : AllTabsEqualHeight Property

Gets or sets whether all the present tabs have equal height. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("AppearanceCategory")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property AllTabsEqualHeight As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Boolean

instance.AllTabsEqualHeight = value

value = instance.AllTabsEqualHeight
C#
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public bool AllTabsEqualHeight {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property bool get_AllTabsEqualHeight();
public: __property void set_AllTabsEqualHeight(
   bool value
);
C++/CLI
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property bool AllTabsEqualHeight {
   bool get();
   void set (bool value);
}

Remarks

The AllTabsEqualHeight property governs the arranging behaviour of the TabStrip when TabItems with different height are present.

If you have multiline TabItems for example, setting the property to True would ensure that all the TabItems have the same height.

Please note that the adjustment of height takes place on a row-per-row basis, i.e. in a two-row TabStrip the height of the TabItems would be equal to the height of the highest item in each row and might be different.

The default value is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
IsBreak Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BackgroundVisibility Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : BackgroundVisibility Property

Gets or sets the visibility of the Background of the TabControl.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<SRCategoryAttribute("AppearanceCategory")>
<DefaultValueAttribute()>
Public Property BackgroundVisibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Visibility

instance.BackgroundVisibility = value

value = instance.BackgroundVisibility
C#
[SRDescriptionAttribute("")]
[SRCategoryAttribute("AppearanceCategory")]
[DefaultValueAttribute()]
public Visibility BackgroundVisibility {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[SRCategoryAttribute("AppearanceCategory")]
[DefaultValueAttribute()]
public: __property Visibility get_BackgroundVisibility();
public: __property void set_BackgroundVisibility(
   Visibility value
);
C++/CLI
[SRDescriptionAttribute("")]
[SRCategoryAttribute("AppearanceCategory")]
[DefaultValueAttribute()]
public:
property Visibility BackgroundVisibility {
   Visibility get();
   void set (Visibility value);
}

Remarks

This property gives you a quick way to change the visibility of the background without having to modify the ControlTemplate of the TabControl.

The default value is Visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BottomTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : BottomTemplate Property

Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property BottomTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As ControlTemplate

instance.BottomTemplate = value

value = instance.BottomTemplate
C#
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public ControlTemplate BottomTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property ControlTemplate* get_BottomTemplate();
public: __property void set_BottomTemplate(
   ControlTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property ControlTemplate^ BottomTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : IsEnabled Property

Gets or sets whether the TabControl is enabled. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : IsFocused Property

Gets whether the TabControl is focused. This is a dependnecy property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Boolean

value = instance.IsFocused
C#
[BrowsableAttribute(false)]
public bool IsFocused {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsFocused();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsFocused {
   bool get();
}

Remarks

Please note that IsFocused is a read only property. To focus the TabControl, use the Focus method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Item Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : Item Property

index
The index of the TabItem in the Items collection of TabControl
Indexer, gets the TabItem with the given index in the items collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As RadTabItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim index As Integer
Dim value As RadTabItem

value = instance.Item(index)
C#
public RadTabItem this[
   int index
]; {get;}
Managed Extensions for C++
public: __property RadTabItem* get_Item(
   int index
);
C++/CLI
public:
property RadTabItem^ default [int] {
   RadTabItem^ get(int index);
}

Parameters

index
The index of the TabItem in the Items collection of TabControl

Remarks

You can use the indexer to quickly get the RadTabItem with the given index. The indexer is a shortcut for the ContainerFromIndex method.

Note that you cannot use the indexer to change (repalce) an item if you would like to do this use the ItemsControl.Items property. If an invalid index is passed null is returned.

The following examle demonstrates how you can use the indexer to quickly access a given tab item.

RadTabControl tabControl = new RadTabControl();
tabControl.ItemsSource = new string[] { "Tab Header 1", "Tab Header 2", "Tab Hedaer 3" };
tabControl[1].IsSelected = true;

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : LeftTemplate Property

Gets or sets the template of the TabControl when the TabStripPlacement is set to Left. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to LeftThis is a dependency property.")>
Public Property LeftTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As ControlTemplate

instance.LeftTemplate = value

value = instance.LeftTemplate
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to LeftThis is a dependency property.")]
public ControlTemplate LeftTemplate {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to LeftThis is a dependency property.")]
public: __property ControlTemplate* get_LeftTemplate();
public: __property void set_LeftTemplate(
   ControlTemplate* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to LeftThis is a dependency property.")]
public:
property ControlTemplate^ LeftTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ReorderTabRows Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : ReorderTabRows Property

Gets or sets whether the TabItem rows would be reordered when selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ReorderTabRows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Boolean

instance.ReorderTabRows = value

value = instance.ReorderTabRows
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool ReorderTabRows {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ReorderTabRows();
public: __property void set_ReorderTabRows(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool ReorderTabRows {
   bool get();
   void set (bool value);
}

Remarks

The ReorderTabRows property governs the behaviour of the TabItems when selected. Its effect can only be observed when more than one row of TabItems are present. Refer to RadTabItem.IsBreak for more information on how to create multirow TabStrips.

Setting the property to true would make the rows in the TabStrip change place so that the selected item is always in the row nearest to the presented content (i.e. the bottommost row in a Top position, the rightmost column in a Left position, etc.)

Please note that the index of each item remains the same even when reordered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
TabStripPlacement Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RightTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : RightTemplate Property

Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to RightThis is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property RightTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As ControlTemplate

instance.RightTemplate = value

value = instance.RightTemplate
C#
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to RightThis is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public ControlTemplate RightTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to RightThis is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property ControlTemplate* get_RightTemplate();
public: __property void set_RightTemplate(
   ControlTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to RightThis is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property ControlTemplate^ RightTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedContent Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedContent Property

Gets the content of the selected item. This is a dependency property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public ReadOnly Property SelectedContent As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Object

value = instance.SelectedContent
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public object SelectedContent {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property Object* get_SelectedContent();
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property Object^ SelectedContent {
   Object^ get();
}

Remarks

The SelectedContent property returns the Content of the currently selected item.

Note that the property cannot be set. To change the Content of the TabControl change the currenly selected item.

If no items are selected, the proeprty would return null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
SelectedContentTemplate Property
SelectedItem Property
SelectedIndex Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedContentTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedContentTemplate Property

Gets the content template of the currenly selected item. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedContentTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As DataTemplate

value = instance.SelectedContentTemplate
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public DataTemplate SelectedContentTemplate {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property DataTemplate* get_SelectedContentTemplate();
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property DataTemplate^ SelectedContentTemplate {
   DataTemplate^ get();
}

Remarks

The ContentTemplate property returns the ContentTemplate of the currently selected item.

Note that the property cannot be set. To change the ContentTemplate of the TabControl items, use the ItemsControl.ItemTemplate and ItemsControl.ItemTemplateSelector properties if an ItemsSource has been provided. Alternatively the RadTabItem.ContentTemplate can be used to assign a template on a per-item basis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedIndex Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedIndex Property

Gets or sets the index of the selected item. The default value is -1 which means that no item is selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("AppearanceCategory")>
<SRDescriptionAttribute("")>
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public int SelectedIndex {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Remarks

The SelectedIndex property is used to get or set the index of the selected item. Setting the property to -1 will deselect all items.

Please note that the selected index property can change even SelectedItem property remains the same. This can happen when items are inserted before the currently selected item. The same is true if items are removed.

To get the currently displayed content, use the SelectedContent property.

When no items are present, the default value is -1. If items are present by default the first item (with index 0) would be selected.

Setting the selected index to anything outside the current range (0 to Items.Count -1) will not alter the SelectedIndex and no exception will be thrown.

If a newly inserted RadTabItem has its RadTabItem.IsSelected property set to true, it would become the selected item.

To get the index of an item, use the IndexFromContainer method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
SelectedItem Property
SelectionChanged Event
SelectedContent Property
SelectedContentTemplate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedItem Property

Gets or sets the currenly selected item. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public object SelectedItem {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^ value);
}

Remarks

The SelectedItem property gets or sets the currently selected item. The item can be of any type, including RadTabItem

If toy would like to retrieve the selected container, you can use the ContainerFromIndex and ContainerFromItem methods to retrive the container.

If no item is selected, the prpperty will return null.

If you would like to set a TabItem as selected before adding it to the TabControl, you can use the RadTabItem.IsSelected property of the RadTabItem.

Please note that setting the SelectedItem property to anythin that is not contained in the Items of the control would not throw an exception and would not change the property.

To receive notifications when the selected item is changed, sign up for the SelectionChnaged event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
SelectedIndex Property
SelectionChanged Event
SelectedContent Property
SelectedContentTemplate Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabOrientation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TabOrientation Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("AppearanceCategory")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property TabOrientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Orientation

instance.TabOrientation = value

value = instance.TabOrientation
C#
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public Orientation TabOrientation {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property Orientation get_TabOrientation();
public: __property void set_TabOrientation(
   Orientation value
);
C++/CLI
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property Orientation TabOrientation {
   Orientation get();
   void set (Orientation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPlacement Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TabStripPlacement Property

Gets or sets the Position of the TabStrip with regard to the content. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("AppearanceCategory")>
<SRDescriptionAttribute("")>
Public Property TabStripPlacement As Dock
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As Dock

instance.TabStripPlacement = value

value = instance.TabStripPlacement
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public Dock TabStripPlacement {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public: __property Dock get_TabStripPlacement();
public: __property void set_TabStripPlacement(
   Dock value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("AppearanceCategory")]
[SRDescriptionAttribute("")]
public:
property Dock TabStripPlacement {
   Dock get();
   void set (Dock value);
}

Remarks

The TabStripPlacement property allows you to change where the TabStrip (i.e. the buttons) would appear relative to the content.

Please note that changing the TabStripPlacement of the TabControl internally changes the ControlTemplate of the TabItems. To acieve a consistent look when a custom theme is created, ControlTemplates for the four positions should be provied.

The default value is Top.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
TabOrientation Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TopTemplate Property

Gets or sets the template of the TabControl when the TabStripPlacement is set to top. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Top. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property TopTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim value As ControlTemplate

instance.TopTemplate = value

value = instance.TopTemplate
C#
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Top. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public ControlTemplate TopTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Top. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property ControlTemplate* get_TopTemplate();
public: __property void set_TopTemplate(
   ControlTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the template of the TabControl when the TabStripPlacement is set to Top. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property ControlTemplate^ TopTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

For a list of all members of this type, see RadTabControl members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AlignProperty | Identifies the Align property.
static (Shared in Visual Basic) | AllTabsEqualHeightProperty | Identifies the AllTabsEqualHeight property.
static (Shared in Visual Basic) | BackgroundVisibilityProperty | Identifies the BackgroundVisibility property.
static (Shared in Visual Basic) | BottomTemplateProperty | Identifies the BottomTemplate property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused property.
static (Shared in Visual Basic) | LeftTemplateProperty | Identifies the LeftTemplate property.
static (Shared in Visual Basic) | ReorderTabRowsProperty | Identifies the ReorderTabRows property.
static (Shared in Visual Basic) | RightTemplateProperty | Identifies the RightTemplate property.
static (Shared in Visual Basic) | SelectedContentProperty | Identifies the SelectedContent property.
static (Shared in Visual Basic) | SelectedContentTemplateProperty | Identifies the SelectedContentTemplate property.
static (Shared in Visual Basic) | SelectedIndexProperty | Identifies the SelectedIndex proeprty.
static (Shared in Visual Basic) | SelectedItemProperty | Identifies the SelectedItem property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged Event.
static (Shared in Visual Basic) | TabOrientationProperty | Identifies the TabOrientation property.
static (Shared in Visual Basic) | TabStripPlacementProperty | Identifies the TabStripPlacement property.
static (Shared in Visual Basic) | TopTemplateProperty | Identifies the TopTemplate property.
Top

See Also

Reference

RadTabControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AlignProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : AlignProperty Field

Identifies the Align property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AlignProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.AlignProperty
C#
public static readonly DependencyProperty AlignProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AlignProperty
C++/CLI
public:
static readonly DependencyProperty^ AlignProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AllTabsEqualHeightProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : AllTabsEqualHeightProperty Field

Identifies the AllTabsEqualHeight property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AllTabsEqualHeightProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.AllTabsEqualHeightProperty
C#
public static readonly DependencyProperty AllTabsEqualHeightProperty
Managed Extensions for C++
public: static readonly DependencyProperty* AllTabsEqualHeightProperty
C++/CLI
public:
static readonly DependencyProperty^ AllTabsEqualHeightProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
AllTabsEqualHeight Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BackgroundVisibilityProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : BackgroundVisibilityProperty Field

Identifies the BackgroundVisibility property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundVisibilityProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.BackgroundVisibilityProperty
C#
public static readonly DependencyProperty BackgroundVisibilityProperty
Managed Extensions for C++
public: static readonly DependencyProperty* BackgroundVisibilityProperty
C++/CLI
public:
static readonly DependencyProperty^ BackgroundVisibilityProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BottomTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : BottomTemplateProperty Field

Identifies the BottomTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BottomTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.BottomTemplateProperty
C#
public static readonly DependencyProperty BottomTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* BottomTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ BottomTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : IsEnabledProperty Field

Identifies the IsEnabled property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsFocusedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : IsFocusedProperty Field

Identifies the IsFocused property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.IsFocusedProperty
C#
public static readonly DependencyProperty IsFocusedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFocusedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFocusedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : LeftTemplateProperty Field

Identifies the LeftTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LeftTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.LeftTemplateProperty
C#
public static readonly DependencyProperty LeftTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LeftTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ LeftTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ReorderTabRowsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : ReorderTabRowsProperty Field

Identifies the ReorderTabRows property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ReorderTabRowsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.ReorderTabRowsProperty
C#
public static readonly DependencyProperty ReorderTabRowsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ReorderTabRowsProperty
C++/CLI
public:
static readonly DependencyProperty^ ReorderTabRowsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RightTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : RightTemplateProperty Field

Identifies the RightTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RightTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.RightTemplateProperty
C#
public static readonly DependencyProperty RightTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RightTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ RightTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedContentProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedContentProperty Field

Identifies the SelectedContent property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedContentProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.SelectedContentProperty
C#
public static readonly DependencyProperty SelectedContentProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedContentProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedContentProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedContentTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedContentTemplateProperty Field

Identifies the SelectedContentTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedContentTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.SelectedContentTemplateProperty
C#
public static readonly DependencyProperty SelectedContentTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedContentTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedContentTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedIndexProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedIndexProperty Field

Identifies the SelectedIndex proeprty.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.SelectedIndexProperty
C#
public static readonly DependencyProperty SelectedIndexProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedIndexProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedIndexProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItemProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectedItemProperty Field

Identifies the SelectedItem property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.SelectedItemProperty
C#
public static readonly DependencyProperty SelectedItemProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedItemProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedItemProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectionChangedEvent Field

Identifies the SelectionChanged Event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly SelectionChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTabControl.SelectionChangedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent SelectionChangedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* SelectionChangedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ SelectionChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
SelectionChanged Event


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabOrientationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TabOrientationProperty Field

Identifies the TabOrientation property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TabOrientationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.TabOrientationProperty
C#
public static readonly DependencyProperty TabOrientationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TabOrientationProperty
C++/CLI
public:
static readonly DependencyProperty^ TabOrientationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPlacementProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TabStripPlacementProperty Field

Identifies the TabStripPlacement property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.TabStripPlacementProperty
C#
public static readonly DependencyProperty TabStripPlacementProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TabStripPlacementProperty
C++/CLI
public:
static readonly DependencyProperty^ TabStripPlacementProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : TopTemplateProperty Field

Identifies the TopTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabControl.TopTemplateProperty
C#
public static readonly DependencyProperty TopTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ TopTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabControl Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabControl Class

For a list of all members of this type, see RadTabControl members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionChanged | Fired when a tab is selected. This is a routed event.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTabControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabControl Class : SelectionChanged Event

Fired when a tab is selected. This is a routed event.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event SelectionChanged() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabControl
Dim handler As RoutedEventHandler

AddHandler instance.SelectionChanged, handler
C#
[SRDescriptionAttribute("")]
public event RoutedEventHandler SelectionChanged()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event RoutedEventHandler* SelectionChanged
C++/CLI
[SRDescriptionAttribute("")]
public:
event RoutedEventHandler^ SelectionChanged

Remarks

The SelectionChanged event is fired whenever the currently selected tab changes (or when all tabs are deselected). The event would be triggered when the user selects a different tab or when the selected index or selected item change.

SelectionChanged is a routed event which means that you can handle the event in one of the parents of the TabControl as well.

Please note that the event would not fire until a template has been applied.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabControl Class
RadTabControl Members
SelectedIndex Property
SelectedItem Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

Represents a tab item, the default item of the RadTabControl.

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStateGroup")>
<TemplatePartAttribute(Name="FocusRectangleElement", Type=System.Windows.Shapes.Rectangle)>
<DefaultPropertyAttribute("Header")>
Public Class RadTabItem
   Inherits HeaderedContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
C#
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStateGroup")]
[TemplatePartAttribute(Name="FocusRectangleElement", Type=System.Windows.Shapes.Rectangle)]
[DefaultPropertyAttribute("Header")]
public class RadTabItem : HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStateGroup")]
[TemplatePartAttribute(Name="FocusRectangleElement", Type=System.Windows.Shapes.Rectangle)]
[DefaultPropertyAttribute("Header")]
public __gc class RadTabItem : public HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStateGroup")]
[TemplatePartAttribute(Name="FocusRectangleElement", Type=System.Windows.Shapes.Rectangle)]
[DefaultPropertyAttribute("Header")]
public ref class RadTabItem : public HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

The RadTabItem class is the default item of the RadTabControl. The TabItem appears in the TabStrip of the TabControl while the contents of its Content property are shown when the Tab is selected.

When tabs are inserted into the TabControl the last Tab to have its RadTabItem.IsSelected property set to true would be selected.

You can change the look of the Control by setting the Theme, Style or Control Tempalte properties. To change the look of all the TabItems in a TabControl, use the ItemsControl.ItemContainerStyle and ItemsControl.ItemContainerStyleSelector

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.HeaderedContentControl
Telerik.Windows.Controls.RadTabItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Members
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

The following tables list the members exposed by RadTabItem.

Public Constructors

 | Name | Description
Public Constructor | RadTabItem Constructor | Default constructor of the RadTabItem.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BottomTemplateProperty | Identifies the BottomTemplate property.
static (Shared in Visual Basic) | IsBreakProperty | Identifies the IsBreak dependency property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected property.
static (Shared in Visual Basic) | LeftTemplateProperty | Identifies the LeftTemplate property.
static (Shared in Visual Basic) | RightTemplateProperty | Identifies the RightTemplate property.
static (Shared in Visual Basic) | TabStripPlacementProperty | Identifies the TabStripPlacement property.
static (Shared in Visual Basic) | TopTemplateProperty | Identifies the TopTemplate property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BottomTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Header | Gets or sets the header of the control. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsBreak | Gets or sets whether the next tab would be displayed on the next row. This is a dependnecy property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsFocused | Gets whether the tab is focused. This is a dependnecy property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets whether the mouse is over the control. This is a dependency property.
Public Property | IsSelected | Gets or sets whether the TabItem is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LeftTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RightTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | TabStripPlacement | Gets the perceived placement of the TabItem. This is a dependency property.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TopTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to top. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Protected Method | OnContentChanged | Overridden. Called when the Content property changes.
Protected Method | OnHeaderChanged | Allows derived classes to act on header change. (Inherited from HeaderedContentControl)
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change. (Inherited from HeaderedContentControl)
Protected Method | OnIsEnabledChanged | Overridden. Called when the IsEnabled property changes.
Protected Method | OnIsFocusedChanged | Called when the focus has been changed.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTabItem Class
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : RadTabItem Constructor

Default constructor of the RadTabItem.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem()
C#
public RadTabItem()
Managed Extensions for C++
public: RadTabItem();
C++/CLI
public:
RadTabItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
RadTabItem Class


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

For a list of all members of this type, see RadTabItem members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Protected Method | OnContentChanged | Overridden. Called when the Content property changes.
Protected Method | OnHeaderChanged | Allows derived classes to act on header change. (Inherited from HeaderedContentControl)
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change. (Inherited from HeaderedContentControl)
Protected Method | OnIsEnabledChanged | Overridden. Called when the IsEnabled property changes.
Protected Method | OnIsFocusedChanged | Called when the focus has been changed.
Top

See Also

Reference

RadTabItem Class
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate().

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnContentChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : OnContentChanged Method

oldContent
The old value of the Content property.
newContent
The new value of the Content property.
Called when the Content property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged( _
   ByVal oldContent As Object, _
   ByVal newContent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim oldContent As Object
Dim newContent As Object

instance.OnContentChanged(oldContent, newContent)
C#
protected override void OnContentChanged(
   object oldContent,
   object newContent
)
Managed Extensions for C++
protected: void OnContentChanged(
   Object* oldContent,
   Object* newContent
) override
C++/CLI
protected:
void OnContentChanged(
   Object^ oldContent,
   Object^ newContent
) override

Parameters

oldContent
The old value of the Content property.
newContent
The new value of the Content property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnIsEnabledChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : OnIsEnabledChanged Method

isEnabled
New value of the IsEnabled property.
Called when the IsEnabled property changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnIsEnabledChanged( _
   ByVal isEnabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim isEnabled As Boolean

instance.OnIsEnabledChanged(isEnabled)
C#
protected override void OnIsEnabledChanged(
   bool isEnabled
)
Managed Extensions for C++
protected: void OnIsEnabledChanged(
   bool isEnabled
) override
C++/CLI
protected:
void OnIsEnabledChanged(
   bool isEnabled
) override

Parameters

isEnabled
New value of the IsEnabled property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnIsFocusedChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : OnIsFocusedChanged Method

oldValue
The previous value of IsFocused.
newValue
The current value of IsFocused.
Called when the focus has been changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnIsFocusedChanged( _
   ByVal oldValue As Boolean, _
   ByVal newValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim oldValue As Boolean
Dim newValue As Boolean

instance.OnIsFocusedChanged(oldValue, newValue)
C#
protected virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)
Managed Extensions for C++
protected: virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)
C++/CLI
protected:
virtual void OnIsFocusedChanged(
   bool oldValue,
   bool newValue
)

Parameters

oldValue
The previous value of IsFocused.
newValue
The current value of IsFocused.

Remarks

When overriden in a derived class, the OnIsFocusChanged method can be used for a place to act when focus is changed. If the base call is supressed, the visuals of the TabItem will not change to reflect the change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

For a list of all members of this type, see RadTabItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | BottomTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Header | Gets or sets the header of the control. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsBreak | Gets or sets whether the next tab would be displayed on the next row. This is a dependnecy property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsFocused | Gets whether the tab is focused. This is a dependnecy property.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets whether the mouse is over the control. This is a dependency property.
Public Property | IsSelected | Gets or sets whether the TabItem is selected. This is a dependency property.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LeftTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RightTemplate | Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | TabStripPlacement | Gets the perceived placement of the TabItem. This is a dependency property.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TopTemplate | Gets or sets the template of the TabItem when the TabStripPlacement is set to top. This is a dependency property.
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadTabItem Class
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BottomTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : BottomTemplate Property

Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
Public Property BottomTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As ControlTemplate

instance.BottomTemplate = value

value = instance.BottomTemplate
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public ControlTemplate BottomTemplate {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public: __property ControlTemplate* get_BottomTemplate();
public: __property void set_BottomTemplate(
   ControlTemplate* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Bottom. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
public:
property ControlTemplate^ BottomTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsBreak Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsBreak Property

Gets or sets whether the next tab would be displayed on the next row. This is a dependnecy property.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<DescriptionAttribute("Gets or sets whether the next tab would be displayed on the next row")>
<DefaultValueAttribute()>
Public Property IsBreak As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As Boolean

instance.IsBreak = value

value = instance.IsBreak
C#
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Gets or sets whether the next tab would be displayed on the next row")]
[DefaultValueAttribute()]
public bool IsBreak {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Gets or sets whether the next tab would be displayed on the next row")]
[DefaultValueAttribute()]
public: __property bool get_IsBreak();
public: __property void set_IsBreak(
   bool value
);
C++/CLI
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Gets or sets whether the next tab would be displayed on the next row")]
[DefaultValueAttribute()]
public:
property bool IsBreak {
   bool get();
   void set (bool value);
}

Remarks

To create a multi-row Tabstrip in the RadTabControl, set the IsBreak property to true for the last item in the row. The same applies for columns when the TabStripPlacement of the TabControl is set to Left or Right.

Note that the TabControl would not automatically create new TabRows when there is not enough space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
TabStripPlacement Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsFocused Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsFocused Property

Gets whether the tab is focused. This is a dependnecy property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsFocused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As Boolean

value = instance.IsFocused
C#
[BrowsableAttribute(false)]
public bool IsFocused {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsFocused();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsFocused {
   bool get();
}

Remarks

The IsFocused property idicates whether the TabItem has focus. If the tab has focus, this means that the keyboard can be used for navigation. The Left and right keys move to the previous and next items while the Home and End key move to the first and last enabled item respectively.

The IsFocused property is Read-only, to move the focus to an element, use the Focus method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsMouseOver Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsMouseOver Property

Gets whether the mouse is over the control. This is a dependency property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsMouseOver As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As Boolean

value = instance.IsMouseOver
C#
[BrowsableAttribute(false)]
public bool IsMouseOver {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsMouseOver();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsMouseOver {
   bool get();
}

Remarks

The IsMouseOver idicates whether the mouse is over the TabItem. The property can be used in DataBinding.

The property is read-only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsSelected Property

Gets or sets whether the TabItem is selected. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool IsSelected {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Remarks

The IsSelected property indicates whether an item is selected. Setting the property to true is one of the ways to select a TabItem, along with SelectedIndex and SelectedItem

When another item is selected, IsSelected will change to false.

Multiple TabItems with their property set to tue can be added to the TabControl, only the last one to be added will be selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
SelectedItem Property
SelectedIndex Property
SelectedContent Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : LeftTemplate Property

Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property LeftTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As ControlTemplate

instance.LeftTemplate = value

value = instance.LeftTemplate
C#
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public ControlTemplate LeftTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property ControlTemplate* get_LeftTemplate();
public: __property void set_LeftTemplate(
   ControlTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Left. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property ControlTemplate^ LeftTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RightTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : RightTemplate Property

Gets or sets the template of the TabControl when the TabStripPlacement is set to Right. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<SRCategoryAttribute("Appearance")>
Public Property RightTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As ControlTemplate

instance.RightTemplate = value

value = instance.RightTemplate
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public ControlTemplate RightTemplate {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public: __property ControlTemplate* get_RightTemplate();
public: __property void set_RightTemplate(
   ControlTemplate* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[SRCategoryAttribute("Appearance")]
public:
property ControlTemplate^ RightTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPlacement Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : TabStripPlacement Property

Gets the perceived placement of the TabItem. This is a dependency property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property TabStripPlacement As Dock
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As Dock

value = instance.TabStripPlacement
C#
[BrowsableAttribute(false)]
public Dock TabStripPlacement {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Dock get_TabStripPlacement();
C++/CLI
[BrowsableAttribute(false)]
public:
property Dock TabStripPlacement {
   Dock get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : TopTemplate Property

Gets or sets the template of the TabItem when the TabStripPlacement is set to top. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Top. This is a dependency property.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property TopTemplate As ControlTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadTabItem
Dim value As ControlTemplate

instance.TopTemplate = value

value = instance.TopTemplate
C#
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Top. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public ControlTemplate TopTemplate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Top. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property ControlTemplate* get_TopTemplate();
public: __property void set_TopTemplate(
   ControlTemplate* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the template of the TabItem when the TabStripPlacement is set to Top. This is a dependency property.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property ControlTemplate^ TopTemplate {
   ControlTemplate^ get();
   void set (ControlTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

For a list of all members of this type, see RadTabItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BottomTemplateProperty | Identifies the BottomTemplate property.
static (Shared in Visual Basic) | IsBreakProperty | Identifies the IsBreak dependency property.
static (Shared in Visual Basic) | IsFocusedProperty | Identifies the IsFocused dependency property.
static (Shared in Visual Basic) | IsMouseOverProperty | Identifies the IsMouseOver property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected property.
static (Shared in Visual Basic) | LeftTemplateProperty | Identifies the LeftTemplate property.
static (Shared in Visual Basic) | RightTemplateProperty | Identifies the RightTemplate property.
static (Shared in Visual Basic) | TabStripPlacementProperty | Identifies the TabStripPlacement property.
static (Shared in Visual Basic) | TopTemplateProperty | Identifies the TopTemplate property.
Top

See Also

Reference

RadTabItem Class
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BottomTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : BottomTemplateProperty Field

Identifies the BottomTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BottomTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.BottomTemplateProperty
C#
public static readonly DependencyProperty BottomTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* BottomTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ BottomTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsBreakProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsBreakProperty Field

Identifies the IsBreak dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsBreakProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.IsBreakProperty
C#
public static readonly DependencyProperty IsBreakProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsBreakProperty
C++/CLI
public:
static readonly DependencyProperty^ IsBreakProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
IsBreak Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsFocusedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsFocusedProperty Field

Identifies the IsFocused dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.IsFocusedProperty
C#
public static readonly DependencyProperty IsFocusedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsFocusedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsFocusedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsMouseOverProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsMouseOverProperty Field

Identifies the IsMouseOver property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.IsMouseOverProperty
C#
public static readonly DependencyProperty IsMouseOverProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsMouseOverProperty
C++/CLI
public:
static readonly DependencyProperty^ IsMouseOverProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
IsMouseOver Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelectedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : IsSelectedProperty Field

Identifies the IsSelected property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.IsSelectedProperty
C#
public static readonly DependencyProperty IsSelectedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members
IsSelected Property


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : LeftTemplateProperty Field

Identifies the LeftTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LeftTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.LeftTemplateProperty
C#
public static readonly DependencyProperty LeftTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LeftTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ LeftTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RightTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : RightTemplateProperty Field

Identifies the RightTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RightTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.RightTemplateProperty
C#
public static readonly DependencyProperty RightTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* RightTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ RightTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPlacementProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : TabStripPlacementProperty Field

Identifies the TabStripPlacement property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.TabStripPlacementProperty
C#
public static readonly DependencyProperty TabStripPlacementProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TabStripPlacementProperty
C++/CLI
public:
static readonly DependencyProperty^ TabStripPlacementProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTabItem Class : TopTemplateProperty Field

Identifies the TopTemplate property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTabItem.TopTemplateProperty
C#
public static readonly DependencyProperty TopTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ TopTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTabItem Class
RadTabItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

Object Model

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class RadTreeView
   Inherits ItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
C#
[ScriptableTypeAttribute()]
public class RadTreeView : ItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class RadTreeView : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[ScriptableTypeAttribute()]
public ref class RadTreeView : public ItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadTreeView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

The following tables list the members exposed by RadTreeView.

Public Constructors

 | Name | Description
Public Constructor | RadTreeView Constructor | Initializes a new instance of the RadTreeView class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DragEndedEvent | Identifies the DragEnded routed event.
static (Shared in Visual Basic) | DragStartedEvent | Identifies the DragStarted routed event.
static (Shared in Visual Basic) | ExpanderStyleProperty | Identifies the ExpanderStyle dependency property.
static (Shared in Visual Basic) | ImagesBaseDirProperty | Identifies the ImagesBaseDir dependency property.
static (Shared in Visual Basic) | IsDragDropBetweenTreeViewsAllowedProperty | Identifies the IsDragDropBetweenTreeViewsAllowed dependency property.
static (Shared in Visual Basic) | IsDragDropEnabledProperty | Identifies the IsDragDropEnabled dependency property.
static (Shared in Visual Basic) | IsDragPreviewEnabledProperty | Identifies the IsDragPreviewEnabled dependency property.
static (Shared in Visual Basic) | IsDragTooltipEnabledProperty | Identifies the IsDragTooltipEnabled dependency property.
static (Shared in Visual Basic) | IsDropPreviewLineEnabledProperty | Identifies the IsDropPreviewLineEnabled dependency property.
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandOnDblClickEnabledProperty | Identifies the IsExpandOnDblClickEnabled dependency property.
static (Shared in Visual Basic) | IsIncrementalSearchEnabledProperty | Identifies the IsIncrementalSearchEnabled dependency property.
static (Shared in Visual Basic) | IsLineEnabledProperty | Identifies the IsLineEnabled dependency property.
static (Shared in Visual Basic) | IsLoadOnDemandEnabledProperty | Identifies the IsLoadOnDemandEnabled dependency property.
static (Shared in Visual Basic) | IsOptionElementsEnabledProperty | Identifies the IsOptionElementsEnabled dependency property.
static (Shared in Visual Basic) | IsRootLinesEnabledProperty | Identifies the IsRootLinesEnabled dependency property.
static (Shared in Visual Basic) | IsSingleExpandPathProperty | Identifies the IsSingleExpandPath dependency property.
static (Shared in Visual Basic) | IsTriStateModeProperty | Identifies the IsTriStateMode dependency property.
static (Shared in Visual Basic) | ItemsIndentProperty | Identifies the ItemsIndent dependency property.
static (Shared in Visual Basic) | ItemsOptionListTypeProperty | Identifies the ItemsOptionListType dependency property.
static (Shared in Visual Basic) | PathSeparatorProperty | Identifies the PathSeparator dependency property.
static (Shared in Visual Basic) | PreviewDragEndedEvent | Identifies the PreviewDragEnded routed event.
static (Shared in Visual Basic) | PreviewDragStartedEvent | Identifies the PreviewDragStarted routed event.
static (Shared in Visual Basic) | SelectedItemsProperty | Identifies the SelectedItemsProperty dependency property.
static (Shared in Visual Basic) | SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
static (Shared in Visual Basic) | SelectedValueProperty | Identifies the SelectedValue dependency property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged routed event.
static (Shared in Visual Basic) | SelectionModeProperty | Identifies the SelectionMode dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpanderStyle | Gets or sets the style of RadTreeViewItem expander button
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImagesBaseDir | The directory where image files used in the treeview reside
Public Property | IsDragDropEnabled | Gets or sets a value indicating whether drag and drop is enabled.
Public Property | IsDragPreviewEnabled | Gets or sets a value indicating whether drag feedback is shown while dragging.
Public Property | IsDragTooltipEnabled | Gets or sets a value indicating whether drag tooltip is shown while dragging.
Public Property | IsDropPreviewLineEnabled | Gets or sets a value indicating whether drag outline is shown while dragging.
Public Property | IsEditable | Gets or sets a value indicating whether the user can edit the text of item.
Public Property | IsEditing | Gets if there is an open editor in the tree view.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface.
Public Property | IsExpandOnDblClickEnabled | Gets or sets a value whether the item will toggle its expand state on double click
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsLineEnabled | Gets or sets a value indicating whether lines are displayed between item.
Public Property | IsLoadOnDemandEnabled | Gets or sets a value indicating whether loading on demand is enabled.
Public Property | IsOptionElementsEnabled | Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.
Public Property | IsRootLinesEnabled | Gets or sets a value indicating whether lines are displayed next to root item.
Public Property | IsSingleExpandPath | Gets a value indicating whether only the current branch of the treeview is expanded.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | IsTriStateMode | Gets or sets a value indicating whether tri state mode of the option lists is enabled.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsIndent | Gets or sets the distance to indent each of the tree item levels.
Public Property | ItemsOptionListType | Gets or sets the type of option list formed by itemContainer item.
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PathSeparator | Gets or sets the delimiter string that the tree item path uses. The tree item path contains of a set of tree item labels separated by the PathSeparator delimiter strings. The default return value is the backslash character (\).
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollViewer | Gets the scrollviewer control the is inside the RadTreeView
Public Property | SelectedContainer | Gets the itemContainer that is currently selected.
Public Property | SelectedItem | Gets the item that is currently selected.
Public Property | SelectedItems | Gets a collection containing the items that are currently selected.
Public Property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.
Public Property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem
Public Property | SelectionMode | Gets or sets the selection mode.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextDropAfter |
Public Property | TextDropBefore |
Public Property | TextDropIn |
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | AddItemByPath | Overloaded. Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.
Public Method | CollapseAll | Expands all item.
Public Method | ContainerFromItemRecursive | Search recursively in the tree to get an item container (RadTreeViewItem) for a particular item.
Public Method | ExpandAll | Expands all item.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetItemByPath | Overloaded. Gets a item by specifying a path to it.
Public Method | OnApplyTemplate | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden.
Protected Method | GetContainerForItemOverride | Overridden.
Protected Method | HandleMouseMove |
Protected Method | HandleMouseUp |
Protected Method | IsItemItsOwnContainerOverride | Overridden.
Protected Method | OnDragEnded |
Protected Method | OnDragStarted |
Protected Method | OnItemsChanged | Overridden.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnPreviewDragEnded |
Protected Method | OnPreviewDragStarted |
Protected Method | OnSelectionChanged |
Protected Method | PrepareContainerForItemOverride | Overridden.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when a child treeview item has been checked.
Public Event | Collapsed | Occurs when a child treeview item has been collapsed.
Public Event | DragEnded | Occurs when the drag has ended.
Public Event | DragStarted | Occurs when the drag has started
Public Event | Edited | Occurs when a child treeview item has been edited.
Public Event | Expanded | Occurs when a child treeview item has been expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LoadOnDemand | Occurs when a child treeview item is loading its child items on demand.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewChecked | Occurs before a child treeview item is checked.
Public Event | PreviewCollapsed | Occurs before a child treeview item is collapsed.
Public Event | PreviewDragEnded | Occurs before the drag has been ended.
Public Event | PreviewDragStarted | Occurs before the drag is started
Public Event | PreviewEdited | Occurs before a child treeview item to accept the new Edited data.
Public Event | PreviewExpanded | Occurs before a child treeview item is expanded.
Public Event | PreviewSelected | Occurs before a child treeview item is selected.
Public Event | PreviewUnchecked | Occurs before a child treeview item is unchecked.
Public Event | PreviewUnselected | Occurs before a child treeview item is unselected.
Public Event | Selected | Occurs when a child treeview item has been selected.
Public Event | SelectionChanged | Occurs after the value of the SelectedItems property of a tree is changed.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unchecked | Occurs when a child treeview item has been unchecked.
Public Event | Unselected | Occurs when a child treeview item has been unselected.
Top

See Also

Reference

RadTreeView Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : RadTreeView Constructor

Initializes a new instance of the RadTreeView class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView()
C#
public RadTreeView()
Managed Extensions for C++
public: RadTreeView();
C++/CLI
public:
RadTreeView();

Remarks

Use this constructor to create and initialize a new instance of the RadTreeView control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

For a list of all members of this type, see RadTreeView members.

Public Methods

 | Name | Description
Public Method | AddItemByPath | Overloaded. Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.
Public Method | CollapseAll | Expands all item.
Public Method | ContainerFromItemRecursive | Search recursively in the tree to get an item container (RadTreeViewItem) for a particular item.
Public Method | ExpandAll | Expands all item.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetItemByPath | Overloaded. Gets a item by specifying a path to it.
Public Method | OnApplyTemplate | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden.
Protected Method | GetContainerForItemOverride | Overridden.
Protected Method | HandleMouseMove |
Protected Method | HandleMouseUp |
Protected Method | IsItemItsOwnContainerOverride | Overridden.
Protected Method | OnDragEnded |
Protected Method | OnDragStarted |
Protected Method | OnItemsChanged | Overridden.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnPreviewDragEnded |
Protected Method | OnPreviewDragStarted |
Protected Method | OnSelectionChanged |
Protected Method | PrepareContainerForItemOverride | Overridden.
Top

See Also

Reference

RadTreeView Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AddItemByPath Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : AddItemByPath Method

Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.

Overload List

Overload | Description
AddItemByPath(String) | Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.
AddItemByPath(String,String) | Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AddItemByPath(String) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class > AddItemByPath Method : AddItemByPath(String) Method

path
Where the item should be added.
Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Overloads Function AddItemByPath( _
   ByVal path As String _
) As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim path As String
Dim value As RadTreeViewItem

value = instance.AddItemByPath(path)
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem AddItemByPath(
   string path
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: RadTreeViewItem* AddItemByPath(
   string* path
)
C++/CLI
[ScriptableMemberAttribute()]
public:
RadTreeViewItem^ AddItemByPath(
   String^ path
)

Parameters

path
Where the item should be added.

Return Value

The new item if the operation is successful.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AddItemByPath(String,String) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class > AddItemByPath Method : AddItemByPath(String,String) Method

path
Where the item should be added.
separator
The path separator
Creates a new item and adds a item by path. The label of the new item will be the text after the last separator.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Overloads Function AddItemByPath( _
   ByVal path As String, _
   ByVal separator As String _
) As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim path As String
Dim separator As String
Dim value As RadTreeViewItem

value = instance.AddItemByPath(path, separator)
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem AddItemByPath(
   string path,
   string separator
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: RadTreeViewItem* AddItemByPath(
   string* path,
   string* separator
)
C++/CLI
[ScriptableMemberAttribute()]
public:
RadTreeViewItem^ AddItemByPath(
   String^ path,
   String^ separator
)

Parameters

path
Where the item should be added.
separator
The path separator

Return Value

The new item if the operation is successful.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ClearContainerForItemOverride Method

element
item

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CollapseAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : CollapseAll Method

Expands all item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub CollapseAll()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView

instance.CollapseAll()
C#
[ScriptableMemberAttribute()]
public void CollapseAll()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void CollapseAll();
C++/CLI
[ScriptableMemberAttribute()]
public:
void CollapseAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ContainerFromItemRecursive Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ContainerFromItemRecursive Method

item
the data item
Search recursively in the tree to get an item container (RadTreeViewItem) for a particular item.

Syntax

Visual Basic (Declaration)
Public Function ContainerFromItemRecursive( _
   ByVal item As Object _
) As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim item As Object
Dim value As RadTreeViewItem

value = instance.ContainerFromItemRecursive(item)
C#
public RadTreeViewItem ContainerFromItemRecursive(
   object item
)
Managed Extensions for C++
public: RadTreeViewItem* ContainerFromItemRecursive(
   Object* item
)
C++/CLI
public:
RadTreeViewItem^ ContainerFromItemRecursive(
   Object^ item
)

Parameters

item
the data item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ExpandAll Method

Expands all item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView

instance.ExpandAll()
C#
[ScriptableMemberAttribute()]
public void ExpandAll()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void ExpandAll();
C++/CLI
[ScriptableMemberAttribute()]
public:
void ExpandAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : GetContainerForItemOverride Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetItemByPath Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : GetItemByPath Method

Gets a item by specifying a path to it.

Overload List

Overload | Description
GetItemByPath(String) | Gets a item by specifying a path to it.
GetItemByPath(String,String) | Gets a item by specifying a path to it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetItemByPath(String) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class > GetItemByPath Method : GetItemByPath(String) Method

path
The path to the item.
Gets a item by specifying a path to it.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Overloads Function GetItemByPath( _
   ByVal path As String _
) As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim path As String
Dim value As RadTreeViewItem

value = instance.GetItemByPath(path)
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem GetItemByPath(
   string path
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: RadTreeViewItem* GetItemByPath(
   string* path
)
C++/CLI
[ScriptableMemberAttribute()]
public:
RadTreeViewItem^ GetItemByPath(
   String^ path
)

Parameters

path
The path to the item.

Return Value

The item if found.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetItemByPath(String,String) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class > GetItemByPath Method : GetItemByPath(String,String) Method

path
The path to the item.
separator
Gets a item by specifying a path to it.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Overloads Function GetItemByPath( _
   ByVal path As String, _
   ByVal separator As String _
) As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim path As String
Dim separator As String
Dim value As RadTreeViewItem

value = instance.GetItemByPath(path, separator)
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem GetItemByPath(
   string path,
   string separator
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: RadTreeViewItem* GetItemByPath(
   string* path,
   string* separator
)
C++/CLI
[ScriptableMemberAttribute()]
public:
RadTreeViewItem^ GetItemByPath(
   String^ path,
   String^ separator
)

Parameters

path
The path to the item.
separator

Return Value

The item if found.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HandleMouseMove Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : HandleMouseMove Method

e

Syntax

Visual Basic (Declaration)
Protected Sub HandleMouseMove( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As MouseEventArgs

instance.HandleMouseMove(e)
C#
protected void HandleMouseMove(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void HandleMouseMove(
   MouseEventArgs* e
)
C++/CLI
protected:
void HandleMouseMove(
   MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HandleMouseUp Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : HandleMouseUp Method

e

Syntax

Visual Basic (Declaration)
Protected Sub HandleMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As MouseEventArgs

instance.HandleMouseUp(e)
C#
protected void HandleMouseUp(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void HandleMouseUp(
   MouseEventArgs* e
)
C++/CLI
protected:
void HandleMouseUp(
   MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsItemItsOwnContainerOverride Method

item

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnApplyTemplate Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnDragEnded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnDragEnded Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDragEnded( _
   ByVal e As RadTreeViewDragEndedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As RadTreeViewDragEndedEventArgs

instance.OnDragEnded(e)
C#
protected virtual void OnDragEnded(
   RadTreeViewDragEndedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDragEnded(
   RadTreeViewDragEndedEventArgs* e
)
C++/CLI
protected:
virtual void OnDragEnded(
   RadTreeViewDragEndedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnDragStarted Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnDragStarted Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDragStarted( _
   ByVal e As RadTreeViewDragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As RadTreeViewDragEventArgs

instance.OnDragStarted(e)
C#
protected virtual void OnDragStarted(
   RadTreeViewDragEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDragStarted(
   RadTreeViewDragEventArgs* e
)
C++/CLI
protected:
virtual void OnDragStarted(
   RadTreeViewDragEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnItemsChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewDragEnded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnPreviewDragEnded Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewDragEnded( _
   ByVal e As RadTreeViewDragEndedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As RadTreeViewDragEndedEventArgs
Dim value As Boolean

value = instance.OnPreviewDragEnded(e)
C#
protected virtual bool OnPreviewDragEnded(
   RadTreeViewDragEndedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewDragEnded(
   RadTreeViewDragEndedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewDragEnded(
   RadTreeViewDragEndedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewDragStarted Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnPreviewDragStarted Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewDragStarted( _
   ByVal e As RadTreeViewDragEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As RadTreeViewDragEventArgs
Dim value As Boolean

value = instance.OnPreviewDragStarted(e)
C#
protected virtual bool OnPreviewDragStarted(
   RadTreeViewDragEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewDragStarted(
   RadTreeViewDragEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewDragStarted(
   RadTreeViewDragEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelectionChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : OnSelectionChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
C#
protected virtual void OnSelectionChanged(
   SelectionChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectionChanged(
   SelectionChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelectionChanged(
   SelectionChangedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PrepareContainerForItemOverride Method

element
item

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

For a list of all members of this type, see RadTreeView members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpanderStyle | Gets or sets the style of RadTreeViewItem expander button
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | ImagesBaseDir | The directory where image files used in the treeview reside
Public Property | IsDragDropEnabled | Gets or sets a value indicating whether drag and drop is enabled.
Public Property | IsDragPreviewEnabled | Gets or sets a value indicating whether drag feedback is shown while dragging.
Public Property | IsDragTooltipEnabled | Gets or sets a value indicating whether drag tooltip is shown while dragging.
Public Property | IsDropPreviewLineEnabled | Gets or sets a value indicating whether drag outline is shown while dragging.
Public Property | IsEditable | Gets or sets a value indicating whether the user can edit the text of item.
Public Property | IsEditing | Gets if there is an open editor in the tree view.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface.
Public Property | IsExpandOnDblClickEnabled | Gets or sets a value whether the item will toggle its expand state on double click
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsLineEnabled | Gets or sets a value indicating whether lines are displayed between item.
Public Property | IsLoadOnDemandEnabled | Gets or sets a value indicating whether loading on demand is enabled.
Public Property | IsOptionElementsEnabled | Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.
Public Property | IsRootLinesEnabled | Gets or sets a value indicating whether lines are displayed next to root item.
Public Property | IsSingleExpandPath | Gets a value indicating whether only the current branch of the treeview is expanded.
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | IsTriStateMode | Gets or sets a value indicating whether tri state mode of the option lists is enabled.
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsIndent | Gets or sets the distance to indent each of the tree item levels.
Public Property | ItemsOptionListType | Gets or sets the type of option list formed by itemContainer item.
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PathSeparator | Gets or sets the delimiter string that the tree item path uses. The tree item path contains of a set of tree item labels separated by the PathSeparator delimiter strings. The default return value is the backslash character (\).
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollViewer | Gets the scrollviewer control the is inside the RadTreeView
Public Property | SelectedContainer | Gets the itemContainer that is currently selected.
Public Property | SelectedItem | Gets the item that is currently selected.
Public Property | SelectedItems | Gets a collection containing the items that are currently selected.
Public Property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.
Public Property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem
Public Property | SelectionMode | Gets or sets the selection mode.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextDropAfter |
Public Property | TextDropBefore |
Public Property | TextDropIn |
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadTreeView Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpanderStyle Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ExpanderStyle Property

Gets or sets the style of RadTreeViewItem expander button

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the style of RadTreeViewItem expander button")>
<BrowsableAttribute(False)>
Public Property ExpanderStyle As Style
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Style

instance.ExpanderStyle = value

value = instance.ExpanderStyle
C#
[DescriptionAttribute("Gets or sets the style of RadTreeViewItem expander button")]
[BrowsableAttribute(false)]
public Style ExpanderStyle {get; set;}
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the style of RadTreeViewItem expander button")]
[BrowsableAttribute(false)]
public: __property Style* get_ExpanderStyle();
public: __property void set_ExpanderStyle(
   Style* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the style of RadTreeViewItem expander button")]
[BrowsableAttribute(false)]
public:
property Style^ ExpanderStyle {
   Style^ get();
   void set (Style^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ImagesBaseDir Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ImagesBaseDir Property

The directory where image files used in the treeview reside

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The directory where image files used in the treeview reside")>
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
Public Property ImagesBaseDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.ImagesBaseDir = value

value = instance.ImagesBaseDir
C#
[DescriptionAttribute("The directory where image files used in the treeview reside")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
public string ImagesBaseDir {get; set;}
Managed Extensions for C++
[DescriptionAttribute("The directory where image files used in the treeview reside")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
public: __property string* get_ImagesBaseDir();
public: __property void set_ImagesBaseDir(
   string* value
);
C++/CLI
[DescriptionAttribute("The directory where image files used in the treeview reside")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
public:
property String^ ImagesBaseDir {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragDropEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragDropEnabled Property

Gets or sets a value indicating whether drag and drop is enabled.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether drag and drop is enabled.")>
Public Property IsDragDropEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsDragDropEnabled = value

value = instance.IsDragDropEnabled
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag and drop is enabled.")]
public bool IsDragDropEnabled {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag and drop is enabled.")]
public: __property bool get_IsDragDropEnabled();
public: __property void set_IsDragDropEnabled(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag and drop is enabled.")]
public:
property bool IsDragDropEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragPreviewEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragPreviewEnabled Property

Gets or sets a value indicating whether drag feedback is shown while dragging.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether drag feedback is shown while dragging.")>
Public Property IsDragPreviewEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsDragPreviewEnabled = value

value = instance.IsDragPreviewEnabled
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag feedback is shown while dragging.")]
public bool IsDragPreviewEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag feedback is shown while dragging.")]
public: __property bool get_IsDragPreviewEnabled();
public: __property void set_IsDragPreviewEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag feedback is shown while dragging.")]
public:
property bool IsDragPreviewEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragTooltipEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragTooltipEnabled Property

Gets or sets a value indicating whether drag tooltip is shown while dragging.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether drag tooltip is shown while dragging.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
Public Property IsDragTooltipEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsDragTooltipEnabled = value

value = instance.IsDragTooltipEnabled
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag tooltip is shown while dragging.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public bool IsDragTooltipEnabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag tooltip is shown while dragging.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_IsDragTooltipEnabled();
public: __property void set_IsDragTooltipEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag tooltip is shown while dragging.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool IsDragTooltipEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDropPreviewLineEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDropPreviewLineEnabled Property

Gets or sets a value indicating whether drag outline is shown while dragging.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether drag outline is shown while dragging.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property IsDropPreviewLineEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsDropPreviewLineEnabled = value

value = instance.IsDropPreviewLineEnabled
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag outline is shown while dragging.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool IsDropPreviewLineEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag outline is shown while dragging.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_IsDropPreviewLineEnabled();
public: __property void set_IsDropPreviewLineEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether drag outline is shown while dragging.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool IsDropPreviewLineEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEditable Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsEditable Property

Gets or sets a value indicating whether the user can edit the text of item.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Gets or sets a value indicating whether the user can edit the text of item.")>
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
Public Property IsEditable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsEditable = value

value = instance.IsEditable
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the user can edit the text of item.")]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public bool IsEditable {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the user can edit the text of item.")]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public: __property bool get_IsEditable();
public: __property void set_IsEditable(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the user can edit the text of item.")]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public:
property bool IsEditable {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEditing Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsEditing Property

Gets if there is an open editor in the tree view.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets if there is an open editor in the tree view.")>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property IsEditing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

value = instance.IsEditing
C#
[DescriptionAttribute("Gets if there is an open editor in the tree view.")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool IsEditing {get;}
Managed Extensions for C++
[DescriptionAttribute("Gets if there is an open editor in the tree view.")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsEditing();
C++/CLI
[DescriptionAttribute("Gets if there is an open editor in the tree view.")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsEditing {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsEnabled Property

Gets or sets a value indicating whether this element is enabled in the user interface.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[ScriptableMemberAttribute()]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpandOnDblClickEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsExpandOnDblClickEnabled Property

Gets or sets a value whether the item will toggle its expand state on double click

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value whether the item will toggle its expand state on double click.")>
Public Property IsExpandOnDblClickEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsExpandOnDblClickEnabled = value

value = instance.IsExpandOnDblClickEnabled
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value whether the item will toggle its expand state on double click.")]
public bool IsExpandOnDblClickEnabled {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value whether the item will toggle its expand state on double click.")]
public: __property bool get_IsExpandOnDblClickEnabled();
public: __property void set_IsExpandOnDblClickEnabled(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value whether the item will toggle its expand state on double click.")]
public:
property bool IsExpandOnDblClickEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLineEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsLineEnabled Property

Gets or sets a value indicating whether lines are displayed between item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether lines are displayed between item.")>
<CategoryAttribute("Behavior")>
Public Property IsLineEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsLineEnabled = value

value = instance.IsLineEnabled
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed between item.")]
[CategoryAttribute("Behavior")]
public bool IsLineEnabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed between item.")]
[CategoryAttribute("Behavior")]
public: __property bool get_IsLineEnabled();
public: __property void set_IsLineEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed between item.")]
[CategoryAttribute("Behavior")]
public:
property bool IsLineEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadOnDemandEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsLoadOnDemandEnabled Property

Gets or sets a value indicating whether loading on demand is enabled.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")>
Public Property IsLoadOnDemandEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsLoadOnDemandEnabled = value

value = instance.IsLoadOnDemandEnabled
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
public bool IsLoadOnDemandEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
public: __property bool get_IsLoadOnDemandEnabled();
public: __property void set_IsLoadOnDemandEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
public:
property bool IsLoadOnDemandEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsOptionElementsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsOptionElementsEnabled Property

Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.")>
<ScriptableMemberAttribute()>
Public Property IsOptionElementsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsOptionElementsEnabled = value

value = instance.IsOptionElementsEnabled
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.")]
[ScriptableMemberAttribute()]
public bool IsOptionElementsEnabled {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.")]
[ScriptableMemberAttribute()]
public: __property bool get_IsOptionElementsEnabled();
public: __property void set_IsOptionElementsEnabled(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether checkboxes/radio buttons are displayed besides item.")]
[ScriptableMemberAttribute()]
public:
property bool IsOptionElementsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRootLinesEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsRootLinesEnabled Property

Gets or sets a value indicating whether lines are displayed next to root item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Gets or sets a value indicating whether lines are displayed next to root item.")>
Public Property IsRootLinesEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsRootLinesEnabled = value

value = instance.IsRootLinesEnabled
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed next to root item.")]
public bool IsRootLinesEnabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed next to root item.")]
public: __property bool get_IsRootLinesEnabled();
public: __property void set_IsRootLinesEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether lines are displayed next to root item.")]
public:
property bool IsRootLinesEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSingleExpandPath Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsSingleExpandPath Property

Gets a value indicating whether only the current branch of the treeview is expanded.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("When set to true, automatically collapses all item that are not part of the last expanded item path.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Functionality")>
Public Property IsSingleExpandPath As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsSingleExpandPath = value

value = instance.IsSingleExpandPath
C#
[DefaultValueAttribute()]
[DescriptionAttribute("When set to true, automatically collapses all item that are not part of the last expanded item path.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Functionality")]
public bool IsSingleExpandPath {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("When set to true, automatically collapses all item that are not part of the last expanded item path.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Functionality")]
public: __property bool get_IsSingleExpandPath();
public: __property void set_IsSingleExpandPath(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("When set to true, automatically collapses all item that are not part of the last expanded item path.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Functionality")]
public:
property bool IsSingleExpandPath {
   bool get();
   void set (bool value);
}

Remarks

The property closes all item that are not parents of the last expanded item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsTriStateMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsTriStateMode Property

Gets or sets a value indicating whether tri state mode of the option lists is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether tri state mode of the option lists  is enabled.")>
<CategoryAttribute("Behavior")>
Public Property IsTriStateMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Boolean

instance.IsTriStateMode = value

value = instance.IsTriStateMode
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether tri state mode of the option lists  is enabled.")]
[CategoryAttribute("Behavior")]
public bool IsTriStateMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether tri state mode of the option lists  is enabled.")]
[CategoryAttribute("Behavior")]
public: __property bool get_IsTriStateMode();
public: __property void set_IsTriStateMode(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether tri state mode of the option lists  is enabled.")]
[CategoryAttribute("Behavior")]
public:
property bool IsTriStateMode {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsIndent Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ItemsIndent Property

Gets or sets the distance to indent each of the tree item levels.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the distance to indent each of the tree item levels.")>
Public Property ItemsIndent As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Integer

instance.ItemsIndent = value

value = instance.ItemsIndent
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the distance to indent each of the tree item levels.")]
public int ItemsIndent {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the distance to indent each of the tree item levels.")]
public: __property int get_ItemsIndent();
public: __property void set_ItemsIndent(
   int value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the distance to indent each of the tree item levels.")]
public:
property int ItemsIndent {
   int get();
   void set (int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsOptionListType Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ItemsOptionListType Property

Gets or sets the type of option list formed by itemContainer item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property ItemsOptionListType As OptionListType
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As OptionListType

instance.ItemsOptionListType = value

value = instance.ItemsOptionListType
C#
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public OptionListType ItemsOptionListType {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property OptionListType get_ItemsOptionListType();
public: __property void set_ItemsOptionListType(
   OptionListType value
);
C++/CLI
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property OptionListType ItemsOptionListType {
   OptionListType get();
   void set (OptionListType value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PathSeparator Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PathSeparator Property

Gets or sets the delimiter string that the tree item path uses. The tree item path contains of a set of tree item labels separated by the PathSeparator delimiter strings. The default return value is the backslash character (\).

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the value of the path separator.")>
Public Property PathSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.PathSeparator = value

value = instance.PathSeparator
C#
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the value of the path separator.")]
public string PathSeparator {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the value of the path separator.")]
public: __property string* get_PathSeparator();
public: __property void set_PathSeparator(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the value of the path separator.")]
public:
property String^ PathSeparator {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ScrollViewer Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ScrollViewer Property

Gets the scrollviewer control the is inside the RadTreeView

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property ScrollViewer As ScrollViewer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As ScrollViewer

value = instance.ScrollViewer
C#
[ScriptableMemberAttribute()]
public ScrollViewer ScrollViewer {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property ScrollViewer* get_ScrollViewer();
C++/CLI
[ScriptableMemberAttribute()]
public:
property ScrollViewer^ ScrollViewer {
   ScrollViewer^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedContainer Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedContainer Property

Gets the itemContainer that is currently selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property SelectedContainer As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As RadTreeViewItem

value = instance.SelectedContainer
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem SelectedContainer {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property RadTreeViewItem* get_SelectedContainer();
C++/CLI
[ScriptableMemberAttribute()]
public:
property RadTreeViewItem^ SelectedContainer {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedItem Property

Gets the item that is currently selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the item that is currently selected.")>
Public ReadOnly Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Object

value = instance.SelectedItem
C#
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the item that is currently selected.")]
public object SelectedItem {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the item that is currently selected.")]
public: __property Object* get_SelectedItem();
C++/CLI
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the item that is currently selected.")]
public:
property Object^ SelectedItem {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedItems Property

Gets a collection containing the items that are currently selected.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<CategoryAttribute("Behaviour")>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets a collection containing the items that are currently selected.")>
<DefaultValueAttribute()>
Public ReadOnly Property SelectedItems As ObservableCollection(Of Object)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As ObservableCollection(Of Object)

value = instance.SelectedItems
C#
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behaviour")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets a collection containing the items that are currently selected.")]
[DefaultValueAttribute()]
public ObservableCollection<object> SelectedItems {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behaviour")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets a collection containing the items that are currently selected.")]
[DefaultValueAttribute()]
public: __property ObservableCollection<Object*>* get_SelectedItems();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behaviour")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets a collection containing the items that are currently selected.")]
[DefaultValueAttribute()]
public:
property ObservableCollection<Object^>^ SelectedItems {
   ObservableCollection<Object^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValue Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedValue Property

Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property SelectedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As Object

value = instance.SelectedValue
C#
[ScriptableMemberAttribute()]
public object SelectedValue {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property Object* get_SelectedValue();
C++/CLI
[ScriptableMemberAttribute()]
public:
property Object^ SelectedValue {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValuePath Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedValuePath Property

Gets or sets the path that is used to get the SelectedValue from the SelectedItem

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property SelectedValuePath As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.SelectedValuePath = value

value = instance.SelectedValuePath
C#
[ScriptableMemberAttribute()]
public string SelectedValuePath {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_SelectedValuePath();
public: __property void set_SelectedValuePath(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ SelectedValuePath {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectionMode Property

Gets or sets the selection mode.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the selection mode.")>
Public Property SelectionMode As SelectionMode
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As SelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the selection mode.")]
public SelectionMode SelectionMode {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the selection mode.")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the selection mode.")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (SelectionMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TextDropAfter Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : TextDropAfter Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<ScriptableMemberAttribute()>
Public Property TextDropAfter As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.TextDropAfter = value

value = instance.TextDropAfter
C#
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public string TextDropAfter {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public: __property string* get_TextDropAfter();
public: __property void set_TextDropAfter(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public:
property String^ TextDropAfter {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TextDropBefore Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : TextDropBefore Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<ScriptableMemberAttribute()>
Public Property TextDropBefore As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.TextDropBefore = value

value = instance.TextDropBefore
C#
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public string TextDropBefore {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public: __property string* get_TextDropBefore();
public: __property void set_TextDropBefore(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public:
property String^ TextDropBefore {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TextDropIn Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : TextDropIn Property

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<ScriptableMemberAttribute()>
Public Property TextDropIn As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim value As String

instance.TextDropIn = value

value = instance.TextDropIn
C#
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public string TextDropIn {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public: __property string* get_TextDropIn();
public: __property void set_TextDropIn(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
[ScriptableMemberAttribute()]
public:
property String^ TextDropIn {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

For a list of all members of this type, see RadTreeView members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DragEndedEvent | Identifies the DragEnded routed event.
static (Shared in Visual Basic) | DragStartedEvent | Identifies the DragStarted routed event.
static (Shared in Visual Basic) | ExpanderStyleProperty | Identifies the ExpanderStyle dependency property.
static (Shared in Visual Basic) | ImagesBaseDirProperty | Identifies the ImagesBaseDir dependency property.
static (Shared in Visual Basic) | IsDragDropBetweenTreeViewsAllowedProperty | Identifies the IsDragDropBetweenTreeViewsAllowed dependency property.
static (Shared in Visual Basic) | IsDragDropEnabledProperty | Identifies the IsDragDropEnabled dependency property.
static (Shared in Visual Basic) | IsDragPreviewEnabledProperty | Identifies the IsDragPreviewEnabled dependency property.
static (Shared in Visual Basic) | IsDragTooltipEnabledProperty | Identifies the IsDragTooltipEnabled dependency property.
static (Shared in Visual Basic) | IsDropPreviewLineEnabledProperty | Identifies the IsDropPreviewLineEnabled dependency property.
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandOnDblClickEnabledProperty | Identifies the IsExpandOnDblClickEnabled dependency property.
static (Shared in Visual Basic) | IsIncrementalSearchEnabledProperty | Identifies the IsIncrementalSearchEnabled dependency property.
static (Shared in Visual Basic) | IsLineEnabledProperty | Identifies the IsLineEnabled dependency property.
static (Shared in Visual Basic) | IsLoadOnDemandEnabledProperty | Identifies the IsLoadOnDemandEnabled dependency property.
static (Shared in Visual Basic) | IsOptionElementsEnabledProperty | Identifies the IsOptionElementsEnabled dependency property.
static (Shared in Visual Basic) | IsRootLinesEnabledProperty | Identifies the IsRootLinesEnabled dependency property.
static (Shared in Visual Basic) | IsSingleExpandPathProperty | Identifies the IsSingleExpandPath dependency property.
static (Shared in Visual Basic) | IsTriStateModeProperty | Identifies the IsTriStateMode dependency property.
static (Shared in Visual Basic) | ItemsIndentProperty | Identifies the ItemsIndent dependency property.
static (Shared in Visual Basic) | ItemsOptionListTypeProperty | Identifies the ItemsOptionListType dependency property.
static (Shared in Visual Basic) | PathSeparatorProperty | Identifies the PathSeparator dependency property.
static (Shared in Visual Basic) | PreviewDragEndedEvent | Identifies the PreviewDragEnded routed event.
static (Shared in Visual Basic) | PreviewDragStartedEvent | Identifies the PreviewDragStarted routed event.
static (Shared in Visual Basic) | SelectedItemsProperty | Identifies the SelectedItemsProperty dependency property.
static (Shared in Visual Basic) | SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
static (Shared in Visual Basic) | SelectedValueProperty | Identifies the SelectedValue dependency property.
static (Shared in Visual Basic) | SelectionChangedEvent | Identifies the SelectionChanged routed event.
static (Shared in Visual Basic) | SelectionModeProperty | Identifies the SelectionMode dependency property.
Top

See Also

Reference

RadTreeView Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DragEndedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : DragEndedEvent Field

Identifies the DragEnded routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DragEndedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeView.DragEndedEvent
C#
public static readonly RoutedEvent DragEndedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* DragEndedEvent
C++/CLI
public:
static readonly RoutedEvent^ DragEndedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DragStartedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : DragStartedEvent Field

Identifies the DragStarted routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DragStartedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeView.DragStartedEvent
C#
public static readonly RoutedEvent DragStartedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* DragStartedEvent
C++/CLI
public:
static readonly RoutedEvent^ DragStartedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpanderStyleProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ExpanderStyleProperty Field

Identifies the ExpanderStyle dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpanderStyleProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.ExpanderStyleProperty
C#
public static readonly DependencyProperty ExpanderStyleProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ExpanderStyleProperty
C++/CLI
public:
static readonly DependencyProperty^ ExpanderStyleProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ImagesBaseDirProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ImagesBaseDirProperty Field

Identifies the ImagesBaseDir dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ImagesBaseDirProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.ImagesBaseDirProperty
C#
public static readonly DependencyProperty ImagesBaseDirProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ImagesBaseDirProperty
C++/CLI
public:
static readonly DependencyProperty^ ImagesBaseDirProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragDropBetweenTreeViewsAllowedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragDropBetweenTreeViewsAllowedProperty Field

Identifies the IsDragDropBetweenTreeViewsAllowed dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDragDropBetweenTreeViewsAllowedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsDragDropBetweenTreeViewsAllowedProperty
C#
public static readonly DependencyProperty IsDragDropBetweenTreeViewsAllowedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDragDropBetweenTreeViewsAllowedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDragDropBetweenTreeViewsAllowedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragDropEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragDropEnabledProperty Field

Identifies the IsDragDropEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDragDropEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsDragDropEnabledProperty
C#
public static readonly DependencyProperty IsDragDropEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDragDropEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDragDropEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragPreviewEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragPreviewEnabledProperty Field

Identifies the IsDragPreviewEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDragPreviewEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsDragPreviewEnabledProperty
C#
public static readonly DependencyProperty IsDragPreviewEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDragPreviewEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDragPreviewEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDragTooltipEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDragTooltipEnabledProperty Field

Identifies the IsDragTooltipEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDragTooltipEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsDragTooltipEnabledProperty
C#
public static readonly DependencyProperty IsDragTooltipEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDragTooltipEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDragTooltipEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDropPreviewLineEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsDropPreviewLineEnabledProperty Field

Identifies the IsDropPreviewLineEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDropPreviewLineEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsDropPreviewLineEnabledProperty
C#
public static readonly DependencyProperty IsDropPreviewLineEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDropPreviewLineEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDropPreviewLineEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEditableProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsEditableProperty Field

Identifies the IsEditable dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEditableProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsEditableProperty
C#
public static readonly DependencyProperty IsEditableProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEditableProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEditableProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpandOnDblClickEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsExpandOnDblClickEnabledProperty Field

Identifies the IsExpandOnDblClickEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsExpandOnDblClickEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsExpandOnDblClickEnabledProperty
C#
public static readonly DependencyProperty IsExpandOnDblClickEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsExpandOnDblClickEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsExpandOnDblClickEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsIncrementalSearchEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsIncrementalSearchEnabledProperty Field

Identifies the IsIncrementalSearchEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsIncrementalSearchEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsIncrementalSearchEnabledProperty
C#
public static readonly DependencyProperty IsIncrementalSearchEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsIncrementalSearchEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsIncrementalSearchEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLineEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsLineEnabledProperty Field

Identifies the IsLineEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsLineEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsLineEnabledProperty
C#
public static readonly DependencyProperty IsLineEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsLineEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsLineEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadOnDemandEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsLoadOnDemandEnabledProperty Field

Identifies the IsLoadOnDemandEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsLoadOnDemandEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsLoadOnDemandEnabledProperty
C#
public static readonly DependencyProperty IsLoadOnDemandEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsLoadOnDemandEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsLoadOnDemandEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsOptionElementsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsOptionElementsEnabledProperty Field

Identifies the IsOptionElementsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsOptionElementsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsOptionElementsEnabledProperty
C#
public static readonly DependencyProperty IsOptionElementsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsOptionElementsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsOptionElementsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRootLinesEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsRootLinesEnabledProperty Field

Identifies the IsRootLinesEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRootLinesEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsRootLinesEnabledProperty
C#
public static readonly DependencyProperty IsRootLinesEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRootLinesEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRootLinesEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSingleExpandPathProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsSingleExpandPathProperty Field

Identifies the IsSingleExpandPath dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSingleExpandPathProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsSingleExpandPathProperty
C#
public static readonly DependencyProperty IsSingleExpandPathProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSingleExpandPathProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSingleExpandPathProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsTriStateModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : IsTriStateModeProperty Field

Identifies the IsTriStateMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsTriStateModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.IsTriStateModeProperty
C#
public static readonly DependencyProperty IsTriStateModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsTriStateModeProperty
C++/CLI
public:
static readonly DependencyProperty^ IsTriStateModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsIndentProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ItemsIndentProperty Field

Identifies the ItemsIndent dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemsIndentProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.ItemsIndentProperty
C#
public static readonly DependencyProperty ItemsIndentProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemsIndentProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemsIndentProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsOptionListTypeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : ItemsOptionListTypeProperty Field

Identifies the ItemsOptionListType dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemsOptionListTypeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.ItemsOptionListTypeProperty
C#
public static readonly DependencyProperty ItemsOptionListTypeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemsOptionListTypeProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemsOptionListTypeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PathSeparatorProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PathSeparatorProperty Field

Identifies the PathSeparator dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PathSeparatorProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.PathSeparatorProperty
C#
public static readonly DependencyProperty PathSeparatorProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PathSeparatorProperty
C++/CLI
public:
static readonly DependencyProperty^ PathSeparatorProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewDragEndedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewDragEndedEvent Field

Identifies the PreviewDragEnded routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewDragEndedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeView.PreviewDragEndedEvent
C#
public static readonly RoutedEvent PreviewDragEndedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewDragEndedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewDragEndedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewDragStartedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewDragStartedEvent Field

Identifies the PreviewDragStarted routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewDragStartedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeView.PreviewDragStartedEvent
C#
public static readonly RoutedEvent PreviewDragStartedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewDragStartedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewDragStartedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedItemsProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedItemsProperty Field

Identifies the SelectedItemsProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemsProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.SelectedItemsProperty
C#
public static readonly DependencyProperty SelectedItemsProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedItemsProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedItemsProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValuePathProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedValuePathProperty Field

Identifies the SelectedValuePath dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedValuePathProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.SelectedValuePathProperty
C#
public static readonly DependencyProperty SelectedValuePathProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedValuePathProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedValuePathProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedValueProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectedValueProperty Field

Identifies the SelectedValue dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedValueProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.SelectedValueProperty
C#
public static readonly DependencyProperty SelectedValueProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedValueProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedValueProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectionChangedEvent Field

Identifies the SelectionChanged routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeView.SelectionChangedEvent
C#
public static readonly RoutedEvent SelectionChangedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SelectionChangedEvent
C++/CLI
public:
static readonly RoutedEvent^ SelectionChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectionModeProperty Field

Identifies the SelectionMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeView.SelectionModeProperty
C#
public static readonly DependencyProperty SelectionModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectionModeProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectionModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeView Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeView Class

For a list of all members of this type, see RadTreeView members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when a child treeview item has been checked.
Public Event | Collapsed | Occurs when a child treeview item has been collapsed.
Public Event | DragEnded | Occurs when the drag has ended.
Public Event | DragStarted | Occurs when the drag has started
Public Event | Edited | Occurs when a child treeview item has been edited.
Public Event | Expanded | Occurs when a child treeview item has been expanded.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LoadOnDemand | Occurs when a child treeview item is loading its child items on demand.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewChecked | Occurs before a child treeview item is checked.
Public Event | PreviewCollapsed | Occurs before a child treeview item is collapsed.
Public Event | PreviewDragEnded | Occurs before the drag has been ended.
Public Event | PreviewDragStarted | Occurs before the drag is started
Public Event | PreviewEdited | Occurs before a child treeview item to accept the new Edited data.
Public Event | PreviewExpanded | Occurs before a child treeview item is expanded.
Public Event | PreviewSelected | Occurs before a child treeview item is selected.
Public Event | PreviewUnchecked | Occurs before a child treeview item is unchecked.
Public Event | PreviewUnselected | Occurs before a child treeview item is unselected.
Public Event | Selected | Occurs when a child treeview item has been selected.
Public Event | SelectionChanged | Occurs after the value of the SelectedItems property of a tree is changed.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unchecked | Occurs when a child treeview item has been unchecked.
Public Event | Unselected | Occurs when a child treeview item has been unselected.
Top

See Also

Reference

RadTreeView Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Checked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Checked Event

Occurs when a child treeview item has been checked.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Checked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Checked, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Checked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Checked
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Checked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Collapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Collapsed Event

Occurs when a child treeview item has been collapsed.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Collapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Collapsed, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Collapsed()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Collapsed
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Collapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DragEnded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : DragEnded Event

Occurs when the drag has ended.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when the drag has ended.")>
<ScriptableMemberAttribute()>
Public Event DragEnded() As RadTreeViewDragEndedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewDragEndedEventHandler

AddHandler instance.DragEnded, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has ended.")]
[ScriptableMemberAttribute()]
public event RadTreeViewDragEndedEventHandler DragEnded()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has ended.")]
[ScriptableMemberAttribute()]
public: __event RadTreeViewDragEndedEventHandler* DragEnded
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has ended.")]
[ScriptableMemberAttribute()]
public:
event RadTreeViewDragEndedEventHandler^ DragEnded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DragStarted Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : DragStarted Event

Occurs when the drag has started

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when the drag has started.")>
<ScriptableMemberAttribute()>
Public Event DragStarted() As RadTreeViewDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewDragEventHandler

AddHandler instance.DragStarted, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has started.")]
[ScriptableMemberAttribute()]
public event RadTreeViewDragEventHandler DragStarted()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has started.")]
[ScriptableMemberAttribute()]
public: __event RadTreeViewDragEventHandler* DragStarted
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the drag has started.")]
[ScriptableMemberAttribute()]
public:
event RadTreeViewDragEventHandler^ DragStarted

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Edited Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Edited Event

Occurs when a child treeview item has been edited.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Edited() As RadTreeViewItemEditedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewItemEditedEventHandler

AddHandler instance.Edited, handler
C#
[ScriptableMemberAttribute()]
public event RadTreeViewItemEditedEventHandler Edited()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event RadTreeViewItemEditedEventHandler* Edited
C++/CLI
[ScriptableMemberAttribute()]
public:
event RadTreeViewItemEditedEventHandler^ Edited

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Expanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Expanded Event

Occurs when a child treeview item has been expanded.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Expanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Expanded, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Expanded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Expanded
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Expanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LoadOnDemand Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : LoadOnDemand Event

Occurs when a child treeview item is loading its child items on demand.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event LoadOnDemand() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.LoadOnDemand, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> LoadOnDemand()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* LoadOnDemand
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ LoadOnDemand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewChecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewChecked Event

Occurs before a child treeview item is checked.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewChecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewChecked, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewChecked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewChecked
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewChecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewCollapsed Event

Occurs before a child treeview item is collapsed.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewCollapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewCollapsed, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewCollapsed()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewCollapsed
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewCollapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewDragEnded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewDragEnded Event

Occurs before the drag has been ended.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs before the drag has been ended.")>
Public Event PreviewDragEnded() As RadTreeViewDragEndedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewDragEndedEventHandler

AddHandler instance.PreviewDragEnded, handler
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the drag has been ended.")]
public event RadTreeViewDragEndedEventHandler PreviewDragEnded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the drag has been ended.")]
public: __event RadTreeViewDragEndedEventHandler* PreviewDragEnded
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the drag has been ended.")]
public:
event RadTreeViewDragEndedEventHandler^ PreviewDragEnded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewDragStarted Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewDragStarted Event

Occurs before the drag is started

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs before the drag is started.")>
Public Event PreviewDragStarted() As RadTreeViewDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewDragEventHandler

AddHandler instance.PreviewDragStarted, handler
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before the drag is started.")]
public event RadTreeViewDragEventHandler PreviewDragStarted()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before the drag is started.")]
public: __event RadTreeViewDragEventHandler* PreviewDragStarted
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before the drag is started.")]
public:
event RadTreeViewDragEventHandler^ PreviewDragStarted

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewEdited Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewEdited Event

Occurs before a child treeview item to accept the new Edited data.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewEdited() As RadTreeViewItemEditedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As RadTreeViewItemEditedEventHandler

AddHandler instance.PreviewEdited, handler
C#
[ScriptableMemberAttribute()]
public event RadTreeViewItemEditedEventHandler PreviewEdited()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event RadTreeViewItemEditedEventHandler* PreviewEdited
C++/CLI
[ScriptableMemberAttribute()]
public:
event RadTreeViewItemEditedEventHandler^ PreviewEdited

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewExpanded Event

Occurs before a child treeview item is expanded.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewExpanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewExpanded, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewExpanded()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewExpanded
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewExpanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewSelected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewSelected Event

Occurs before a child treeview item is selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewSelected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewSelected, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewSelected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewSelected
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewSelected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUnchecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewUnchecked Event

Occurs before a child treeview item is unchecked.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewUnchecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewUnchecked, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewUnchecked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewUnchecked
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewUnchecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUnselected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : PreviewUnselected Event

Occurs before a child treeview item is unselected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event PreviewUnselected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewUnselected, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> PreviewUnselected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewUnselected
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewUnselected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Selected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Selected Event

Occurs when a child treeview item has been selected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Selected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Selected, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Selected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Selected
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Selected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectionChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : SelectionChanged Event

Occurs after the value of the SelectedItems property of a tree is changed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs after the value of the SelectedItems property of a tree is changed.")>
<ScriptableMemberAttribute()>
Public Event SelectionChanged() As SelectionChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As SelectionChangedEventHandler

AddHandler instance.SelectionChanged, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs after the value of the SelectedItems property of a tree is changed.")]
[ScriptableMemberAttribute()]
public event SelectionChangedEventHandler SelectionChanged()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs after the value of the SelectedItems property of a tree is changed.")]
[ScriptableMemberAttribute()]
public: __event SelectionChangedEventHandler* SelectionChanged
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs after the value of the SelectedItems property of a tree is changed.")]
[ScriptableMemberAttribute()]
public:
event SelectionChangedEventHandler^ SelectionChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Unchecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Unchecked Event

Occurs when a child treeview item has been unchecked.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Unchecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Unchecked, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Unchecked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Unchecked
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Unchecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Unselected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeView Class : Unselected Event

Occurs when a child treeview item has been unselected.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Event Unselected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeView
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Unselected, handler
C#
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Unselected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Unselected
C++/CLI
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Unselected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeView Class
RadTreeView Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewAutomationPeer Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewAutomationPeer Class

Syntax

Visual Basic (Declaration)
Public Class RadTreeViewAutomationPeer
   Inherits FrameworkElementAutomationPeer
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewAutomationPeer
C#
public class RadTreeViewAutomationPeer : FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadTreeViewAutomationPeer : public FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadTreeViewAutomationPeer : public FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.Automation.Peers.AutomationPeer
System.Windows.Automation.Peers.FrameworkElementAutomationPeer
Telerik.Windows.Controls.RadTreeViewAutomationPeer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewAutomationPeer Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls Namespace : RadTreeViewAutomationPeer Class

The following tables list the members exposed by RadTreeViewAutomationPeer.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewAutomationPeer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Owner | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Top

Public Methods

 | Name | Description
Public Method | GetPattern | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetAcceleratorKeyCore | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Protected Method | GetAutomationControlTypeCore | Overridden.
Protected Method | GetChildrenCore | Overridden.
Protected Method | GetClassNameCore | Overridden.
Top

See Also

Reference

RadTreeViewAutomationPeer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewAutomationPeer Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewAutomationPeer Class : RadTreeViewAutomationPeer Constructor

owner

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As RadTreeView _
)
Visual Basic (Usage) Copy Code
Dim owner As RadTreeView

Dim instance As RadTreeViewAutomationPeer(owner)
C#
public RadTreeViewAutomationPeer(
   RadTreeView owner
)
Managed Extensions for C++
public: RadTreeViewAutomationPeer(
   RadTreeView* owner
)
C++/CLI
public:
RadTreeViewAutomationPeer(
   RadTreeView^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Class
RadTreeViewAutomationPeer Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewAutomationPeer Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewAutomationPeer Class

For a list of all members of this type, see RadTreeViewAutomationPeer members.

Public Methods

 | Name | Description
Public Method | GetPattern | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetAcceleratorKeyCore | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Protected Method | GetAutomationControlTypeCore | Overridden.
Protected Method | GetChildrenCore | Overridden.
Protected Method | GetClassNameCore | Overridden.
Top

See Also

Reference

RadTreeViewAutomationPeer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetAutomationControlTypeCore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewAutomationPeer Class : GetAutomationControlTypeCore Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetAutomationControlTypeCore() As AutomationControlType
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewAutomationPeer
Dim value As AutomationControlType

value = instance.GetAutomationControlTypeCore()
C#
protected override AutomationControlType GetAutomationControlTypeCore()
Managed Extensions for C++
protected: AutomationControlType GetAutomationControlTypeCore(); override
C++/CLI
protected:
AutomationControlType GetAutomationControlTypeCore(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Class
RadTreeViewAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetChildrenCore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewAutomationPeer Class : GetChildrenCore Method

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1002:DoNotExposeGenericLists",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Protected Overrides Function GetChildrenCore() As List(Of AutomationPeer)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewAutomationPeer
Dim value As List(Of AutomationPeer)

value = instance.GetChildrenCore()
C#
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1002:DoNotExposeGenericLists",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected override List<AutomationPeer> GetChildrenCore()
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1002:DoNotExposeGenericLists",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected: List<AutomationPeer*>* GetChildrenCore(); override
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Design",
   CheckId="CA1002:DoNotExposeGenericLists",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected:
List<AutomationPeer^>^ GetChildrenCore(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Class
RadTreeViewAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetClassNameCore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewAutomationPeer Class : GetClassNameCore Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetClassNameCore() As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewAutomationPeer
Dim value As String

value = instance.GetClassNameCore()
C#
protected override string GetClassNameCore()
Managed Extensions for C++
protected: string* GetClassNameCore(); override
C++/CLI
protected:
String^ GetClassNameCore(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Class
RadTreeViewAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetPattern Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewAutomationPeer Class : GetPattern Method

patternInterface

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPattern( _
   ByVal patternInterface As PatternInterface _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewAutomationPeer
Dim patternInterface As PatternInterface
Dim value As Object

value = instance.GetPattern(patternInterface)
C#
public override object GetPattern(
   PatternInterface patternInterface
)
Managed Extensions for C++
public: Object* GetPattern(
   PatternInterface patternInterface
) override
C++/CLI
public:
Object^ GetPattern(
   PatternInterface patternInterface
) override

Parameters

patternInterface

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewAutomationPeer Class
RadTreeViewAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEndedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEndedEventArgs Class

The EventArgs for the DradEdned event of the TreeView.

Object Model

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class RadTreeViewDragEndedEventArgs
   Inherits RadTreeViewDragEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEndedEventArgs
C#
[ScriptableTypeAttribute()]
public class RadTreeViewDragEndedEventArgs : RadTreeViewDragEventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class RadTreeViewDragEndedEventArgs : public RadTreeViewDragEventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class RadTreeViewDragEndedEventArgs : public RadTreeViewDragEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadTreeViewDragEventArgs
Telerik.Windows.Controls.RadTreeViewDragEndedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEndedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEndedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEndedEventArgs Class

The following tables list the members exposed by RadTreeViewDragEndedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewDragEndedEventArgs Constructor | Constructor of the RadTreeViewDragEndedEventArgs.
Top

Public Properties

 | Name | Description
Public Property | DraggedItems | (Inherited from RadTreeViewDragEventArgs)
Public Property | DropPosition | Gets the position where the items are dropped relative to the TargetDropItem.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | IsCanceled | Gets whether the event has been canceled.
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | TargetDropItem | Gets the item on which the items are dropped.
Top

See Also

Reference

RadTreeViewDragEndedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEndedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEndedEventArgs Class : RadTreeViewDragEndedEventArgs Constructor

isCanceled
Is the event canceled.
draggedItems
The items that are being dragged.
targetDropItem
The target item on which they are dropped.
dropPosition
The drop position.
routedEvent
The associated routed event.
source
The source of the event.
Constructor of the RadTreeViewDragEndedEventArgs.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal isCanceled As Boolean, _
   ByVal draggedItems As Collection(Of Object), _
   ByVal targetDropItem As RadTreeViewItem, _
   ByVal dropPosition As DropPosition, _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As Object _
)
Visual Basic (Usage) Copy Code
Dim isCanceled As Boolean
Dim draggedItems As Collection(Of Object)
Dim targetDropItem As RadTreeViewItem
Dim dropPosition As DropPosition
Dim routedEvent As RoutedEvent
Dim source As Object

Dim instance As RadTreeViewDragEndedEventArgs(isCanceled, draggedItems, targetDropItem, dropPosition, routedEvent, source)
C#
public RadTreeViewDragEndedEventArgs(
   bool isCanceled,
   Collection<object> draggedItems,
   RadTreeViewItem targetDropItem,
   DropPosition dropPosition,
   RoutedEvent routedEvent,
   object source
)
Managed Extensions for C++
public: RadTreeViewDragEndedEventArgs(
   bool isCanceled,
   Collection<Object*>* draggedItems,
   RadTreeViewItem* targetDropItem,
   DropPosition dropPosition,
   RoutedEvent* routedEvent,
   Object* source
)
C++/CLI
public:
RadTreeViewDragEndedEventArgs(
   bool isCanceled,
   Collection<Object^>^ draggedItems,
   RadTreeViewItem^ targetDropItem,
   DropPosition dropPosition,
   RoutedEvent^ routedEvent,
   Object^ source
)

Parameters

isCanceled
Is the event canceled.
draggedItems
The items that are being dragged.
targetDropItem
The target item on which they are dropped.
dropPosition
The drop position.
routedEvent
The associated routed event.
source
The source of the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEndedEventArgs Class
RadTreeViewDragEndedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEndedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEndedEventArgs Class

For a list of all members of this type, see RadTreeViewDragEndedEventArgs members.

Public Properties

 | Name | Description
Public Property | DraggedItems | (Inherited from RadTreeViewDragEventArgs)
Public Property | DropPosition | Gets the position where the items are dropped relative to the TargetDropItem.
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | IsCanceled | Gets whether the event has been canceled.
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | TargetDropItem | Gets the item on which the items are dropped.
Top

See Also

Reference

RadTreeViewDragEndedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DropPosition Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEndedEventArgs Class : DropPosition Property

Gets the position where the items are dropped relative to the TargetDropItem.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property DropPosition As DropPosition
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEndedEventArgs
Dim value As DropPosition

value = instance.DropPosition
C#
[ScriptableMemberAttribute()]
public DropPosition DropPosition {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property DropPosition get_DropPosition();
C++/CLI
[ScriptableMemberAttribute()]
public:
property DropPosition DropPosition {
   DropPosition get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEndedEventArgs Class
RadTreeViewDragEndedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCanceled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEndedEventArgs Class : IsCanceled Property

Gets whether the event has been canceled.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property IsCanceled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEndedEventArgs
Dim value As Boolean

value = instance.IsCanceled
C#
[ScriptableMemberAttribute()]
public bool IsCanceled {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsCanceled();
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsCanceled {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEndedEventArgs Class
RadTreeViewDragEndedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TargetDropItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEndedEventArgs Class : TargetDropItem Property

Gets the item on which the items are dropped.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property TargetDropItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEndedEventArgs
Dim value As RadTreeViewItem

value = instance.TargetDropItem
C#
[ScriptableMemberAttribute()]
public RadTreeViewItem TargetDropItem {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property RadTreeViewItem* get_TargetDropItem();
C++/CLI
[ScriptableMemberAttribute()]
public:
property RadTreeViewItem^ TargetDropItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEndedEventArgs Class
RadTreeViewDragEndedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class RadTreeViewDragEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEventArgs
C#
[ScriptableTypeAttribute()]
public class RadTreeViewDragEventArgs : RadRoutedEventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class RadTreeViewDragEventArgs : public RadRoutedEventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class RadTreeViewDragEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadTreeViewDragEventArgs
Telerik.Windows.Controls.RadTreeViewDragEndedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEventArgs Class

The following tables list the members exposed by RadTreeViewDragEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewDragEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | DraggedItems |
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadTreeViewDragEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEventArgs Class : RadTreeViewDragEventArgs Constructor

draggedItems
routedEvent
source

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal draggedItems As Collection(Of Object), _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As Object _
)
Visual Basic (Usage) Copy Code
Dim draggedItems As Collection(Of Object)
Dim routedEvent As RoutedEvent
Dim source As Object

Dim instance As RadTreeViewDragEventArgs(draggedItems, routedEvent, source)
C#
public RadTreeViewDragEventArgs(
   Collection<object> draggedItems,
   RoutedEvent routedEvent,
   object source
)
Managed Extensions for C++
public: RadTreeViewDragEventArgs(
   Collection<Object*>* draggedItems,
   RoutedEvent* routedEvent,
   Object* source
)
C++/CLI
public:
RadTreeViewDragEventArgs(
   Collection<Object^>^ draggedItems,
   RoutedEvent^ routedEvent,
   Object^ source
)

Parameters

draggedItems
routedEvent
source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEventArgs Class
RadTreeViewDragEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEventArgs Class

For a list of all members of this type, see RadTreeViewDragEventArgs members.

Public Properties

 | Name | Description
Public Property | DraggedItems |
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadTreeViewDragEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DraggedItems Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewDragEventArgs Class : DraggedItems Property

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property DraggedItems As Collection(Of Object)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewDragEventArgs
Dim value As Collection(Of Object)

value = instance.DraggedItems
C#
[ScriptableMemberAttribute()]
public Collection<object> DraggedItems {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property Collection<Object*>* get_DraggedItems();
C++/CLI
[ScriptableMemberAttribute()]
public:
property Collection<Object^>^ DraggedItems {
   Collection<Object^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewDragEventArgs Class
RadTreeViewDragEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

Object Model

Syntax

Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)>
<ScriptableTypeAttribute()>
<DefaultPropertyAttribute("Header")>
Public Class RadTreeViewItem
   Inherits HeaderedItemsControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
C#
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
[ScriptableTypeAttribute()]
[DefaultPropertyAttribute("Header")]
public class RadTreeViewItem : HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
[ScriptableTypeAttribute()]
[DefaultPropertyAttribute("Header")]
public __gc class RadTreeViewItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Header", Type=System.Windows.Controls.ContentControl)]
[ScriptableTypeAttribute()]
[DefaultPropertyAttribute("Header")]
public ref class RadTreeViewItem : public HeaderedItemsControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.RadTreeViewItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

The following tables list the members exposed by RadTreeViewItem.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewItem Constructor | Initializes new instance of the RadTreeViewItem class
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CheckedEvent | Identifies the Checked routed event.
static (Shared in Visual Basic) | CheckStateProperty | Identifies the CheckState dependency property.
static (Shared in Visual Basic) | CollapsedEvent | Identifies the Collapsed routed event.
static (Shared in Visual Basic) | DefaultImageSrcProperty | Identifies the DefaultImageSrc dependency property.
static (Shared in Visual Basic) | EditedEvent | Identifies the Edit routed event.
static (Shared in Visual Basic) | ExpandedEvent | Identifies the Expanded routed event.
static (Shared in Visual Basic) | ExpandedImageSrcProperty | Identifies the ExpandedImageSrc dependency property.
static (Shared in Visual Basic) | IsCheckBoxEnabledProperty | Identifies the IsCheckBoxEnabled dependency property.
static (Shared in Visual Basic) | IsDropAllowedProperty | Identifies the IsDropAllowed dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandedProperty | Identifies the IsExpanded dependency property.
static (Shared in Visual Basic) | IsLoadingOnDemandProperty | Identifies the IsLoadingOnDemand dependency property.
static (Shared in Visual Basic) | IsLoadOnDemandEnabledProperty | Identifies the IsLoadOnDemandEnabled dependency property.
static (Shared in Visual Basic) | IsRadioButtonEnabledProperty | Identifies the IsRadioButtonEnabled dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | IsSelectionActiveProperty | Identifies the IsSelectionActive dependency property.
static (Shared in Visual Basic) | ItemsOptionListTypeProperty | Identifies the ItemsOptionListType dependency property.
static (Shared in Visual Basic) | LoadOnDemandEvent | Identifies the LoadOnDemand routed event.
static (Shared in Visual Basic) | PreviewCheckedEvent | Identifies the PreviewChecked routed event.
static (Shared in Visual Basic) | PreviewCollapsedEvent | Identifies the PreviewCollapsed routed event.
static (Shared in Visual Basic) | PreviewEditedEvent | Identifies the PreviewEdited routed event.
static (Shared in Visual Basic) | PreviewExpandedEvent | Identifies the PreviewExpanded routed event.
static (Shared in Visual Basic) | PreviewSelectedEvent | Identifies the PreviewSelected routed event.
static (Shared in Visual Basic) | PreviewUncheckedEvent | Identifies the PreviewUnchecked routed event.
static (Shared in Visual Basic) | PreviewUnselectedEvent | Identifies the PreviewUnselected routed event.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | SelectedImageSrcProperty | Identifies the SelectedImageSrc dependency property.
static (Shared in Visual Basic) | UncheckedEvent | Identifies the Unchecked routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CheckState | Gets or sets the check state of the item.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DefaultImageSrc | Gets or sets the image of the item.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpandedImageSrc | Gets or sets the expanded image of the item.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | FullPath | Gets the path from the root tree item to the current tree item delimited with the PathSeparator specified by RadTreeView.
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Index | Gets the position of the tree item in the tree item collection.
Public Property | IsCheckBoxEnabled | Gets or sets whether the tree item will display a check box.
Public Property | IsDropAllowed | Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface.
Public Property | IsExpanded | Gets or sets a value indicating whether the tree item is in the expanded state.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInSelectedPath | Gets a value indicating whether this item is in the selection path.
Public Property | IsInViewport | Gets a value indicating whether the tree item is in scrollviewer viewport.
Public Property | IsLoadingOnDemand | Gets or sets whether the tree item is in loading on demand state
Public Property | IsLoadOnDemandEnabled | Gets or sets a value indicating whether loading on demand is enabled.
Public Property | IsRadioButtonEnabled | Gets or sets whether the tree item will display a radio button.
Public Property | IsRootItem | Gets a value if the item is root item
Public Property | IsSelected | Gets or sets a value indicating whether the tree item is in selected state.
Public Property | IsSelectionActive | Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Gets the data item associated to the RadTreeViewItem
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsOptionListType | Gets or sets the type of option list formed by container item.
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Level | Gets the zero-based depth of the tree item in the RadTreeView tree.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | NextItem | Gets the next available item. Used for traversal of the tree view.
Public Property | NextSiblingItem | Gets the next sibling tree item.
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | ParentItem | Gets the parent tree item of the current tree item.
Public Property | ParentTreeView | Gets the parent tree view that the tree item is assigned to.
Public Property | PreviousItem | Gets the previous available item. Used for traversal of the tree view.
Public Property | PreviousSiblingItem | Gets the previous sibling tree item.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RootItem | Gets the root parent item for this instance.
Public Property | SelectedImageSrc | Gets or sets the selected image of the item.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginEdit | Entry point for editing
Public Method | BringIntoView | Scrolls the tree view to a given item.
Public Method | CollapseAll | Collapses the item and its child items recursively.
Public Method | Contains | Checks if the item has a particular item in its collection
Public Method | EndEdit | Allows a pending edit operation to be ended.
Public Method | EnsureVisible | Ensures that a given item is displayed
Public Method | ExpandAll | Expands the item and its child items recursively.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | IsBefore | Gets a value indicating whether this item is rendered before the passed item.
Public Method | OnApplyTemplate | Overridden.
Public Method | ToString | Overridden. Return item text value
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden.
Protected Method | GetContainerForItemOverride | Overridden.
Protected Method | IsItemItsOwnContainerOverride | Overridden.
Protected Method | OnChecked |
Protected Method | OnCollapsed |
Protected Method | OnCreateAutomationPeer | Overridden.
Protected Method | OnEdited |
Protected Method | OnExpanded |
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnLoadOnDemand |
Protected Method | OnPreviewChecked |
Protected Method | OnPreviewCollapsed |
Protected Method | OnPreviewEdited |
Protected Method | OnPreviewExpanded |
Protected Method | OnPreviewSelected |
Protected Method | OnPreviewUnchecked |
Protected Method | OnPreviewUnselected |
Protected Method | OnSelected |
Protected Method | OnUnchecked |
Protected Method | OnUnselected |
Protected Method | PrepareContainerForItemOverride | Overridden.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when the item is checked.
Public Event | Collapsed | Occurs after the tree item is collapsed
Public Event | Edited | Occurs when a item has been edited
Public Event | Expanded | Occurs after the value of the IsExpanded property of a tree item is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LoadOnDemand | Occurs when the tree item should load its child items on demand.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewChecked | Occurs before the tree item is checked
Public Event | PreviewCollapsed | Occurs before an item is collapsed.
Public Event | PreviewEdited | Occurs before the item to accept the new edit text.
Public Event | PreviewExpanded | Occurs before an item is expanded.
Public Event | PreviewSelected | Occurs before the tree item is selected
Public Event | PreviewUnchecked | Occurs before the tree item is unchecked
Public Event | PreviewUnselected | Occurs before an item is unselected
Public Event | Selected | Occurs after the tree item is selected For more information about handling events, see also PreviewSelected
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unchecked | Occurs when the item is unchecked.
Public Event | Unselected | Occurs after the tree item is unselected
Top

See Also

Reference

RadTreeViewItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : RadTreeViewItem Constructor

Initializes new instance of the RadTreeViewItem class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem()
C#
public RadTreeViewItem()
Managed Extensions for C++
public: RadTreeViewItem();
C++/CLI
public:
RadTreeViewItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

For a list of all members of this type, see RadTreeViewItem members.

Public Methods

 | Name | Description
Public Method | BeginEdit | Entry point for editing
Public Method | BringIntoView | Scrolls the tree view to a given item.
Public Method | CollapseAll | Collapses the item and its child items recursively.
Public Method | Contains | Checks if the item has a particular item in its collection
Public Method | EndEdit | Allows a pending edit operation to be ended.
Public Method | EnsureVisible | Ensures that a given item is displayed
Public Method | ExpandAll | Expands the item and its child items recursively.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | IsBefore | Gets a value indicating whether this item is rendered before the passed item.
Public Method | OnApplyTemplate | Overridden.
Public Method | ToString | Overridden. Return item text value
Top

Protected Methods

 | Name | Description
Protected Method | ClearContainerForItemOverride | Overridden.
Protected Method | GetContainerForItemOverride | Overridden.
Protected Method | IsItemItsOwnContainerOverride | Overridden.
Protected Method | OnChecked |
Protected Method | OnCollapsed |
Protected Method | OnCreateAutomationPeer | Overridden.
Protected Method | OnEdited |
Protected Method | OnExpanded |
Protected Method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateChanged | Called when the HeaderTemplate property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl)
Protected Method | OnItemsChanged | Overridden.
Protected Method | OnItemTemplateSelectorChanged | When overriden OnRadItemTemplateSelectorChanged is called when the TemplateSelector for the contained items changes. (Inherited from ItemsControl)
Protected Method | OnLoadOnDemand |
Protected Method | OnPreviewChecked |
Protected Method | OnPreviewCollapsed |
Protected Method | OnPreviewEdited |
Protected Method | OnPreviewExpanded |
Protected Method | OnPreviewSelected |
Protected Method | OnPreviewUnchecked |
Protected Method | OnPreviewUnselected |
Protected Method | OnSelected |
Protected Method | OnUnchecked |
Protected Method | OnUnselected |
Protected Method | PrepareContainerForItemOverride | Overridden.
Top

See Also

Reference

RadTreeViewItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BeginEdit Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : BeginEdit Method

Entry point for editing

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Function BeginEdit() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.BeginEdit()
C#
[ScriptableMemberAttribute()]
public bool BeginEdit()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: bool BeginEdit();
C++/CLI
[ScriptableMemberAttribute()]
public:
bool BeginEdit();

Return Value

Returns true if editing can begin.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BringIntoView Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : BringIntoView Method

Scrolls the tree view to a given item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub BringIntoView()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem

instance.BringIntoView()
C#
[ScriptableMemberAttribute()]
public void BringIntoView()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void BringIntoView();
C++/CLI
[ScriptableMemberAttribute()]
public:
void BringIntoView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ClearContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ClearContainerForItemOverride Method

element
item

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim element As DependencyObject
Dim item As Object

instance.ClearContainerForItemOverride(element, item)
C#
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void ClearContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void ClearContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CollapseAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : CollapseAll Method

Collapses the item and its child items recursively.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Collapses the item and its child items recursively.")>
Public Sub CollapseAll()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem

instance.CollapseAll()
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Collapses the item and its child items recursively.")]
public void CollapseAll()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Collapses the item and its child items recursively.")]
public: void CollapseAll();
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Collapses the item and its child items recursively.")]
public:
void CollapseAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Contains Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Contains Method

item
the item to be searched
Checks if the item has a particular item in its collection

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Checks if the item has a particular item in its collection")>
<ScriptableMemberAttribute()>
Public Function Contains( _
   ByVal item As RadTreeViewItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim item As RadTreeViewItem
Dim value As Boolean

value = instance.Contains(item)
C#
[DescriptionAttribute("Checks if the item has a particular item in its collection")]
[ScriptableMemberAttribute()]
public bool Contains(
   RadTreeViewItem item
)
Managed Extensions for C++
[DescriptionAttribute("Checks if the item has a particular item in its collection")]
[ScriptableMemberAttribute()]
public: bool Contains(
   RadTreeViewItem* item
)
C++/CLI
[DescriptionAttribute("Checks if the item has a particular item in its collection")]
[ScriptableMemberAttribute()]
public:
bool Contains(
   RadTreeViewItem^ item
)

Parameters

item
the item to be searched

Return Value

boolean value indicating the item to be searched

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
EndEdit Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : EndEdit Method

cancelEdit
Boolean value indicating whether the edit operation should be canceled.
Allows a pending edit operation to be ended.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Function EndEdit( _
   ByVal cancelEdit As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim cancelEdit As Boolean
Dim value As Boolean

value = instance.EndEdit(cancelEdit)
C#
[ScriptableMemberAttribute()]
public bool EndEdit(
   bool cancelEdit
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: bool EndEdit(
   bool cancelEdit
)
C++/CLI
[ScriptableMemberAttribute()]
public:
bool EndEdit(
   bool cancelEdit
)

Parameters

cancelEdit
Boolean value indicating whether the edit operation should be canceled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
EnsureVisible Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : EnsureVisible Method

Ensures that a given item is displayed

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Sub EnsureVisible()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem

instance.EnsureVisible()
C#
[ScriptableMemberAttribute()]
public void EnsureVisible()
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: void EnsureVisible();
C++/CLI
[ScriptableMemberAttribute()]
public:
void EnsureVisible();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ExpandAll Method

Expands the item and its child items recursively.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Expands the item and its child items recursively.")>
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem

instance.ExpandAll()
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Expands the item and its child items recursively.")]
public void ExpandAll()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Expands the item and its child items recursively.")]
public: void ExpandAll();
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Expands the item and its child items recursively.")]
public:
void ExpandAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : GetContainerForItemOverride Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride() As DependencyObject
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As DependencyObject

value = instance.GetContainerForItemOverride()
C#
protected override DependencyObject GetContainerForItemOverride()
Managed Extensions for C++
protected: DependencyObject* GetContainerForItemOverride(); override
C++/CLI
protected:
DependencyObject^ GetContainerForItemOverride(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsBefore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsBefore Method

item
Gets a value indicating whether this item is rendered before the passed item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Function IsBefore( _
   ByVal item As RadTreeViewItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim item As RadTreeViewItem
Dim value As Boolean

value = instance.IsBefore(item)
C#
[ScriptableMemberAttribute()]
public bool IsBefore(
   RadTreeViewItem item
)
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: bool IsBefore(
   RadTreeViewItem* item
)
C++/CLI
[ScriptableMemberAttribute()]
public:
bool IsBefore(
   RadTreeViewItem^ item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsItemItsOwnContainerOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsItemItsOwnContainerOverride Method

item

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim item As Object
Dim value As Boolean

value = instance.IsItemItsOwnContainerOverride(item)
C#
protected override bool IsItemItsOwnContainerOverride(
   object item
)
Managed Extensions for C++
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
C++/CLI
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnApplyTemplate Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnChecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnChecked Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnChecked( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnChecked(e)
C#
protected virtual void OnChecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnChecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnChecked(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnCollapsed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnCollapsed Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollapsed( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnCollapsed(e)
C#
protected virtual void OnCollapsed(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCollapsed(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnCollapsed(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnCreateAutomationPeer Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnCreateAutomationPeer Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function OnCreateAutomationPeer() As AutomationPeer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As AutomationPeer

value = instance.OnCreateAutomationPeer()
C#
protected override AutomationPeer OnCreateAutomationPeer()
Managed Extensions for C++
protected: AutomationPeer* OnCreateAutomationPeer(); override
C++/CLI
protected:
AutomationPeer^ OnCreateAutomationPeer(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnEdited Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnEdited Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEdited( _
   ByVal e As RadTreeViewItemEditedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadTreeViewItemEditedEventArgs

instance.OnEdited(e)
C#
protected virtual void OnEdited(
   RadTreeViewItemEditedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnEdited(
   RadTreeViewItemEditedEventArgs* e
)
C++/CLI
protected:
virtual void OnEdited(
   RadTreeViewItemEditedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnExpanded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnExpanded Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnExpanded( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnExpanded(e)
C#
protected virtual void OnExpanded(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnExpanded(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnExpanded(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnItemsChanged Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnItemsChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As NotifyCollectionChangedEventArgs

instance.OnItemsChanged(e)
C#
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs* e
) override
C++/CLI
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnLoadOnDemand Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnLoadOnDemand Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLoadOnDemand( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnLoadOnDemand(e)
C#
protected virtual void OnLoadOnDemand(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnLoadOnDemand(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnLoadOnDemand(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewChecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewChecked Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewChecked( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewChecked(e)
C#
protected virtual bool OnPreviewChecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewChecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewChecked(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewCollapsed Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewCollapsed Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewCollapsed( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewCollapsed(e)
C#
protected virtual bool OnPreviewCollapsed(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewCollapsed(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewCollapsed(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewEdited Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewEdited Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewEdited( _
   ByVal e As RadTreeViewItemEditedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadTreeViewItemEditedEventArgs
Dim value As Boolean

value = instance.OnPreviewEdited(e)
C#
protected virtual bool OnPreviewEdited(
   RadTreeViewItemEditedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewEdited(
   RadTreeViewItemEditedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewEdited(
   RadTreeViewItemEditedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewExpanded Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewExpanded Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewExpanded( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewExpanded(e)
C#
protected virtual bool OnPreviewExpanded(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewExpanded(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewExpanded(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewSelected Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewSelected( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewSelected(e)
C#
protected virtual bool OnPreviewSelected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewSelected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewSelected(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewUnchecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewUnchecked Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewUnchecked( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewUnchecked(e)
C#
protected virtual bool OnPreviewUnchecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewUnchecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewUnchecked(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnPreviewUnselected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnPreviewUnselected Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnPreviewUnselected( _
   ByVal e As RadRoutedEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs
Dim value As Boolean

value = instance.OnPreviewUnselected(e)
C#
protected virtual bool OnPreviewUnselected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual bool OnPreviewUnselected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual bool OnPreviewUnselected(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnSelected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnSelected Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnSelected(e)
C#
protected virtual void OnSelected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelected(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnUnchecked Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnUnchecked Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUnchecked( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnUnchecked(e)
C#
protected virtual void OnUnchecked(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUnchecked(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnUnchecked(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnUnselected Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : OnUnselected Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUnselected( _
   ByVal e As RadRoutedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim e As RadRoutedEventArgs

instance.OnUnselected(e)
C#
protected virtual void OnUnselected(
   RadRoutedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUnselected(
   RadRoutedEventArgs* e
)
C++/CLI
protected:
virtual void OnUnselected(
   RadRoutedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PrepareContainerForItemOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PrepareContainerForItemOverride Method

element
item

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim element As DependencyObject
Dim item As Object

instance.PrepareContainerForItemOverride(element, item)
C#
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
)
Managed Extensions for C++
protected: void PrepareContainerForItemOverride(
   DependencyObject* element,
   Object* item
) override
C++/CLI
protected:
void PrepareContainerForItemOverride(
   DependencyObject^ element,
   Object^ item
) override

Parameters

element
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ToString Method

Return item text value

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

the text of the item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

For a list of all members of this type, see RadTreeViewItem members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CheckState | Gets or sets the check state of the item.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DefaultImageSrc | Gets or sets the image of the item.
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ExpandedImageSrc | Gets or sets the expanded image of the item.
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | FullPath | Gets the path from the root tree item to the current tree item delimited with the PathSeparator specified by RadTreeView.
Public Property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. This is a dependency property. (Inherited from HeaderedItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Index | Gets the position of the tree item in the tree item collection.
Public Property | IsCheckBoxEnabled | Gets or sets whether the tree item will display a check box.
Public Property | IsDropAllowed | Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface.
Public Property | IsExpanded | Gets or sets a value indicating whether the tree item is in the expanded state.
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInSelectedPath | Gets a value indicating whether this item is in the selection path.
Public Property | IsInViewport | Gets a value indicating whether the tree item is in scrollviewer viewport.
Public Property | IsLoadingOnDemand | Gets or sets whether the tree item is in loading on demand state
Public Property | IsLoadOnDemandEnabled | Gets or sets a value indicating whether loading on demand is enabled.
Public Property | IsRadioButtonEnabled | Gets or sets whether the tree item will display a radio button.
Public Property | IsRootItem | Gets a value if the item is root item
Public Property | IsSelected | Gets or sets a value indicating whether the tree item is in selected state.
Public Property | IsSelectionActive | Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | Item | Gets the data item associated to the RadTreeViewItem
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsOptionListType | Gets or sets the type of option list formed by container item.
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Level | Gets the zero-based depth of the tree item in the RadTreeView tree.
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | NextItem | Gets the next available item. Used for traversal of the tree view.
Public Property | NextSiblingItem | Gets the next sibling tree item.
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | ParentItem | Gets the parent tree item of the current tree item.
Public Property | ParentTreeView | Gets the parent tree view that the tree item is assigned to.
Public Property | PreviousItem | Gets the previous available item. Used for traversal of the tree view.
Public Property | PreviousSiblingItem | Gets the previous sibling tree item.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | RootItem | Gets the root parent item for this instance.
Public Property | SelectedImageSrc | Gets or sets the selected image of the item.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadTreeViewItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CheckState Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : CheckState Property

Gets or sets the check state of the item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets or sets the state of RadTreeViewItem")>
<BrowsableAttribute(False)>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property CheckState As ToggleState
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As ToggleState

instance.CheckState = value

value = instance.CheckState
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets the state of RadTreeViewItem")]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public ToggleState CheckState {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets the state of RadTreeViewItem")]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property ToggleState get_CheckState();
public: __property void set_CheckState(
   ToggleState value
);
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets the state of RadTreeViewItem")]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property ToggleState CheckState {
   ToggleState get();
   void set (ToggleState value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DefaultImageSrc Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : DefaultImageSrc Property

Gets or sets the image of the item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the image of the item.")>
<CategoryAttribute("Appearance")>
Public Overridable Property DefaultImageSrc As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As String

instance.DefaultImageSrc = value

value = instance.DefaultImageSrc
C#
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public virtual string DefaultImageSrc {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public: __property virtual string* get_DefaultImageSrc();
public: __property virtual void set_DefaultImageSrc(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public:
virtual property String^ DefaultImageSrc {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandedImageSrc Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ExpandedImageSrc Property

Gets or sets the expanded image of the item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the image of the item.")>
<CategoryAttribute("Appearance")>
<ScriptableMemberAttribute()>
Public Property ExpandedImageSrc As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As String

instance.ExpandedImageSrc = value

value = instance.ExpandedImageSrc
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
[ScriptableMemberAttribute()]
public string ExpandedImageSrc {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
[ScriptableMemberAttribute()]
public: __property string* get_ExpandedImageSrc();
public: __property void set_ExpandedImageSrc(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
[ScriptableMemberAttribute()]
public:
property String^ ExpandedImageSrc {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
FullPath Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : FullPath Property

Gets the path from the root tree item to the current tree item delimited with the PathSeparator specified by RadTreeView.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the path from the root tree item to the current tree item  delimited with the PathSeparator specified by RadTreeView.")>
Public ReadOnly Property FullPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As String

value = instance.FullPath
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the path from the root tree item to the current tree item  delimited with the PathSeparator specified by RadTreeView.")]
public string FullPath {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the path from the root tree item to the current tree item  delimited with the PathSeparator specified by RadTreeView.")]
public: __property string* get_FullPath();
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the path from the root tree item to the current tree item  delimited with the PathSeparator specified by RadTreeView.")]
public:
property String^ FullPath {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Index Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Index Property

Gets the position of the tree item in the tree item collection.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<CategoryAttribute("Behavior")>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Integer

value = instance.Index
C#
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
public int Index {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
public: __property int get_Index();
C++/CLI
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
public:
property int Index {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCheckBoxEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsCheckBoxEnabled Property

Gets or sets whether the tree item will display a check box.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets or sets whether the tree item will display a check box.")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public ReadOnly Property IsCheckBoxEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsCheckBoxEnabled
C#
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item will display a check box.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool IsCheckBoxEnabled {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item will display a check box.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_IsCheckBoxEnabled();
C++/CLI
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item will display a check box.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool IsCheckBoxEnabled {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDropAllowed Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsDropAllowed Property

Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.")>
Public Property IsDropAllowed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsDropAllowed = value

value = instance.IsDropAllowed
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.")]
public bool IsDropAllowed {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.")]
public: __property bool get_IsDropAllowed();
public: __property void set_IsDropAllowed(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item can accept data that the user drags onto it.")]
public:
property bool IsDropAllowed {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsEnabled Property

Gets or sets a value indicating whether this element is enabled in the user interface.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public Property IsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
[ScriptableMemberAttribute()]
public bool IsEnabled {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpanded Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsExpanded Property

Gets or sets a value indicating whether the tree item is in the expanded state.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether the tree item is in the expanded state.")>
Public Property IsExpanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsExpanded = value

value = instance.IsExpanded
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in the expanded state.")]
public bool IsExpanded {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in the expanded state.")]
public: __property bool get_IsExpanded();
public: __property void set_IsExpanded(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in the expanded state.")]
public:
property bool IsExpanded {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsInSelectedPath Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsInSelectedPath Property

Gets a value indicating whether this item is in the selection path.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property IsInSelectedPath As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsInSelectedPath
C#
[ScriptableMemberAttribute()]
public bool IsInSelectedPath {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsInSelectedPath();
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsInSelectedPath {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsInViewport Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsInViewport Property

Gets a value indicating whether the tree item is in scrollviewer viewport.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property IsInViewport As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsInViewport
C#
[ScriptableMemberAttribute()]
public bool IsInViewport {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property bool get_IsInViewport();
C++/CLI
[ScriptableMemberAttribute()]
public:
property bool IsInViewport {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadingOnDemand Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsLoadingOnDemand Property

Gets or sets whether the tree item is in loading on demand state

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets whether the tree item is in loading on demand state.")>
Public Property IsLoadingOnDemand As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsLoadingOnDemand = value

value = instance.IsLoadingOnDemand
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item is in loading on demand state.")]
public bool IsLoadingOnDemand {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item is in loading on demand state.")]
public: __property bool get_IsLoadingOnDemand();
public: __property void set_IsLoadingOnDemand(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the tree item is in loading on demand state.")]
public:
property bool IsLoadingOnDemand {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadOnDemandEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsLoadOnDemandEnabled Property

Gets or sets a value indicating whether loading on demand is enabled.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property IsLoadOnDemandEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsLoadOnDemandEnabled = value

value = instance.IsLoadOnDemandEnabled
C#
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool IsLoadOnDemandEnabled {get; set;}
Managed Extensions for C++
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_IsLoadOnDemandEnabled();
public: __property void set_IsLoadOnDemandEnabled(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets a value indicating whether loading on demand is enabled.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool IsLoadOnDemandEnabled {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRadioButtonEnabled Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsRadioButtonEnabled Property

Gets or sets whether the tree item will display a radio button.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Gets or sets whether the tree item will display a radio button.")>
<BrowsableAttribute(False)>
Public ReadOnly Property IsRadioButtonEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsRadioButtonEnabled
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets whether the tree item will display a radio button.")]
[BrowsableAttribute(false)]
public bool IsRadioButtonEnabled {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets whether the tree item will display a radio button.")]
[BrowsableAttribute(false)]
public: __property bool get_IsRadioButtonEnabled();
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets whether the tree item will display a radio button.")]
[BrowsableAttribute(false)]
public:
property bool IsRadioButtonEnabled {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRootItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsRootItem Property

Gets a value if the item is root item

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets a value if the item is root item")>
Public ReadOnly Property IsRootItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsRootItem
C#
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets a value if the item is root item")]
public bool IsRootItem {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets a value if the item is root item")]
public: __property bool get_IsRootItem();
C++/CLI
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets a value if the item is root item")]
public:
property bool IsRootItem {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelected Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsSelected Property

Gets or sets a value indicating whether the tree item is in selected state.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Gets or sets a value indicating whether the tree item is in selected state.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in selected state.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool IsSelected {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in selected state.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether the tree item is in selected state.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelectionActive Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsSelectionActive Property

Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused.")>
<CategoryAttribute("Behavior")>
Public ReadOnly Property IsSelectionActive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Boolean

value = instance.IsSelectionActive
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused.")]
[CategoryAttribute("Behavior")]
public bool IsSelectionActive {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused.")]
[CategoryAttribute("Behavior")]
public: __property bool get_IsSelectionActive();
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets whether the tree item selection is active - e.g. the item is selected and the treeview is focused.")]
[CategoryAttribute("Behavior")]
public:
property bool IsSelectionActive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Item Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Item Property

Gets the data item associated to the RadTreeViewItem

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public ReadOnly Property Item As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Object

value = instance.Item
C#
[CompilerGeneratedAttribute()]
public object Item {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Object* get_Item();
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Object^ Item {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsOptionListType Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ItemsOptionListType Property

Gets or sets the type of option list formed by container item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
Public Property ItemsOptionListType As OptionListType
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As OptionListType

instance.ItemsOptionListType = value

value = instance.ItemsOptionListType
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public OptionListType ItemsOptionListType {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public: __property OptionListType get_ItemsOptionListType();
public: __property void set_ItemsOptionListType(
   OptionListType value
);
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
public:
property OptionListType ItemsOptionListType {
   OptionListType get();
   void set (OptionListType value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Level Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Level Property

Gets the zero-based depth of the tree item in the RadTreeView tree.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Level As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As Integer

value = instance.Level
C#
[DesignerSerializationVisibilityAttribute()]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public int Level {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Level();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property int Level {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
NextItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : NextItem Property

Gets the next available item. Used for traversal of the tree view.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the next available item. Used for traversal of the tree view.")>
Public ReadOnly Property NextItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.NextItem
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next available item. Used for traversal of the tree view.")]
public RadTreeViewItem NextItem {get;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next available item. Used for traversal of the tree view.")]
public: __property RadTreeViewItem* get_NextItem();
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next available item. Used for traversal of the tree view.")]
public:
property RadTreeViewItem^ NextItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
NextSiblingItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : NextSiblingItem Property

Gets the next sibling tree item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the next sibling tree item.")>
Public ReadOnly Property NextSiblingItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.NextSiblingItem
C#
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next sibling tree item.")]
public RadTreeViewItem NextSiblingItem {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next sibling tree item.")]
public: __property RadTreeViewItem* get_NextSiblingItem();
C++/CLI
[BrowsableAttribute(false)]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the next sibling tree item.")]
public:
property RadTreeViewItem^ NextSiblingItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ParentItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ParentItem Property

Gets the parent tree item of the current tree item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets the parent tree item of the current tree item.")>
<DesignerSerializationVisibilityAttribute()>
<CategoryAttribute("Behavior")>
Public ReadOnly Property ParentItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.ParentItem
C#
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets the parent tree item of the current tree item.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
public RadTreeViewItem ParentItem {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets the parent tree item of the current tree item.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
public: __property RadTreeViewItem* get_ParentItem();
C++/CLI
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets the parent tree item of the current tree item.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
public:
property RadTreeViewItem^ ParentItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ParentTreeView Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ParentTreeView Property

Gets the parent tree view that the tree item is assigned to.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ScriptableMemberAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the parent tree view that the tree item is assigned to.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property ParentTreeView As RadTreeView
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeView

value = instance.ParentTreeView
C#
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the parent tree view that the tree item is assigned to.")]
[DesignerSerializationVisibilityAttribute()]
public RadTreeView ParentTreeView {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the parent tree view that the tree item is assigned to.")]
[DesignerSerializationVisibilityAttribute()]
public: __property RadTreeView* get_ParentTreeView();
C++/CLI
[DefaultValueAttribute()]
[ScriptableMemberAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the parent tree view that the tree item is assigned to.")]
[DesignerSerializationVisibilityAttribute()]
public:
property RadTreeView^ ParentTreeView {
   RadTreeView^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviousItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviousItem Property

Gets the previous available item. Used for traversal of the tree view.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<ScriptableMemberAttribute()>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the previous available item. Used for traversal of the tree view.")>
<CategoryAttribute("Behavior")>
Public ReadOnly Property PreviousItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.PreviousItem
C#
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the previous available item. Used for traversal of the tree view.")]
[CategoryAttribute("Behavior")]
public RadTreeViewItem PreviousItem {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the previous available item. Used for traversal of the tree view.")]
[CategoryAttribute("Behavior")]
public: __property RadTreeViewItem* get_PreviousItem();
C++/CLI
[BrowsableAttribute(false)]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the previous available item. Used for traversal of the tree view.")]
[CategoryAttribute("Behavior")]
public:
property RadTreeViewItem^ PreviousItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviousSiblingItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviousSiblingItem Property

Gets the previous sibling tree item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Gets the previous sibling tree item.")>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property PreviousSiblingItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.PreviousSiblingItem
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets the previous sibling tree item.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public RadTreeViewItem PreviousSiblingItem {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets the previous sibling tree item.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property RadTreeViewItem* get_PreviousSiblingItem();
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Gets the previous sibling tree item.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property RadTreeViewItem^ PreviousSiblingItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RootItem Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : RootItem Property

Gets the root parent item for this instance.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the root parent item for this instance.")>
Public ReadOnly Property RootItem As RadTreeViewItem
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As RadTreeViewItem

value = instance.RootItem
C#
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the root parent item for this instance.")]
public RadTreeViewItem RootItem {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the root parent item for this instance.")]
public: __property RadTreeViewItem* get_RootItem();
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets the root parent item for this instance.")]
public:
property RadTreeViewItem^ RootItem {
   RadTreeViewItem^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedImageSrc Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : SelectedImageSrc Property

Gets or sets the selected image of the item.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the image of the item.")>
<CategoryAttribute("Appearance")>
Public Property SelectedImageSrc As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim value As String

instance.SelectedImageSrc = value

value = instance.SelectedImageSrc
C#
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public string SelectedImageSrc {get; set;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public: __property string* get_SelectedImageSrc();
public: __property void set_SelectedImageSrc(
   string* value
);
C++/CLI
[ScriptableMemberAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image of the item.")]
[CategoryAttribute("Appearance")]
public:
property String^ SelectedImageSrc {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

For a list of all members of this type, see RadTreeViewItem members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CheckedEvent | Identifies the Checked routed event.
static (Shared in Visual Basic) | CheckStateProperty | Identifies the CheckState dependency property.
static (Shared in Visual Basic) | CollapsedEvent | Identifies the Collapsed routed event.
static (Shared in Visual Basic) | DefaultImageSrcProperty | Identifies the DefaultImageSrc dependency property.
static (Shared in Visual Basic) | EditedEvent | Identifies the Edit routed event.
static (Shared in Visual Basic) | ExpandedEvent | Identifies the Expanded routed event.
static (Shared in Visual Basic) | ExpandedImageSrcProperty | Identifies the ExpandedImageSrc dependency property.
static (Shared in Visual Basic) | IsCheckBoxEnabledProperty | Identifies the IsCheckBoxEnabled dependency property.
static (Shared in Visual Basic) | IsDropAllowedProperty | Identifies the IsDropAllowed dependency property.
static (Shared in Visual Basic) | IsEnabledProperty | Identifies the IsEnabled dependency property.
static (Shared in Visual Basic) | IsExpandedProperty | Identifies the IsExpanded dependency property.
static (Shared in Visual Basic) | IsLoadingOnDemandProperty | Identifies the IsLoadingOnDemand dependency property.
static (Shared in Visual Basic) | IsLoadOnDemandEnabledProperty | Identifies the IsLoadOnDemandEnabled dependency property.
static (Shared in Visual Basic) | IsRadioButtonEnabledProperty | Identifies the IsRadioButtonEnabled dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | IsSelectionActiveProperty | Identifies the IsSelectionActive dependency property.
static (Shared in Visual Basic) | ItemsOptionListTypeProperty | Identifies the ItemsOptionListType dependency property.
static (Shared in Visual Basic) | LoadOnDemandEvent | Identifies the LoadOnDemand routed event.
static (Shared in Visual Basic) | PreviewCheckedEvent | Identifies the PreviewChecked routed event.
static (Shared in Visual Basic) | PreviewCollapsedEvent | Identifies the PreviewCollapsed routed event.
static (Shared in Visual Basic) | PreviewEditedEvent | Identifies the PreviewEdited routed event.
static (Shared in Visual Basic) | PreviewExpandedEvent | Identifies the PreviewExpanded routed event.
static (Shared in Visual Basic) | PreviewSelectedEvent | Identifies the PreviewSelected routed event.
static (Shared in Visual Basic) | PreviewUncheckedEvent | Identifies the PreviewUnchecked routed event.
static (Shared in Visual Basic) | PreviewUnselectedEvent | Identifies the PreviewUnselected routed event.
static (Shared in Visual Basic) | SelectedEvent | Identifies the Selected routed event.
static (Shared in Visual Basic) | SelectedImageSrcProperty | Identifies the SelectedImageSrc dependency property.
static (Shared in Visual Basic) | UncheckedEvent | Identifies the Unchecked routed event.
static (Shared in Visual Basic) | UnselectedEvent | Identifies the Unselected routed event.
Top

See Also

Reference

RadTreeViewItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : CheckedEvent Field

Identifies the Checked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.CheckedEvent
C#
public static readonly RoutedEvent CheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* CheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ CheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CheckStateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : CheckStateProperty Field

Identifies the CheckState dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CheckStateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.CheckStateProperty
C#
public static readonly DependencyProperty CheckStateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* CheckStateProperty
C++/CLI
public:
static readonly DependencyProperty^ CheckStateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CollapsedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : CollapsedEvent Field

Identifies the Collapsed routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CollapsedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.CollapsedEvent
C#
public static readonly RoutedEvent CollapsedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* CollapsedEvent
C++/CLI
public:
static readonly RoutedEvent^ CollapsedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DefaultImageSrcProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : DefaultImageSrcProperty Field

Identifies the DefaultImageSrc dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultImageSrcProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.DefaultImageSrcProperty
C#
public static readonly DependencyProperty DefaultImageSrcProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DefaultImageSrcProperty
C++/CLI
public:
static readonly DependencyProperty^ DefaultImageSrcProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
EditedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : EditedEvent Field

Identifies the Edit routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EditedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.EditedEvent
C#
public static readonly RoutedEvent EditedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* EditedEvent
C++/CLI
public:
static readonly RoutedEvent^ EditedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ExpandedEvent Field

Identifies the Expanded routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpandedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.ExpandedEvent
C#
public static readonly RoutedEvent ExpandedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* ExpandedEvent
C++/CLI
public:
static readonly RoutedEvent^ ExpandedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandedImageSrcProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ExpandedImageSrcProperty Field

Identifies the ExpandedImageSrc dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpandedImageSrcProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.ExpandedImageSrcProperty
C#
public static readonly DependencyProperty ExpandedImageSrcProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ExpandedImageSrcProperty
C++/CLI
public:
static readonly DependencyProperty^ ExpandedImageSrcProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsCheckBoxEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsCheckBoxEnabledProperty Field

Identifies the IsCheckBoxEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsCheckBoxEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsCheckBoxEnabledProperty
C#
public static readonly DependencyProperty IsCheckBoxEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsCheckBoxEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsCheckBoxEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsDropAllowedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsDropAllowedProperty Field

Identifies the IsDropAllowed dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsDropAllowedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsDropAllowedProperty
C#
public static readonly DependencyProperty IsDropAllowedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsDropAllowedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsDropAllowedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsEnabledProperty Field

Identifies the IsEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsEnabledProperty
C#
public static readonly DependencyProperty IsEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsExpandedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsExpandedProperty Field

Identifies the IsExpanded dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsExpandedProperty
C#
public static readonly DependencyProperty IsExpandedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsExpandedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsExpandedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadingOnDemandProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsLoadingOnDemandProperty Field

Identifies the IsLoadingOnDemand dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsLoadingOnDemandProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsLoadingOnDemandProperty
C#
public static readonly DependencyProperty IsLoadingOnDemandProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsLoadingOnDemandProperty
C++/CLI
public:
static readonly DependencyProperty^ IsLoadingOnDemandProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsLoadOnDemandEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsLoadOnDemandEnabledProperty Field

Identifies the IsLoadOnDemandEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsLoadOnDemandEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsLoadOnDemandEnabledProperty
C#
public static readonly DependencyProperty IsLoadOnDemandEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsLoadOnDemandEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsLoadOnDemandEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsRadioButtonEnabledProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsRadioButtonEnabledProperty Field

Identifies the IsRadioButtonEnabled dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsRadioButtonEnabledProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsRadioButtonEnabledProperty
C#
public static readonly DependencyProperty IsRadioButtonEnabledProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsRadioButtonEnabledProperty
C++/CLI
public:
static readonly DependencyProperty^ IsRadioButtonEnabledProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelectedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsSelectedProperty Field

Identifies the IsSelected dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsSelectedProperty
C#
public static readonly DependencyProperty IsSelectedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsSelectionActiveProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : IsSelectionActiveProperty Field

Identifies the IsSelectionActive dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsSelectionActiveProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.IsSelectionActiveProperty
C#
public static readonly DependencyProperty IsSelectionActiveProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsSelectionActiveProperty
C++/CLI
public:
static readonly DependencyProperty^ IsSelectionActiveProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ItemsOptionListTypeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : ItemsOptionListTypeProperty Field

Identifies the ItemsOptionListType dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ItemsOptionListTypeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.ItemsOptionListTypeProperty
C#
public static readonly DependencyProperty ItemsOptionListTypeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ItemsOptionListTypeProperty
C++/CLI
public:
static readonly DependencyProperty^ ItemsOptionListTypeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LoadOnDemandEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : LoadOnDemandEvent Field

Identifies the LoadOnDemand routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LoadOnDemandEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.LoadOnDemandEvent
C#
public static readonly RoutedEvent LoadOnDemandEvent
Managed Extensions for C++
public: static readonly RoutedEvent* LoadOnDemandEvent
C++/CLI
public:
static readonly RoutedEvent^ LoadOnDemandEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewCheckedEvent Field

Identifies the PreviewChecked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewCheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewCheckedEvent
C#
public static readonly RoutedEvent PreviewCheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewCheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewCheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewCollapsedEvent Field

Identifies the PreviewCollapsed routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewCollapsedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewCollapsedEvent
C#
public static readonly RoutedEvent PreviewCollapsedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewCollapsedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewCollapsedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewEditedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewEditedEvent Field

Identifies the PreviewEdited routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewEditedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewEditedEvent
C#
public static readonly RoutedEvent PreviewEditedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewEditedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewEditedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpandedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewExpandedEvent Field

Identifies the PreviewExpanded routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewExpandedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewExpandedEvent
C#
public static readonly RoutedEvent PreviewExpandedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewExpandedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewExpandedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewSelectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewSelectedEvent Field

Identifies the PreviewSelected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewSelectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewSelectedEvent
C#
public static readonly RoutedEvent PreviewSelectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewSelectedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewSelectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUncheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewUncheckedEvent Field

Identifies the PreviewUnchecked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewUncheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewUncheckedEvent
C#
public static readonly RoutedEvent PreviewUncheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewUncheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewUncheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUnselectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewUnselectedEvent Field

Identifies the PreviewUnselected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewUnselectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.PreviewUnselectedEvent
C#
public static readonly RoutedEvent PreviewUnselectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* PreviewUnselectedEvent
C++/CLI
public:
static readonly RoutedEvent^ PreviewUnselectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : SelectedEvent Field

Identifies the Selected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.SelectedEvent
C#
public static readonly RoutedEvent SelectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* SelectedEvent
C++/CLI
public:
static readonly RoutedEvent^ SelectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedImageSrcProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : SelectedImageSrcProperty Field

Identifies the SelectedImageSrc dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedImageSrcProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadTreeViewItem.SelectedImageSrcProperty
C#
public static readonly DependencyProperty SelectedImageSrcProperty
Managed Extensions for C++
public: static readonly DependencyProperty* SelectedImageSrcProperty
C++/CLI
public:
static readonly DependencyProperty^ SelectedImageSrcProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
UncheckedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : UncheckedEvent Field

Identifies the Unchecked routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UncheckedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.UncheckedEvent
C#
public static readonly RoutedEvent UncheckedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* UncheckedEvent
C++/CLI
public:
static readonly RoutedEvent^ UncheckedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
UnselectedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : UnselectedEvent Field

Identifies the Unselected routed event.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UnselectedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadTreeViewItem.UnselectedEvent
C#
public static readonly RoutedEvent UnselectedEvent
Managed Extensions for C++
public: static readonly RoutedEvent* UnselectedEvent
C++/CLI
public:
static readonly RoutedEvent^ UnselectedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItem Class

For a list of all members of this type, see RadTreeViewItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Checked | Occurs when the item is checked.
Public Event | Collapsed | Occurs after the tree item is collapsed
Public Event | Edited | Occurs when a item has been edited
Public Event | Expanded | Occurs after the value of the IsExpanded property of a tree item is changed.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LoadOnDemand | Occurs when the tree item should load its child items on demand.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewChecked | Occurs before the tree item is checked
Public Event | PreviewCollapsed | Occurs before an item is collapsed.
Public Event | PreviewEdited | Occurs before the item to accept the new edit text.
Public Event | PreviewExpanded | Occurs before an item is expanded.
Public Event | PreviewSelected | Occurs before the tree item is selected
Public Event | PreviewUnchecked | Occurs before the tree item is unchecked
Public Event | PreviewUnselected | Occurs before an item is unselected
Public Event | Selected | Occurs after the tree item is selected For more information about handling events, see also PreviewSelected
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unchecked | Occurs when the item is unchecked.
Public Event | Unselected | Occurs after the tree item is unselected
Top

See Also

Reference

RadTreeViewItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Checked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Checked Event

Occurs when the item is checked.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs when the item is checked.")>
Public Event Checked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Checked, handler
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when the item is checked.")]
public event EventHandler<RadRoutedEventArgs> Checked()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when the item is checked.")]
public: __event EventHandler<RadRoutedEventArgs*>* Checked
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when the item is checked.")]
public:
event EventHandler<RadRoutedEventArgs^>^ Checked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Collapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Collapsed Event

Occurs after the tree item is collapsed

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when a item is collapsed.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
Public Event Collapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Collapsed, handler
C#
[DescriptionAttribute("Occurs when a item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public event EventHandler<RadRoutedEventArgs> Collapsed()
Managed Extensions for C++
[DescriptionAttribute("Occurs when a item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public: __event EventHandler<RadRoutedEventArgs*>* Collapsed
C++/CLI
[DescriptionAttribute("Occurs when a item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public:
event EventHandler<RadRoutedEventArgs^>^ Collapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Edited Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Edited Event

Occurs when a item has been edited

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when a item has been edited.")>
<ScriptableMemberAttribute()>
Public Event Edited() As RadTreeViewItemEditedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As RadTreeViewItemEditedEventHandler

AddHandler instance.Edited, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item has been edited.")]
[ScriptableMemberAttribute()]
public event RadTreeViewItemEditedEventHandler Edited()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item has been edited.")]
[ScriptableMemberAttribute()]
public: __event RadTreeViewItemEditedEventHandler* Edited
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item has been edited.")]
[ScriptableMemberAttribute()]
public:
event RadTreeViewItemEditedEventHandler^ Edited

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Expanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Expanded Event

Occurs after the value of the IsExpanded property of a tree item is changed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs when a item is expanded.")>
Public Event Expanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Expanded, handler
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when a item is expanded.")]
public event EventHandler<RadRoutedEventArgs> Expanded()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when a item is expanded.")]
public: __event EventHandler<RadRoutedEventArgs*>* Expanded
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs when a item is expanded.")]
public:
event EventHandler<RadRoutedEventArgs^>^ Expanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LoadOnDemand Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : LoadOnDemand Event

Occurs when the tree item should load its child items on demand.

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when the tree item should load its child items on demand.")>
Public Event LoadOnDemand() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.LoadOnDemand, handler
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the tree item should load its child items on demand.")]
public event EventHandler<RadRoutedEventArgs> LoadOnDemand()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the tree item should load its child items on demand.")]
public: __event EventHandler<RadRoutedEventArgs*>* LoadOnDemand
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the tree item should load its child items on demand.")]
public:
event EventHandler<RadRoutedEventArgs^>^ LoadOnDemand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewChecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewChecked Event

Occurs before the tree item is checked

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs before an item is checked.")>
<CategoryAttribute("Behavior")>
Public Event PreviewChecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewChecked, handler
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is checked.")]
[CategoryAttribute("Behavior")]
public event EventHandler<RadRoutedEventArgs> PreviewChecked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is checked.")]
[CategoryAttribute("Behavior")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewChecked
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is checked.")]
[CategoryAttribute("Behavior")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewChecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewCollapsed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewCollapsed Event

Occurs before an item is collapsed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs before an item is collapsed.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
Public Event PreviewCollapsed() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewCollapsed, handler
C#
[DescriptionAttribute("Occurs before an item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public event EventHandler<RadRoutedEventArgs> PreviewCollapsed()
Managed Extensions for C++
[DescriptionAttribute("Occurs before an item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewCollapsed
C++/CLI
[DescriptionAttribute("Occurs before an item is collapsed.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewCollapsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewEdited Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewEdited Event

Occurs before the item to accept the new edit text.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs before the item to accept the new edit text.")>
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
Public Event PreviewEdited() As RadTreeViewItemEditedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As RadTreeViewItemEditedEventHandler

AddHandler instance.PreviewEdited, handler
C#
[DescriptionAttribute("Occurs before the item to accept the new edit text.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public event RadTreeViewItemEditedEventHandler PreviewEdited()
Managed Extensions for C++
[DescriptionAttribute("Occurs before the item to accept the new edit text.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public: __event RadTreeViewItemEditedEventHandler* PreviewEdited
C++/CLI
[DescriptionAttribute("Occurs before the item to accept the new edit text.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public:
event RadTreeViewItemEditedEventHandler^ PreviewEdited

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewExpanded Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewExpanded Event

Occurs before an item is expanded.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs before an item is expanded.")>
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
Public Event PreviewExpanded() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewExpanded, handler
C#
[DescriptionAttribute("Occurs before an item is expanded.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public event EventHandler<RadRoutedEventArgs> PreviewExpanded()
Managed Extensions for C++
[DescriptionAttribute("Occurs before an item is expanded.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewExpanded
C++/CLI
[DescriptionAttribute("Occurs before an item is expanded.")]
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewExpanded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewSelected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewSelected Event

Occurs before the tree item is selected

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs before the tree item is selected.")>
Public Event PreviewSelected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewSelected, handler
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the tree item is selected.")]
public event EventHandler<RadRoutedEventArgs> PreviewSelected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the tree item is selected.")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewSelected
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs before the tree item is selected.")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewSelected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUnchecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewUnchecked Event

Occurs before the tree item is unchecked

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs before an item is unchecked.")>
<CategoryAttribute("Behavior")>
Public Event PreviewUnchecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewUnchecked, handler
C#
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unchecked.")]
[CategoryAttribute("Behavior")]
public event EventHandler<RadRoutedEventArgs> PreviewUnchecked()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unchecked.")]
[CategoryAttribute("Behavior")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewUnchecked
C++/CLI
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unchecked.")]
[CategoryAttribute("Behavior")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewUnchecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreviewUnselected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : PreviewUnselected Event

Occurs before an item is unselected

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
<DescriptionAttribute("Occurs before an item is unselected.")>
Public Event PreviewUnselected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.PreviewUnselected, handler
C#
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unselected.")]
public event EventHandler<RadRoutedEventArgs> PreviewUnselected()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unselected.")]
public: __event EventHandler<RadRoutedEventArgs*>* PreviewUnselected
C++/CLI
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
[DescriptionAttribute("Occurs before an item is unselected.")]
public:
event EventHandler<RadRoutedEventArgs^>^ PreviewUnselected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Selected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Selected Event

Occurs after the tree item is selected For more information about handling events, see also PreviewSelected

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when a item is selected.")>
<CategoryAttribute("Behavior")>
<ScriptableMemberAttribute()>
Public Event Selected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Selected, handler
C#
[DescriptionAttribute("Occurs when a item is selected.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Selected()
Managed Extensions for C++
[DescriptionAttribute("Occurs when a item is selected.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Selected
C++/CLI
[DescriptionAttribute("Occurs when a item is selected.")]
[CategoryAttribute("Behavior")]
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Selected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Unchecked Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Unchecked Event

Occurs when the item is unchecked.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when the item is unchecked.")>
<ScriptableMemberAttribute()>
Public Event Unchecked() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Unchecked, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the item is unchecked.")]
[ScriptableMemberAttribute()]
public event EventHandler<RadRoutedEventArgs> Unchecked()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the item is unchecked.")]
[ScriptableMemberAttribute()]
public: __event EventHandler<RadRoutedEventArgs*>* Unchecked
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when the item is unchecked.")]
[ScriptableMemberAttribute()]
public:
event EventHandler<RadRoutedEventArgs^>^ Unchecked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Unselected Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItem Class : Unselected Event

Occurs after the tree item is unselected

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Occurs when a item is unselected.")>
Public Event Unselected() As EventHandler(Of RadRoutedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItem
Dim handler As EventHandler(Of RadRoutedEventArgs)

AddHandler instance.Unselected, handler
C#
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item is unselected.")]
public event EventHandler<RadRoutedEventArgs> Unselected()
Managed Extensions for C++
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item is unselected.")]
public: __event EventHandler<RadRoutedEventArgs*>* Unselected
C++/CLI
[ScriptableMemberAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Occurs when a item is unselected.")]
public:
event EventHandler<RadRoutedEventArgs^>^ Unselected

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItem Class
RadTreeViewItem Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemAutomationPeer Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemAutomationPeer Class

Syntax

Visual Basic (Declaration)
Public Class RadTreeViewItemAutomationPeer
   Inherits FrameworkElementAutomationPeer
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemAutomationPeer
C#
public class RadTreeViewItemAutomationPeer : FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class RadTreeViewItemAutomationPeer : public FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class RadTreeViewItemAutomationPeer : public FrameworkElementAutomationPeer, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.Automation.Peers.AutomationPeer
System.Windows.Automation.Peers.FrameworkElementAutomationPeer
Telerik.Windows.Controls.RadTreeViewItemAutomationPeer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemAutomationPeer Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemAutomationPeer Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemAutomationPeer Class

The following tables list the members exposed by RadTreeViewItemAutomationPeer.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewItemAutomationPeer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Owner | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Top

Public Methods

 | Name | Description
Public Method | GetPattern | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetAcceleratorKeyCore | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Protected Method | GetAutomationControlTypeCore | Overridden.
Protected Method | GetClassNameCore | Overridden.
Top

See Also

Reference

RadTreeViewItemAutomationPeer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemAutomationPeer Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemAutomationPeer Class : RadTreeViewItemAutomationPeer Constructor

owner

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As RadTreeViewItem _
)
Visual Basic (Usage) Copy Code
Dim owner As RadTreeViewItem

Dim instance As RadTreeViewItemAutomationPeer(owner)
C#
public RadTreeViewItemAutomationPeer(
   RadTreeViewItem owner
)
Managed Extensions for C++
public: RadTreeViewItemAutomationPeer(
   RadTreeViewItem* owner
)
C++/CLI
public:
RadTreeViewItemAutomationPeer(
   RadTreeViewItem^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemAutomationPeer Class
RadTreeViewItemAutomationPeer Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemAutomationPeer Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemAutomationPeer Class

For a list of all members of this type, see RadTreeViewItemAutomationPeer members.

Public Methods

 | Name | Description
Public Method | GetPattern | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetAcceleratorKeyCore | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Protected Method | GetAutomationControlTypeCore | Overridden.
Protected Method | GetClassNameCore | Overridden.
Top

See Also

Reference

RadTreeViewItemAutomationPeer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetAutomationControlTypeCore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemAutomationPeer Class : GetAutomationControlTypeCore Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetAutomationControlTypeCore() As AutomationControlType
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemAutomationPeer
Dim value As AutomationControlType

value = instance.GetAutomationControlTypeCore()
C#
protected override AutomationControlType GetAutomationControlTypeCore()
Managed Extensions for C++
protected: AutomationControlType GetAutomationControlTypeCore(); override
C++/CLI
protected:
AutomationControlType GetAutomationControlTypeCore(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemAutomationPeer Class
RadTreeViewItemAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetClassNameCore Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemAutomationPeer Class : GetClassNameCore Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetClassNameCore() As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemAutomationPeer
Dim value As String

value = instance.GetClassNameCore()
C#
protected override string GetClassNameCore()
Managed Extensions for C++
protected: string* GetClassNameCore(); override
C++/CLI
protected:
String^ GetClassNameCore(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemAutomationPeer Class
RadTreeViewItemAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
GetPattern Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemAutomationPeer Class : GetPattern Method

patternInterface

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPattern( _
   ByVal patternInterface As PatternInterface _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemAutomationPeer
Dim patternInterface As PatternInterface
Dim value As Object

value = instance.GetPattern(patternInterface)
C#
public override object GetPattern(
   PatternInterface patternInterface
)
Managed Extensions for C++
public: Object* GetPattern(
   PatternInterface patternInterface
) override
C++/CLI
public:
Object^ GetPattern(
   PatternInterface patternInterface
) override

Parameters

patternInterface

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemAutomationPeer Class
RadTreeViewItemAutomationPeer Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemEditedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemEditedEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
<ScriptableTypeAttribute()>
Public Class RadTreeViewItemEditedEventArgs
   Inherits RadRoutedEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemEditedEventArgs
C#
[ScriptableTypeAttribute()]
public class RadTreeViewItemEditedEventArgs : RadRoutedEventArgs
Managed Extensions for C++
[ScriptableTypeAttribute()]
public __gc class RadTreeViewItemEditedEventArgs : public RadRoutedEventArgs
C++/CLI
[ScriptableTypeAttribute()]
public ref class RadTreeViewItemEditedEventArgs : public RadRoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadTreeViewItemEditedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemEditedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemEditedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemEditedEventArgs Class

The following tables list the members exposed by RadTreeViewItemEditedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewItemEditedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | NewText |
Public Property | OldText |
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadTreeViewItemEditedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemEditedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemEditedEventArgs Class : RadTreeViewItemEditedEventArgs Constructor

newText
oldText
routedEvent
source

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal newText As String, _
   ByVal oldText As String, _
   ByVal routedEvent As RoutedEvent, _
   ByVal source As Object _
)
Visual Basic (Usage) Copy Code
Dim newText As String
Dim oldText As String
Dim routedEvent As RoutedEvent
Dim source As Object

Dim instance As RadTreeViewItemEditedEventArgs(newText, oldText, routedEvent, source)
C#
public RadTreeViewItemEditedEventArgs(
   string newText,
   string oldText,
   RoutedEvent routedEvent,
   object source
)
Managed Extensions for C++
public: RadTreeViewItemEditedEventArgs(
   string* newText,
   string* oldText,
   RoutedEvent* routedEvent,
   Object* source
)
C++/CLI
public:
RadTreeViewItemEditedEventArgs(
   String^ newText,
   String^ oldText,
   RoutedEvent^ routedEvent,
   Object^ source
)

Parameters

newText
oldText
routedEvent
source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemEditedEventArgs Class
RadTreeViewItemEditedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemEditedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemEditedEventArgs Class

For a list of all members of this type, see RadTreeViewItemEditedEventArgs members.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | NewText |
Public Property | OldText |
Public Property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Public Property | Source | Gets or sets a reference to the object that raised the event. (Inherited from Telerik.Windows.RadRoutedEventArgs)
Top

See Also

Reference

RadTreeViewItemEditedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
NewText Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemEditedEventArgs Class : NewText Property

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property NewText As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemEditedEventArgs
Dim value As String

value = instance.NewText
C#
[ScriptableMemberAttribute()]
public string NewText {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_NewText();
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ NewText {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemEditedEventArgs Class
RadTreeViewItemEditedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OldText Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadTreeViewItemEditedEventArgs Class : OldText Property

Syntax

Visual Basic (Declaration)
<ScriptableMemberAttribute()>
Public ReadOnly Property OldText As String
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewItemEditedEventArgs
Dim value As String

value = instance.OldText
C#
[ScriptableMemberAttribute()]
public string OldText {get;}
Managed Extensions for C++
[ScriptableMemberAttribute()]
public: __property string* get_OldText();
C++/CLI
[ScriptableMemberAttribute()]
public:
property String^ OldText {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadTreeViewItemEditedEventArgs Class
RadTreeViewItemEditedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

Partial class RadWindow which contains properties declaration and callbacks

Object Model

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
<DefaultPropertyAttribute("Content")>
Public Class RadWindow
   Inherits HeaderedContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
C#
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
[DefaultPropertyAttribute("Content")]
public class RadWindow : HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
[DefaultPropertyAttribute("Content")]
public __gc class RadWindow : public HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1506:AvoidExcessiveClassCoupling",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
[DefaultPropertyAttribute("Content")]
public ref class RadWindow : public HeaderedContentControl, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.HeaderedContentControl
Telerik.Windows.Controls.RadWindow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class Members
See Also Fields Properties Methods Events
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

The following tables list the members exposed by RadWindow.

Public Constructors

 | Name | Description
Public Constructor | RadWindow Constructor | Initializes a new instance of the RadTabControl class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DialogResultProperty | Identifies the DialogResultProperty dependency property.
static (Shared in Visual Basic) | IconProperty | Identifies the IconProperty dependency property.
static (Shared in Visual Basic) | IconTemplateProperty | Identifies the IconTemplateProperty dependency property.
static (Shared in Visual Basic) | IsClosedProperty | Identifies the IsClosedProperty dependency property.
static (Shared in Visual Basic) | LeftProperty | Identifies the LeftProperty dependency property.
static (Shared in Visual Basic) | LocationChangedEvent | Identifies the LocationChanged routed event.
static (Shared in Visual Basic) | ModalBrushProperty | Identifies the ModalBrush dependency property.
static (Shared in Visual Basic) | OpenedEvent | Identifies the Opened routed event.
static (Shared in Visual Basic) | PinModeProperty | Identifies the PinMode dependency property.
static (Shared in Visual Basic) | PreserveSizeAndLocationProperty | Identifies the PreserveSizeAndLocation Property.
static (Shared in Visual Basic) | PromptResultProperty | Identifies the PromptResultProperty dependency property.
static (Shared in Visual Basic) | ResizeModeProperty | Identifies the ResizeMode dependency property.
static (Shared in Visual Basic) | TitleBrushProperty | Identifies the TitleBrush dependency property.
static (Shared in Visual Basic) | TopMostProperty | Identifies the TopMostProperty dependency property.
static (Shared in Visual Basic) | TopProperty | Identifies the TopProperty dependency property.
static (Shared in Visual Basic) | WindowStartupLocationProperty | Identifies the IconProperty dependency property.
static (Shared in Visual Basic) | WindowStateChangedEvent | Identifies the WindowStateChanged routed event.
static (Shared in Visual Basic) | WindowStateProperty | Identifies the WindowState dependency property.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | DialogResult | Gets or sets a DialogResult value for the RadWindow. This is a dependency property.
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Header | Gets or sets the header of the control. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Icon | Gets or sets the Icon image to appear in the RadWindow titlebar. This is a dependency property.
Public Property | IconTemplate | Gets or sets the IconTemplate property. This is a dependency property.
Public Property | IsClosed | Gets a value for the RadWindow representing the current closed state. This is a dependency property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMaximized | Gets a value that represents whether the RadWindow is maximized.
Public Property | IsModal | Gets a value that represents whether the RadWindow is modal.
Public Property | IsOpen | Gets a value for the RadWindow representing the current open state. This is a dependency property.
Public Property | IsPinned | Gets the value representing whether the RadWindow is pinned;
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.
Public Property | LeftOffset | Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | ModalBrush | Gets or sets a title brush for the modal background of a window. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PinMode | Gets or sets a PinMode value for the RadWindow. This is a dependency property.
Public Property | PreserveSizeAndLocation | Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.
Public Property | PromptResult | Gets or sets a PromptResult value for the RadWindow. This is a dependency property.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ResizeMode | Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TitleBrush | Gets or sets a title brush for the title. This is a dependency property.
Public Property | Top | Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.
Public Property | TopMost | Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property
Public Property | TopOffset | Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | WindowStartupLocation | Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.
Public Property | WindowState | Gets or sets a WindowState value for the RadWindow. This is a dependency property.
Public Property | Z | Gets the Z order of the RadWindow.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Alert | Overloaded. Opens an Alert modal window.
Public Method | BringToFront | Attemps to bring to window over any other windows except topmost.
Public Method | Close | Manually closes a window.
static (Shared in Visual Basic) | Confirm | Overloaded. Opens a Confirm modal window.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | Hide | Makes a RadWindow invisible.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
static (Shared in Visual Basic) | Prompt | Overloaded. Opens a Prompt modal window.
Public Method | Show | Opens a window.
Public Method | ShowDialog | Opens a modal RadWindow.
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnHeaderChanged | Allows derived classes to act on header change. (Inherited from HeaderedContentControl)
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change. (Inherited from HeaderedContentControl)
Protected Method | OnIsEnabledChanged | //TODO: Document (Inherited from HeaderedContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Closed | Occurs when the RadWindow is closed.
Public Event | Closing | Occurs when the RadWindow is closing.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LocationChanged | Occurs when the value of a Left or Top changes.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Opened | Occurs when the RadWindow is opened.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | WindowStateChanged | Occurs when the value of a WindowState changes.
Top

See Also

Reference

RadWindow Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : RadWindow Constructor

Initializes a new instance of the RadTabControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow()
C#
public RadWindow()
Managed Extensions for C++
public: RadWindow();
C++/CLI
public:
RadWindow();

Remarks

Use this constructor to create an instance of the RadWindow. In order for the TabControl to be displayed, it is not necessary to add it to the visual tree.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Alert | Overloaded. Opens an Alert modal window.
Public Method | BringToFront | Attemps to bring to window over any other windows except topmost.
Public Method | Close | Manually closes a window.
static (Shared in Visual Basic) | Confirm | Overloaded. Opens a Confirm modal window.
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | Hide | Makes a RadWindow invisible.
Public Method | OnApplyTemplate | Overridden. When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.
static (Shared in Visual Basic) | Prompt | Overloaded. Opens a Prompt modal window.
Public Method | Show | Opens a window.
Public Method | ShowDialog | Opens a modal RadWindow.
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnHeaderChanged | Allows derived classes to act on header change. (Inherited from HeaderedContentControl)
Protected Method | OnHeaderTemplateChanged | Allows derived classes to act on HeaderTemplate change. (Inherited from HeaderedContentControl)
Protected Method | OnIsEnabledChanged | //TODO: Document (Inherited from HeaderedContentControl)
Top

See Also

Reference

RadWindow Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Alert Method

Opens an Alert modal window.

Overload List

Overload | Description
Alert(Object) | Opens an Alert modal window.
Alert(Object,Object) | Opens an Alert modal window.
Alert(Object,Object,Generic EventHandler) |
Alert(Object,Object,Generic EventHandler,RoutedEventHandler) |
Alert(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert(Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Alert Method : Alert(Object) Method

text
Text to be displayed.
Opens an Alert modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Alert( _
   ByVal text As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object

RadWindow.Alert(text)
C#
public static void Alert(
   object text
)
Managed Extensions for C++
public: static void Alert(
   Object* text
)
C++/CLI
public:
static void Alert(
   Object^ text
)

Parameters

text
Text to be displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert(Object,Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Alert Method : Alert(Object,Object) Method

text
Text to be displayed.
header
Object to appear in the titlebar.
Opens an Alert modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Alert( _
   ByVal text As Object, _
   ByVal header As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object

RadWindow.Alert(text, header)
C#
public static void Alert(
   object text,
   object header
)
Managed Extensions for C++
public: static void Alert(
   Object* text,
   Object* header
)
C++/CLI
public:
static void Alert(
   Object^ text,
   Object^ header
)

Parameters

text
Text to be displayed.
header
Object to appear in the titlebar.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert(Object,Object,Generic EventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Alert Method : Alert(Object,Object,Generic EventHandler) Method

text
header
closed

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Alert( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)

RadWindow.Alert(text, header, closed)
C#
public static void Alert(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed
)
Managed Extensions for C++
public: static void Alert(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed
)
C++/CLI
public:
static void Alert(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed
)

Parameters

text
header
closed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert(Object,Object,Generic EventHandler,RoutedEventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Alert Method : Alert(Object,Object,Generic EventHandler,RoutedEventHandler) Method

text
header
closed
opened

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Alert( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler

RadWindow.Alert(text, header, closed, opened)
C#
public static void Alert(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened
)
Managed Extensions for C++
public: static void Alert(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened
)
C++/CLI
public:
static void Alert(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened
)

Parameters

text
header
closed
opened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Alert(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Alert Method : Alert(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method

text
header
closed
opened
theme

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Alert( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler, _
   ByVal theme As Theme _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler
Dim theme As Theme

RadWindow.Alert(text, header, closed, opened, theme)
C#
public static void Alert(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened,
   Theme theme
)
Managed Extensions for C++
public: static void Alert(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened,
   Theme* theme
)
C++/CLI
public:
static void Alert(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened,
   Theme^ theme
)

Parameters

text
header
closed
opened
theme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
BringToFront Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : BringToFront Method

Attemps to bring to window over any other windows except topmost.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.BringToFront()
C#
public void BringToFront()
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Close Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Close Method

Manually closes a window.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Confirm Method

Opens a Confirm modal window.

Overload List

Overload | Description
Confirm(Object) | Opens a Confirm modal window.
Confirm(Object,Object) | Opens a Confirm modal window.
Confirm(Object,Object,Generic EventHandler) |
Confirm(Object,Object,Generic EventHandler,RoutedEventHandler) |
Confirm(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm(Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Confirm Method : Confirm(Object) Method

text
Text to be displayed.
Opens a Confirm modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Confirm( _
   ByVal text As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object

RadWindow.Confirm(text)
C#
public static void Confirm(
   object text
)
Managed Extensions for C++
public: static void Confirm(
   Object* text
)
C++/CLI
public:
static void Confirm(
   Object^ text
)

Parameters

text
Text to be displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm(Object,Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Confirm Method : Confirm(Object,Object) Method

text
Text to be displayed.
header
Object to appear in the titlebar.
Opens a Confirm modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Confirm( _
   ByVal text As Object, _
   ByVal header As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object

RadWindow.Confirm(text, header)
C#
public static void Confirm(
   object text,
   object header
)
Managed Extensions for C++
public: static void Confirm(
   Object* text,
   Object* header
)
C++/CLI
public:
static void Confirm(
   Object^ text,
   Object^ header
)

Parameters

text
Text to be displayed.
header
Object to appear in the titlebar.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm(Object,Object,Generic EventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Confirm Method : Confirm(Object,Object,Generic EventHandler) Method

text
header
closed

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Confirm( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)

RadWindow.Confirm(text, header, closed)
C#
public static void Confirm(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed
)
Managed Extensions for C++
public: static void Confirm(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed
)
C++/CLI
public:
static void Confirm(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed
)

Parameters

text
header
closed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm(Object,Object,Generic EventHandler,RoutedEventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Confirm Method : Confirm(Object,Object,Generic EventHandler,RoutedEventHandler) Method

text
header
closed
opened

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Confirm( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler

RadWindow.Confirm(text, header, closed, opened)
C#
public static void Confirm(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened
)
Managed Extensions for C++
public: static void Confirm(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened
)
C++/CLI
public:
static void Confirm(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened
)

Parameters

text
header
closed
opened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Confirm(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Confirm Method : Confirm(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method

text
header
closed
opened
theme

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Confirm( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler, _
   ByVal theme As Theme _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler
Dim theme As Theme

RadWindow.Confirm(text, header, closed, opened, theme)
C#
public static void Confirm(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened,
   Theme theme
)
Managed Extensions for C++
public: static void Confirm(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened,
   Theme* theme
)
C++/CLI
public:
static void Confirm(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened,
   Theme^ theme
)

Parameters

text
header
closed
opened
theme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Hide Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Hide Method

Makes a RadWindow invisible.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.Hide()
C#
public void Hide()
Managed Extensions for C++
public: void Hide();
C++/CLI
public:
void Hide();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OnApplyTemplate Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.OnApplyTemplate()
C#
public override void OnApplyTemplate()
Managed Extensions for C++
public: void OnApplyTemplate(); override
C++/CLI
public:
void OnApplyTemplate(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Prompt Method

Opens a Prompt modal window.

Overload List

Overload | Description
Prompt(Object) | Opens a Prompt modal window.
Prompt(Object,Object) | Opens a Prompt modal window.
Prompt(Object,Object,Generic EventHandler) |
Prompt(Object,Object,Generic EventHandler,RoutedEventHandler) |
Prompt(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt(Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Prompt Method : Prompt(Object) Method

text
Question to the user.
Opens a Prompt modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Prompt( _
   ByVal text As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object

RadWindow.Prompt(text)
C#
public static void Prompt(
   object text
)
Managed Extensions for C++
public: static void Prompt(
   Object* text
)
C++/CLI
public:
static void Prompt(
   Object^ text
)

Parameters

text
Question to the user.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt(Object,Object) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Prompt Method : Prompt(Object,Object) Method

text
Question to the user.
header
Object to appear in the titlebar.
Opens a Prompt modal window.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Prompt( _
   ByVal text As Object, _
   ByVal header As Object _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object

RadWindow.Prompt(text, header)
C#
public static void Prompt(
   object text,
   object header
)
Managed Extensions for C++
public: static void Prompt(
   Object* text,
   Object* header
)
C++/CLI
public:
static void Prompt(
   Object^ text,
   Object^ header
)

Parameters

text
Question to the user.
header
Object to appear in the titlebar.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt(Object,Object,Generic EventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Prompt Method : Prompt(Object,Object,Generic EventHandler) Method

text
header
closed

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Prompt( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs) _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)

RadWindow.Prompt(text, header, closed)
C#
public static void Prompt(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed
)
Managed Extensions for C++
public: static void Prompt(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed
)
C++/CLI
public:
static void Prompt(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed
)

Parameters

text
header
closed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt(Object,Object,Generic EventHandler,RoutedEventHandler) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Prompt Method : Prompt(Object,Object,Generic EventHandler,RoutedEventHandler) Method

text
header
closed
opened

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Prompt( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler

RadWindow.Prompt(text, header, closed, opened)
C#
public static void Prompt(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened
)
Managed Extensions for C++
public: static void Prompt(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened
)
C++/CLI
public:
static void Prompt(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened
)

Parameters

text
header
closed
opened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Prompt(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class > Prompt Method : Prompt(Object,Object,Generic EventHandler,RoutedEventHandler,Theme) Method

text
header
closed
opened
theme

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Prompt( _
   ByVal text As Object, _
   ByVal header As Object, _
   ByVal closed As EventHandler(Of WindowClosedEventArgs), _
   ByVal opened As RoutedEventHandler, _
   ByVal theme As Theme _
)
Visual Basic (Usage) Copy Code
Dim text As Object
Dim header As Object
Dim closed As EventHandler(Of WindowClosedEventArgs)
Dim opened As RoutedEventHandler
Dim theme As Theme

RadWindow.Prompt(text, header, closed, opened, theme)
C#
public static void Prompt(
   object text,
   object header,
   EventHandler<WindowClosedEventArgs> closed,
   RoutedEventHandler opened,
   Theme theme
)
Managed Extensions for C++
public: static void Prompt(
   Object* text,
   Object* header,
   EventHandler<WindowClosedEventArgs*>* closed,
   RoutedEventHandler* opened,
   Theme* theme
)
C++/CLI
public:
static void Prompt(
   Object^ text,
   Object^ header,
   EventHandler<WindowClosedEventArgs^>^ closed,
   RoutedEventHandler^ opened,
   Theme^ theme
)

Parameters

text
header
closed
opened
theme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members
Overload List


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Show Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Show Method

Opens a window.

Syntax

Visual Basic (Declaration)
Public Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.Show()
C#
public void Show()
Managed Extensions for C++
public: void Show();
C++/CLI
public:
void Show();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ShowDialog Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ShowDialog Method

Opens a modal RadWindow.

Syntax

Visual Basic (Declaration)
Public Sub ShowDialog()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow

instance.ShowDialog()
C#
public void ShowDialog()
Managed Extensions for C++
public: void ShowDialog();
C++/CLI
public:
void ShowDialog();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | DialogResult | Gets or sets a DialogResult value for the RadWindow. This is a dependency property.
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasHeader | Gets whether there is header assigned. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Header | Gets or sets the header of the control. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | HeaderTemplate | Gets or sets the data tempalte for the header. This is a dependency property. (Inherited from HeaderedContentControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Icon | Gets or sets the Icon image to appear in the RadWindow titlebar. This is a dependency property.
Public Property | IconTemplate | Gets or sets the IconTemplate property. This is a dependency property.
Public Property | IsClosed | Gets a value for the RadWindow representing the current closed state. This is a dependency property.
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsMaximized | Gets a value that represents whether the RadWindow is maximized.
Public Property | IsModal | Gets a value that represents whether the RadWindow is modal.
Public Property | IsOpen | Gets a value for the RadWindow representing the current open state. This is a dependency property.
Public Property | IsPinned | Gets the value representing whether the RadWindow is pinned;
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.
Public Property | LeftOffset | Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | ModalBrush | Gets or sets a title brush for the modal background of a window. This is a dependency property.
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PinMode | Gets or sets a PinMode value for the RadWindow. This is a dependency property.
Public Property | PreserveSizeAndLocation | Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.
Public Property | PromptResult | Gets or sets a PromptResult value for the RadWindow. This is a dependency property.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ResizeMode | Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TitleBrush | Gets or sets a title brush for the title. This is a dependency property.
Public Property | Top | Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.
Public Property | TopMost | Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property
Public Property | TopOffset | Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | WindowStartupLocation | Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.
Public Property | WindowState | Gets or sets a WindowState value for the RadWindow. This is a dependency property.
Public Property | Z | Gets the Z order of the RadWindow.
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadWindow Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DialogResult Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : DialogResult Property

Gets or sets a DialogResult value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets a DialogResult value for the RadWindow. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
Public Property DialogResult As Nullable(Of Boolean)
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Nullable(Of Boolean)

instance.DialogResult = value

value = instance.DialogResult
C#
[SRDescriptionAttribute("Gets or sets a DialogResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public Nullable<bool> DialogResult {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets a DialogResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public: __property Nullable<bool> get_DialogResult();
public: __property void set_DialogResult(
   Nullable<bool> value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets a DialogResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public:
property Nullable<bool> DialogResult {
   Nullable<bool> get();
   void set (Nullable<bool> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Icon Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Icon Property

Gets or sets the Icon image to appear in the RadWindow titlebar. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets the Icon image to appear in the RadWindow title bar. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
Public Property Icon As Object
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Object

instance.Icon = value

value = instance.Icon
C#
[SRDescriptionAttribute("Gets or sets the Icon image to appear in the RadWindow title bar. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public object Icon {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets the Icon image to appear in the RadWindow title bar. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public: __property Object* get_Icon();
public: __property void set_Icon(
   Object* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets the Icon image to appear in the RadWindow title bar. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public:
property Object^ Icon {
   Object^ get();
   void set (Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IconTemplate Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IconTemplate Property

Gets or sets the IconTemplate property. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the IconTemplate property. This is a dependency property.")>
Public Property IconTemplate As DataTemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As DataTemplate

instance.IconTemplate = value

value = instance.IconTemplate
C#
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the IconTemplate property. This is a dependency property.")]
public DataTemplate IconTemplate {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the IconTemplate property. This is a dependency property.")]
public: __property DataTemplate* get_IconTemplate();
public: __property void set_IconTemplate(
   DataTemplate* value
);
C++/CLI
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the IconTemplate property. This is a dependency property.")]
public:
property DataTemplate^ IconTemplate {
   DataTemplate^ get();
   void set (DataTemplate^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsClosed Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsClosed Property

Gets a value for the RadWindow representing the current closed state. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets a value for the RadWindow representing the current closed state. This is a dependency property.")>
<SRCategoryAttribute("MiscCategory")>
Public ReadOnly Property IsClosed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

value = instance.IsClosed
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current closed state. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public bool IsClosed {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current closed state. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public: __property bool get_IsClosed();
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current closed state. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public:
property bool IsClosed {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsMaximized Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsMaximized Property

Gets a value that represents whether the RadWindow is maximized.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets a value that represents whether the RadWindow is maximized.")>
<SRCategoryAttribute("MiscCategory")>
Public Property IsMaximized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

instance.IsMaximized = value

value = instance.IsMaximized
C#
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is maximized.")]
[SRCategoryAttribute("MiscCategory")]
public bool IsMaximized {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is maximized.")]
[SRCategoryAttribute("MiscCategory")]
public: __property bool get_IsMaximized();
public: __property void set_IsMaximized(
   bool value
);
C++/CLI
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is maximized.")]
[SRCategoryAttribute("MiscCategory")]
public:
property bool IsMaximized {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsModal Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsModal Property

Gets a value that represents whether the RadWindow is modal.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets a value that represents whether the RadWindow is modal.")>
Public ReadOnly Property IsModal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

value = instance.IsModal
C#
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is modal.")]
public bool IsModal {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is modal.")]
public: __property bool get_IsModal();
C++/CLI
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets a value that represents whether the RadWindow is modal.")]
public:
property bool IsModal {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsOpen Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsOpen Property

Gets a value for the RadWindow representing the current open state. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets a value for the RadWindow representing the current open state. This is a dependency property.")>
Public ReadOnly Property IsOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

value = instance.IsOpen
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current open state. This is a dependency property.")]
public bool IsOpen {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current open state. This is a dependency property.")]
public: __property bool get_IsOpen();
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets a value for the RadWindow representing the current open state. This is a dependency property.")]
public:
property bool IsOpen {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsPinned Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsPinned Property

Gets the value representing whether the RadWindow is pinned;

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets the value representing whether the RadWindow is pinned;")>
<SRCategoryAttribute("MiscCategory")>
Public ReadOnly Property IsPinned As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

value = instance.IsPinned
C#
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the value representing whether the RadWindow is pinned;")]
[SRCategoryAttribute("MiscCategory")]
public bool IsPinned {get;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the value representing whether the RadWindow is pinned;")]
[SRCategoryAttribute("MiscCategory")]
public: __property bool get_IsPinned();
C++/CLI
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets the value representing whether the RadWindow is pinned;")]
[SRCategoryAttribute("MiscCategory")]
public:
property bool IsPinned {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Left Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Left Property

Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.")>
<DefaultValueAttribute()>
Public Property Left As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Double

instance.Left = value

value = instance.Left
C#
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.")]
[DefaultValueAttribute()]
public double Left {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.")]
[DefaultValueAttribute()]
public: __property double get_Left();
public: __property void set_Left(
   double value
);
C++/CLI
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the left side of an element and the left side of the page. This is a dependency property.")]
[DefaultValueAttribute()]
public:
property double Left {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftOffset Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : LeftOffset Property

Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")>
Public Property LeftOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Double

instance.LeftOffset = value

value = instance.LeftOffset
C#
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
public double LeftOffset {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
public: __property double get_LeftOffset();
public: __property void set_LeftOffset(
   double value
);
C++/CLI
[CompilerGeneratedAttribute()]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Left position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
public:
property double LeftOffset {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ModalBrush Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ModalBrush Property

Gets or sets a title brush for the modal background of a window. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets a title brush for the modal background of a window. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("BrushesCategory")>
Public Property ModalBrush As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Brush

instance.ModalBrush = value

value = instance.ModalBrush
C#
[SRDescriptionAttribute("Gets or sets a title brush for the modal background of a window. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BrushesCategory")]
public Brush ModalBrush {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets a title brush for the modal background of a window. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BrushesCategory")]
public: __property Brush* get_ModalBrush();
public: __property void set_ModalBrush(
   Brush* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets a title brush for the modal background of a window. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("BrushesCategory")]
public:
property Brush^ ModalBrush {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PinMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PinMode Property

Gets or sets a PinMode value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets a PinMode value for the RadWindow. This is a dependency property.")>
Public Property PinMode As PinMode
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As PinMode

instance.PinMode = value

value = instance.PinMode
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a PinMode value for the RadWindow. This is a dependency property.")]
public PinMode PinMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a PinMode value for the RadWindow. This is a dependency property.")]
public: __property PinMode get_PinMode();
public: __property void set_PinMode(
   PinMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a PinMode value for the RadWindow. This is a dependency property.")]
public:
property PinMode PinMode {
   PinMode get();
   void set (PinMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreserveSizeAndLocation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PreserveSizeAndLocation Property

Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.")>
Public Property PreserveSizeAndLocation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

instance.PreserveSizeAndLocation = value

value = instance.PreserveSizeAndLocation
C#
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.")]
public bool PreserveSizeAndLocation {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.")]
public: __property bool get_PreserveSizeAndLocation();
public: __property void set_PreserveSizeAndLocation(
   bool value
);
C++/CLI
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets the value which determines whether the window preserves its size and location when WindowState property is changed. This is a dependency property.")]
public:
property bool PreserveSizeAndLocation {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PromptResult Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PromptResult Property

Gets or sets a PromptResult value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets a PromptResult value for the RadWindow. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
Public Property PromptResult As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As String

instance.PromptResult = value

value = instance.PromptResult
C#
[SRDescriptionAttribute("Gets or sets a PromptResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public string PromptResult {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets a PromptResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public: __property string* get_PromptResult();
public: __property void set_PromptResult(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets a PromptResult value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public:
property String^ PromptResult {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ResizeMode Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ResizeMode Property

Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.")>
<SRCategoryAttribute("MiscCategory")>
Public Property ResizeMode As ResizeMode
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As ResizeMode

instance.ResizeMode = value

value = instance.ResizeMode
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public ResizeMode ResizeMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public: __property ResizeMode get_ResizeMode();
public: __property void set_ResizeMode(
   ResizeMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a ResizeMode value for the RadWindow. This is a dependency property.")]
[SRCategoryAttribute("MiscCategory")]
public:
property ResizeMode ResizeMode {
   ResizeMode get();
   void set (ResizeMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TitleBrush Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TitleBrush Property

Gets or sets a title brush for the title. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets a title brush for the title. This is a dependency property.")>
<SRCategoryAttribute("BrushesCategory")>
Public Property TitleBrush As Brush
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Brush

instance.TitleBrush = value

value = instance.TitleBrush
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a title brush for the title. This is a dependency property.")]
[SRCategoryAttribute("BrushesCategory")]
public Brush TitleBrush {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a title brush for the title. This is a dependency property.")]
[SRCategoryAttribute("BrushesCategory")]
public: __property Brush* get_TitleBrush();
public: __property void set_TitleBrush(
   Brush* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a title brush for the title. This is a dependency property.")]
[SRCategoryAttribute("BrushesCategory")]
public:
property Brush^ TitleBrush {
   Brush^ get();
   void set (Brush^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Top Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Top Property

Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.")>
Public Property Top As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Double

instance.Top = value

value = instance.Top
C#
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.")]
public double Top {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.")]
public: __property double get_Top();
public: __property void set_Top(
   double value
);
C++/CLI
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets a value that represents the distance between the top of an element and the top of the page. This is a dependency property.")]
public:
property double Top {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopMost Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TopMost Property

Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property")>
Public Property TopMost As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

instance.TopMost = value

value = instance.TopMost
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property")]
public bool TopMost {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property")]
public: __property bool get_TopMost();
public: __property void set_TopMost(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a value that indicates whether a window appears in the topmost z-order. This is a dependency property")]
public:
property bool TopMost {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopOffset Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TopOffset Property

Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")>
<SRCategoryAttribute("MiscCategory")>
Public Property TopOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Double

instance.TopOffset = value

value = instance.TopOffset
C#
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
[SRCategoryAttribute("MiscCategory")]
public double TopOffset {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
[SRCategoryAttribute("MiscCategory")]
public: __property double get_TopOffset();
public: __property void set_TopOffset(
   double value
);
C++/CLI
[CompilerGeneratedAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Gets or sets an offset value for the Top position in case of WindowStartupLocation.CenterParent and WindowStartupLocation.CenterParent")]
[SRCategoryAttribute("MiscCategory")]
public:
property double TopOffset {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStartupLocation Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowStartupLocation Property

Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
<SRDescriptionAttribute("Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.")>
Public Property WindowStartupLocation As WindowStartupLocation
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As WindowStartupLocation

instance.WindowStartupLocation = value

value = instance.WindowStartupLocation
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.")]
public WindowStartupLocation WindowStartupLocation {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.")]
public: __property WindowStartupLocation get_WindowStartupLocation();
public: __property void set_WindowStartupLocation(
   WindowStartupLocation value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
[SRDescriptionAttribute("Gets or sets a WindowStartupLocation value for the RadWindow. This is a dependency property.")]
public:
property WindowStartupLocation WindowStartupLocation {
   WindowStartupLocation get();
   void set (WindowStartupLocation value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowState Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowState Property

Gets or sets a WindowState value for the RadWindow. This is a dependency property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets or sets a WindowState value for the RadWindow. This is a dependency property.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("MiscCategory")>
Public Property WindowState As WindowState
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As WindowState

instance.WindowState = value

value = instance.WindowState
C#
[SRDescriptionAttribute("Gets or sets a WindowState value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public WindowState WindowState {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets or sets a WindowState value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public: __property WindowState get_WindowState();
public: __property void set_WindowState(
   WindowState value
);
C++/CLI
[SRDescriptionAttribute("Gets or sets a WindowState value for the RadWindow. This is a dependency property.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("MiscCategory")]
public:
property WindowState WindowState {
   WindowState get();
   void set (WindowState value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Z Property
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Z Property

Gets the Z order of the RadWindow.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets the Z order of the RadWindow.")>
<SRCategoryAttribute("MiscCategory")>
<DefaultValueAttribute()>
Public ReadOnly Property Z As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Integer

value = instance.Z
C#
[SRDescriptionAttribute("Gets the Z order of the RadWindow.")]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
public int Z {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Gets the Z order of the RadWindow.")]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
public: __property int get_Z();
C++/CLI
[SRDescriptionAttribute("Gets the Z order of the RadWindow.")]
[SRCategoryAttribute("MiscCategory")]
[DefaultValueAttribute()]
public:
property int Z {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%% $$Fields$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class Fields
See Also
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DialogResultProperty | Identifies the DialogResultProperty dependency property.
static (Shared in Visual Basic) | IconProperty | Identifies the IconProperty dependency property.
static (Shared in Visual Basic) | IconTemplateProperty | Identifies the IconTemplateProperty dependency property.
static (Shared in Visual Basic) | IsClosedProperty | Identifies the IsClosedProperty dependency property.
static (Shared in Visual Basic) | LeftProperty | Identifies the LeftProperty dependency property.
static (Shared in Visual Basic) | LocationChangedEvent | Identifies the LocationChanged routed event.
static (Shared in Visual Basic) | ModalBrushProperty | Identifies the ModalBrush dependency property.
static (Shared in Visual Basic) | OpenedEvent | Identifies the Opened routed event.
static (Shared in Visual Basic) | PinModeProperty | Identifies the PinMode dependency property.
static (Shared in Visual Basic) | PreserveSizeAndLocationProperty | Identifies the PreserveSizeAndLocation Property.
static (Shared in Visual Basic) | PromptResultProperty | Identifies the PromptResultProperty dependency property.
static (Shared in Visual Basic) | ResizeModeProperty | Identifies the ResizeMode dependency property.
static (Shared in Visual Basic) | TitleBrushProperty | Identifies the TitleBrush dependency property.
static (Shared in Visual Basic) | TopMostProperty | Identifies the TopMostProperty dependency property.
static (Shared in Visual Basic) | TopProperty | Identifies the TopProperty dependency property.
static (Shared in Visual Basic) | WindowStartupLocationProperty | Identifies the IconProperty dependency property.
static (Shared in Visual Basic) | WindowStateChangedEvent | Identifies the WindowStateChanged routed event.
static (Shared in Visual Basic) | WindowStateProperty | Identifies the WindowState dependency property.
Top

See Also

Reference

RadWindow Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DialogResultProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : DialogResultProperty Field

Identifies the DialogResultProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DialogResultProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.DialogResultProperty
C#
public static readonly DependencyProperty DialogResultProperty
Managed Extensions for C++
public: static readonly DependencyProperty* DialogResultProperty
C++/CLI
public:
static readonly DependencyProperty^ DialogResultProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IconProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IconProperty Field

Identifies the IconProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IconProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.IconProperty
C#
public static readonly DependencyProperty IconProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IconProperty
C++/CLI
public:
static readonly DependencyProperty^ IconProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IconTemplateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IconTemplateProperty Field

Identifies the IconTemplateProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IconTemplateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.IconTemplateProperty
C#
public static readonly DependencyProperty IconTemplateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IconTemplateProperty
C++/CLI
public:
static readonly DependencyProperty^ IconTemplateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
IsClosedProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : IsClosedProperty Field

Identifies the IsClosedProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IsClosedProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.IsClosedProperty
C#
public static readonly DependencyProperty IsClosedProperty
Managed Extensions for C++
public: static readonly DependencyProperty* IsClosedProperty
C++/CLI
public:
static readonly DependencyProperty^ IsClosedProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LeftProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : LeftProperty Field

Identifies the LeftProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LeftProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.LeftProperty
C#
public static readonly DependencyProperty LeftProperty
Managed Extensions for C++
public: static readonly DependencyProperty* LeftProperty
C++/CLI
public:
static readonly DependencyProperty^ LeftProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LocationChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : LocationChangedEvent Field

Identifies the LocationChanged routed event.

Syntax

Visual Basic (Declaration)
Public Shared LocationChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadWindow.LocationChangedEvent

RadWindow.LocationChangedEvent = value
C#
public static RoutedEvent LocationChangedEvent
Managed Extensions for C++
public: static RoutedEvent* LocationChangedEvent
C++/CLI
public:
static RoutedEvent^ LocationChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ModalBrushProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ModalBrushProperty Field

Identifies the ModalBrush dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ModalBrushProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.ModalBrushProperty
C#
public static readonly DependencyProperty ModalBrushProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ModalBrushProperty
C++/CLI
public:
static readonly DependencyProperty^ ModalBrushProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OpenedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : OpenedEvent Field

Identifies the Opened routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly OpenedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadWindow.OpenedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent OpenedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* OpenedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ OpenedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PinModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PinModeProperty Field

Identifies the PinMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PinModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.PinModeProperty
C#
public static readonly DependencyProperty PinModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PinModeProperty
C++/CLI
public:
static readonly DependencyProperty^ PinModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PreserveSizeAndLocationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PreserveSizeAndLocationProperty Field

Identifies the PreserveSizeAndLocation Property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreserveSizeAndLocationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.PreserveSizeAndLocationProperty
C#
public static readonly DependencyProperty PreserveSizeAndLocationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PreserveSizeAndLocationProperty
C++/CLI
public:
static readonly DependencyProperty^ PreserveSizeAndLocationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PromptResultProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : PromptResultProperty Field

Identifies the PromptResultProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PromptResultProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.PromptResultProperty
C#
public static readonly DependencyProperty PromptResultProperty
Managed Extensions for C++
public: static readonly DependencyProperty* PromptResultProperty
C++/CLI
public:
static readonly DependencyProperty^ PromptResultProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ResizeModeProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : ResizeModeProperty Field

Identifies the ResizeMode dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ResizeModeProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.ResizeModeProperty
C#
public static readonly DependencyProperty ResizeModeProperty
Managed Extensions for C++
public: static readonly DependencyProperty* ResizeModeProperty
C++/CLI
public:
static readonly DependencyProperty^ ResizeModeProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TitleBrushProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TitleBrushProperty Field

Identifies the TitleBrush dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TitleBrushProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.TitleBrushProperty
C#
public static readonly DependencyProperty TitleBrushProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TitleBrushProperty
C++/CLI
public:
static readonly DependencyProperty^ TitleBrushProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopMostProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TopMostProperty Field

Identifies the TopMostProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopMostProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.TopMostProperty
C#
public static readonly DependencyProperty TopMostProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopMostProperty
C++/CLI
public:
static readonly DependencyProperty^ TopMostProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TopProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : TopProperty Field

Identifies the TopProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TopProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.TopProperty
C#
public static readonly DependencyProperty TopProperty
Managed Extensions for C++
public: static readonly DependencyProperty* TopProperty
C++/CLI
public:
static readonly DependencyProperty^ TopProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStartupLocationProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowStartupLocationProperty Field

Identifies the IconProperty dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly WindowStartupLocationProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.WindowStartupLocationProperty
C#
public static readonly DependencyProperty WindowStartupLocationProperty
Managed Extensions for C++
public: static readonly DependencyProperty* WindowStartupLocationProperty
C++/CLI
public:
static readonly DependencyProperty^ WindowStartupLocationProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStateChangedEvent Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowStateChangedEvent Field

Identifies the WindowStateChanged routed event.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Public Shared ReadOnly WindowStateChangedEvent As RoutedEvent
Visual Basic (Usage) Copy Code
Dim value As RoutedEvent

value = RadWindow.WindowStateChangedEvent
C#
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public static readonly RoutedEvent WindowStateChangedEvent
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public: static readonly RoutedEvent* WindowStateChangedEvent
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Security",
   CheckId="CA2104:DoNotDeclareReadOnlyMutableReferenceTypes",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
public:
static readonly RoutedEvent^ WindowStateChangedEvent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStateProperty Field
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowStateProperty Field

Identifies the WindowState dependency property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly WindowStateProperty As DependencyProperty
Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = RadWindow.WindowStateProperty
C#
public static readonly DependencyProperty WindowStateProperty
Managed Extensions for C++
public: static readonly DependencyProperty* WindowStateProperty
C++/CLI
public:
static readonly DependencyProperty^ WindowStateProperty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindow Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Closed | Occurs when the RadWindow is closed.
Public Event | Closing | Occurs when the RadWindow is closing.
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LocationChanged | Occurs when the value of a Left or Top changes.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Opened | Occurs when the RadWindow is opened.
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | WindowStateChanged | Occurs when the value of a WindowState changes.
Top

See Also

Reference

RadWindow Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Closed Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Closed Event

Occurs when the RadWindow is closed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Closed() As EventHandler(Of WindowClosedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim handler As EventHandler(Of WindowClosedEventArgs)

AddHandler instance.Closed, handler
C#
[SRCategoryAttribute("Behavior")]
public event EventHandler<WindowClosedEventArgs> Closed()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event EventHandler<WindowClosedEventArgs*>* Closed
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event EventHandler<WindowClosedEventArgs^>^ Closed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Closing Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Closing Event

Occurs when the RadWindow is closing.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Closing() As EventHandler(Of WindowClosingEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim handler As EventHandler(Of WindowClosingEventArgs)

AddHandler instance.Closing, handler
C#
[SRCategoryAttribute("Behavior")]
public event EventHandler<WindowClosingEventArgs> Closing()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event EventHandler<WindowClosingEventArgs*>* Closing
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event EventHandler<WindowClosingEventArgs^>^ Closing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
LocationChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : LocationChanged Event

Occurs when the value of a Left or Top changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event LocationChanged() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim handler As RoutedEventHandler

AddHandler instance.LocationChanged, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler LocationChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* LocationChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ LocationChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Opened Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : Opened Event

Occurs when the RadWindow is opened.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event Opened() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim handler As RoutedEventHandler

AddHandler instance.Opened, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler Opened()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* Opened
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ Opened

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStateChanged Event
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindow Class : WindowStateChanged Event

Occurs when the value of a WindowState changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
Public Event WindowStateChanged() As RoutedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim handler As RoutedEventHandler

AddHandler instance.WindowStateChanged, handler
C#
[SRCategoryAttribute("Behavior")]
public event RoutedEventHandler WindowStateChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
public: __event RoutedEventHandler* WindowStateChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
public:
event RoutedEventHandler^ WindowStateChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindow Class
RadWindow Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindowManager Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : RadWindowManager Class

RadWindowManager class exposes methods that apply to all RadWindows which are in the current RootVisual element.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class RadWindowManager
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
C#
public static class RadWindowManager
Managed Extensions for C++
public __gc abstract __sealed class RadWindowManager
C++/CLI
public ref class RadWindowManager abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.RadWindowManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindowManager Class Members
See Also Methods
[image]
Telerik.Windows.Controls Namespace : RadWindowManager Class

The following tables list the members exposed by RadWindowManager.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseAll | Closes all RadWindows that are open.
static (Shared in Visual Basic) | HideAll | Hides all RadWindows that are open.
static (Shared in Visual Basic) | MinimizeAll | Minimizes all RadWindows that are open.
static (Shared in Visual Basic) | NormalAll | Restores all RadWindows that are open.
static (Shared in Visual Basic) | ShowAll | Shows all RadWindows that are hidden or haven't been opened so far.
Top

See Also

Reference

RadWindowManager Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadWindowManager Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadWindowManager Class

For a list of all members of this type, see RadWindowManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseAll | Closes all RadWindows that are open.
static (Shared in Visual Basic) | HideAll | Hides all RadWindows that are open.
static (Shared in Visual Basic) | MinimizeAll | Minimizes all RadWindows that are open.
static (Shared in Visual Basic) | NormalAll | Restores all RadWindows that are open.
static (Shared in Visual Basic) | ShowAll | Shows all RadWindows that are hidden or haven't been opened so far.
Top

See Also

Reference

RadWindowManager Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
CloseAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindowManager Class : CloseAll Method

Closes all RadWindows that are open.

Syntax

Visual Basic (Declaration)
Public Shared Sub CloseAll()
Visual Basic (Usage) Copy Code
RadWindowManager.CloseAll()
C#
public static void CloseAll()
Managed Extensions for C++
public: static void CloseAll();
C++/CLI
public:
static void CloseAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
HideAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindowManager Class : HideAll Method

Hides all RadWindows that are open.

Syntax

Visual Basic (Declaration)
Public Shared Sub HideAll()
Visual Basic (Usage) Copy Code
RadWindowManager.HideAll()
C#
public static void HideAll()
Managed Extensions for C++
public: static void HideAll();
C++/CLI
public:
static void HideAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MinimizeAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindowManager Class : MinimizeAll Method

Minimizes all RadWindows that are open.

Syntax

Visual Basic (Declaration)
Public Shared Sub MinimizeAll()
Visual Basic (Usage) Copy Code
RadWindowManager.MinimizeAll()
C#
public static void MinimizeAll()
Managed Extensions for C++
public: static void MinimizeAll();
C++/CLI
public:
static void MinimizeAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
NormalAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindowManager Class : NormalAll Method

Restores all RadWindows that are open.

Syntax

Visual Basic (Declaration)
Public Shared Sub NormalAll()
Visual Basic (Usage) Copy Code
RadWindowManager.NormalAll()
C#
public static void NormalAll()
Managed Extensions for C++
public: static void NormalAll();
C++/CLI
public:
static void NormalAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ShowAll Method
See Also
[image]
Telerik.Windows.Controls Namespace > RadWindowManager Class : ShowAll Method

Shows all RadWindows that are hidden or haven't been opened so far.

Syntax

Visual Basic (Declaration)
Public Shared Sub ShowAll()
Visual Basic (Usage) Copy Code
RadWindowManager.ShowAll()
C#
public static void ShowAll()
Managed Extensions for C++
public: static void ShowAll();
C++/CLI
public:
static void ShowAll();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripExtensions Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : TabStripExtensions Class

Helper TabStrip extensions.

Syntax

Visual Basic (Declaration)
<ExtensionAttribute()>
Public MustInherit NotInheritable Class TabStripExtensions
Visual Basic (Usage) Copy Code
Dim instance As TabStripExtensions
C#
[ExtensionAttribute()]
public static class TabStripExtensions
Managed Extensions for C++
[ExtensionAttribute()]
public __gc abstract __sealed class TabStripExtensions
C++/CLI
[ExtensionAttribute()]
public ref class TabStripExtensions abstract sealed

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.TabStripExtensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripExtensions Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripExtensions Class Members
See Also
[image]
Telerik.Windows.Controls Namespace : TabStripExtensions Class

The following tables list the members exposed by TabStripExtensions.

See Also

Reference

TabStripExtensions Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosedEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : WindowClosedEventArgs Class

WindowClosedEventArgs exposes DialogResult and PromptResult property for handling the closed event of a window.

Syntax

Visual Basic (Declaration)
Public Class WindowClosedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WindowClosedEventArgs
C#
public class WindowClosedEventArgs : EventArgs
Managed Extensions for C++
public __gc class WindowClosedEventArgs : public EventArgs
C++/CLI
public ref class WindowClosedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.WindowClosedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosedEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosedEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : WindowClosedEventArgs Class

The following tables list the members exposed by WindowClosedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WindowClosedEventArgs Constructor | WindowClosedEventArgs default constructor.
Top

Public Properties

 | Name | Description
Public Property | DialogResult | Gets or sets the DialogResult of the RadWindow.
Public Property | PromptResult | Gets or sets the PromptResult of the RadWindow.
Top

See Also

Reference

WindowClosedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosedEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > WindowClosedEventArgs Class : WindowClosedEventArgs Constructor

WindowClosedEventArgs default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowClosedEventArgs()
C#
public WindowClosedEventArgs()
Managed Extensions for C++
public: WindowClosedEventArgs();
C++/CLI
public:
WindowClosedEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosedEventArgs Class
WindowClosedEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosedEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : WindowClosedEventArgs Class

For a list of all members of this type, see WindowClosedEventArgs members.

Public Properties

 | Name | Description
Public Property | DialogResult | Gets or sets the DialogResult of the RadWindow.
Public Property | PromptResult | Gets or sets the PromptResult of the RadWindow.
Top

See Also

Reference

WindowClosedEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DialogResult Property
See Also
[image]
Telerik.Windows.Controls Namespace > WindowClosedEventArgs Class : DialogResult Property

Gets or sets the DialogResult of the RadWindow.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property DialogResult As Nullable(Of Boolean)
Visual Basic (Usage) Copy Code
Dim instance As WindowClosedEventArgs
Dim value As Nullable(Of Boolean)

instance.DialogResult = value

value = instance.DialogResult
C#
[CompilerGeneratedAttribute()]
public Nullable<bool> DialogResult {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Nullable<bool> get_DialogResult();
public: __property void set_DialogResult(
   Nullable<bool> value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Nullable<bool> DialogResult {
   Nullable<bool> get();
   void set (Nullable<bool> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosedEventArgs Class
WindowClosedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PromptResult Property
See Also
[image]
Telerik.Windows.Controls Namespace > WindowClosedEventArgs Class : PromptResult Property

Gets or sets the PromptResult of the RadWindow.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property PromptResult As String
Visual Basic (Usage) Copy Code
Dim instance As WindowClosedEventArgs
Dim value As String

instance.PromptResult = value

value = instance.PromptResult
C#
[CompilerGeneratedAttribute()]
public string PromptResult {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property string* get_PromptResult();
public: __property void set_PromptResult(
   string* value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property String^ PromptResult {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosedEventArgs Class
WindowClosedEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosingEventArgs Class
See Also Members
[image]
Telerik.Windows.Controls Namespace : WindowClosingEventArgs Class

WindowClosingEventArgs exposes DialogResult and PromptResult property for handling the closing event of a window.

Syntax

Visual Basic (Declaration)
Public Class WindowClosingEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WindowClosingEventArgs
C#
public class WindowClosingEventArgs : EventArgs
Managed Extensions for C++
public __gc class WindowClosingEventArgs : public EventArgs
C++/CLI
public ref class WindowClosingEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.WindowClosingEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosingEventArgs Members
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosingEventArgs Class Members
See Also Properties
[image]
Telerik.Windows.Controls Namespace : WindowClosingEventArgs Class

The following tables list the members exposed by WindowClosingEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WindowClosingEventArgs Constructor | WindowClosingEventArgs default constructor.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the RadWindow closing will be canceled.
Top

See Also

Reference

WindowClosingEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosingEventArgs Constructor
See Also
[image]
Telerik.Windows.Controls Namespace > WindowClosingEventArgs Class : WindowClosingEventArgs Constructor

WindowClosingEventArgs default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowClosingEventArgs()
C#
public WindowClosingEventArgs()
Managed Extensions for C++
public: WindowClosingEventArgs();
C++/CLI
public:
WindowClosingEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosingEventArgs Class
WindowClosingEventArgs Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowClosingEventArgs Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : WindowClosingEventArgs Class

For a list of all members of this type, see WindowClosingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the RadWindow closing will be canceled.
Top

See Also

Reference

WindowClosingEventArgs Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Cancel Property
See Also
[image]
Telerik.Windows.Controls Namespace > WindowClosingEventArgs Class : Cancel Property

Gets or sets a value indicating whether the RadWindow closing will be canceled.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property Cancel As Nullable(Of Boolean)
Visual Basic (Usage) Copy Code
Dim instance As WindowClosingEventArgs
Dim value As Nullable(Of Boolean)

instance.Cancel = value

value = instance.Cancel
C#
[CompilerGeneratedAttribute()]
public Nullable<bool> Cancel {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Nullable<bool> get_Cancel();
public: __property void set_Cancel(
   Nullable<bool> value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Nullable<bool> Cancel {
   Nullable<bool> get();
   void set (Nullable<bool> value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WindowClosingEventArgs Class
WindowClosingEventArgs Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
DropPosition Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : DropPosition Enumeration

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DropPosition
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DropPosition
C#
[FlagsAttribute()]
public enum DropPosition : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DropPosition : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DropPosition : public Enum

Members

Member | Description
Before |
Inside |
After |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.DropPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ExpandMode Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : ExpandMode Enumeration

The ExpandMode enumeration is used in RadPanelBar to specify the allowed number of expanded RadPanelBarItem

Syntax

Visual Basic (Declaration)
Public Enum ExpandMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ExpandMode
C#
public enum ExpandMode : Enum
Managed Extensions for C++
__value public enum ExpandMode : public Enum
C++/CLI
public enum class ExpandMode : public Enum

Members

Member | Description
Single | ExpandMode.Single allows a RadPanelBar object to have only one expanded RadPanelBarItem
Multiple | ExpandMode.Multiple allows a RadPanelBar object to have many expanded RadPanelBarItem

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.ExpandMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuItemRole Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : MenuItemRole Enumeration

Defines the different roles that a RadMenuItem can have.

Syntax

Visual Basic (Declaration)
Public Enum MenuItemRole
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MenuItemRole
C#
public enum MenuItemRole : Enum
Managed Extensions for C++
__value public enum MenuItemRole : public Enum
C++/CLI
public enum class MenuItemRole : public Enum

Members

Member | Description
TopLevelItem | Top-level menu item that can invoke commands.
TopLevelHeader | Header for top-level menus.
SubmenuItem | Menu item in a submenu that can invoke commands.
SubmenuHeader | Header for a submenu.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.MenuItemRole

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
OptionListType Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : OptionListType Enumeration

Specifies the type of option list formed by itemContainer item.

Syntax

Visual Basic (Declaration)
Public Enum OptionListType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionListType
C#
public enum OptionListType : Enum
Managed Extensions for C++
__value public enum OptionListType : public Enum
C++/CLI
public enum class OptionListType : public Enum

Members

Member | Description
CheckList | All Items have a check box.
OptionList | All Items have a radio button.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.OptionListType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
PinMode Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : PinMode Enumeration

Specifies whether a window has the Pin button. Used by the PinMode property

Syntax

Visual Basic (Declaration)
Public Enum PinMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PinMode
C#
public enum PinMode : Enum
Managed Extensions for C++
__value public enum PinMode : public Enum
C++/CLI
public enum class PinMode : public Enum

Members

Member | Description
Pin | RadWindow will have a pin button which will be controlled by the user.
Fixed | RadWindow will have a fixed position set by the code, and the user will not be able to move the RadWindow.
NoPin | RadWIndow will not have a pin button, and the user will be able to move the RadWindow.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.PinMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ResizeMode Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : ResizeMode Enumeration

Specifies whether a window can be resized and, if so, how it can be resized. Used by the ResizeMode property.

Syntax

Visual Basic (Declaration)
Public Enum ResizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ResizeMode
C#
public enum ResizeMode : Enum
Managed Extensions for C++
__value public enum ResizeMode : public Enum
C++/CLI
public enum class ResizeMode : public Enum

Members

Member | Description
CanResize | RadWindow can be resized. The Minimize, Maximize, Pin and Close buttons are all shown.
CanMinimize | RadWindow can only be minimized, restored and pinned. Only the Minimize, Close and Pin buttons are shown.
CanMaximize | RadWindow can only be maximizied, restored and pinned. Only the Maximize, Close and Pin buttons are shown.
NoResize | RadWindow cannot be resized. The Minimize, Maximize and Pin buttons are not displayed in the title bar

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.ResizeMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripAlign Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : TabStripAlign Enumeration

The align of the buttons in the TabStrip.

Syntax

Visual Basic (Declaration)
Public Enum TabStripAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TabStripAlign
C#
public enum TabStripAlign : Enum
Managed Extensions for C++
__value public enum TabStripAlign : public Enum
C++/CLI
public enum class TabStripAlign : public Enum

Members

Member | Description
Justify | The buttons are stretched or shrinked to fill the available space.
Center | The buttons are centered. If there is not enough space they would be justified.
Left | The buttons are stacked on the leftr side. If there is not enough space they would be justified.
Right | The buttons would be stacked on the right side. If there is not enough space they would be justified.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.TabStripAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TraversalDirection Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : TraversalDirection Enumeration

The TraversalDirection enumeration is used in RadPanelBar to specify the direction in which a user is moving the selected item of the control. TraversalDirection is used only when the user is navigating with the keyboard.

Syntax

Visual Basic (Declaration)
Public Enum TraversalDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TraversalDirection
C#
public enum TraversalDirection : Enum
Managed Extensions for C++
__value public enum TraversalDirection : public Enum
C++/CLI
public enum class TraversalDirection : public Enum

Members

Member | Description
Up | TraversalDirection.Up means that the user is navigating upwards in the visual tree formed by the RadPanelBarItem contained in a RadPanelBar
Down | TraversalDirection.Down means that the user is navigating downwards in the visual tree formed by the RadPanelBarItem contained in a RadPanelBar

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.TraversalDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowStartupLocation Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : WindowStartupLocation Enumeration

Specifies the position that a Window will be shown in when it is first opened. Used by the RadWindow.WindowStartupLocation property.

Syntax

Visual Basic (Declaration)
Public Enum WindowStartupLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowStartupLocation
C#
public enum WindowStartupLocation : Enum
Managed Extensions for C++
__value public enum WindowStartupLocation : public Enum
C++/CLI
public enum class WindowStartupLocation : public Enum

Members

Member | Description
Manual | The startup location of a RadWindow is set from code.
CenterScreen | The startup location of a RadWindow is the center of the screen.
CenterParent | The startup location of a Window is the center of the parent that owns it, as specified by the Window.Parent property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.WindowStartupLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
WindowState Enumeration
See Also
[image]
Telerik.Windows.Controls Namespace : WindowState Enumeration

Specifies whether a window is in normal, minimized, or maximized state. Used by the WindowState property.

Syntax

Visual Basic (Declaration)
Public Enum WindowState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As WindowState
C#
public enum WindowState : Enum
Managed Extensions for C++
__value public enum WindowState : public Enum
C++/CLI
public enum class WindowState : public Enum

Members

Member | Description
Normal | The window is restored,this is the default value.
Maximized | The window is maximized.
Minimized | The window is minimized.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Windows.Controls.WindowState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEndedEventHandler Delegate
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEndedEventHandler Delegate

sender
The TreeView
e
The arguments of the DragEnded event.
The handler for the TreeViews's DragEnded event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadTreeViewDragEndedEventHandler( _
   ByVal sender As Object, _
   ByVal e As RadTreeViewDragEndedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RadTreeViewDragEndedEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadTreeViewDragEndedEventHandler(
   object sender,
   RadTreeViewDragEndedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void RadTreeViewDragEndedEventHandler(
   Object* sender,
   RadTreeViewDragEndedEventArgs* e
)
C++/CLI
public delegate void RadTreeViewDragEndedEventHandler(
   Object^ sender,
   RadTreeViewDragEndedEventArgs^ e
)

Parameters

sender
The TreeView
e
The arguments of the DragEnded event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewDragEventHandler Delegate
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewDragEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadTreeViewDragEventHandler( _
   ByVal sender As Object, _
   ByVal e As RadTreeViewDragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RadTreeViewDragEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadTreeViewDragEventHandler(
   object sender,
   RadTreeViewDragEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void RadTreeViewDragEventHandler(
   Object* sender,
   RadTreeViewDragEventArgs* e
)
C++/CLI
public delegate void RadTreeViewDragEventHandler(
   Object^ sender,
   RadTreeViewDragEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemEditedEventHandler Delegate
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemEditedEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadTreeViewItemEditedEventHandler( _
   ByVal sender As Object, _
   ByVal e As RadTreeViewItemEditedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RadTreeViewItemEditedEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadTreeViewItemEditedEventHandler(
   object sender,
   RadTreeViewItemEditedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void RadTreeViewItemEditedEventHandler(
   Object* sender,
   RadTreeViewItemEditedEventArgs* e
)
C++/CLI
public delegate void RadTreeViewItemEditedEventHandler(
   Object^ sender,
   RadTreeViewItemEditedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Telerik.Windows.Controls Namespace


%%ItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Telerik.Windows.Controls.Primitives Namespace (Telerik.Windows.Controls.Navigation)
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | TabItemContentPresenter | Content holder for the TabItem.
Class | TabItemMarginConverter | Used in RadTabItem to adjust the items Margin when selected/deselected.
Class | TabStripPanel | The panel used for arranging the TabItems of the TabStrip in the TabControl.

See Also

Reference

Telerik.Windows.Controls.Navigation Assembly


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Class
See Also Members
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemContentPresenter Class

Content holder for the TabItem.

Syntax

Visual Basic (Declaration)
Public Class TabItemContentPresenter
   Inherits ContentControl
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As TabItemContentPresenter
C#
public class TabItemContentPresenter : ContentControl, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class TabItemContentPresenter : public ContentControl, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class TabItemContentPresenter : public ContentControl, IManagedPeer, INativeCoreTypeWrapper

Remarks

Please note that this class would be replaced with a panel before the official release.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.Primitives.TabItemContentPresenter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemContentPresenter Members
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemContentPresenter Class

The following tables list the members exposed by TabItemContentPresenter.

Public Constructors

 | Name | Description
Public Constructor | TabItemContentPresenter Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TabItemContentPresenter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Constructor
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemContentPresenter Class : TabItemContentPresenter Constructor

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabItemContentPresenter()
C#
public TabItemContentPresenter()
Managed Extensions for C++
public: TabItemContentPresenter();
C++/CLI
public:
TabItemContentPresenter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemContentPresenter Class
TabItemContentPresenter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Class Methods
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemContentPresenter Class

For a list of all members of this type, see TabItemContentPresenter members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnIsEnabledChanged | (Inherited from System.Windows.Controls.ContentControl)
Top

See Also

Reference

TabItemContentPresenter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemContentPresenter Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TabItemContentPresenter
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemContentPresenter Class
TabItemContentPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemContentPresenter Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TabItemContentPresenter
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemContentPresenter Class
TabItemContentPresenter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemMarginConverter Class
See Also Members
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemMarginConverter Class

Used in RadTabItem to adjust the items Margin when selected/deselected.

Syntax

Visual Basic (Declaration)
Public Class TabItemMarginConverter
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter
C#
public class TabItemMarginConverter
Managed Extensions for C++
public __gc class TabItemMarginConverter
C++/CLI
public ref class TabItemMarginConverter

Inheritance Hierarchy

System.Object
Telerik.Windows.Controls.Primitives.TabItemMarginConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Members
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemMarginConverter Class Members
See Also Properties Methods
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemMarginConverter Class

The following tables list the members exposed by TabItemMarginConverter.

Public Constructors

 | Name | Description
Public Constructor | TabItemMarginConverter Constructor |
Top

Public Properties

 | Name | Description
Public Property | SelectedMargin | Gets or sets the margin of the TabItem when selected.
Public Property | UnselectedMargin | Gets or sets the margin of the TabItem when unselected.
Top

Public Methods

 | Name | Description
Public Method | Convert | Modifies the source data before passing it to the target for display in the UI.
Public Method | ConvertBack | Modifies the target data before passing it to the source object.
Top

See Also

Reference

TabItemMarginConverter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemMarginConverter Constructor
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemMarginConverter Class : TabItemMarginConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter()
C#
public TabItemMarginConverter()
Managed Extensions for C++
public: TabItemMarginConverter();
C++/CLI
public:
TabItemMarginConverter();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Class
TabItemMarginConverter Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemMarginConverter Class Methods
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemMarginConverter Class

For a list of all members of this type, see TabItemMarginConverter members.

Public Methods

 | Name | Description
Public Method | Convert | Modifies the source data before passing it to the target for display in the UI.
Public Method | ConvertBack | Modifies the target data before passing it to the source object.
Top

See Also

Reference

TabItemMarginConverter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Convert Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemMarginConverter Class : Convert Method

value
The source data being passed to the target.
targetType
The Type of data expected by the target dependency property.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.
Modifies the source data before passing it to the target for display in the UI.

Syntax

Visual Basic (Declaration)
Public Function Convert( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.Convert(value, targetType, parameter, culture)
C#
public object Convert(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
Managed Extensions for C++
public: Object* Convert(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
C++/CLI
public:
Object^ Convert(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The source data being passed to the target.
targetType
The Type of data expected by the target dependency property.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.

Return Value

The value to be passed to the target dependency property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Class
TabItemMarginConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ConvertBack Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemMarginConverter Class : ConvertBack Method

value
The target data being passed to the source.
targetType
The Type of data expected by the source object.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.
Modifies the target data before passing it to the source object.

Syntax

Visual Basic (Declaration)
Public Function ConvertBack( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.ConvertBack(value, targetType, parameter, culture)
C#
public object ConvertBack(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
Managed Extensions for C++
public: Object* ConvertBack(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
C++/CLI
public:
Object^ ConvertBack(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
The target data being passed to the source.
targetType
The Type of data expected by the source object.
parameter
An optional parameter to be used in the converter logic.
culture
The culture of the conversion.

Return Value

The value to be passed to the source object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Class
TabItemMarginConverter Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemMarginConverter Class Properties
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemMarginConverter Class

For a list of all members of this type, see TabItemMarginConverter members.

Public Properties

 | Name | Description
Public Property | SelectedMargin | Gets or sets the margin of the TabItem when selected.
Public Property | UnselectedMargin | Gets or sets the margin of the TabItem when unselected.
Top

See Also

Reference

TabItemMarginConverter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
SelectedMargin Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemMarginConverter Class : SelectedMargin Property

Gets or sets the margin of the TabItem when selected.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property SelectedMargin As Thickness
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter
Dim value As Thickness

instance.SelectedMargin = value

value = instance.SelectedMargin
C#
[CompilerGeneratedAttribute()]
public Thickness SelectedMargin {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Thickness get_SelectedMargin();
public: __property void set_SelectedMargin(
   Thickness value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Thickness SelectedMargin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Class
TabItemMarginConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
UnselectedMargin Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabItemMarginConverter Class : UnselectedMargin Property

Gets or sets the margin of the TabItem when unselected.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property UnselectedMargin As Thickness
Visual Basic (Usage) Copy Code
Dim instance As TabItemMarginConverter
Dim value As Thickness

instance.UnselectedMargin = value

value = instance.UnselectedMargin
C#
[CompilerGeneratedAttribute()]
public Thickness UnselectedMargin {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Thickness get_UnselectedMargin();
public: __property void set_UnselectedMargin(
   Thickness value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Thickness UnselectedMargin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabItemMarginConverter Class
TabItemMarginConverter Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Class
See Also Members
[image]
Telerik.Windows.Controls.Primitives Namespace : TabStripPanel Class

The panel used for arranging the TabItems of the TabStrip in the TabControl.

Syntax

Visual Basic (Declaration)
Public Class TabStripPanel
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
C#
public class TabStripPanel : Panel, IManagedPeer, INativeCoreTypeWrapper
Managed Extensions for C++
public __gc class TabStripPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper
C++/CLI
public ref class TabStripPanel : public Panel, IManagedPeer, INativeCoreTypeWrapper

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.Primitives.TabStripPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Members
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Members$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Class Members
See Also Properties Methods Events
[image]
Telerik.Windows.Controls.Primitives Namespace : TabStripPanel Class

The following tables list the members exposed by TabStripPanel.

Public Constructors

 | Name | Description
Public Constructor | TabStripPanel Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Align | The align of the items.
Public Property | AllTabsEqualHeight | Should all tabs be of equal height.
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RearrangeTabs | Should the selected item be closest to the contnets.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabStripPlacement | Where is the TabStrip with regard to its content.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Top

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TabStripPanel Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Constructor
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : TabStripPanel Constructor

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel()
C#
public TabStripPanel()
Managed Extensions for C++
public: TabStripPanel();
C++/CLI
public:
TabStripPanel();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Class Methods
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabStripPanel Class

For a list of all members of this type, see TabStripPanel members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Overridden. When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.
Protected Method | MeasureOverride | Overridden. When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.
Top

See Also

Reference

TabStripPanel Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
ArrangeOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : ArrangeOverride Method

finalSize
The final area within the parent that this element should use to arrange itself and its children.
When implemented in a derived class, provides the behavior for the "Arrange" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim finalSize As Size
Dim value As Size

value = instance.ArrangeOverride(finalSize)
C#
protected override Size ArrangeOverride(
   Size finalSize
)
Managed Extensions for C++
protected: Size ArrangeOverride(
   Size finalSize
) override
C++/CLI
protected:
Size ArrangeOverride(
   Size finalSize
) override

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
MeasureOverride Method
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : MeasureOverride Method

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.
When implemented in a derived class, provides the behavior for the "Measure" pass of Silverlight layout.

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1502:AvoidExcessiveComplexity",
   Scope="",
   Target="",
   MessageId="",
   Justification="")>
Protected Overrides Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim availableSize As Size
Dim value As Size

value = instance.MeasureOverride(availableSize)
C#
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1502:AvoidExcessiveComplexity",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected override Size MeasureOverride(
   Size availableSize
)
Managed Extensions for C++
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1502:AvoidExcessiveComplexity",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected: Size MeasureOverride(
   Size availableSize
) override
C++/CLI
[SuppressMessageAttribute(Category="Microsoft.Maintainability",
   CheckId="CA1502:AvoidExcessiveComplexity",
   Scope="",
   Target="",
   MessageId="",
   Justification="")]
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Class Properties
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabStripPanel Class

For a list of all members of this type, see TabStripPanel members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Align | The align of the items.
Public Property | AllTabsEqualHeight | Should all tabs be of equal height.
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RearrangeTabs | Should the selected item be closest to the contnets.
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabStripPlacement | Where is the TabStrip with regard to its content.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TabStripPanel Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Align Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : Align Property

The align of the items.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property Align As TabStripAlign
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim value As TabStripAlign

instance.Align = value

value = instance.Align
C#
[CompilerGeneratedAttribute()]
public TabStripAlign Align {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property TabStripAlign get_Align();
public: __property void set_Align(
   TabStripAlign value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property TabStripAlign Align {
   TabStripAlign get();
   void set (TabStripAlign value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
AllTabsEqualHeight Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : AllTabsEqualHeight Property

Should all tabs be of equal height.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property AllTabsEqualHeight As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim value As Boolean

instance.AllTabsEqualHeight = value

value = instance.AllTabsEqualHeight
C#
[CompilerGeneratedAttribute()]
public bool AllTabsEqualHeight {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property bool get_AllTabsEqualHeight();
public: __property void set_AllTabsEqualHeight(
   bool value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property bool AllTabsEqualHeight {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
RearrangeTabs Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : RearrangeTabs Property

Should the selected item be closest to the contnets.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property RearrangeTabs As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim value As Boolean

instance.RearrangeTabs = value

value = instance.RearrangeTabs
C#
[CompilerGeneratedAttribute()]
public bool RearrangeTabs {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property bool get_RearrangeTabs();
public: __property void set_RearrangeTabs(
   bool value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property bool RearrangeTabs {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


%%PageItemTitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPlacement Property
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace > TabStripPanel Class : TabStripPlacement Property

Where is the TabStrip with regard to its content.

Syntax

Visual Basic (Declaration)
<CompilerGeneratedAttribute()>
Public Property TabStripPlacement As Dock
Visual Basic (Usage) Copy Code
Dim instance As TabStripPanel
Dim value As Dock

instance.TabStripPlacement = value

value = instance.TabStripPlacement
C#
[CompilerGeneratedAttribute()]
public Dock TabStripPlacement {get; set;}
Managed Extensions for C++
[CompilerGeneratedAttribute()]
public: __property Dock get_TabStripPlacement();
public: __property void set_TabStripPlacement(
   Dock value
);
C++/CLI
[CompilerGeneratedAttribute()]
public:
property Dock TabStripPlacement {
   Dock get();
   void set (Dock value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabStripPanel Class
TabStripPanel Members


$$GETTING_STARTED$$ - %%projecttitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Telerik.Windows.Controls.Input Send comments on this topic.
Introduction


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarButton Class Events
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarButton Class

For a list of all members of this type, see CalendarButton members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarButton Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Class Events
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarPanel Class

For a list of all members of this type, see CalendarPanel members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Class Methods
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarPanel Class

For a list of all members of this type, see CalendarPanel members.

Public Methods

 | Name | Description
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.FrameworkElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Top

Protected Methods

 | Name | Description
Protected Method | ArrangeOverride | Defines the layout of the Telerik.Windows.Controls.Primitives.RadUniformGrid by distributing space evenly among all of the child elements. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Protected Method | MeasureOverride | Computes the desired size of the Telerik.Windows.Controls.Primitives.RadUniformGrid by measuring all of the child elements. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Top

See Also

Reference

CalendarPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarPanel Class Properties
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarPanel Class

For a list of all members of this type, see CalendarPanel members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Panel)
Public Property | Children | (Inherited from System.Windows.Controls.Panel)
Public Property | ChildrenFlow | Gets or sets a value that specifies the dimension in which child content is arranged. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Columns | Gets or sets the number of columns that are in the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HideFirstColumn | Gets or sets value that hide or show the first column. This is a Dependency property. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | HideFirstRow | Gets or sets value that hide or show the first row. This is a Dependency property. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PreserveSpaceForCollapsedChildren | Gets or sets a value specifying whether a collapsed child's size should be preserved. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Rows | Gets or sets the number of rows that are in the grid. (Inherited from Telerik.Windows.Controls.Primitives.RadUniformGrid)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
CalendarView Class Events
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : CalendarView Class

For a list of all members of this type, see CalendarView members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

CalendarView Class
Telerik.Windows.Controls.Calendar Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
TransitionPanel Class Events
See Also
[image]
Telerik.Windows.Controls.Calendar Namespace : TransitionPanel Class

For a list of all members of this type, see TransitionPanel members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TransitionPanel Class
Telerik.Windows.Controls.Calendar Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.Calendar Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.Controls.Calendar.CalendarDateChangedEventArgs
Telerik.Windows.Controls.Calendar.CalendarModeChangedEventArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.Calendar.CalendarButton
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.Calendar.CalendarView
System.Windows.Controls.Panel
Telerik.Windows.Controls.Calendar.TransitionPanel
Telerik.Windows.Controls.Primitives.RadUniformGrid
Telerik.Windows.Controls.Calendar.CalendarPanel
Telerik.Windows.Controls.Calendar.CalendarAnimation
Telerik.Windows.Controls.Calendar.CalendarButtonContent
Telerik.Windows.Controls.Calendar.RequestBase
Telerik.Windows.Controls.Calendar.ActionRequest
Telerik.Windows.Controls.Calendar.ActionRequest<T>
Telerik.Windows.Controls.Calendar.ActionRequest<T1, T2>

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Input Send comments on this topic.
DateParseException Class Methods
See Also
[image]
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace : DateParseException Class

For a list of all members of this type, see DateParseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DateParseException Class
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.DatePicker.DateTimeParsing Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Exception
Telerik.Windows.Controls.DatePicker.DateTimeParsing.DateParseException

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadComboBoxItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadComboBoxItem Class

For a list of all members of this type, see RadComboBoxItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Selected | Occurs when a ListBoxItem is selected. (Inherited from ListBoxItem)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | Unselected | Occurs when a ListBoxItem is unselected. (Inherited from ListBoxItem)
Top

See Also

Reference

RadComboBoxItem Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadNumericUpDown Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadNumericUpDown Class

For a list of all members of this type, see RadNumericUpDown members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadNumericUpDown Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Input Send comments on this topic.
RadUpDown Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadUpDown Class

For a list of all members of this type, see RadUpDown members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadUpDown Class
Telerik.Windows.Controls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls.Upload Namespace Inheritance Hierarchy
See Also

See Also

Reference

Telerik.Windows.Controls.Input Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Input Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.Input) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Windows.Controls.DateTimeTypeConverter
System.EventArgs
Telerik.Windows.Controls.FilesSelectedEventArgs
Telerik.Windows.Controls.FileUploadedEventArgs
Telerik.Windows.Controls.UploadProgressEventArgs
Telerik.Windows.Controls.UploadStartedEventArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.ListBoxItem
Telerik.Windows.Controls.RadComboBoxItem
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.Selector
Telerik.Windows.Controls.RadComboBox
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.RadUpDown
Telerik.Windows.Controls.RadNumericUpDown
Telerik.Windows.Controls.RadCalendar
Telerik.Windows.Controls.RadDatePicker
Telerik.Windows.Controls.RadUpload
Telerik.Windows.Controls.RadUploadItem
Telerik.Windows.Controls.RadUploadSelectedFile

See Also

Reference

Telerik.Windows.Controls.Input Assembly


$$GETTING_STARTED$$ - %%projecttitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Introduction


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : PlaylistPresenter Class

For a list of all members of this type, see PlaylistPresenter members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

PlaylistPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
PlaylistPresenter Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : PlaylistPresenter Class

For a list of all members of this type, see PlaylistPresenter members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

PlaylistPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadChaptersPresenter Class

For a list of all members of this type, see RadChaptersPresenter members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadChaptersPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadChaptersPresenter Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadChaptersPresenter Class

For a list of all members of this type, see RadChaptersPresenter members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | DisplayMemberPath | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | HasItems | Gets whether the ItemsControl has any children. (Inherited from ItemsControl)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl)
Public Property | ItemContainerStyle | Gets or sets the style for the item containers of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | ItemContainerStyleSelector | Gets or sets the style selector for the items of the control. This is a dependency property. (Inherited from ItemsControl)
Public Property | Items | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsPanel | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemsSource | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplate | (Inherited from System.Windows.Controls.ItemsControl)
Public Property | ItemTemplateSelector | Gets or sets the template selector for the items of the control. This is a dependency proeprty. (Inherited from ItemsControl)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadChaptersPresenter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

For a list of all members of this type, see RadMediaChapter members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaChapter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaChapter Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaChapter Class

For a list of all members of this type, see RadMediaChapter members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadMediaChapter Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
RadMediaItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadMediaItem Class

For a list of all members of this type, see RadMediaItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadMediaItem Class
Telerik.Windows.Controls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.MediaPlayer Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.MediaPlayer) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Windows.Controls.FullscreenChangedEventArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.PlaylistPresenter
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.RadChaptersPresenter
Telerik.Windows.Controls.RadMediaItem
Telerik.Windows.Controls.RadMediaPlayer
Telerik.Windows.Controls.RadMediaChapter
Telerik.Windows.Controls.ItemsCountToIsEnabledConverter

See Also

Reference

Telerik.Windows.Controls.MediaPlayer Assembly


$$GETTING_STARTED$$ - %%projecttitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Telerik.Windows.Controls.Navigation Send comments on this topic.
Introduction


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
MenuBase Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : MenuBase Class

For a list of all members of this type, see MenuBase members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

MenuBase Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Class Events
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemContentPresenter Class

For a list of all members of this type, see TabItemContentPresenter members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TabItemContentPresenter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabItemContentPresenter Class Properties
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabItemContentPresenter Class

For a list of all members of this type, see TabItemContentPresenter members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

TabItemContentPresenter Class
Telerik.Windows.Controls.Primitives Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
TabStripPanel Class Events
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : TabStripPanel Class

For a list of all members of this type, see TabStripPanel members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

TabStripPanel Class
Telerik.Windows.Controls.Primitives Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
Telerik.Windows.Controls.Primitives Namespace (Telerik.Windows.Controls.Navigation) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.Primitives.TabItemContentPresenter
System.Windows.Controls.Panel
Telerik.Windows.Controls.Primitives.TabStripPanel
Telerik.Windows.Controls.Primitives.TabItemMarginConverter

See Also

Reference

Telerik.Windows.Controls.Navigation Assembly


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadAlert Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadAlert Class

For a list of all members of this type, see RadAlert members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadAlert Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadConfirm Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadConfirm Class

For a list of all members of this type, see RadConfirm members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadConfirm Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadPrompt Class

For a list of all members of this type, see RadPrompt members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | Cancel | Identifier of Cancel (Inherited from RadConfirm)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | Ok | Identifier of Cancel (Inherited from RadAlert)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadPrompt Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadPrompt Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadPrompt Class

For a list of all members of this type, see RadPrompt members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Content | (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.ContentControl)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TextAlignment | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextDecorations | (Inherited from System.Windows.Controls.ContentControl)
Public Property | TextWrapping | (Inherited from System.Windows.Controls.ContentControl)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadPrompt Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadSeparator Class

For a list of all members of this type, see RadSeparator members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadSeparator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Methods$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Class Methods
See Also
[image]
Telerik.Windows.Controls Namespace : RadSeparator Class

For a list of all members of this type, see RadSeparator members.

Public Methods

 | Name | Description
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadSeparator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadSeparator Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadSeparator Class

For a list of all members of this type, see RadSeparator members.

Public Properties

 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top

Protected Properties

 | Name | Description
Protected Property | DefaultStyleKey | (Inherited from System.Windows.Controls.Control)
Top

See Also

Reference

RadSeparator Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTabItem Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadTabItem Class

For a list of all members of this type, see RadTabItem members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTabItem Class
Telerik.Windows.Controls Namespace
RadTabControl Class
IsSelected Property


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewAutomationPeer Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewAutomationPeer Class

For a list of all members of this type, see RadTreeViewAutomationPeer members.

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Owner | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Top

See Also

Reference

RadTreeViewAutomationPeer Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Properties$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
RadTreeViewItemAutomationPeer Class Properties
See Also
[image]
Telerik.Windows.Controls Namespace : RadTreeViewItemAutomationPeer Class

For a list of all members of this type, see RadTreeViewItemAutomationPeer members.

Public Properties

 | Name | Description
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Owner | (Inherited from System.Windows.Automation.Peers.FrameworkElementAutomationPeer)
Top

See Also

Reference

RadTreeViewItemAutomationPeer Class
Telerik.Windows.Controls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls.Navigation Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls.Navigation) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadTreeViewDragEventArgs
Telerik.Windows.Controls.RadTreeViewDragEndedEventArgs
Telerik.Windows.Controls.RadTreeViewItemEditedEventArgs
Telerik.Windows.Controls.WindowClosedEventArgs
Telerik.Windows.Controls.WindowClosingEventArgs
System.Windows.DependencyObject
System.Windows.Automation.Peers.AutomationPeer
System.Windows.Automation.Peers.FrameworkElementAutomationPeer
Telerik.Windows.Controls.RadTreeViewAutomationPeer
Telerik.Windows.Controls.RadTreeViewItemAutomationPeer
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.HeaderedContentControl
Telerik.Windows.Controls.RadTabItem
Telerik.Windows.Controls.RadWindow
Telerik.Windows.Controls.RadAlert
Telerik.Windows.Controls.RadConfirm
Telerik.Windows.Controls.RadPrompt
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.RadMenuItem
Telerik.Windows.Controls.RadPanelBarItem
Telerik.Windows.Controls.RadTreeViewItem
Telerik.Windows.Controls.MenuBase
Telerik.Windows.Controls.RadMenu
Telerik.Windows.Controls.RadCube
Telerik.Windows.Controls.RadPanelBar
Telerik.Windows.Controls.RadTabControl
Telerik.Windows.Controls.RadTreeView
Telerik.Windows.Controls.RadSeparator
Telerik.Windows.Controls.RadWindowManager
Telerik.Windows.Controls.TabStripExtensions

See Also

Reference

Telerik.Windows.Controls.Navigation Assembly


$$GETTING_STARTED$$ - %%projecttitle%%

Telerik.Windows.Controls Send comments on this topic.
Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Telerik.Windows.Controls Send comments on this topic.
Introduction


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls Send comments on this topic.
System.Windows.Controls Namespace Inheritance Hierarchy
See Also

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedContentControl Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedContentControl Class

For a list of all members of this type, see HeaderedContentControl members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

HeaderedContentControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
HeaderedItemsControl Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : HeaderedItemsControl Class

For a list of all members of this type, see HeaderedItemsControl members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

HeaderedItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
ItemsControl Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : ItemsControl Class

For a list of all members of this type, see ItemsControl members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

ItemsControl Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadUniformGrid Class Events
See Also
[image]
Telerik.Windows.Controls.Primitives Namespace : RadUniformGrid Class

For a list of all members of this type, see RadUniformGrid members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadUniformGrid Class
Telerik.Windows.Controls.Primitives Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Controls.Primitives Namespace (Telerik.Windows.Controls) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
Telerik.Windows.Controls.Primitives.RadUniformGrid

See Also

Reference

Telerik.Windows.Controls Assembly


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadDockPanel Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadDockPanel Class

For a list of all members of this type, see RadDockPanel members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadDockPanel Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadProgressBar Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadProgressBar Class

For a list of all members of this type, see RadProgressBar members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadProgressBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadSlider Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadSlider Class

For a list of all members of this type, see RadSlider members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SelectionEndChanged | Occurs when SelectionEnd changes value. (Inherited from DoubleRangeBase)
Public Event | SelectionRangeChanged | Occurs when SelectionRange changes value. (Inherited from DoubleRangeBase)
Public Event | SelectionStartChanged | Occurs when SelectionStart changes value. (Inherited from DoubleRangeBase)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | ValueChanged | (Inherited from System.Windows.Controls.Primitives.RangeBase)
Top

See Also

Reference

RadSlider Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadTickBar Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadTickBar Class

For a list of all members of this type, see RadTickBar members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadTickBar Class
Telerik.Windows.Controls Namespace


%%PageItemTitle%% $$Events$$

Telerik.Windows.Controls Send comments on this topic.
RadWrapPanel Class Events
See Also
[image]
Telerik.Windows.Controls Namespace : RadWrapPanel Class

For a list of all members of this type, see RadWrapPanel members.

Public Events

 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

RadWrapPanel Class
Telerik.Windows.Controls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Controls Namespace (Telerik.Windows.Controls) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Controls.RadSelectionChangedEventArgs
Telerik.Windows.Controls.SelectionChangedEventArgs
Telerik.Windows.Controls.RangeSelectionChangedEventArgs
System.Windows.DependencyObject
System.Windows.FrameworkTemplate
System.Windows.DataTemplate
Telerik.Windows.Controls.HierarchicalDataTemplate
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Telerik.Windows.Controls.HeaderedContentControl
Telerik.Windows.Controls.ListBoxItem
Telerik.Windows.Controls.RadPopup
System.Windows.Controls.ItemsControl
Telerik.Windows.Controls.ItemsControl
Telerik.Windows.Controls.HeaderedItemsControl
Telerik.Windows.Controls.Selector
System.Windows.Controls.Primitives.RangeBase
Telerik.Windows.Controls.DoubleRangeBase
Telerik.Windows.Controls.RadSlider
Telerik.Windows.Controls.RadProgressBar
Telerik.Windows.Controls.RadTickBar
System.Windows.Controls.Panel
Telerik.Windows.Controls.RadDockPanel
Telerik.Windows.Controls.RadWrapPanel
Telerik.Windows.Controls.DataTemplateSelector
Telerik.Windows.Controls.ItemContainerGenerator
Telerik.Windows.Controls.ItemsControlExtensions
Telerik.Windows.Controls.RadControl
Telerik.Windows.Controls.ResourceDictionary
Telerik.Windows.Controls.StyleSelector
Telerik.Windows.Controls.TextSearch
Telerik.Windows.Controls.Theme

See Also

Reference

Telerik.Windows.Controls Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows.Input Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
Telerik.Windows.Input.MouseButtonEventArgs
Telerik.Windows.Input.MouseWheelEventArgs
Telerik.Windows.Input.Mouse

See Also

Reference

Telerik.Windows.Controls Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Telerik.Windows.Controls Send comments on this topic.
Telerik.Windows Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Telerik.Windows.RadRoutedEventArgs
System.Windows.PropertyMetadata
Telerik.Windows.PropertyMetadata
Telerik.Windows.DependencyPropertyExtensions
Telerik.Windows.DependencyPropertyKey
Telerik.Windows.EventManager
Telerik.Windows.RoutedEvent

See Also

Reference

Telerik.Windows.Controls Assembly