Introduction

Telerik RadAjax v1.8 Send comments on this topic.
Introduction

Glossary Item Box

Thank you for choosing Telerik RadAjax!

Telerik RadAjax provides a universal, cross-browser approach for creating highly interactive applications. The patent-pending Click-and-Go™ technology allows developers to AJAX-enable any ASP.NET application without making any modifications (placing Update Panels, setting triggers, etc.) and without writing a single line of JavaScript or server-side code.

Telerik RadAjax automatically replaces the postback behavior of the selected page elements with AJAX callbacks, thus eliminating the need for manually invoking AJAX requests. Furthermore, unlike other AJAX frameworks, the ASP.NET page life-cycle is preserved, which guarantees the proper functioning of the applications. ViewState, EventValidation and client scripts are also preserved as if a regular postback is performed.

New to AJAX? - read more about this new development technique.

Already familiar with AJAX? - learn about the Telerik AJAX framework and its advantages when compared to other AJAX solutions.

This document includes:

  • Telerik AJAX framework - what is the new telerik AJAX offering and what are its benefits
  • Advantages of the Telerik AJAX framework - key points you need to keep in mind when evaluating various AJAX solutions
  • AJAX Panel - an universal AJAX-enabling container
  • AJAX Manager - allows you to configure in design-time which page element(s) need to initiate callbacks and which elements need to be respectively updated
  • AJAX Loading Panel - a component that serves as a progress indicator during an AJAX request
  • AJAX Timer - a component that initiates AJAX requests at specified time intervals

Telerik RadAjax works on both .NET 1.x and 2.0 frameworks.

Telerik RadAjax is available individually or as part of the Telerik RadControls for ASP.NET suite - "Unleashing the power of Thin Client™".

If you need further assistance, please contact clientservice@telerik.com

Revised: 4/15/2008

© 2002-2008 Telerik. All Rights Reserved.


What's New

Telerik RadAjax v1.8 Send comments on this topic.
What's New

Glossary Item Box

What's New in Telerik RadAjax v1.6 (part of Q4 2006)

  1. Transparency for loading panels - the loading panel does not "replace" the updated control by default. Instead, the loading is shown "over" the control.
  2. New smart tags for all controls in Telerik RadAjax suite - the new smart tag provides access to commonly used properties and the learning resources.

  3. Request queueing - Telerik RadAjax supports for queueing the pending ajax requests

What's New in Telerik RadAjax v1.5 (part of Q3 2006)

  1. Support for WebServices - there is a special control in Telerik RadAjax controls suite called RadAjaxServiceManager. It makes possible to perform client-side calls to web services and retrieve information via AJAX requests using simple or advanced web service invocation.

    Services collection
    See Quick-start framework sample for simple WebService invocation

    See Quick-start framework sample for advanced WebService invocation

  2. Codeless Response.Redirect support - reinforcing the idea of codeless development Telerik RadAjax now natively supports Response.Redirect during AJAX requests, without the need for any code modifications.
  3. Support for XY coordinates on ImageButton - now the XY coordinates of the ImageButton are sent to the server and can be further processed.
  4. Only a single ajax request is allowed at any given time. This has been changed because of problems users have encountered, when a second ajax request is initiated while the first one is still running (more info in KB article #729).

© 2002-2008 Telerik. All Rights Reserved.


What is AJAX?

Telerik RadAjax v1.8 Send comments on this topic.
What is AJAX?
See Also

Glossary Item Box

The core idea behind AJAX is to make the communication with the server asynchronous, so that data is transferred and processed in the background. As a result the user can continue working on the other parts of the page without interruption. In an AJAX-enabled application only the relevant page elements are updated, only when this is necessary.

In contrast, the traditional synchronous (postback-based) communication would require a full page reload each time data has to be transferred to/from the server. This leads to the following negative effects:

  • Poor Interactivity - the user interaction with the application is interrupted every time a server call is needed, since a postback has to be made.
  • Ineffectiveness - with the full page rendered and transferred to the client after each postback, the process is time consuming and traffic intensive.
  • Low Usability - the requirement for full page postback whenever the user interface has to be changed imposes hefty limitations on the degree of sophistication of web user interfaces. Befor AJAX rich and smooth interfaces with on-demand updates could only be implemented using Flash technology.

AJAX-enabled applications, on the other hand, rely on a new asynchronous method of client-server communication. It is implemented as a JavaScript engine that is loaded on the client during the initial page load. From there on, this engine serves as a mediator that sends only relevant XML-formatted data to the server and subsequently processes the server response to update the relevant page elements.

Below is a diagram of the complete lifecycle of an AJAX-enabled web form.

Enlarge Click to enlarge
  1. Initial request by the browser – the user requests the particular URL.
  2. The complete page is rendered by the server (along with the JavaScript AJAX engine) and sent to the client (HTML, CSS, JavaScript AJAX engine).
  3. All subsequent requests to the server are initiated as function calls to the JavaScript engine.
  4. The JavaScript engine then makes an XmlHttpRequest to the server.
  5. The server processes the request and sends a response in XML format to the client (XML document). It contains the data only of the page elements that need to be changed. In most cases this data comprises just a fraction of the total page markup.
  6. The AJAX engine processes the server response, updates the relevant page content or performs another operation with the new data received from the server. (HTML + CSS)

AJAX development however is a quite complex process. It requires:

  • Intensive JavaScript coding - this may turn to be a problem for a large number of .Net developers. Furthermore, the lack of good debugging tools for client-side script makes the process even more complicated.
  • Comprehensive knowledge of the ASP.NET page lifecycle - AJAX applications typically break the normal page life-cycle and do not work properly. As a result developers have to handle ViewState management, EventValidation, and preservation of client-scripts.

The Telerik Telerik RadAjax framework eliminates those challenges. The product features Telerik's Click-and-Go™ patent-pending technology, which allow you to jump-start your AJAX development today:

  • AJAX-enable any existing or new application, regardless of its level of complexity
  • Don't have to know in details how AJAX works
  • Don't have to make any modification to your application - you do not need to place Update Panels, set triggers, manually invoke AJAX requests, etc.
  • Don't have to write a single line of code (JavaScript or server-side)

For more information see section: "Advantages of Telerik AJAX framework".

See Also

AJAX Controls
Telerik AJAX framework

© 2002-2008 Telerik. All Rights Reserved.


No Modifications to Your Application

Telerik RadAjax v1.8 Send comments on this topic.
No Modifications to Your Application
See Also
Advantages of telerik AJAX framework > No Modifications to Your Application

Glossary Item Box

The greatest advantage of the Telerik RadAjax framework is that you don't need to make any changes to your existing applications or build new ones in some specific way so that they can be AJAX-enabled. In contrast, implementing any of the other AJAX frameworks on the market requires major rework, which increases significantly the migration time and effort as well as the chances for introducing new bugs.

In contrast, the Click-and-Go™ technology of Telerik RadAjax allows you to AJAX-enable any ASP.NET application without making any modification, without writing a single line of code:

  • Existing applications - in order to AJAX-enable an existing application you need to simply drop the AJAX Manager control at the bottom of your form, define the AJAX relations using a single dialog in Visual Studio .Net design mode and hit F5.
  • New applications - you don't have to follow any specific guidelines when building an application that is to be AJAX-enabled with Telerik RadAjax. Simply build a regular postback-based application the way you are used to and use the AJAX Manager to AJAX-enable it at the end.

AJAX-enabling a sample application with other AJAX frameworks

In order to AJAX-enable with simple application with you will usually have to place the so called "Callback Panels" (name may vary) around each area that needs to be updated. This may introduce some challenges with preserving the application's layout and graphic design.

In simple scenarios like the one above placing Callback Panels may not be very difficult. But imagine you have a real-life application (e.g. Telerik HelpDesk sample) with dozens of UI controls that need to start working with AJAX. Placing 20+ Callback Panels and figuring which element should go in the respective panel may be a challenge even for the most advanced developers.

AJAX-enabling a sample application with Telerik RadAjax

Telerik RadAjax offers a fundamentally different approach to AJAX-enabling existing applications. The AJAX engine parses the page markup and detects which elements need to be updated. As a result there is no need to place Callback Panels around those elements or modify your application in any other way.

Basically you need to perform two easy tasks:

  1. Drag and drop the AJAX Manager control on your form
  2. Set the AJAX relations using a single dialog in Visual Studio .Net design mode

As a result, the simple application discussed before will look as shown below - the only modification is the AJAX Manager control placed at the bottom of the form. All controls above it remain intact in their original state.

Once the AJAX Manager is placed on the form you need to use its configuration dialog to define the AJAX relations among the controls on the page, i.e. which controls should initiate AJAX request and which controls should be updated by each respective AJAX request. In our example there are two such relations:

  1. When the calendar control is clicked the e-mail list (datagrid) and the message body (div) need to be respectively updated
  2. When an e-mail message is clicked the message body needs to be updated

Those two relations can be easily set using treeviews with checkboxes in the AJAX Manager dialog:

The other advantage of the AJAX Manager is that it serves as a centralized place for management of the AJAX relations.

See Also

Centralized Management of AJAX Relations

© 2002-2008 Telerik. All Rights Reserved.


Centralized Management of AJAX Relations

Telerik RadAjax v1.8 Send comments on this topic.
Centralized Management of AJAX Relations
See Also
Advantages of telerik AJAX framework > Centralized Management of AJAX Relations

Glossary Item Box

A typical challenge with other AJAX frameworks is the fact that the AJAX behavior of the page (which controls initiate AJAX requests and update other controls) is achieved by setting numerous controls individually.

For example, in certain frameworks you need to set some kind of triggers that initiate AJAX callbacks upon predefined conditions. For example:

  • "Message Body" Ajax Panel - Trigger 1: The message body needs to be updated when an e-mail item is clicked
  • "Message Body" Ajax Panel - Trigger 2: The message body needs to be updated when the calendar is clicked
  • "E-mail list" Ajax Panel - Trigger 1: The e-mail list needs to be updated when the calendar is clicked

The combination of these 3 Triggers define the 2 AJAX relations on the page, which are:

  1. When the calendar is clicked the e-mail list and the message body need to be updated
  2. When an e-mail message is clicked the message body only needs to be updated

As you can see, it is not very easy to figure out what will be the effect of the combination of triggers, especially when you have complex real-life applications like the Telerik HelpDesk sample. This task would require placing 20+ Ajax Panels and setting 50+ triggers.

Moreover, setting several triggers that facilitate every of the numerous AJAX relations will definitely need serious planning and probably something like a "Trigger diagram".

In contrast, the Telerik RadAjax framework offers a centralized place where you can define and modify the AJAX relations on the page. This is done through the single configuration dialog of the AJAX Manager in Visual Studio .Net design mode.

If we need to implement the above scenario we need to simply set the two relations in the dialog.

Relation 1: When the calendar is clicked the e-mail list and the message body need to be updated

Relation 2: When an e-mail message is clicked the message body only needs to be updated

It is clearly of benefit for developers to be able to see all AJAX relations at a glance in one centralized place (the AJAX Manager dialog) , rather than having to configure every Trigger of every Ajax Panel individually.

The logic for setting AJAX relations in the AJAX Manager dialog leads to another benefit - the AJAX relations are defined in the same sequence in which users interact with the interface of the application. For more information see section "Intuitive Way for Defining AJAX Relations".

See Also

Intuitive Way for Defining AJAX Relations

© 2002-2008 Telerik. All Rights Reserved.


Intuitive Way for Defining AJAX Relations

Telerik RadAjax v1.8 Send comments on this topic.
Intuitive Way for Defining AJAX Relations
See Also
Advantages of telerik AJAX framework > Intuitive Way for Defining AJAX Relations

Glossary Item Box

When using other AJAX frameworks, you need to set some kind of AJAX triggers in order to define the AJAX behavior of the page (which controls initiate AJAX requests and which controls are respectively updated). This approach, however, presents a serious inconvenience because the AJAX relations are defined in a way that's reverse to the users' natural interaction with the application interface.

Consider we have the following AJAX relation:

  • When the calendar is clicked the e-mail list and the message body need to be updated

This represents the actual sequence in which the user will interact with the application - he/she will click a day on the calendar and as a result the e-mail list and the message body will be updated.

However, when using triggers you will have to define this scenario in the opposite way - which element has to be updated as a resuit of another element being clicked. So for the above AJAX relation you will have to set 2 triggers.

  • "Message Body" ajax Panel - Trigger 1: The message body needs to be updated when the calendar is clicked
  • "E-mail list" ajax Panel - Trigger 2: The e-mail list needs to be updated when the calendar is clicked

    As you can see, the combination of 2 triggers define one AJAX relation. Moreover, they are defined in the reverse direction, which can be a significant challenge when AJAX-enabling complex real-life applications like the Telerik HelpDesk sample, which will probably need 20+ ajax Panels and 50+ triggers.

    The Telerik RadAjax framework offers a much more intuitive way for setting AJAX relations, which follows the users' natural interaction with the application interface.

    Consider we have to implement the same AJAX relation:

    • When the calendar is clicked the e-mail list and the message body need to be updated

    To do this we need to open the AJAX Manager dialog and use the checkboxes to define the following:

    1. Set the calendar (Calendar1 control) as a control that will initiate AJAX requests
    2. Set the e-mail list (EmailGrid control) and the message body (MessageBody control) as controls that need to be updated after the respective AJAX request (in our case initiated by the calendar)

    This approach is much more convenient and gives you an "at-a-glance" picture of the various AJAX relations and the elements that comprise them. To extract this information otherwise would require that you go over all Triggers and draw something like a "Trigger diagram".

    Last but not least the Telerik RadAjax framework offers a completely Codeless Development experience.

    • See Also

    Codeless Development

    © 2002-2008 Telerik. All Rights Reserved.


Codeless Development

Telerik RadAjax v1.8 Send comments on this topic.
Codeless Development
See Also
Advantages of telerik AJAX framework > Codeless Development

Glossary Item Box

A key factor for the relatively slow adoption of the AJAX development technique is the fact that it relatively complex and requires advanced coding skills. The client-side scripting tends to be particularly intricate and naturally difficult for most developers.

The Telerik RadAjax framework is built with that idea in mind and offers a completely codeless development experience when building AJAX-enabling applications. Both the client- and server-side parts of the AJAX engine are encapsulated in a component model (AJAX Manager and AJAX Panel), which only have to be configured using Visual Studio design mode.

The patent-pending Click-and-Go™ technology allows you to define all AJAX relations on the page (which controls initiate AJAX requests and which controls are respectively updated) using a single dialog. Then all postback requests made by the controls you select as AJAX initiators will be automatically replaced with AJAX ajax requests. No other modification to your application will be necessary and not a single line of client- or server-side code will need to be written. (Watch a video)

In contrast, other AJAX frameworks offer simply a generic ajax initiating control. From there on you have to manually write custom JavaScript functions that call the "ajax" method of this control, and attach the JavaScript functions to the various events of the controls that you need to AJAX enable.

Consider you need to AJAX-enable the standard ASP.NET calendar. This control renders a __doPostBack() functions for every day of the current month as well as for the previous- and next-month buttons. So you will generally have to do the following:

  • write a custom JavaScript function that calls the "Makeajax" method of the generic ajax control with the respective parameters
  • override the DayRender event of the calendar so that for each day you call the this custom JavaScript function instead of the __doPostBack function of the calendar
  • since the SelectionChanged event of the calendar will not be fired, you have to move the server-side code that is executed on SelectionChanged event of the calendar to the "ajax" server event of the generic ajax control

Now think about complex real-life applications with numerous controls and AJAX relations, like the Telerik HelpDesk sample. Implementing AJAX in the above mentioned manner will be if not impossible then definitely not worth the efforts. Moreover, this approach will break the ASP.NET page lifecycle, which can cause problems to your application.

See Also

No Modifications to Your Application
Centralized Management of AJAX Relations
Intuitive Way for Defining AJAX Relations

© 2002-2008 Telerik. All Rights Reserved.


Telerik AJAX framework

Telerik RadAjax v1.8 Send comments on this topic.
Telerik AJAX framework
See Also

Glossary Item Box

The telerik AJAX framework allows developers to AJAX-enable any new or existing ASP.NET application without writing a single line of code. No previous knowledge of the AJAX development technique is needed, which makes Telerik RadAjax a prefect solution even for beginners.

In the core of the Telerik RadAjax framework is a patent-pending technology, which can make selected controls on the page perform AJAX callbacks instead of traditional postbacks. The whole AJAX behavior of the page is controlled through a single control, called Telerik AJAX Manager, which is configured completely in design-time through a single dialog.

Benefits of the Telerik AJAX framework

  • AJAX-enable any existing or new application, regardless of its level of complexity - most AJAX-enabling products offer just limited AJAX capabilities, allowing you to merely load/update a control with a callback. Those solutions, however, do not send form values to the server for processing, or do not preserve the ASP.NET page lifecycle. As a result you can implement only a limited number of scenarios. The Telerik RadAjax framework on the other hand can cover any scenario that can be implemented with the traditional postback mechanism. Resultingly, you can build very sophisticated applications, similar to Outlook Web Access or the Telerik HelpDesk sample.
  • Don't have to know in details how AJAX works - you don't have to know AJAX in order to use AJAX. The Telerik framework encapsulates the complexity and intricate client-side scripting in a convenient component model. The postback behavior of the selected elements is automatically replaced with AJAX callbacks and the typical challenges of AJAX development are handled internally. So there is less to learn and less to worry about.
  • Don't have to make any modification to your application - a key disadvantage of other AJAX frameworks is the fact that you need to turn you application inside out and make major modifications in order to make it work with AJAX. You typically have to place Callback Panels around areas that need to be updated, set triggers, and manually invoke AJAX requests. In contrast, thanks to the patent pending Click-and-Go™ technology of Telerik RadAjax you only have to drag-and-drop the AJAX Manager on the page, tick the respective checkboxes in the dialog, and hit F5. You application is now AJAX-enabled. (Watch a video)

  • Don't have to write a single line of code (JavaScript or server-side) - the Telerik RadAjax framework offers a completely codeless approach for AJAX-enabling existing or new web applications. Postback requests of selected elements are automatically replaced with AJAX callbacks so that you don't have to attach custom JavaScript functions to page elements and invoke AJAX requests manually. Furthermore, the elements that need to be updated after the server response are updated automatically by the Telerik RadAjax client-side engine.

Controls comprising the Telerik RadAjax framework

The the Telerik RadAjax framework features two main controls - the AJAX Manager and the AJAX Panel. Both of them include the Telerik server- and client-side AJAX engine and may be used individually.

  • AJAX Manager - enables selected control(s) on the page to initiate AJAX requests instead of postbacks, and update other control(s) on the page. All AJAX relations (which control updates which) are defined through one centralized place - the convenient dialog of the AJAX Manager (in Visual Studio design mode).
    The AJAX Manager can handle even the most complex scenarios and offers a number of advantages compared to other solutions.

  • AJAX Panel - this control is suitable for simpler scenarios. It represents a container that AJAX-enables all controls placed inside. As a result those controls start making AJAX callbacks instead of postbacks.
    The AJAX Panel only affects the elements placed inside it. For example, if you put a DataGrid control or the Telerik Telerik RadGrid inside an AJAX panel, the grid will start performing AJAX requests instead of postback for paging, sorting, editing, etc. However, the grid will not be able to update other elements on the page, which are outside the AJAX Panel. Such scenarios can be easily handled by the AJAX Manager. To read more about the difference between the AJAX Manager and the AJAX panel and the suggested use cases, please read section "AJAX Controls -> Panel vs. Manager".

In addition, the Telerik RadAjax framework includes two auxiliary controls:

  • Loading Panel - this is a control that is shown during the AJAX request and serves a a progress indicator.
  • AJAX Timer - this time-bound control ticks and makes one or more postbacks at a predefined interval. This control should be used together with AJAX Panel or AJAX Manager in order to perform AJAX requests.

Features of the Telerik AJAX framework

  • Works with any standard ASP.NET controls and most 3rd party controls (including Telerik RadControls for ASP.NET) - the Telerik RadAjax patent-pending technology can AJAX enable any of the standard controls shipped with Visual Studio 2003 and 2005 and well as all of the controls included in the Telerik suite for ASP.NET. Most 3rd party controls are also supported, however due to some specifics of certain implementations full compatibility is impossible.
  • Support for .NET 1.x and 2.0 - Telerik RadAjax uses a proprietary AJAX engine that works both on the 1.x and 2.0 versions of the .NET framework.
  • Preservation of the page life-cycle - Telerik RadAjax does not break the normal page life-cycle, which guarantees the proper functioning of your applications. Actually, the AJAX-enabled controls don't really know that they are working in AJAX mode rather than postback mode.
  • Proper handling of the ASP.NET ViewState and EventValidation - unlike other AJAX Frameworks Telerik RadAjax updates the ViewState of the page after the AJAX request in order to keep it in a consistent state regardless of the type of the request that has been made (AJAX callback or postback).
  • Persistence of form values - all form values are sent to the server for processing during the AJAX request and are persisted between AJAX requests. All form controls can be referenced in the code-behind as if a postback occurred. This feature guarantees that your AJAX-enabled applications will not be limited to mere rendering of controls with AJAX, but can cover even the most complex scenario.
  • Persistence of JavaScript code - Telerik RadAjax controls re-initialize JavaScript code after an AJAX request has been performed. This behavior is very important when working with third party that feature rich client-side functionality like the Telerik RadControls for ASP.NET for ASP.NET. The proper functioning of such controls will not be affected when they are AJAX-enabled with Telerik RadAjax.
  • Support for ASP.NET Client Validation - Telerik RadAjax controls fully support server- and client-side validation implemented with the standard ASP.NET validation controls.
  • Search-engine optimization - the Telerik RadAjax controls automatically detect and handle the web crawlers (search engines) and render alternative content, suitable for indexing.

See Also

Advantages
No Modifications to Your Application

AJAX Controls
AJAX Manager
AJAX Panel
Panel vs. Manager

© 2002-2008 Telerik. All Rights Reserved.


Getting started

Telerik RadAjax v1.8 Send comments on this topic.
Getting started

Glossary Item Box

The following introductory topic shows the basic steps to set up and configure RadAjaxManager and AjaxLoadingPanel, to Ajax-enable your implementation.

  1. The RadAjaxManager can be added easily to any implementation, requiring the replacement of ordinary post backs with ajax request.
  2. To use the RadAjaxManager you simply need to drag it from the toolbox, onto the design surface, along any other present controls. This step, as well as all consequent steps presented here are completely codeless:

  3. To further enhance the user experience, you can take advantage of AjaxLoadingPanel. This control supports image templates, which can be shown as a progress indication, whenever a callback request is performed, i.e. when the page is loading silently. To include it, simply drag and drop the AjaxLoadingPanel on the design surface.

  4. Next, in order to Ajax-enable the individual controls on the page, you can configure RadAjaxManager through the “Configure Ajax Manager” link of the Smart Tag. Again, this step is completely codeless, requiring only design-time configuration of the necessary relations among the AJAX Manager and the other controls :

  5. On the left-hand side are included the control(s) which will initiate the Ajax requests. On the right-hand side is the list of controls which will be updated via Ajax, instead of ordinary post back. You can easily include/exclude items from these list via the checkboxes to the left :

  6. Further, you can easily specify a Loading Panel, which will be displayed during the ajax request. The loading panel can be displayed for each control that will be updated via the Ajax Manager. The only setting which needs to be included is the ID of an existing Loading Panel:

  7. The screenshot below demonstrates the previous steps in execution. The upper button, located between the two List Boxes, adds an artist’s name to the right-hand side List Box control. With the help of the AJAX Manager, the normal post back is replaced by a callback. Additionally, the loading panel is displayed over the currently updated control:

© 2002-2008 Telerik. All Rights Reserved.


Migrating from r.a.d.callback to Telerik RadAjax

Telerik RadAjax v1.8 Send comments on this topic.
Migrating from r.a.d.callback to Telerik RadAjax
See Also

Glossary Item Box

The patent-pending technology used in Telerik AJAX framework allows developers to AJAX-enable any ASP.NET application without writing a single line of code. This brings Telerik RadAjax suite to a higher level in terms of ajaxifying the web pages compared to its predecessor r.a.d.callback. Instead of having a complete set of individual AJAX-enabled controls, it features the ajaxifier controls AJAX Manager and AJAX Panel, which will automatically AJAX-enable any postback control.

AJAX Manager is a control that ajaxifies selected controls on the page. It makes any control on the page perform an AJAX request and update one or more controls including itself. AJAX Manager has a visual tool that makes it very easy and completely codeless to set the relation between the callback initiator and the updated control(s).

AJAX Panel is an container control that makes all controls placed inside it start performing callbacks instead of postbacks.

Migrating Callback Controls to RadAjaxManager

The Telerik RadAjax suite does not contain the callback controls from the r.a.d.callback package. This might require some changes: your applications will no longer use the old callback controls; instead, AJAX Manager will ajaxify the standard controls.
AJAX Manager is kept compatible with the callback controls and they can co-exist on the same page. This can help you migrate your pages smoothly over a longer period of time.

In general, you need to replace the callback controls with their ASP.NET counterparts. Then you need to set them in Ajax Manager as AJAX request initiators (see The AJAX Manager topic).

The example below demonstrates how to migrate a CallbackCheckBox to standard CheckBox and AJAX Manager.

The implementation with r.a.d.callback:

ASPX/ASCX Copy Code
<radClb:CallbackCheckBox
id="cbAdditionaInformation"
runat="server"
Text="Add Contact Information"
ControlsToUpdate="outerPanel,LoadingPanel2">
</radClb:CallbackCheckBox>

Same with RadAjax:

The manager will auto-generate this code in the ASPX:

ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="CheckBox1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="outerPanel" LoadingPanelID="LoadingPanel2" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
AJAX Manager will transform postbacks to AJAX requests. That is why the CheckBox control needs its AutoPostBack property set to true.

Generic Callback (RadCallback) to RadAjaxManager

The Telerik RadAjax suite no longer features the generic callback control from the r.a.d.callback suite. It has the much more powerfull AJAX Manager control. AJAX Manager has all the functionality offered by the generic callback control. In addition it has a better design-time support and lets you set more accurately the relation between the AJAX initiator and the updated controls. Moreover, you are not required to write any JavaScript in order to initiate a request. Yet you can still trigger a request using client-side code.

A single AJAX Manager can replace several generic callback controls because it lets you set several groups of AJAX initiators and their updated controls.

Migrating the AJAX request initiation can be performed in two ways:

  • Most of the calls to MakeCallback() should be replaced by a postback event. Remove your calls to MakeCallback(), and set the control's AutoPostBack property to true. Set the control in AJAX Manager using the designer.
  • Client request initiation from JavaScript event handlers - replace the calls to MakeCallback() with calls to AjaxRequest() (see "Changes to the Client API" section below). describe the changes in functions.

CallbackPanel to RadAjaxPanel

RadAjaxPanel entirely replaces the CallbackPanel control. In order to migrate you need to change the CallbackPanel tag in the ASPX with the RadAjaxPanel tag.

Implementation with CallbackPanel:

ASPX/ASCX Copy Code
<radclb:CallbackPanel ID="CallbackPanel1" Width="509px" Height="280px" runat="server">
...
</radclb:CallbackPanel>

Implementation with RadAjaxPanel:

ASPX/ASCX Copy Code
<rad:RadAjaxPanel ID="AjaxPanel1" Width="509px" Height="280px" runat="server">
...
</rad:RadAjaxPanel>
The AsyncRequest method has been deprecated in Telerik RadAjax. Use AjaxRequest instead.

Migrating ControlsToUpdate collection to AjaxSettings collection

The successor of ControlsToUpdate collection in Telerik RadAjax is the AjaxSettings collection. There you can add the AJAX pairs of AJAX initiator, updated control and the Loading Template that will be displayed during the request.

in r.a.d.callback here is how you set the ControlsToUpdate collection:

CallbackButton1.ControlsToUpdate.Add(RadGrid1, LoadingPanel1);

in Telerik RadAjax you should use the AjaxSettings collection of AjaxSetting objects in this way:

RadAjaxManager1.AjaxSettings.AddAjaxSetting(Button1, RadGrid1, LoadingPanel1);

Note that you should set the AjaxSettings collection on each Page_Load!

The parameters are as follow:

  • Button1 - the AJAX initiator;
  • RadGrid1 - the control that will be updated;
  • LoadingPanel1 - the Loading Panel that will be shown during the request.

Changes to the Client API

  • MakeCallback migrates to AjaxRequest or AjaxRequestWithTarget: both RadAjaxPanel and RadAjaxManager have this new function. Here is a comparison between the old and the new function:

RadCallback control (part of r.a.d.callback) RadAjaxPanel and RadAjaxManager (part of r.a.d.ajax)
<%=RadCallback1.ClientID%>.MakeCallback('add', '1, 2, 3');
ClientID | The client ID of the generic callback control (e.g. '<%=RadCallback1.ClientID%>')

EventName

 The name of the event which raises the callback
EventArgs | The arguments for the event

AjaxRequestWithTarget function:
<%=AjaxPanel1.ClientID%>.AjaxRequestWithTarget(eventTarget, eventArgument)
eventTarget | The control which should raise postback event. You should always use the control's UniqueID.
eventArgument | This is optional argument for the event
AjaxRequest function
<%=AjaxPanel1.ClientID%>.AjaxRequest(arguments)
arguments The parameters, which the control had used when it raised the request.

  • AjaxRequestWithTarget mimics the __doPostBack(eventTarget, eventArgument) function:

  • <%=AjaxPanel1.ClientID%>.AjaxRequestWithTarget(eventTarget, eventArgument) (see AJAX Panel topic for details).

  • There are a number of changes in the client-side events. They are compatible with r.a.d.callback and should not break the functionality. See the "Client-side" section for details regarding these events.

See Also

AJAX Controls
AJAX Panel
AJAX Manager

© 2002-2008 Telerik. All Rights Reserved.


Changes and backward compatibility

Telerik RadAjax v1.8 Send comments on this topic.
Changes and backward compatibility

Glossary Item Box

Telerik RadAjax v1.8 (part of Q2 2007)

There are no major changes and the product is fully backwards compatible.

Telerik RadAjax v1.6 (part of Q4 2006)

Description | Type | Change
SetMaxRequestQueueSize - specifies the maximum size of the ajax request queue | property | New
IsStarted - returns the state of the RadAjaxTimer | property | New
AjaxRequestError - this property defines the name of the function or the JavaScript code of the function that will handle the errors on AJAX requests. | property | New
DefaultLoadingPanelID - specifies the default loading panel for AJAX Manager | property | New

© 2002-2008 Telerik. All Rights Reserved.


Which license should I use or purchase

Telerik RadAjax v1.8 Send comments on this topic.
Which license should I use or purchase
See Also
Licensing > Which license should I use or purchase

Glossary Item Box

Telerik offers several different packages for you to choose from:

Trial licenses

Description

If you are a first-time Telerik user, it would be best to create an account in our Client.NET extranet (www.telerik.com/Clientnet) and download a Trial license. The Trial licenses are fully-functional and are identical in functionality to the paid versions. Review the Which file do I need to install? section for further instructions.

Support

A trial license comes with the Bronze Support package, which guarantees a 72-hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer licenses

Description

A Developer license is granted per developer seat: one developer is allowed to work with the product per license. Developer licenses have no run-time limitations and allow the usage of all Telerik controls in an UNLIMITED number of custom web applications. The controls can be installed on more than one machine as long as only the licensed developer is using the product.

License Keys

Developer licenses come with special builds that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from a trial license to a Developer license, please review the instructions in the following section: Trial License v.x to Developer License v1.x

Support

The Single Developer license comes with the Silver Support package which guarantees a 48 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer Subscription license

Description

Unlike the Single Developer license, Single Developer Subscription license offers a Subscription. A Subscription license entitles you to receive, for free, all released updates and new products for the duration of one year from the date of purchase. This license is the easiest and most cost-effective way to ensure that you are using the latest versions of our products. With the Subscription license you save more than 70% on Telerik products if purchased separately.

The Single Developer Subscription license is offered for the Telerik RadControls for ASP.NET suite only. Subscriptions are not available for individual products at this time.

You can renew your subscription at approximately 50% of the original price. You will be promptly notified when the Subscription license is about to expire.

All RadControls for ASP.NET subscription holders are entitled to a license to RadControls for ASP.NET AJAX suite.

License Keys

The Developer license comes with a special build that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from Trial to a Developer license, please review the instructions in the following section: Trial License v.x to Developer License v1.x

Support

The Single Developer Subscription license comes with the Gold Support package which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Telerik maintains a public Product Roadmap, which will give you details on the upcoming products and versions for the next quarter. This guarantees that you see a good return on your investment in the Subscription license.

Source Code license

Description

The Source Code license is an excellent investment if you need to customize our controls to fit a specific requirement, or if your company wishes to own the source code for all products used.

A Source Code license is offered with purchases of five or more Single Developer or Single Developer Subscription licenses for Telerik RadControls for ASP.NET suite. If you have opted for the Subscription license, you will be receiving the source codes for all products released within one year from the date of purchase.

Source Code licenses are offered for the Telerik RadControls for ASP.NET suite only and are not available for individual products at this time.

Support

The Source Code license comes with the Gold Support package, which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. All questions from Source code licensees are treated with priority.

For more information, review the available Support Options.

Custom Source Code modifications are not supported by Telerik.

Discounts Offered

Telerik offers the following volume discounts on all licenses:

  • 3 to 4 licenses - 10%
  • 5 to 9 licenses - 20%
  • 10 to 19 licenses - 30%
  • 20 or more - 40%

Telerik also offers discounts to qualified educational, non-profit, charity and government entities. For more information on how to qualify for a discount, visit our Special pricing page.

See Also

Sales FAQ page
Purchase Online
Support Options
Support FAQ
Client.Net FAQ
License Agreement

© 2002-2008 Telerik. All Rights Reserved.


License Agreement

Telerik RadAjax v1.8 Send comments on this topic.
License Agreement
Licensing > License Agreement

Glossary Item Box

Telerik End-User License Agreement

By purchasing, installing, or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. Check the box "I have read and agree to the License Agreement" if you agree.

IMPORTANT – READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as “SOFTWARE”).

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered “use” of the SOFTWARE.

2-1. Redistribution rights:

All product licenses are perpetual and royalty-free. You can ship the SOFTWARE as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.

You may distribute the SOFTWARE provided that:

  • You reasonably ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You need to duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You need to include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).

2-2. Silver Support:

As part of your license you are entitled to "Silver" Support Package which guarantees response within 48 hours.

3. DEVELOPER LICENSE PLUS SUBSCRIPTION AND SOURCE CODE LICENSE

You are granted 1 (one) Developer License as defined above. In addition you are entitled to a 1 Year Subscription, Source Code and Gold Support Package.

3-1. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year.

  • 3-2. Source Code

    As part of the DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE you are granted the right to view and modify the SOFTWARE's source code only as authorized below:
  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided as is. Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, such modifications and all rights associated therewith will be the exclusive property of TELERIK. You are granted the right to use such modifications as set forth in this agreement.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-3. Gold Support:

As part of your license you are entitled to "Gold" Support Package which guarantees response within 24 hours.

II. OTHER RIGHTS AND LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by other individuals than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed part of products that have the same or substantially the same primary functionality. (Example for RadControls for ASP.NET: you may purchase Telerik RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE.
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market YOUR SOFTWARE.
  • You are not allowed to disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
  • You agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of YOUR SOFTWARE

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic files only. Documentation shall also be provided in electronic format.

IV. UPGRADES

You are eligible for free minor upgrades (e.g. v.1.5 to v.1.8), patches, and bug-fixes for the SOFTWARE, including source code if applicable. SOFTWARE labeled as an upgrade replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE” you are entitled to receive all version updates for the SOFTWARE period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, shall it be offered individually or as a part of a product SUITE. However, TELERIK is obligated to provide the proper level of support for all discontinued products for a period of 1 (one) year after the date of discontinuance.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying written materials for a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty within thirty days after the warranty period expires.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the State of Massachusetts, U.S.A. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.

© 2002-2008 Telerik. All Rights Reserved.


System requirements and browser support

Telerik RadAjax v1.8 Send comments on this topic.
System requirements and browser support
Installation and deployment > Installation > System Requirements > System requirements and browser support

Glossary Item Box

System Requirements

The following page describes the system requirements needed by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx

Browser Support

The following page shows all browsers and versions supported by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/browser-support.aspx

Browser Limitations

The following article explains the browser limitations and what implications they have on Telerik RadControls for ASP.NET:

http://www.telerik.com/support/browser-support/browser-issues.aspx

Files and folders needed by Telerik RadAjax and Telerik RadControls for ASP.NET to function

The following section explains the files and folders needed to be used in your application in order for Telerik RadControls for ASP.NET to function properly:

Files and folders needed by Telerik RadControls for ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Which file do I need to install?

Telerik RadAjax v1.8 Send comments on this topic.
Which file do I need to install?
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Which file do I need to install?

Glossary Item Box

Telerik offers you the following ways to install Telerik RadAjax:

  • as an individual install, or
  • as part of the complete Telerik RadControls for ASP.NET suite.

If you plan to use only Telerik RadAjax in your project, we recommend that you install Telerik RadAjax only. In case you want to use two or more products from the Telerik RadControls for ASP.NET suite, it is probably better to install the full Telerik RadControls for ASP.NET suite.

Each installation package comes in three types:

  • EXE file for automatic installation;
    The EXE files are intended for easy and automatic installation of a product. It installs the control(s) on your computer in a folder in your Program Files named Telerik, and automatically creates the necessary virtual folders and projects. Additionally, the EXE installs the help file(s) in your VS.NET IDE and in your local copy of MSDN (if you have one). The EXE files are best for first-time Telerik users and ASP.NET novices.
  • ZIP file for manual (advanced) installation;
    The ZIP is used for manual (advanced) installs and for upgrading/updating purposes. The folder structure is different from the EXE. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot. Use the ZIP file for installation on shared hosting.
  • DLL and Scripts only (a.k.a. HOTFIX) file for updating/upgrading a product to a newer version;
    This is a bare-bones upgrade option for our controls. The DLL and Scripts files contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product and just want to update it, there is no need to download the complete suite - download the latest HOTFIX for the product and apply it.
The latest EXE and ZIP packages available for download already have all updates/HOTFIXES applied. There is no need to update them further.

If you already have a Telerik control installed from the EXE, you can safely install an updated version of the same control - the installer will keep your existing installation. The new files will be placed in a separate folder and the new installation does not damage the common installer files. The new Telerik RadAjax installation may have an updated help too: it is registered with the correct ajax namespace. You can see the updated Telerik RadAjax help in your help2 viewer.

See Also

Installing the Telerik RadControls for ASP.NET suite from EXE file
Installing the Telerik RadControls for ASP.NET suite from ZIP file
Installing Telerik RadAjax from EXE file
Installing Telerik RadAjax from ZIP file
Using the 'DLL and Scripts only' file (HOTFIX)

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from EXE file

Telerik RadAjax v1.8 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Installing the Telerik RadControls for ASP.NET suite from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the suite on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have one installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadControls for ASP.NET installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadControls for ASP.NET on your machine from the EXE file, follow the instructions below:

  1. Log into your Client.NET account.
  2. Go to My Licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\RadControlsQ1 2007.

The wizard will create the necessary virtual folders.

To view live examples of the Telerik RadAjax functionality, you can launch the Quick-Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> RadControls Q1 2007 for ASP.NET -> ASP.NET 2.X -> RadControls Q1 2007 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadControls on your machine from the EXE file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Programs -> Telerik -> RadControlsQ1 2007 for ASP.NET-> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

The Telerik RadControls for ASP.NET package adds the products automatically to the VS.NET 2005 toolbox. To learn how to add them manually, see Adding Telerik RadAjax to the Visual Studio 2005 Toolbox.

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadAjax from EXE file

Telerik RadAjax v1.8 Send comments on this topic.
Installing Telerik RadAjax from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Installing Telerik RadAjax from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the control on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadAjax installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadAjax on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadAjax.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadAjax_1_8.exe and follow the instructions.

The wizard will create a virtual folder "Telerik RadAjax1.8NET2" (accessible at http://localhost/Telerik/telerikradajax1.8_NET2).

To view live examples of the Telerik RadAjax functionality, you can launch the Quick Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> Telerik RadAjax v1.8 -> ASP.NET 2.X -> Telerik RadAjax v1.8 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadAjax v1.8\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadAjax v1.8\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadAjax on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Locate Telerik RadAjax, and click on it.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadAjax_1_8.exe and follow the instructions.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Telerik -> Telerik RadAjax v1.8 -> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

Telerik RadAjax will be added automatically to VS.NET 2005's toolbox. Review the following instructions to add it manually: Adding Telerik RadAjax to the Visual Studio 2005 Toolbox

The wizard will install the Telerik RadAjax component in the following folder unless you specify otherwise:
\Program Files\Telerik\Telerik RadAjax1.8\NET2.

The installation folder contains the following subfolders and files:

  • "bin" - contains the .dll files

  • "Common" - contains JavaScripts and css files

  • "RadControls" - contains the clients-side JavaScript and resource files
    You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.

  • "ajax" - contains the running examples from the Quick-Start framework

  • LiveExamplesCS - a browser link to run the C# version of the examples locally
  • LiveExamplesVB - a browser link to run the VB.NET version of the examples locally

The information below is generic for all Telerik controls. The particular details vary for individual control installations.

The installation folders of some Telerik controls may also contain the following subfolders:

  • "DeploymentActions" - contains the files required for proper deployment of the control
  • "Help" - contains all the files required for generating Help2
  • "Img" - contains system images
  • "InstalledRelated" - contains the files required for proper installation of the control

See Also

Adding Telerik RadAjax to an ASP.NET WebForm
Add/Remove Telerik RadAjax to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from ZIP file

Telerik RadAjax v1.8 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Installing the Telerik RadControls for ASP.NET suite from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadControls for ASP.NET manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install without IIS Running (VS 2005 only)

To install the Telerik RadControls for ASP.NET suite on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadControls for ASP.NET - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help1
    • HelpNET20 folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET2.x
    • other files and folders.
  5. The latest package available for download has all latest updates/HOTFIXES applied. There is no need to update it further.
  6. Once the download completes, create a Telerik_RadControls folder in your IIS's inetpub/wwwroot folder.
  7. From the downloaded file, extract the files from the NET2 folder into inetpub/wwwroot/Telerik_RadControls folder. After the process ends, the inetpub/wwwroot/Telerik_RadControls folder should contain the following files and folders:
    • app_themes folder - contains the themes and skins used by Telerik's navigational controls
    • bin folder - contains the controls' .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files, needed by Telerik's controls. You will need to copy this folder in your web application only if you intend to use skins different from the Default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell, Telerik RadUpload and Telerik RadWindow products.
    • folders, named after Telerik's controls (i.e. Calendar, Chart, Combobox, etc.) - these contain the running examples for each control from the Quick-Start framework
    • other project files and folders.
  8. Create a .NET2 virtual directory for the folder where you extracted the files. Show How?

    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (Telerik_RadControls).
    2. Select Properties.
    3. Click the Create button. The application name will become Telerik_RadControls.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  9. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were extracted. See Setting ASNET (Network Service) Permissions for more information.

To run the examples paste the following link in your browser: http://localhost/Telerik_RadControls/

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add any control to the VS.NET toolbox, review Adding Telerik RadAjax to the Visual Studio 2005 Toolbox
To use any Telerik ASP.NET control in your project, review Adding Telerik RadAjax to an ASP.NET WebForm

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadAjax from ZIP file

Telerik RadAjax v1.8 Send comments on this topic.
Installing Telerik RadAjax from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Installing Telerik RadAjax from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadAjax manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install Telerik RadAjax with IIS running

To install Telerik RadAjax on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadAjax.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadAjax - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadAjax under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadAjax under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. Once the download completes, create a RadAjax folder in your IIS's inetpub/wwwroot folder.
  6. From the downloaded file, extract all files from the NET2 folder into inetpub/wwwroot/RadAjax folder. After the process ends, the inetpub/wwwroot/RadAjax/ folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for RadChart, RadEditor, RadSpell, RadUpload and RadWindow products.
    • ajax folder - contains the running examples from the Quick-Start framework
    • other project files.
  7. Create a .NET2 virtual directory for the folder where you unzipped the files. Show How?
    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (RadAjax).
    2. Select Properties.
    3. Click the Create button. The application name will become RadAjax.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  8. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were unzipped. See Setting ASNET (Network Service) Permissions for more information.

To run the examples, paste the following link in your browser: http://localhost/RadAjax

Install Telerik RadAjax without or with IIS stopped (VS 2005 Only)

To install Telerik RadAjax on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadAjax.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadAjax - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadAjax under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadAjax under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. From the downloaded file, extract all files from the NET2 folder into folder at a convenient location on your disk. After the process ends, the folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
    • ajax folder - contains the running examples from the Quick-Start framework
    • other project files.
  6. Open and Run (Ctrl+F5) Quick-Start Framework VisualStudio Web Site using the provided solution file ControlsExamples.sln in the NET2 folder. VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add Telerik RadAjax to the VS.NET toolbox, review Adding Telerik RadAjax to the Visual Studio 2005 Toolbox.

To use the Telerik RadAjax in your project, please review Adding Telerik RadAjax to an ASP.NET WebForm.

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Adding Telerik RadAjax to an ASP.NET WebForm
Add/Remove Telerik RadAjax to the Global Assembly Cache
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Using the 'DLL and Scripts only' file (HOTFIX)

Telerik RadAjax v1.8 Send comments on this topic.
Using the 'DLL and Scripts only' file (HOTFIX)
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Using the 'DLL and Scripts only' file (HOTFIX)

Glossary Item Box

Show All Show All
Hide All Hide All

The "DLL and Scripts only" file (a.k.a. HOTFIX file) is a bare-bones upgrade option for our controls - they contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product, there is no need to download the complete suite - download the "DLL and scripts only" version and follow the instructions below for applying the hotfix. The "DLL and Scripts only" file contains the following folders and files:

  • bin folder - contains the .dll file(s)
  • RadControls folder - contains the clients-side JavaScript and resource files for Telerik RadAjax
If you are installing a Telerik product for the first time, we recommend that you download the complete package (EXE or ZIP file).

To update Telerik RadAjax to a new version

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).
  3. Locate the control that you need to install, i.e. Telerik RadAjax, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. If you have purchased the control, you need to download the file which has the Dev abbreviation in it.
  5. Once the download completes, unzip the files at a convenient location.
  6. If the upgrade is major (i.e. from v.x to v1.x), check the Changes and Backward Compatibility section in this manual for further instructions.
  7. Back up your application.
  8. Close Visual Studio or any ither IDE which may lock the old assembly.
  9. From the newly downloaded and unzipped files, copy the new DLL (located in the bin folder) to your web-application's bin folder. Replace the old dll.
  10. [Optional. Follow this step only if you intend to use skins different from the default or if you plan to modify the JavaScript files
    Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products. ]
    Copy the new RadControls folder to the root of your web-application. Replace all files and folders when asked. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate the old folder and paste the new RadControls folder over it. Replace all files and folders when asked.
  11. If you are using VS.NET, update the control's reference in your project to point to the new DLL.
  12. Recompile your project.
  13. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadAjax to the Global Assembly Cache
  14. Run the project.
  15. If you still get the older version of Telerik RadAjax Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadAjax's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadAjax, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....
  16. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadAjax (the Developer versions of Telerik's controls do not throw copyright messages).

    If you have purchased the control, then you have downloaded the wrong "DLL and Scripts only" file. Make sure you you download the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

See Also

Adding Telerik RadAjax to an ASP.NET WebForm
Add/Remove Telerik RadAjax to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Setting ASPNET (Network Service) Permissions

Telerik RadAjax v1.8 Send comments on this topic.
Setting ASPNET (Network Service) Permissions
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Setting ASPNET (Network Service) Permissions

Glossary Item Box

In most applications, users typically access Web applications anonymously — that is, they do not initially provide authentication credentials. In that case, the Web application has to assume (impersonate) some identity that it can use to request resources.
By default, when ASP.NET allows anonymous access, the application runs in the context of a special local (not domain) account. The user context depends on the operating system. In Windows 2000 and Windows XP, applications run under the account called ASPNET. In Windows Server 2003, the user context is called NETWORK SERVICE. These user accounts are created during the .NET Framework installation process with a unique, strong password, and are granted only limited permissions. The ASPNET or NETWORK SERVICE user can access only specific folders that are required to run a Web application, such as the \bin directory in which a Web application stores compiled files.

Full information on the topic can be found in MSDN: Security Considerations for ASP.NET Web Applications

Instructions on how to give process permissions on a folder - FAT32 file system

No need to give any permissions on the folder.

Instructions on how to give process permissions on a folder - NTFS file system

Internet Information Services v5.x - name of account: ASPNET user

  1. Right-click on the RadAjax (or Telerik_RadControls) folder and select Properties.
  2. Click on the Security tab. If you do not see the security tab, click Show here

    The Security tab is not visible because you have Simple File Sharing enabled. You will need to disable it before you continue. To do so:
    1. Open a Windows Explorer.
    2. On the Tools menu, click Folder Options, and then click the View tab.
    3. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box (at the bottom of the list).
    4. Click OK.
    5. Right-click on the folder you need to add ASPNET permissions to and select Properties. Click on the Security tab.

  3. Click on Add (to add a new user).

  4. Click on Locations to select your local machine. Your screen should look similar to the following:

    Setting ASPNET permissions

  5. Select your local machine and click OK.

  6. Type ASPNET in the textbox and click on Check Names. ASPNET should underline (if it doesn't then you don't have Microsoft's .NET framework installed).

    ASPNET user

  7. Click OK.

  8. Select the LOCAL MACHINE NAME/ASPNET user you just created (it should be named ASP.NET Machine Account (NAME/ASPNET)) and check the Full Control box to give it full permissions.

  9. Click APPLY.

  10. Click Advanced and make sure that the "Inherit from parent ..." check box is checked.

  11. Click OK to close the Advanced properties.

  12. Click OK to close the folder properties.

Internet Information Services v6.x - name of account: Network Service user

Same as above but replace ASPNET with Network Service.

© 2002-2008 Telerik. All Rights Reserved.


Trial License Limitations

Telerik RadAjax v1.8 Send comments on this topic.
Trial License Limitations
See Also
Installation and deployment > Installation > Installing Telerik RadAjax on your computer > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik components, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your application is displaying a license key error, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading the Trial License to a Production License section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with trial error messages (see below) displayed randomly on the page.

Trial error messages

The trial licenses will occasionally display the following message on your webform:

Telerik RadAjax 1.8 trial version. Copyright Telerik © 2002-2008. To remove this message, please, purchase a developer version .

See Also

License Agreement

© 2002-2008 Telerik. All Rights Reserved.


Files and folders needed by Telerik RadControls for ASP.NET

Telerik RadAjax v1.8 Send comments on this topic.
Files and folders needed by Telerik RadControls for ASP.NET
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Files and folders needed by Telerik RadControls for ASP.NET

Glossary Item Box

Please, review the following KB article on the topic:

Which files and folders are mandatory to be on the server for Telerik RadControls for ASP.NET to function

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


The 'RadControls' Folder

Telerik RadAjax v1.8 Send comments on this topic.
The 'RadControls' Folder
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > The 'RadControls' Folder

Glossary Item Box

The RadControls folder is an essential part of Telerik RadControls for ASP.NET - it contains all resources needed for the components to function properly (i.e. images, client-side scripts, configuration files, skins, etc.).

You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files. However because of the specific control features, you will always need to copy /RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.

Each Telerik component seeks its resources in the respective subfolder of RadControls: for example, /RadControls/Ajax is the folder where the resources for Telerik RadAjax reside.

Copying the RadControls folder to your web application

To work with Telerik RadControls for ASP.NET, you need to copy the RadControls folder to your web application. The folder must contain all the subfolders of the controls you are going to use. Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Do not include the RadControls folder in your VS.NET solution! Show Why?

When the RadControls folder is included in a VB.NET project, VS.NET tends to change some files within the RadControls folder automatically. The extent of these changes depends on the IDE settings; notably, the following controls are affected:
  • Telerik RadEditor
  • Telerik RadSpell
  • Telerik RadChart
Telerik controls are written in C# - hence the several *.CS codebehind files within the RadControls/[control] folder. When such .ASCX/ASPX files are included in the project, VS.NET automatically changes the Language attribute of their Page/Control directive from cs to vb and breaks the control.

To avoid the problem:
  1. In Windows Explorer, do a filtered search to locate all ASPX and ASCX files within the RadControls folder.
  2. Once the search is over, select all files and right-click to get their properties.
  3. Select the Hidden check box and click OK.
Now Visual Studio will not see the files, so errors will not be thrown. At the same time IIS will see the files and will display them fine.

If you have already included the RadControls folder in your VS2005 project:
  1. Open your Visual Studio 2005 project.
  2. In the Solution Explorer locate the RadControls folder and expand it.
  3. Locate the problematic ascx files, right-click them and select "Exclude from project". Unfortunately, this can be done for files only (unlike VS2003), so the process should be repeated for all ascx files.
  4. Open Windows Explorer, navigate to your project's folder.
  5. Back up the RadControls folder from your project, especially any customized files you may have (ConfigFile.xml, ToolsFile.xml, any css files, images. etc).
  6. Delete the damaged RadControls folder.
  7. Navigate to the installation folder of Telerik RadAjax (for example).
  8. Copy the RadControls folder from the installation folder to the root of your web application.
  9. Rebuild and run your project.

Moving the RadControls folder within your web-application

  1. Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/).
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB which in turn breaks the application! Use Windows Explorer instead.
  2. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

      <radA:RadAjax
            RadControlsDir="~/Resources/RadControls/" ...>
      </radA:RadAjax>

    • Or set the property globally from the Web.config file of the application:
      <configuration>
            <appSettings>
                   <add key="Telerik.WebControls.RadControlsDir" value="~/Resources/RadControls/"/>
            </appSettings>
      </configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.

Moving the RadControls folder outside your web-application

This is the best scenario if you want to have a single RadControls folder for several applications. This mechanism also enables different versions of Telerik products to reside in different web applications:

  1. Manually copy the RadControls to the new location.
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB, which in turn breaks the application! Use Windows Explorer instead.
  2. Create a virtual directory with name RadControls under each application's root which points physically to the same physical RadControls folder. That physical folder should include all the scripts and other required settings of the controls.
    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.
  3. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

      <radA:RadAjax
            RadControlsDir="~/RadControls/"  ...>
      </radA:RadAjax>

    • Or set the property globally from the Web.config file of the application:
      <configuration>
            <appSettings>
                  <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>
            </appSettings>
      </configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
      • Make sure you set the RadControlsDir property to "~/RadControls/" (with a slash following the folder name).

"You have not copied the RadControls folder to the root folder of your web-application" error message

When opening a page which contains Telerik RadAjax, the following error message appears:
“Telerik RadAjax v1.8: You have not copied the RadControls folder to the root folder of your web-application or you have applied an update incorrectly."

This message shows that the control is not able to locate its RadControls/ajax folder. It usually appears after updating the control to a newer version. The causes for the message to appear are:

  • The assembly version and the RadControls/ajax folder version are from different installation downloads, i.e. from different Telerik RadAjax versions.
    Example: RadAjax.NET2.DLL is version 1.8.2, whereas the Telerik RadAjax's RadControls/Ajax folder is from version 1.8.1 or other.
  • The proper assembly is in the bin folder of the application, but the RadControls/ajax folder is missing or misplaced.

To solve the problem:

  1. Check whether the RadControls folder is placed in the root of your web application and that you have NOT set the RadControlsDir property to point to another location.
  2. Check whether the RadControls/ajax folder contains a subfolder, named Scripts, and a subfolder which carries the version of the control as its name.
    For example, if you use Telerik RadAjax v1.8.2 - the folder should be \RadControls\Ajax\Scripts\1_8_2 and this version number should match the RadAjax.NET2.dll version placed in the /bin folder.
    If such discrepancy exists between the control's assembly and the RadControls folder, use a DLL and RadControls folder from a working application or download the ZIP file from your Client.net account and use the files from there.
  3. Another reason could be that some files from the RadControls/ajax folder are missing or damaged. Please delete the current RadControls folder and paste the original one from the same download that you have the assembly from.
  4. For some reason your project may still reference the previous version of control's DLL, and not the latest. In this case we suggest removing the old assembly reference from your VS.NET project and adding a new reference to to the new assembly.
  5. If you have added the control in the GAC (Global assembly cache), remove it by running gacUtil and then add the new version.
  6. If you are trying to move the RadControls folder through the RadControlsDir property, please review the following section for resolution:

  7. [not related to Telerik controls] Delete .NET, VS and browser caches because they can cause a problem too:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
      C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects.
    4. Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\VSWebCache.
    5. Delete your browser cache: Tools -> Internet Options -> Delete Files....

See Also

Setting the RadControlsDir property

© 2002-2008 Telerik. All Rights Reserved.


Setting the RadControlsDir property

Telerik RadAjax v1.8 Send comments on this topic.
Setting the RadControlsDir property
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Setting the RadControlsDir property

Glossary Item Box

The RadControlsDir property can be set:

  • either from the ASPX/ASCX page where Telerik RadAjax resides (or programmatically, from the code behind),
  • or globally, for all controls in the web application, from the Web.config file.

To set RadControlsDir from the Web.config, add the following line inside the appSettings tag:

<configuration>
      <appSettings>

           <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>

      </appSettings>
</configuration>

Notes.
  • In the above example, the tilde "~" represents the root of your web application.
  • You can change the location of the RadControls folder. The path given here is to serve only as an illustration.
  • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
  • When you set the RadControlsDir property, its value does not automatically update other properties that contain URL strings. You need to update these properties manually.

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadAjax to the Visual Studio 2005 Toolbox

Telerik RadAjax v1.8 Send comments on this topic.
Adding Telerik RadAjax to the Visual Studio 2005 Toolbox
See Also
Installation and deployment > Installation > Adding Telerik RadAjax to the Visual Studio 2005 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2005 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadAjax to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2005.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadAjax installation folder, open the NET2 folder and from the bin subfolder, select the RadAjax.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NET Q1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadAjax, the bin folder is located in the folder where the installation files have been unzipped (usually "\Inetpub\wwwroot\RadAjax_1_8\NET2"

  7. Click Open to confirm. The Telerik RadAjax icon should appear in the Toolbox.

  8. If you intend to use skins different from the default or if you plan to modify the JavaScript files, do not forget to copy the respective RadControls folder to the root of your application. For more information, see The 'RadControls' Folder.

See Also

Adding Telerik RadAjax to an ASP.NET WebForm

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadAjax to the Visual Studio 2008 Toolbox

Telerik RadAjax v1.8 Send comments on this topic.
Adding Telerik RadAjax to the Visual Studio 2008 Toolbox
Installation and deployment > Installation > Adding Telerik RadAjax to the Visual Studio 2008 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2008 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadControls for ASP.NET AJAX for ASP.NET to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2008.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadAjax installation folder and from the bin subfolder, select the RadAjax.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NET Q1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadControls, the bin folder is located in the folder where the installation files have been unzipped

  7. Click Open to confirm. The icon of the control will appear in the Toolbox. Visual Studio 2008 toolbox

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadAjax to an ASP.NET WebForm

Telerik RadAjax v1.8 Send comments on this topic.
Adding Telerik RadAjax to an ASP.NET WebForm
Installation and deployment > Installation > Adding Telerik RadAjax to an ASP.NET WebForm

Glossary Item Box

To add Telerik RadAjax to an ASP.NET WebForm you can use either of the following approaches:

  • Drag the Telerik RadAjax icon from the Visual Studio Toolbox;

  • Write the Telerik RadAjax tag manually.

If you intend to use skins different from the default or if you plan to modify the JavaScript files, you also need to manually copy the Ajax subfolder under the RadControls folder from the Telerik RadAjax installation folder to the root folder of your web application.

Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.
If your RadControls folder contains multiple subfolders for Telerik controls - for example, if you are using a Telerik RadControls for ASP.NET installation as opposed to a Telerik RadAjax installation - make sure you copy only the subfolders of the controls you are going to use (Ajax and any other controls you need). Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Adding Telerik RadAjax to a WebForm using Visual Studio .Net

The easiest way to deploy Telerik RadAjax is by dragging its icon from the Visual Studio .NET Toolbox in Design mode. Visual Studio will automatically copy the RadAjax.NET2.dll to the bin folder of your web-application and will create the respective references. You only have to copy the RadControls folder to the root folder of your web application as explained above.

Adding Telerik RadAjax to a WebForm manually

If you are not using Visual Studio .NET, you can deploy Telerik RadAjax manually. Follow the instructions below:

  1. Copy the RadControls folder from the Telerik RadAjax installation folder to the folder of your web application.

  2. Copy the RadAjax.NET2.dll from the bin folder of the Telerik RadAjax installation to the bin folder of your web application.

  3. Open your aspx/ascx file and add the Telerik RadAjax Register directive at the top:
    <%@ Register TagPrefix="radA" Namespace="Telerik.WebControls" Assembly="RadAjax.Net2" %>

    If you plan all pages in your application to use Telerik RadAjax you can add the following lines in your web.config file. In this case you don't need to add this directive in your pages.

    <pages>
      <controls>
        <add tagPrefix="radA" namespace="Telerik.WebControls" assembly="RadAjax.Net2" />
      </controls>
    </pages>

  4. Write the Telerik RadAjax tags in the body of the WebForm:

    <radA:RadAjax ID="ajax1" Runat="server">
    </radA:RadAjax>
  5. Add any additional properties you need between the Telerik RadAjax tags.

Troubleshooting: the css styles do not apply correctly

If you have a Telerik control in a user control with output caching turned on you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:

<link href="~/RadControls/Ajax/Skins/[SkinName]/styles.css"rel="stylesheet"runat="server">

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadAjax v1.8 Send comments on this topic.
Using IntelliSense in Visual Studio 2005
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadAjax is dragged to the webform the RadAjax.Net2.xml file is automatically added in the bin directory of the project.

In ASPX, when you start typing or when you insert a space, VisualStudio will show a dropdown with suggestions for autocomplete:

Intellisence in ASPX code

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2008

Telerik RadAjax v1.8 Send comments on this topic.
Using IntelliSense in Visual Studio 2008
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2008

Glossary Item Box

Visual Studio 2008 automatically enables IntelliSense - it detects all classes, properties and methods in the DLL file and the JavaScript code.

For additional convenience each Telerik control comes with an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadAjax is dragged to the webform the RadAjax.xml file is automatically added in the bin directory of the project.

When the Telerik control is dragged to the webform the XML file is automatically added in the bin directory of the project.
In ASPX, when you start typing or when you insert a space, Visual Studio will show a dropdown with suggestions for autocomplete:

ASPX AutoComplete

Visual Studio 2008 provides full Javascript Intellisense completion in ASPX files, HTM files, as well as in external JS files. It provides rich support for the ASP.NET AJAX client JavaScript framework and JavaScript code built with it:

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed.

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadAjax v1.x Trial to Telerik RadAjax v1.x Developer license

Telerik RadAjax v1.8 Send comments on this topic.
Upgrading Telerik RadAjax v1.x Trial to Telerik RadAjax v1.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadAjax v1.x Trial to Telerik RadAjax v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadAjax v1.8 Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadAjax files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadAjax, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Back up your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadAjax.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Ajax folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Ajax folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Ajax folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadAjax to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadAjax Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadAjax's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadAjax, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadAjax (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

5. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES".

© 2002-2008 Telerik. All Rights Reserved.


Add/Remove Telerik RadAjax to the Global Assembly Cache

Telerik RadAjax v1.8 Send comments on this topic.
Add/Remove Telerik RadAjax to the Global Assembly Cache
See Also
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Add/Remove Telerik RadAjax to the Global Assembly Cache

Glossary Item Box

Add to Global Assembly Cache

There are two ways to add a control to the Global Assembly Cache (GAC):

Automatic

  1. Go to Start -> Settings -> Control Panel -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration
  2. Expand the nodes and locate Assembly cache
  3. Right-click on it and select Add:

    Microsoft .NET 2.0 Configuration panel
  4. Browse to the Telerik bin directory and ctrl-highlight the needed DLL's (the demo and DictionaryConfiguration DLLs are not needed).
  5. Click Open.

Manual

  1. Run the .NET command prompt (Start -> Programs -> Microsoft VS.NET -> VS.NET Tools -> VS.NET prompt) and start the gacutil.exe tool with -i parameter (install) and the name of the control, e.g.

    gacutil.exe -i "C:\Program Files\Telerik\Telerik RadAjax1.8\NET2\bin\RadAjax.Net2.dll"

    You may also directly copy the dll files to the "\WINDOWS\assembly" (or "\WINNT\assembly") folder of your server - this is equivalent to the effect of the gacutil.exe utility.

  2. Change the machine.config file of the server and add a reference to the assembly in the GAC. The machine.config file is the configuration file for all web applications on the server. It is located at: "\WINDOWS\Microsoft.NET\Framework\[Framework Version]\CONFIG". It is similar in to the web.config file, but the web.config only works for the web application, in which it resides.

    Locate the <assemblies> tag (which should be under <configuration><system.web> <compilation>/<compilers>/<assemblies> ) Between the <assemblies> tag, you should enter something similar to:

    <add assembly="AssemblyFileName, Version=0.0.0.0, Culture=neutral, PublicKeyToken=5edf592a9c40680c" />

    To get the information that goes into the assembly attribute (version, culture, PublicKeyToken), you can run the gacutil /l command, which will return a list of all the assemblies in the GAC. You will have to look for the one you just added and copy the entire line (minus the Custom=null part at the end).
    For example the following command:

    gacutil -l RadAjax.Net2

    will return:

    RadAjax, Version=1.8.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5 Custom=null

    so the correct entry in the machine.config should be:

    <add assembly="RadAjax.Net2, Version=1.8.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

After that you should be able to use the control in all the application on the server without having to copy it to the "bin" folder of each web-application.

Remove from Global Assembly Cache

In order to remove Telerik RadAjax from GAC, please use the following command:

gacutil.exe -u radajax

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Multi Targeting in Visual Studio 2008

Telerik RadAjax v1.8 Send comments on this topic.
Multi Targeting in Visual Studio 2008
See Also
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Multi Targeting in Visual Studio 2008

Glossary Item Box

In Visual Studio 2008 you are able to build applications targeting multiple versions of the .NET Framework. Apart from ASP.NET 3.5, VS 2008 can open, edit and build ASP.NET 2.0 applications (applications with ASP.NET AJAX 1.0 as well). Visual Studio 2008 can also deploy these application on .NET 2.0 machines. You are able to easily build applications with RadControls targeting both ASP.NET 2.0 and ASP.NET 3.5.

See Also

External Link
See more information on how to use Multi Targeting in VS 2008

© 2002-2008 Telerik. All Rights Reserved.


Deploying Telerik RadAjax on Shared Hosting

Telerik RadAjax v1.8 Send comments on this topic.
Deploying Telerik RadAjax on Shared Hosting
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Deploying Telerik RadAjax on Shared Hosting

Glossary Item Box

All Telerik controls are server controls and have to be installed on the web server in order to function properly. This also means that you will need to create the respective virtual directories and give the proper permissions (ASPNET [IIS5], NEtwork Service [IIS6]) in order to use them on the shared hosting.

If you have already created the application on your development machine

1. Copy/upload the compiled application via FTP to the production server, i.e. on the shared hosting. The application should reside in the inetpub/wwwroot folder.

2. Create a virtual directory for the application folder. Before you do this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. If you do not have access to the Information Services console, ask your provider to set the application for you. If the provider does not offer instructions, then:

1. Locate the Internet Information Services console;

2. Navigate to the application folder;

3. Find the folder's Properties;

4. Create a virtual directory;

5. Remember the application name and click OK.

3. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (using IIS6 or IIS7, Windows Server 2003, Windows Vista/Longhorn) on the application folder. Again, before doing this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. Otherwise, contact your provider to set the permissions for you.

4. Run the project.

Notes.

As the proper operation of some Telerik RadEditor elements need some external files to be loaded, a RadControls folder instance is needed for the control to run.

There are two possible RadControls folder usages:

  • Copy the RadControls folder within your web-application:

    Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/). Specify its position via the RadControlsDir property of the control's declaration: <radE:RadEditor RadControlsDir="~/Resources/RadControls/" ...></radE:RadEditor>, where the "~" (tilde) symbol in the path represents your web-application root directory.
  • Copy the RadControls folder outside your web-application (this is the best scenario if you would like to share the RadControls folder across multiple web applications): Manually copy the RadControls to the new location using Windows Explorer. Create a virtual directory with a preferred name (e.g. RadControls) under each application's root which points physically to the same physical RadControls folder.

    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.

    If the Virtual subfolder alias is different than RadControls, specify the virtual folder position via the RadControlsDir property in the editor's declaration in your ASCX/ASPX file
    <radE:RadEditor RadControlsDir="~/MyRadControls/" ...></radE:RadEditor>

    More information on the topic is available in the following help article: The 'RadControls' folder.

If you plan to deploy the controls directly on the shared hosting

1. Log in your Client.NET account.

2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).

3. Locate the needed control, and click on it.

4. Click on the "Download" tab to download the Manual installation (ZIP) file.

5. On the server, create a "Telerik" folder in your "inetpub/wwwroot" folder on the server.

6. If you intend to use skins different from the default or if you plan to modify the JavaScript files, create a new folder named RadControls in the inetpub/wwwroot/Telerik folder.

7. Follow the instructions from the first case above.

© 2002-2008 Telerik. All Rights Reserved.


Embedded Resources

Telerik RadAjax v1.8 Send comments on this topic.
Embedded Resources
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Embedded Resources

Glossary Item Box

All Telerik RadControls for ASP.NET have their web resources embedded in the control assembly. Each control automatically fetches the required resources from the web. Embedded Resources are easier to manage because they require that you only maintain a single DLL for each RadControl when you upgrade versions/deploy applications. You no longer need to include the JavaScripts and the other related files with the RadControls folder in the root of your application. If you use external resources, you'll simply need to make sure you keep your DLLs and RadControls folders in sync when you upgrade and deploy.

Note that you still need the RadControls folder if you want to use a skin other than the Default.

You can control this functionality by setting the boolean property UseEmbeddedScripts.

When UseEmbeddedScripts is set to true (by default) web resources are streamed by the built-in web resource handler using a query string (like WebResource.axd?d=HTLSHE...). This scenario is suitable for easier deployment (no RadControls required).
The backside of using the embedded resources is that sometimes web resources are not cached (e.g. when your site is in debug mode <compilation debug="true" />). In addition the long query strings are adding bulk to the HTML you are sending to the client. Using external resources, i.e. the RadControls folder may nearly halve the page size due to the shorter resource paths. Your mileage may vary depending on the RadControls you are using.

If you set UseEmbeddedScripts to false, the control will use the necessary resources (files) from the RadControls folder. This is appropriate for example for cases when the web resource handler is disabled or when you have applied some modifications to the JavaScript or CSS files used by the control.

None of the functionality of the controls will change. Switching this property would only mean that you have to keep a local copy of the RadControls folder with the JS files in your application, since you are not going to use the embedded ones.
You cannot combine both methods for getting web resources, i.e. you cannot make the control take its scripts as embedded resources and skin file from RadControls.

© 2002-2008 Telerik. All Rights Reserved.


Trust level

Telerik RadAjax v1.8 Send comments on this topic.
Trust level
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Trust level

Glossary Item Box

This topic refers the case you are trying to publish a site to a shared environment. The site is using the <RadControlName> component, where only the <RadControlName>.dll file exists in the /bin directory of the application along with the scripts directory (/RadControls/<ControlName>/Scripts) on the root.

All RadControls supports Medium trust level under shared hosting environment.

Note that a requirement for the RadControl is to have the trust level set to Medium at minimum - otherwise you may receive server error like the following:

Could not load type Telerik.RadAjaxDesign.AjaxComponentEditor from assembly mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

To modify the trust level setting please follow the instructions below:

Locate the machine.config file placed in the \Microsoft.NET\Framework\v2.0.50727\CONFIG folder on your production server. Open it for editing and change the following line:

machine.config Copy Code
<trust level="Medium" originUrl=""/>

Further information about the different trust level options and their policies you can find in the MSDN:

http://msdn2.microsoft.com/en-us/library/tkscy493.aspx

http://msdn2.microsoft.com/en-us/library/wyts434y.aspx

© 2002-2008 Telerik. All Rights Reserved.


Troubleshooting deployment on the production server

Telerik RadAjax v1.8 Send comments on this topic.
Troubleshooting deployment on the production server
Installation and deployment > Deploying Telerik RadAjax into ASP.NET Applications > Troubleshooting deployment on the production server

Glossary Item Box

Since the Q2 2006 release our controls utilize webresources which is a new feature of ASP.NET 2.0. There are cases in which this may cause problems. For some reason requesting the webresource handler (webresource.axd) returns error number 404. This javascript files used by the control should be streamed by the web resource handler. As a result of the aforementioned error this does not happen and you may experience JavaScript errors on the client.

Here some tips how the problem can be solved:

First approach

  1. Open IIS management snap-in ( e.g. run inetmgr.exe)
  2. Right click your website and choose properties
  3. Go to the "Home Directory" tab and click the "Configuration" button
  4. A dialog should pop out and you would see the mappings listbox
  5. Find the entry for the ".axd" extension and edit it by clicking the "Edit" button
  6. In the new dialog uncheck the "Verify if file exist" checkbox - which I suspect is causing the problem.

Second approach

Alternatively, if the steps above don't solve the issue, you can try creating an empty WebResource.axd file in the site root folder.

Third approach

You can try setting UseEmbeddedScripts property to false. Thus the control will use the scripts from RadControls/Ajax/Scripts folder instead the embedded resource.

© 2002-2008 Telerik. All Rights Reserved.


What is DNN (DotNetNuke)

Telerik RadAjax v1.8 Send comments on this topic.
What is DNN (DotNetNuke)
DNN > What is DNN (DotNetNuke)

Glossary Item Box

DotNetNuke (DNN) is an open source Portal and Content Management Framework, based on Microsoft's .NET technology. DNN offers a robust, extensible and fully functional framework for the development of a broad range of commercial portal applications.

For more information on DNN, visit the official DotNetNuke web site here.

DotNetNuke is able to create the most complex content management systems entirely with its built-in features, yet also allows administrators to work effectively with add-ons, third party assemblies, and custom tools. DNN modules and skins are easy to find, purchase, or build. Site customization and functionality are limitless.

© 2002-2008 Telerik. All Rights Reserved.


DNN Concepts

Telerik RadAjax v1.8 Send comments on this topic.
DNN Concepts
DNN > DNN Concepts

Glossary Item Box

What is a skinobject?

Skins Objects are active elements which can be included in the static HTML markup of a skin file to produce a dynamic user interface. There are a number of default skin objects included with DotNetNuke for common portal functions such as login, status, and navigation.

Custom skin objects are packaged and installed using the same process as Custom Modules ( Private Assemblies ). All of the necessary skin object resource files are combined with a DotNetNuke manifest file (*.dnn ) and packaged into a ZIP file. Example of a manifest file:

<?xml version="1.0" encoding="utf-8" ?>
<dotnetnuke version="2.0" type="SkinObject">
<folders>
 <folder>
  <name>CompanyName - PageTitle</name>
  <modules>
   <module>
    <controls>
     <control>
      <key>PAGETITLE</key>
      <src>PageTitle.ascx</src>
      <type>SkinObject</type>
     </control>
    </controls>
   </module>
  </modules>
  <files>
   <file>
    <name>PageTitle.ascx</name>
      </file>
   <file>
       <name>YourCompanyName.PageTitle.dll</name>
      </file>
  </files>
  </folder>
</folders>
</dotnetnuke>

For ASCX skins then you will need to specify the @Register and actual user control tag in your skin file ( ie. <dnn:Login runat="server" id="dnnLogin" /> ). If you are creating HTML skins then you simply need to specify the token ( ie. [LOGIN] ).

Skin objects support the concept of named instances. For example, if you want to have two menu controls in your skin, you can specify [MENU:1] and [MENU:2] in your skin file. In most cases you will only be using a single instance of a skin object in your skin and in this case it is fine to use a singleton instance specification ( ie. [MENU] ).

Skin objects also contain attributes. Each skin object has its own set of supported attributes. If you are creating ASCX skins then you will need to specify the attribute directly in your skin file ( ie. <dnn:Login runat=”server” id=”dnnLogin” Text=”Signin” /> ). If you are creating HTML skins then you must include your attributes specifications in a separate file – this preserves the presentation of the HTML skin file for the designer. A skin package can contain a global attributes specification named “skin.xml” (or “container.xml” for containers) which applies to all skin files in the package. In addition, you can also override the global skin attribute specification with a skin specific attribute specification by providing a “skinfilename.xml” file. The skin uploader will merge the skin attributes with the HTML presentation file to create an ASCX skin file. The following XML fragment represents the structure of the attributes file:

<Objects>
 <Object>
  <Token>[LOGIN]</Token>
  <Settings>
   <Setting>
    <Name>Text</Name>
    <Value>Sign in</Value>
   </Setting>
  </Settings>
 </Object>
</Objects>

There is a one to one correspondence of skin object declarations in your skin file (i.e. [MENU]) with the attribute specification in the XML file. This is also true for named instances.

What is a skin?

Skins are customized and interchangeable sets of graphics which allow administrators to easily change the look of their websites, without having to reorganize their content. In "skinning" a site, administrators can completely change the look of their portal without the need to reorganize content – all at the click of a button.

NOTE:

Since skins are based on ASCX files which are essentially executable once they are added to an ASPX page, there is some risk that malicious script could be inserted into the skin files – putting the entire installation in danger. Be sure to download skins only from trusted locations.

How do skins work?

DNN uses placeholders to separate the skin objects from the static markup which designers can then include in their skin. Placeholders are simply [TOKEN] text, which uniquely identify a skin object. To mitigate the performance impact of replacing these placeholders at runtime, DNN features a simple skin upload mechanism which does the substitution of placeholders with the skin objects to produce a user control file (.ascx) which can then be rendered by the engine. This pre-processing occurs only once when the skin is uploaded.

Skins can be applied at a host (the whole DNN install), portal (only one site), or tab (single page) level. Skins can also be applied at the module level (in this case they are referred to as Containers). All skin files are organized under the Portals folder. Child assignments are able to override parent assignments (i.e. a skin applied at the tab level should override a skin applied at the portal level).

A skin or container package is comprised of multiple files which constitute a complete skin:

*.htm, *.html files – abstract skin definition files which will be processed by the skin uploader to create an *.ascx file

*.ascx files – skin definition user controls which are precompiled in the format required by the skin engine.

*.css files – styles sheets related to skins

*.gif, *.jpg, *.jpeg, *.png – supporting graphics files

*.* – any other resource files required for the skin (allowable file extensions are secured by the Host “File Upload Extensions” setting)

Skin definitions can be created using two different methods, HTML or ASCX ( user controls ). Basically the only difference between the two methods is the file extension of the skin definition file and the use of tokens versus actual user control tags.

Content panes are the containers for the content modules which are automatically injected at runtime. Content panes are simply HTML tags with some custom attributes specified specifically an ID and a RUNAT=”SERVER” attribute ( ie. <TD ID=”ContentPane” RUNAT=”SERVER”>).

What is a Container?

As mentioned earlier, containers are skin definitions which can be applied to content modules. A container is defined in exactly the same manner as a skin except for the fact that there are a different set of skin objects used in containers.

What is a module?

Simply, they are modular pieces of code which provide some form of specific functionality to the user, and are grouped together in units to form complete web pages. These modules can be easily added, edited, deleted, restored, moved around on a page, or transferred to other pages. DotNetNuke installation includes over 25 free modules. These are: Account LogIn, Announcements, Banners, Contacts, Discussion, Documents, Events List/Calendar, FAQs, Feedback, IFrame, Image, Links, News Feed (RSS), Search Input, Search Results, Service Directory, Survey, Text/HTML, User Accounts, User Defined Table, Users Online, Weblog Calendar, Weblog Recent List, Weblog Referrals List, Weblogs, and XML/XSL.

© 2002-2008 Telerik. All Rights Reserved.


RadControls for DNN

Telerik RadAjax v1.8 Send comments on this topic.
RadControls for DNN
DNN > RadControls for DNN

Glossary Item Box

The Telerik RadControls suite is the most innovative and comprehensive tool set for ASP.NET development, tailored for seamless integration with the DotNetNuke project. This integrated collection of controls allows professionals to build web-solutions with the UI richness and responsiveness of desktop applications. From the WYSIWYG editor, to navigation, the RadControls DotNetNuke Edition allows you to substantially enhance the interface and usability of your DotNetNuke projects.

Telerik offers the following products for DNN:

  • RadMenu - SkinObject and a sample skin
  • RadPanelbar - SkinObject and a sample skin
  • RadTabstrip - SkinObject and and a sample skin
  • RadTreeview - SkinObject, a sample skin, and a module
  • RadEditor - HtmlEditorProvider (which can be used instead of the default DNN editor)
  • RadCalendar - SkinObject(which can be used instead of the default DNN calendar) and a module
  • RadGrid - a sample module
  • RadRotator - a module
  • RadAjax - a sample module

A SkinObject can be used as a component of a DNN skin. A SkinObject by itself is useless unless you make it a part of a skin. For example, consider the sample RadMenu skin:

SkinObject and skin
Enlarge Click to enlarge

A module can be inserted in a pane to provide some functionality. For example consider the RadCalendar module:

RadCalendar module
Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


How to download RadAjax for DNN

Telerik RadAjax v1.8 Send comments on this topic.
How to download RadAjax for DNN
DNN > How to download RadAjax for DNN

Glossary Item Box

  1. Log in your Client.NET account.
  2. Go to Products -> RadControls for ASP.NET -> Download Trial
  3. Click on the individual products tab to expand the list of controls

    Enlarge Click to enlarge
  4. Click on a control to expand the list of available files for download

    Enlarge Click to enlarge
  5. Download the DNN module or skin

    Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


Globalization

Telerik RadAjax v1.8 Send comments on this topic.
Globalization

Glossary Item Box

When you use the AJAX controls on a page with non-english characters, after a callback has been fired those characters are being messed up. This happens because the XmlHttpRequest javascript object, which is responsible for the callback request, does not support encoding different than UTF-8. We highly recommend that you use UTF-8 encoding for your applications. This can be done by adding the following line into the application's web.config file:

web.config Copy Code
<globalization requestEncoding="UTF-8" fileEncoding="UTF-8" responseEncoding="UTF-8"/>

However if it is still messes up the page, you can use a function to convert the encoding from the client to the server. Set the encoding to the one you are going to use:

web.config Copy Code
<globalization requestEncoding="iso-8859-1" fileEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>

and use a custom function similar to the one below:

C# Copy Code
string ConvertText(string srcEncoding, string destEncoding, string textToConvert)
{
Encoding src = Encoding.GetEncoding(srcEncoding);
Encoding dest = Encoding.GetEncoding(destEncoding);
byte[] srcTextBytes = src.GetBytes(textToConvert);
byte[] destTextBytes = Encoding.Convert(dest, src, srcTextBytes);
char[] destChars = new char[src.GetCharCount(destTextBytes, 0, destTextBytes.Length)];
src.GetChars(destTextBytes, 0, destTextBytes.Length, destChars, 0);
return new string(destChars);
}
VB.NET Copy Code
Function ConvertText(ByVal srcEncoding As String, ByVal destEncoding As String, ByVal textToConvert As String) As String
Dim src As Encoding = Encoding.GetEncoding(srcEncoding)
Dim dest As Encoding = Encoding.GetEncoding(destEncoding)
Dim srcTextBytes As Byte() = src.GetBytes(textToConvert)
Dim destTextBytes As Byte() = Encoding.Convert(dest, src, srcTextBytes)
Dim destChars(src.GetCharCount(destTextBytes, 0, destTextBytes.Length)) As Char
src.GetChars(destTextBytes, 0, destTextBytes.Length, destChars, 0)
Return New String(destChars)
End Function 'ConvertText

For example converting from "iso-8859-1" (Swedish) to "UTF-8" will look like this:

lblAjax.Text = "AJAX returned: " + ConvertText("iso-8859-1", "utf-8", tbAjax.Text);

© 2002-2008 Telerik. All Rights Reserved.


AJAX Manager

Telerik RadAjax v1.8 Send comments on this topic.
AJAX Manager
See Also
AJAX Manager > AJAX Manager

Glossary Item Box

AJAX Manager is one of the two major controls of the Telerik RadAjax suite. The other one is AJAX Panel. AJAX Manager allows developers rapidly develop powerful and complex AJAX solutions.

The main features of AJAX Manager are:

  • You can ajaxify all controls that normally work with postbacks.
  • Defines visually and codeless (in Visual Studio design-time) which elements should initiate AJAX requests and which elements should be updated
  • No need to modify your application logic
  • Allows you to update a number of page elements at once regardless of their position on the page.
  • No need to write any JavaScript or invoke AJAX requests manually

Using a single AJAX Manager on the page you can create complex web applications like Microsoft Outlook ® Web Access portal.

The visual designer of AJAX Manager, accessible in VisualStudio, lets you set even the most complicated update scenarios such as:

A single control to update one or more controls with an AJAX request: | 1 updates 2 and 3 | Update schema
A second control to update other controls (or even controls from the previous scenario) with an AJAX request: | 3 updates 2 and 5
A control to update itself with an AJAX request: | 6 updates 6 (i.e. itself)
Call the AJAX Manager API from a control on the page and update control(s) on the page | Using the AJAX manager API, 2 is made to update 1 and 4

In order to use AJAX Manager, you need to drag it from the VisualStudio toolbox to your page.

Note that you can't have two AJAX Managers in a single NamingContainer. You can have one AJAX Manager on the page and another in an UserControl loaded on the page. You may also use one RadAjaxManager in a MasterPage and another one in a ContentPage of this MasterPage.

Setting the control relations in Property Builder

AJAX Manager comes with a visual builder for setting the relations between the AJAX request initiator and the controls that will be updated. You can start the property builder by choosing the Configure Ajax Manager command in the control's smart tag.

The property builder is pretty intuitive and simple to use. The tool has three panes:

  1. The left pane is a treeview with all controls on the page. Select a control that will initiate the callback request. Only the controls that have their check-boxes checked will initiate callbacks. Once you select the control in this pane, you need to choose the controls that will be updated. This can be done in the middle pane.
  2. The middle pane is another treeview with all controls on the page. Here you can select which controls will be updated after a callback request from the control checked and selected in the left pane.
    Please note that your selection in the middle pane can be applied only to one control from the left pane. Thus you can have different sets of controls that will be updated depending on the callback initiator control (from the left pane). After you set the controls that will be updated, you may select a Loading panel for each one of them. The Loading panel is set in the right pane.
  3. The right pane lets you specify the Loading panel that will be used for the controls selected in the middle pane. Each control that will be updated can have a separate Loading panel set. A default loading panel could be set as well through DefaultLoadingPanelID property of RadAjaxManager control. If it is used, there is no need to set the loading panel on each new AJAX setting - the default loading panel will be automatically applied everywhere.

    You can find the working example of the screenshot below here:
    The property builder

Setting the control relations in CodeBehind

You can set the relationship between ajaxified and updated controls on server-side as well. For this purpose you need to use the AddAjaxSetting method:

RadAjaxManager1.AjaxSettings.AddAjaxSetting(<ajaxified control>, <updated control>, <LoadingPanel> or null if none);

Client-side functions

You can make any external control to force AJAX Manager perform an AJAX request by calling this client-side function. When using this function the event target defaults to the RadAjaxManager instance.

You can construct the javascript function calls manually or alternatively use the server-side method GetAjaxEventReference and have Telerik RadAjax generate the necessary code for you.

<%=AjaxManager1.ClientID%>.AjaxRequest(arguments)

arguments The parameters, which the control had used when it raised the request

This function can be handled by the AjaxRequest event on the server.

The AjaxRequestWithTarget(eventTarget, eventArgument) function can be called to simulate a postback/AJAX request send by other control with the specified UniqueID and specified arguments.

__doPostBack(eventTarget, eventArgument) or <%=AjaxManager1.ClientID%>.AjaxRequestWithTarget(eventTarget, eventArgument)
eventTarget | The control which should raise postback event. Otherwise if your control is in a INamingContainer, you should use the control's UniqueID.
eventArgument | This is optional argument for the event

When you set a control as eventTarget it will raise an AJAX request and will update the controls that it was set to update in the property editor. This function can be handled by the correspondent event handler (i.e. Button_Click) on the server.

See Also

AJAX Panel
Panel vs. Manager

Server-side API
AjaxRequest Event

Client-side
Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


Toggle control visibility

Telerik RadAjax v1.8 Send comments on this topic.
Toggle control visibility
AJAX Manager > How-To > Toggle control visibility

Glossary Item Box

It is a common scenario for ASP.NET applications to show/hide controls as a result of user interaction or some event. You can have the same functionality with AJAX Manager as well but should have something in mind. RadAjaxManager relies on the HTML output of controls to be updated, that's why you need to put the control that should be updated in an always visible container like ASP Panel. Then set in the AJAX Manager the AJAX pairs where the AJAX initiator control should update the ASP Panel.

In the code-behind set the Visible property of the control that should be shown/hidden to true or false accordingly.

Below is a sample scenario where we toggle the visibility of an Image using a Button, CheckBox and RadioButtonList.

ASPX/ASCX Copy Code
<asp:CheckBox ID="CheckBox1" runat="server" AutoPostBack="True" Checked="True"
OnCheckedChanged="CheckBox1_CheckedChanged"
Text="Toggle Visibility" />
<asp:RadioButtonList ID="RadioButtonList1" runat="server" AutoPostBack="True"
OnSelectedIndexChanged= "RadioButtonList1_SelectedIndexChanged" />
<asp:ListItem Selected="True">Visible</asp:ListItem>
<asp:ListItem Value="NotVisible">Not Visible</asp:ListItem>
</asp:RadioButtonList>
<asp:Button ID="Button1" runat="server" OnClick="Button1_Click" Text="Toggle visibility" />
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server"">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="CheckBox1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="RadioButtonList1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
<asp:Panel ID="Panel1" runat="server" Height="95px" Width="244px">
<asp:Image ID="Image1" runat="server"
ImageUrl="http://www.telerik.com/images/Homepage/TelerikLogo.gif" Visible="False" />
</asp:Panel>

And in the code-behind:

C# Copy Code
protected void CheckBox1_CheckedChanged(object sender, EventArgs e)
{
Image1.Visible = CheckBox1.Checked;
}
protected void RadioButtonList1_SelectedIndexChanged(object sender, EventArgs e)
{
Image1.Visible = RadioButtonList1.SelectedValue.Equals("Visible");
}
protected void Button1_Click(object sender, EventArgs e)
{
Image1.Visible = !Image1.Visible;
}
VB.NET Copy Code
Protected Sub CheckBox1_CheckedChanged(ByVal sender As Object, ByVal e As EventArgs)
Image1.Visible = CheckBox1.Checked
End Sub
Protected Sub RadioButtonList1_SelectedIndexChanged(ByVal sender As Object, ByVal e As EventArgs)
Image1.Visible = RadioButtonList1.SelectedValue.Equals("Visible")
End Sub
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As EventArgs)
Image1.Visible = Not Image1.Visible
End Sub

Toggle visibility with AJAX Manager

Also see this KB article on the matter.

© 2002-2008 Telerik. All Rights Reserved.


Set AjaxSettings programmatically

Telerik RadAjax v1.8 Send comments on this topic.
Set AjaxSettings programmatically
AJAX Manager > How-To > Set AjaxSettings programmatically

Glossary Item Box

In some cases you need to add AJAX pairs dynamically (at runtime). You should always do this in a Page event handler, which is executed each time during the page lifecycle (Page_Load, Page_Init, Page_PreRender) so that the control could be ajaxified when the page is initially loaded.

Note that you need to assure that the controls that take part in the AJAX pair are available on the page!
The example below demonstrates how to ajaxify a Button dynamically to toggle the visibility of an Image:
ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" >
</rad:RadAjaxManager>
<asp:Panel ID="Panel1" runat="server" Height="95px">
<asp:Image ID="Image1" runat="server" ImageUrl="http://www.telerik.com/images/Homepage/TelerikLogo.gif" />
</asp:Panel>
And in the code-behind:
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
RadAjaxManager1.AjaxSettings.AddAjaxSetting(Button1, Panel1, null);
}
...
protected void Button1_Click(object sender, EventArgs e)
{
Image1.Visible = !Image1.Visible;
}

VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
RadAjaxManager1.AjaxSettings.AddAjaxSetting(Button1, Panel1, Nothing)
End Sub
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As EventArgs)
Image1.Visible = Not Image1.Visible
End Sub

© 2002-2008 Telerik. All Rights Reserved.


Ajaxify user controls

Telerik RadAjax v1.8 Send comments on this topic.
Ajaxify user controls
See Also
AJAX Manager > How-To > Ajaxify user controls

Glossary Item Box

In case you have an application that contains WebUserControls and want to ajaxify/update these controls with RadAjaxManager, you may do the following:

  1. Wrap the control in an ASP Panel:
    ASPX/ASCX Copy Code
    <asp:Panel id="Panel1" runat="server" height="200px" width="300px">
    <uc1:WebUserControl1 id="WebUserControl11" runat="server"></uc1:WebUserControl1>
    </    asp:Panel>

    And ajaxify/update the panel using AJAX Manager designer. This way the UserControl will be updated with AJAX request on any action of its containing controls.

  2. Put Ajax Manager in the user control and specify the necessary AjaxSettings there. However, this may not be feasible when you want to ajaxify multiple user controls - you will need an instance of RadAjaxManager in each control.
  3. Use single Ajax Manager instance in your main page.

    In this case you may add necessary AjaxSettings dynamically. You should access all the involved controls in both main page's and user controls code-behind.

In complex scenarios (many user controls interacting with each other) we highly recommend choosing the third option.

In case of WebUserControl containing a second RadAjaxManager, if you have ajaxified a panel for instance, which contains the user control, those controls inside it are already ajaxified. The second AJAX Manager will find them already ajaxified and won't do the expected updates.

Both managers will work correctly as long as they don't mess each other. Of course, one could also use a single RadAjaxManager for ajaxifying and updating controls both in the main page as well as in the user control.

A sample following this approach is posted from Telerik, attached in this forum thread

Here is a simple example demonstrating how this could be achieved:

ASPX - Main Page Copy Code
<form id="Form1" method="post" runat="server">
<uc1:WebUserControl1 id="WebUserControl1" runat="server"></uc1:WebUserControl1>
<rad:RadAjaxManager id="RadAjaxManager1" runat="server"></rad:RadAjaxManager>
</form>
ASPX - User Control Copy Code
<asp:Button id="Button1" Text="Button" runat="server"></asp:Button>
<asp:Label id="Label1" runat="server">Label</asp:Label>

And in the code-behind:

C# - Main Page Copy Code
protected void Page_Load(object sender, EventArgs e)
{
//Get the WebUserControl
UserControl MyControl = (UserControl)Page.FindControl("WebUserControl1");
//Get user control's button and label
Button MyButton = (Button)MyControl.FindControl("Button1");
Label MyLabel = (Label)MyControl.FindControl("Label1");
//Add the necessary AJAX setting programmatically
RadAjaxManager1.AjaxSettings.AddAjaxSetting(MyButton, MyLabel, null);
}
VB.NET - Main Page Copy Code
Protected Sub Page_Load(sender As Object, e As EventArgs)
'Get the WebUserControl
Dim MyControl As UserControl = CType(Page.FindControl("WebUserControl1"), UserControl)
'Get user control's button and label
Dim MyButton As Button = CType(MyControl.FindControl("Button1"), Button)
Dim MyLabel As Label = CType(MyControl.FindControl("Label1"), Label)
'Add the necessary AJAX setting programmatically
RadAjaxManager1.AjaxSettings.AddAjaxSetting(MyButton, MyLabel, Nothing)
End Sub 'Page_Load

C# - User Control Copy Code
protected void Button1_Click(object sender, System.EventArgs e)
{
Label1.Text = DateTime.Now.ToLongTimeString();
}
VB.NET - User Control Copy Code
Protected Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
Label1.Text = DateTime.Now
End Sub

See Also

Load user controls
Set AjaxSettings programmatically

© 2002-2008 Telerik. All Rights Reserved.


AJAX and MasterPage

Telerik RadAjax v1.8 Send comments on this topic.
AJAX and MasterPage
See Also
AJAX Manager > How-To > AJAX and MasterPage

Glossary Item Box

The controls in Telerik RadAjax suite can be used in various scenarios with MasterPage. However you should have in mind that you cannot have two AJAX Managers in a single INamingContainer, yet you can still put instances in different containers (content pages). In case of using AJAX Panel you have no limitations and you can wrap a whole content page or the master page content in a panel.

You can use RadAjaxManager instances in MasterPage and in any ContentPage. Unfortunately not all possible scenarios can be handled when using RadAjaxManager in content pages - in this case a control in the master page cannot be ajaxified. RadAjaxManager can handle only the cases when the controls to ajaxify are beneath in the control hierarchy.

A better approach that we highly recommend is to place the AJAX Manager in your MasterPage. Then the mager will be responsible for updating all the content in the content page as well as the MasterPage controls. Same is valid for AjaxLoadingPanel, which can be used for all defined AjaxSettings.

You cannot define the necessary AjaxSettings through RadAjaxManager designer because the designer cannot localize controls within ContentPlaceHolder. These should be added in the code-behind for the Master or Content page.

RadAjax controls should be accessed at ContentPage's code-behind using FindControl method of MasterPage object. However, in case you use a lot of ContentPages, you should write the same "finding" code in all the places. A better approach is to set the Manager (and the Loading Panel if used) as a property and access it directly. You may refer to the following forum thread from telerik asp-net-community where this approach is discussed (see Robert's code-snippet):

http://www.telerik.com/asp-net-community/forums/forum-thread.aspx?b311D=ebgbb

A live example with Telerik RadAjax and MasterPage can be found here:

http://www.telerik.com/demos/aspnet/Ajax/Examples/ASPNET20/MasterPage/DefaultCS.aspx

The MasterPage code-behind is available in your installation folder:

C:\Program Files\Telerik\RadControlsQ1 2007\NET2\Ajax\Examples\ASPNET20\MasterPage

or at

C:\Program Files\Telerik\Telerik RadAjax1.8\NET2\Ajax\Examples\ASPNET20\MasterPage

if you have installed Telerik RadAjax only.

See Also

MasterPages: ajaxify and update controls in master and content page
MasterPages: initiating requests from one ContentPlaceHolder and loading/updating controls in another

© 2002-2008 Telerik. All Rights Reserved.


MasterPages: ajaxify and update controls in master and content page

Telerik RadAjax v1.8 Send comments on this topic.
MasterPages: ajaxify and update controls in master and content page
AJAX Manager > How-To > MasterPages: ajaxify and update controls in master and content page

Glossary Item Box

With RadAjaxManager in your MasterPage you can ajax-enable and update every single control in your application. The example below shows how this could be achieved adding the necessary AJAX settings programmatically.

This sample application contains buttons in the the master and content page. The two buttons update controls in the master and content page as well. See the code below for details:

ASPX MasterPage Copy Code
<rad:radajaxmanager id="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="btnDecrease">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1"></rad:AjaxUpdatedControl>
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:radajaxmanager>
<asp:LinkButton ID="btnDecrease" runat="server" OnClick="btnDecrease_Click">Decrease</asp:LinkButton>
<asp:TextBox ID="TextBox1" runat="server">0</asp:TextBox>
<asp:contentplaceholder id="ContentPlaceHolder1" runat="server">
</asp:contentplaceholder>

And in the code-behind:

C# MasterPage Copy Code
protected void Page_Load(object sender, EventArgs e)
{
Label Label1 = (Label)ContentPlaceHolder1.FindControl("Label1");
RadAjaxManager1.AjaxSettings.AddAjaxSetting(btnDecrease, Label1, null);
}
protected void btnDecrease_Click(object sender, EventArgs e)
{
Label Label1 = (Label)ContentPlaceHolder1.FindControl("Label1");
Label1.Text = Int32.Parse(Label1.Text) - 1 + "";
TextBox1.Text = Int32.Parse(TextBox1.Text) - 1 + "";
}
VB.NET MasterPage Copy Code
Protected Sub Page_Load(sender As Object, e As EventArgs)
Dim Label1 As Label = CType(ContentPlaceHolder1.FindControl("Label1"), Label)
RadAjaxManager1.AjaxSettings.AddAjaxSetting(btnDecrease, Label1, Nothing)
End Sub 'Page_Load

Protected Sub btnDecrease_Click(sender As Object, e As EventArgs)
Dim Label1 As Label = CType(ContentPlaceHolder1.FindControl("Label1"), Label)
Label1.Text = Int32.Parse(Label1.Text) - 1 + ""
TextBox1.Text = Int32.Parse(TextBox1.Text) - 1 + ""
End Sub 'btnDecrease_Click

Content Page

ASXP Content Page Copy Code
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="Server">
<asp:Button ID="btnIncrease" runat="server" Text="Increase" OnClick="btnIncrease_Click" />
<asp:Label ID="Label1" runat="server" Text="0"></asp:Label>
</asp:Content>

And in the code-behind:

C# Content Page Copy Code
protected void Page_Load(object sender, EventArgs e)
{
RadAjaxManager AjaxManager = (RadAjaxManager)this.Master.FindControl("RadAjaxManager1");
AjaxManager.AjaxSettings.AddAjaxSetting(btnIncrease, Label1, null);
TextBox TextBox1 = (TextBox)this.Master.FindControl("TextBox1");
AjaxManager.AjaxSettings.AddAjaxSetting(btnIncrease, TextBox1, null);
}
protected void btnIncrease_Click(object sender, EventArgs e)
{
Label1.Text = Int32.Parse(Label1.Text) + 1 + "";
TextBox TextBox1 = (TextBox)this.Master.FindControl("TextBox1");
TextBox1.Text = Int32.Parse(TextBox1.Text) + 1 + "";
}
VB.NET Content Page Copy Code
Protected Sub Page_Load(sender As Object, e As EventArgs)
Dim AjaxManager As RadAjaxManager = CType(Me.Master.FindControl("RadAjaxManager1"), RadAjaxManager)
AjaxManager.AjaxSettings.AddAjaxSetting(btnIncrease, Label1, Nothing)
Dim TextBox1 As TextBox = CType(Me.Master.FindControl("TextBox1"), TextBox)
AjaxManager.AjaxSettings.AddAjaxSetting(btnIncrease, TextBox1, Nothing)
End Sub 'Page_Load

Protected Sub btnIncrease_Click(sender As Object, e As EventArgs)
Label1.Text = Int32.Parse(Label1.Text) + 1 + ""
Dim TextBox1 As TextBox = CType(Me.Master.FindControl("TextBox1"), TextBox)
TextBox1.Text = Int32.Parse(TextBox1.Text) + 1 + ""
End Sub 'btnIncrease_Click

© 2002-2008 Telerik. All Rights Reserved.


MasterPages: initiating requests from one ContentPlaceHolder and loading/updating controls in another

Telerik RadAjax v1.8 Send comments on this topic.
MasterPages: initiating requests from one ContentPlaceHolder and loading/updating controls in another
AJAX Manager > How-To > MasterPages: initiating requests from one ContentPlaceHolder and loading/updating controls in another

Glossary Item Box

RadAjaxManager could handle all the MasterPage and WebUserControls scenarios no matter the complexity of the application. To prove this, we show you how it can handle a scenario, where loading of WebUserControls is done in contents of MasterPage by RadAjaxManager.

An important point to notice in the following implementation, is the event bubbling approach. We use it because we load dynamically a user control from an action in another loaded user control. So the button click event is bubbled from the user control to the content page, where the first user control is loaded on each page load. Then we determine whether to perform loading of the second user control depending on the command from the button's bubbled event.

Here is the full working code containing a MasterPage, content page and two simple WebUserControls:

MasterPage ASPX:

ASPX MasterPage Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" />
<asp:ContentPlaceHolder ID="ContentPlaceHolder1" runat="server">
</asp:ContentPlaceHolder>
<asp:Panel ID="Panel1" runat="server">
<asp:ContentPlaceHolder ID="ContentPlaceHolder2" runat="server">
</asp:ContentPlaceHolder>
</asp:Panel>

This MasterPage has no code-behind.

Standard content page ASPX:

ASPX Content Page Copy Code
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="Server">
</asp:Content>
<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder2" runat="Server">
</asp:Content>

The key content page code-behind:

C# Content Page Copy Code
private object Content(string id)
{
return Page.Master.FindControl(id);
}
protected void Page_Load(object sender, System.EventArgs e)
{
//Load
Content("ContentPlaceHolder1").Controls.Add(LoadControl("~/Page1.ascx"));
Content("ContentPlaceHolder1").Controls(1).ID = "UserControl1";
//Get loaded user control's buttons
Button AjaxButtonLoad = (Button)Content("ContentPlaceHolder1").FindControl("UserControl1").FindControl("btnLoad");
Button AjaxButtonClear = (Button)Content("ContentPlaceHolder1").FindControl("UserControl1").FindControl("btnClear");
//Get the manager and the panel from the MasterPage
RadAjaxManager AjaxManager = (RadAjaxManager)Content("RadAjaxManager1");
Panel MyPanel = (Panel)Content("Panel1");
//Add the necessary AJAX settings - buttons update the panel in order to load the second user control there
AjaxManager.AjaxSettings.AddAjaxSetting(AjaxButtonLoad, MyPanel, null);
AjaxManager.AjaxSettings.AddAjaxSetting(AjaxButtonClear, MyPanel, null);
}
protected override bool OnBubbleEvent(object source, System.EventArgs args)
{
CommandEventArgs commandArgs = args as CommandEventArgs;
//determine whether to load the user control depending on bubbled button command
if (commandArgs != null)
{
if (commandArgs.CommandName == "Load")
{
Content("ContentPlaceHolder2").Controls.Add(LoadControl("~/Page2.ascx"));
Content("ContentPlaceHolder2").Controls(1).ID = "UserControl2";
}
else if (commandArgs.CommandName == "Clear") {
//do nothing. the control won't be loaded anyway
}
}
return base.OnBubbleEvent(source, args);
}
VB.NET Content Page Copy Code
Private Function Content(ByVal id As String)
Return Page.Master.FindControl(id)
End Function
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
'Load
Content("ContentPlaceHolder1").Controls.Add(LoadControl("~/Page1.ascx"))
Content("ContentPlaceHolder1").Controls(1).ID = "UserControl1"
'Get loaded user control's buttons
Dim AjaxButtonLoad As Button = CType(Content("ContentPlaceHolder1").FindControl("UserControl1").FindControl("btnLoad"), Button)
Dim AjaxButtonClear As Button = CType(Content("ContentPlaceHolder1").FindControl("UserControl1").FindControl("btnClear"), Button)
'Get the manager and the panel from the MasterPage
Dim AjaxManager As RadAjaxManager = CType(Content("RadAjaxManager1"), RadAjaxManager)
Dim MyPanel As Panel = CType(Content("Panel1"), Panel)
'Add the necessary AJAX settings - buttons update the panel in order to load the second user control there
AjaxManager.AjaxSettings.AddAjaxSetting(AjaxButtonLoad, MyPanel, Nothing)
AjaxManager.AjaxSettings.AddAjaxSetting(AjaxButtonClear, MyPanel, Nothing)
End Sub
Protected Overrides Function OnBubbleEvent(ByVal source As Object, ByVal args As System.EventArgs) As Boolean
Dim commandArgs As CommandEventArgs = TryCast(args, CommandEventArgs)
'determine whether to load the user control depending on bubbled button command
If commandArgs IsNot Nothing Then
If commandArgs.CommandName = "Load" Then
Content("ContentPlaceHolder2").Controls.Add(LoadControl("~/Page2.ascx"))
Content("ContentPlaceHolder2").Controls(1).ID = "UserControl2"
ElseIf commandArgs.CommandName = "Clear" Then
'do nothing. the control won't be loaded anyway
End If
End If
Return MyBase.OnBubbleEvent(source, args)
End Function
First WebUserControl's code, which is loaded on each page load:
ASPX WebUserControl Copy Code
<asp:Button ID="btnLoad" runat="server" Text="Load" CommandName="Load" />
<asp:Button ID="btnClear" runat="server" Text="Clear" CommandName="Clear" />

Code-behind:

C# WebUserControl Copy Code
public event EventHandler BtnClick;
protected void Button1_Click(object sender, System.EventArgs e)
{
if (BtnClick != null) {
BtnClick(sender, e);
}
}
VB.NET WebUserControl Copy Code
Public Event BtnClick As EventHandler
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnLoad.Click
RaiseEvent BtnClick(sender, e)
End Sub

And the second WebUserControl, which is loaded when the "Load" button in the first WebUserControl is clicked:

It just shows some text in the ASPX:

UserControl2

and has no code-behind.

© 2002-2008 Telerik. All Rights Reserved.


Using the ResolveUpdatedControls event

Telerik RadAjax v1.8 Send comments on this topic.
Using the ResolveUpdatedControls event
See Also
AJAX Manager > How-To > Using the ResolveUpdatedControls event

Glossary Item Box

In some scenarios you might need to initiate ajax request from control that will no longer be available when the updated html for the page comes in. For example this is the case when you load new user control on the place of the old one, and the initiator will be no longer available since the old user control is replaced. Then the ajax controls will throw an error:

The raising postback control with ID <The_ID_Of_The_Control> cannot be found.
Please handle the ResolveUpdatedControls event and set args.SuppressError to 'true' if the control has been unloaded.

For such cases you can handle the ResolveUpdatedControls event and update the needed controls without the need for the initiator control:

C# Copy Code
protected void RadAjaxManager1_ResolveUpdatedControls(object sender, Telerik.WebControls.UpdatedControlsEventArgs e)
{
e.UpdatedControls.Add( new AjaxUpdatedControl("control_id", "loading_panel_id"));
e.SuppressError = true;
}
VB.NET Copy Code
Protected Sub RadAjaxManager1_ResolveUpdatedControls(ByVal sender As Object, ByVal e As Telerik.WebControls.UpdatedControlsEventArgs)
e.UpdatedControls.Add(New AjaxUpdatedControl("control_id", "loading_panel_id"))
e.SuppressError = True
End Sub

where the control_id is the control that will be updated and loading_panel_id is the corresponding LoadingPanel. The e.SuppressError is needed in order to suppress the error message above thrown by the Ajax control.

You cannot specify loading panels for the controls that you add to the UpdatedControls collection here. In order to display the loading panels the RadAjaxManager needs to know which are the updated controls prior to sending the Ajax request to the server (so it can apply the loading panels while the request is in progress). However, when handling the ResolveUpdatedControls server-side event you are modifying the UpdatedControls collection on the server-side when the Ajax request is already in progress.

In such scenarios we would suggest you to use sticky loading panels -- you would not get individual visual tip for each updated control but you would still get an indication that the page content is updated.

More useful examples could be found attached in this forum thread or in the following Telerik RadAjax Code Library projects and KB articles.

See Also

KB articles
Loading user controls dynamically on TabClick and postback from a user control
Updating different control with AJAX depending on clicked ToolbarButton

Code Library
Loading user controls dynamically and use ResolveUpdatedControls event
Use ResolveUpdatedControls event to optimize HTTP traffic

© 2002-2008 Telerik. All Rights Reserved.


Ajaxify particular templated GridView buttons

Telerik RadAjax v1.8 Send comments on this topic.
Ajaxify particular templated GridView buttons
See Also
AJAX Manager > How-To > Ajaxify particular templated GridView buttons

Glossary Item Box

Sometimes you may want to ajaxify particular controls (residing in template column of GridView control) in order to update other controls (for example outside of the GridView) without postback. The most straight-forward solution is to ajaxify the whole GridView. Here is a sample code:

ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="GridView1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="GridView1" />
<rad:AjaxUpdatedControl ControlID="TextBox" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

However, you may need another column to make regular postbacks or even the rest of the actions to trigger standard postback requests.

This is when the RadAjaxManager comes into place. The manager settings can be added programmatically specifying each particular control which you want to ajaxify and/or update. The essential part is to attach the appropriate event(s) in which to apply the ajax settings. For the GridView in this situation the proper place is the Row_PreRender event handler.

The GridView in the sample contains one template and one button column. The ImageButtons in the template column are ajaxified by the ajax manager and the buttons in the ButtonField start regular postbacks. Both the image and the push buttons update text box outside of the GridView.

ASPX:

ASPX/ASCX Copy Code
<asp:TextBox ID="TextBox1" runat="server" Width="400px" Text="not updated"></asp:TextBox>
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
</rad:RadAjaxManager>
<asp:GridView ID="GridView1" DataSourceID="AccessDataSource1" AllowPaging="true" runat="server">
<Columns>
<asp:TemplateField HeaderText="TemplateField">
<ItemTemplate>
<asp:ImageButton ID="ImageButton1" CommandName="MyCommand" CommandArgument='<%# Eval("CustomerID") %>'
ImageUrl= "arrow.gif" runat="server" />
</ItemTemplate>
</asp:TemplateField>
<asp:ButtonField ButtonType="Button" HeaderText="ButtonField" CommandName="Test" Text="Button" ImageUrl="arrow.gif" />
</Columns>
</asp:GridView>
<asp:AccessDataSource ID="AccessDataSource1" DataFile="~/Grid/Data/Access/Nwind.mdb" runat="server"
SelectCommand= "SELECT * FROM [Customers]"></asp:AccessDataSource>

And in the code-behind:

C# Copy Code
protected void GridView1_RowCreated(object sender, System.Web.UI.WebControls.GridViewRowEventArgs e)
{
if (e.Row.RowType == DataControlRowType.DataRow) {
e.Row.PreRender += new System.EventHandler(Row_PreRender);
}
}
protected void GridView1_RowCommand(object sender, System.Web.UI.WebControls.GridViewCommandEventArgs e)
{
TextBox1.Text = string.Format("CommandName:{0}, CommandArgument:{1}", e.CommandName, e.CommandArgument);
}
protected void Row_PreRender(object sender, System.EventArgs e)
{
ImageButton ImageButton1 = ((ImageButton)(((Control)(sender)).FindControl( "ImageButton1")));
RadAjaxManager1.AjaxSettings.AddAjaxSetting(ImageButton1, TextBox1, null);
}
VB.NET Copy Code
Protected Sub GridView1_RowCreated(ByVal sender As Object, ByVal e As System.Web.UI.WebControls.GridViewRowEventArgs) Handles GridView1.RowCreated
If e.Row.RowType = DataControlRowType.DataRow Then
AddHandler e.Row.PreRender, AddressOf Row_PreRender
End If
End Sub
Protected Sub GridView1_RowCommand(ByVal sender As Object, ByVal e As System.Web.UI.WebControls.GridViewCommandEventArgs) Handles GridView1.RowCommand
TextBox1.Text = String.Format("CommandName:{0}, CommandArgument:{1}", e.CommandName, e.CommandArgument)
End Sub
Protected Sub Row_PreRender(ByVal sender As Object, ByVal e As System.EventArgs)
Dim ImageButton1 As ImageButton = CType(CType(sender, Control).FindControl("ImageButton1"), ImageButton)
RadAjaxManager1.AjaxSettings.AddAjaxSetting(ImageButton1, TextBox1, Nothing)
End Sub

See Also

KB articles
Ajaxifying particular controls in Telerik RadGrid template column with Ajax Manager

© 2002-2008 Telerik. All Rights Reserved.


Update in composite control

Telerik RadAjax v1.8 Send comments on this topic.
Update in composite control
See Also
AJAX Manager > How-To > Update in composite control

Glossary Item Box

This topic demonstrates a possible scenario of AJAX Manager updates controls from a composite control. It is important to set IDs of instantiated controls as well as adding them into controls collection. A necessary AJAX setting could be added at CreateChildControls method, however this must be done after controls are added into corresponding controls collection.

The example below includes a single AJAX Manager control on the page. Here is the code-behind:

C# Copy Code
public partial class Default : System.Web.UI.Page
{
TestComposite Tst1;
protected void Page_Load(object sender, EventArgs e)
{
Tst1 = new TestComposite(RadAjaxManager1, "1");
//set an ID of instantiated control!
Tst1.ID = "tst1";
this.form1.Controls.Add(Tst1);
}
protected void RadAjaxManager1_AjaxRequest(object sender, Telerik.WebControls.AjaxRequestEventArgs e)
{
//Update control from the composite on AJAX request
Tst1.controLbl.Text = Tst1.controTB.Text;
}
}
VB.NET Copy Code
Public Partial Class [Default]
Inherits System.Web.UI.Page
Private Tst1 As TestComposite
Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
Tst1 = New TestComposite(RadAjaxManager1, "1")
'set an ID of instantiated control!
Tst1.ID = "tst1"
Me.form1.Controls.Add(Tst1)
End Sub
Protected Sub RadAjaxManager1_AjaxRequest(ByVal sender As Object, ByVal e As Telerik.WebControls.AjaxRequestEventArgs)
'Update control from the composite on AJAX request
Tst1.controLbl.Text = Tst1.controTB.Text
End Sub
End Class

And the composite control class:

C# Copy Code
public class TestComposite : CompositeControl
{
private Telerik.WebControls.RadAjaxManager m_radAm;
private string m_UniqueId;
public TextBox MyTxt;
public Label MyLbl;
public TestComposite(Telerik.WebControls.RadAjaxManager radAm, string UniqueId)
{
m_radAm = radAm;
m_UniqueId = UniqueId;
}
protected override void RecreateChildControls()
{
EnsureChildControls();
}
protected override void CreateChildControls()
{
MyTxt = new TextBox();
MyLbl = new Label();
//set IDs of instantiated controls!
MyLbl.ID = "Lbl_" + m_UniqueId;
MyTxt.ID = "Txt_" + m_UniqueId;
MyLbl.Text = "LabelText";
//add the controls into controls collection!
this.Controls.Add(MyTxt);
this.Controls.Add(MyLbl);
//Manually add AJAX request triggered on onBlur client event of the text box
MyTxt.Attributes.Add("onBlur", m_radAm.GetAjaxEventReference(MyTxt.ClientID));
//Add the ajax setting - this should be done after controls are added into controls collection
m_radAm.AjaxSettings.AddAjaxSetting(m_radAm, MyLbl);
}
public TextBox controTB
{
get {
return MyTxt;
}
}
public Label controLbl
{
get
{
return MyLbl;
}
}
protected override void Render(HtmlTextWriter output)
{
MyTxt.RenderControl(output);
MyLbl.RenderControl(output);
}
}
VB.NET Copy Code
Public Class TestComposite
Inherits CompositeControl
Private m_radAm As Telerik.WebControls.RadAjaxManager
Private m_UniqueId As String
Public MyTxt As TextBox
Public MyLbl As Label
Public Sub New(ByVal radAm As Telerik.WebControls.RadAjaxManager, ByVal UniqueId As String)
m_radAm = radAm
m_UniqueId = UniqueId
End Sub
Protected Overloads Overrides Sub RecreateChildControls()
EnsureChildControls()
End Sub
Protected Overloads Overrides Sub CreateChildControls()
MyTxt = New TextBox()
MyLbl = New Label()
'set IDs of instantiated controls!
MyLbl.ID = "Lbl_" + m_UniqueId
MyTxt.ID = "Txt_" + m_UniqueId
MyLbl.Text = "LabelText"
'add the controls into controls collection!
Me.Controls.Add(MyTxt)
Me.Controls.Add(MyLbl)
'Manually add AJAX request triggered on onBlur client event of the text box
MyTxt.Attributes.Add("onBlur", m_radAm.GetAjaxEventReference(MyTxt.ClientID))
'Add the ajax setting - this should be done after controls are added into controls collection
m_radAm.AjaxSettings.AddAjaxSetting(m_radAm, MyLbl)
End Sub
Public ReadOnly Property controTB() As TextBox
Get
Return MyTxt
End Get
End Property
Public ReadOnly Property controLbl() As Label
Get
Return MyLbl
End Get
End Property
Protected Overloads Overrides Sub Render(ByVal output As HtmlTextWriter)
MyTxt.RenderControl(output)
MyLbl.RenderControl(output)
End Sub
End Class

See Also

How-To
Manually add AJAX request to client event of control

© 2002-2008 Telerik. All Rights Reserved.


AJAX Manager Designer does not locate all controls

Telerik RadAjax v1.8 Send comments on this topic.
AJAX Manager Designer does not locate all controls
AJAX Manager > Troubleshooting > AJAX Manager Designer does not locate all controls

Glossary Item Box

RadAjaxManager designer is not able to locate controls on the page in some specific scenarios, but still those controls can be ajaxified and updated by AJAX Manager:

1) Controls are placed in cells of ASP:Table.

Those table cells need to have an ID set as well as runat="server" included and the designer will locate all the controls within the table. Here is an example:

ASPX/ASCX Copy Code
<asp:Table ID="Table1" runat="server">
<asp:TableRow runat="server" ID="rol_1">
<asp:TableCell runat="server" ID="cell_11">
<asp:Panel ID="Panel1" runat="server">
<asp:Button ID="Button1" runat="server" Text="Button" />
<asp:TextBox ID="TextBox1" runat="server"></asp:TextBox>
</asp:Panel>
</asp:TableCell>
<asp:TableCell runat="server" ID="cell_12"></asp:TableCell>
<asp:TableCell runat="server" ID="cell_13"></asp:TableCell>
</asp:TableRow>
<asp:TableRow runat="server" ID="row_2">
<asp:TableCell runat="server" ID="cell_21">
<div runat="server" id="div1">
<asp:CheckBox ID="CheckBox1" runat="server" />
</div>
</asp:TableCell>
<asp:TableCell runat="server" ID="cell_22"></asp:TableCell>
<asp:TableCell runat="server" ID="cell_23"></asp:TableCell>
</asp:TableRow>
</asp:Table>
Then the button, check box and text box could be located by designer and the following AJAX settings could be added:
ASPX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="CheckBox1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

2) Control is nested in a template of a composite control.

Those templates may "hide" wrapped controls from the AJAX Manager Designer. We plan to remove this limitation, but meanwhile we recommend adding AJAX settings programmatically in such scenarios, which approach together with FindControl method usage, provides AJAX Manager with the ability to ajaxify and update controls at all "levels" of the application. For example if the control you want to update is located within RadDockableObject (see RadDock web control), it could be found at runtime using RadDockableObject.FindControl("<controlID>") and then set it as updated control.

See the AJAX RadDock online demo, where this approach is followed.

3) Controls are placed in a WebUserControl.

The above (from 2)) is valid here as well. You could use the same approach and add AJAX settings dynamically.

See also how to ajaxify user controls.

4) Controls are placed in a different content of MasterPage scenario.

Again the same approach could be followed as the controls are hidden from the designer when placed in content place holder.

See also how to deal with AJAX in MasterPage scenario .

© 2002-2008 Telerik. All Rights Reserved.


Ajaxifying controls wrapped in RadAjaxPanel and added to AJAX Manager settings

Telerik RadAjax v1.8 Send comments on this topic.
Ajaxifying controls wrapped in RadAjaxPanel and added to AJAX Manager settings
AJAX Manager > Troubleshooting > Ajaxifying controls wrapped in RadAjaxPanel and added to AJAX Manager settings

Glossary Item Box

If one and the same control is placed in RadAjaxPanel as well as included in RadAjaxManager settings as ajaxified control (i.e. it is ajaxified by both the panel and manager), the corresponding manager's setting will not work. In this case the AJAX Panel ajaxifies that control instead of the manager. RadAjaxPanel is designed to update only its content, therefore you can not use the manager to update other controls outside of the panel from control ajaxified by the manager and inside the RadAjaxPanel.

The code snippet below will not work as expected (the button won't update the label):

ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="RadAjaxPanel" />
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
<rad:RadAjaxPanel ID="RadAjaxPanel" runat="server">
<asp:Button ID="Button1" runat="server" Text="Update Button" />
<asp:TextBox ID="TextBox1" runat="server" Text="Update me" ></asp:TextBox>
</rad:RadAjaxPanel>
<asp:Label ID="Label1" runat="server">Me too</asp:Label>

The RadAjaxPanel functionality can be simulated completely by the manager - simply replace the AJAX Panel with an ASP:Panel. The modified version of the above code will perform the same task as if you use RadAjaxPanel instead of manager:

ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Panel1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

Moreover, you are free from the limitation to update controls only within the boundaries of the ajax panel.

Here is the entire solution of the problematic settings defined in the begging of this article:

ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" />
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
<asp:Panel ID="Panel" runat="server">
<asp:Button ID="Button1" runat="server" Text="Update Button" />
<asp:TextBox ID="TextBox1" runat="server" Text="Update me" ></asp:TextBox>
</asp:Panel>
<asp:Label ID="Label1" runat="server">Me too</asp:Label>

Keep in mind that you can switch the ajaxified "Button1" with "Panel1" if necessary. However, the refresh of the controls embed in the panel can take a bit longer time in comparison with hitting an ajaxified button.

© 2002-2008 Telerik. All Rights Reserved.


Error: Cannot update control with ID:

Telerik RadAjax v1.8 Send comments on this topic.
Error: Cannot update control with ID: . The control does not exist.
AJAX Manager > Troubleshooting > Error: Cannot update control with ID: . The control does not exist.

Glossary Item Box

This error is thrown by RadAjaxManager when a control is added as AjaxUpdatedControl, but is not rendered on the page (control, which is initially hidden) or does not render any HTML output. In this case, RadAjaxManager cannot locate it thus throwing the error.

Put this control in an always visible container control (like ASP:Panel, which Visible property is not false) and set the container as updated in AJAX Settings instead. Note also that initially not bound controls (such as Grid) may not render any output, so that the error will appear in this case as well.

The error could also be thrown when a setting is added without the use of RadAjaxManager Designer and points to control in different naming container. In case when controls cannot be added in AJAX Manager settings through the designer, you should add them programmatically. The topic, showing how controls can be referred in MasterPage and different content place holder, could be very useful for complicated scenarios:

MasterPages: ajaxify and update controls in master and content page

© 2002-2008 Telerik. All Rights Reserved.


Error: Object does not support this property or method

Telerik RadAjax v1.8 Send comments on this topic.
Error: Object does not support this property or method
AJAX Manager > Troubleshooting > Error: Object does not support this property or method

Glossary Item Box

In the present version of Telerik RadAjax controls, such error is thrown in a very specific case when AJAX Manager has associated "RadAjaxManager" as ID. After thorough investigation we found that fixing this very rare issue will require too much efforts and change of an internal Telerik RadAjax mechanism so that we will kindly ask our customers to simply use different ID than the problematic one.

© 2002-2008 Telerik. All Rights Reserved.


AJAX Panel

Telerik RadAjax v1.8 Send comments on this topic.
AJAX Panel
See Also
AJAX Panel > AJAX Panel

Glossary Item Box

AJAX Panel is one of the two major controls of the Telerik RadAjax suite. The other one is AJAX Manager. The AJAX Panel control provides the easiest way to AJAX-enable ASP.NET web control(s). To do this you simply need to place the controls that you want ajaxified into AJAX Panel and Telerik RadAjax takes care of the rest. Best of all this happens transparently to the framework and the controls that are being ajaxified.

The main features of AJAX Panel are:

  • Ajaxifies all controls inside that normally work with postbacks.
  • Defines visually and codeless (in Visual Studio design-time) which elements should be updated via AJAX requests. All elements wrapped in the panel will be updated via AJAX
  • No need to modify your application logic
  • Allows you to update a number of page elements at once
  • No need to write any JavaScript or invoke AJAX requests manually

AJAX Panel Usage

All you need to do is to drag the control you want to make callbacks into the AJAX Panel. Then it will start performing callbacks instead of postbacks. On the image below you see a typical usage scenario. A standard ASP.NET control (calendar in this case) is placed in an AJAX Panel. On the web form there is also a Loading Panel that will be shown in the place of the AJAX Panel during the AJAX request.

AJAX Panel (Design-time)

Note that the whole AJAX Panel (with ALL controls inside) is updated when one of the controls makes an AJAX request. Thus if you put the whole page into a AJAX Panel, this may cause reduced performance, as all controls within the panel will be updated, not just the AJAX initiator.
Placing the whole page into a AJAX Panel is usable when you have relatively small number of controls on the page.

Out-of-Panel Update

There are cases when you may want to update the information inside the panel by triggering a callback externally from other control on the page. You need to make a call to the <%RadAjaxPanel1.ClientID%>.AjaxRequest() method (passing the necessary information as parameters to it) and then override the RaisePostBackEvent method to apply the changes. Here is a sample implementation, which changes the background color of the panel:

ASPX/ASCX Copy Code
<rad:RadAjaxPanel id="RadAjaxPanel1" runat="server"
EnableAJAX= "True">
</rad:RadAjaxPanel>
<br />
<input type=button value="Change color" onclick='<%=RadAjaxPanel1.ClientID%>.AjaxRequestWithTarget( "<%= RadAjaxPanel1.UniqueID %>", "ChangeColor")' />

And in the code-behind:

C# Copy Code
protected override void RaisePostBackEvent(IPostBackEventHandler source, String eventArgument)
{
base.RaisePostBackEvent(source, eventArgument);
switch(eventArgument)
{
case "ChangeColor":
RadAjaxPanel1.BackColor = Color.Maroon;
break;
}
}
VB.NET Copy Code
Protected Overrides Sub RaisePostBackEvent(ByVal source As IPostBackEventHandler, ByVal eventArgument As String)
MyBase.RaisePostBackEvent(source, eventArgument)
Select Case eventArgument
Case "ChangeColor"
RadAjaxPanel1.BackColor = Color.Maroon
End Select
End Sub

Exclude controls from ajaxifying

As the AjaxPanel ajaxifies all controls unconditionally, if you want to exclude a control you can use the following approach: implement the realPostBack function into your ASPX/ASCX file and add a custom OnClick attribute to the control (button in this case).

javascript Copy Code
<script type="text/javascript">
function realPostBack(eventTarget, eventArgument)
{
__doPostBack(eventTarget, eventArgument);
}
</script>
ASPX/ASCX Copy Code
<rad:RadAjaxPanel ID="RadAjaxPanel1" runat="server">
<asp:Button ID="Button1" runat="server" OnClick="Button1_Click" Text="Button" /></rad:RadAjaxPanel>

And in the code-behind, in Page_Load:

C# Copy Code
if (!Page.IsPostBack)
{
Button1.Attributes.Add( "onclick", string.Format("realPostBack(\"{0}\", \"\"); return false;", Button1.UniqueID));
}
VB.NET Copy Code
If Not Page.IsPostBack Then
Button1.Attributes.Add("onclick", String.Format("realPostBack(""{0}"", """"); return false;", Button1.UniqueID))
End If

If you do not have a control that registers the __doPostBack function on the page you can add the following line in the Page_Load as well:

C# Copy Code
this.Page.ClientScript.GetPostBackEventReference(this, "");
VB.NET Copy Code
Me.Page.ClientScript.GetPostBackEventReference(Me, "")

AjaxRequestWithTarget() reference

You can make any external control to force AJAX Panel perform an AJAX request by calling this client-side function. When using this function the event target defaults to the RadAjaxPanel instance.

You can construct the javascript function calls manually or alternatively use the server-side method GetAjaxEventReference and have Telerik RadAjax generate the necessary code for you.

__doPostBack(eventTarget, eventArgument) or <%=RadAjaxPanel1.ClientID%>.AjaxRequestWithTarget(eventTarget, eventArgument)
eventTarget | The control which should raise postback event. You should use the control's UniqueID.
eventArgument | This is optional argument for the event

AjaxRequest() reference:

<%=RadAjaxPanel1.ClientID%>.AjaxRequest(arguments)

arguments The parameters, which the control had used when it raised the request

When either of these functions is is called on the client it can be handled in the AjaxRequest event handler on the server.

See Also

AJAX Manager
Panel vs. Manager

Server-side API
AjaxRequest Event

Client-side
Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


Achieve interaction between AJAX Panels

Telerik RadAjax v1.8 Send comments on this topic.
Achieve interaction between AJAX Panels
AJAX Panel > How-To > Achieve interaction between AJAX Panels

Glossary Item Box

First of all, note that RadAjaxPanel control is designed to update only its content controls so it is always recommended using RadAjaxManager when an update to external controls is needed.

However, you can achieve interaction between panels without the use of RadAjaxManager. The example below uses ResponseScripts property, together with client-side AjaxRequest function. Note the use of Page_PreRender event as well as the property persisted in ViewState.

ASPX Copy Code
<h3>Panel1</h3>
<rad:RadAjaxPanel ID="RadAjaxPanel1" runat="server">
<asp:Button ID="btnIncrease" OnClick="btnIncrease_Click" Text="Increase" runat="server">
</asp:Button>
<asp:Label ID="Label1" runat="server">0</asp:Label>
<asp:TextBox ID="TextBox1" Text="0" runat="server"></asp:TextBox>
</rad:RadAjaxPanel>
<h3>Panel2</h3>
<rad:RadAjaxPanel ID="RadAjaxPanel2" runat="server">
<asp:Button ID="btnDecrease" OnClick="btnDecrease_Click" Text="Decrease" runat="server">
</asp:Button>
<asp:Label ID="Label2" runat="server">0</asp:Label>
<asp:TextBox ID="TextBox2" Text="0" runat="server"></asp:TextBox>
</rad:RadAjaxPanel>
And in the code-behind (C#):
C# Copy Code
protected void Page_PreRender(object sender, EventArgs e)
{
if (RadAjaxPanel1.IsAjaxRequest || RadAjaxPanel2.IsAjaxRequest)
{
TextBox1.Text = Label1.Text = TextBox2.Text = Label2.Text = Count.ToString();
}
}
public int Count
{
get
{
return this.ViewState["Count"] == null ? 0 : (int)this.ViewState["Count"];
}
set
{
this.ViewState["Count"] = value;
}
}
protected void btnIncrease_Click(object sender, System.EventArgs e)
{
Count++;
RadAjaxPanel1.ResponseScripts.Add(String.Format("window['{0}'].AjaxRequest();", RadAjaxPanel2.ClientID));
}
protected void btnDecrease_Click(object sender, System.EventArgs e)
{
Count--;
RadAjaxPanel2.ResponseScripts.Add(String.Format("window['{0}'].AjaxRequest();", RadAjaxPanel1.ClientID));
}

And VB.NET:

VB.NET Copy Code
Protected Sub Page_PreRender(ByVal sender As Object, ByVal e As EventArgs) Handles Me.PreRender
If RadAjaxPanel1.IsAjaxRequest Or RadAjaxPanel2.IsAjaxRequest Then
Dim countValue As String = Count.ToString()
TextBox1.Text = countValue
Label1.Text = countValue
TextBox2.Text = countValue
Label2.Text = countValue
End If
End Sub 'Page_PreRender

Public Property Count() As Integer
Get
If Me.ViewState("Count") Is Nothing Then
Return 0
Else
Return CInt(Me.ViewState("Count"))
End If
End Get
Set(ByVal value As Integer)
Me.ViewState("Count") = value
End Set
End Property

Protected Sub btnIncrease_Click(ByVal sender As Object, ByVal e As System.EventArgs)
Count += 1
RadAjaxPanel1.ResponseScripts.Add(String.Format("window['{0}'].AjaxRequest();", RadAjaxPanel2.ClientID))
End Sub 'btnIncrease_Click

Protected Sub btnDecrease_Click(ByVal sender As Object, ByVal e As System.EventArgs)
Count -= 1
RadAjaxPanel2.ResponseScripts.Add(String.Format("window['{0}'].AjaxRequest();", RadAjaxPanel1.ClientID))
End Sub 'btnDecrease_Click

© 2002-2008 Telerik. All Rights Reserved.


Scroll to top after AJAX

Telerik RadAjax v1.8 Send comments on this topic.
Scroll to top after AJAX
AJAX Panel > How-To > Scroll to top after AJAX

Glossary Item Box

By default RadAjaxPanel maintains the focus of ajaxified control when the response ends. For instance, if you have a button at the bottom of the page embedded in an AJAX Panel, the button will still be focused when the update finishes.

However, with a longer page you may need to scroll the page to the top after AJAX (where the updated controls might be placed).

The following JavaScript function does the trick:

JavaScript Copy Code
<script type="text/javascript">
function scrollTop()
{
window.document.body.scrollTop = 0;
window.document.documentElement.scrollTop = 0;
}
</script>
This function has to be added to the ResponseScripts collection of the RadAjaxPanel control in order to be executed after an AJAX call. Here is a sample code-snippet:
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
RadAjaxPanel1.ResponseScripts.Add("scrollTop();");
}

private void cmd1_Click(object sender, System.EventArgs e)
{
lbl1.Text = System.DateTime.Now.ToString;
//set no active element
RadAjaxPanel1.ActiveElementID = null;
}
VB.NET Copy Code
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
RadAjaxPanel1.ResponseScripts.Add("scrollTop();")
End Sub

Private Sub cmd1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles cmd1.Click
lbl1.Text = Date.Now.ToString
//set no active element
RadAjaxPanel1.ActiveElementID = Nothing
End Sub

The RadAjaxManager control does not maintain focus on active controls after an asynchronous request. If you need to focus a specific control, manager's FocusControl method can be used. Below is a link to an online demo demonstrating this aspect of the ajax manager server side API:

http://www.telerik.com/demos/aspnet/Ajax/Examples/Common/SettingFocus/DefaultCS.aspx

© 2002-2008 Telerik. All Rights Reserved.


Panel vs. Manager

Telerik RadAjax v1.8 Send comments on this topic.
Panel vs. Manager
See Also

Glossary Item Box

When should I use the Panel and when the Manager?

Both RadAjaxManager and RadAjaxPanel are controls that ajaxify other controls. However there are some differences and specifics with these two controls that make them suitable or not for a specific scenario.

Having these two controls in hand gives you a great flexibility in AJAX-enabling web pages.

When to use RadAjaxPanel

RadAjaxPanel is a lightweight control that lets you update a part of your web page with AJAX while keeping the rest of the page working with postbacks.

AJAX Panel is more suitable for cases when you need to update a group of neighboring controls at once. You have to wrap the controls that should be ajaxified in the AJAX Panel. Only controls that are inside the Panel will be updated via AJAX. You cannot set the Panel to update external controls on the page.

When a control (inside the Panel) tries to postback, it will make an AJAX request and all controls in the Panel will be updated.

When to use RadAjaxManager

AJAX Manager offers a complete solution for turning a postback-based application into an AJAX-driven one.

RadAjaxManager control is mostly dedicated to complex scenarios. With AJAX Manager you have many AJAX initiator controls that update different non-adjacent controls. This is the major difference with AJAX Panel, which updates only itself (and controls that it holds).

Sample Scenario

On the screenshot below there is a sample HelpDesk application. As you can see there three panes there. Clicking in pane 1 updates 2 and 3 and clicking in pane 2 updates pane 3. The possible approaches are described below the image

Panel vs. Manager

First Approach

You can put the whole application in AJAX Panel. Then clicking in either pane 1 or pane 2 will update the three panes altogether using AJAX request.

Although easiest, this is not the optimal scenario for this case.

Second Approach

You can place pane 2 and pane 3 in AJAX Panel. Then when the user clicks in pane 2, it will update pane 2 and pane 3 with AJAX request. In this scenario you need to have pane 1 making external calls to AjaxRequest() function of the AJAX Panel holding panes 2 and 3.

This is the most complicated and yet not optimal approach. It shows that although panes 2 and 3 are neighboring, it is not suitable to place them in a panel.

Third Approach

In this case you can use AJAX Manager to make the treeview in pane 1 update the grid in pane 2. Then you need to make the gird in pane 2 update the panel in pane 3.

See Also

How-to and FAQ
Frequently Asked Questions

© 2002-2008 Telerik. All Rights Reserved.


AJAX Loading Panel

Telerik RadAjax v1.8 Send comments on this topic.
AJAX Loading Panel
See Also
AJAX Loading Panel > AJAX Loading Panel

Glossary Item Box

Telerik RadAjax has a support for templates that will be shown as a progress indication when a callback request is performed, i.e. when the page is loading silently. This will improve the overall feeling of the page as there will be no sudden changes and unnecessary flickering. There are some sample loading panels below:

Loading panel 1 Loading panel 2 Loading panel 3

Position

In order to have a LoadingPanel, you need to drag it to your web form from the toolbox just like any control. Then you can set a control to use a LoadingPanel using the design-time. The IsSticky property of the LoadingPanel defines where the panel will appear. By default, when IsSticky is false, the LoadingPanel will appear over the updated control. If you set IsSticky to true, the panel will appear where you have set it in the WebForm.

In case you have many controls added to the AjaxSettings and want to use IsSticky="true", then you need to set absolute positioning for the LoadingPanel control i.e:

<rad:AjaxLoadingPanel ID="AjaxLoadingPanel1" IsSticky="true" runat="server" Height="75px" Width="75px" style="position:absolute;">
<asp:Image ID="Image1" runat="server" AlternateText="Loading..." ImageUrl="~/RadControls/Ajax/Skins/Default/Loading.gif" />
</rad:AjaxLoadingPanel>

You can use a single LoadingPanel for many controls. It will show on the place of each control that was set to use it, IsSticky was set to true.

You can modify the LoadingPanel control as you would do with a normal template. The example below shows how to set an Image and a Label inside the LoadingPanel.

ASPX Copy Code
<rad:AjaxLoadingPanel
id="AjaxLoadingPanel1"
runat="server"
Width="256px"
Height="64px">
<asp:Label id="Label2" runat="server" ForeColor="Red">Loading... </asp:Label>
<asp:Image id="Image1" runat="server" Width="224px" Height="48px" ImageUrl="Loading.gif"></asp:Image>
</rad:AjaxLoadingPanel>
Timing

There are cases when you update a small amount of data. In this scenario the AJAX request executes very fast and there is not enough time to show the Loading Panel. You see a brief flickering instead, which may seem annoying and may confuse the site visitor. For this purpose LoadingPanel provides two properties: InitialDelayTime and MinDisplayTime.

The InitialDelayTime property specifies the delay in milliseconds, after which the LoadingPanel will be shown. If the request returns before this time, the LoadingPanel will not be shown.

This, however does not solve the scenario, when the request returns shortly after the initial delay time has passed. The page has just shown the Loading Panel and has to hide it again. The result will be even more annoying flicker. That's why there is another property for the LoadingPanel: MinDisplayTime. It specifies the minimum time in milliseconds that the Loading Panel will last. The control will not be shown before this period has passed even if the request returns. This will ensure more smoother interface for your page.

Transparency

The loading panel does not "replace" the updated control by default. Instead, it is shown "over" the control. The Transparency property value should be set in percentage (values 0-100). The default value of the Transparency property is 0, which means the loading panel is absolutely visible.

See the online demo and check how changing the transparency value changes loading panel appearance.

Explicitly show and hide the loading panel

Since Telerik RadAjax v1.6.2 AJAX Loading Panel's Show and Hide methods can be explicitly called on the client. This allows you to update controls according to some condition (using the ResolveUpdatedControls event) and display a loading panel over the control that will be updated (Show the panel in OnRequestStart, hide it in OnResponseEnd). Review this topic for more info.

See Also

Live demos
AJAX Loading panel images
Loading panel Transparency feature

© 2002-2008 Telerik. All Rights Reserved.


Show and hide loading panel explicitly

Telerik RadAjax v1.8 Send comments on this topic.
Show and hide loading panel explicitly
See Also
AJAX Loading Panel > AJAX Loading Panel How-To > Show and hide loading panel explicitly

Glossary Item Box

To display the loading panel over an element, just call the Show method client-side. This allows you to update controls according to some condition (using the ResolveUpdatedControls event) and display a loading panel over the control that will be updated (Show the panel in OnRequestStart, hide it in OnResponseEnd):

JavaScript Copy Code
<script type="text/javascript">
var currentLoadingPanel = null;
var currentUpdatedControl = null;

function AjaxRequestStart(sender, args)
{
//the RadMenuItem-originated postback will setup the EventArgument with something like RadMenu1$m1
var menuItemIndex = args.EventArgument.match(/.*?\$m(\d+)/)[1];
currentLoadingPanel = RadAjaxNamespace.LoadingPanels["<%= AjaxLoadingPanel1.ClientID %>"];

//find out what we'll be updating
if (parseInt(menuItemIndex) == 0)
{
currentUpdatedControl = "<%=Panel1.ClientID %>";
}
else
{
currentUpdatedControl = "<%=Panel2.ClientID %>";
}

//show the loading panel over the updated control
currentLoadingPanel.Show(currentUpdatedControl);
}

function AjaxResponseEnd()
{
//hide the loading panel and clean up the global variables
if (currentLoadingPanel != null)
currentLoadingPanel.Hide(currentUpdatedControl);

currentUpdatedControl = null;
currentLoadingPanel = null;
}
</script>

When you use this approach for RadControls, you need to invoke the currentLoadingPanel.Hide() method with a slight change due to the rendering of the RadControls. The code that shows the loading panels tries to append "_wrapper" at the end of the updated controls, because all of the RadControls' html wrapper elements end in this suffix. However, the code for hiding the loading panel will not look for the wrapper suffix, which will cause a javascript error. To use the above script for RadControls please apply the following change to the Hide() method:

currentLoadingPanel.Hide(currentUpdatedControl+"_wrapper");

See Also

AJAX Loading Panel How-To
Set Loading Panel depending on AJAX initiator

© 2002-2008 Telerik. All Rights Reserved.


Show AJAX Loading Panel on initial page load

Telerik RadAjax v1.8 Send comments on this topic.
Show AJAX Loading Panel on initial page load
See Also
AJAX Loading Panel > AJAX Loading Panel How-To > Show AJAX Loading Panel on initial page load

Glossary Item Box

Although AJAX Loading Panel is designed to be shown on update of control(s) with an AJAX request, people would like to show it on initial page load as well. It is not supported out of the box, however it is easy achievable using some additional code.

The focus on the following example is the window.onload function, which initiates an AJAX request from the client. To be more functional, we have added an update of an ASP:Panel to this example. Thus, we need an AJAX Manager setting, where RadAjaxMnager updates the panel (shows an initially invisible inner panel actually).

JavaScript Copy Code
<script type="text/javascript">
window.onload = function()
{
setTimeout( function(){
window[ "<%= RadAjaxManager1.ClientID %>"].AjaxRequest("InitialPageLoad");
}, 200);
}
</script>

ASPX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" OnAjaxRequest="RadAjaxManager1_AjaxRequest">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="RadAjaxManager1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Panel1" LoadingPanelID="AjaxLoadingPanel1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
<asp:Panel ID="Panel1" runat="server">
<asp:Panel ID="Panel2" Visible="false" runat="server">
My content:
</asp:Panel>
</asp:Panel>
<rad:AjaxLoadingPanel ID="AjaxLoadingPanel1" runat="server" Height="75px" Width="75px">
<asp:Image ID="Image1" runat="server" AlternateText="Loading..." ImageUrl="~/RadControls/Ajax/Skins/Default/Loading.gif" />
</rad:AjaxLoadingPanel>

C# Copy Code
protected void RadAjaxManager1_AjaxRequest(object sender, Telerik.WebControls.AjaxRequestEventArgs e)
{
if (e.Argument == "InitialPageLoad")
{
//simulate longer page load
System.Threading.Thread.Sleep(2000);
Panel2.Visible = true;
}
}

VB.NET Copy Code
Protected Sub RadAjaxManager1_AjaxRequest(ByVal sender As Object, ByVal e As Telerik.WebControls.AjaxRequestEventArgs) Handles RadAjaxManager1.AjaxRequest
If e.Argument = "InitialPageLoad" Then
'simulate longer page load
System.Threading.Thread.Sleep(2000)
Panel2.Visible = True
End If
End Sub

See Also

AJAX Client-Side
Client-Side API

AJAX Manager How-To
Toggle control visibility

© 2002-2008 Telerik. All Rights Reserved.


Center LoadingPanel on the screen

Telerik RadAjax v1.8 Send comments on this topic.
Center LoadingPanel on the screen
AJAX Loading Panel > AJAX Loading Panel How-To > Center LoadingPanel on the screen

Glossary Item Box

The below code calculates and positions the loading panel in the middle of the screen. Note the use of absolute positioning and Sticky mode of the loading panel.

JavaScript Copy Code
<script type="text/javascript">
function centerUpdatePanel()
{
centerElementOnScreen(document.getElementById("LoadingPanel1"));
}

function centerElementOnScreen(element)
{
var scrollTop = document.body.scrollTop;
var scrollLeft = document.body.scrollLeft;

var viewPortHeight = document.body.clientHeight;
var viewPortWidth = document.body.clientWidth;

if (document.compatMode == "CSS1Compat")
{
viewPortHeight = document.documentElement.clientHeight;
viewPortWidth = document.documentElement.clientWidth;

scrollTop = document.documentElement.scrollTop;
scrollLeft = document.documentElement.scrollLeft;
}

var topOffset = Math.ceil(viewPortHeight/2 - element.offsetHeight/2);
var leftOffset = Math.ceil(viewPortWidth/2 - element.offsetWidth/2);

var top = scrollTop + topOffset - 40;
var left = scrollLeft + leftOffset - 70;

element.style.position = "absolute";
element.style.top = top + "px";
element.style.left = left + "px";
}
</script>

<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" ClientEvents-OnRequestStart="centerUpdatePanel();"></rad:RadAjaxManager>

<rad:AjaxLoadingPanel IsSticky="true" ID="LoadingPanel1" runat="Server">
<asp:Image ID="Image1" runat="server" AlternateText="Wird geladen" Style="" ImageUrl="~/RadControls/AJAX/Skins/Default/loading.gif" />

Ready example with RadAjaxPanel can be found posted in this forum thread.

© 2002-2008 Telerik. All Rights Reserved.


Show the loading panel next to AJAX initiator

Telerik RadAjax v1.8 Send comments on this topic.
Show the loading panel next to AJAX initiator
AJAX Loading Panel > AJAX Loading Panel How-To > Show the loading panel next to AJAX initiator

Glossary Item Box

Sometimes people may want to show the loading panel on a specific position, like right next to the AJAX initiator for example. When you have a complex control, e.g. tabstrip, it could be better to show the loading over the clicked tab (say the tabstrip is updated itself via AJAX) instead of showing it on one and the same place.

In order to achieve that you can use a Sticky loading panel (set IsSticky to "true") and set the loading panel position at OnRequestStart event, using the event arguments' EventTargetElement attributes. Below is a sample code you can use and modify according to your exact needs. There are some standard controls (for simplicity) which are ajaxified and update a label control in this example.

There is just one tricky thing here (the first line from the following RequestStart function) - we clear the displayed loading panels cache, otherwise the first loading panel position will be used on each subsequent request. Then we change left and top attributes of loading panel element style according to the offset of the event target in this case.

JavaScript Copy Code
<script type="text/javascript">
function RequestStart(sender, eventArgs)
{
//clear the loading panels cache
AjaxNS.DisplayedLoadingPanels = [];

var divElementStyle = document.getElementById("AjaxLoadingPanel1").style;
divElementStyle.position = 'absolute';

//position the loading panel
divElementStyle.left = eventArgs.EventTargetElement.offsetLeft;
divElementStyle.top = eventArgs.EventTargetElement.offsetTop;
}
</script>

<rad:radajaxmanager id="RadAjaxManager1" runat="server">
<ClientEvents OnRequestStart="RequestStart"></ClientEvents>
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" LoadingPanelID="AjaxLoadingPanel1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="Button2">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" LoadingPanelID="AjaxLoadingPanel1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="CheckBox1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" LoadingPanelID="AjaxLoadingPanel1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:radajaxmanager>
<rad:ajaxloadingpanel id="AjaxLoadingPanel1" runat="server" height="75px" width="75px" IsSticky="True" MinDisplayTime="500">
<asp:Image id="Image1" runat="server" AlternateText="Loading..." ImageUrl="~/RadControls/Ajax/Skins/Default/Loading.gif"></asp:Image>
</rad:ajaxloadingpanel>

<asp:Button ID="Button1" runat="server" OnClick="Button1_Click" Text="Button" width="100px"/>
<asp:Label ID="Label1" runat="server" Text="Label" style="z-index: 103; left: 137px; position: absolute; top: 255px"></asp:Label>
<asp:CheckBox ID="CheckBox1" runat="server" AutoPostBack="True" Text="check box" />
<asp:Button ID="Button2" runat="server" OnClick="Button1_Click" Text="Button2" width="100px"/>

On button and checkbox click events we just update the label server-side.

© 2002-2008 Telerik. All Rights Reserved.


Set Loading Panel depending on AJAX initiator

Telerik RadAjax v1.8 Send comments on this topic.
Set Loading Panel depending on AJAX initiator
See Also
AJAX Loading Panel > AJAX Loading Panel How-To > Set Loading Panel depending on AJAX initiator

Glossary Item Box

You may set different AJAX Loading Panel for every single (ajaxified) control, which updates a control on the page.

In general this could be done using different AjaxSettings for each of ajaxified controls. See the following AJAX Manager settings, where different buttons update one and the same label control, using different loading panels:

ASPX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" LoadingPanelID="AjaxLoadingPanel1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="Button2">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" LoadingPanelID="AjaxLoadingPanel2" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
There is another, more flexible approach to change the loading panel depending on the AJAX initiator. Attach the following JavaScript function to RadAjaxManager's OnRequestStart client event:
JavaScript Copy Code
<script type="text/javascript">
function OnRequestStart(ajaxManager, arguments)
{
var settings = ajaxManager.AjaxSettings;
for (var i = 0; i < settings.length; i++)
{
if (settings[i].InitControlID == arguments.EventTarget)
{
var updatedControls = settings[i].UpdatedControls;
for (var j = 0; j < updatedControls.length; j++)
{
var updatedControl = updatedControls[j];
if (arguments.EventTarget == "Button1")
{
updatedControl.PanelID = "AjaxLoadingPanel1";
}
else if (arguments.EventTarget == "Button2")
{
updatedControl.PanelID = "AjaxLoadingPanel2";
}

}
}
}
}
</script>
Using arguments.EventTarget, the function checks the control, which made the AJAX request and sets the correspondent AjaxLoadingPanel to PanelID of the updated control.

See Also

AJAX Loading Panel How-To
Show and hide loading panel explicitly

© 2002-2008 Telerik. All Rights Reserved.


AJAX Timer

Telerik RadAjax v1.8 Send comments on this topic.
AJAX Timer
See Also
AJAX Timer > AJAX Timer

Glossary Item Box

RadAjaxTimer is a postback timer control. It "ticks" and makes one or more postbacks at a predefined interval.

In order to make this control perform AJAX requests instead of postbacks, put it in AJAX Panel or set it with AJAX Manager.

RadAjaxTimer in RadAjaxManager | RadAjaxTimer in RadAjaxPanel
RadAjaxTimer in RadAjaxManager Enlarge Click to enlarge | RadAjaxTimer in RadAjaxPanel Enlarge Click to enlarge

Once you place the control in a WebForm (drag it from VisualStudio toolbox), you can set the server-side AutoStart property of RadAjaxTimer to true. The control will start ticking on page load. The interval between two ticks can be set with the Interval property. This property accepts values in milliseconds. It's runtime change restarts the timer automatically so that the new value is applied.

RadAjaxTimer fires a Tick event on each tick. You can handle this event in order to perform your own actions when some predefined interval (e.g. five ticks) has passed.

<rad:RadAjaxTimer AutoStart="true" id="RadAjaxTimer1" runat="server" Interval="3000"></rad:RadAjaxTimer>

You can start/stop the timer control at runtime. In this case the AutoStart property should be set to false (otherwise the control will start on its own). There are two methods for controlling the Timer: Start and Stop:

  • Start method starts the control by setting its IsStarted property to true.
  • Stop method stops the control by setting IsStarted to false.

RadAjaxTimer client-side

RadAjaxTimer provides two client-side methods:

  • Start() - starts the Timer
  • Stop() - stops the Timer

The following code exemplifies the usage of these methods:

JavaScript Copy Code
<input type="button" id="StartButton" class="button" onclick="StartTimer();" value="Start"></input>
<input type="button" id="StopButton" class="button" onclick="StopTimer();" value="Stop"></input>
<script type="text/javascript">
<!--
document.getElementById( "StartButton").disabled = true;
function StartTimer()
{
<%= RadAjaxTimer1.ClientID %>.Start();
document.getElementById( "StartButton").disabled = true;
document.getElementById( "StopButton").disabled = false;
}

function StopTimer()
{
<%= RadAjaxTimer1.ClientID %>.Stop();
document.getElementById( "StartButton").disabled = false;
document.getElementById( "StopButton").disabled = true;
}
//-->
</script>
RadAjaxTimer also exposes the OnClientTick event, which will can be cancel if needed:
JavaScript Copy Code
<script type="text/javascript">
function ClientTick(sender, eventArgs)
{
eventArgs.CancelServerTick = true;
//return false will do the same for you;
}
</script>

<rad:RadAjaxTimer id="RadAjaxTimer2" runat="server" AutoStart="true" Interval="1000" OnClientTick="ClientTick">

See Also

AJAX Panel
AJAX Manager

© 2002-2008 Telerik. All Rights Reserved.


WebService manager

Telerik RadAjax v1.8 Send comments on this topic.
WebService manager
See Also
WebServiceManager > WebService manager

Glossary Item Box

Telerik RadAjax provides the ability to call web services and retrieve information via AJAX requests. For this purpose there is a special control in Telerik RadAjax controls suite called RadAjaxServiceManager. You need to drag the control from the web form to your toolbox and fill the Services collection. This is a collection of Paths to different web services. You can set relative or absolute paths to the services. The only limitation is that these services MUST be within your Web Application or domain.

Setup Web.Config

First of all in order to use WebServices in Telerik RadAjax, you should modify the web.config file for your application and add the following configuration element inside <system.web> tag:

web.config Copy Code
<webServices>
<protocols>
<add name="HttpPost"/>
</protocols>
</webServices>

Setup service invocation

Once you have set the services, there are two ways for their invocation:

  • Simple WebService invocation - you call the service and use it without passing additional parameters
  • Advanced WebService invocation - you call the service but you need to pass one or more parameters in order to get results.

In both cases you need to write a custom JavaScript code that will handle the received response. Telerik RadAjax will generate automatically a proxy method, which has the same name as the WebService method. It will accept two parameters: ServiceCompleteCallback and ServiceErrorCallback. These two parameters correspond to two JavaScript functions. The first one, ServiceCompleteCallback will be executed when in case of successful WebService method execution. The second one, ServiceErrorCallback will be executed in case of failure, so you can use it to display a friendly error message. You should define the bodies of these callback functions in your script block using the following signatures:

Script Copy Code
function ServiceCompleteCallback(ResponseAsJSON, ResponseAsXml, ResponseAsText)
{
// write your code here...
}

function ServiceErrorCallback(args)
{
// display a friendly error message...
}

See Also

Simple WebService invocation
Advanced WebService invocation

© 2002-2008 Telerik. All Rights Reserved.


Simple WebService invocation

Telerik RadAjax v1.8 Send comments on this topic.
Simple WebService invocation
See Also
WebServiceManager > Simple WebService invocation

Glossary Item Box

In case of simple WebService invocation, all you need to know is the name of the WebService method and the type of the information it returns. You can see the available operations when you open the web service ASMX file in a web browser (see this online demo for more info).

Telerik RadAjax will generate automatically a proxy method, which has the same name as the WebService method. It will accept two parameters: ServiceCompleteCallback and ServiceErrorCallback. These two parameters correspond to two JavaScript functions. The first one, ServiceCompleteCallback will be executed when in case of successful WebService method execution. The second one, ServiceErrorCallback will be executed in case of failure, so you can use it to display a friendly error message.

JavaScript Copy Code
<script type="text/javascript">

function CallService()
{
QuoteService.GetQuote(ServiceCompleteCallback, ServiceErrorCallback);
}

function ServiceCompleteCallback(ResponseAsJSON, ResponseAsXml, ResponseAsText)
{
document.getElementById("label1").innerHTML = ResponseAsJSON;
}

function ServiceErrorCallback(args)
{
alert("Error occurred:" + args.ErrorText);
}

</script>
In case the web service returns more complex results such as array or object, you should use ResponseAsJSON argument (which is a JavaScript object) to access them:
JavaScript Copy Code
/* The following function will display the third element from the result array */
function ServiceCompleteCallback(ResponseAsJSON, ResponseAsXml, ResponseAsText)
{
document.getElementById("label1").innerHTML = ResponseAsJSON[2];
}

/* The following function will display the FirstName and the LastName properties from the returned object */

function ServiceCompleteCallback(ResponseAsJSON, ResponseAsXml, ResponseAsText)
{
document.getElementById("label1").innerHTML = ResponseAsJSON.FirstName;
document.getElementById("label2").innerHTML = ResponseAsJSON.LastName;
}

See Also

WebService manager
Advanced WebService invocation

© 2002-2008 Telerik. All Rights Reserved.


Advanced WebService invocation

Telerik RadAjax v1.8 Send comments on this topic.
Advanced WebService invocation
See Also
WebServiceManager > Advanced WebService invocation

Glossary Item Box

In case of comples WebService invocation, you need to pass a parameter to the web service in order to get the result. The results depend on the passed parameter.

The proxy method that Telerik RadAjax generates to call the service has the same name and takes the same parameters as the WebService method plus the required two parameters: ServiceCompleteCallback and ServiceErrorCallback:

Script Copy Code
function CallService()
{
LibraryService.LookUp(ID_parameter, ServiceCompleteCallback, ServiceErrorCallback);
}
You can pass as many parameters, as you need. You only have to insert them in the parameters list in front of the required ones:

Script Copy Code
function CallService()
{
LibraryService.LookUp(Parameter1, Parameter2, Parameter3, ServiceCompleteCallback, ServiceErrorCallback);
}

You can see the available WebService operations and the parameters that they accept in the WebService ASMX file:

http://www.telerik.com/DEMOS/ASPNET/Ajax/Examples/ServiceManager/Orders/OrdersService.asmx

Telerik RadAjax will generate automatically a proxy method, which has the same name as the WebService method. It will accept two parameters: ServiceCompleteCallback and ServiceErrorCallback. These two parameters correspond to two JavaScript functions. The first one, ServiceCompleteCallback will be executed when in case of successful WebService method execution. The second one, ServiceErrorCallback will be executed in case of failure, so you can use it to display a friendly error message.

The following example is from Telerik RadAjax Quick-Start Framework (you can see the working example here)

It takes the entered value from a text box and passes it as a parameter to a WebService and its LookUp operation. The WebService on its turn returns an array of results which are processed and filled in a table:

JavaScript Copy Code
<script type="text/javascript">

function CallService()
{
var orderid_input =document.getElementById("orderid_input");

if(orderid_input.value != "")
{
/* The valeue from the text box (orderid_input.value) is passed as a parameter */
LibraryService.LookUp(orderid_input.value, ServiceCompleteCallback, ServiceErrorCallback);
}
else
{
alert("Please Enter a value!");
}
}

function ServiceCompleteCallback(ResponseAsJSON, ResponseAsXml, ResponseAsText)
{
var Orders = ResponseAsJSON.Orders;

for(var item in Orders[0])
{
var element = document.getElementById(item);

if(element != null)
{
try
{
element.innerHTML = Orders[0][item];
}
catch(ex){}
}
}

var responseDiv = document.getElementById("ResponseAsText");

if(ResponseAsXml.xml)
{
responseDiv.innerHTML = "<xmp>"+ResponseAsXml.xml+"</xmp>";
}
else
{
responseDiv.innerHTML = "Browser does not provide a raw XML response";
}
}

function ServiceErrorCallback(args)
{
var label = document.getElementById("errorLabel");
label.innerHTML = "Error occurred: " + args.ErrorText + "<br />" + "Details: " + args.Text;
}

</script>

See Also

WebService manager
Simple WebService invocation

© 2002-2008 Telerik. All Rights Reserved.


Frequently Asked Questions

Telerik RadAjax v1.8 Send comments on this topic.
Frequently Asked Questions
How-to > Frequently Asked Questions

Glossary Item Box

  1. Q: I have a button and a control (RadTreeview for example). The button should update the control with AJAX. How should I proceed?
    A: You should use the AJAX manager. In the left pane select the button and in the middle pane select the treeview.
  2. Q: My control is within an AJAX Panel and I want to update a control in another AJAX Panel. Is this possible?
    A: Instead of using two AJAX Panels, consider using a single AJAX Manager.
    However if you still want to use the two panels, you should make external call from the AJAX-initiator control to the AjaxRequest client-side function of the target AJAX Panel. (see AJAX Panel topic)
  3. Q: I need to load an user control dynamically with AJAX. Is this possible?
    A: The only difference between the standard loading of controls and AJAX loading is that you should put control in an ASP panel instead of a Placeholder.
  4. Q: I have two controls that interact and update each other. How should I ajaxify them?
    A: Depending on your application you can use a single Panel to wrap the two controls or AJAX Manager in case the controls are non-adjacent.
  5. Q: Can I use AJAX Panel in another AJAX Panel (i.e. nested AJAX Panels)?
    A: There should be no problem to use nested AJAX Panels. However we recommend you to revise the page logic and see if you can achieve the same behavior with AJAX Manager or two AJAX Panels which are not nested.
  6. Q: I have a client-side code, which is executed on some of the events of a control inside AJAX Panel. How should I proceed?
    A: There is nothing special that you need to do in this case - AJAX Panel automatically evaluates the client-side code and does not require you to write additional code.
  7. Q: I have a control A, which updates control B, which then updates control C. The control C then updates control A again. Controls are dependent on each other and should be updated sequentially. What would you suggest?
    A: The answer depends on how the controls are placed on the Page. In case they are neighboring, place them in AJAX Panel. In case they are non-adjacent, use AJAX Manager and set the AJAX Relations.
  8. Q: I need my controls disabled during AJAX. What should I do?
    A: You should hook the Panel/Manager client-side event OnRequestStart and write custom JavaScript code to achieve your goal. Then you should re-enable it by hooking the OnResponseEnd client-side event.
  9. Q: Why is my RadAjaxTimer performing POSTBACKS instead of AJAX requests?
    A: You need to ajaxify RadAjaxTimer with RadAjaxManager or place it inside a RadAjaxPanel.

© 2002-2008 Telerik. All Rights Reserved.


Updating 3rd party controls with Telerik RadAjax

Telerik RadAjax v1.8 Send comments on this topic.
Updating 3rd party controls with Telerik RadAjax
How-to > Updating 3rd party controls with Telerik RadAjax

Glossary Item Box

Basically you should first check if the control is MS AJAX compatible (MS AJAX is the MS framework for ajax-enabling controls). If the control works with it, it will most likely work without problems with our AJAX framework as well. Technical difficulties may occur when updating 3rd party controls which use JavaScript code on client-side outside of the updating area. As controls are not aware that they are being updated by AJAX (rather than a postback), they cannot restore their client-side functionality as the HTML element is being replaced by a new object. Things to check for:

  1. The control, which is to be updated via AJAX request should be aware of this fact. This means that it has to be pre-modified to work with XmlHttpRequests. This should be done by its vendor, so please contact the control's vendor for help on the issue.
    All Telerik RadControls for ASP.NET have been modified and are ready to be used with telerik's AJAX controls (the first compatible version is Telerik RadControls for ASP.NET Q2 2006)
  2. Make sure the control renders in one tag. This will ensure its proper update. You can check this by viewing the page's source. If the control does not render in one tag, you should nest it in a ASP Panel or a DIV tag.
  3. Set EnableOutsideScripts property of the RadAjaxManager or RadAjaxPanel to true in order to properly restore the client-side JavaScripts in case they are outside of the updating area.

Also see this KB article on the matter.

© 2002-2008 Telerik. All Rights Reserved.


Redirecting to another page

Telerik RadAjax v1.8 Send comments on this topic.
Redirecting to another page
How-to > Redirecting to another page

Glossary Item Box

Telerik RadAjax supports two kinds of redirection:

  • Response.Redirect() - the standard ASP.NET means of redirection.
  • generating JavaScript that sets window.location.href.

Redirecting on the client (JavaScript window.location.href)

RadAjaxManager and RadAjaxPanel also support the Redirect() method, which in essence adds a short javascript to be evaluated after the AJAX request. The javascript code uses the window.location.href property to navigate to a new URL.

C# Copy Code
RadAjaxManager1.Redirect("http://www.google.com/");
VB.NET Copy Code
RadAjaxManager1.Redirect("http://www.google.com/")
or
C# Copy Code
RadAjaxPanel1.Redirect("http://www.google.com/");
VB.NET Copy Code
RadAjaxPanel1.Redirect("http://www.google.com/")
Redirect when session times out.

When using authentication for your page and the session expires you need to add the following code to the Page_Init event of the Login.aspx page:

C# Copy Code
protected void Page_Init(object sender, EventArgs e)
{
Response.RedirectLocation = Request.Url.ToString();
}
This way clicking on ajaxified control when the session has expired will lead to the expected behavior of redirecting to the login page.

© 2002-2008 Telerik. All Rights Reserved.


Disable controls during AJAX

Telerik RadAjax v1.8 Send comments on this topic.
Disable controls during AJAX
How-to > Disable controls during AJAX

Glossary Item Box

You may want to disable control during AJAX, so the clients won't be able to use it before response end. This could easy be achieved using OnRequestSent and OnResponseEnd client-side events changing the disabled value.

Here is a complete working code showing the mentioned approach:

JavaScript Copy Code
<script type="text/javascript">
function RequestSent(sender, args)
{
args.EventTargetElement.disabled = true;
}
function ResponseEnd(sender, args)
{
args.EventTargetElement.disabled = false;
}
</script>
ASPX/ASCX Copy Code
<asp:Button ID="btnUpdate" runat="server" Text="Update" />
<asp:Label ID="Label1" runat="server"></asp:Label>

<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" >
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="btnUpdate">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1"/>
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
<ClientEvents OnRequestSent="RequestSent" OnResponseEnd="ResponseEnd" />
</rad:RadAjaxManager>

Implementing the above will disable any control, which has already start a request until its response ends.

If one wants to disable AJAX until the current response finishes, no matter which control has started the first request and which is going to make a second one, a global flag may be used as in the following script:

JavaScript Copy Code
<script type="text/javascript">
var AjaxIsActive = false;

function RequestSent()
{
if (!AjaxIsActive)
{
AjaxIsActive = true;
}
else
{
alert('Wait for ajax to finish');
return false;
}
}

function ResponseEnd()
{
AjaxIsActive = false;
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Load user controls

Telerik RadAjax v1.8 Send comments on this topic.
Load user controls
See Also
How-to > Load user controls

Glossary Item Box

The dynamic loading of user controls follows the same logic as in normal postback application with small specifics regarding the usage of either of the Telerik RadAjax controls. The only difference between the standard loading of controls and AJAX loading is that you should add the control in an asp:Panel instead of a Placeholder. This is due to the fact that the Placeholder does not render any HTML output and therefore cannot be updated with our ajax control. You can load custom user controls via AJAX requests by following the steps below:

  1. You need to have an appropriate container for it - usually that will be a specially designated asp:panel.
  2. Instantiate your user control in Page_Init or Page_Load and always recreate the last loaded User Control:
    VB.NET Copy Code
    Dim MyControl As UserControl = Me.LoadControl(controlName)
    Me.LoadMyUserControl( Me.CurrentControl, Panel1)

    C# Copy Code
    UserControl MyControl = (UserControl)LoadControl(controlName);
    LoadMyUserControl(CurrentControl, Panel1);
  3. Make sure you assign unique ID to the dynamically loaded User Control:

    VB.NET Copy Code
    Dim userControlID As String = controlName.Split("."c)(0)
    MyControl.ID = userControlID.Replace("/", "").Replace("~", "")

    C# Copy Code
    string userControlID = controlName.Split('.')[0];
    MyControl.ID = userControlID.Replace(    "/", "").Replace("~", "");
  4. Place the instance inside the controls collection of the container:

    VB.NET Copy Code
    parent.Controls.Add(MyControl)

    C# Copy Code
    parent.Controls.Add(MyControl);

  5. Here is the code from a sample project:

    ASPX/ASCX Copy Code
    <div>
    <asp:Button ID="Button1" runat="server" Text="Load WebUserControl1.ascx" />
    <asp:Button ID="Button2" runat="server" Text="Load WebUserControl2.ascx" />
    <br />
    <asp:Panel ID="Panel1" runat="server"></asp:Panel>
    <rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
    <AjaxSettings>
    <rad:AjaxSetting AjaxControlID="Button1">
    <UpdatedControls>
    <rad:AjaxUpdatedControl ControlID="Panel1" />
    </UpdatedControls>
    </rad:AjaxSetting>
    <rad:AjaxSetting AjaxControlID="Button2">
    <UpdatedControls>
    <rad:AjaxUpdatedControl ControlID="Panel1" />
    </UpdatedControls>
    </rad:AjaxSetting>
    </AjaxSettings>
    </rad:RadAjaxManager>
    </div>

    And in the code-behind:

    VB.NET Copy Code
    Private Property LatestLoadedControlName() As String
    Get
    Return CStr(ViewState("LatestLoadedControlName"))
    End Get
    Set(ByVal value As String)
    ViewState("LatestLoadedControlName") = value
    End Set
    End Property
    Private Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If Not (LatestLoadedControlName Is Nothing) Then
    LoadUserControl(LatestLoadedControlName)
    Else
    LoadUserControl("WebUserControl1.ascx")
    End If
    End Sub
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    LoadUserControl("WebUserControl1.ascx")
    End Sub
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    LoadUserControl("WebUserControl2.ascx")
    End Sub
    Public Sub LoadUserControl(ByVal controlName As String)
    If Not (LatestLoadedControlName Is Nothing) Then
    Dim previousControl As Control = Panel1.FindControl(LatestLoadedControlName.Split("."c)(0))
    If Not (previousControl Is Nothing) Then
    Me.Panel1.Controls.Remove(previousControl)
    End If
    End If
    Dim userControlID As String = controlName.Split("."c)(0)
    Dim targetControl As Control = Panel1.FindControl(userControlID)
    If targetControl Is Nothing Then
    Dim userControl As UserControl = CType(Me.LoadControl(controlName), UserControl)
    'slashes and tildes are forbidden
    userControl.ID = userControlID.Replace("/", "").Replace("~", "")
    Me.Panel1.Controls.Add(userControl)
    LatestLoadedControlName = controlName
    End If
    End Sub

    C# Copy Code
    private void Page_Load(object sender, System.EventArgs e)
    {
    if (LatestLoadedControlName != null)
    {
    LoadUserControl(LatestLoadedControlName);
    }
    else
    {
    LoadUserControl("WebUserControl2.ascx");
    }
    }
    protected void Button1_Click(object sender, EventArgs e)
    {
    LoadUserControl(    "WebUserControl1.ascx");
    }
    protected void Button2_Click(object sender, EventArgs e)
    {
    LoadUserControl(    "WebUserControl2.ascx");
    }

    public void LoadUserControl(string controlName)
    {
    if (LatestLoadedControlName != null)
    {
    Control previousControl = Panel1.FindControl(LatestLoadedControlName.Split(    '.')[0]);
    if (previousControl != null)
    {
    this.Panel1.Controls.Remove(previousControl);
    }
    }
    string userControlID = controlName.Split('.')[0];
    Control targetControl = Panel1.FindControl(userControlID);
    if (targetControl == null)
    {
    UserControl userControl = (UserControl)    this.LoadControl(controlName);
    //slashes and tildes are forbidden
    userControl.ID = userControlID.Replace("/", "").Replace("~", "");
    this.Panel1.Controls.Add(userControl);
    LatestLoadedControlName = controlName;
    }
    }
    private string LatestLoadedControlName
    {
    get
    {
    return (string)ViewState["LatestLoadedControlName"];
    }
    set
    {
    ViewState[    "LatestLoadedControlName"] = value;
    }
    }

For full code working application you can check this example in Telerik RadAjax Quick Start Framework:

http://www.telerik.com/demos/aspnet/Ajax/Examples/Common/LoadingUserControls/DefaultCS.aspx

See Also

AJAX Manager How-To
Using ResolveUpdatedControls event

KB articles
Loading user controls dynamically on TabStrip's TabClick

Code Library
Loading user controls dynamically with AJAX Manager and use ResolveUpdatedControls

© 2002-2008 Telerik. All Rights Reserved.


Executing custom javascript code after AJAX update

Telerik RadAjax v1.8 Send comments on this topic.
Executing custom javascript code after AJAX update
How-to > Executing custom javascript code after AJAX update

Glossary Item Box

Telerik RadAjax offers the ability to execute custom JavaScript code which comes as a response from the server thus giving you more flexibility to complete more specific or complex tasks on the client.

The best and most intuitive approach is to use the ResponseScripts property of the RadAjaxPanel or RadAjaxManager.

Here is a source code example which pops an alert when a Button is clicked:

C# Copy Code
private void Button1_Click(object sender, System.EventArgs e)
{
AjaxManager1.ResponseScripts.Add(string.Format("alert('Hello from the server! Server time is {0}');", DateTime.Now.ToLongTimeString()));
}

Another approach, however, is to simply add a literal control to the Controls collection of the panel which contains the necessary script:

C# Copy Code
string script = "<script type='text/javascript'>alert('hi');</script>";
AjaxPanel1.Controls.Add(new LiteralControl(script));

For cases when you have code blocks in the .aspx you might encounter "Cannot modify controls collection .." error. In this case, place an asp:PlaceHolder in the AJAX Panel and add the Literal to its Controls collection instead:

C# Copy Code
string script = "<script type='text/javascript'>alert('hi');</script>";
PlaceHolder1.Controls.Add(new LiteralControl(script));

You can also check this KB article out.

© 2002-2008 Telerik. All Rights Reserved.


Forcing postback

Telerik RadAjax v1.8 Send comments on this topic.
Forcing postback
See Also
How-to > Forcing postback

Glossary Item Box

telerik is pioneer in offering cross-browser compatible components for ASP.NET but still it would be great to gracefully fallback to postbacks on unsupported browsers or old versions of supported ones. You can force Telerik RadAjax controls and all controls they ajaxify to work in postback mode by simply setting the EnableAjax property of RadAjaxPanel and RadAjaxManager to false. The best approach to achieve this will be to check on the server for the unsupported browser or specific version and set EnableAjax to false.

If you want to perform a single postback instead of AJAX request, arguments.EnableAjax should be false:

In the code-behind:

C# Copy Code
if (!RadAjaxManager1.EnableAJAX)
{
RadAjaxManager1.ClientEvents.OnRequestStart = "OnRequestStart";
}
On the client:
Example Title Copy Code
<script type="text/javascript">
function OnRequestStart(sender, args)
{
args.EnableAjax = false;
}
</script>

See Also

How-to and FAQ
Exclude controls from ajaxifying

© 2002-2008 Telerik. All Rights Reserved.


Exclude controls from ajaxifying

Telerik RadAjax v1.8 Send comments on this topic.
Exclude controls from ajaxifying
See Also
How-to > Exclude controls from ajaxifying

Glossary Item Box

By default the AJAX Panel ajaxifies all controls placed inside. If you want to exclude a control from ajaxifying you can use the following approach:

Attributes OnClick and __doPostBack call

  1. Implement the realPostBack function into your aspx/ascx file
  2. Add a custom OnClick attribute to the control (Button in this case).
    Example Title Copy Code
    <script type="text/javascript">
    function realPostBack(eventTarget, eventArgument)
    {
    __doPostBack(eventTarget, eventArgument);
    }
    </script>

    <    asp:Button ID="Button1" runat="server" Text="Button" />
    <    asp:TextBox ID="TextBox1" runat="server"></asp:TextBox>
    <    rad:RadAjaxPanel ID="RadAjaxPanel1" runat="server">
    <asp:LinkButton ID="LinkButton1" runat="server" Text="PostBack"></asp:LinkButton>
    <asp:LinkButton ID="LinkButton2" runat="server" Text="Ajax"></asp:LinkButton>
    </    rad:RadAjaxPanel>
    And in the code-behind (Page_Load event handler):

    C# Copy Code
    if (!Page.IsPostBack)
    {
    LinkButton1.Attributes.Add(     "onclick", string.Format("realPostBack(\"{0}\", \"\"); return false;", LinkButton1.UniqueID));
    }

    VB.NET Copy Code
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
    If Not Page.IsPostBack Then
    LinkButton1.Attributes.Add( "onclick", String.Format("realPostBack('{0}', ''); return false;", LinkButton1.UniqueID))
    End If
    End Sub

If you do not have a control that registers the __doPostBack function on the page you should add the following line in the Page_Load as well:
this.Page.ClientScript.GetPostBackEventReference(this, "");

This will come handy when you want a single control to perform post-back for your scenario or you want to upload files from control in AJAX Panel.

Set EnableAJAX to false at OnRequestStart for the particular control/request

1. Hook OnRequestStart client event

2. Set args.EnableAJAX = false for the respective initiator

ASPX/ASCX Copy Code
<script type="text/javascript">
function RequestStart(sender, args)
{
if (args.EventTarget == "Button1")
{
args.EnableAjax = false;
}
}
</script>
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Panel1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
<ClientEvents OnRequestStart="RequestStart" />
</rad:RadAjaxManager>
<asp:Panel ID="Panel1" runat="server">
<asp:Button ID="Button2" runat="server" Text="AJAX"/>
<asp:Button ID="Button1" runat="server" Text="Postback instead of AJAX"/>
</asp:Panel>
Exclude Dynamically Loaded Controls

In case you are loading the user control dynamically, the code if (!Page.IsPostBack) in the example above in its Page_Load event handler is never executed. You can check for the attached OnClick event instead of the IsPostBack. For example:

C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
bool isOnClickAttached = false;
IEnumerator keys = this.CheckBox1.Attributes.Keys.GetEnumerator();
while(keys.MoveNext())
{
if(keys.Current.Equals("onClick"))
{
isOnClickAttached = true;
break;
}
}
if(!isOnClickAttached)
this.CheckBox1.Attributes.Add( "onClick", string.Format("realPostBack(\"{0}\", \"\"); return false;", this.CheckBox1.UniqueID));
}
VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
Dim isOnClickAttached As Boolean = false
Dim keys As IEnumerator = Me.CheckBox1.Attributes.Keys.GetEnumerator

While keys.MoveNext
If keys.Current.Equals("onClick") Then
isOnClickAttached = true
'TODO: Warning!!! break;If
End If

End While
If Not isOnClickAttached Then
Me.CheckBox1.Attributes.Add( "onClick", String.Format("realPostBack(\""{0}\"", \""\""); return false;", Me.CheckBox1.UniqueID))
End If
End Sub

See Also

Troubleshooting
AJAX And File Upload

How-to
Forcing postback

© 2002-2008 Telerik. All Rights Reserved.


Cancel AJAX request

Telerik RadAjax v1.8 Send comments on this topic.
Cancel AJAX request
See Also
How-to > Cancel AJAX request

Glossary Item Box

You can cancel an AJAX request in a client-script function simply by returning value false. The client-script function can be called upon OnRequestStart event.

JavaScript Copy Code
function CheckZipCode()
{
var zipCode = document.getElementById('<%=TextBox1.ClientID%>').value;
if (zipCode.length != 5)
{
alert('Please enter a valid 5 digit postal code!');
return false; // cancel the AJAX request
}
else
{
var fiveDigitCheckRE=/^\d{5}$/ //regular expression for checking a 5 digit number
if (zipCode.search(fiveDigitCheckRE) == -1)
{
alert("Only digits are allowed!"); return false; // cancel the AJAX request
}
}
}
You can also check this example out:

http://localhost/Telerik/Telerik RadAjax1.0_NET2/Ajax/Examples/Common/CancelAJAX/DefaultCS.aspx

See Also

AJAX How-To
Client confirmation and AJAX

© 2002-2008 Telerik. All Rights Reserved.


Client confirmation and AJAX

Telerik RadAjax v1.8 Send comments on this topic.
Client confirmation and AJAX
See Also
How-to > Client confirmation and AJAX

Glossary Item Box

One may need to provide a confirmation dialog to the users and initiate an AJAX request if accepted. Confirmation using standard post backs often looks like this:

ASPX Copy Code
<asp:ImageButton ID="ImageButton1" runat="server" OnClientClick="return confirm('Are you sure?');" />
The OnClientClick should be changed a bit to work with AJAX:
ASPX Copy Code
<asp:ImageButton ID="ImageButton2" runat="server" OnClientClick="if (!confirm('Are you sure?')) return false;" />
when the button is ajaxified by added the necessary AJAX setting to RadAjaxManager or when the button is placed within RadAjaxPanel control.

Alternatively, the OnRequestStart client-side event could be used to implement more complex logic. Here is a sample script:

JavaScript Copy Code
<script type='text/javascript'>
function OnRequestStart(ajaxControl, eventArgs)
{
var eventTarget = eventArgs.EventTarget;
if (eventTarget == "<%= ImageButton1.UniqueID %>")
{
return confirm('Are you sure?');
}
else
{
return false;
}
}

You can review the Cancellation of AJAX requests online demo, where this approach is followed.

See Also

AJAX How-To
Cancellation of AJAX requests

© 2002-2008 Telerik. All Rights Reserved.


Error handling for AJAX requests

Telerik RadAjax v1.8 Send comments on this topic.
Error handling for AJAX requests
How-to > Error handling for AJAX requests

Glossary Item Box

You can provide your own error handler for AJAX requests if you wish to block or handle those errors in a specific way. Keep in mind that thus you can intercept invalid request content type errors, Server.Transfer calls, etc. but not generic ASP.NET server exceptions.

For this purpose Telerik RadAjax provides a special property AjaxRequestError. You can either supply the name of a javascript function or executable code like "alert(e.message)"

The JavaScript handler function should have the following signature:

JavaScript Copy Code
AjaxRequestErrorHandler(e, clientID)
{
...
}
It must be defined ABOVE the code clock which contains your AJAX enabled control.
ASPX/ASCX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server" OnAjaxRequestError=””…/>
or
<radg:RadGrid ID="RadGrid1" runat="server" OnAjaxRequestError=””…/>
or
Script Copy Code
<script type=”text/javascript”>
function HandleAJAXError(e, clientID)
{
alert(e.message);
}
</script>

<rad:RadAjaxManager OnAjaxRequestError=” HandleAJAXError” … />
or
<radg:RadGrid ID="RadGrid1" runat="server" OnAjaxRequestError=”HandleAJAXError” … />

In case you need to get a hold of the Response object in ajax call on the client, you can use the OnRequestError event which will be raised in case of status different than 200. Here is an example syntax:

<script type="text/javascript">
function RequestError(sender, e)
{
alert(e.Status);
alert(e.ResponseText);
alert(e.ResponseHeaders);
return false;
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Manually add an AJAX request to a client-side event of an HTML element

Telerik RadAjax v1.8 Send comments on this topic.
Manually add an AJAX request to a client-side event of an HTML element
How-to > Manually add an AJAX request to a client-side event of an HTML element

Glossary Item Box

Usually the HTML elements have more client-side events than their server-side counterparts. For example the asp:TextBox control implements only the TextChanged server-side event while the corresponding HTML element has a few more ?? OnMouseOver, OnMouseOut, OnKeyPress, OnKeyUp, OnKeyDown, etc. If you want to ajaxify one of these client events you have to follow the instructions bellow:

Method I (add the attribute declaratively)

  1. Add the OnMouseUp attribute and make it call a custom function:
    ASPX Copy Code
    <asp:TextBox onkeyup="TextBoxCustomAjax('TextBox1');" ID="TextBox1" runat="server" ></asp:TextBox>
  2. Implement the TextBoxCustomAjax function:
    JavaScript Copy Code
    <script type="text/javascript">
    function TextBoxCustomAjax(eventArgs)
    {
    <%=RadAjaxManager1.ClientID %>.AjaxRequest(eventArgs);
    }
    </script>
  3. Implement the AjaxRequest server event of the AjaxManager:
    C# Copy Code
    protected void RadAjaxManager1_AjaxRequest( object sender, Telerik.WebControls.AjaxRequestEventArgs e)
    {
    if (e.Argument == TextBox1.ClientID)
    {
    Label1.Text = TextBox1.Text;
    }
    }
  4. Set from the designer that the RadAjaxManager1 will update Label1.

Method II (add the attribute from code-behind).

  1. Add the OnKeyUp attribute:
    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
    {
    TextBox1.Attributes.Add(     "onkeyup", RadAjaxManager1.GetAjaxRequestReference(TextBox1.ClientID));
    }
  2. Implement the AjaxRequest event of the RadAjaxManager:
    C# Copy Code
    protected void RadAjaxManager1_AjaxRequest(object sender, Telerik.WebControls.AjaxRequestEventArgs e)
    {
    if (e.Argument == TextBox1.ClientID)
    {
    Label1.Text = TextBox1.Text;
    }
    }
  3. Set from the design-time configuration wizard that RadAjaxManager1 will update Label1.

© 2002-2008 Telerik. All Rights Reserved.


Assign different Client-events for different controls

Telerik RadAjax v1.8 Send comments on this topic.
Assign different Client-events for different controls
How-to > Assign different Client-events for different controls

Glossary Item Box

In order to assign different client-events to different ajaxified controls you can use the following approach:

ASPX Copy Code
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server"><AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="DropDownList1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
<ClientEvents OnRequestStart="Start" OnResponseEnd="End" />
</rad:RadAjaxManager>
<asp:Button ID="Button1" runat="server" OnClick="Button1_Click" Text="Button" />
<asp:DropDownList ID="DropDownList1" runat="server" AutoPostBack="True" OnSelectedIndexChanged="DropDownList1_SelectedIndexChanged">
<asp:ListItem>111</asp:ListItem>
<asp:ListItem>222</asp:ListItem>
</asp:DropDownList>
JavaScript Copy Code
<script type="text/javascript">
function Start(sender, arguments)
{
if (arguments.EventTarget == "<%= Button1.UniqueID %>")
{
alert("StartButton");
}
if (arguments.EventTarget == "<%= DropDownList1.UniqueID %>")
{
alert("StartDropdown");
}
}
function End(sender, arguments)
{
if (arguments.EventTarget == "<%= Button1.UniqueID %>")
{
alert("EndButton");
}
if (arguments.EventTarget == "<%= DropDownList1.UniqueID %>")
{
alert("EndDropdown");
}
}
</script>
This way the DropDownList and the Button will have different client-events although using the same RadAjaxManager or RadAjaxPanel.

© 2002-2008 Telerik. All Rights Reserved.


Disable AJAX when client browser does not support it

Telerik RadAjax v1.8 Send comments on this topic.
Disable AJAX when client browser does not support it
See Also
How-to > Disable AJAX when client browser does not support it

Glossary Item Box

Telerik RadAjax controls won't work on browsers that do not support XmlHttp requests. You may want to disable AJAX when such a browser opens your site. This could be easily achieved by setting the EnableAJAX property of used Telerik RadAjax control to false both on client- and server-side.

.NET 2.x Framework

The .NET2 framework provides SupportsXmlHttp property and it should be used to check if the browser supports XmlHttpRequest:

Example Title Copy Code
RadAjaxManager1.EnableAJAX = Page.Request.Browser.SupportsXmlHttp;
When this check in made in Page_Load event handler it will make your page working as standard postback page for those browsers, where Telerik RadAjax controls will fail.

.NET 1.x Framework

If you use .NET 1.x you can define a browserCaps element in you web.config file (or machine.config) for the specific browser and/or OS. It has a case element with a match property which defines the specific browser agent to search for (using regular expressions). SupportsCallbacks is not a default typed capability in this 1.x config section, but you can add your own to the section using a "capabilities" element.

See Also

External link
Browser Definition File Schema (browsers Element) in MSDN
Browser Detection using ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Keep Focus After AJAX Update

Telerik RadAjax v1.8 Send comments on this topic.
Keep Focus After AJAX Update
How-to > Keep Focus After AJAX Update

Glossary Item Box

If one needs to set the focus after AJAX update, generally manager's FocusControl(ControlID) method should be used as demonstrated in the following demo:

http://www.telerik.com/demos/aspnet/Ajax/Examples/Common/SettingFocus/DefaultCS.aspx

However, say there are two text boxes making AJAX requests (their AutoPostBack is enabled and they are linked by RadAjaxManager) so their TextChanged is fired. To keep clicked control focused (it becomes focused if there is no AJAX update), one needs to pass the focused element to the server in order to call FocusControl for that control.

Getting the focused element via JavaScript is easy with the help of document.activeElement on IE. We provide a cross-browser solution here though.

ASPX Copy Code
<input type="hidden" id="ToFocusID" runat="server" />
<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="TextBox1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1" />
<rad:AjaxUpdatedControl ControlID="TextBox2" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="TextBox2">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1" />
<rad:AjaxUpdatedControl ControlID="TextBox2" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
<ClientEvents OnRequestStart="RequestStart" />
</rad:RadAjaxManager>
<asp:TextBox ID="TextBox1" AutoPostBack="true" runat="server" OnTextChanged="TextBox1_TextChanged"></asp:TextBox>
<asp:TextBox ID="TextBox2" AutoPostBack="true" runat="server" OnTextChanged="TextBox2_TextChanged"></asp:TextBox>

JavaScript Copy Code
<script type="text/javascript">
var activeElement;
window.onload = function()
{
if(!document.activeElement)
{
var elements = document.getElementsByTagName("*");
for(var i = 0, length = elements.length; i < length; i++)
{
var element = elements[i];
element.onfocus = function()
{
activeElement = this;
}
}
}
}
function RequestStart(sender, e)
{
document.getElementById("ToFocusID").value = (activeElement)? activeElement.id : document.activeElement.id;
}
</script>

C# Copy Code
protected void TextBox1_TextChanged(object sender, EventArgs e)
{
RadAjaxManager1.FocusControl(ToFocusID.Value);
}

protected void TextBox2_TextChanged(object sender, EventArgs e)
{
RadAjaxManager1.FocusControl(ToFocusID.Value);
}

© 2002-2008 Telerik. All Rights Reserved.


How to use Css Conditional Comments with Ajax

Telerik RadAjax v1.8 Send comments on this topic.
How to use Css Conditional Comments with Ajax
How-to > How to use Css Conditional Comments with Ajax

Glossary Item Box

With the advent of Internet Explorer 7 (IE 7), there is now little choice but to create separate style sheets for different browsers, at least for a moderately complex visual design or layout. One of the approaches is to use Conditional Comments. The advantages of that are:

  • Only browsers that need (or take advantage) of the style sheets will download them;
  • The base style sheets (should) be completely standards based, serving as the foundation (i.e. any new/obscure browser has no excuse if it supports CSS);
  • No validation issues for browser specific code such as IE’s expressions, or untested CSS 3 rules.

This article explains how to take advantage of the Css conditional comments and still be able to use our ajax controls.

What the AjaxManager does, is look for link or style tags and adds them to the page on ajax request. It skips the conditional comments and therefore all styles are loaded after ajax request, no matter which browser or version it is. Unfortunately we have not found a feasible way to check for those and we cannot easily fix this problem. However we have found two workarounds for the time being which depend on the scenario, developer and his needs :

  • set the EnablePageHeadUpdate property of the ajax control to false - this way it will not update the head tag. However if you load dynamically controls with ajax, their stylesheets will not be applied in this case. This is fixable as well - you just need to manually add the stylesheet declarations for the controls on the page.
  • move the conditional comments out of the head tag. This way they will not be updated by the AjaxManager and still applied depending on the browser used. It is even valid xhtml1.1 as the html comments are skipped by the html validator i.e.:

    ASPX Copy Code
    <body>
    <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="ie6.css" />
    <![endif]-->
    <form id="form1" runat="server">

© 2002-2008 Telerik. All Rights Reserved.


Working with custom error pages

Telerik RadAjax v1.8 Send comments on this topic.
Working with custom error pages
How-to > Working with custom error pages

Glossary Item Box

This article covers the case when you are using Telerik RadAjax and you have set custom errors on in your web.config. When an error is thrown somewhere in your code, the page normally displays an javascript alert box stating that an Unexpected ajax response was received from the server. You need to ensure that this will not happen and the page will throw the error and let the .NET runtime bubble this error up to the global.asax file so the user gets redirected to the error page as set in the web.config file.

The server actually redirects to the custom error page. The browser handles that transparently (there is no way for client-side code to detect a redirect in an AJAX request) and then returns the custom error page. You should be able to confirm that with tools like Fiddler and the Firebug Firefox extension. Now the client-side code detects unexpected content and throws the error that you will see.

The solution to this would be to edit your custom error page, so that it sets the Response.RedirectLocation property to its own URL. This way, normal post-back requests will not be redirected - the server will return a 200 status code, instead of 300. AJAX requests will still have the Location HTTP header that will get picked up by Telerik RadAjax and it will redirect to the custom error page. That page will be loaded with a normal GET request and you can display the error to the user accordingly.
Generally speaking Response.RedirectLocation needs to be set unconditionally inside the OnInit event of the ErrorPage.

C# Copy Code
protected override void OnInit(EventArgs e)
{
Response.RedirectLocation = "Error.aspx";
base.OnInit(e);
}

© 2002-2008 Telerik. All Rights Reserved.


Download files with ajaxified control

Telerik RadAjax v1.8 Send comments on this topic.
Download files with ajaxified control
How-to > Download files with ajaxified control

Glossary Item Box

If you want to invoke download for a file from ajaxified control (either placed in RadAjaxPanel or ajaxified by RadAjaxManager), you cannot use the normal

C# Copy Code
Response.WriteFile("~/Your_File");
because the xmlhttp request cannot handle this.

Instead you can use the ResponseScripts collection of the ajax control to change the location header and download the file:

Example Title Copy Code
RadAjaxPanel1.ResponseScripts.Add(String.Format(@"window.location.href = ""{0}"";", http://yoursite.com/Your_File));
The ResponseScripts collection will be executed after ajax request completes.

© 2002-2008 Telerik. All Rights Reserved.


Set maximum request queue size

Telerik RadAjax v1.8 Send comments on this topic.
Set maximum request queue size
How-to > Set maximum request queue size

Glossary Item Box

The default behavior of the AJAX controls is to ignore further AJAX requests during the execution of the current request. However this might not be convenient for some applications. All AJAX controls provide a method called SetMaxRequestQueueSize(int). Using this method you can control the request queue size in RadAjaxNamespace.

By default the queueing of requests is set to queue size of 5 (five).

This setting is not persisted in ViewState and you should set it each time the Page is loaded!
C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
<AnyAjaxEnabledControl>.SetMaxRequestQueueSize(5);
}

© 2002-2008 Telerik. All Rights Reserved.


capture connection error and cancel ajax request

Telerik RadAjax v1.8 Send comments on this topic.
capture connection error and cancel ajax request
How-to > capture connection error and cancel ajax request

Glossary Item Box

RadAjax does not provide out-of-the-box support for detecting connection timeout errors. However, here is a code snippet that demonstrates how you could achieve the desired functionality through the client-side API of RadAjax:

JavaScript Copy Code
<script type="text/javascript">
var timeoutId = null;
function OnRequestStart(sender, args)
{
// set your desired timeout value here in milliseconds
var connectionTimeout = 3000; // 3sec

// get the XMLHttpRequest object
var requestInProgress = args.XMLHttpRequest;

// get the loading panel
var currentLoadingPanel = RadAjaxNamespace.LoadingPanels["<%= LoadingPanel1.ClientID %>"];

// get the updated control ID
var currentUpdatedControl = "<%= RadAjaxPanel1.ClientID %>";

// abort the request and hide the loading panel if the Ajax Request has not returned prior
// to the evaluation of the expression (that occurs after the specified number of milliseconds)
timeoutId = window.setTimeout(function()
{
requestInProgress.abort();
currentLoadingPanel.Hide(currentUpdatedControl);
alert("Connection timeout!");
}, connectionTimeout);
}

function OnResponseEnd(sender, args)
{
// clear the timeout if the request returns successfully
window.clearTimeout(timeoutId);
}
</script>

ASPX Copy Code
<rad:RadAjaxPanel ID="RadAjaxPanel1" Height="100px" Width="200px" runat="server"
ClientEvents-OnResponseEnd="OnResponseEnd" ClientEvents-OnRequestStart="OnRequestStart"
LoadingPanelID="LoadingPanel1">
<asp:Button ID="Button1" runat="server" Text="Button" OnClick="Button1_Click" />
<asp:Label ID="Label1" runat="server">
</asp:Label>
</rad:RadAjaxPanel>
<rad:AjaxLoadingPanel ID="LoadingPanel1" runat="server" Transparency="10" BackColor="Beige">
<asp:Image ID="Image1" runat="server" ImageUrl="~/RadControls/Ajax/Skins/Default/loading.gif" />
</rad:AjaxLoadingPanel>
C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
//this is to simulate 5 seconds delay from the server and is only added for the example. In your real
//life page you do not need this!!!

System.Threading.Thread.Sleep(5000);
Label1.Text = DateTime.Now.ToString();
}

When you use this approach for RadControls, you need to invoke the currentLoadingPanel.Hide() method with a slight change due to the rendering of the RadControls. The code that shows the loading panels tries to append "_wrapper" at the end of the updated controls, because all of the RadControls' html wrapper elements end in this suffix. However, the code for hiding the loading panel will not look for the wrapper suffix, which will cause a javascript error. To use the above script for RadControls please apply the following change to the Hide() method:

currentLoadingPanel.Hide(currentUpdatedControl+"_wrapper");

© 2002-2008 Telerik. All Rights Reserved.


Reinitializing global variables on ajax request

Telerik RadAjax v1.8 Send comments on this topic.
Reinitializing global variables on ajax request
How-to > Reinitializing global variables on ajax request

Glossary Item Box

When using global variables and ajax, you need to re-assign them on each request, because when RadAjax starts an Ajax request, it will dispose the old object to minimize the chance for memory leaks. If you do not reassign the global variable you will end up with the old non-functional disposed object after the ajax request returns. Here is a sample code that will share more light on the matter:

ASPX Copy Code
<body onload="documentloaded()">
<form id="form1" runat="server">
<script type="text/javascript">
var globalvar;
function documentloaded()
{
globalvar = <%= RadControl1.ClientID %>;
}
</script>

.........

</form>
</body>
[CodeBehind]

Here we reassign the global variable so the new object is available after ajax request:

C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
if (RadAjaxManager1.IsAjaxRequest)
{
RadAjaxManager1.ResponseScripts.Add( string.Format("globalvar = window['{0}']", RadControl1.ClientID));
}
}
VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
If RadAjaxManager1.IsAjaxRequest Then
RadAjaxManager1.ResponseScripts.Add( String.Format("globalvar = window['{0}']", RadControl1.ClientID))
End If
End Sub

© 2002-2008 Telerik. All Rights Reserved.


Optimizing client-side performance

Telerik RadAjax v1.8 Send comments on this topic.
Optimizing client-side performance
Performance tips and tricks > Optimizing client-side performance

Glossary Item Box

The RadAjaxManager control allows you to easily create settings that update many controls on the page. Having a large number of updated controls can both help with a performance problem by rendering smaller portions of the page and worsen the situation by triggering unnecessary DOM layout updates. Dealing with such a performance problem will require actions specific for the current scenario.

Diagnosing DOM updates as the source of a performance problem

Typically such scenarios manifest as slow client-side update time. The server-side code runs quickly and the browser takes a long time to display the updated HTML, typically peaking at 100% CPU usage. The execution time of an Ajax request can be measured by handling the OnRequestStart, OnResponseReceived, and OnResponseEnd client events:

  1. You can use OnRequestStart to measure the current time.
  2. The time between OnRequestStart and OnResponseReceived is the server render time and the network delay.
  3. The time between OnResponseReceived and OnResponseEnd is the time needed to update the DOM elements.
JavaScript Copy Code
<script type="text/javascript">
var start = null;
var received = null;
function requestStart()
{
start = new Date();
}

function responseReceived()
{
received = new Date();
}

function responseEnd()
{
var end = new Date();
document.title = "server: " + (received - start) + " client: " + (end - received) + " total: " + (end - start);
}
</script>

The typical symptom of poor client-side performance is large client time value.

Optimizing DOM updates

Most of the slowdown happens when updating multiple controls in a table element. Every DOM update triggers a set of layout recalculations that take up unneeded time. Take the following HTML for example:

ASPX Copy Code
<div id="Header" style="width: 100%;" runat="server">
<table id="Table3" cellspacing="0" cellpadding="0" border="0" width="100%">
<tr>
<td>
<asp:Label ID="lblStatus" runat="server" />
</td>
<td>&nbsp;</td>
<td style="height: 25px">
<asp:Label ID="lblMessage" runat="server" />
</td>
</tr>
</table>
</div>

Having two AjaxSetting's for both labels will cause two DOM element updates: the spans rendered by lblStatus and lblMessage respectively. This will make the browser recalculate the table size twice. The process can be optimized by updating the TABLE or the outer DIV element. Updating the Header control will update both labels and will trigger one DOM update only.

Prohibitively bad performance is usually the result of updating controls that are placed deeply inside nested tables. Most browsers are slow when rendering elements with percentage dimensions (typically width or height of 100%), so another way to optimize this is to switch to sizes in pixels. Another possible solution is to use fixed table layout by setting an HTML table's CSS style property table-layout to fixed:

CSS Copy Code
<style type="text/css">
#Header table
{
table-layout: fixed;
}
</style>

You will need to define width and <colgroup> and <col> elements for your table when using fixed table layout. Check Microsoft's HTML optimization article for other suggestions on improving page and table performance..

Other performance boosters

Having too many CSS stylesheet inclusions or too large CSS style blocks in your <head> tag can be slow to update too. You can try switching Telerik RadAjax's head update feature off if you do not load CSS-rich controls in Ajax requests. You can do that by setting the EnablePageHeadUpdate property to false.

Most browsers render documents a lot slower when operating in quirks mode. Try switching to strict mode by specifying a doctype for your document:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

© 2002-2008 Telerik. All Rights Reserved.


Known reasons for error messages

Telerik RadAjax v1.8 Send comments on this topic.
Known reasons for error messages
Troubleshooting > Known reasons for error messages

Glossary Item Box

1) Dialog with the following error:

Unexpected ajax response was received from the server.

This may be caused by one of the following reasons:

- Server.Transfer.

- Custom http handler.

- Incorrect loading of an "Ajaxified" user control.

Verify that you don't get a server-side exception or any other undesired behavior, by setting the EnableAJAX property to false.

Most often people hit this error when using Server.Transfer method. Note that some control may use this method internally (like the ASP:LoginView control).

In order to redirect to another page in AJAX-enabled application, you should use the approaches mentioned in Redirecting to another page help topic. In most cases Response.RedirectLocation does the trick. You could also check with Redirect method of RadAjax controls.

The other most possible reason is about improper loading of user controls. Our Loading user controls help topic will help you fix the error in your code.

Another scenario, when this error will be thrown, is if an AJAX request is performed from a control, part of an user control, which is just unloaded. You can use AJAX Manager ResolveUpdatedControls server-side event to handle this case.

Additionally, if the above does not help, you could disable AJAX as suggested in the error message. This will help you verify whether the error is AJAX usage related and if it is not, to fix any server-side error if such is thrown.

2) Cannot update control with ID: <specific_control_ID>. The control does not exist.

This error is thrown by RadAjaxManager when a control is added as AjaxUpdatedControl, but is not rendered on the page (control, which is initially hidden) or does not render any HTML output. In this case, RadAjaxManager cannot locate it thus throwing the error.

Put this control in an always visible control (like ASP:Panel, which Visible property is not false) and set the container control as updated in AjaxSettings instead. Note also that initially not bound controls (such as Grid) may not render any output, so that the error will appear in this case as well.

The error could also be thrown when a setting is added without the use of RadAjaxManager Designer and points to control in different naming container. In case when controls cannot be added in AJAX Manager settings through the designer, you should add them programmatically. The topic, showing how controls can be referred in MasterPage and different content place holder, could be very useful for complicated scenarios:

MasterPages: ajaxify and update controls in master and content page

3) "Object does not support this property or method"

In the present version of Telerik RadAjax, the error is thrown in a very specific case when AJAX Manager has associated "RadAjaxManager" as ID. After thorough investigation we found that fixing this very rare issue will require too much efforts and change of an internal Telerik RadAjax mechanism so that we will kindly ask our customers to simply use different ID than the problematic one.

4) RadAjaxManager causes my page to output some gibberish after update. What is going on?

The generated output looks something like this:

_RadAjaxResponseScript__RadAjaxResponseScript_

/*_Telerik_ajaxScript_*/window["RadAjaxManager1"].ControlsToUpdate = ['RadAjaxManager1', 'Panel1']; window["RadAjaxManager1"].PostbackControlIDServer = "Button1"/*_Telerik_ajaxScript_*/

We have seen this problem only when there is invalid html on the page (unclosed tags, overlapping tags etc.) Depending on the case, most of the times the browser will keep quiet and you will not know of this problem. But using the W3C validator you can locate and fix such problems. The AjaxManager is sensitive for this, because it updates parts of the page from one tag to another and when these tags are wrong, it does not know what to do and places the html returned by the xmlhttp request in the wrong place - therefore receiving parts of html in the output page.

5) The state information is invalid for this page and might be corrupted

Firefox 1.5 and up uses in-memory caching for entire Web pages, including their JavaScript states, for a single browser session. Going backward and forward between visited pages requires no page loading and the JavaScript states are preserved. This feature, referred to by some as bfcache (for "Back-Forward Cache"), makes page navigation very fast. This caching state is preserved until the user closes the browser.

Please refer to the "Ajax, ViewState and Firefox" article in this help section for more information and workaround.

© 2002-2008 Telerik. All Rights Reserved.


Most Common Mistakes

Telerik RadAjax v1.8 Send comments on this topic.
Most Common Mistakes
Troubleshooting > Most Common Mistakes

Glossary Item Box

My page went blank after I fired an event from dynamically loaded user control

This can happen of improper loading of User Controls. When loading user controls you need to have in mind two things:

  1. Always recreate the last loaded User Control on Page_Init/Page_Load
  2. Assign unique IDs to the loaded controls

If the page goes blank please check if the control is always recreated.

Lost ViewState

After postback/ajax request my control does not keep its last state. This can happen if you are loading user controls and you do not assign Unique IDs to them. In this case the framework will generate an automatic ID which can be different than the original ID and therefore the ViewState is being lost. This is the cause for losing the last state of the control.

Postback Events not being fired

After dynamically loading User Control I cannot fire the events of any of its controls:
This is caused by improper loading as well. If the control is persisted on the page, but its events are not fired - check if you have assigned an ID to this control. This is required by the framework to preserve the ViewState and handle the control events.

Updating controls that do not render any html output

In order to update controls with AJAX, you have to make sure that they DO render on the page and if this is met - check that they are rendered as single html element. Common mistake is to try to update a PlaceHolder in order to ajaxify the controls in it. You should simply place an asp:Panel within it and update the panel instead. Other ASP controls which do not render any HTML on the page are Repeater and Literal controls.

Showing/Hiding controls with ajax

The visibility of controls is best controlled during the ajax request if they are placed inside a control on the page that is always visible. Here are the exact steps:

  1. Place the control in an element which is always visible, such as a Panel, an AJAX Panel or a DIV.
  2. Add this visible control to the AJAX pairs where the AJAX initiator control should update the visible control.
  3. Change the Visible property of the control you want to hide/show.

Loading Panel does not display (UserControl with dynamically created controls scenario)

Problem: I have a user control that is populated with dynamically created controls. After I have ajax-enabled the user control with RadAjaxPanel (RadAjaxManager) the loading panel I have specified does not display at all when any of the dynamically created controls triggers the Ajax request (though the Ajax request itself is completed successfully and the content is updated).

Solution: The most likely reason for this behavior is missing ID for the dynamically created controls. Please make sure you are assigning an ID to the controls and you should experience no further problems.

© 2002-2008 Telerik. All Rights Reserved.


Ajaxified control still postbacks

Telerik RadAjax v1.8 Send comments on this topic.
Ajaxified control still postbacks
Troubleshooting > Ajaxified control still postbacks

Glossary Item Box

Symptom: You have added AjaxSetting for a control to be ajaxified, but it still makes regular postbacks.

You may have:

1) AjaxSettings defined in ASPX

Please, verify whether the control ID matches completely in correspondent AjaxSetting. You may check whether AJAX Manager designer shows your control as ajaxified, which will ensure that the manager will find and ajaxify this control at runtime.

2) AjaxSettings defined in the code-behind.

Check if you are adding your AjaxSettings on any control's event-handler? AjaxSettings are not preserved in the ViewState so you have to add them on each PageLoad. In cases like this you may find your "ajaxified" control making postback on the first try.

© 2002-2008 Telerik. All Rights Reserved.


Control is not updated after AJAX

Telerik RadAjax v1.8 Send comments on this topic.
Control is not updated after AJAX
Troubleshooting > Control is not updated after AJAX

Glossary Item Box

You have added the necessary AJAX settings, but the control is not updated as expected. There are several possible reasons for this in cases when RadAjaxManager is used:

1) First of all, you should check whether the control is updated without using AJAX.

Just set EnableAJAX property of RadAjaxManager to false and verify your control is updated using regular postbacks. Note in most cases the AJAX initiator control (the one set as ajaxified) will need to post back to the server, so the Ajax Manager will be able to "tranform" its postbacks to AJAX requests.

2) You should verify whether the proper AJAX initiator control is set and an user interaction concerning this control updates the one, set as AJAX updated control.

For instance, confusion may come when using AjaxRequestWithTarget client-side function. There, the AJAX initiator is the control, which UniqueID is set as the eventTarget argument of the function, which may not be (as is the purpose of this function) RadAjaxPanel or RadAjaxManager controls. On the other hand when one updates a control in AjaxRequest server side for example, the AJAX initiator should be RadAjaxManager itself.

3) Check whether you don't try to ajaxify control placed in RadAjaxPanel using the RadAjaxManager.

For instance, if you have placed a button in RadAjaxPanel and want the button to update control outside of the AJAX Panel, it won't be updated despite the AJAX Manager's AJAX Settings. RadAjaxPanel precedes RadAjaxManager so the Panel will make the AJAX requests updating its content only (as this is the way that the control is designed).

4) You have ajaxified container control (like ASP:Panel) and also want to ajaxify control inside it.

Note, this can't be achieved using RadAjaxManager designer. If you have added such settings manually, indeed some of them won't work. Here is an example where a button is expected to update two labels:

ASPX Copy Code
<asp:Panel ID="Panel1" runat="server" Height="51px" Width="287px">
<asp:Button ID="Button1" runat="server" Text="Button" OnClick="Button1_Click" />
<asp:Label ID="Label1" runat="server" Text="1" Height="18px" Width="224px"></asp:Label>
</asp:Panel>

<asp:Label ID="Label2" runat="server" Text="2" />

<rad:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Panel1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label2" />
</UpdatedControls>
</rad:AjaxSetting>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

Here only one label will be updated, because only one of these settings will be taken by the Manager. RadAjaxManager designer won't allow adding the second setting and you may simply use only one AjaxControlID (Panel1 or Button1) to achieve your goal:

ASPX Copy Code
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label2" />
<rad:AjaxUpdatedControl ControlID="Label1" />
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>

5) Using two RadAjaxManager controls - one in a web user control.

Note, in case of WebUserControl containing a second RadAjaxManager, if you have ajaxified a panel for instance, which contains the user control, those controls inside it are already ajaxified. The second AJAX Manager will find them already ajaxified and won't do the expected updates.

Both managers will work correctly as long as they don't mess each other. Of course, one could also use a single RadAjaxManager for ajaxifying and updating controls both in the main page as well as in the user control. More on the matter can be found here.

A sample following this approach is posted from Telerik, attached in this forum thread.

© 2002-2008 Telerik. All Rights Reserved.


AJAX And File Upload

Telerik RadAjax v1.8 Send comments on this topic.
AJAX And File Upload
Troubleshooting > AJAX And File Upload

Glossary Item Box

You may experience difficulties trying to upload files with ajaxified controls. For example using the standard <INPUT type=file> on AJAX request the uploaded files items will be empty.

Indeed, there are browser restrictions and XmlHttpRequest object limitations which makes uploading files through AJAX requests impossible. Thus, if you want to use Telerik RadAjax controls with a page, where a control perform uploading files, this control should make regular post-backs instead.

In a typical scenario you may have the whole page (or a part of it) nested within an AJAX Panel. In this case you have to manually exclude from ajaxifying the control, which is implemented to upload files. Detailed information how this could be achieved may be found here.

Using AJAX Manager in a page, where files are uploaded, should not be a problem. You should only take care of not setting the correspondent control as ajaxified in Manager's AjaxSettings.

A working application of Uploading Files could be found in Telerik RadAjax live examples:

http://www.telerik.com/demos/aspnet/Ajax/Examples/Common/FileUpload/DefaultCS.aspx

An integration AJAX Telerik RadUpload example is also available online:

http://www.telerik.com/demos/aspnet/Controls/Examples/Integration/Ajax/Upload/DefaultCS.aspx

When you instantiate file upload control through ajax call (e.g. set Visible="true" or control is nested in template control) you will need to manually add enctype="multipart/form-data" to the form as our ajax controls (MS Ajax as well) do not update the form tag.

© 2002-2008 Telerik. All Rights Reserved.


Back and Forward browser buttons do not work properly

Telerik RadAjax v1.8 Send comments on this topic.
Back and Forward browser buttons do not work properly
Troubleshooting > Back and Forward browser buttons do not work properly

Glossary Item Box

The ajax controls are using xmlhttp requests which update silently parts of the page. The browser Back and Forward functionality is only available when a full postback has occurred and that is the reason for them not to remember the last page state after ajax request. This is the only "disadvantage" from user usability point of view. Currently there are no flexible workarounds for this limitation, but our devs are researching on the matter and we hope to provide a solution.

© 2002-2008 Telerik. All Rights Reserved.


Dropped Ajax requests from child window

Telerik RadAjax v1.8 Send comments on this topic.
Dropped Ajax requests from child window
Troubleshooting > Dropped Ajax requests from child window

Glossary Item Box

In Internet Explorer, windows opened using window.open from another window, exist in the same thread as the parent window. This is not true for Mozilla and Safari as there all child windows are opened in different threads. Thus when you initiate an ajax request in the child window and close this window it will be aborted in Mozilla, because closing it you actually destroy the thread which is running the ajax request. This workd in IE, because the child window runs in the same thread as the parent and it does not destroy it when it closes.

To resolve this issue you need to create ajax requests in the context of the parent window and apply a slight timeout on it:

JavaScript Copy Code
<script type="text/javascript">
            function OnClickHandler()
            {
                var thisWindow = window;
                var parentWindow = window.opener;
                parentWindow.setTimeout(function() { UpdateData(thisWindow, parentWindow) } , 0);
            }

            //this is executed in the parent window context
            function UpdateData(childWindow, parentWindow)
            {
                var radAjaxManagerObject = parentWindow["RadAjaxManager1"];
                radAjaxManagerObject.AjaxRequest(params);
                childWindow.close();
            }
</script>

The same goes when using our Telerik RadWindow control. You still need to force the execution in the parentWindow, as otherwise the request will be canceled, once the window is closed:

JavaScript Copy Code
<script type="text/javascript">
//This code is mandatory if any interaction with the "parent" RadWindow object is needed
function GetRadWindow()
{
var oWindow = null;
if (window.radWindow) oWindow = window.radWindow;
else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;
return oWindow;
}

function Cancel_Clicked()
{
GetRadWindow().Close();
}

function DoParentCallback()
{
var parentWindow = window.parent;
parentWindow.setTimeout( function()
{
var radAjaxManagerObject = parentWindow["RadAjaxManager1"];
radAjaxManagerObject.AjaxRequest();
} , 0);

Cancel_Clicked();
}
</script>

Note that we use setTimeout to force execution in the parentWindow's context as it will not get closed. Another thing to keep in mind is that one should not reference the child window in your setTimeout-invoked code as it might have already been destroyed.

© 2002-2008 Telerik. All Rights Reserved.


AJAX and ASP:Menu

Telerik RadAjax v1.8 Send comments on this topic.
AJAX and ASP:Menu
Troubleshooting > AJAX and ASP:Menu

Glossary Item Box

Unfortunately updating ASP:Menu control via AJAX is not possible. This is due to the way the scripts of menu control are rendered - it just does not fulfill the requirements of updating any controls via AJAX.

Instead, you can use RadMenu control, which contains many more features and its integration with Telerik RadAjax controls is thoroughly tested. You can review its online demos as well as its documentation.

© 2002-2008 Telerik. All Rights Reserved.


Ajax, ViewState, and Firefox

Telerik RadAjax v1.8 Send comments on this topic.
Ajax, ViewState, and Firefox
Troubleshooting > Ajax, ViewState, and Firefox

Glossary Item Box

Firefox 1.5 and up uses in-memory caching for entire Web pages, including their JavaScript states, for a single browser session. Going backward and forward between visited pages requires no page loading and the JavaScript states are preserved. This feature, referred to by some as bfcache (for "Back-Forward Cache"), makes page navigation very fast. This caching state is preserved until the user closes the browser.

However, this Firefox feature caches the page viewstate field as well thus breaking the asynchronous postback calls to the server in some scenarios (page refreshes, Back button navigation). For example the problem is evident if you refresh a page in Firefox with the F5 button and not with the Ctrl+F5 combination (the former does not clear the form values, whereas the latter does clear them) and then try to perform an Ajax request. The result you would most certainly get is a "The state information is invalid for this page and might be corrupted" page exception.

The Mozilla Development Center states that setting cache-control: no-store in the response header of the page prevents Firefox from caching the page so you could use the following code snippet to add a cache-control: no-store response header to any page requested by any browser that is not Internet Explorer:

C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
if (Request.Browser.MSDomVersion.Major == 0) // Non IE Browser?)
{
Response.Cache.SetNoStore(); // No client side cashing for non IE browsers
}
}
VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
' Non IE Browser?
If (Request.Browser.MSDomVersion.Major = 0) Then
Response.Cache.SetNoStore() ' No client side cashing for non IE browsers
End If
End Sub

© 2002-2008 Telerik. All Rights Reserved.


Client-Side API
See Also
Client-side > Client-Side API

Glossary Item Box

At client-side you can execute your own JavaScript functions at certain stages of the AJAX request. Additionally you can use a generic JavaScript function to make explicit AJAX requests to the server from the client.

You can construct the javascript function calls manually or alternatively use the server-side method GetAjaxEventReference and have Telerik RadAjax generate the necessary code for you.

Client-side API

AjaxRequest(arguments)

The AjaxRequest(arguments) function, is used to initiate a generic AJAX request. When using this function the event target defaults to the RadAjaxPanel or RadAjaxManager instance.

<%=AjaxManager1.ClientID%>.AjaxRequest(arguments)

arguments The parameters, which the control had used when it raised the request

AjaxRequest event

When it is called on the client it can be handled in the AjaxRequest event handler on the server:

JavaScript Copy Code
function InitiateAjaxRequest(arguments)
{
var ajaxManager = <%= RadAjaxManager1.ClientID %>;
ajaxManager.AjaxRequest(arguments);
}
And in the code-behind:
C# Copy Code
private void RadAjaxManager1_AjaxRequest(object sender, AjaxRequestEventArgs e)
{
//code to handle the generic AJAX request
}
VB.NET Copy Code
Private Sub RadAjaxManager1_AjaxRequest(ByVal sender As Object, ByVal e As AjaxRequestEventArgs) Handles RadAjaxManager1.AjaxRequest
'code to handle the generic AJAX request
End Sub

When an AJAX request is triggered using AjaxRequest function from the client, the AJAX Manager itself should be set as the AJAX initiator updating the corresponding control like this:

ASPX Copy Code
<rad:RadAjaxManager id="RadAjaxManager1" runat="server" OnAjaxRequest="AjaxManager_AjaxRequest">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="RadAjaxManager1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1"></rad:AjaxUpdatedControl>
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

AjaxRequestWithTarget(eventTarget, eventArgument)

The AjaxRequestWithTarget(eventTarget, eventArgument) function can be called to simulate a postback/AJAX request send by other control (besides AjaxManager or AjaxPanel) with the specified UniqueID and specified arguments. Its execution can be handled by the correspondent event (i.e. Button_Click) on the server.

__doPostBack(eventTarget, eventArgument) or <%=AjaxPanel1.ClientID%>.AjaxRequestWithTarget(eventTarget, eventArgument)
eventTarget | The control which should raise postback event. You should always use the control's UniqueID.
eventArgument | This is optional argument for the event

Note: AjaxRequestWithTarget is designed as a substitute of the standard __doPostBack function. Thus, you need to override RaisePostBackEvent

of the page in order to get its argument server-side.

Here is an example how to use AjaxRequestWithTarget:

ASPX Copy Code
<input type="button" onclick="AjaxRequestButton(); return false;" value="AjaxButton">
<asp:Button id="Button1" runat="server" Text="Button" OnClick="Button1_Click"></asp:Button>
<asp:TextBox id="TextBox1" runat="server" Text=""></asp:TextBox>
<rad:RadAjaxManager id="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="TextBox1"></rad:AjaxUpdatedControl>
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>
JavaScript Copy Code
function AjaxRequestButton(arguments)
{
var ajaxManager = <%= RadAjaxManager1.ClientID %>;
ajaxManager.AjaxRequestWithTarget('<%= Button1.UniqueID %>', '');
}

And in the code-behind:

C# Copy Code
protected void Button1_Click(object sender, System.EventArgs e)
{
TextBox1.Text = DateTime.Now.ToLongTimeString();
}
Example Title Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
TextBox1.Text = DateTime.Now
End Sub
You can see the working example by following this link:

http://www.telerik.com/demos/aspnet/Ajax/Examples/Manager/ClientSideAPI/DefaultCS.aspx

See Also

AJAX Controls
AJAX Panel
AJAX Manager

Server-side API
AjaxRequest Event

© 2002-2008 Telerik. All Rights Reserved.


OnRequestStart

Telerik RadAjax v1.8 Send comments on this topic.
OnRequestStart
See Also
Client-side > Client-side Events > OnRequestStart

Glossary Item Box

Fired by

This event is fired when a request to the server is started.

Arguments

sender - this is the instance of the client-side RadAjaxManager/RadAjaxPanel object
arguments

- arguments.XMLHttpRequest - get the XMLHttpRequest object. You can cancel it with xmlHttpRequest.abort();
- arguments.EventTarget - the UniqueID of the element that had raised the request
- arguments.EventArgument - the second parameter of the original __doPostback function
- arguments.EventTargetElement - an instance of the client-side object that had raised the AJAX request
- arguments.EnableAjax - an AJAX request is performed if this is true. Otherwise a normal post-back is performed.

Can be canceled

Yes, return false.

If you want to perform post-back instead of AJAX request, arguments.EnableAjax should be false.

Example

In the example shown below, the JavaScript function is defined in the html form. To execute them you should then set the corresponding ClientEvent property to the name of the JavaScript function.

The javascript function for implementing the OnRequestStart event looks like this:

ASPX Copy Code
<script type="text/javascript">

function onRequestStart(sender, arguments)
{
alert( 'AJAX request has just started.');
};

<rad:RadAjaxManager id="RadAjaxManager1" runat="server">
<ClientEvents OnRequestStart="onRequestStart"></ClientEvents>
</rad:RadAjaxManager>

Remarks

Telerik RadAjax controls provide client events which allow you to execute JavaScript code on the client at different stages of the AJAX request. This functionality gives you more flexibility in completing complex tasks in your project.

To implement this functionality, you need to define the custom JavaScript functions you want to use, and then call them from code-behind using the ClientEvents property of the control.

See Also

Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


OnRequestSent

Telerik RadAjax v1.8 Send comments on this topic.
OnRequestSent
See Also
Client-side > Client-side Events > OnRequestSent

Glossary Item Box

Fired by

This event is fired when a request is sent to the server.

Arguments

sender - this is the instance of the client-side RadAjaxManager/RadAjaxPanel object
arguments
 - arguments.EventTarget - the UniqueID of the element that had raised the request
- arguments.EventArgument - the second parameter of the original __doPostback function
- arguments.EventTargetElement - an instance of the client-side object that had raised the callback request

Can be canceled

No

Example

The javascript function for implementing the OnRequestSent event looks like this:

ASPX/ASCX Copy Code
<script type="text/javascript">
function onRequestSent(sender, arguments)
{
alert( "AJAX request has been sent.");
};
</script>

<rad:RadAjaxPanel ID="RadAjaxPanel1" runat="server" ClientEvents-OnRequestSent="onRequestSent"
Height="200px" Width="300px">
</rad:RadAjaxPanel>
Remarks

Telerik RadAjax controls provide client events which allow you to execute JavaScript code on the client at different stages of the AJAX request. This functionality gives you more flexibility in completing complex tasks in your project.

To implement this functionality, you need to define the custom JavaScript functions you want to use, and then call them from code-behind using the ClientEvents property of the control.

See Also

Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


OnResponseReceived

Telerik RadAjax v1.8 Send comments on this topic.
OnResponseReceived
See Also
Client-side > Client-side Events > OnResponseReceived

Glossary Item Box

Fired by

This event is fired when a response is received from the server.

Arguments

sender - this is the instance of the client-side RadAjaxManager/RadAjaxPanel object
arguments
 - arguments.EventTarget - the UniqueID of the element that had raised the request
- arguments.EventArgument - the second parameter of the original __doPostback function
- arguments.EventTargetElement - an instance of the client-side object that had raised the AJAX request
- arguments.ResponseText - the response (HTML output) returned from the server after the AJAX update. This is added for debugging purposes only -- you can examine what exactly is the output returned from the server before processing it on the client (newly rendered page).

Can be canceled

No

Example

In the example shown below, the JavaScript function is defined in the html form. To execute them you should then set the corresponding ClientEvent property to the name of the JavaScript function.

The javascript function for implementing the OnReponseReceived event looks like this:

ASPX/ASCX Copy Code
<script type="text/javascript">
function onResponseReceived(sender, arguments)
{
alert('Response was just received but not processed');
alert('Script to be processed: ' + arguments.ResponseText);
}
</script>

<rad:RadAjaxManager id="RadAjaxManager1" runat="server">
<ClientEvents OnResponseReceived="onResponseReceived"></ClientEvents>
</rad:RadAjaxManager>
Remarks

Telerik RadAjax controls provide client events which allow you to execute JavaScript code on the client at different stages of the AJAX request. This functionality gives you more flexibility in completing complex tasks in your project.

To implement this functionality, you need to define the custom JavaScript functions you want to use, and then call them from code-behind using the ClientEvents property of the control.

See Also

Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


OnResponseEnd

Telerik RadAjax v1.8 Send comments on this topic.
OnResponseEnd
See Also
Client-side > Client-side Events > OnResponseEnd

Glossary Item Box

Fired by

This event is fired when a response from the server is processed.

Arguments

sender - this is the instance of the client-side RadAjaxManager/RadAjaxPanel object
arguments
 - arguments.EventTarget - the UniqueID of the element that had raised the request
- arguments.EventArgument - the second parameter of the original __doPostback function
- arguments.EventTargetElement - an instance of the client-side object that had raised the callback request

Can be canceled

No

Example

In the example shown below, the JavaScript function is defined in the html form. To execute them you should then set the corresponding ClientEvent property to the name of the JavaScript function.

The javascript function for implementing the OnReponseEnd event looks like this:

ASPX/ASCX Copy Code
<script type="text/javascript">
function onResponseEnd(sender, arguments)
{
alert( 'Callback request is completed. Response is processed.');
};
<rad:RadAjaxPanel ID="RadAjaxPanel1" runat="server" ClientEvents-OnResponseEnd="onResponseEnd"
Height="200px" Width="300px">
</rad:RadAjaxPanel>
Remarks

Telerik RadAjax controls provide client events which allow you to execute JavaScript code on the client at different stages of the AJAX request. This functionality gives you more flexibility in completing complex tasks in your project.

To implement this functionality, you need to define the custom JavaScript functions you want to use, and then call them from code-behind using the ClientEvents property of the control.

See Also

Client-Side API

© 2002-2008 Telerik. All Rights Reserved.


Pass more than one argument

Telerik RadAjax v1.8 Send comments on this topic.
Pass more than one argument
Client-side > Client-side How-To > Pass more than one argument

Glossary Item Box

By default the AjaxRequest and AjaxRequestWithTarget functions accept only one argument. Sometimes one might need to pass more arguments - this can be achieved by joining the arguments on the client:

[Javascript]

JavaScript Copy Code
var arg3 = arg1 + "," + arg2;

ajaxManager.AjaxRequest(arg3);
and split them on the server in the AjaxManager_AjaxRequest:
C# Copy Code
private void RadAjaxManager1_AjaxRequest(object sender, AjaxRequestEventArgs e)
{
string argument = (e.Argument);
String[] stringArray = argument.Split(",".ToCharArray());
}
VB.NET Copy Code
Protected Sub RadAjaxManager1_AjaxRequest(ByVal sender As Object, ByVal e As Telerik.WebControls.AjaxRequestEventArgs) Handles RadAjaxManager1.AjaxRequest
Dim argument As String = e.Argument
Dim stringArray As [String]() = argument.Split(",".ToCharArray())
End Sub
Online example showing this in action is available here.

© 2002-2008 Telerik. All Rights Reserved.


Change mouse cursor on AJAX update

Telerik RadAjax v1.8 Send comments on this topic.
Change mouse cursor on AJAX update
Client-side > Client-side How-To > Change mouse cursor on AJAX update

Glossary Item Box

Changing the mouse cursor on Ajax update could be achieved using the client-side event of Telerik RadAjax controls. The easiest way is to use the following events script:

JavaScript Copy Code
function OnRequestStart(sender, args)
{
document.body.style.cursor = "wait";
};

function OnResponseEnd(sender, args)
{
document.body.style.cursor = "default";
};

Here is another solution using additional CSS classes:

JavaScript Copy Code
<script type="text/javascript">
function RequestStart(sender, args)
{
document.body.className = document.body.className.replace("Normal", "Wait");
}
function ResponseEnd(sender, args)
{
document.body.className = document.body.className.replace("Wait", "Normal");
}
</script>
JavaScript Copy Code
<script type="text/javascript">
function RequestStart(sender, args)
{
document.body.className = document.body.className.replace("Normal", "Wait");
}
function ResponseEnd(sender, args)
{
document.body.className = document.body.className.replace("Wait", "Normal");
}
</script>

CSS Copy Code
<style type="text/css">
.Wait
{
}

.Normal
{
}

/* override input cursors with a more specific CSS selector */
.Wait INPUT
{
cursor: wait;
}

.Normal INPUT
{
cursor: default;
}

/* override grid cursors with a more specific CSS selector */
.Wait TABLE
{
cursor: wait;
}

.Normal TABLE
{
cursor: default;
}
</style>

© 2002-2008 Telerik. All Rights Reserved.


AjaxClientEvents Class

RadAjax Send comments on this topic.
AjaxClientEvents Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxClientEvents Class

The following client events are available:

  • OnRequestStart
  • OnRequestSent
  • OnResponseReceived
  • OnResponseEnd

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxClientEvents
   Inherits AjaxObjectWithState
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
C#
public class AjaxClientEvents : AjaxObjectWithState

Inheritance Hierarchy

System.Object
Telerik.WebControls.AjaxObjectWithState
Telerik.WebControls.AjaxClientEvents

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxClientEvents Class Members

AjaxClientEvents Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : AjaxClientEvents Class

The following tables list the members exposed by AjaxClientEvents.

Public Constructors

 | Name | Description
Public Constructor | AjaxClientEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnRequestError | This client-side event is fired when asynchronous request is finished.
Public Property | OnRequestSent |
Public Property | OnRequestStart |
Public Property | OnResponseEnd |
Public Property | OnResponseReceived |
Public Property | ViewState | (Inherited from AjaxObjectWithState)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AjaxObjectWithState)
Top

See Also

Reference

AjaxClientEvents Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxClientEvents Constructor

AjaxClientEvents Constructor
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : AjaxClientEvents Constructor

OwnerStateBag

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal OwnerStateBag As StateBag _
)
Visual Basic (Usage) Copy Code
Dim OwnerStateBag As StateBag

Dim instance As AjaxClientEvents(OwnerStateBag)
C#
public AjaxClientEvents(
   StateBag OwnerStateBag
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal OwnerStateBag As StateBag _
)
Visual Basic (Usage) Copy Code
Dim OwnerStateBag As StateBag

Dim instance As AjaxClientEvents(OwnerStateBag)
C#
public AjaxClientEvents(
   StateBag OwnerStateBag
)

Parameters

OwnerStateBag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


AjaxClientEvents Class Properties

AjaxClientEvents Class Properties
[image]
Telerik.WebControls Namespace : AjaxClientEvents Class

For a list of all members of this type, see AjaxClientEvents members.

Public Properties

 | Name | Description
Public Property | OnRequestError | This client-side event is fired when asynchronous request is finished.
Public Property | OnRequestSent |
Public Property | OnRequestStart |
Public Property | OnResponseEnd |
Public Property | OnResponseReceived |
Public Property | ViewState | (Inherited from AjaxObjectWithState)
Top

See Also

Reference

AjaxClientEvents Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


OnRequestError Property

OnRequestError Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : OnRequestError Property

This client-side event is fired when asynchronous request is finished.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OnRequestError As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

instance.OnRequestError = value

value = instance.OnRequestError
C#
public virtual string OnRequestError {get; set;}

Remarks

This client-side event is fired when the server returns status different from '200 OK'. RadAjaxManager/RadAjaxPanel.OnRequestError can be used for various purposes such redirects, permissions checks, etc.

Fired by | RadAjaxManager/RadAjaxPanel
Arguments | Error object
Can be canceled | Yes, return false to cancel
Examples | ascx/aspx <ClientEvents-OnRequestError="RequestError" ... JavaScript <script> function RequestError(sender, e) { alert("Status code: " + e.Status); alert("ResponseText: " + e.ResponseText); alert("ResponseHeaders: " + e.ResponseHeaders); } </script>

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


OnRequestSent Property

OnRequestSent Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : OnRequestSent Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OnRequestSent As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

instance.OnRequestSent = value

value = instance.OnRequestSent
C#
public virtual string OnRequestSent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


OnRequestStart Property

OnRequestStart Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : OnRequestStart Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OnRequestStart As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

instance.OnRequestStart = value

value = instance.OnRequestStart
C#
public virtual string OnRequestStart {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


OnResponseEnd Property

OnResponseEnd Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : OnResponseEnd Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OnResponseEnd As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

instance.OnResponseEnd = value

value = instance.OnResponseEnd
C#
public virtual string OnResponseEnd {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


OnResponseReceived Property

OnResponseReceived Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : OnResponseReceived Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OnResponseReceived As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

instance.OnResponseReceived = value

value = instance.OnResponseReceived
C#
public virtual string OnResponseReceived {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Class

AjaxLoadingPanel Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxLoadingPanel Class

This class represents a panel that will be used as a progress indicator during an AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxLoadingPanel
   Inherits Panel
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
C#
public class AjaxLoadingPanel : Panel

Example

<rad:AjaxLoadingPanel id="LoadingPanel1" runat="server">
<img id=Img1 alt="" src="~/Img/Loading.gif" runat="server" />
</rad:AjaxLoadingPanel>

Remarks

The AjaxLoadingPanel's contents will be displayed instead the updated controls, so that users are aware what controls will get updated. You can have the Loading Panel shown on a predefined location if you set its IsSticky property.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Panel
Telerik.WebControls.AjaxLoadingPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Class Members

AjaxLoadingPanel Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : AjaxLoadingPanel Class

The following tables list the members exposed by AjaxLoadingPanel.

Public Constructors

 | Name | Description
Public Constructor | AjaxLoadingPanel Constructor | The default constructor for the AjaxLoadingPanel class.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialDelayTime | Gets or sets a value specifying the delay in milliseconds, after which the AjaxLoadingPanel will be shown. If the request returns before this time, the AjaxLoadingPanel will not be shown.
Public Property | IsSticky | The IsSticky property of the Loading Panel controls where the panel will appear during the AJAX request. If this property is set to true, the panel will appear where you have placed it on your webform. If this property is set to false, the Loading panel will appear on the place of the updated control(s). By default this property is set to false.
Public Property | MinDisplayTime | Gets or sets a value that specifies the minimum time in milliseconds that the AjaxLoadingPanel will last. The control will not be updated before this period has passed even if the request returns. This will ensure more smoother interface for your page.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | Relative path to RadControls folder.
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Transparency | Gets or sets transparency in percentage. Default value is 0 percents.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.Panel)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.Panel)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxLoadingPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Constructor

AjaxLoadingPanel Constructor
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : AjaxLoadingPanel Constructor

The default constructor for the AjaxLoadingPanel class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel()
C#
public AjaxLoadingPanel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel()
C#
public AjaxLoadingPanel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Class Properties

AjaxLoadingPanel Class Properties
[image]
Telerik.WebControls Namespace : AjaxLoadingPanel Class

For a list of all members of this type, see AjaxLoadingPanel members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialDelayTime | Gets or sets a value specifying the delay in milliseconds, after which the AjaxLoadingPanel will be shown. If the request returns before this time, the AjaxLoadingPanel will not be shown.
Public Property | IsSticky | The IsSticky property of the Loading Panel controls where the panel will appear during the AJAX request. If this property is set to true, the panel will appear where you have placed it on your webform. If this property is set to false, the Loading panel will appear on the place of the updated control(s). By default this property is set to false.
Public Property | MinDisplayTime | Gets or sets a value that specifies the minimum time in milliseconds that the AjaxLoadingPanel will last. The control will not be updated before this period has passed even if the request returns. This will ensure more smoother interface for your page.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | Relative path to RadControls folder.
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Transparency | Gets or sets transparency in percentage. Default value is 0 percents.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

See Also

Reference

AjaxLoadingPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


InitialDelayTime Property

InitialDelayTime Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : InitialDelayTime Property

Gets or sets a value specifying the delay in milliseconds, after which the AjaxLoadingPanel will be shown. If the request returns before this time, the AjaxLoadingPanel will not be shown.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialDelayTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As Integer

instance.InitialDelayTime = value

value = instance.InitialDelayTime
C#
public int InitialDelayTime {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


IsSticky Property

IsSticky Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : IsSticky Property

The IsSticky property of the Loading Panel controls where the panel will appear during the AJAX request. If this property is set to true, the panel will appear where you have placed it on your webform. If this property is set to false, the Loading panel will appear on the place of the updated control(s).

By default this property is set to false.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSticky As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As Boolean

instance.IsSticky = value

value = instance.IsSticky
C#
public bool IsSticky {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


MinDisplayTime Property

MinDisplayTime Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : MinDisplayTime Property

Gets or sets a value that specifies the minimum time in milliseconds that the AjaxLoadingPanel will last. The control will not be updated before this period has passed even if the request returns. This will ensure more smoother interface for your page.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property MinDisplayTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As Integer

instance.MinDisplayTime = value

value = instance.MinDisplayTime
C#
public int MinDisplayTime {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : RadControlsDir Property

Relative path to RadControls folder.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


Transparency Property

Transparency Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : Transparency Property

Gets or sets transparency in percentage. Default value is 0 percents.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property Transparency As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As Integer

instance.Transparency = value

value = instance.Transparency
C#
public int Transparency {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > AjaxLoadingPanel Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxLoadingPanel
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxLoadingPanel Class
AjaxLoadingPanel Members

© telerik 2002-2008. All Rights Reserved.


AjaxRequestEventArgs Class

AjaxRequestEventArgs Class
See Also Members Example
[image]
Telerik.WebControls Namespace : AjaxRequestEventArgs Class

A class containing the AJAX event arguments during an AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxRequestEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As AjaxRequestEventArgs
C#
public class AjaxRequestEventArgs : EventArgs

Example

C# Copy Code
//ASPX

 &lt;INPUT type="button" value="Button" onclick="window['&lt;%= RadAjaxManager1.ClientID %&gt;'].AjaxRequest();"&gt;

 //Server Side Code
private void RadAjaxManager1_AjaxRequest(object sender, Telerik.WebControls.AjaxRequestEventArgs e)
{
   //Code Handler using AjaxRequestEventArgs....
}

Visual Basic Copy Code
'ASPX
<Input Type="button" value="Button" onclick="window['<%= RadAjaxManager1.ClientID %>'].AjaxRequest();">

'Server Side Code
Private Sub RadAjaxManager1_AjaxRequest(ByVal sender As Object, ByVal e As Telerik.WebControls.AjaxRequestEventArgs)
    'Code Handler using AjaxRequestEventArgs....
End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.AjaxRequestEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxRequestEventArgs Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxRequestEventArgs Class Members

AjaxRequestEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : AjaxRequestEventArgs Class

The following tables list the members exposed by AjaxRequestEventArgs.

Public Constructors

 | Name | Description
Public Constructor | AjaxRequestEventArgs Constructor | Creates a new instance of the AsyncRequestEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Argument | Returns the name of the AJAX request event.
Top

See Also

Reference

AjaxRequestEventArgs Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxRequestEventArgs Constructor

AjaxRequestEventArgs Constructor
[image]
Telerik.WebControls Namespace > AjaxRequestEventArgs Class : AjaxRequestEventArgs Constructor

argument
Creates a new instance of the AsyncRequestEventArgs class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal argument As String _
)
Visual Basic (Usage) Copy Code
Dim argument As String

Dim instance As AjaxRequestEventArgs(argument)
C#
public AjaxRequestEventArgs(
   string argument
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal argument As String _
)
Visual Basic (Usage) Copy Code
Dim argument As String

Dim instance As AjaxRequestEventArgs(argument)
C#
public AjaxRequestEventArgs(
   string argument
)

Parameters

argument

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxRequestEventArgs Class
AjaxRequestEventArgs Members

© telerik 2002-2008. All Rights Reserved.


AjaxRequestEventArgs Class Properties

AjaxRequestEventArgs Class Properties
[image]
Telerik.WebControls Namespace : AjaxRequestEventArgs Class

For a list of all members of this type, see AjaxRequestEventArgs members.

Public Properties

 | Name | Description
Public Property | Argument | Returns the name of the AJAX request event.
Top

See Also

Reference

AjaxRequestEventArgs Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Argument Property

Argument Property
[image]
Telerik.WebControls Namespace > AjaxRequestEventArgs Class : Argument Property

Returns the name of the AJAX request event.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Argument As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxRequestEventArgs
Dim value As String

value = instance.Argument
C#
public string Argument {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxRequestEventArgs Class
AjaxRequestEventArgs Members

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Class

AjaxSetting Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxSetting Class

Represents a single AjaxManager setting - a mapping between a control that initiates an AJAX request and a collection of controls to be updated by the operation.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxSetting
Visual Basic (Usage) Copy Code
Dim instance As AjaxSetting
C#
public class AjaxSetting

Inheritance Hierarchy

System.Object
Telerik.WebControls.AjaxSetting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Class Members

AjaxSetting Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : AjaxSetting Class

The following tables list the members exposed by AjaxSetting.

Public Constructors

 | Name | Description
Public Constructor | AjaxSetting Constructor | Overloaded. Default constructor for the AjaxSetting class.
Top

Public Properties

 | Name | Description
Public Property | AjaxControlID | This field holds the control id of the control that can initiate an AJAX request.
Public Property | UpdatedControls | A collection of controls that will be updated by the AjaxManager
Top

See Also

Reference

AjaxSetting Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Constructor

AjaxSetting Constructor
[image]
Telerik.WebControls Namespace > AjaxSetting Class : AjaxSetting Constructor

Default constructor for the AjaxSetting class.

Overload List

Overload | Description
AjaxSetting Constructor() | Default constructor for the AjaxSetting class.
AjaxSetting Constructor(String) | A constructor for AjaxSetting taking the ClientID of the control initiating the AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Class
AjaxSetting Members

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Constructor()

AjaxSetting Constructor()
See Also
[image]
Telerik.WebControls Namespace > AjaxSetting Class > AjaxSetting Constructor : AjaxSetting Constructor()

Default constructor for the AjaxSetting class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxSetting()
C#
public AjaxSetting()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxSetting()
C#
public AjaxSetting()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Class
AjaxSetting Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Constructor(String)

AjaxSetting Constructor(String)
See Also
[image]
Telerik.WebControls Namespace > AjaxSetting Class > AjaxSetting Constructor : AjaxSetting Constructor(String)

controlID
A constructor for AjaxSetting taking the ClientID of the control initiating the AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal controlID As String _
)
Visual Basic (Usage) Copy Code
Dim controlID As String

Dim instance As AjaxSetting(controlID)
C#
public AjaxSetting(
   string controlID
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal controlID As String _
)
Visual Basic (Usage) Copy Code
Dim controlID As String

Dim instance As AjaxSetting(controlID)
C#
public AjaxSetting(
   string controlID
)

Parameters

controlID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Class
AjaxSetting Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AjaxSetting Class Properties

AjaxSetting Class Properties
[image]
Telerik.WebControls Namespace : AjaxSetting Class

For a list of all members of this type, see AjaxSetting members.

Public Properties

 | Name | Description
Public Property | AjaxControlID | This field holds the control id of the control that can initiate an AJAX request.
Public Property | UpdatedControls | A collection of controls that will be updated by the AjaxManager
Top

See Also

Reference

AjaxSetting Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxControlID Property

AjaxControlID Property
[image]
Telerik.WebControls Namespace > AjaxSetting Class : AjaxControlID Property

This field holds the control id of the control that can initiate an AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property AjaxControlID As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxSetting
Dim value As String

instance.AjaxControlID = value

value = instance.AjaxControlID
C#
public string AjaxControlID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Class
AjaxSetting Members

© telerik 2002-2008. All Rights Reserved.


UpdatedControls Property

UpdatedControls Property
[image]
Telerik.WebControls Namespace > AjaxSetting Class : UpdatedControls Property

A collection of controls that will be updated by the AjaxManager

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdatedControls As AjaxUpdatedControlsCollection
Visual Basic (Usage) Copy Code
Dim instance As AjaxSetting
Dim value As AjaxUpdatedControlsCollection

value = instance.UpdatedControls
C#
public AjaxUpdatedControlsCollection UpdatedControls {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSetting Class
AjaxSetting Members

© telerik 2002-2008. All Rights Reserved.


AjaxSettingsCollection Class

AjaxSettingsCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxSettingsCollection Class

Summary description for ConfiguredControls.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxSettingsCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
C#
public class AjaxSettingsCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.AjaxSettingsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxSettingsCollection Class Members

AjaxSettingsCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : AjaxSettingsCollection Class

The following tables list the members exposed by AjaxSettingsCollection.

Public Constructors

 | Name | Description
Public Constructor | AjaxSettingsCollection Constructor | The default constructor for AjaxSettingsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Default indexer for the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the collection.
Public Method | AddAjaxSetting | Overloaded. This method adds a new AjaxSetting to the collection by building one from its parameters.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks wether the item is present in the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of the specified item.
Public Method | Insert | Inserts an item at the specificed index in the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToString | Overridden.
Top

See Also

Reference

AjaxSettingsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxSettingsCollection Constructor

AjaxSettingsCollection Constructor
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : AjaxSettingsCollection Constructor

The default constructor for AjaxSettingsCollection class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection()
C#
public AjaxSettingsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection()
C#
public AjaxSettingsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxSettingsCollection Class Methods

AjaxSettingsCollection Class Methods
[image]
Telerik.WebControls Namespace : AjaxSettingsCollection Class

For a list of all members of this type, see AjaxSettingsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the collection.
Public Method | AddAjaxSetting | Overloaded. This method adds a new AjaxSetting to the collection by building one from its parameters.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks wether the item is present in the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of the specified item.
Public Method | Insert | Inserts an item at the specificed index in the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToString | Overridden.
Top

See Also

Reference

AjaxSettingsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : Add Method

ajaxSetting
An instance of AjaxSetting to be added.
Adds an item to the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal ajaxSetting As AjaxSetting _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxSetting As AjaxSetting
Dim value As Integer

value = instance.Add(ajaxSetting)
C#
public int Add(
   AjaxSetting ajaxSetting
)

Parameters

ajaxSetting
An instance of AjaxSetting to be added.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


AddAjaxSetting Method

AddAjaxSetting Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : AddAjaxSetting Method

This method adds a new AjaxSetting to the collection by building one from its parameters.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Overload List

Overload | Description
AddAjaxSetting(Control,Control,AjaxLoadingPanel) | This method adds a new AjaxSetting to the collection by building one from its parameters.
AddAjaxSetting(Control,Control) | This method adds a new AjaxSetting to the collection by building one from its parameters.

Overload List

Overload | Description
AddAjaxSetting(Control,Control,AjaxLoadingPanel) | This method adds a new AjaxSetting to the collection by building one from its parameters.
AddAjaxSetting(Control,Control) | This method adds a new AjaxSetting to the collection by building one from its parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


AddAjaxSetting(Control,Control,AjaxLoadingPanel) Method

AddAjaxSetting(Control,Control,AjaxLoadingPanel) Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class > AddAjaxSetting Method : AddAjaxSetting(Control,Control,AjaxLoadingPanel) Method

ajaxifiedControl
The web control to be ajaxified (the initiator of the AJAX request)
updatedControl
The web control that has to be updated.
loadingPanel
The loading panel to be displayed during the update.
This method adds a new AjaxSetting to the collection by building one from its parameters.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddAjaxSetting( _
   ByVal ajaxifiedControl As Control, _
   ByVal updatedControl As Control, _
   ByVal loadingPanel As AjaxLoadingPanel _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxifiedControl As Control
Dim updatedControl As Control
Dim loadingPanel As AjaxLoadingPanel

instance.AddAjaxSetting(ajaxifiedControl, updatedControl, loadingPanel)
C#
public void AddAjaxSetting(
   Control ajaxifiedControl,
   Control updatedControl,
   AjaxLoadingPanel loadingPanel
)

Parameters

ajaxifiedControl
The web control to be ajaxified (the initiator of the AJAX request)
updatedControl
The web control that has to be updated.
loadingPanel
The loading panel to be displayed during the update.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AddAjaxSetting(Control,Control) Method

AddAjaxSetting(Control,Control) Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class > AddAjaxSetting Method : AddAjaxSetting(Control,Control) Method

ajaxifiedControl
The web control to be ajaxified (the initiator of the AJAX request)
updatedControl
The web control that has to be updated.
This method adds a new AjaxSetting to the collection by building one from its parameters.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddAjaxSetting( _
   ByVal ajaxifiedControl As Control, _
   ByVal updatedControl As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxifiedControl As Control
Dim updatedControl As Control

instance.AddAjaxSetting(ajaxifiedControl, updatedControl)
C#
public void AddAjaxSetting(
   Control ajaxifiedControl,
   Control updatedControl
)

Parameters

ajaxifiedControl
The web control to be ajaxified (the initiator of the AJAX request)
updatedControl
The web control that has to be updated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members
Overload List

© telerik 2002-2008. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : Contains Method

ajaxSetting
An instance of AjaxSetting
Checks wether the item is present in the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ajaxSetting As AjaxSetting _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxSetting As AjaxSetting
Dim value As Boolean

value = instance.Contains(ajaxSetting)
C#
public bool Contains(
   AjaxSetting ajaxSetting
)

Parameters

ajaxSetting
An instance of AjaxSetting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : IndexOf Method

ajaxSetting
An instance of AjaxSetting
Determines the index of the specified item.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal ajaxSetting As AjaxSetting _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxSetting As AjaxSetting
Dim value As Integer

value = instance.IndexOf(ajaxSetting)
C#
public int IndexOf(
   AjaxSetting ajaxSetting
)

Parameters

ajaxSetting
An instance of AjaxSetting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


Insert Method

Insert Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : Insert Method

index
An instance of AjaxSetting
ajaxSetting
Inserts an item at the specificed index in the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal ajaxSetting As AjaxSetting _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim index As Integer
Dim ajaxSetting As AjaxSetting

instance.Insert(index, ajaxSetting)
C#
public void Insert(
   int index,
   AjaxSetting ajaxSetting
)

Parameters

index
An instance of AjaxSetting
ajaxSetting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


Remove Method

Remove Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : Remove Method

ajaxSetting
An instance of AjaxSetting to be removed
Removes an item from the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal ajaxSetting As AjaxSetting _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim ajaxSetting As AjaxSetting

instance.Remove(ajaxSetting)
C#
public void Remove(
   AjaxSetting ajaxSetting
)

Parameters

ajaxSetting
An instance of AjaxSetting to be removed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : ToString Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxSettingsCollection Class Properties

AjaxSettingsCollection Class Properties
[image]
Telerik.WebControls Namespace : AjaxSettingsCollection Class

For a list of all members of this type, see AjaxSettingsCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Default indexer for the collection.
Top

See Also

Reference

AjaxSettingsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > AjaxSettingsCollection Class : Item Property

index
Default indexer for the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As AjaxSetting
Visual Basic (Usage) Copy Code
Dim instance As AjaxSettingsCollection
Dim index As Integer
Dim value As AjaxSetting

instance.Item(index) = value

value = instance.Item(index)
C#
public AjaxSetting this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxSettingsCollection Class
AjaxSettingsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Class

AjaxUpdatedControl Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxUpdatedControl Class

This class holds a reference to a single updated control and the loading panel to display.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxUpdatedControl
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
C#
public class AjaxUpdatedControl

Inheritance Hierarchy

System.Object
Telerik.WebControls.AjaxUpdatedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Class Members

AjaxUpdatedControl Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : AjaxUpdatedControl Class

The following tables list the members exposed by AjaxUpdatedControl.

Public Constructors

 | Name | Description
Public Constructor | AjaxUpdatedControl Constructor | Overloaded. A constructor of AjaxUpdatedControl which takes as parameters the control to be updated and the id of the loading panel to display.
Top

Public Properties

 | Name | Description
Public Property | ControlID | The ID of the web control that is to be updated.
Public Property | LoadingPanelID | The ID of the AjaxLoadingPanel to be displayed during the update of the control.
Public Property | Site |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Top

See Also

Reference

AjaxUpdatedControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Constructor

AjaxUpdatedControl Constructor
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : AjaxUpdatedControl Constructor

A constructor of AjaxUpdatedControl which takes as parameters the control to be updated and the id of the loading panel to display.

Overload List

Overload | Description
AjaxUpdatedControl Constructor() | The default constructor of the AjaxUpdatedControl class.
AjaxUpdatedControl Constructor(String,String) | A constructor of AjaxUpdatedControl which takes as parameters the control to be updated and the id of the loading panel to display.
AjaxUpdatedControl Constructor(String,String,RadAjaxManager) |

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Constructor()

AjaxUpdatedControl Constructor()
See Also
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class > AjaxUpdatedControl Constructor : AjaxUpdatedControl Constructor()

The default constructor of the AjaxUpdatedControl class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl()
C#
public AjaxUpdatedControl()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl()
C#
public AjaxUpdatedControl()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Constructor(String,String)

AjaxUpdatedControl Constructor(String,String)
See Also
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class > AjaxUpdatedControl Constructor : AjaxUpdatedControl Constructor(String,String)

ctrlID
The ID of the control that will be updated by RadAjax
loadPID
The ID of the LoadingPanel to display during the update.
A constructor of AjaxUpdatedControl which takes as parameters the control to be updated and the id of the loading panel to display.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ctrlID As String, _
   ByVal loadPID As String _
)
Visual Basic (Usage) Copy Code
Dim ctrlID As String
Dim loadPID As String

Dim instance As AjaxUpdatedControl(ctrlID, loadPID)
C#
public AjaxUpdatedControl(
   string ctrlID,
   string loadPID
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ctrlID As String, _
   ByVal loadPID As String _
)
Visual Basic (Usage) Copy Code
Dim ctrlID As String
Dim loadPID As String

Dim instance As AjaxUpdatedControl(ctrlID, loadPID)
C#
public AjaxUpdatedControl(
   string ctrlID,
   string loadPID
)

Parameters

ctrlID
The ID of the control that will be updated by RadAjax
loadPID
The ID of the LoadingPanel to display during the update.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Constructor(String,String,RadAjaxManager)

AjaxUpdatedControl Constructor(String,String,RadAjaxManager)
See Also
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class > AjaxUpdatedControl Constructor : AjaxUpdatedControl Constructor(String,String,RadAjaxManager)

ctrlID
loadPID
manager

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ctrlID As String, _
   ByVal loadPID As String, _
   ByVal manager As RadAjaxManager _
)
Visual Basic (Usage) Copy Code
Dim ctrlID As String
Dim loadPID As String
Dim manager As RadAjaxManager

Dim instance As AjaxUpdatedControl(ctrlID, loadPID, manager)
C#
public AjaxUpdatedControl(
   string ctrlID,
   string loadPID,
   RadAjaxManager manager
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ctrlID As String, _
   ByVal loadPID As String, _
   ByVal manager As RadAjaxManager _
)
Visual Basic (Usage) Copy Code
Dim ctrlID As String
Dim loadPID As String
Dim manager As RadAjaxManager

Dim instance As AjaxUpdatedControl(ctrlID, loadPID, manager)
C#
public AjaxUpdatedControl(
   string ctrlID,
   string loadPID,
   RadAjaxManager manager
)

Parameters

ctrlID
loadPID
manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Class Methods

AjaxUpdatedControl Class Methods
[image]
Telerik.WebControls Namespace : AjaxUpdatedControl Class

For a list of all members of this type, see AjaxUpdatedControl members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Top

See Also

Reference

AjaxUpdatedControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Equals Method

Equals Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : Equals Method

other

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
C#
public override bool Equals(
   object other
)

Parameters

other

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


GetHashCode Method

GetHashCode Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : GetHashCode Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControl Class Properties

AjaxUpdatedControl Class Properties
[image]
Telerik.WebControls Namespace : AjaxUpdatedControl Class

For a list of all members of this type, see AjaxUpdatedControl members.

Public Properties

 | Name | Description
Public Property | ControlID | The ID of the web control that is to be updated.
Public Property | LoadingPanelID | The ID of the AjaxLoadingPanel to be displayed during the update of the control.
Public Property | Site |
Top

See Also

Reference

AjaxUpdatedControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ControlID Property

ControlID Property
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : ControlID Property

The ID of the web control that is to be updated.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property ControlID As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
Dim value As String

instance.ControlID = value

value = instance.ControlID
C#
public string ControlID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


LoadingPanelID Property

LoadingPanelID Property
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : LoadingPanelID Property

The ID of the AjaxLoadingPanel to be displayed during the update of the control.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property LoadingPanelID As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
Dim value As String

instance.LoadingPanelID = value

value = instance.LoadingPanelID
C#
public string LoadingPanelID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


Site Property

Site Property
[image]
Telerik.WebControls Namespace > AjaxUpdatedControl Class : Site Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControl
Dim value As ISite

instance.Site = value

value = instance.Site
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControl Class
AjaxUpdatedControl Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControlsCollection Class

AjaxUpdatedControlsCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxUpdatedControlsCollection Class

A collection of the controls that are updated by the AjaxManager.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxUpdatedControlsCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
C#
public class AjaxUpdatedControlsCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.AjaxUpdatedControlsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControlsCollection Class Members

AjaxUpdatedControlsCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : AjaxUpdatedControlsCollection Class

The following tables list the members exposed by AjaxUpdatedControlsCollection.

Public Constructors

 | Name | Description
Public Constructor | AjaxUpdatedControlsCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | The default indexer of the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the collection
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks wether the collection contains the specified item.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Gets the index of the specified item in the collection.
Public Method | Insert | Inserts an item at the specified index in the collection.
Public Method | Remove | Removes the specified item from the collection
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AjaxUpdatedControlsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControlsCollection Constructor

AjaxUpdatedControlsCollection Constructor
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : AjaxUpdatedControlsCollection Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection()
C#
public AjaxUpdatedControlsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection()
C#
public AjaxUpdatedControlsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControlsCollection Class Methods

AjaxUpdatedControlsCollection Class Methods
[image]
Telerik.WebControls Namespace : AjaxUpdatedControlsCollection Class

For a list of all members of this type, see AjaxUpdatedControlsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the collection
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks wether the collection contains the specified item.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Gets the index of the specified item in the collection.
Public Method | Insert | Inserts an item at the specified index in the collection.
Public Method | Remove | Removes the specified item from the collection
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AjaxUpdatedControlsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : Add Method

newItem
Adds an item to the collection

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal newItem As AjaxUpdatedControl _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim newItem As AjaxUpdatedControl
Dim value As Integer

value = instance.Add(newItem)
C#
public int Add(
   AjaxUpdatedControl newItem
)

Parameters

newItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


AddRange Method

AddRange Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : AddRange Method

controls

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal controls As AjaxUpdatedControlsCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim controls As AjaxUpdatedControlsCollection

instance.AddRange(controls)
C#
public void AddRange(
   AjaxUpdatedControlsCollection controls
)

Parameters

controls

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : Contains Method

updatedControl
Checks wether the collection contains the specified item.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal updatedControl As AjaxUpdatedControl _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim updatedControl As AjaxUpdatedControl
Dim value As Boolean

value = instance.Contains(updatedControl)
C#
public bool Contains(
   AjaxUpdatedControl updatedControl
)

Parameters

updatedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : IndexOf Method

updatedControl
Gets the index of the specified item in the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal updatedControl As AjaxUpdatedControl _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim updatedControl As AjaxUpdatedControl
Dim value As Integer

value = instance.IndexOf(updatedControl)
C#
public int IndexOf(
   AjaxUpdatedControl updatedControl
)

Parameters

updatedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


Insert Method

Insert Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : Insert Method

index
updatedControl
Inserts an item at the specified index in the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal updatedControl As AjaxUpdatedControl _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim index As Integer
Dim updatedControl As AjaxUpdatedControl

instance.Insert(index, updatedControl)
C#
public void Insert(
   int index,
   AjaxUpdatedControl updatedControl
)

Parameters

index
updatedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


Remove Method

Remove Method
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : Remove Method

updatedControl
Removes the specified item from the collection

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal updatedControl As AjaxUpdatedControl _
)
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim updatedControl As AjaxUpdatedControl

instance.Remove(updatedControl)
C#
public void Remove(
   AjaxUpdatedControl updatedControl
)

Parameters

updatedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdatedControlsCollection Class Properties

AjaxUpdatedControlsCollection Class Properties
[image]
Telerik.WebControls Namespace : AjaxUpdatedControlsCollection Class

For a list of all members of this type, see AjaxUpdatedControlsCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | The default indexer of the collection.
Top

See Also

Reference

AjaxUpdatedControlsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > AjaxUpdatedControlsCollection Class : Item Property

index
The default indexer of the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As AjaxUpdatedControl
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdatedControlsCollection
Dim index As Integer
Dim value As AjaxUpdatedControl

instance.Item(index) = value

value = instance.Item(index)
C#
public AjaxUpdatedControl this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdatedControlsCollection Class
AjaxUpdatedControlsCollection Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Class

AjaxUpdateGroup Class
See Also Members
[image]
Telerik.WebControls Namespace : AjaxUpdateGroup Class

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class AjaxUpdateGroup
   Inherits Control
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup
C#
public class AjaxUpdateGroup : Control

Inheritance Hierarchy

System.Object
System.Web.UI.Control
Telerik.WebControls.AjaxUpdateGroup

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdateGroup Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Class Members

AjaxUpdateGroup Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : AjaxUpdateGroup Class

The following tables list the members exposed by AjaxUpdateGroup.

Public Constructors

 | Name | Description
Public Constructor | AjaxUpdateGroup Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlsToUpdate |
Public Property | EnableTheming | (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.Control)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | Overridden.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxUpdateGroup Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Constructor

AjaxUpdateGroup Constructor
[image]
Telerik.WebControls Namespace > AjaxUpdateGroup Class : AjaxUpdateGroup Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup()
C#
public AjaxUpdateGroup()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup()
C#
public AjaxUpdateGroup()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdateGroup Class
AjaxUpdateGroup Members

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Class Properties

AjaxUpdateGroup Class Properties
[image]
Telerik.WebControls Namespace : AjaxUpdateGroup Class

For a list of all members of this type, see AjaxUpdateGroup members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlsToUpdate |
Public Property | EnableTheming | (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.Control)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | Overridden.
Top

See Also

Reference

AjaxUpdateGroup Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ControlsToUpdate Property

ControlsToUpdate Property
[image]
Telerik.WebControls Namespace > AjaxUpdateGroup Class : ControlsToUpdate Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlsToUpdate As PanelControlsToUpdate
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup
Dim value As PanelControlsToUpdate

value = instance.ControlsToUpdate
C#
public PanelControlsToUpdate ControlsToUpdate {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdateGroup Class
AjaxUpdateGroup Members

© telerik 2002-2008. All Rights Reserved.


EnableViewState Property

EnableViewState Property
[image]
Telerik.WebControls Namespace > AjaxUpdateGroup Class : EnableViewState Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
public override bool EnableViewState {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdateGroup Class
AjaxUpdateGroup Members

© telerik 2002-2008. All Rights Reserved.


Visible Property

Visible Property
[image]
Telerik.WebControls Namespace > AjaxUpdateGroup Class : Visible Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AjaxUpdateGroup
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxUpdateGroup Class
AjaxUpdateGroup Members

© telerik 2002-2008. All Rights Reserved.


ClientProxyScriptGenerator Class

ClientProxyScriptGenerator Class
See Also Members
[image]
Telerik.WebControls Namespace : ClientProxyScriptGenerator Class

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Private Class ClientProxyScriptGenerator
Visual Basic (Usage) Copy Code
Dim instance As ClientProxyScriptGenerator
C#
private class ClientProxyScriptGenerator

Inheritance Hierarchy

System.Object
Telerik.WebControls.ClientProxyScriptGenerator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ClientProxyScriptGenerator Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ClientProxyScriptGenerator Class Members

ClientProxyScriptGenerator Class Members
[image]
Telerik.WebControls Namespace : ClientProxyScriptGenerator Class

The following tables list the members exposed by ClientProxyScriptGenerator.

Public Constructors

 | Name | Description
Public Constructor | ClientProxyScriptGenerator Constructor |
Top

See Also

Reference

ClientProxyScriptGenerator Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ClientProxyScriptGenerator Constructor

ClientProxyScriptGenerator Constructor
[image]
Telerik.WebControls Namespace > ClientProxyScriptGenerator Class : ClientProxyScriptGenerator Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ClientProxyScriptGenerator()
C#
public ClientProxyScriptGenerator()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ClientProxyScriptGenerator()
C#
public ClientProxyScriptGenerator()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ClientProxyScriptGenerator Class
ClientProxyScriptGenerator Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Class

RadAjaxManager Class
See Also Members
[image]
Telerik.WebControls Namespace : RadAjaxManager Class

RadAjaxManager is one of the two main controls that come with the Telerik RadAjax suite. Using the AJAX Manager control on your page, you can ajaxify all controls that normally work with postbacks. AJAX Manager has a builder tool that allows you to set the AJAX relations in design-mode and absolutely codeless. Using a single AJAX Manager on the page you can create complex web applications like Microsoft Outlook ® Web Access portal.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class RadAjaxManager
   Inherits RadAJAXControl
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
C#
public class RadAjaxManager : RadAJAXControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxUtils.RadAJAXControl
Telerik.WebControls.RadAjaxManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Class Members

RadAjaxManager Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadAjaxManager Class

The following tables list the members exposed by RadAjaxManager.

Public Constructors

 | Name | Description
Public Constructor | RadAjaxManager Constructor | Initializes a new instance of the RadAjaxManager class.
Top

Public Properties

Name | Description
Public Property | AjaxSettings | AjaxSettings provides a way to programmatically set or get the AjaxSettings collection associated with the instance of the RadAjaxManager. It is usually defined declaratively (as demonstrated below) or using the visual designer.
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ClientEvents

Gets a reference to the AjaxClientEvents object which specifies the names of the JavaScript functions which are called at different stages of the AJAXrequest.

The following client events are available:

  • OnRequestStart
  • OnRequestSent
  • OnResponseReceived
  • OnResponseEnd
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultLoadingPanelID | Sets or gets the default loading panel for every ajax setting
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableSelfUpdate | Gets or sets a value indicating whether the AjaxManager will update itself on ajax request.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | Overridden. For RadAjaxManager, this properly is read-only.
Top

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Sets focus to the specified web control after the AJAX Request is finished. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientID |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | AjaxRequest | Occurs whenever the client-side function AjaxRequest(arguments) is called. Alternatively the event is fired with AjaxRequestWithTarget(eventTarget, eventArgument) when the eventTarget is the UniqueID of the AJAX Manager instance. When the manager ajaxifies itself it will perform an AJAX request, otherwise it will postback to the server (this is the default behavior).
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | ResolveUpdatedControls | Occurs when the RadAjaxManager resolves the UpdatedControls collection for the control that initiated the Ajax request to the server. Handling this event is the last place where you can modify the collection of controls that would be updated on the current Ajax request (note that you can add as well as remove controls).
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Constructor

RadAjaxManager Constructor
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : RadAjaxManager Constructor

Initializes a new instance of the RadAjaxManager class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager()
C#
public RadAjaxManager()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager()
C#
public RadAjaxManager()

Return Value

Returns a reference to the newly instatiated RadAjaxManager object.

Remarks

Use this constructor to create and initialize a new instance of the RadAjaxManager class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Class Methods

RadAjaxManager Class Methods
[image]
Telerik.WebControls Namespace : RadAjaxManager Class

For a list of all members of this type, see RadAjaxManager members.

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Sets focus to the specified web control after the AJAX Request is finished. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientID |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ResolveClientID Method

ResolveClientID Method
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : ResolveClientID Method

controlID

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveClientID( _
   ByVal controlID As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim controlID As String
Dim value As String

value = instance.ResolveClientID(controlID)
C#
public string ResolveClientID(
   string controlID
)

Parameters

controlID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Class Properties

RadAjaxManager Class Properties
[image]
Telerik.WebControls Namespace : RadAjaxManager Class

For a list of all members of this type, see RadAjaxManager members.

Public Properties

Name | Description
Public Property | AjaxSettings | AjaxSettings provides a way to programmatically set or get the AjaxSettings collection associated with the instance of the RadAjaxManager. It is usually defined declaratively (as demonstrated below) or using the visual designer.
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ClientEvents

Gets a reference to the AjaxClientEvents object which specifies the names of the JavaScript functions which are called at different stages of the AJAXrequest.

The following client events are available:

  • OnRequestStart
  • OnRequestSent
  • OnResponseReceived
  • OnResponseEnd
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultLoadingPanelID | Sets or gets the default loading panel for every ajax setting
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableSelfUpdate | Gets or sets a value indicating whether the AjaxManager will update itself on ajax request.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | Overridden. For RadAjaxManager, this properly is read-only.
Top

See Also

Reference

RadAjaxManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxSettings Property

AjaxSettings Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : AjaxSettings Property

AjaxSettings provides a way to programmatically set or get the AjaxSettings collection associated with the instance of the RadAjaxManager. It is usually defined declaratively (as demonstrated below) or using the visual designer.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AjaxSettings As AjaxSettingsCollection
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As AjaxSettingsCollection

value = instance.AjaxSettings
C#
public AjaxSettingsCollection AjaxSettings {get;}

Return Value

AjaxSettingsCollection

Example

<rad:RadAjaxManager id="RadAjaxManager1" runat="server">
<AjaxSettings>
<rad:AjaxSetting AjaxControlID="Button1">
<UpdatedControls>
<rad:AjaxUpdatedControl ControlID="Label1"></rad:AjaxUpdatedControl>
</UpdatedControls>
</rad:AjaxSetting>
</AjaxSettings>
</rad:RadAjaxManager>

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members
AjaxSettings Property

© telerik 2002-2008. All Rights Reserved.


ClientEvents Property

ClientEvents Property
See Also Example
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : ClientEvents Property

Gets a reference to the AjaxClientEvents object which specifies the names of the JavaScript functions which are called at different stages of the AJAXrequest.

The following client events are available:

  • OnRequestStart
  • OnRequestSent
  • OnResponseReceived
  • OnResponseEnd

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientEvents As AjaxClientEvents
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As AjaxClientEvents

value = instance.ClientEvents
C#
public AjaxClientEvents ClientEvents {get;}

Return Value

AjaxClientEvents object which specifies the names of the JavaScript functions.

Example

This example demonstrates a sample usage of the ClientEvents property.
C# Copy Code
&lt;form id="Form1" method="post" runat="server" &gt;
&lt;script Type="text/javascript"&gt;
function onRequestStart()
{
alert("Request has just started!");
}
function onRequestSent()
{
alert("Request has been just sent");
}
function onResponseReceived()
{
alert("Response has been received");
}
function onResponseEnd()
{
alert("Response is already handled");
}
&lt;/script&gt;
. . .
&lt;/form&gt;

 private void Page_Load(object sender, System.EventArgs e)
{
if (!Page.IsPostback) {
RadAjaxManager.ClientEvents.OnRequestStart = "onRequestStart";
RadAjaxManager.ClientEvents.OnRequestSent = "onRequestSent";
RadAjaxManager.ClientEvents.OnResponseReceived = "onResponseReceived";
RadAjaxManager.ClientEvents.OnResponseEnd = "onResponseEnd";
}
}

Visual Basic Copy Code
<form id="Form1" method="post" runat="server" >
<script Type="text/javascript">
Function onRequestStart()
{
alert("Request has just started!");
}
Function onRequestSent()
{
alert("Request has been just sent");
}
Function onResponseReceived()
{
alert("Response has been received");
}
Function onResponseEnd()
{
alert("Response is already handled");
}
</script>
. . .
</form>

Private Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs)
If Not Page.IsPostBack Then
RadAjaxManager.ClientEvents.OnRequestStart = "onRequestStart"
RadAjaxManager.ClientEvents.OnRequestSent = "onRequestSent"
RadAjaxManager.ClientEvents.OnResponseReceived = "onResponseReceived"
RadAjaxManager.ClientEvents.OnResponseEnd = "onResponseEnd"
End If

End Sub 'Page_Load

Remarks

This property is read-only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members
AjaxClientEvents Class

© telerik 2002-2008. All Rights Reserved.


DefaultLoadingPanelID Property

DefaultLoadingPanelID Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : DefaultLoadingPanelID Property

Sets or gets the default loading panel for every ajax setting

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultLoadingPanelID As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As String

instance.DefaultLoadingPanelID = value

value = instance.DefaultLoadingPanelID
C#
public string DefaultLoadingPanelID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


EnableSelfUpdate Property

EnableSelfUpdate Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : EnableSelfUpdate Property

Gets or sets a value indicating whether the AjaxManager will update itself on ajax request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableSelfUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As Boolean

instance.EnableSelfUpdate = value

value = instance.EnableSelfUpdate
C#
public bool EnableSelfUpdate {get; set;}

Return Value

The default value is true.

Remarks

Setting this property to false makes sense in scenarios where one needs to use very granulated AjaxSettings (e.g. 5 ajax settings where each initiator updates 5-10 distinct controls) that would cause significant overhead if they are transfered on every ajax request to the client. Note, however, that you would not be able to modify the manager behavior on ajax request as its state will not be passed to the client-side.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


Visible Property

Visible Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : Visible Property

For RadAjaxManager, this properly is read-only.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager Class Events

RadAjaxManager Class Events
[image]
Telerik.WebControls Namespace : RadAjaxManager Class

For a list of all members of this type, see RadAjaxManager members.

Public Events

 | Name | Description
Public Event | AjaxRequest | Occurs whenever the client-side function AjaxRequest(arguments) is called. Alternatively the event is fired with AjaxRequestWithTarget(eventTarget, eventArgument) when the eventTarget is the UniqueID of the AJAX Manager instance. When the manager ajaxifies itself it will perform an AJAX request, otherwise it will postback to the server (this is the default behavior).
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | ResolveUpdatedControls | Occurs when the RadAjaxManager resolves the UpdatedControls collection for the control that initiated the Ajax request to the server. Handling this event is the last place where you can modify the collection of controls that would be updated on the current Ajax request (note that you can add as well as remove controls).
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxRequest Event

AjaxRequest Event
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : AjaxRequest Event

Occurs whenever the client-side function AjaxRequest(arguments) is called. Alternatively the event is fired with AjaxRequestWithTarget(eventTarget, eventArgument) when the eventTarget is the UniqueID of the AJAX Manager instance.

When the manager ajaxifies itself it will perform an AJAX request, otherwise it will postback to the server (this is the default behavior).

Example

<script type="text/javascript">

RadAjaxManager1.AjaxRequest(event_argument);

</script>

Event Data

The event handler receives an argument of type AjaxRequestEventArgs containing data related to this event. The following AjaxRequestEventArgs properties provide information specific to this event.

Property | Description
Argument | Returns the name of the AJAX request event.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Event AjaxRequest() As RadAjaxManager.AsyncRequestDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim handler As RadAjaxManager.AsyncRequestDelegate

AddHandler instance.AjaxRequest, handler
C#
public event RadAjaxManager.AsyncRequestDelegate AjaxRequest()

Syntax

Visual Basic (Declaration)
Public Event AjaxRequest() As RadAjaxManager.AsyncRequestDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim handler As RadAjaxManager.AsyncRequestDelegate

AddHandler instance.AjaxRequest, handler
C#
public event RadAjaxManager.AsyncRequestDelegate AjaxRequest()

Event Data

The event handler receives an argument of type AjaxRequestEventArgs containing data related to this event. The following AjaxRequestEventArgs properties provide information specific to this event.

Property | Description
Argument | Returns the name of the AJAX request event.

Example

<script type="text/javascript">

RadAjaxManager1.AjaxRequest(event_argument);

</script>

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


ResolveUpdatedControls Event

ResolveUpdatedControls Event
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : ResolveUpdatedControls Event

Occurs when the RadAjaxManager resolves the UpdatedControls collection for the control that initiated the Ajax request to the server.

Handling this event is the last place where you can modify the collection of controls that would be updated on the current Ajax request (note that you can add as well as remove controls).

Event Data

The event handler receives an argument of type UpdatedControlsEventArgs containing data related to this event. The following UpdatedControlsEventArgs properties provide information specific to this event.

Property | Description
PostBackControlID | Gets the ID of the control that initiated the Ajax request.
SuppressError | Gets or sets a value indicating whether an exception should be thrown if the collection of controls that should be updated is empty after handling the ResolveUpdatedControls event.
UpdatedControls | Gets the collection of controls that would be updated on the current Ajax request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Event ResolveUpdatedControls() As RadAjaxManager.ResolveUpdatedControlsDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim handler As RadAjaxManager.ResolveUpdatedControlsDelegate

AddHandler instance.ResolveUpdatedControls, handler
C#
public event RadAjaxManager.ResolveUpdatedControlsDelegate ResolveUpdatedControls()

Syntax

Visual Basic (Declaration)
Public Event ResolveUpdatedControls() As RadAjaxManager.ResolveUpdatedControlsDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim handler As RadAjaxManager.ResolveUpdatedControlsDelegate

AddHandler instance.ResolveUpdatedControls, handler
C#
public event RadAjaxManager.ResolveUpdatedControlsDelegate ResolveUpdatedControls()

Event Data

The event handler receives an argument of type UpdatedControlsEventArgs containing data related to this event. The following UpdatedControlsEventArgs properties provide information specific to this event.

Property | Description
PostBackControlID | Gets the ID of the control that initiated the Ajax request.
SuppressError | Gets or sets a value indicating whether an exception should be thrown if the collection of controls that should be updated is empty after handling the ResolveUpdatedControls event.
UpdatedControls | Gets the collection of controls that would be updated on the current Ajax request.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Class

RadAjaxPanel Class
See Also Members
[image]
Telerik.WebControls Namespace : RadAjaxPanel Class

AJAX Panel is used as a placeholder for other controls. Once placed in the panel, any ASP.NET control will start making AJAX requests instead of traditional postbacks.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class RadAjaxPanel
   Inherits RadMultipleUpdateAjaxControl
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
C#
public class RadAjaxPanel : RadMultipleUpdateAjaxControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxUtils.RadAJAXControl
Telerik.WebControls.RadMultipleUpdateAjaxControl
Telerik.WebControls.RadAjaxPanel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Class Members

RadAjaxPanel Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadAjaxPanel Class

The following tables list the members exposed by RadAjaxPanel.

Public Constructors

 | Name | Description
Public Constructor | RadAjaxPanel Constructor | Initializes a new instance of the AJAXPanel class.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ActiveElementID |
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | This property specifies the image that should be displayed as background in the AjaxPanel. If left blank, no background image is applied.
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientEvents | Set of options for panel's client-events
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | This property specifies the horizontal alignment of the RadAjaxPanel contents.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | LoadingPanelID | Gets or sets the ID of the AjaxLoadingPanel control that will be displayed over the control during AJAX requests. If you leave this blank (string.Empty) there will be no loading panel displayed. Note, if AjaxLoadingPanel is placed in a different naming container, its UniqueID should be used instead its ID property. Otherwise the AjaxLoadingPanel won't be found.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | ScrollBars |
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | This property specifies the layout of the AjaxPanel. When this is set to FALSE, the AjaxPanel contents will not be wrapped to a new line no matter how wide the control is.
Top

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Overridden.
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | AjaxRequest | This event is fired when RaisePostbackEvent of the AJAXPanel is fired.
Public Event | Command | The Command event is raised when RaiseBuibble event is fired in the AJAXPanel control.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Constructor

RadAjaxPanel Constructor
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : RadAjaxPanel Constructor

Initializes a new instance of the AJAXPanel class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel()
C#
public RadAjaxPanel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel()
C#
public RadAjaxPanel()

Return Value

Returns a reference to the newly instatiated AJAXPanel object.

Remarks

Use this constructor to create and initialize a new instance of the AJAXPanel class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Class Methods

RadAjaxPanel Class Methods
[image]
Telerik.WebControls Namespace : RadAjaxPanel Class

For a list of all members of this type, see RadAjaxPanel members.

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Overridden.
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


FocusControl Method

FocusControl Method
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : FocusControl Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Overload List

Overload | Description
FocusControl(Control) |
FocusControl(String) |

Overload List

Overload | Description
FocusControl(Control) |
FocusControl(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


FocusControl(Control) Method

FocusControl(Control) Method
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class > FocusControl Method : FocusControl(Control) Method

controlToFocus

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub FocusControl( _
   ByVal controlToFocus As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim controlToFocus As Control

instance.FocusControl(controlToFocus)
C#
public override void FocusControl(
   Control controlToFocus
)

Parameters

controlToFocus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members
Overload List

© telerik 2002-2008. All Rights Reserved.


FocusControl(String) Method

FocusControl(String) Method
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class > FocusControl Method : FocusControl(String) Method

controlToFocusID

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub FocusControl( _
   ByVal controlToFocusID As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim controlToFocusID As String

instance.FocusControl(controlToFocusID)
C#
public override void FocusControl(
   string controlToFocusID
)

Parameters

controlToFocusID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members
Overload List

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Class Properties

RadAjaxPanel Class Properties
[image]
Telerik.WebControls Namespace : RadAjaxPanel Class

For a list of all members of this type, see RadAjaxPanel members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ActiveElementID |
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | This property specifies the image that should be displayed as background in the AjaxPanel. If left blank, no background image is applied.
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientEvents | Set of options for panel's client-events
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | This property specifies the horizontal alignment of the RadAjaxPanel contents.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | LoadingPanelID | Gets or sets the ID of the AjaxLoadingPanel control that will be displayed over the control during AJAX requests. If you leave this blank (string.Empty) there will be no loading panel displayed. Note, if AjaxLoadingPanel is placed in a different naming container, its UniqueID should be used instead its ID property. Otherwise the AjaxLoadingPanel won't be found.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns. (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | ScrollBars |
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url | (Inherited from Telerik.WebControls.RadAjaxUtils.RadAJAXControl)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | This property specifies the layout of the AjaxPanel. When this is set to FALSE, the AjaxPanel contents will not be wrapped to a new line no matter how wide the control is.
Top

See Also

Reference

RadAjaxPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ActiveElementID Property

ActiveElementID Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : ActiveElementID Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveElementID As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As String

instance.ActiveElementID = value

value = instance.ActiveElementID
C#
public string ActiveElementID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


BackImageUrl Property

BackImageUrl Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : BackImageUrl Property

This property specifies the image that should be displayed as background in the AjaxPanel. If left blank, no background image is applied.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property BackImageUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As String

instance.BackImageUrl = value

value = instance.BackImageUrl
C#
public virtual string BackImageUrl {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


ClientEvents Property

ClientEvents Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : ClientEvents Property

Set of options for panel's client-events

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientEvents As AjaxClientEvents
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As AjaxClientEvents

value = instance.ClientEvents
C#
public AjaxClientEvents ClientEvents {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


HorizontalAlign Property

HorizontalAlign Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : HorizontalAlign Property

This property specifies the horizontal alignment of the RadAjaxPanel contents.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property HorizontalAlign As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
public virtual HorizontalAlign HorizontalAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


LoadingPanelID Property

LoadingPanelID Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : LoadingPanelID Property

Gets or sets the ID of the AjaxLoadingPanel control that will be displayed over the control during AJAX requests. If you leave this blank (string.Empty) there will be no loading panel displayed. Note, if AjaxLoadingPanel is placed in a different naming container, its UniqueID should be used instead its ID property. Otherwise the AjaxLoadingPanel won't be found.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property LoadingPanelID As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As String

instance.LoadingPanelID = value

value = instance.LoadingPanelID
C#
public string LoadingPanelID {get; set;}

Return Value

The ID of the loading panel. An empty string means that no panel will be displayed while loading data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


ScrollBars Property

ScrollBars Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : ScrollBars Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ScrollBars As ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
public virtual ScrollBars ScrollBars {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


Wrap Property

Wrap Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : Wrap Property

This property specifies the layout of the AjaxPanel. When this is set to FALSE, the AjaxPanel contents will not be wrapped to a new line no matter how wide the control is.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Wrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As Boolean

instance.Wrap = value

value = instance.Wrap
C#
public virtual bool Wrap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel Class Events

RadAjaxPanel Class Events
[image]
Telerik.WebControls Namespace : RadAjaxPanel Class

For a list of all members of this type, see RadAjaxPanel members.

Public Events

 | Name | Description
Public Event | AjaxRequest | This event is fired when RaisePostbackEvent of the AJAXPanel is fired.
Public Event | Command | The Command event is raised when RaiseBuibble event is fired in the AJAXPanel control.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxRequest Event

AjaxRequest Event
See Also Example
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : AjaxRequest Event

This event is fired when RaisePostbackEvent of the AJAXPanel is fired.

Example

[ASPX/ASCX]
<rad:RadAjaxPanel id="AJAXPanel1" runat="server"
EnableAJAX= "True">
</rad:RadAjaxPanel>
<br />
<input type=button value="Change color"onclick='RadAjaxNamespace.AjaxRequest( "<ClientID >", "ChangeColor" ,"<ClientID >")' />

Event Data

The event handler receives an argument of type AjaxRequestEventArgs containing data related to this event. The following AjaxRequestEventArgs properties provide information specific to this event.

Property | Description
Argument | Returns the name of the AJAX request event.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Event AjaxRequest() As RadAjaxPanel.AjaxPanelRequestEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim handler As RadAjaxPanel.AjaxPanelRequestEventHandler

AddHandler instance.AjaxRequest, handler
C#
public event RadAjaxPanel.AjaxPanelRequestEventHandler AjaxRequest()

Syntax

Visual Basic (Declaration)
Public Event AjaxRequest() As RadAjaxPanel.AjaxPanelRequestEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim handler As RadAjaxPanel.AjaxPanelRequestEventHandler

AddHandler instance.AjaxRequest, handler
C#
public event RadAjaxPanel.AjaxPanelRequestEventHandler AjaxRequest()

Event Data

The event handler receives an argument of type AjaxRequestEventArgs containing data related to this event. The following AjaxRequestEventArgs properties provide information specific to this event.

Property | Description
Argument | Returns the name of the AJAX request event.

Example

[ASPX/ASCX]
<rad:RadAjaxPanel id="AJAXPanel1" runat="server"
EnableAJAX= "True">
</rad:RadAjaxPanel>
<br />
<input type=button value="Change color"onclick='RadAjaxNamespace.AjaxRequest( "<ClientID >", "ChangeColor" ,"<ClientID >")' />
C# Copy Code
private void AJAXPanel1_Request(object source, Telerik.WebControls.AJAXPanel.AJAXPanelRequestEventArgs e)
{
   if(e.RequestArgument == "ChangeColor")
   {
       AJAXPanel1.BackColor = Color.Maroon;
   }
}

Visual Basic Copy Code
Private Sub AJAXPanel1_Request(ByVal source As Object, ByVal e As Telerik.WebControls.AJAXPanel.AJAXPanelRequestEventArgs)
    If (e.RequestArgument = "ChangeColor") Then
        AJAXPanel1.BackColor = Color.Maroon
    End If
End Sub

Remarks

e.RequestArgument is the eventArgument of the RaisePostbackEvent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


Command Event

Command Event
See Also Example
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : Command Event

The Command event is raised when RaiseBuibble event is fired in the AJAXPanel control.

Example

<rad:RadAjaxPanel ID="AJAXPanel1" runat="server"
                OnCommand="AJAXPanel1_Command">
<asp:Button ID="Button1" CommandName="MyCommand" runat="server" Text="My Text"
                />

...

</rad:RadAjaxPanel>

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Event Command() As CommandEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim handler As CommandEventHandler

AddHandler instance.Command, handler
C#
public event CommandEventHandler Command()

Syntax

Visual Basic (Declaration)
Public Event Command() As CommandEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim handler As CommandEventHandler

AddHandler instance.Command, handler
C#
public event CommandEventHandler Command()

Example

<rad:RadAjaxPanel ID="AJAXPanel1" runat="server"
                OnCommand="AJAXPanel1_Command">
<asp:Button ID="Button1" CommandName="MyCommand" runat="server" Text="My Text"
                />

...

</rad:RadAjaxPanel>

C# Copy Code
private void AJAXPanel1_Command(object sender, System.Web.UI.WebControls.CommandEventArgs e)
{
   if(e.CommandName == "MyCommand")
   {
       // your code goes here
   }
}

Visual Basic Copy Code
Private Sub AJAXPanel1_Command(ByVal sender As Object, ByVal e As System.Web.UI.WebControls.CommandEventArgs)
    If (e.CommandName = "MyCommand") Then
        ' your code goes here
    End If
End Sub

Remarks

This event is commonly used to handle button controls with a custom CommandName value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Class

RadAjaxServiceManager Class
See Also Members
[image]
Telerik.WebControls Namespace : RadAjaxServiceManager Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class RadAjaxServiceManager
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager
C#
public class RadAjaxServiceManager : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxServiceManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxServiceManager Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Class Members

RadAjaxServiceManager Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadAjaxServiceManager Class

The following tables list the members exposed by RadAjaxServiceManager.

Public Constructors

 | Name | Description
Public Constructor | RadAjaxServiceManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | WebServices | This property holds the collection of WebServicesReference items. You can use this property to add web service references programmatically.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxServiceManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Constructor

RadAjaxServiceManager Constructor
[image]
Telerik.WebControls Namespace > RadAjaxServiceManager Class : RadAjaxServiceManager Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager()
C#
public RadAjaxServiceManager()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager()
C#
public RadAjaxServiceManager()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxServiceManager Class
RadAjaxServiceManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Class Properties

RadAjaxServiceManager Class Properties
[image]
Telerik.WebControls Namespace : RadAjaxServiceManager Class

For a list of all members of this type, see RadAjaxServiceManager members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | WebServices | This property holds the collection of WebServicesReference items. You can use this property to add web service references programmatically.
Top

See Also

Reference

RadAjaxServiceManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


WebServices Property

WebServices Property
See Also Example
[image]
Telerik.WebControls Namespace > RadAjaxServiceManager Class : WebServices Property

This property holds the collection of WebServicesReference items. You can use this property to add web service references programmatically.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WebServices As WebServiceReferenceCollection
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager
Dim value As WebServiceReferenceCollection

value = instance.WebServices
C#
public WebServiceReferenceCollection WebServices {get;}

Return Value

WebServiceReferenceCollection Class

Example

C# Copy Code
RadAjaxServiceManager1.WebServices.Add(new WebServiceReference("path-to-webservice"));

Visual Basic Copy Code
RadAjaxServiceManager1.WebServices.Add(New WebServiceReference("path-to-webservice"))

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxServiceManager Class
RadAjaxServiceManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Class

RadAjaxTimer Class
See Also Members
[image]
Telerik.WebControls Namespace : RadAjaxTimer Class

The RadAjaxTimer class is a simple postback control that raises a postback Tick event continuously with a specified Interval Property. In order to make the timer control perform AJAX requests, you need to ajaxify it with RadAjaxManager or by placing it in RadAjaxPanel.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class RadAjaxTimer
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
C#
public class RadAjaxTimer : RadControl

Example

If RadAjaxTimer is not ajaxified it will only perform postbacks.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxTimer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Class Members

RadAjaxTimer Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadAjaxTimer Class

The following tables list the members exposed by RadAjaxTimer.

Public Constructors

 | Name | Description
Public Constructor | RadAjaxTimer Constructor | This is the default constructor for the RadAjaxTimer class.
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoStart | This property determines wether the timer should begin ticking on the client after a server response (either AJAX or postback)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialDelayTime | This property adds an additional delay to the timer interval after initial page load and regular postbacks. The delay will not be added when the timer is updated by an AJAX request.
Public Property | Interval | This property specifies the interval in which the timer would raise the Tick Event event. Default value is: 2000ms (2 seconds) Changing this value will restart the timer automatically so that the new value will be applied.
Public Property | IsStarted | This property determines wether the timer is currently active.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientTick | Use this event on the client if you wish to prevent the server side Tick event from firing.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | Start | Starts the instance of the timer.
Public Method | Stop | Stops the instance of the timer.
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Tick | This is the bread and butter event of the timer. It executes once during each Interval Property. You may use this event to rebind your controls or make other changes.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxTimer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Constructor

RadAjaxTimer Constructor
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : RadAjaxTimer Constructor

This is the default constructor for the RadAjaxTimer class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer()
C#
public RadAjaxTimer()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer()
C#
public RadAjaxTimer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Class Methods

RadAjaxTimer Class Methods
[image]
Telerik.WebControls Namespace : RadAjaxTimer Class

For a list of all members of this type, see RadAjaxTimer members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | Start | Starts the instance of the timer.
Public Method | Stop | Stops the instance of the timer.
Top

See Also

Reference

RadAjaxTimer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Start Method

Start Method
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : Start Method

Starts the instance of the timer.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Start()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer

instance.Start()
C#
public void Start()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


Stop Method

Stop Method
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : Stop Method

Stops the instance of the timer.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Stop()
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer

instance.Stop()
C#
public void Stop()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Class Properties

RadAjaxTimer Class Properties
[image]
Telerik.WebControls Namespace : RadAjaxTimer Class

For a list of all members of this type, see RadAjaxTimer members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoStart | This property determines wether the timer should begin ticking on the client after a server response (either AJAX or postback)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialDelayTime | This property adds an additional delay to the timer interval after initial page load and regular postbacks. The delay will not be added when the timer is updated by an AJAX request.
Public Property | Interval | This property specifies the interval in which the timer would raise the Tick Event event. Default value is: 2000ms (2 seconds) Changing this value will restart the timer automatically so that the new value will be applied.
Public Property | IsStarted | This property determines wether the timer is currently active.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientTick | Use this event on the client if you wish to prevent the server side Tick event from firing.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.WebControls.RadAjaxUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxTimer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AutoStart Property

AutoStart Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : AutoStart Property

This property determines wether the timer should begin ticking on the client after a server response (either AJAX or postback)

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As Boolean

instance.AutoStart = value

value = instance.AutoStart
C#
public bool AutoStart {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


InitialDelayTime Property

InitialDelayTime Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : InitialDelayTime Property

This property adds an additional delay to the timer interval after initial page load and regular postbacks. The delay will not be added when the timer is updated by an AJAX request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialDelayTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As Integer

instance.InitialDelayTime = value

value = instance.InitialDelayTime
C#
public int InitialDelayTime {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


Interval Property

Interval Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : Interval Property

This property specifies the interval in which the timer would raise the Tick Event event.

Default value is: 2000ms (2 seconds)

Changing this value will restart the timer automatically so that the new value will be applied.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property Interval As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As Integer

instance.Interval = value

value = instance.Interval
C#
public int Interval {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


IsStarted Property

IsStarted Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : IsStarted Property

This property determines wether the timer is currently active.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStarted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As Boolean

value = instance.IsStarted
C#
public bool IsStarted {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


OnClientTick Property

OnClientTick Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : OnClientTick Property

Use this event on the client if you wish to prevent the server side Tick event from firing.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientTick As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As String

instance.OnClientTick = value

value = instance.OnClientTick
C#
public string OnClientTick {get; set;}

Example

<script type="text/javascript" >

function MyTickHandler(eventArgument)
{

//Cancel Server Tick
eventArgument.CancelServerClick = true;
alert("I've been called!");
};

</script>

<rad:RadAjaxTimer ID="RadAjaxTimer1" OnClientTick="MyTickHandler" runat="server" />

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer Class Events

RadAjaxTimer Class Events
[image]
Telerik.WebControls Namespace : RadAjaxTimer Class

For a list of all members of this type, see RadAjaxTimer members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Tick | This is the bread and butter event of the timer. It executes once during each Interval Property. You may use this event to rebind your controls or make other changes.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxTimer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Tick Event

Tick Event
See Also Example
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : Tick Event

This is the bread and butter event of the timer. It executes once during each Interval Property. You may use this event to rebind your controls or make other changes.

Example

If you no longer wish this event to execute you can call the Stop Method method to stop the timer.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Event Tick() As RadAjaxTimer.TickDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim handler As RadAjaxTimer.TickDelegate

AddHandler instance.Tick, handler
C#
public event RadAjaxTimer.TickDelegate Tick()

Syntax

Visual Basic (Declaration)
Public Event Tick() As RadAjaxTimer.TickDelegate
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim handler As RadAjaxTimer.TickDelegate

AddHandler instance.Tick, handler
C#
public event RadAjaxTimer.TickDelegate Tick()

Example

If you no longer wish this event to execute you can call the Stop Method method to stop the timer.
Rebinding controls in the Tick event
C# Copy Code
private void LoadData1()
{
   //perform the actual control rebinding.
}

 private void RadAjaxTimer1_Tick(object sender, Telerik.WebControls.TickEventArgs e)
{
   LoadData1();
}

Rebinding controls in the Tick event
Visual Basic Copy Code
Private Sub LoadData1()
    'Perform actual control rebinding.
End Sub

Private Sub RadAjaxTimer1_Tick(sender As Object, e As Telerik.WebControls.TickEventArgs) Handles RadAjaxTimer1.Tick
    LoadData1()
End Sub 'RadAjaxTimer1_Tick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


TickEventArgs Class

TickEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : TickEventArgs Class

Summary description for TickEventArgs.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class TickEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TickEventArgs
C#
public class TickEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.TickEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TickEventArgs Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


TickEventArgs Class Members

TickEventArgs Class Members
[image]
Telerik.WebControls Namespace : TickEventArgs Class

The following tables list the members exposed by TickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TickEventArgs Constructor |
Top

See Also

Reference

TickEventArgs Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


TickEventArgs Constructor

TickEventArgs Constructor
[image]
Telerik.WebControls Namespace > TickEventArgs Class : TickEventArgs Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TickEventArgs()
C#
public TickEventArgs()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TickEventArgs()
C#
public TickEventArgs()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TickEventArgs Class
TickEventArgs Members

© telerik 2002-2008. All Rights Reserved.


UpdatableControl Class

UpdatableControl Class
See Also Members
[image]
Telerik.WebControls Namespace : UpdatableControl Class

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class UpdatableControl
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl
C#
public class UpdatableControl

Inheritance Hierarchy

System.Object
Telerik.WebControls.UpdatableControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


UpdatableControl Class Members

UpdatableControl Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : UpdatableControl Class

The following tables list the members exposed by UpdatableControl.

Public Constructors

 | Name | Description
Public Constructor | UpdatableControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | TargetID |
Top

Public Methods

 | Name | Description
Public Method | LoadViewState |
Public Method | SaveViewState |
Public Method | TrackViewState |
Top

See Also

Reference

UpdatableControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


UpdatableControl Constructor

UpdatableControl Constructor
[image]
Telerik.WebControls Namespace > UpdatableControl Class : UpdatableControl Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl()
C#
public UpdatableControl()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl()
C#
public UpdatableControl()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Class
UpdatableControl Members

© telerik 2002-2008. All Rights Reserved.


UpdatableControl Class Methods

UpdatableControl Class Methods
[image]
Telerik.WebControls Namespace : UpdatableControl Class

For a list of all members of this type, see UpdatableControl members.

Public Methods

 | Name | Description
Public Method | LoadViewState |
Public Method | SaveViewState |
Public Method | TrackViewState |
Top

See Also

Reference

UpdatableControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


LoadViewState Method

LoadViewState Method
[image]
Telerik.WebControls Namespace > UpdatableControl Class : LoadViewState Method

state

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl
Dim state As Object

instance.LoadViewState(state)
C#
public void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Class
UpdatableControl Members

© telerik 2002-2008. All Rights Reserved.


SaveViewState Method

SaveViewState Method
[image]
Telerik.WebControls Namespace > UpdatableControl Class : SaveViewState Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl
Dim value As Object

value = instance.SaveViewState()
C#
public object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Class
UpdatableControl Members

© telerik 2002-2008. All Rights Reserved.


TrackViewState Method

TrackViewState Method
[image]
Telerik.WebControls Namespace > UpdatableControl Class : TrackViewState Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl

instance.TrackViewState()
C#
public void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Class
UpdatableControl Members

© telerik 2002-2008. All Rights Reserved.


UpdatableControl Class Properties

UpdatableControl Class Properties
[image]
Telerik.WebControls Namespace : UpdatableControl Class

For a list of all members of this type, see UpdatableControl members.

Public Properties

 | Name | Description
Public Property | TargetID |
Top

See Also

Reference

UpdatableControl Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


TargetID Property

TargetID Property
[image]
Telerik.WebControls Namespace > UpdatableControl Class : TargetID Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetID As String
Visual Basic (Usage) Copy Code
Dim instance As UpdatableControl
Dim value As String

instance.TargetID = value

value = instance.TargetID
C#
public string TargetID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatableControl Class
UpdatableControl Members

© telerik 2002-2008. All Rights Reserved.


UpdatedControlsEventArgs Class

UpdatedControlsEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : UpdatedControlsEventArgs Class

Provides data for the ResolveUpdatedControls event of the RadAjaxManager control.

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class UpdatedControlsEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UpdatedControlsEventArgs
C#
public class UpdatedControlsEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.UpdatedControlsEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatedControlsEventArgs Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


UpdatedControlsEventArgs Class Members

UpdatedControlsEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : UpdatedControlsEventArgs Class

The following tables list the members exposed by UpdatedControlsEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UpdatedControlsEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PostBackControlID | Gets the ID of the control that initiated the Ajax request.
Public Property | SuppressError | Gets or sets a value indicating whether an exception should be thrown if the collection of controls that should be updated is empty after handling the ResolveUpdatedControls event.
Public Property | UpdatedControls | Gets the collection of controls that would be updated on the current Ajax request.
Top

See Also

Reference

UpdatedControlsEventArgs Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


UpdatedControlsEventArgs Constructor

UpdatedControlsEventArgs Constructor
[image]
Telerik.WebControls Namespace > UpdatedControlsEventArgs Class : UpdatedControlsEventArgs Constructor

updatedControls
postbackControlID

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal updatedControls As AjaxUpdatedControlsCollection, _
   ByVal postbackControlID As String _
)
Visual Basic (Usage) Copy Code
Dim updatedControls As AjaxUpdatedControlsCollection
Dim postbackControlID As String

Dim instance As UpdatedControlsEventArgs(updatedControls, postbackControlID)
C#
public UpdatedControlsEventArgs(
   AjaxUpdatedControlsCollection updatedControls,
   string postbackControlID
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal updatedControls As AjaxUpdatedControlsCollection, _
   ByVal postbackControlID As String _
)
Visual Basic (Usage) Copy Code
Dim updatedControls As AjaxUpdatedControlsCollection
Dim postbackControlID As String

Dim instance As UpdatedControlsEventArgs(updatedControls, postbackControlID)
C#
public UpdatedControlsEventArgs(
   AjaxUpdatedControlsCollection updatedControls,
   string postbackControlID
)

Parameters

updatedControls
postbackControlID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatedControlsEventArgs Class
UpdatedControlsEventArgs Members

© telerik 2002-2008. All Rights Reserved.


UpdatedControlsEventArgs Class Properties

UpdatedControlsEventArgs Class Properties
[image]
Telerik.WebControls Namespace : UpdatedControlsEventArgs Class

For a list of all members of this type, see UpdatedControlsEventArgs members.

Public Properties

 | Name | Description
Public Property | PostBackControlID | Gets the ID of the control that initiated the Ajax request.
Public Property | SuppressError | Gets or sets a value indicating whether an exception should be thrown if the collection of controls that should be updated is empty after handling the ResolveUpdatedControls event.
Public Property | UpdatedControls | Gets the collection of controls that would be updated on the current Ajax request.
Top

See Also

Reference

UpdatedControlsEventArgs Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


PostBackControlID Property

PostBackControlID Property
[image]
Telerik.WebControls Namespace > UpdatedControlsEventArgs Class : PostBackControlID Property

Gets the ID of the control that initiated the Ajax request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PostBackControlID As String
Visual Basic (Usage) Copy Code
Dim instance As UpdatedControlsEventArgs
Dim value As String

value = instance.PostBackControlID
C#
public string PostBackControlID {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatedControlsEventArgs Class
UpdatedControlsEventArgs Members

© telerik 2002-2008. All Rights Reserved.


SuppressError Property

SuppressError Property
[image]
Telerik.WebControls Namespace > UpdatedControlsEventArgs Class : SuppressError Property

Gets or sets a value indicating whether an exception should be thrown if the collection of controls that should be updated is empty after handling the ResolveUpdatedControls event.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property SuppressError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UpdatedControlsEventArgs
Dim value As Boolean

instance.SuppressError = value

value = instance.SuppressError
C#
public bool SuppressError {get; set;}

Return Value

The default value is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatedControlsEventArgs Class
UpdatedControlsEventArgs Members

© telerik 2002-2008. All Rights Reserved.


UpdatedControls Property

UpdatedControls Property
[image]
Telerik.WebControls Namespace > UpdatedControlsEventArgs Class : UpdatedControls Property

Gets the collection of controls that would be updated on the current Ajax request.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdatedControls As AjaxUpdatedControlsCollection
Visual Basic (Usage) Copy Code
Dim instance As UpdatedControlsEventArgs
Dim value As AjaxUpdatedControlsCollection

value = instance.UpdatedControls
C#
public AjaxUpdatedControlsCollection UpdatedControls {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UpdatedControlsEventArgs Class
UpdatedControlsEventArgs Members

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Class

WebServiceReference Class
See Also Members
[image]
Telerik.WebControls Namespace : WebServiceReference Class

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class WebServiceReference
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReference
C#
public class WebServiceReference

Inheritance Hierarchy

System.Object
Telerik.WebControls.WebServiceReference

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Class Members

WebServiceReference Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : WebServiceReference Class

The following tables list the members exposed by WebServiceReference.

Public Constructors

 | Name | Description
Public Constructor | WebServiceReference Constructor | Overloaded. This a constructor which you can use to set the Path property of the WebServiceReference class.
Top

Public Properties

 | Name | Description
Public Property | Path | This property indicates the path to your web service. You can use both relative or absolute values for the path to the webservice. If you use "~/WebService.asmx" as your service path, RadAjaxServiceManager will be looking for it in the root of your web application.
Public Property | PerformAsyncronousRequests | Gets or sets a value indicating whether the web service calls should be performed via synchronous or asynchronous requests.
Top

See Also

Reference

WebServiceReference Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Constructor

WebServiceReference Constructor
[image]
Telerik.WebControls Namespace > WebServiceReference Class : WebServiceReference Constructor

This a constructor which you can use to set the Path property of the WebServiceReference class.

Overload List

Overload | Description
WebServiceReference Constructor() | This is the default constructor. You will need to set the Path property manually.
WebServiceReference Constructor(String) | This a constructor which you can use to set the path property of the WebServiceReference class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Class
WebServiceReference Members

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Constructor()

WebServiceReference Constructor()
See Also
[image]
Telerik.WebControls Namespace > WebServiceReference Class > WebServiceReference Constructor : WebServiceReference Constructor()

This is the default constructor. You will need to set the Path property manually.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReference()
C#
public WebServiceReference()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReference()
C#
public WebServiceReference()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Class
WebServiceReference Members
Overload List

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Constructor(String)

WebServiceReference Constructor(String)
See Also
[image]
Telerik.WebControls Namespace > WebServiceReference Class > WebServiceReference Constructor : WebServiceReference Constructor(String)

path
This a constructor which you can use to set the path property of the WebServiceReference class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal path As String _
)
Visual Basic (Usage) Copy Code
Dim path As String

Dim instance As WebServiceReference(path)
C#
public WebServiceReference(
   string path
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal path As String _
)
Visual Basic (Usage) Copy Code
Dim path As String

Dim instance As WebServiceReference(path)
C#
public WebServiceReference(
   string path
)

Parameters

path

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Class
WebServiceReference Members
Overload List

© telerik 2002-2008. All Rights Reserved.


WebServiceReference Class Properties

WebServiceReference Class Properties
[image]
Telerik.WebControls Namespace : WebServiceReference Class

For a list of all members of this type, see WebServiceReference members.

Public Properties

 | Name | Description
Public Property | Path | This property indicates the path to your web service. You can use both relative or absolute values for the path to the webservice. If you use "~/WebService.asmx" as your service path, RadAjaxServiceManager will be looking for it in the root of your web application.
Public Property | PerformAsyncronousRequests | Gets or sets a value indicating whether the web service calls should be performed via synchronous or asynchronous requests.
Top

See Also

Reference

WebServiceReference Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Path Property

Path Property
[image]
Telerik.WebControls Namespace > WebServiceReference Class : Path Property

This property indicates the path to your web service. You can use both relative or absolute values for the path to the webservice.

If you use "~/WebService.asmx" as your service path, RadAjaxServiceManager will be looking for it in the root of your web application.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReference
Dim value As String

instance.Path = value

value = instance.Path
C#
public string Path {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Class
WebServiceReference Members

© telerik 2002-2008. All Rights Reserved.


PerformAsyncronousRequests Property

PerformAsyncronousRequests Property
[image]
Telerik.WebControls Namespace > WebServiceReference Class : PerformAsyncronousRequests Property

Gets or sets a value indicating whether the web service calls should be performed via synchronous or asynchronous requests.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property PerformAsyncronousRequests As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReference
Dim value As Boolean

instance.PerformAsyncronousRequests = value

value = instance.PerformAsyncronousRequests
C#
public bool PerformAsyncronousRequests {get; set;}

Return Value

The default value is true (i.e. perform asynchronous calls).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReference Class
WebServiceReference Members

© telerik 2002-2008. All Rights Reserved.


WebServiceReferenceCollection Class

WebServiceReferenceCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : WebServiceReferenceCollection Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Class WebServiceReferenceCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
C#
public class WebServiceReferenceCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.WebServiceReferenceCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


WebServiceReferenceCollection Class Members

WebServiceReferenceCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : WebServiceReferenceCollection Class

The following tables list the members exposed by WebServiceReferenceCollection.

Public Constructors

 | Name | Description
Public Constructor | WebServiceReferenceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | This indexer allows you to retrieve an item from the collection using its index.
Top

Public Methods

 | Name | Description
Public Method | Add | This method allows you to add a WebServiceReference Class to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether an element is in the WebServiceReferenceCollection Class.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Returns the zero-based index of the first occurrence of a value in the WebServiceReferenceCollection or in a portion of it.
Public Method | Insert | Inserts an element into the WebServiceReferenceCollection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the WebServiceReferenceCollection Class.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

WebServiceReferenceCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


WebServiceReferenceCollection Constructor

WebServiceReferenceCollection Constructor
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : WebServiceReferenceCollection Constructor

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection()
C#
public WebServiceReferenceCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection()
C#
public WebServiceReferenceCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


WebServiceReferenceCollection Class Methods

WebServiceReferenceCollection Class Methods
[image]
Telerik.WebControls Namespace : WebServiceReferenceCollection Class

For a list of all members of this type, see WebServiceReferenceCollection members.

Public Methods

 | Name | Description
Public Method | Add | This method allows you to add a WebServiceReference Class to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether an element is in the WebServiceReferenceCollection Class.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Returns the zero-based index of the first occurrence of a value in the WebServiceReferenceCollection or in a portion of it.
Public Method | Insert | Inserts an element into the WebServiceReferenceCollection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the WebServiceReferenceCollection Class.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

WebServiceReferenceCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : Add Method

methodData
This method allows you to add a WebServiceReference Class to the collection.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal methodData As WebServiceReference _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim methodData As WebServiceReference
Dim value As Integer

value = instance.Add(methodData)
C#
public int Add(
   WebServiceReference methodData
)

Parameters

methodData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : Contains Method

methodData
Determines whether an element is in the WebServiceReferenceCollection Class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal methodData As WebServiceReference _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim methodData As WebServiceReference
Dim value As Boolean

value = instance.Contains(methodData)
C#
public bool Contains(
   WebServiceReference methodData
)

Parameters

methodData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : IndexOf Method

methodData
Returns the zero-based index of the first occurrence of a value in the WebServiceReferenceCollection or in a portion of it.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal methodData As WebServiceReference _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim methodData As WebServiceReference
Dim value As Integer

value = instance.IndexOf(methodData)
C#
public int IndexOf(
   WebServiceReference methodData
)

Parameters

methodData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


Insert Method

Insert Method
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : Insert Method

index
methodData
Inserts an element into the WebServiceReferenceCollection at the specified index.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal methodData As WebServiceReference _
)
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim index As Integer
Dim methodData As WebServiceReference

instance.Insert(index, methodData)
C#
public void Insert(
   int index,
   WebServiceReference methodData
)

Parameters

index
methodData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


Remove Method

Remove Method
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : Remove Method

methodData
Removes the first occurrence of a specific object from the WebServiceReferenceCollection Class.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal methodData As WebServiceReference _
)
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim methodData As WebServiceReference

instance.Remove(methodData)
C#
public void Remove(
   WebServiceReference methodData
)

Parameters

methodData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


WebServiceReferenceCollection Class Properties

WebServiceReferenceCollection Class Properties
[image]
Telerik.WebControls Namespace : WebServiceReferenceCollection Class

For a list of all members of this type, see WebServiceReferenceCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | This indexer allows you to retrieve an item from the collection using its index.
Top

See Also

Reference

WebServiceReferenceCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > WebServiceReferenceCollection Class : Item Property

index
This indexer allows you to retrieve an item from the collection using its index.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WebServiceReference
Visual Basic (Usage) Copy Code
Dim instance As WebServiceReferenceCollection
Dim index As Integer
Dim value As WebServiceReference

instance.Item(index) = value

value = instance.Item(index)
C#
public WebServiceReference this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WebServiceReferenceCollection Class
WebServiceReferenceCollection Members

© telerik 2002-2008. All Rights Reserved.


RadAJAXControl Class

RadAJAXControl Class
See Also Members
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadAJAXControl Class

This control is intended for internal usage by other telerik controls.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadAJAXControl
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
C#
public abstract class RadAJAXControl : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxUtils.RadAJAXControl
Telerik.WebControls.RadAjaxManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Members
Telerik.WebControls.RadAjaxUtils Namespace


RadAJAXControl Class Members

RadAJAXControl Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadAJAXControl Class

The following tables list the members exposed by RadAJAXControl.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode.
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated.
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control.
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url |
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side.
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Sets focus to the specified web control after the AJAX Request is finished.
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel.
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location.
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAJAXControl Class
Telerik.WebControls.RadAjaxUtils Namespace


RadAJAXControl Class Methods

RadAJAXControl Class Methods
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadAJAXControl Class

For a list of all members of this type, see RadAJAXControl members.

Public Methods

 | Name | Description
Public Method | Alert | Displays an alert message at client-side.
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | FocusControl | Overloaded. Sets focus to the specified web control after the AJAX Request is finished.
Public Method | GetAjaxEventReference | Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel.
Public Method | GetAjaxRequestReference | OBSOLETE: Please, use GetAjaxEventReference instead.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Redirect | Redirects the page to another location.
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetMaxRequestQueueSize |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAJAXControl Class
Telerik.WebControls.RadAjaxUtils Namespace


Alert Method

Alert Method
See Also Example
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : Alert Method

message
Displays an alert message at client-side.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Alert( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim message As String

instance.Alert(message)
C#
public void Alert(
   string message
)

Parameters

message

Return Value

None.

Example

The following example illustrates a sample usage of the Alert method.
C# Copy Code
private void Button1_Click(object sender, System.EventArgs e)
{
if (!UserAccessAllowed(UserProfile))
{
RadAjaxManager1.Alert("You are not allowed to access this user control!");
}
else
{
LoadSecretControl();
}
}

Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Button1.Click
If Not UserAccessAllowed(UserProfile) Then
RadAjaxManager1.Alert("You are not allowed to access this user control!")
Else
LoadSecretControl()
End If
End Sub 'Button1_Click

Remarks

This is the easiest way to show a message, generated from the server, on the client in a message box.

Note: Special characteres are not escaped.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


FocusControl Method

FocusControl Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : FocusControl Method

Sets focus to the specified web control after the AJAX Request is finished.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Overload List

Overload | Description
FocusControl(Control) | Sets focus to the specified web control after the AJAX Request is finished.
FocusControl(String) | Sets focus to the specified web control after the AJAX Request is finished.

Overload List

Overload | Description
FocusControl(Control) | Sets focus to the specified web control after the AJAX Request is finished.
FocusControl(String) | Sets focus to the specified web control after the AJAX Request is finished.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


FocusControl(Control) Method

FocusControl(Control) Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class > FocusControl Method : FocusControl(Control) Method

controlToFocus
Sets focus to the specified web control after the AJAX Request is finished.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub FocusControl( _
   ByVal controlToFocus As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim controlToFocus As Control

instance.FocusControl(controlToFocus)
C#
public virtual void FocusControl(
   Control controlToFocus
)

Parameters

controlToFocus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members
Overload List

© telerik 2002-2008. All Rights Reserved.


FocusControl(String) Method

FocusControl(String) Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class > FocusControl Method : FocusControl(String) Method

controlToFocusID
Sets focus to the specified web control after the AJAX Request is finished.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub FocusControl( _
   ByVal controlToFocusID As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim controlToFocusID As String

instance.FocusControl(controlToFocusID)
C#
public virtual void FocusControl(
   string controlToFocusID
)

Parameters

controlToFocusID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members
Overload List

© telerik 2002-2008. All Rights Reserved.


GetAjaxEventReference Method

GetAjaxEventReference Method
See Also Example
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : GetAjaxEventReference Method

argument
Gets client side code which raises an AjaxRequest event in either AJAX Manager or AJAX Panel.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAjaxEventReference( _
   ByVal argument As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim argument As String
Dim value As String

value = instance.GetAjaxEventReference(argument)
C#
public string GetAjaxEventReference(
   string argument
)

Parameters

argument

Example

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
   // Create a generic AJAX Request when the button is clicked.
   // "return false" to prevent postbacks
   Button1.Attributes["onclick"] = RadAjaxPanel1.GetAjaxEventReference("argument...") + " return false;";
   // Generic requests can be fired on both AJAX Manager and AJAX Panel
   Button1.Attributes["onclick"] = RadAjaxManager1.GetAjaxEventReference("argument...") + " return false;";
}

Visual Basic Copy Code
Private Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Page.Load
    ' Create a generic AJAX Request When the button Is clicked.
    ' "return false" To prevent postbacks
    Button1.Attributes["onclick"] = RadAjaxPanel1.GetAjaxEventReference("argument...") & " return false;"
    ' Generic requests can be fired On both AJAX Manager And AJAX Panel
    Button1.Attributes["onclick"] = RadAjaxManager1.GetAjaxEventReference("argument...") & " return false;"
End Sub

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


GetAjaxRequestReference Method

GetAjaxRequestReference Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : GetAjaxRequestReference Method

argument
OBSOLETE: Please, use GetAjaxEventReference instead.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAjaxRequestReference( _
   ByVal argument As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim argument As String
Dim value As String

value = instance.GetAjaxRequestReference(argument)
C#
public string GetAjaxRequestReference(
   string argument
)

Parameters

argument

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


Redirect Method

Redirect Method
See Also Example
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : Redirect Method

location
Redirects the page to another location.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub Redirect( _
   ByVal location As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim location As String

instance.Redirect(location)
C#
public void Redirect(
   string location
)

Parameters

location

Return Value

None.

Example

The following code redirects from a button's click event handler. Note the control should be ajaxified in order redirection to work.
C# Copy Code
private void Button1_Click(object sender, System.EventArgs e)
{
   RadAjaxManager1.Redirect("support.aspx");
}

Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Button1.Click
RadAjaxManager1.Redirect("support.aspx")
End Sub 'Button1_Click

Remarks

This method is usually used in the AJAX event handler instead of Response.Redirect(). It provides the only way to redirect to a page which does not contain any AJAX control at all.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


SetMaxRequestQueueSize Method

SetMaxRequestQueueSize Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : SetMaxRequestQueueSize Method

maxRequestQueueSize

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetMaxRequestQueueSize( _
   ByVal maxRequestQueueSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim maxRequestQueueSize As Integer

instance.SetMaxRequestQueueSize(maxRequestQueueSize)
C#
public void SetMaxRequestQueueSize(
   int maxRequestQueueSize
)

Parameters

maxRequestQueueSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


RadAJAXControl Class Properties

RadAJAXControl Class Properties
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadAJAXControl Class

For a list of all members of this type, see RadAJAXControl members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AjaxUrl | Gets or sets a value containing the URL that will be used for AJAX request.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableAJAX | Gets or sets a value indicating whether the control will work in AJAX or Postback mode.
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableOutsideScripts | Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated.
Public Property | EnablePageHeadUpdate | Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | IsAjaxRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control.
Public Property | IsAsyncRequest | Gets a value indicating whether the current request is an AJAX request initiated by the current control.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnAjaxRequestError | Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from RadControl)
Public Property | ResponseScripts | Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Url |
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadAJAXControl Class
Telerik.WebControls.RadAjaxUtils Namespace


AjaxUrl Property

AjaxUrl Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : AjaxUrl Property

Gets or sets a value containing the URL that will be used for AJAX request.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property AjaxUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As String

instance.AjaxUrl = value

value = instance.AjaxUrl
C#
public string AjaxUrl {get; set;}

Return Value

Returns a String containing the URL that will be used for AJAX request. The default value is the URL of the current page.

Remarks

AJAX Panel and AJAX Manager automatically resolve the current page URL when forming the request. However if you want to achieve different scenario such as AJAX requests between two pages you can set the desired URL for the request using this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


EnableAJAX Property

EnableAJAX Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : EnableAJAX Property

Gets or sets a value indicating whether the control will work in AJAX or Postback mode.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableAJAX As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

instance.EnableAJAX = value

value = instance.EnableAJAX
C#
public virtual bool EnableAJAX {get; set;}

Return Value

Returns true by default.

Remarks

Set to false to force using postbacks instead of AJAX requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


EnableOutsideScripts Property

EnableOutsideScripts Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : EnableOutsideScripts Property

Gets or sets a value indicating if the outside scripts for the AJAX-enabled controls will be evaluated.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableOutsideScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

instance.EnableOutsideScripts = value

value = instance.EnableOutsideScripts
C#
public virtual bool EnableOutsideScripts {get; set;}

Return Value

The default value is false.

Remarks

Outside scripts are scripts rendered from the code-behind and are usually not executed if they are rendered outside of the currently updated control(s).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


EnablePageHeadUpdate Property

EnablePageHeadUpdate Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : EnablePageHeadUpdate Property

Gets or sets a value indicating whether the control will update the page <head> element, so that changes to the title and stylesheets are applied.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EnablePageHeadUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

instance.EnablePageHeadUpdate = value

value = instance.EnablePageHeadUpdate
C#
public virtual bool EnablePageHeadUpdate {get; set;}

Return Value

Returns true by default.

Remarks

Set to false to disable header updates if you do not need them.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


IsAjaxRequest Property

IsAjaxRequest Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : IsAjaxRequest Property

Gets a value indicating whether the current request is an AJAX request initiated by the current control.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsAjaxRequest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

value = instance.IsAjaxRequest
C#
public virtual bool IsAjaxRequest {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


IsAsyncRequest Property

IsAsyncRequest Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : IsAsyncRequest Property

Gets a value indicating whether the current request is an AJAX request initiated by the current control.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsAsyncRequest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

value = instance.IsAsyncRequest
C#
public virtual bool IsAsyncRequest {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


OnAjaxRequestError Property

OnAjaxRequestError Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : OnAjaxRequestError Property

Using this property you can provide your own error handler for AJAX requests in RadAjax, RadGrid, RadCalendar if you wish to block or handle those errors in a specific way. You can either supply the name of a javascript function or executable code like "alert(e.message)" The javascript handler function should have the following signature: AjaxRequestErrorHandler(e, clientID) {...} It must also be defined ABOVE the code clock which contains your AJAX enabled control.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property OnAjaxRequestError As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As String

instance.OnAjaxRequestError = value

value = instance.OnAjaxRequestError
C#
public string OnAjaxRequestError {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


ResponseScripts Property

ResponseScripts Property
See Also Example
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : ResponseScripts Property

Gets or sets a string collection of JavaScripts that will be executed on client-side when the response returns.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ResponseScripts As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As StringCollection

value = instance.ResponseScripts
C#
public virtual StringCollection ResponseScripts {get;}

Example

The following example demonstrates a sample usage of the ResponseScripts property:

            [C#]

            <form id="Form1" method="post" runat="server">
<script language="C#" runat="server">
private void Button1_Click(object sender, System.EventArgs e)
{
RadAjaxManager1.ResponseScripts.Add("alert('This can be any script!');");
}
</script>
<rad:RadAjaxManager id="RadAjaxManager1" runat="server" >
 <AjaxSettings>
  <rad:AjaxSetting AjaxControlID="Button1">
  <rad:AjaxSetting>
 </AjaxSettings>
</rad:RadAjaxManager>
</form>
Visual Basic Copy Code
<form id="Form1" method="post" runat="server">
<script language="VB" runat="server">
Private Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Button1.Click
 RadAjaxManager.ResponseScripts.Add("alert('This can be any script!');")
End Sub 'RadAjaxManager1_AjaxRequest
</script>
<rad:RadAjaxManager id="RadAjaxManager1" runat="server" >
 <AjaxSettings>
  <rad:AjaxSetting AjaxControlID="Button1">
  <rad:AjaxSetting>
 </AjaxSettings>
</rad:RadAjaxManager>
</form>

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


Url Property

Url Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : Url Property

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As String

value = instance.Url
C#
public virtual string Url {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


RadControlDesignerActionList Class

RadControlDesignerActionList Class
See Also Members
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadControlDesignerActionList Class

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Private Class RadControlDesignerActionList
   Inherits DesignerActionList
Visual Basic (Usage) Copy Code
Dim instance As RadControlDesignerActionList
C#
private class RadControlDesignerActionList : DesignerActionList

Inheritance Hierarchy

System.Object
System.ComponentModel.Design.DesignerActionList
Telerik.WebControls.RadAjaxUtils.RadControlDesignerActionList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Members
Telerik.WebControls.RadAjaxUtils Namespace


RadControlDesignerActionList Class Members

RadControlDesignerActionList Class Members
See Also Properties Methods
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadControlDesignerActionList Class

The following tables list the members exposed by RadControlDesignerActionList.

Public Constructors

 | Name | Description
Public Constructor | RadControlDesignerActionList Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoShow | Overridden.
Public Property | Component | (Inherited from System.ComponentModel.Design.DesignerActionList)
Public Property | SearchString |
Top

Public Methods

 | Name | Description
Public Method | CopyActionItemsTo |
Public Method | GetService | (Inherited from System.ComponentModel.Design.DesignerActionList)
Public Method | GetSortedActionItems | Overridden.
Top

See Also

Reference

RadControlDesignerActionList Class
Telerik.WebControls.RadAjaxUtils Namespace


RadControlDesignerActionList Constructor

RadControlDesignerActionList Constructor
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadControlDesignerActionList Class : RadControlDesignerActionList Constructor

parent

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ControlDesigner _
)
Visual Basic (Usage) Copy Code
Dim parent As ControlDesigner

Dim instance As RadControlDesignerActionList(parent)
C#
public RadControlDesignerActionList(
   ControlDesigner parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ControlDesigner _
)
Visual Basic (Usage) Copy Code
Dim parent As ControlDesigner

Dim instance As RadControlDesignerActionList(parent)
C#
public RadControlDesignerActionList(
   ControlDesigner parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Class
RadControlDesignerActionList Members

© telerik 2002-2008. All Rights Reserved.


RadControlDesignerActionList Class Methods

RadControlDesignerActionList Class Methods
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadControlDesignerActionList Class

For a list of all members of this type, see RadControlDesignerActionList members.

Public Methods

 | Name | Description
Public Method | CopyActionItemsTo |
Public Method | GetService | (Inherited from System.ComponentModel.Design.DesignerActionList)
Public Method | GetSortedActionItems | Overridden.
Top

See Also

Reference

RadControlDesignerActionList Class
Telerik.WebControls.RadAjaxUtils Namespace


CopyActionItemsTo Method

CopyActionItemsTo Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadControlDesignerActionList Class : CopyActionItemsTo Method

sourceCollection
targetCollection

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyActionItemsTo( _
   ByVal sourceCollection As DesignerActionItemCollection, _
   ByVal targetCollection As DesignerActionItemCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As RadControlDesignerActionList
Dim sourceCollection As DesignerActionItemCollection
Dim targetCollection As DesignerActionItemCollection

instance.CopyActionItemsTo(sourceCollection, targetCollection)
C#
public virtual void CopyActionItemsTo(
   DesignerActionItemCollection sourceCollection,
   DesignerActionItemCollection targetCollection
)

Parameters

sourceCollection
targetCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Class
RadControlDesignerActionList Members

© telerik 2002-2008. All Rights Reserved.


GetSortedActionItems Method

GetSortedActionItems Method
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadControlDesignerActionList Class : GetSortedActionItems Method

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetSortedActionItems() As DesignerActionItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RadControlDesignerActionList
Dim value As DesignerActionItemCollection

value = instance.GetSortedActionItems()
C#
public override DesignerActionItemCollection GetSortedActionItems()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Class
RadControlDesignerActionList Members

© telerik 2002-2008. All Rights Reserved.


RadControlDesignerActionList Class Properties

RadControlDesignerActionList Class Properties
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadControlDesignerActionList Class

For a list of all members of this type, see RadControlDesignerActionList members.

Public Properties

 | Name | Description
Public Property | AutoShow | Overridden.
Public Property | Component | (Inherited from System.ComponentModel.Design.DesignerActionList)
Public Property | SearchString |
Top

See Also

Reference

RadControlDesignerActionList Class
Telerik.WebControls.RadAjaxUtils Namespace


AutoShow Property

AutoShow Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadControlDesignerActionList Class : AutoShow Property

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property AutoShow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadControlDesignerActionList
Dim value As Boolean

instance.AutoShow = value

value = instance.AutoShow
C#
public override bool AutoShow {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Class
RadControlDesignerActionList Members

© telerik 2002-2008. All Rights Reserved.


SearchString Property

SearchString Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadControlDesignerActionList Class : SearchString Property

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SearchString As String
Visual Basic (Usage) Copy Code
Dim instance As RadControlDesignerActionList
Dim value As String

instance.SearchString = value

value = instance.SearchString
C#
public virtual string SearchString {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadControlDesignerActionList Class
RadControlDesignerActionList Members

© telerik 2002-2008. All Rights Reserved.


Get more help

Telerik RadAjax v1.8 Send comments on this topic.
Get more help

Glossary Item Box

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/Telerik RadControls for ASP.NET/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • online code library - visit http://www.telerik.com/community/code-library/default.aspx adn download a growing number of samples, get hands-on experience with the RadControls and submit some of your favorite implementations.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

© 2002-2008 Telerik. All Rights Reserved.


Glossary

Telerik RadAjax v1.8 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

AJAX pair

The AJAX pair includes:

  • the control that will initiate the AJAX request
  • control(s) that will be udpated via AJAX
  • [optionally] the AJAX Loading panel that will be shown during the request

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names

Telerik RadAjax v1.8 Send comments on this topic.
Guidelines for Specifying Domain Names

Glossary Item Box

To create a License key you will need to know the IP and domain/machine name by which you plan to access the control, i.e.

http://123.123.123.123/MyApplication/

http://www.mysite.com/MyApplication/

http://MachineName/MyApplication/

If you plan to sue the control on localhost or 127.0.0.1 you do not need keys - the control will work properly, but a copyright message will be displayed occasionally.

The control checks the URL by which it is accessed and compares this URL to the IP and domain name encoded in the license key. If these do not match, a copyright message will be shown.

Entering domain/machine names

Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com
http://mydomain/ | mydomain | http://mydomain
http://machinename/ | machinename | http://machinenam

In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk):

Original URL | Right | Wrong
http://www.mysite.co.uk | mysite.co.uk | http://www.mysite.co.uk
http://mysite.gov.tw | mysite.gov.tw | http://mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl | http://www.support.mysite.biz.nl

If the the domain/machine name is unknown, or if the control will be used on localhost, use localhost in the domain field when creating the keys.

Entering IPs

Use only the top-level IP address. The control will work on all subdomains and ports. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://123.123.123.123/ | 123.123.123.123 | http://123.123.123.123
http://123.123.123.123:8080/ | 123.123.123.123 | 123.123.123.123:8080 http://123.123.123.123 http:// 123.123.123.123:8080

Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | http://123.123.123.123

If you have a dynamic DNS/IP, then it would be best to access the control by a domain name, rather than IP. In this case, use 127.0.0.1 in the IP field when creating the keys.

If the IP is unknown, or if the control is to be used on localhost only, use 127.0.0.1 in the IP field when creating the keys.

Other Important Information

If you are behind a firewall, the license ley will still work, as only the URL is checked.

The key will work for the major version of the product it was created for. For example, if the key is created for Telerik RadAjax v1.x it will NOT work on another major version (such as v.x).

Back to Setting License Keys.

© 2002-2008 Telerik. All Rights Reserved.


More About License

Telerik RadAjax v1.8 Send comments on this topic.
More About License

Glossary Item Box

The LicenseFiles are XML files, which contain the licensing information (Company and LicenseKey) for every component of the Telerik RadControls for ASP.NET web-suite. This approach is much more convenient than setting licensing information directly in the control's properties, especially when you use multiple components on multiple pages. In case you upgrade your component, or implement the same application on a different server (domain) you have to change the Company and LicenseKey information only once – in the LicenseFile. Every Telerik component is shipped with a LicenseFile.XML located in the "~/RadControls" subfolder of the web-application. The LicenseFile property is set by default to point to this file so all you have to do is enter the required properties in the file. Below is a sample LicenseFile.XML:

<root>

<license control="editor" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY1"/>
<license control="spell" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY2"/>
<license control="menu" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY3"/>

</root>

Please, note that you may use a single LicenseFile to unlock more than one Telerik components.

If you place trial and commercial key(s), Standard or Professional edition, the editor will use the commercial key(s).

Note:The values set in the LicenseKey and Company properties of the Telerik RadEditor tag will override the ones set in the LicenseFile. If you want to use the LicenseFile approach make sure you remove the LicenseKey and Company properties from the Telerik RadEditor tag.

© 2002-2008 Telerik. All Rights Reserved.


Support Options

Telerik RadAjax v1.8 Send comments on this topic.
Support Options

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadAjax v.x Developer to Telerik RadAjax v1.x Developer license

Telerik RadAjax v1.8 Send comments on this topic.
Upgrading Telerik RadAjax v.x Developer to Telerik RadAjax v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadAjax v.x Developer license to Telerik RadAjax v1.8 Developer license.

These instructions are also valid for upgrading Telerik RadAjax v1.x Developer license to a newer Telerik RadAjax minor version.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadAjax files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadAjax, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Backup your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadAjax.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Ajax folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Ajax folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Ajax folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadAjax to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadAjax Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadAjax's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadAjax, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadAjax (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

4. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES"

© 2002-2008 Telerik. All Rights Reserved.


Assembly Overview

RadAjax Assembly

Namespaces

Namespace | Description
Telerik.WebControls |
Telerik.WebControls.RadAjaxUtils |


Getting Started - RadAjax

Getting Started

© telerik 2002-2008. All Rights Reserved.


Introduction - RadAjax

Introduction

© telerik 2002-2008. All Rights Reserved.


AjaxClientEvents Class Methods

AjaxClientEvents Class Methods
[image]
Telerik.WebControls Namespace : AjaxClientEvents Class

For a list of all members of this type, see AjaxClientEvents members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AjaxObjectWithState)
Top

See Also

Reference

AjaxClientEvents Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : ToString Method

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


ViewState Property

ViewState Property
[image]
Telerik.WebControls Namespace > AjaxClientEvents Class : ViewState Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ViewState As AjaxStateBag
Visual Basic (Usage) Copy Code
Dim instance As AjaxClientEvents
Dim value As AjaxStateBag

value = instance.ViewState
C#
public AjaxStateBag ViewState {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxClientEvents Class
AjaxClientEvents Members

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Class Events

AjaxLoadingPanel Class Events
[image]
Telerik.WebControls Namespace : AjaxLoadingPanel Class

For a list of all members of this type, see AjaxLoadingPanel members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxLoadingPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxLoadingPanel Class Methods

AjaxLoadingPanel Class Methods
[image]
Telerik.WebControls Namespace : AjaxLoadingPanel Class

For a list of all members of this type, see AjaxLoadingPanel members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.Panel)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.Panel)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxLoadingPanel Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Class Events

AjaxUpdateGroup Class Events
[image]
Telerik.WebControls Namespace : AjaxUpdateGroup Class

For a list of all members of this type, see AjaxUpdateGroup members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxUpdateGroup Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


AjaxUpdateGroup Class Methods

AjaxUpdateGroup Class Methods
[image]
Telerik.WebControls Namespace : AjaxUpdateGroup Class

For a list of all members of this type, see AjaxUpdateGroup members.

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AjaxUpdateGroup Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxManager.ResolveUpdatedControlsDelegate Delegate

RadAjaxManager.ResolveUpdatedControlsDelegate Delegate
[image]
Telerik.WebControls Namespace : RadAjaxManager.ResolveUpdatedControlsDelegate Delegate

sender
e

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadAjaxManager.ResolveUpdatedControlsDelegate( _
   ByVal sender As Object, _
   ByVal e As UpdatedControlsEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ResolveUpdatedControlsDelegate(AddressOf HandlerMethod)
C#
public delegate void RadAjaxManager.ResolveUpdatedControlsDelegate(
   object sender,
   UpdatedControlsEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadAjaxManager Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxManager
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxManager Class
RadAjaxManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxPanel.AjaxPanelRequestEventHandler Delegate

RadAjaxPanel.AjaxPanelRequestEventHandler Delegate
[image]
Telerik.WebControls Namespace : RadAjaxPanel.AjaxPanelRequestEventHandler Delegate

source

The source of the event.

e

An AJAXPanelRequestEventArgs object that contains event data.

Represents the method that will handle the AjaxRequest event.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadAjaxPanel.AjaxPanelRequestEventHandler( _
   ByVal source As Object, _
   ByVal e As AjaxRequestEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AjaxPanelRequestEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadAjaxPanel.AjaxPanelRequestEventHandler(
   object source,
   AjaxRequestEventArgs e
)

Parameters

source

The source of the event.

e

An AJAXPanelRequestEventArgs object that contains event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadAjaxPanel Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxPanel
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxPanel Class
RadAjaxPanel Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Class Events

RadAjaxServiceManager Class Events
[image]
Telerik.WebControls Namespace : RadAjaxServiceManager Class

For a list of all members of this type, see RadAjaxServiceManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxServiceManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadAjaxServiceManager Class Methods

RadAjaxServiceManager Class Methods
[image]
Telerik.WebControls Namespace : RadAjaxServiceManager Class

For a list of all members of this type, see RadAjaxServiceManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAjaxServiceManager Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadAjaxServiceManager Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxServiceManager Class
RadAjaxServiceManager Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadAjaxServiceManager Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxServiceManager
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxServiceManager Class
RadAjaxServiceManager Members

© telerik 2002-2008. All Rights Reserved.


RadAjaxTimer.TickDelegate Delegate

RadAjaxTimer.TickDelegate Delegate
[image]
Telerik.WebControls Namespace : RadAjaxTimer.TickDelegate Delegate

sender
e

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadAjaxTimer.TickDelegate( _
   ByVal sender As Object, _
   ByVal e As TickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TickDelegate(AddressOf HandlerMethod)
C#
public delegate void RadAjaxTimer.TickDelegate(
   object sender,
   TickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadAjaxTimer Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAjaxTimer
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAjaxTimer Class
RadAjaxTimer Members

© telerik 2002-2008. All Rights Reserved.


RadAJAXControl Class Events

RadAJAXControl Class Events
[image]
Telerik.WebControls.RadAjaxUtils Namespace : RadAJAXControl Class

For a list of all members of this type, see RadAJAXControl members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadAJAXControl Class
Telerik.WebControls.RadAjaxUtils Namespace


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : RadControlsDir Property

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls.RadAjaxUtils Namespace > RadAJAXControl Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls.RadAjaxUtils
Assembly: RadAjax (in RadAjax.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadAJAXControl
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadAJAXControl Class
RadAJAXControl Members

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls.RadAjaxUtils Namespace

Telerik.WebControls.RadAjaxUtils Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
RadAJAXControl | This control is intended for internal usage by other telerik controls.
RadControlDesignerActionList |

See Also

Reference

RadAjax Assembly

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls.RadAjaxUtils Namespace Inheritance Hierarchy

Telerik.WebControls.RadAjaxUtils Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.ComponentModel.Design.DesignerActionList
Telerik.WebControls.RadAjaxUtils.RadControlDesignerActionList
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxUtils.RadAJAXControl

See Also

Reference

RadAjax Assembly

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls Namespace

Telerik.WebControls Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
AjaxClientEvents

The following client events are available:

  • OnRequestStart
  • OnRequestSent
  • OnResponseReceived
  • OnResponseEnd
AjaxLoadingPanel | This class represents a panel that will be used as a progress indicator during an AJAX request.
AjaxRequestEventArgs | A class containing the AJAX event arguments during an AJAX request.
AjaxSetting | Represents a single AjaxManager setting - a mapping between a control that initiates an AJAX request and a collection of controls to be updated by the operation.
AjaxSettingsCollection | Summary description for ConfiguredControls.
AjaxUpdatedControl | This class holds a reference to a single updated control and the loading panel to display.
AjaxUpdatedControlsCollection | A collection of the controls that are updated by the AjaxManager.
AjaxUpdateGroup
ClientProxyScriptGenerator
RadAjaxManager | RadAjaxManager is one of the two main controls that come with the Telerik RadAjax suite. Using the AJAX Manager control on your page, you can ajaxify all controls that normally work with postbacks. AJAX Manager has a builder tool that allows you to set the AJAX relations in design-mode and absolutely codeless. Using a single AJAX Manager on the page you can create complex web applications like Microsoft Outlook ® Web Access portal.
RadAjaxPanel | AJAX Panel is used as a placeholder for other controls. Once placed in the panel, any ASP.NET control will start making AJAX requests instead of traditional postbacks.
RadAjaxServiceManager
RadAjaxTimer | The RadAjaxTimer class is a simple postback control that raises a postback Tick event continuously with a specified Interval Property. In order to make the timer control perform AJAX requests, you need to ajaxify it with RadAjaxManager or by placing it in RadAjaxPanel.
TickEventArgs | Summary description for TickEventArgs.
UpdatableControl
UpdatedControlsEventArgs | Provides data for the ResolveUpdatedControls event of the RadAjaxManager control.
WebServiceReference
WebServiceReferenceCollection

Delegates

Delegate | Description
RadAjaxManager.ResolveUpdatedControlsDelegate |
RadAjaxPanel.AjaxPanelRequestEventHandler | Represents the method that will handle the AjaxRequest event.
RadAjaxTimer.TickDelegate |

See Also

Reference

RadAjax Assembly

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls Namespace Inheritance Hierarchy

Telerik.WebControls Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.AjaxSettingsCollection
Telerik.WebControls.AjaxUpdatedControlsCollection
Telerik.WebControls.WebServiceReferenceCollection
System.EventArgs
Telerik.WebControls.AjaxRequestEventArgs
Telerik.WebControls.TickEventArgs
Telerik.WebControls.UpdatedControlsEventArgs
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Panel
Telerik.WebControls.AjaxLoadingPanel
Telerik.WebControls.RadAjaxUtils.RadControl
Telerik.WebControls.RadAjaxServiceManager
Telerik.WebControls.RadAjaxTimer
Telerik.WebControls.RadAjaxUtils.RadAJAXControl
Telerik.WebControls.RadAjaxManager
Telerik.WebControls.RadMultipleUpdateAjaxControl
Telerik.WebControls.RadAjaxPanel
Telerik.WebControls.AjaxUpdateGroup
Telerik.WebControls.AjaxObjectWithState
Telerik.WebControls.AjaxClientEvents
Telerik.WebControls.AjaxSetting
Telerik.WebControls.AjaxUpdatedControl
Telerik.WebControls.ClientProxyScriptGenerator
Telerik.WebControls.UpdatableControl
Telerik.WebControls.WebServiceReference

See Also

Reference

RadAjax Assembly

© telerik 2002-2008. All Rights Reserved.